Cisco 10000 Series Router Quality of Service Configuration Guide
Attaching Service Policies
Downloads: This chapterpdf (PDF - 607.0KB) The complete bookPDF (PDF - 21.32MB) | Feedback

Attaching Service Policies

Table Of Contents

Attaching Service Policies

Interfaces Supporting QoS Service Policies

Attaching ATM QoS Service Policies

Feature History for ATM QoS

ATM QoS Inheritance

service-policy Command

Syntax Description

service-policy Command History

service-policy Command Modes

Usage Guidelines for the service-policy Command

Restrictions and Limitations for Attaching ATM Service Policies

Attaching ATM QoS Service Policies to ATM Interfaces, Subinterfaces, and PVCs

Attaching QoS Service Policies to an ATM Interface

Attaching QoS Service Policies to an ATM Point-to-Point Subinterface

Attaching QoS Service Policies to an ATM PVC

Attaching QoS Service Policies to an ATM PVC Range and an ATM PVC in a Range

Attaching Frame Relay QoS Service Policies

Feature History for Frame Relay QoS

Frame Relay QoS Inheritance

map-class frame-relay Command

Syntax Description

map-class frame-relay Command History

Usage Guidelines for the map-class frame-relay Command

Restrictions and Limitations for Frame Relay QoS Service Policies

Creating and Attaching QoS Policies to Frame Relay Interfaces, Subinterfaces, and Data-Link Connection Identifiers

Attaching a QoS Service Policy to a Frame Relay Interface or Point-to-Point Subinterface

Attaching a QoS Service Policy to a Frame Relay DLCI

Attaching Virtual LAN QoS Service Policies

Feature History for VLAN QoS

VLAN QoS Inheritance

Restrictions and Limitations for Attaching QoS Services to VLAN Subinterfaces

Attaching QoS Policies to VLAN Interfaces and Subinterfaces

Attaching QoS Service Policies to Physical Interfaces with VLAN Subinterfaces

Attaching QoS Service Policies to VLAN Subinterfaces

Attaching Virtual Access Interface QoS Service Policies

Feature History for VAI QoS

VAI QoS Inheritance

Restrictions and Limitations for Attaching QoS Services to a VAI

Attaching QoS Policies to VAIs Using Virtual Template Interfaces

Applying a QoS Service Policy to a Virtual Template Interface

Applying a Virtual Template Interface to a BBA Group

Attaching a BBA Group to an Interface or Subinterface for PPPoE Sessions

Attaching Layer 2 Access Concentrator QoS Service Policies

Feature History for LAC QoS

LAC QoS Inheritance

Restrictions and Limitations for Attaching LAC QoS

Attaching QoS Policies to LAC ATM Virtual Circuits

Applying QoS on Layer 2 Tunnel Packets

Verifying and Monitoring QoS Service Policies

Verification Example for QoS Service Policies

Related Documentation


Attaching Service Policies


This chapter describes how to attach QoS service policies. After you create a QoS service policy, the next step is to attach the policy to an interface or virtual circuit (VC). By doing this, the router knows which service policy to apply to the packets arriving at or leaving the router. An interface can have different service policies for inbound and outbound packets.

This chapter includes the following topics:

Interfaces Supporting QoS Service Policies

Attaching ATM QoS Service Policies

Attaching Frame Relay QoS Service Policies

Attaching Virtual LAN QoS Service Policies

Attaching Virtual Access Interface QoS Service Policies

Attaching Layer 2 Access Concentrator QoS Service Policies

Applying QoS on Layer 2 Tunnel Packets

Verifying and Monitoring QoS Service Policies

Related Documentation

Interfaces Supporting QoS Service Policies

You can attach QoS service policies to:

Physical interfaces

Multilink Point-to-Point Protocol (MLPPP) and Multilink Frame Relay (MFR) interfaces

ATM unspecified bit rate (UBR) permanent virtual circuits (PVCs) and point-to-point subinterfaces

ATM shaped (peak cell rate is specified) UBR PVCs and point-to-point subinterfaces

ATM constant bit rate (CBR) PVCs and point-to-point subinterfaces

ATM variable bit rate (VBR) PVCs and point-to-point subinterfaces

Label-controlled Asynchronous Transfer Mode (LC-ATM) subinterfaces

Frame Relay PVCs, point-to-point subinterfaces, and map classes

Ethernet virtual local area networks (VLANs)

IP tunnel interfaces

Virtual access interfaces

Each interface, subinterface, or PVC can have no more than two policy maps attached: one for inbound traffic and one for outbound traffic. The router does not require that the inbound and outbound policies be the same; you can attach different input and output policies.


Note In a Cisco 10000 series router, we recommend that you do not attach a service-policy to an interface that has an IP interface session.


Attaching ATM QoS Service Policies

You can attach a QoS service policy to an ATM interface, point-to-point subinterface, or PVC using the service-policy command.

This section describes the following topics:

Feature History for ATM QoS

ATM QoS Inheritance

service-policy Command

Restrictions and Limitations for Attaching ATM Service Policies

Attaching ATM QoS Service Policies to ATM Interfaces, Subinterfaces, and PVCs

Feature History for ATM QoS

Cisco IOS Release
Description
Required PRE

12.0(17)SL

The attachment of ATM QoS service policies feature was introduced on the router.

PRE1

12.2(15)BX

This feature was introduced on the PRE2.

PRE2

12.3(7)XI2

This feature was modified to allow you to attach ATM QoS service policies to a range of PVCs and to a specific PVC within the PVC range.

PRE2

12.2(28)SB

This feature was integrated in Cisco IOS Release 12.2(28)SB for the PRE2.

PRE2

12.2(31)SB2

This feature was introduced on the PRE3.

PRE2
PRE3


ATM QoS Inheritance

The following describes how ATM traffic inherits QoS policies:

For all releases earlier than Cisco IOS Release 12.3(7)XI2, if you attach a service policy only to the physical interface, the aggregate of all unspecified bit rate (UBR) PVCs is subject to the physical interface's service policy.

For Cisco IOS Release 12.3(7)XI2 and later releases, if you attach a service policy only to the physical interface, the aggregate of all unshaped UBR PVCs is subject to the physical interface's service policy. In Cisco IOS Release 12.3(7)XI2 and later releases, the router treats shaped UBR PVCs like variable bit rate (VBR) and constant bit rate (CBR) PVCs.

If you attach a service policy only to individual PVCs and not to the physical interface, only the individual PVC is subject to its attached service policy.

If you attach service policies to both the physical interface and individual PVCs, the aggregate of all UBR PVCs that do not have a service policy is subject to the physical interface's service policy. All PVCs that do have a service policy are individually subject to their attached service policies.

The router can operate in one of two ATM queueing modes: atm pxf queuing or no atm pxf queuing. The router supports:

Unshaped UBR and nonreal-time VBR (VBR-nrt) PVCs when you configure the atm pxf queuing command on the ATM interfaces

Unshaped UBR, shaped UBR, and VBR-nrt PVCs when you configure the no atm pxf queuing command on the ATM interfaces

For more information about ATM service classes, see the "ATM Service Categories" section.

The router allocates bandwidth to VBR, CBR, and shaped UBR PVCs before allocating bandwidth to unshaped UBR PVCs. As a result, a diminished amount of bandwidth is available to allocate to unshaped UBR PVCs. To override this behavior, create an hierarchical policy with the bandwidth specified and attach the policy to the ATM port or physical interface. For more information, see Chapter 13 "Defining QoS for Multiple Policy Levels."

service-policy Command

To attach a policy map that the router can use to apply QoS services to inbound and outbound packets, use the service-policy command in interface or map class configuration mode. Use the no form of the command to remove a service policy. This command has no default value or behavior.

service-policy {input | output} policy-map-name
 
   

no service-policy {input | output} policy-map-name

Syntax Description

input

Indicates to apply the QoS policy to inbound packets.

output

Indicates to apply the QoS policy to outbound packets.

policy-map-name

The name of the policy map (created using the policy-map command) you want to attach. The policy-map-name can be a maximum of 40 alphanumeric characters.


service-policy Command History

Cisco IOS Release
Description

12.0(17)SL

This command was introduced on the PRE1.

12.2(15)BX

This command was introduced on the PRE2.

12.3(7)XI2

This command was enhanced on the PRE2 to allow you to attach a policy map to a range of PVCs, and to a specific PVC within the PVC range.

12.2(28)SB

This command was integrated in Cisco IOS Release 12.2(28)SB for the PRE2.

12.2(31)SB2

This command was introduced on the PRE3.


service-policy Command Modes

You can configure this command in the following configuration modes:

Bundle-VC (for ATM VC bundle members)

Interface

Map-class (for Frame Relay VCs)

PVC-in-range (for ATM VCs)

PVC range (for ATM VCs)

VC submode (for a standalone VC)

Usage Guidelines for the service-policy Command

The service-policy {input | output} policy-map-name command is used to attach a service policy to an interface.

The service-policy policy-map-name command is used to create hierarchical service policies in policy-map class configuration mode. Do not specify input or output when using the service-policy command in an hierarchical policy.

In Cisco IOS Release 12.2(33)SB and later releases, the router no longer accepts the abbreviated form (ser) of the service-policy command. Instead, you must spell out the command name service- before the router accepts the command.

For example, when attaching a policy map the following error message appears when you attempt to use the abbreviated form of the service-policy command:

Router(config)# interface gigabit1/1/0
Router(config-if)# ser out ?
% Unrecognized command
Router(config-if)# ser ?
% Unrecognized command
 
   

When you enter the command as service-, the router accepts the command as shown in the following example:

Router(config-if)# service- ?
input	Assign policy-map to the input of an interface
output	Assign policy-map to the output of an interface
type	Configure CPL Service Policy
 
   

In releases earlier than Cisco IOS Release 12.2(33)SB, the router accepts the abbreviated form of the service-policy command. For example, the router accepts the following commands:

Router(config)# interface gigabit1/1/0
Router(config-if)# ser out test

Restrictions and Limitations for Attaching ATM Service Policies

On ATM line cards, you can apply a policy map to the physical interface, point-to-point subinterfaces, and to individual PVCs. The router does not support applying QoS service policies to point-to-multipoint subinterfaces. However, you can apply service policies to VCs that are on multipoint interfaces.

The policy map you assign to a PVC takes precedence over the policy map you assign to the main interface.

You must first configure the atm pxf queuing command on the interface and then attach the policy map.


Note Do not change the queuing mode while VCs are configured on the interface. To change the mode, first delete the VCs and then change the mode. Changing the mode while VCs are configured can produce undesired results, and the change does not take effect until the router reloads.


For a policy map to be successfully attached to an interface or ATM VC, the aggregate of the configured minimum bandwidths of the policy map classes is limited to the speed of the interface, unless you use the atm over-subscription-factor command to oversubscribe the interface.

The router does not support a service policy based on queuing for unshaped UBR PVCs.

Attaching ATM QoS Service Policies to ATM Interfaces, Subinterfaces, and PVCs

You can attach a QoS service policy to ATM interfaces, point-to-point subinterfaces, or PVCs.

To attach an ATM QoS service policy, perform one of the following configuration tasks:

Attaching QoS Service Policies to an ATM Interface

Attaching QoS Service Policies to an ATM Point-to-Point Subinterface

Attaching QoS Service Policies to an ATM PVC

Attaching QoS Service Policies to an ATM PVC Range and an ATM PVC in a Range

Attaching QoS Service Policies to an ATM Interface

To attach a QoS service policy to an ATM interface, enter the following commands beginning in interface configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface atm slot/module/port

Specifies the interface to which you want to attach the QoS service policy and enters interface configuration mode.

Step 2 

Router(config-if)# service-policy {input 
| output} policy-map-name

Attaches the service policy you specify to the interface.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. If you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map you want to attach to the subinterface.

Note The router applies the service policy to the ATM interface and to all PVCs configured on the interface that do not have their own QoS policy applied.

Configuration Example for Attaching QoS Service Policies to an ATM Interface

Example 4-1 shows how to attach the QoS service policy named myQoS to inbound traffic arriving at ATM interface 1/0/0. The router applies the service policy to all of the PVCs configured on the interface.

Example 4-1 Attaching a QoS Policy to an ATM Interface

Router(config)# interface atm 1/0/0
Router(config-if)# service-policy input myQoS

Attaching QoS Service Policies to an ATM Point-to-Point Subinterface

To attach a QoS service policy to an ATM point-to-point subinterface, enter the following commands beginning in interface configuration mode:


Note The router does not support QoS service policies on ATM point-to-multipoint subinterfaces. However, you can apply service policies to VCs that are configured on multipoint interfaces.


 
Command
Purpose

Step 1 

Router(config)# interface atm slot/module/port

Specifies the ATM interface and enters interface configuration mode.

Step 2 

Router(config-if)# atm pxf queuing

Specifies the interface mode. In this mode, the interface operates in low VC count. The router operates in atm pxf queuing mode by default. You do not need to specify this mode unless the router is currently configured for no atm pxf queuing.

Note This is the required interface operating mode for QoS service policies that include queuing actions.

Step 3 

Router(config-if)# interface atm slot/module/port.subinterface point-to-point

Specifies the point-to-point subinterface and enters subinterface configuration mode.

Step 4 

Router(config-subif)# service-policy 
{input | output} policy-map-name

Attaches the service policy you specify to the ATM subinterface.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. If you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map you want to attach to the subinterface.

Note The router applies the service policy to the ATM subinterface and to all PVCs configured on the subinterface that does not have its own QoS policy applied.

Configuration Example for Attaching QoS Service Policies to an ATM Point-to-Point Subinterface

Example 4-2 attaches a QoS service policy named myQoS to ATM point-to-point subinterface 3/0/0.1 for inbound traffic.

Example 4-2 Attaching a QoS Service Policy to an ATM Point-to-Point Subinterface

Router(config)# interface atm 3/0/0
Router(config-if)# atm pxf queuing
Router(config-if)# interface atm 3/0/0.1 point-to-point
Router(config-subif)# service-policy input myQoS

Attaching QoS Service Policies to an ATM PVC

To attach a QoS service policy to an individual ATM PVC, enter the following commands beginning in interface configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface atm slot/module/port

Specifies the ATM interface and enters interface configuration mode.

Step 2 

Router(config-if)# atm pxf queuing

Specifies the interface mode. In this mode, the interface operates in low VC count. The router operates in atm pxf queuing mode by default. You do not need to specify this mode unless the router is currently configured for no atm pxf queuing.

Note This is the required interface operating mode for QoS service policies that include queuing actions.

Step 3 

Router(config-if)# interface atm slot/module/port.subinterface point-to-point

Specifies the point-to-point subinterface and enters subinterface configuration mode.

Step 4 

Router(config-subif)# pvc [name] vpi/vci

Creates an ATM permanent virtual circuit (PVC) and enters ATM VC configuration mode.

name is the name used to identify the PVC.

vpi is the virtual path identifier.

vci is the virtual circuit identifier.

Step 5 

Router(config-if-atm-vc)# service-policy 
[input | output] policy-map-name

Attaches the service policy you specify to the specified ATM PVC.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. If you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map you want to attach to the subinterface.

Note The router applies the service policy to only the individual ATM PVC that you specify.

Configuration Example for Attaching QoS Service Policies to an ATM PVC

Example 4-3 shows how to attach a QoS service policy named bronze to PVC 0/101 on the ATM subinterface 3/0/0.1 for inbound traffic.

Example 4-3 Attaching a QoS Service Policy to an ATM PVC

Router(config)# interface atm 3/0/0
Router(config-if)# atm pxf queuing
Router(config)# interface atm 3/0/0.1
Router(config-subif)# pvc 0/101
Router(config-if-atm-vc)# service-policy input bronze

Attaching QoS Service Policies to an ATM PVC Range and an ATM PVC in a Range

To attach a QoS service policy to a range of ATM PVCs or to a specific ATM PVC in a range of PVCs, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface atm slot/module/port

Specifies the ATM interface and enters interface configuration mode.

Step 2 

Router(config-if)# range [range-name] pvc 
start-vpi/start-vci end-vpi/end-vci 

Defines a range of ATM permanent virtual circuits (PVCs). Enters ATM range configuration mode.

(Optional) range-name is the name of the range. The range-name can be a maximum of 15 characters.

start-vpi/ specifies the beginning value for a range of virtual path identifiers (VPIs). The slash is required. If you do not provide a VPI value or the slash, the default value of 0 is used. Valid values for VPI are from 0 to 255.

start-vci specifies the beginning value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535.

end-vpi/ specifies the end value for a range of virtual path identifiers (VPIs). The slash is required. If you do not provide a VPI value or the slash, the start-vpi value is used by default. Valid values for VPI are from 0 to 255.

end-vci specifies the end value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535.

Step 3 

Router(config-if-atm-range)# 
service-policy [input | output] 
policy-map-name

Attaches the service policy you specify to the specified ATM PVC range.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. If you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map you want to attach to the subinterface.

Note The router applies the service policy to only the PVCs within the PVC range.

Step 4 

Router(config-if-atm-range)# pvc-in-range [pvc-name] vpi/vci

Configures an individual PVC within a PVC range. Enters ATM range PVC configuration mode.

(Optional) pvc-name is the name given to the PVC. The PVC name can have a maximum of 15 characters.

vpi/ is the virtual path identifier (VPI) for this PVC. The slash is required. If you do not specify a VPI value or the slash, the default value of 0 is used. Valid VPI values are from 0 to 255.

vci is the virtual circuit identifier (VCI) for this PVC. Valid values are from 32 to 2047.

Step 5 

Router(config-if-atm-range-pvc)# 
service-policy [input | output] 
policy-map-name

Attaches the service policy you specify to the specified PVC within the ATM PVC range.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. If you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map you want to attach to the subinterface.

Note The router applies the service policy to only the individual ATM PVC within the PVC range.

Configuration Example for Attaching QoS Service Policies to an ATM PVC

Example 4-4 shows how to attach policy maps to a range of ATM PVCs and to a specific PVC within a PVC range. In the example, the service policy named voice is attached to the range of ATM PVCs 1/32 to 1/34. The router applies the service policy to all of the PVCs within the PVC range. The service policy named data is attached to PVC 1/33 within the PVC range. The router applies the service policy to only PVC 1/33.

Example 4-4 Attaching Policy Maps to ATM PVC Ranges and PVCs in PVC Ranges

Router(config)# interface atm 2/0/0
Router(config-if)# range pvc 1/32 1/34
Router(config-if-atm-range)# service-policy input voice
Router(config-if-atm-range)# pvc-in-range 1/33
Router(config-if-atm-range-vc)# service-policy input data

Attaching Frame Relay QoS Service Policies

You can attach QoS service policies to Frame Relay interfaces, PVCs on subinterfaces, data-link connection identifiers (DLCIs), and map classes using the map-class frame-relay and service-policy commands. You can apply a map class to an interface or subinterface.

This section includes the following topics:

Feature History for Frame Relay QoS

Frame Relay QoS Inheritance

map-class frame-relay Command

Restrictions and Limitations for Frame Relay QoS Service Policies

Creating and Attaching QoS Policies to Frame Relay Interfaces, Subinterfaces, and Data-Link Connection Identifiers

Feature History for Frame Relay QoS

Cisco IOS Release
Description
Required PRE

12.0(23)SX

The attachment of Frame Relay QoS service policies feature was introduced on the router.

PRE1

12.0(25)S

This feature was integrated into Cisco IOS Release 12.0(25)S.

PRE1


Frame Relay QoS Inheritance

On Frame Relay interfaces, you can attach a service policy to the physical interface, an individual PVC, or to both the physical interface and one or more PVCs. The following describes how Frame Relay traffic inherits QoS policies:

If you attach a service policy only to the physical interface, the aggregate of all PVCs is subject to the physical interface's service policy.

If you attach a service policy only to individual PVCs and not to the physical interface, only the individual PVC is subject to its attached service policy.

If you attach service policies to both the physical interface and individual PVCs, the aggregate of all PVCs that do not have a service policy is subject to the physical interface's service policy. All PVCs that do have a service policy are individually subject to their attached service policies.

If you attach a service policy to a Frame Relay point-to-point subinterface (either directly or using a map class), the router applies the QoS service policy to the aggregate of all of the DLCIs configured on the subinterface.

If you attach a service policy to an individual DLCI (either directly or using a map class), the router only applies the QoS service policy to the individual DLCI.

map-class frame-relay Command

To attach a QoS service policy to a Frame Relay interface, PVC on a subinterface, DLCI, or map class, use the map-class frame-relay command in global configuration mode. To remove a map class, use the no form of the command. This command has no default behavior.

map-class frame-relay map-class-name
 
   
no map-class frame-relay map-class-name

Syntax Description

map-class-name

The name of the map class. The map-class-name can be a maximum of 40 alphanumeric characters.


map-class frame-relay Command History

Cisco IOS Release
Description

12.0(23)SX

This command was introduced on the PRE1.

12.0(25)S

This command was integrated into Cisco IOS Release 12.0(25)S.


Usage Guidelines for the map-class frame-relay Command

You can attach a QoS service policy to a Frame Relay map class using the service-policy command. For more information, see the "service-policy Command" section.

You can apply a map class to a Frame Relay interface and subinterface.

Restrictions and Limitations for Frame Relay QoS Service Policies

Do not configure Frame Relay services using both the modular QoS command-line interface (MQC) and the Frame Relay legacy commands.

For Cisco IOS Release 12.0(22)S and later releases, use the MQC to configure QoS services for Frame Relay interfaces.

For all releases earlier than Cisco IOS Release 12.0(22)S, use the Frame Relay commands to configure Frame Relay QoS services. For more information, see "Configuring Frame Relay QoS Using Frame Relay Legacy Commands."

The router has no preset scaling limit for Frame Relay QoS services. You can apply any number of Frame Relay QoS services.

The router does not support attaching QoS service policies to Frame Relay point-to-multipoint subinterfaces.

You cannot attach a policy map and a map class to the same subinterface. For Cisco IOS Release 12.0(22)S and later releases, use the MQC to create and attach a policy map as described in this chapter. For all releases earlier than Cisco IOS Release 12.0(22)S, use the Frame Relay legacy commands to create and attach a Frame Relay QoS policy as described in "Configuring Frame Relay QoS Using Frame Relay Legacy Commands."

Output QoS policies that contain queuing actions must be nested service policies.

Creating and Attaching QoS Policies to Frame Relay Interfaces, Subinterfaces, and Data-Link Connection Identifiers

To create a Frame Relay QoS service policy, use the modular QoS CLI (MQC) elements called class maps and policy maps. For more information, see the "Classifying Traffic Using a Class Map" section and the "Creating a Policy Map" section.

After you create the policy map, you can attach it to a Frame Relay interface, point-to-point subinterface, data-link connection identifier (DLCI), or map class. You can apply a map class to an interface or subinterface.


Note The router does not support attaching a QoS service policy to a Frame Relay point-to-multipoint subinterface. You can attach a QoS service policy to either a Frame Relay subinterface, a Frame Relay DLCI, but not to both.


To attach a QoS service policy to a Frame Relay link, perform any of the following tasks:

Attaching a QoS Service Policy to a Frame Relay Interface or Point-to-Point Subinterface

Attaching a QoS Service Policy to a Frame Relay DLCI

Attaching a QoS Service Policy to a Frame Relay Interface or Point-to-Point Subinterface

To attach a QoS policy to a Frame Relay interface or point-to-point subinterface, perform either of the following tasks:

Attaching a QoS Policy Directly to a Frame Relay Interface or Point-to-Point Subinterface

Attaching a QoS Service Policy to a Frame Relay Interface or Point-to-Point Subinterface Using a Map Class


Note You cannot attach a QoS policy to the same Frame Relay interface or subinterface by using both the MQC and a map class. For releases earlier than Cisco IOS Release 12.0(22)S, use the Frame Relay commands to attach QoS policies (see "Configuring Frame Relay QoS Using Frame Relay Legacy Commands"). For Cisco IOS Release 12.0(22)S and later releases, use the MQC.


Attaching a QoS Policy Directly to a Frame Relay Interface or Point-to-Point Subinterface

To attach a QoS policy directly to a Frame Relay interface or point-to-point subinterface, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type slot/subslot/port.subinterface

Specifies the interface or subinterface to which you want to attach the QoS service policy. Enters interface or subinterface configuration mode.

Step 2 

Router(config-if)# service-policy {input 
| output} policy-map-name

Applies the service policy you specify to the interface or subinterface.

input indicates to apply the service policy to the inbound traffic on the interface.

output indicates to apply the service policy to the outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. The router ignores these commands when you use them with the input keyword.

policy-map-name is the name of the policy map you want to attach to the interface.

Note The router applies the service policy to the aggregate of all of the data link connection identifies (DLCIs) configured on the interface or subinterface.

Configuration Examples for Attaching QoS Policies Directly to a Frame Relay Interface or Point-to-Point Subinterface

Example 4-5 shows how to attach the service policy named mypolicy2 to serial subinterface 1/0/0.1 in the inbound direction.

Example 4-5 Attaching a QoS Policy Directly to a Frame Relay Point-to-Point Subinterface

Router(config)# interface serial 1/0/0.1 point-to-point
Router(config-if)# service-policy input mypolicy2 
 
   

Example 4-6 shows how to attach the service policy named silver to serial interface 4/0/0 in the inbound direction.

Example 4-6 Attaching a QoS Policy Directly to a Frame Relay Interface

Router(config)# interface serial 4/0/0
Router(config-if)# service-policy input silver 
 
   

Attaching a QoS Service Policy to a Frame Relay Interface or Point-to-Point Subinterface Using a Map Class

To attach a QoS service policy to a Frame Relay interface or point-to-point subinterface using a Frame Relay map class, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# map-class frame-relay map-class-name

Specifies a map class and enters map-class configuration mode.

map-class-name identifies the map class.

Step 2 

Router(config-map-c)# service-policy 
[input | output] policy-map-name

Applies the service policy you specify to the map class.

input indicates to apply the service policy to the inbound traffic on the interface.

output indicates to apply the service policy to the outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. The router ignores these commands when you use them with the input keyword.

policy-map-name is the name of the policy map.

Step 3 

Router(config-map-c)# exit

Exits map-class configuration mode.

Step 4 

Router(config)# interface type slot/subslot/port.subinterface [point-to-point]

Specifies the interface or subinterface to which you want to attach the map class. Enters interface or subinterface configuration mode.

Step 5 

Router(config-if)# frame-relay class name

Associates a map class with a Frame Relay subinterface.

name is the name of the map class you want to associate with the interface.

Note The router applies the service policy configured in the map class to the aggregate of all of the data link connection identifies (DLCIs) on the interface or subinterface.

Configuration Examples for Attaching a QoS Policy to a Frame Relay Interface or Point-to-Point Subinterface Using a Map Class

Example 4-7 shows how to configure a policy map named policy1 within a Frame Relay map class named VCs_slow and attach the map class to serial subinterface 1/0/0.1.

Example 4-7 Configuring a QoS Service Policy on a Frame Relay Subinterface Using a Map Class

Router(config)# map-class frame-relay VCs_slow
Router(config-map-c)# service-policy policy1
Router(config-map-c)# exit
Router(config)# interface serial 1/0/0.1 point-to-point
Router(config-if)# frame-relay class VCs-slow

Example 4-8 shows how to configure a policy map named bronze within a Frame Relay map class named slow-VCs and attach the map class to serial interface 2/0/0.

Example 4-8 Configuring a QoS Service Policy on a Frame Relay Interface Using a Map Class

Router(config)# map-class frame-relay slow-VCs
Router(config-map-c)# service-policy bronze
Router(config-map-c)# exit
Router(config)# interface serial 2/0/0
Router(config-if)# frame-relay class slow-VCs

Attaching a QoS Service Policy to a Frame Relay DLCI

To attach a QoS service policy to a Frame Relay DLCI, perform one of the following tasks:

Attaching a QoS Service Policy Directly to a Frame Relay DLCI

Attaching a QoS Service Policy to a Frame Relay DLCI Using a Map Class


Note You cannot attach a QoS policy to the same Frame Relay interface or subinterface by using both the MQC and a map class. For releases earlier than Cisco IOS Release 12.0(22)S, use the Frame Relay commands to attach QoS policies (see "Configuring Frame Relay QoS Using Frame Relay Legacy Commands"). For Cisco IOS Release 12.0(22)S and later releases, use the MQC.


Attaching a QoS Service Policy Directly to a Frame Relay DLCI

You can attach a QoS service policy to a Frame Relay DLCI that is configured on an interface or subinterface.

To attach a QoS service policy directly to a Frame Relay DLCI, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type slot/subslot/port.subinterface [point-to-point]

Specifies the interface or subinterface. Enters interface or subinterface configuration mode.

Step 2 

Router(config-if)# frame-relay interface-dlci dlci

Assigns a data link connection identifier (DLCI) to the Frame Relay interface or subinterface. Enters Frame Relay DLCI configuration mode.

dlci is a number that identifies the data link connection on the interface or subinterface.

Step 3 

Router(config-fr-dlci)# service-policy 
[input | output] policy-map-name

Attaches the service policy you specify to the individual DLCI.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. If you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map.

Note The router applies the service policy only to the individual DLCI.

Configuration Examples for Attaching a QoS Service Policy Directly to a Frame Relay DLCI

Example 4-9 shows how to attach the service policy named user_policy to the data link connection identifier (DLCI) 100 on serial subinterface 1/0/0.1 for outbound packets.

Example 4-9 Attaching a QoS Service Policy Directly to a DLCI Configured on a Subinterface

Router(config)# interface serial 1/0/0.1 point-to-point
Router(config-if)# frame-relay interface-dlci 100
Router(config-fr-dlci)# service-policy output user_policy
 
   

Example 4-10 shows how to attach the service policy named voice to DLCI 201 on serial interface 4/0/0 for outbound packets.

Example 4-10 Attaching a QoS Service Policy Directly to a DLCI Configured on an Interface

Router(config)# interface serial 4/0/0
Router(config-if)# frame-relay interface-dlci 201
Router(config-fr-dlci)# service-policy output voice

Attaching a QoS Service Policy to a Frame Relay DLCI Using a Map Class

You can attach a map class with a QoS policy to a Frame Relay DLCI that is configured on an interface or subinterface.

To attach a QoS service policy to a Frame Relay DLCI using a map class, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# map-class frame-relay map-class-name

Specifies a map class and enters map-class configuration mode.

map-class-name identifies the map class.

Step 2 

Router(config-map-c)# service-policy 
[input | output] policy-map-name

Applies the service policy you specify to the map class.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. If you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map.

Step 3 

Router(config-map-c)# exit

Exits map-class configuration mode.

Step 4 

Router(config)# interface type slot/module/port.subinterface [point-to-point]

Specifies an interface or subinterface. Enters interface or subinterface configuration mode.

Step 5 

Router(config-if)# frame-relay interface-dlci dlci

Assigns a data link connection identifier (DLCI) to the Frame Relay interface or subinterface. Enters Frame Relay DLCI configuration mode.

dlci is a number that identifies the data link connection on the interface or subinterface.

Step 6 

Router(config-fr-dlci)# frame-relay class name

Associates a map class with the individual DLCI.

name is the name of the map class that you want to associate with the DLCI.

Note The router applies the service policy configured in the map class to only this individual DLCI.

Configuration Examples for Attaching a QoS Service Policy to a Frame Relay DLCI Using a Map Class

Example 4-11 shows how to configure a policy map named gold within a Frame Relay map class named group1, and attach the map class to DLCI 101 configured on the serial subinterface 1/0/0.2.

Example 4-11 Attaching a QoS Service Policy to a Frame Relay Subinterface DLCI Using a Map Class

Router(config)# map-class frame-relay group1
Router(config-map-class)# service-policy gold
Router(config-map-class)# exit
Router(config)# interface serial 1/0/0.2 point-to-point
Router(config-if)# frame-relay interface-dlci 101
Router(config-fr-dlci)# frame-relay class group1
 
   

Example 4-12 shows how to configure a policy map named Premium within a Frame Relay map class named voice, and attach the map class to DLCI 200 configured on the serial interface 3/0/0.

Example 4-12 Attaching a QoS Service Policy to a Frame Relay Interface DLCI Using a Map Class

Router(config)# map-class frame-relay voice
Router(config-map-class)# service-policy Premium
Router(config-map-class)# exit
Router(config)# interface serial 3/0/0
Router(config-if)# frame-relay interface-dlci 200
Router(config-fr-dlci)# frame-relay class voice

Attaching Virtual LAN QoS Service Policies

On Ethernet interfaces with virtual LANs (VLANs) configured, you can attach a QoS service policy to the physical interface, an individual VLAN subinterface, or to both the physical interface and one or more VLAN subinterfaces.

This section describes the following topics:

Feature History for VLAN QoS

VLAN QoS Inheritance

Restrictions and Limitations for Attaching QoS Services to VLAN Subinterfaces

Attaching QoS Policies to VLAN Interfaces and Subinterfaces

Feature History for VLAN QoS

Cisco IOS Release
Description
Required PRE

12.0(25)SX

The attachment of virtual LAN QoS service policies was introduced on the router.

PRE1

12.2(15)BX

This feature was introduced on the PRE2.

PRE2

12.2(28)SB

This feature was integrated in Cisco IOS Release 12.2(28)SB for the PRE2.

PRE2


VLAN QoS Inheritance

The following describes how VLAN traffic inherits QoS policies:

If you attach a service policy only to the physical interface, the aggregate of all of the VLAN subinterfaces is subject to the physical interface's service policy.

If you attach a service policy only to individual VLAN subinterfaces and not to the physical interface, only the individual VLAN subinterfaces are subject to the attached service policies.

If you attach service policies to both the physical interface and to individual VLAN subinterfaces, the aggregate of all VLAN subinterfaces without a service policy is subject to the physical interface's service policy, and all of the VLAN subinterfaces with a service policy are individually subject to their attached service policies.

Restrictions and Limitations for Attaching QoS Services to VLAN Subinterfaces

The Cisco 10000 series router currently supports PPPoE over IEEE 802.1Q VLAN on Gigabit Ethernet and Fast Ethernet 8-port half-height line cards. The Fast Ethernet port (fe0/0/0) of the performance routing engine (PRE) does not support this feature. This port is for management traffic only.

For PRE1 and PRE2, output QoS policies that contain queueing actions must be nested service policies. However, for PRE3 and PRE4, there is no such restriction and thereby a flat queueing policy can be directly attached to a VLAN subinterface.

Attaching QoS Policies to VLAN Interfaces and Subinterfaces

To attach QoS service policies to VLAN interfaces and subinterfaces, perform any of the following configuration tasks:

Attaching QoS Service Policies to Physical Interfaces with VLAN Subinterfaces

Attaching QoS Service Policies to VLAN Subinterfaces

Attaching QoS Service Policies to Physical Interfaces with VLAN Subinterfaces

To attach QoS service policies to physical interfaces with VLAN subinterfaces, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type slot/module/port

Specifies the physical Ethernet interface to which you want to attach the QoS service policy. Enters interface configuration mode.

Step 2 

Router(config-if)# service-policy {input 
| output} policy-map-name

Attaches the service policy you specify to the physical interface.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. If you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map.

Step 3 

Router(config-if)# interface type slot/module/port.subinterface

Creates a subinterface and enters subinterface configuration mode.

Step 4 

Router(config-subif)# encapsulation dot1q 
vlanid

Configures the subinterface as a VLAN subinterface.

dot1q defines the encapsulation format as IEEE 802.1Q VLAN.

vlanid is a number that identifies the VLAN.

Note The router applies the service policy of the physical interface to all of the individual VLANs configured on the interface.

Configuration Example for Attaching QoS Policies to Physical Interfaces with VLAN Subinterfaces

Example 4-13 shows how to attach a service policy named myQoS to the physical Gigabit Ethernet interface 1/0/0 for inbound traffic. VLAN 4, configured on the GigabitEthernet subinterface 1/0/0.3, inherits the service policy of the physical Gigabit Ethernet interface 1/0/0.

Example 4-13 Attaching a QoS Policy to a VLAN Interface

Router(config)# interface GigabitEthernet 1/0/0
Router(config-if)# service-policy input myQoS
Router(config-if)# interface GigabitEthernet 1/0/0.3
Router(config-subif)# encapsulation dot1q 4

Attaching QoS Service Policies to VLAN Subinterfaces

To attach a QoS service policy to a VLAN subinterface, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type slot/module/port.subinterface

Specifies the Ethernet subinterface to which you want to attach the QoS service policy. Enters subinterface configuration mode.

Step 2 

Router(config-subif)# encapsulation dot1q 
vlanid

Creates a VLAN subinterface.

dot1q defines the encapsulation format as IEEE 802.1Q VLAN.

vlanid is a number that identifies the VLAN.

Step 3 

Router(config-subif)# service-policy 
[input | output] policy-map-name

Attaches the service policy you specify to the subinterface.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. When you use these commands with the input keyword, the router ignores the commands .

policy-map-name is the name of the policy map.

Note The router applies the service policy to only this individual VLAN subinterface.

Configuration Example for Attaching a QoS Service Policy to a VLAN Subinterface

Example 4-14 shows how to attach a policy map named bronze to VLAN 4 on GigabitEthernet subinterface 1/0/0.3 for outbound traffic.

Example 4-14 Attaching a QoS Policy to an Individual VLAN

Router(config)# interface GigabitEthernet 1/0/0.3
Router(config-subif)# encapsulation dot1q 4
Router(config-subif)# service-policy output bronze

Attaching Virtual Access Interface QoS Service Policies

A virtual access interface (VAI) is a virtual interface that the router dynamically creates and configures when a remote user initiates a session to the Cisco 10000 series router.

1. The router uses a template of operational parameters called a virtual template interface to create and configure the VAI.

2. When the user connection terminates, the router deletes the VAI and frees the resources for other client uses.

The virtual template interface is a logical entity that the router applies dynamically as needed to a connection. It is a configuration for an interface, but it is not tied to the physical interface. The VAI uses the attributes of the virtual template to create the session, which results in a VAI that is uniquely configured for a specific user.

After you configure a virtual template, configure the virtual connection that will use the template and then apply the template to the virtual connection. The order in which you create virtual templates and configure the virtual connections that use the templates is not important. However, before a remote user initiates a session to the router, both the virtual templates and connections must exist.

If you use a RADIUS server, the RADIUS configuration takes precedence over the virtual template configuration. For example, the RADIUS configuration might override some parameters and the virtual template provides the remainder of the configuration.


Note Virtual template interfaces and VAIs do not apply to routed bridge encapsulation (RBE) over ATM.


For more information about virtual templates and VAIs, see the Cisco 10000 Series Broadband Aggregation and Leased-Line Configuration Guide at:

http://www.cisco.com/en/US/products/hw/routers/ps133/products_configuration_guide_book09186a00804d45ca.html

This section describes the following topics:

Feature History for VAI QoS

VAI QoS Inheritance

Restrictions and Limitations for Attaching QoS Services to a VAI

Attaching QoS Policies to VAIs Using Virtual Template Interfaces

Feature History for VAI QoS

Cisco IOS Release
Description
Required PRE

12.0(25)SX

The attachment of VAI QoS service policies feature was introduced on the router.

PRE1

12.2(15)BX

This feature was introduced on the PRE2.

PRE2

12.2(28)SB

This feature was integrated in Cisco IOS Release 12.2(28)SB for the PRE2.

PRE2

12.2(31)SB2

This feature was introduced on the PRE3.

PRE2
PRE3


VAI QoS Inheritance

When you apply a QoS service policy to a virtual circuit (VC), the virtual access interfaces (VAIs) that use that VC inherit the QoS policy of the VC. Any VAI that uses that VC is subject to the queueing, policing, and marking actions defined in the VC service policy.

Restrictions and Limitations for Attaching QoS Services to a VAI

Virtual template interfaces and VAIs do not apply to routed bridge encapsulation (RBE) over ATM.

Before a remote user initiates a session to the router, both the virtual template and virtual connection must exist.

Cisco IOS Release 12.2(25)SX does not support the configuration of broadband aggregation (BBA) groups using RADIUS. You must configure BBA groups manually.

You can only apply a QoS policy with queueing-related actions to a VC. Do not apply service policies with class-based weighted fair queueing (CBWFQ) actions to a VAI using a virtual template. The router supports queueing only when you apply the QoS policy to a VC.

You can apply a QoS policy without queueing-related actions to either a VC or a VAI, but not to both at the same time.

You cannot use RADIUS to configure a QoS policy on the VC.

If you configure a QoS policy on a VC, the show policy interface VAI command does not display information to indicate that the VAI is subject to the VC service policy. However, if you apply a policy directly to a VAI, the show policy interface VAI command displays information about the policy on the VAI.

Attaching QoS Policies to VAIs Using Virtual Template Interfaces

To attach QoS service policies to virtual access interfaces (VAIs), perform the following required configuration tasks:

Applying a QoS Service Policy to a Virtual Template Interface

Applying a Virtual Template Interface to a BBA Group

Attaching a BBA Group to an Interface or Subinterface for PPPoE Sessions

Applying a QoS Service Policy to a Virtual Template Interface

To apply a QoS service policy to a virtual template interface, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface virtual-template number

Creates a virtual template interface and enters interface configuration mode.

number is a number from 1 to 200 that identifies the virtual template.

Step 2 

Router(config-if)# service-policy [input | 
output] policy-map-name

Attaches the service policy you specify to the virtual template interface.

input indicates to apply the service policy to inbound traffic on the interface.

output indicates to apply the service policy to outbound traffic on the interface.

Note For QoS policies containing the bandwidth, priority, random-detect, queue-limit, and shape commands, you must specify the output keyword. When you use these commands with the input keyword, the router ignores the commands.

policy-map-name is the name of the policy map.

Configuration Example for Applying QoS Policies to Virtual Template Interfaces

Example 4-15 shows how to apply the policy map named policy1 to the virtual template named virtual-template1 for all inbound traffic. In this example, the virtual template configuration also includes CHAP authentication and point-to-point protocol (PPP) authorization and accounting.

Example 4-15 Applying QoS Policies to a Virtual Template Interface

Router(config)# interface virtual-template1
Router(config-if)# ip unnumbered Loopback1
Router(config-if)# no peer default ip address
Router(config-if)# ppp authentication chap vpn1
Router(config-if)# ppp authorization vpn1
Router(config-if)# ppp accounting vpn1
Router(config-if)# service-policy policy1

Applying a Virtual Template Interface to a BBA Group

A BBA group is a template used to control connections. Cisco IOS Release 12.2(25)SX does not support the configuration of broadband aggregation (BBA) groups using RADIUS. You must configure BBA groups manually.

To apply a virtual template interface to a BBA group for Point-to-Point Protocol over Ethernet (PPPoE) over IEEE 802.1Q VLAN, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# bba-group pppoe {name | global}

Configures a BBA group to be used to establish PPPoE sessions.

name identifies the BBA group. You can configure multiple BBA groups.

global is the default BBA group used for PPPoE connections when a BBA group name is not specified.

Step 2 

Router(config-bba)# virtual-template template-number

Applies the virtual template interface you specify to the BBA group. The router uses the virtual template interface to clone virtual access interfaces (VAIs).

template-number is a number that identifies the virtual template and is used to clone virtual-access interfaces.


Note You cannot simultaneously configure a BBA group for PPPoE and a VPDN group for PPPoE. If you configure a BBA group and then you configure a VPDN group, the protocol command in VPDN accept-dialin configuration mode does not include an option for PPPoE (for example, you cannot specify the protocol pppoe command). Use the no bba-group pppoe command to re-enable the pppoe option for the protocol command.


Configuration Example for Applying a Virtual Template Interface to a BBA Group

Example 4-16 shows how to create a BBA group named vpn1 and apply the virtual template named VirtualTemplate 1 to the group. In the example, the BBA group configuration limits the number of sessions per VC to 5 and specifies that a maximum of 10 PPPoE sessions can be terminated on the interface or subinterface to which the BBA group is attached.

Example 4-16 Applying a Virtual Template Interface to a BBA Group

Router(config)# bba-group pppoe vpn1
Router(config-bba)# VirtualTemplate 1
Router(config-bba)# sessions per-vc limit 5
Router(config-bba)# sessions per-mac limit 10

Attaching a BBA Group to an Interface or Subinterface for PPPoE Sessions

You can attach a BBA group to physical interfaces and subinterfaces with varying encapsulations, or to permanent virtual circuits (PVCs).

To attach a BBA group to an interface or subinterface, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type slot/subslot/port.subinterface

Specifies the interface or subinterface to which you want to attach the BBA group. Enters subinterface configuration mode.

Step 2 

Router(config-subif)# protocol pppoe group group-name

Attaches the BBA group to the specified interface or subinterface. Enables PPP over Ethernet (PPPoE) sessions to be established on the interface, subinterface, or permanent virtual circuits (PVCs).

Note The router applies the QoS policy of the virtual template associated with the BBA group. The QoS policy applies to this interface or subinterface and to any PVCs configured on the interface or subinterface without a specified policy.

Configuration Examples for Attaching a BBA Group to an Interface or Subinterface

Example 4-17 shows how to attach a BBA group named bba1 to the ATM interface 1/0/0 for PPPoE sessions.

Example 4-17 Attaching a BBA Group to an Interface

Router(config)# interface atm 1/0/0
Router(config-if)# protocol pppoe group bba1
Router(config-if)# encapsulation ppp
Router(config-if)# pppoe enable
 
   
 
   

Example 4-18 shows how to attach a BBA group named bba-voice to ATM subinterface 4/0/0.10 for PPPoE sessions. The example also assigns VLAN 4 to the subinterface.

Example 4-18 Attaching a BBA Group to a VLAN Subinterface

Router(config)# interface atm 4/0/0.10
Router(config-subif)# protocol pppoe group bba-voice
Router(config-subif)# encapsulation dot1q 4
Router(config-subif)# pppoe enable
 
   

Example 4-19 shows how to use a virtual template interface to apply a QoS policy to PPPoE sessions. The example configuration shows how to create a virtual template interface, apply the virtual template to a BBA group, and apply the BBA group to an interface or subinterface. The QoS policy named policy1 is applied to the virtual template interface named Virtual-Template1; Virtual-Template1 is applied to the BBA group named VPN_1; and VPN_1 is applied to the ATM interface 5/0, which is configured for aalsnap encapsulation. The QoS policy named voice1 is applied to the virtual template interface named Virtual-Template2; Virtual-Template2 is applied to the BBA group named VPN_2; and VPN_2 is applied to the FastEthernet subinterface 3/0/0.33, which is configured as a VLAN subinterface.

Example 4-19 Applying a QoS Policy to PPPoE Sessions Using a Virtual Template on a VLAN Subinterface

Router(config)# interface Virtual-Template1
Router(config-if)# ip unnumbered Loopback0
Router(config-if)# mtu 1492
Router(config-if)# peer default ip address pool pool1
Router(config-if)# ppp authentication chap
Router(config-if)# service-policy input policy1
 
   
Router(config)# interface Virtual-Template2
Router(config-if)# ip unnumbered Loopback1
Router(config-if)# no peer default ip address
Router(config-if)# ppp authentication chap 
Router(config-if)# ppp authorization
Router(config-if)# service-policy input voice1
 
   
Router(config)# bba-group pppoe VPN_1
Router(config-bba)# virtual-template 1
Router(config-bba)# sessions per-vc limit 5
Router(config-bba)# sessions per-mac limit 10
Router(config-bba)# sessions per-vlan limit 5
!
!
Router(config)# bba-group pppoe VPN_2
Router(config-bba)# virtual-template 2
Router(config-bba)# sessions per-vc limit 5
Router(config-bba)# sessions per-mac limit 10
Router(config-bba)# sessions per-vlan limit 5
!
!
Router(config)# interface atm 5/0
Router(config-if)# protocol pppoe group VPN_1
Router(config-if)# encapsulation aalsnap
!
Router(config)# interface FastEthernet 3/0/0.33
Router(config-subif)# protocol pppoe group VPN_2
Router(config-subif)# encapsulation dot.1q 5
!
!

Attaching Layer 2 Access Concentrator QoS Service Policies

You can attach a QoS service policy to an ATM VC on the Layer 2 access concentrator (LAC) using the service-policy command.

This section describes the following topics:

Feature History for LAC QoS

LAC QoS Inheritance

Restrictions and Limitations for Attaching LAC QoS

Attaching QoS Policies to LAC ATM Virtual Circuits

Feature History for LAC QoS

Cisco IOS Release
Description
Required PRE

12.3(7)XI3

The QoS: Broadband Aggregation Enhancements - Phase 1 feature (also known as LAC QoS) was introduced on the router to support LAC QoS policies on an ATM virtual circuit.

PRE2

12.2(28)SB

LAC QoS was integrated in Cisco IOS Release 12.2(28)SB.

PRE2


LAC QoS Inheritance

The following describes how LAC traffic inherits QoS policies:

If you attach a service policy only to the physical ATM interface, the aggregate of all unshaped UBR PVCs is subject to the physical interface's service policy. The router treats shaped UBR PVCs like variable bit rate (VBR) and constant bit rate (CBR) PVCs.

If you attach a service policy only to individual ATM PVCs and not to the physical ATM interface, only the individual PVC is subject to its attached service policy.

If you attach service policies to both the physical ATM interface and individual ATM PVCs, the aggregate of all UBR PVCs without an attached service policy is subject to the physical interface's service policy. All PVCs with an attached service policy are individually subject to their attached service policies.

When a service policy is attached to an individual ATM PVC, sessions that use that PVC inherit the service policy applied to the PVC or the inherited policy of the PVC. If a session inherits a policy, the show policy interface virtual access command does not display the state of the inherited policy. You can display the state of the policy only on the interface where you configured the policy. If you attach a service policy only to:

The physical Ethernet interface, the aggregate of all of the VLAN subinterfaces is subject to the physical interface's service policy.

Individual VLAN subinterfaces, and not to the physical Ethernet interface, only the individual VLAN subinterfaces are subject to the attached service policies.

If you attach service policies to both the Ethernet physical interface and to individual VLAN subinterfaces, the aggregate of all VLAN subinterfaces without a service policy is subject to the physical interface's service policy, and all of the VLAN subinterfaces with a service policy are individually subject to their attached service policies.

Restrictions and Limitations for Attaching LAC QoS

Cisco IOS Release 12.3(7)XI3 does not support the attachment of LAC QoS directly to sessions by attaching QoS services to a virtual access interface (VAI) using a virtual template. If you apply LAC QoS to a virtual template, the router ignores it.

On ATM line cards, you can apply a policy map to the physical interface, point-to-point subinterfaces, and to individual PVCs. The router does not support applying QoS service policies to point-to-multipoint interfaces. However, you can apply service policies to VCs that are on multipoint interfaces.

The policy map you assign to an ATM PVC takes precedence over the policy map you assign to the main interface.

You must first configure the atm pxf queuing command on the ATM interface and then attach the policy map.


Note Do not change the queuing mode while VCs are configured on the interface. If you must change the mode, first delete the VCs and then change the mode. Changing the mode while VCs are configured can produce undesired results, and the change does not take effect until the router reloads.


The aggregate bandwidth of the classes configured in a policy map is limited to the speed of the interface or subinterface to which it is applied. The aggregate bandwidth of a policy applied to a VC is limited to the capacity of the port, unless you configure oversubscription by using the atm over-subscription-factor command.

The router does not support a service policy based on queueing for unshaped UBR PVCs.

The Cisco 10000 series router currently supports PPPoE over IEEE 802.1Q VLAN on Gigabit Ethernet and Fast Ethernet 8-port half-height line cards. In a PPPoE over Ethernet configuration, you cannot attach a service policy to a subinterface if another service policy is already attached to its main interface.

The Fast Ethernet port (fe0/0/0) of the performance routing engine (PRE) does not support PPPoE over Ethernet. This port is for management traffic only.

Output QoS policies that contain queueing actions must be hierarchical service policies. For more information, see Chapter 13 "Defining QoS for Multiple Policy Levels."

Attaching QoS Policies to LAC ATM Virtual Circuits

You can attach QoS policies to ATM virtual circuits on the LAC. For information about how to do this, see the "Attaching QoS Service Policies to an ATM PVC" section.

Applying QoS on Layer 2 Tunnel Packets

The following describes how the Cisco 10000 series router applies QoS policies to Layer 2 tunnel packets:

Inbound Layer 2 Tunnel Packets

1. When a packet arrives on a physical interface, the router applies the input QoS policy (if one exists) of the physical interface.

2. The router then applies the input QoS policy of the packet's tunnel interface.

Outbound Layer 2 Tunnel Packets

1. When a packet leaves the router, it applies the output QoS policy (if one exists) of the outbound tunnel interface.

2. The router then applies the output QoS policy of the outbound physical interface.

When applying the QoS policy, the physical interface uses the tunnel outer IP header; the tunnel interface uses the inner IP header.

When an IP packet is encapsulated in a tunnel, the router copies the packet's original IP type of service (ToS) value into the tunnel header.

Verifying and Monitoring QoS Service Policies

To verify and monitor QoS service policies attached to ATM, Frame Relay, and VLAN subinterfaces, enter any of the following commands in privileged EXEC mode:

Command
Purpose
Router# show interface

Displays Layer 2 statistics for all interfaces configured on the router.

Router# show interfaces virtual-access number [configuration]

Displays statistical and configuration information about the active VAI that was created using a virtual template interface.

number is the number of the virtual access interface (VAI) that is used to identify the VAI.

The configuration keyword indicates to display only configuration information.

Router# show policy-map interface

Displays the packet statistics of all classes that are configured for all service policies either on the specified interface or subinterface or on a specific PVC on the interface.

The following information displays for each policy:

Class map name

Total packets and bytes

30-second traffic rate

Queue statistics

Bandwidth allocated for the class map

Congestion avoidance parameters

In Cisco IOS Release 12.0(25)SX and later releases, the show policy-map interface command also provides RED drop counts for each IP precedence.

Router# show policy-map interface virtual-access 
number 

Displays statistical and configuration information about the QoS policy configured on the virtual access interface (VAI) you specify.

number is the number of the virtual access interface (VAI) that identifies the VAI.

If you configure a QoS policy on a VC, the show policy-map interface virtual-access command does not display information to indicate that the VAI is subject to the VC service policy. However, if you apply a QoS policy directly to a VAI, the show policy interface virtual-access command displays information about the QoS policy on the VAI.

Router# show pxf interface interface [detail]
 
        

Displays a summary of the statistics accumulated by column 0 of the PXF for the interface you specify. If you do not specify an interface, a summary of the statistics for all PXF interfaces on the router appears.

interface is the type and number of the interface (for example, serial 4/0/0).

detail indicates to display detailed information rather than a summary of information.

The command displays information such as the following:

Number of packets input

Number of errors

Overall status of the interface queues

Board-level statistics for connection to the backplane

Router# show pppoe session all

Displays a summary of the status of all active tunnels for each session ID.

Router# show pppoe session packets

Displays a summary of the status of all packets traveling in and traveling out of a PPPoE session.



Note The show pxf commands are entered as show hardware pxf on the PRE1. For example, to view a statistical summary of PXF column 0 for the specified interface, enter the show hardware pxf interface command.


Verification Example for QoS Service Policies

Example 4-20 shows the information displayed when you enter the show policy-map interface command. In the sample output, random early detection (RED) drop statistics display for each IP precedence.

The sample output in Example 4-20 is based on the following class map and policy map configurations:

class-map match-all prec_0_0
	match access-group 100
class-map match-all prec_0_1
	match access-group 101
class-map match-any class-default
 
   
policy-map wred_1
	class prec_0_0
	bandwidth 75
	random-detect precedence-based
	random-detect exponential-weighting-constant3
	random-detect precedence 0 10 20 10
	class prec_0_1
	bandwidth 73
	random-detect precedence-based
	random-detect exponential-weighting-constant 3
	random-detect precedence 1 10 20 10

Example 4-20 Displaying RED Drop Counts

Router# show policy-map interface atm 7/0/0.2
ATM7/0/0.2: VC 2/101 -
 
   
	Service-policy output: wred_1 
 
   
	Class-map: prec_0_0 (match-all)
	0 packets, 0 bytes
	5 minute offered rate 0 bps, drop rate 0 bps
	Match: access-group 100
	Output queue: 0/64; 0/0 packets/bytes output, 0/0 drops
	Bandwidth : 75 kbps (Weight 3)
	Random-detect (precedence-based):
	Exponential weight: 3 (1/8)
	Current average queue length: 0 packets
	-----------------------------------------------------------------------
	TOS	Min	Max	Mark	Rand-Drop		Tail-Drop
	precedence	thres	thres	probability	Pkts	Bytes	Pkts	Byte
	-----------------------------------------------------------------------
	0	10	20	1/10	0	0	0	0
	1	36	64	1/10	0	0	0	0
	2	40	64	1/10	0	0	0	0
	3	44	64	1/10	0	0	0	0
	4	48	64	1/10	0	0	0	0
	5	52	64	1/10	0	0	0	0
	6	56	64	1/10	0	0	0	0
	7	60	64	1/10	0	0	0	0
	Class-map: prec_0_1 (match-all)
	0 packets, 0 bytes
	5 minute offered rate 0 bps, drop rate 0 bps
	Match: access-group 101
	Output queue: 0/64; 0/0 packets/bytes output, 0/0 drops
	Bandwidth : 73 kbps (Weight 3)
	Random-detect (precedence-based):
	Exponential weight: 3 (1/8)
	Current average queue length: 0 packets
	-----------------------------------------------------------------------
	TOS	Min	Max	Mark	Rand-Drop		Tail-Drop
	precedence	thres	thres	probability	Pkts	Bytes	Pkts	Byte
	-----------------------------------------------------------------------
	0	32	64	1/10	0	0	0	0
	1	10	20	1/10	0	0	0	0
	2	40	64	1/10	0	0	0	0
	3	44	64	1/10	0	0	0	0
	4	48	64	1/10	0	0	0	0
	5	52	64	1/10	0	0	0	0
	6	56	64	1/10	0	0	0	0
	7	60	64	1/10	0	0	0	0
	Class-map: class-default (match-any)
	0 packets, 0 bytes
	5 minute offered rate 0 bps, drop rate 0 bps
	Match: any
	Output queue: 0/64; 3/88 packets/bytes output, 0/0 drops
 
   

Example 4-21 shows another example of the information that appears when you enter the show policy-map interface command. The sample output in Example 4-21 is based on a broadband configuration with the following class map and policy map configurations:

class-map match-any VoIP
	match ip dscp ef
	match ip precedence 5
class-map match-any VoD
	match ip precedence 3
 
   
policy-map QOS-Policy1
	class VoIP
		police 64000 8000 0 conform-action transmit exceed-action drop violate-action drop
		priority
	class VoD
		bandwidth 1500

Example 4-21 Displaying Packet Statistics for a Specific Interface

Router# show policy-map interface atm 7/0/0.2
ATM7/0/0.2: VC 2/101 - 
 
   
Service-policy output: QOS-Policy1 
 
   
	Class-map: VoIP (match-any)
		0 packets, 0 bytes 
		5 minute offered rate 0 bps, drop rate 0 bps 
		Match: ip dscp ef 
			0 packets, 0 bytes 
			5 minute rate 0 bps
		Match: ip precedence 5 
			0 packets, 0 bytes 
			5 minute rate 0 bps 
		Output queue: 0/128; 0/0 packets/bytes output, 0/0 drops 
		Police: 
			64000 bps, 8000 limit, 0 extended limit 
			conformed 0 packets, 0 bytes; action: transmit 
			exceeded 0 packets, 0 bytes; action: drop 
			violated 0 packets, 0 bytes; action: drop 
		Absolute priority 
	Class-map: VoD (match-any) 
		0 packets, 0 bytes 
		5 minute offered rate 0 bps, drop rate 0 bps 
		Match: ip precedence 3 
			0 packets, 0 bytes 
			5 minute rate 0 bps 
		Output queue: 0/64; 0/0 packets/bytes output, 0/0 drops 
		Bandwidth : 1500 kbps (Weight 73) 
	Class-map: class-default (match-any) 
		0 packets, 0 bytes 
		5 minute offered rate 0 bps, drop rate 0 bps 
		Match: any 
		Output queue: 0/32; 0/0 packets/bytes output, 0/0 drops

Related Documentation

This section provides hyperlinks to additional Cisco documentation for the features described in this chapter. To display the documentation, click the document title or a section of the document highlighted in blue. When appropriate, paths to applicable sections are listed below the documentation title.

Feature
Related Documentation

BBA Groups

Cisco 10000 Series Broadband Aggregation and Lease-Line Configuration Guide

Configuring PPPoE over Ethernet and IEEE 802.1Q VLAN

Frame Relay legacy commands

Cisco 10000 Series Router Quality of Service Configuration Guide

Configuring Frame Relay QoS Using Frame Relay Legacy Commands

Subinterface Policy Maps

Cross-Platform Release Notes for Cisco IOS Release 12.0S

Part 2: New Features and Important Notes > New and Changed Information > New Software Features in Cisco IOS Release 12.0(22)S > Subinterface Policy Maps

Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Part 8: Modular Quality of Service Command-Line Interface > Configuring the Modular Quality of Service Command-Line Interface > Modular QoS CLI Configuration Task List > Attaching a Traffic Policy to an Interface

Virtual Access Interfaces

Cisco 10000 Series Broadband Aggregation and Lease-Line Configuration Guide

Configuring Remote Access to MPLS VPN

Virtual Template Interfaces

Cisco 10000 Series Broadband Aggregation and Lease-Line Configuration Guide

Configuring Remote Access to MPLS VPN

Cisco IOS Dial Technologies Configuration Guide, Release 12.2

Configuring Virtual Template Interfaces