Cisco Transport Planner - DWDM Operations Guide, Release 9.2
Appendix A, GUI Information and Shortcuts
Downloads: This chapterpdf (PDF - 904.0KB) The complete bookPDF (PDF - 9.96MB) | Feedback

GUI Information and Shortcuts

Table Of Contents

GUI Information and Shortcuts

A.1  Manage the Cisco Transport Planner Window

A.1.1  Menu and Toolbar Options

A.1.2  Cisco Transport Planner Panes

A.1.3  Shortcuts

A.2  Site Icons

A.3  Demand Editor Icons


GUI Information and Shortcuts


This appendix describes the Cisco Transport Planner views, menus, tools, and shortcuts options. For more information about Cisco Transport Planner, refer to Chapter 1, "Introduction."

A.1  Manage the Cisco Transport Planner Window

The Cisco Transport Planner window provides a menu bar, toolbar, a Project Explorer pane, a Properties pane, an Analyzer pane, and a Task Pane to allow you to manage a network design (Figure A-1). The Mgmt Tree tab displays the networks that you have created for a project. The NtVw Net# tab displays the sites for a network (identified by the Net# on the tab).

Figure A-1 Cisco Transport Planner Window with Network Tree

A.1.1  Menu and Toolbar Options

The Cisco Transport Planner window menu bar and toolbar provide primary Cisco Transport Planner functions. Table A-1 shows the actions that are available from the menu and toolbar.

Table A-1 Menu and Toolbar Options 

Menu
Menu Option
Toolbar
Description

File

New

Creates a new Cisco Transport Planner project. See the "2.1  Creating a Project" section on page 2-1.

Open

Opens an existing Cisco Transport Planner project. See the "1.4.1  Opening a Project" section on page 1-16.

Close

Closes the current project without closing the Cisco Transport Planner session. If you have not saved the current project, Cisco Transport Planner will prompt you to save before closing. See the "1.4.4  Closing a Project" section on page 1-18.

Save

Saves the current project. See the "1.4.4  Closing a Project" section on page 1-18.

Save As

Allows you to save the current project with a new file name. See the "1.4.3  Saving a Project" section on page 1-18.

Clear History

Clears the file history from Cisco Transport Planner. Cisco Transport Planner maintains a list of the last ten open projects in the File menu.

Exit

Exits the Cisco Transport Planner software.

View

My Default Layout

Changes the Cisco Transport Planner display to the user default layout. Cisco Transport Planner allows you to define the default value for Platform Options, Project Options, and General Options. The defined value are used as default for each new created project. See the "1.5  Setting Cisco Transport Planner Options" section on page 1-18.

Default Layout

Returns the Cisco Transport Planner display to the system default layout.

Tasks Pane

Displays the commands available for the selected entity (network, site, duct, etc.).

Project Explorer

Displays the Project Explorer pane, which includes folders for project notes, networks, sites, fibers, traffic demand groups, subnets, maintenance centers, restricted equipment list, and reports. Clicking the plus (+) sign by each folder expands the folder. Clicking the minus (-) sign by each folder hides the folder. contents. You can also right-click a folder and choose Expand from the shortcut menu to show folder contents. The default location of the Project Explorer pane is the upper left section of the Cisco Transport Planner window.

Properties

Displays the Properties pane, which shows parameter settings for the selected entity in the Project Explorer, Mgmt Tree tab, or NtVw Net# tab. The default location of the Properties pane is the lower left section of the Cisco Transport Planner window.

Analyzer Messages

Displays the Analyzer Messages pane at the bottom of the Cisco Transport Planner window. The Analyzer Messages pane displays any error messages that occur during network analysis.

Tools

Options

Opens the Options Explorer dialog box, where you can change the user default settings. See the "1.5  Setting Cisco Transport Planner Options" section on page 1-18.

DB Parts Mgmt

Opens the PartsTreePanel dialog box, where you can view the list of available parts for each release. See the "1.5.4  Setting the Default Project Values" section on page 1-28.

Price List Mgmt

Opens the Price Manager dialog box, where you can view maintenance contracts and add price databases. See the "2.12  Managing the Price List" section on page 2-72.

Export

Opens the Export dialog box, which allows you to export user options, price lists, maintenance contracts, and parts database files. See the "1.5.6  Exporting User Options, Price Lists or Alien Definitions" section on page 1-35.

Import

Opens the Import dialog box, which allows you to import user options, price lists, maintenance contracts, and parts database files. See the "1.5.7  Importing User Options, Price Lists or Alien Definitions" section on page 1-36.

Help

Manual

Opens the Cisco Transport Planner online help.

Tips Of The Day

Opens the Tip of the Day dialog box, which provides helpful hints about using Cisco Transport Planner. Click the Next button to view the next tip and the Back button to view a previous tip. Check Show Tips on Startup to display the Tip of the Day dialog box when you launch Cisco Transport Planner.

About

Displays Cisco Transport Planner version information.

Network Toolbar

Create a new site

Opens the Site Creation wizard when you click this icon and then click in the Cisco Transport Planner window. See the "2.2  Adding Sites" section on page 2-13.

Create a new duct

Allows you to create a new duct between sites. See the "2.3  Adding Fiber Spans" section on page 2-15.

Create a new P2P demand

Opens the Point to Point Demand Creation Wizard when you click this icon and then click two sites. See the "2.7.5  Creating a Point-to-Point Demand" section on page 2-23.

Create a new P-ring demand

Opens the P-Ring Creation Wizard. See the "2.7.6  Creating a Protected Ring Demand" section on page 2-27.

Create a new TDM Aggregated demand

Opens a TDM creation wizard. See the 2.7.9  Creating TDM Aggregated Demands, page 2-43

Create a new Ethernet Aggregated demand

Opens a Ethernet creation wizard. See the 2.7.8  Creating Ethernet Aggregated Demands, page 2-34

Zoom in

Zooms in on the NtVw Net# tab.

Zoom out

Zoom out from the NtVw Net# tab.

Normal viewing

Returns the NtVw Net# tab to normal viewing (1:1).

Fit to window

Resizes the view so that all sites fit inside the NtVw Net# tab window.

Save network view image

 

Saves a JPEG of the network design. See the "2.10.5  Creating a JPEG of the Network Design" section on page 2-66.

Analyze Network

Analyzes the selected network. See the "2.9  Analyzing the Network" section on page 2-58.

Enter design mode

 

Puts the selected Design-Analyzed network back into the design mode for further changes. See the "2.9  Analyzing the Network" section on page 2-58.

Put current network in upgrade mode

 

Creates a copy of the selected Design-Analyzed network in the Upgrade state. See the "2.10.3  Creating an Upgrade Network" section on page 2-61.

Delete current network

 

Deletes the selected network. See the "4.23  Deleting a Network" section on page 4-120.

Copy current network

Copies the selected network. See the "2.10.1  Creating a Copy of the Network" section on page 2-60.

Put current network in install mode

 

Creates a copy of the selected Design-Analyzed network in the Install state. See the "2.10.2  Creating a Network in the Install State" section on page 2-60.

Reports Diff

Opens the Reports Diff dialog box, which allows you to create a report that shows the differences between networks.

Run the Garbage Collector

Deletes unloaded networks from memory.


A.1.2  Cisco Transport Planner Panes

Cisco Transport Planner provides four panes that help you manage a network design: Project Explorer, Properties, Analysis, and Tasks Pane.

A.1.2.1  Project Explorer Pane

The Project Explorer pane provides a management tree for the entire project. Each network appears as a folder that contains the sites, fibers, traffic groups, subnets, maintenance centers, restricted equipment lists, and reports for that network. If you have made changes to a network design, that network folder and the changed item folder appear in blue italics in the pane.

By default, the Project Explorer pane is located in the upper-left section of the Cisco Transport Planner window. Table A-2 shows the actions that are available from the Project Explorer toolbar.

Table A-2 Project Explorer Toolbar Options 

Toolbar
Description

Displays the Project Explorer as a single pane.

Displays the Project Explorer as split panes. The upper pane contains the main project tree; the lower pane shows only the folders for the network that is selected in the upper pane.

Auto scrolls to the selected object in the Project Explorer tree. For example, if you click on a site in the NtView Net# tab but it is not in view in the Project Explorer tree, Cisco Transport Planner will automatically scroll the Project Explorer pane until the selected site is in view.

 

Moves backward through the list of previously selected items in the Project Explorer.

 

Moves forward through the list of previously selected items in the Project Explorer.

Moves (undocks) the Project Explorer pane from the default location in the upper left corner so that you can move it around your desktop area as an individual window.

Moves the Project Explorer back to the default location.

Hides the Project Explorer. To view again, move the mouse over the Prop tab that appears in the upper left corner of the Cisco Transport Planner window.

When in hidden mode, reopens the Project Explorer in the default location.

Closes the Project Explorer pane. To reopen, choose Project Explorer from the View menu.


A.1.2.2  Properties Pane

The Properties pane shows all of the parameters set for a selected item (either in the Project Explorer, the Network Mgmt Tree tab, or the NtVw Net# tab). Many items are editable in the Properties pane. By default, the Properties pane is located in the lower-left section of the Cisco Transport Planner window.

Table A-3 shows the actions that are available from the Properties Pane toolbar.

Table A-3 Properties Pane Toolbar Options 

Toolbar
Description

Categorizes the properties by type.

Organizes the properties in alphabetical order.

Shows or hides the description area at the bottom of the Properties pane.

Expands the property categories (if collapsed).

Collapses the property categories (if expanded).

Moves (undocks) the Properties pane from the default location in the lower left corner so that you can move it around your desktop area as an individual window.

Moves the Properties pane back to the default location.

Hides the Property pane. To view again, move the mouse over the Prop tab that appears in the upper left corner of the Cisco Transport Planner window.

When in hidden mode, reopens the Properties pane so that it appears in the default location.

Closes the Properties Pane. To reopen, choose Properties from the View menu.


A.1.2.3  Analyzer Pane

The Analyzer tab at the bottom of the Cisco Transport Planner window appears after you have analyzed a network design. Clicking the Analyzer tab opens the Analyzer pane. Table A-5 shows the actions that are available from the Analyzer pane.

Table A-4 Analyzer Toolbar Options 

Toolbar
Description

Moves down through the Analyzer messages.

Moves up through the Analyzer messages.

Opens the Apply Filters dialog box, which allows you to filter the messages to show or hide Exceptions, Errors, Warnings, and/or Info.

Expands the Analyzer message categories (if collapsed).

Collapses the Analyzer message categories (if expanded).

Moves (undocks) the Analyzer pane from the default location in the lower left corner so that you can move it around your desktop area as an individual window.

Moves the Analyzer pane back to the default location.

Hides the Analyzer pane. To view again, move the mouse over the Analyzer tab that appears in the bottom of the Cisco Transport Planner window.

Opens the Analyzer pane so that it remains open in the bottom section of the Cisco Transport Planner window.

Closes the Analyzer pane. To reopen, choose Analyzer messages from the View menu.


A.1.2.4  Tasks Pane

The Tasks Pane lists the available commands and reports for a selected item. The commands change based on the selected item. For example, a selected site will have different commands available than a selected fiber span. By default, the Tasks Pane is located in the upper right section of the Cisco Transport Planner window. Table A-5 shows the actions that are available from the Tasks Pane toolbar.

Table A-5 Tasks Pane Toolbar Options 

Toolbar
Description

Moves (undocks) the Tasks Pane from the default location in the lower left corner so that you can move it around your desktop area as an individual window.

Moves the Tasks Pane back to the default location.

Hides the Tasks Pane. To view again, move the mouse over the Tasks tab that appears in the upper right corner of the Cisco Transport Planner window.

When in hidden mode, reopens the Tasks Pane so that it appears in the default location.

Closes the Tasks Pane. To reopen, choose Tasks Pane from the View menu.


A.1.3  Shortcuts

Cisco Transport Planner provides the following mouse shortcuts:

Double-clicking a network icon in the Network Mgmt Tree tab opens the NtVw Net# tab, which shows the sites for that network.

Right-clicking a report table column displays a shortcut menu that allows you to view or hide the columns in a report.

Right-clicking an item in the Network Mgmt Tree tab or NtVw Net# tabs opens a shortcut menu that allows you to choose actions to perform on the selected item. The shortcut menu options differ based on the item selected and the network state. (Many commands are not available until a network is analyzed.) Table A-6 lists the shortcut menu actions that are available for each item.

Table A-6 Shortcut Menu Actions 

Item
Available Shortcut Actions

Networks in the following states: Design, Install, and Upgrade

Unload/Load—Unloads or loads the network. See the "1.4.2  Loading and Unloading Networks" section on page 1-17.

Edit Note—Allows you to create a note for the network. See the "2.5  Adding Notes to a Project" section on page 2-18.

Delete—Removes the network from the project. See the "4.23  Deleting a Network" section on page 4-120.

Copy—Creates a copy of the network. See the "2.10.1  Creating a Copy of the Network" section on page 2-60.

Arrange Sites—Allows you to rearrange sites in the Cisco Transport Planner window. See the "4.16  Arranging Sites" section on page 4-105.

Forcing Manager—Unlocks individual units in multiple sites/ducts. See "2.10.4.1  Forcing Manager" section on page 2-63.

Analyzed networks

Unload/Load—Unloads or loads the network. See the "1.4.2  Loading and Unloading Networks" section on page 1-17.

Edit Note—Allows you to create a note for that item. See the "2.5  Adding Notes to a Project" section on page 2-18.

Install—Creates a copy of the network in the Install state. See the "2.10.2  Creating a Network in the Install State" section on page 2-60.

Open Site Functional View—Opens the site functional view. See the 2.9.1  Viewing the Site Functional View, page 2-58.

Delete—Removes the network from the project. See the "4.23  Deleting a Network" section on page 4-120.

Upgrade—Creates a copy of the network in the Upgrade state. See the "2.10.3  Creating an Upgrade Network" section on page 2-61.

Copy—Creates a copy of the network. See the "2.10.1  Creating a Copy of the Network" section on page 2-60.

Layout—Opens the Layout tab. See the "3.2.6  Viewing the Layout of Single Site" section on page 3-14.

Internal Connections—Opens the Internal Connections tab. See the "3.2.4  Viewing Internal Connections" section on page 3-7.

Optical Results—Opens the Optical Results tab. See the "3.2.10  Viewing Optical Results" section on page 3-22.

Wavelength Routing—Opens the Wavelength Routing tab. See the "3.2.11  Viewing Wavelength Routing" section on page 3-27.

Bill of Material—Opens the Bill of Materials tab. See the "2.11.2  Generating a Network BoM" section on page 2-68.

Installation—Opens a submenu with the following options:

NE Update—Creates a configuration file for each site in the network See the "3.2.2  Saving the NE Update File" section on page 3-3.

Installation Parameters—Opens the Installation Parameters tab. See the "3.2.3  Viewing the Installation Parameters" section on page 3-4.

Arrange Sites—Allows you to rearrange sites in the Cisco Transport Planner window. See the "4.16  Arranging Sites" section on page 4-105.

Sites

Edit—Allows you to edit the demand. See the "4.6  Editing a Point-to-Point Demand" section on page 4-53, "4.7  Editing a P-Ring Demand" section on page 4-55, or "4.8  Editing a ROADM Demand" section on page 4-58.

Edit Note—Allows you to create a note for that item. See the "2.5  Adding Notes to a Project" section on page 2-18.

Unlock—Unlocks the site. See the "2.10.4  Unlocking Parameters in the Network Design" section on page 2-62.

Delete—Removes the site from the project. See the "4.19  Deleting Sites" section on page 4-119.

If the network is analyzed, the following actions are also available:

Layout—Opens the Layout tab. See the "3.2.6  Viewing the Layout of Single Site" section on page 3-14.

Internal Connections—Opens the Internal Connections tab. See the "3.2.4  Viewing Internal Connections" section on page 3-7.

Optical Results—Opens the Optical Results tab. See the "3.2.10  Viewing Optical Results" section on page 3-22.

Wavelength Routing—Opens the Wavelength Routing tab. See the "3.2.11  Viewing Wavelength Routing" section on page 3-27.

Bill of Material—Opens the Bill of Materials tab. See the "2.11.2  Generating a Network BoM" section on page 2-68.

Installation—Opens a submenu with the following options:

NE Update—Creates a configuration file for each site in the network. See the "3.2.2  Saving the NE Update File" section on page 3-3.

Installation Parameters—Opens the Installation Parameters tab. See the "3.2.3  Viewing the Installation Parameters" section on page 3-4.

Open Site Functional View—Opens the site functional view. See the 2.9.1  Viewing the Site Functional View, page 2-58.

Unlock—Unlocks the site. See the "2.10.4  Unlocking Parameters in the Network Design" section on page 2-62.

Forcing Manager—Unlocks individual units in multiple sites/ducts. See "2.10.4.1  Forcing Manager" section on page 2-63.

Fiber spans

Edit Note—Allows you to create a note for that item. See the "2.5  Adding Notes to a Project" section on page 2-18.

If the network is analyzed, the Unlock command is also available. See the "2.10.4  Unlocking Parameters in the Network Design" section on page 2-62.

Traffic demands

Edit Note—Allows you to create a note for that item. See the "2.5  Adding Notes to a Project" section on page 2-18.

Edit—Allows you to edit the demand. See the "4.6  Editing a Point-to-Point Demand" section on page 4-53, "4.7  Editing a P-Ring Demand" section on page 4-55, or "4.8  Editing a ROADM Demand" section on page 4-58.

Delete—Removes the demand from the project. See the "4.20  Deleting a Traffic Demand" section on page 4-119.

If the network is analyzed, the Unlock command is also available. See the "2.10.4  Unlocking Parameters in the Network Design" section on page 2-62.


A.2  Site Icons

A site icon indicates the functionality of site. Table A-7 lists the site icons.

Table A-7 Site Icons

Site Name
Site Icon
Description

Add/Drop

Indicates that this site has add/drop capability. Only point-to-point and P-ring circuits can be added/dropped at this site.

Gain equalizer

Indicates that this site uses wavelength selective switch cards to control the generated tilt and extend unregenerated distances. The site is realized as an ROADM site without demultiplexer cards.

Hub

Indicates that this site is equipped with filters for adding and dropping all the channels (on both West and East sides). All express paths are open in hub configurations.

Line amplifier

Indicates that any add/drop traffic is prevented at this site.

OSC site

Indicates that site is designated for network communication, providing the possibility to access the optical service channel (OSC) for management of the MultiService Transport platform (MSTP) network. By default, no amplifiers are included in this site. However, if Cisco Transport Planner determines that an amplifier is required in the network, it can automatically place it at this location. Cisco Transport Planner allows you to set (force) preamplifier and booster amplifiers for each direction on a OSC Site node.

Pass Through

Indicates that no equipment will be located at this site.

R-OADM

Indicates that this site supports Any-to-Any and also Fixed (point-to-point and P-ring) traffic types.

PSM

Indicates a PSM site with Aw representing the working path and Ap representing the protected path.

Terminal

Indicates a terminal site.

OXC

Indicates a multi degree OXC site.

OIC

Indicates a multi degree OIC site


A.3  Demand Editor Icons

Table A-8 Demand Editor Icons

Icons
Description

Expands the services of a demand (if collapsed).

Collapses the services of a demand (if expanded).

Creates a new service.

Deletes an existing service.

Selects siblings at the same level.

Selects all siblings of the same type.

Opens the path constraints editor.

Opens the regeneration editor.