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Designing Networks with MetroPlanner

Cisco MetroPlanner provides you numerous tools for customizing the software, creating and analyzing 
networks, and creating a bill of materials. You can use to MetroPlanner perform the following tasks:

• 2.1 Launching MetroPlanner and Updating the Pricing File, page 2-1

• 2.2 Setting MetroPlanner Options, page 2-4

• 2.3 Creating Networks, page 2-14

• 2.4 Analyzing the Network, page 2-32

• 2.5 Editing and Viewing Network Components, page 2-40

• 2.6 Saving and Loading Network Designs, page 2-59

• 2.7 Completing the Network Design, page 2-60

• 2.8 Ordering the Equipment, page 2-66

• 2.9 Generating a BOM, page 2-67

Note To run MetroPlanner, you must install the Java 2 Platform, Standard Edition (J2SE), v 1.4.2_04 Java 
Runtime Environment (JRE). You can download it from the following URL:

http://www.oracle.com/technetwork/java/javase/downloads/index.html

2.1 Launching MetroPlanner and Updating the Pricing File
When MetroPlanner Release 2.5.1 is first launched, you will have the option of downloading an updated 
pricing file from CCO.

Step 1 Launch MetroPlanner by double-clicking the MetroPlanner R2.5.1 icon. The Price Update Option 
window appears (Figure 2-1). 
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2.1 Launching MetroPlanner and Updating the Pricing File
Figure 2-1 Price Update Option

Step 2 To obtain a new price list from CCO, click CCO Update. You will be asked for your CCO login and 
password before the new price list is downloaded.

To use a pricing file that is already located on your workstation, click Local File Update. You will then 
be able to browse your workstation for the pricing file. The file format of the pricing file are separated 
by pipes. Each part has the following fields:

• List ID (Not used by MetroPlanner)

• Product Family or Major Parent

• Minor Parent (Not used by MetroPlanner)

• Product Number or Product ID

• Product Description

• Service Category

• Unit Price ($USD)

• Major ID (Not used by MetroPlanner)

• Minor ID (Not used by MetroPlanner

Step 3 To open MetroPlanner without updating, click Continue. The MetroPlanner Activation window opens 
(Figure 2-2).
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2.1 Launching MetroPlanner and Updating the Pricing File
Figure 2-2 MetroPlanner Activation Window

Step 4 Enter your user name in the Login field.

Step 5 Enter your password in the Password field. 

Step 6 Click Remember login and password if you want MetroPlanner to save your user login name and 
password. 

Step 7 Click OK. The Tip of the Day window opens (Figure 2-3).

Figure 2-3 Tip of the Day Window
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2.2 Setting MetroPlanner Options
The Tip of the Day window displays important tips about MetroPlanner features.

Step 8 Click Previous Tip or Next Tip to see either the previous or next tip in the tip sequence.

Step 9 Click Close Tip to close the window.

Step 10 If you want the Tip of the Day window to display each time you open MetroPlanner, select Show “Tip 
of the Day” At Startup. Deselecting this option causes the window to remain closed when you open 
MetroPlanner. 

You can open the Tip of the Day window at any time from MetroPlanner by selecting Help > Tip of the 
day in the menu bar.

2.2 Setting MetroPlanner Options
MetroPlanner provides numerous options for customizing the tool and the designs. You can set the 
options for individual projects, you can create defaults for all projects, and you can set general options 
for the MetroPlanner tool.

2.2.1 Setting Project Options
Setting the options for individual projects allows you to adjust the layout, BOM options, and other 
project-related options. You can only set project options when the network is in Design mode. 

Step 1 Choose Options > Project Options. The Project Options window appears.

Step 2 Click Analyzer Algorithm. The Analyzer Algorithm section comes into focus (Figure 2-4).

Figure 2-4 Project Options Window—Analyzer Algorithm
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2.2.1 Setting Project Options
Step 3 Select the analyzer algorithm type. 

MetroPlanner distinguishes between two classes of applications: Metro Core, where the channel power 
is equalized and dispersion compensation is applied; and Metro Access, where the channels are not 
equalized and dispersion compensation is not applied. MetroPlanner offers 8, 16, and 32 channel Metro 
Core algorithm types.

Note Placing an upper limit on the maximum number of allowed wavelengths in the design allows 
MetroPlanner to provide better optical performances. 

Note Use Metro Access for small networks. Small networks have a low number of sites (approximately three 
to five nodes) and short spans.

The Metro Access algorithm applicability is restricted by:

• The maximum number of required amplifiers for each path direction and for each subnetwork 
(maximum 5)

• Lack of Dispersion Compensation Unit (DCU) compensation requirement

• The overall network circumference (45 km [28.0 miles] if there is at least one 10-Gbps service 
circuit, and 120 km [74.5 miles] if there are only 2.5-Gbps service circuits)

Step 4 Select No In-line Bulk Attenuator Design to design the network without using any in-line bulk 
attenuators. If the network cannot be designed without using external in-line attenuators, MetroPlanner 
displays the following error message: "Unfeasible Network design. Site X should require usage of in-line 
attenuator".

Step 5 Select No TXT/Line-Card Bulk Attenuator Design to design the network without using any external Rx 
bulk attenuators on transponder or line cards. If any of the clients require Rx bulk attenuators, the related 
channel is shown with anomalous working condition (red, orange or yellow), and no Rx bulk attenuators 
are shown in any of the reports or BOMs.

Step 6 Select Design Only Using ROADM... to design the network only using ROADM and OADM 4 channel 
units to add and drop channels in a site, and to avoid creation of an optical bypass where not explicitly 
requested by the user. In this case the network solution could be more expensive. If you leave it 
unchecked, all the currently available add/drop units are used to solve the network to minimize the 
overall network cost.

Step 7 Select Prevent Use of E-LEAF Dispersion Compensation Unit on E-LEAF Spans to prevent 
MetroPlanner from using an E-LEAF Dispersion Compensation Unit (DCU) on E-LEAF spans for the 
overall network. If you leave it unchecked, the MetroPlanner automatically optimizes the usage of 
E-LEAF DCU.

Step 8 Click BOM Options. The BOM Options section comes into focus (Figure 2-5).
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2.2.1 Setting Project Options
Figure 2-5 Project Options—BOM Options

Step 9 Select the following options, as required:

• Include SW License(s)—BOM includes one software license for each shelf for every site in the 
network. Only shelves containing cards that are carrying present traffic are included.

• Include Paper Documentation—BOM includes one hardcopy documentation item for each site in the 
network. Pass-through sites are not included.

• Include CD Documentation—BOM includes one documentation CD item for each site in the 
network. Pass-through sites are not included.

• Include Optical patch-cord to/from TXT/Line Card—The BOM includes both:

– All patch cords connecting the transponder and the line card with the optical add/drop 
multiplexing (OADM) and multiplexing/demultiplexing filters

– All patch cords connecting the transponder with the Y-cable flex-layer modules

Only the patch cord connecting the transponder and line card for present traffic are included on the 
BOM. The patch cord for connecting TXT cards and line card can be of different types and lengths.

• Network Bulk Attenuator (for TXT/Line Card)—The BOM includes all the receive bulk attenuators 
(based on the results in the Optical Channel Results tab) and the in-line bulk attenuator. Only the 
receive bulk attenuators that refer to the present traffic are included in BOM. 

Bulk attenuators are also used in the following cases:

– In-line attenuation for sites without any added or dropped channels in one side, where 
attenuation is required to equalize the channels

– Line amplifier sites where both preamplifier and booster cards require 10 dB of attenuation 
between the preamplifier and the booster amplifier.

These bulk attenuators are always in the BOM, regardless of the TXT/Line Card Bulk Attenuator 
selection.

• Hide BoM Prices—Hides the dollar values of the items on the BOM.

Step 10 Enter the global discount percentage in the Global Discount field. MetroPlanner applies this percentage 
to all networks. 

Step 11 Click Layout. The Layout section comes into focus (Figure 2-6).
2-6
Cisco MetroPlanner DWDM Operations Guide, Release 2.5.1

September 2005



 

Chapter 2      Designing Networks with MetroPlanner
2.2.1 Setting Project Options
Figure 2-6 Project Options—Layout

Step 12 Select either American National Standards Institute (ANSI) or European Telecommunications Standards 
Institute (ETSI) in the Network Platform Layout drop-down list. 

Step 13 Check TXT/Line Card placement OSMINE compliant to place the TXT/line card in the shelf, with 
the following constraints:

• Each unprotected transponder or line card facing west can only be placed on the left side of the shelf 
(Slots 1 to 6), and each unprotected transponder or line card facing east can only be placed on the 
right side of the shelf (Slots 12 to 17).

• Each pair of transponders or line cards that is involved in a Client 1+1 or Y-cable protection group 
must be placed in adjacent slots.

• Each transponder involved in fiber-switched protection can be placed on the left or right side of the 
shelf in order to fill the empty slots.

Leave TXT/Line Card placement OSMINE compliant unchecked to place the TXT/line card in the 
shelf with the following constraints:

• The transponder and line card facing west-side traffic must be placed in the left shelf section 
(Slots 1 to 6), and the transponder and line card facing the east side traffic must be placed in the right 
shelf section (Slots 12 to 17).

• If the number of west and east added and dropped channels changes, the remaining client 
transponder/line cards are placed to fill the remaining available slots.

• When using Y-cable protection, the two transponders must be placed in the same shelf.

• When using Client 1+1 protection, MetroPlanner places the two client cards in the same shelf.

Step 14 Check Ethernet Switch to place an Ethernet switch on each site where it is required. You can override 
this network-level option site by site. Selecting this option only applies it to newly created sites, and not 
to previously existing sites. This optionis unavailable when the design is in the Analyzed status.

Step 15 Click General Options. The General Options section comes into focus (Figure 2-7).
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2.2.2 Setting Default Project Options
Figure 2-7 Project Options—General Options

Step 16 In the Site MTTR field, enter the mean time to repair (MTTR) for each site in the network. If you change 
the MTTR value after creating sites, the new value will only apply to sites you create after the change.

Step 17 Select whether the OSNR values in the Result tables are reported using 0.1-nm resolution bandwidth 
(RBW) or 0.5-nm RBW in the Resolution Bandwidth RBW field. The default value is 0.5 nm. 

Step 18 Choose either kilometers (km) or miles as the default span length unit of measure in the Show spans 
length in field.

Step 19 Click OK when finished.

2.2.2 Setting Default Project Options
Setting the default options for all new projects allows you to adjust the layout, BOM settings, and other 
project-related options. These options will be the default settings for each new project.

Step 1 Select Options > Default Project Options. The Default Project Options window appears. The Default 
Project Options window is nearly identical to the Project Options window, with the addition of the 
Span Parameters option in the left panel.

Step 2 Complete the steps in the “2.2.1 Setting Project Options” section on page 2-4.

Step 3 Click Span Parameters. The Span Parameters area comes into focus (Figure 2-8).
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2.2.3 Setting General Options
Figure 2-8 Default Project Options—Span Parameters

The Span Parameters area displays the same information as the Fibres Dialog window (Figure 2-20 on 
page 2-24). 

Step 4 Complete Step 5 through Step 14 in the “2.3.2.2 Adding Fiber Spans” section on page 2-23.

Step 5 Click OK. These settings are now the default settings for all new projects.

2.2.3 Setting General Options
Setting the general options allows you to change the way MetroPlanner displays information. 

Step 1 Choose Options > General Options from the menu. The General Options window appears. 

Step 2 Select Layers and Tags. The Layers and Tags section comes into focus (Figure 2-9).
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2.2.3 Setting General Options
Figure 2-9 General Options—Layers and Tags

Step 3 In the Fibers area, select one or more check box depending on whether or not you want MetroPlanner to 
display the fibers, the span loss, and the span. 

Step 4 In the Sites area, select one or more check box depending on whether or not you want MetroPlanner to 
display the names, the amplifiers (amps), and the forced amps of the sites in the network design.

Step 5 In the Channels area, select one or more check box depending on whether or not you want MetroPlanner 
to display the Fixed/BLSR and ROADM channels in the network design.

Step 6 Click Colors and Styles. The Colors and Styles section comes into focus (Figure 2-10).
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2.2.3 Setting General Options
Figure 2-10 General Options—Colors and Styles

Step 7 Select the color for the items in the window by clicking the rectangles to the right of the text. The Pick 
a Color window appears (Figure 2-11).

Figure 2-11 Pick a Color Window
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2.2.4 Customizing the Design Background
Step 8 Use the Swatches, HSB, or RGB tab to select a new color for the item. 

Step 9 Click OK to keep the new color, or click Reset to restore the default color.

Step 10 To change the line style for fibers, selected fibers, channels, selected channels, and ROADM channels, 
select a new style from the drop-down list in the Style column. 

Step 11 To change the line width for fibers, selected fibers, channels, selected channels, and ROADM channels, 
select a new width from the drop-down list in the Size column.

Step 12 To discard all the changes, click Restore Defaults at the bottom of the graphic.

Step 13 Select Look and Feel. The Look and Feel section comes into focus (Figure 2-12). 

Figure 2-12 General Options—Look and Feel

Step 14 Select appearance for the MetroPlanner application. In order to see the new appearance, you must restart 
the application. The Windows (system) selection displays the application in your current Windows 
session. 

Step 15 Click OK to keep the changes and close the window.

2.2.4 Customizing the Design Background
You can customize your MetroPlanner window background with a graphic image to enhance the 
presentation of your network design.

Step 1 Choose Options > Background Map from the menu. The Choose Background Map window appears 
(Figure 2-13), allowing you to select a file in JPG or GIF format.
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2.2.4 Customizing the Design Background
Figure 2-13 Choose Background Map Window

Step 2 Select a map from the list on the left, or click Import to add a new map to the list.

Step 3 Click OK. The file will appear as a background for any new network, or for the network you currently 
have open (Figure 2-14).
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2.3 Creating Networks
Figure 2-14 Map File Background

Step 4 If the network map does not appear, choose Options > Show Map from the menu. 

2.3 Creating Networks
In MetroPlanner, network design components consist of sites, spans, and service demands. Components 
can be added to a network design by selecting the buttons shown in Table 2-1.

Table 2-1 Menu Buttons for Adding Network Design Components

Button Description

 Network Wizard

Add Site

Add Fibre

Add Channel/Service

Edit Mode
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2.3.1 Adding Networks Using the Network Wizard
2.3.1 Adding Networks Using the Network Wizard
Use the Network Wizard button to add a ring or linear dense wavelength division multiplexing (DWDM) 
network to the network design. The Network Wizard button allows you to add several sites to the network 
design in one step.

Note The Network Wizard feature adds a ring or linear DWDM network with a maximum of 16 active sites.

Step 1 Click Network Wizard on the menu bar. The Network Wizard window appears (Figure 2-15).

Figure 2-15 Network Wizard (Step 1) Window
:

Step 2 Enter a name for the designed network in the Design Version field (128 maximum characters).

Step 3 Enter a description of the designed network in the Design Description field (256 maximum characters).

Step 4 Enter the name of the customer requiring this network design in the Customer Name field (128 maximum 
characters).

Step 5 Enter the name of the person who designed the network in the Prepared By field (128 maximum 
characters).

Step 6 Click Next. The second panel of the Network Wizard appears (Figure 2-16).
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2.3.1 Adding Networks Using the Network Wizard
Figure 2-16 Network Wizard (Step 2) Window

Step 7 Enter the number of desired nodes in the network in the Number Of Nodes field. The maximum allowed 
value is 60. Table 2-2 displays the different node types and the maximum number of allowed nodes for 
each type.

Step 8 Select a topology from the Topology drop-down list. You can choose either a ring or a linear topology.

Step 9 Select a network platform layout from the Network Platform Layout drop-down list. You can choose 
either ANSI (the North American standard) or ETSI (the international standard). ANSI networks will 
not allow you to define SDH (ETSI) service demands. ETSI networks will not allow you to define 
SONET (ANSI) service demands. 

Table 2-2 Maximum Number of Nodes by Node Type

Node Type Maximum Number Allowed

Non-passthrough ONS 15454 Multi-Service Transport 
Platform (MSTP) 

16

Add/Drop 16

Nodes with OSC termination (equipping an OSC or 
OSC-CSM unit)

20

Amplifier (PRE plus BST) per network and per direction 40

PRE plus BST, per subnetwork1 and per direction

1. The subnetwork is identified within a linear or ring network by the presence of hub nodes or OADM nodes where 
the patchcord between the East and West section has been removed (Anti-ASE node). 

32
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2.3.1 Adding Networks Using the Network Wizard
Note After the layout is set for a network, you cannot change the individual sites.

Step 10 Select the unit of measure that MetroPlanner will use to specify the span length in each span in the 
Span Measurement Units drop-down list. The span units can be either kilometers (km) or miles.

Step 11 Click Next. The third panel of the Network Wizard appears (Figure 2-17).

Figure 2-17 Network Wizard (Step 3) Window

Step 12 Enter the substring text that defines the span labels in the Spans Label Tag field. MetroPlanner defines 
all subsequent spans by adding a sequential number to the label in the Spans Label Tag field (for 
example, Span 1). 

Step 13 Select a fiber type from the Span Fibre Type drop-down list. The MetroPlanner Analyzer performs a 
check to make sure that the network contains spans with fiber types that the design algorithm can manage 
on the same network. If this condition is not met, the analyzer stops analyzing the network and creates 
an error. The available fiber types are:

• G652-SMF–Supported for both Metro Core and Metro Access

• E-LEAF–Supported for Metro Core only

• TW-RS–Supported for Metro Core only

Step 14 Enter a span length in the Span Length field. The displayed unit of measure is retrieved from the 
Span Measurements Units field.
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2.3.1 Adding Networks Using the Network Wizard
Step 15 Enter the end of life (EOL) aging factor in the Ageing Factor field. This factor is multiplied by the start 
of life (SOL) total span loss without connectors.

Step 16 Enter the EOL aging loss in the Ageing Loss field. The EOL loss per span value is added at the end of 
life to each discrete fiber in the network (for example, to add an EOL margin for splicing).

Step 17 Enter the concentrated loss at the east end of the span in the Connector Loss East field.

Step 18 Enter the concentrated loss at the west end of the span in the Connector Loss West field.

Step 19 Choose either the Length Based Model or the Absolute Model radio button. 

Step 20 If you choose Length Based Model in Step 19, enter values in value fields for the following properties 
listed in the table at the bottom of the window:

• Loss Factor—The value of the SOL fiber loss per kilometer used to calculate the loss of each span 
in the network. The fiber loss factor is always entered in dB/km, even if you selected miles as the 
span measurement unit. MetroPlanner automatically converts the loss factor from miles to 
kilometers.

• Chromatic Dispersion factor—The fiber chromatic dispersion factor. The default value is dependent 
on the selected fiber type. Any value you enter is lost whenever you change the fiber type. Chromatic 
dispersion is always entered in ps/nm/km, even if you selected miles as the span measurement unit. 
MetroPlanner automatically converts the loss factor from miles to kilometers. Fiber chromatic 
dispersion is defined for the middle of the wavelength band. It is defined at approximately 1545.3 
nm.

• PMD factor—The polarization mode dispersion (PMD) factor. The default value is dependent on the 
selected fiber type. Any value you enter is lost whenever you change the fiber type. PMD is always 
entered in , even if you selected miles as the s pan measurement unit. MetroPlanner 
automatically converts the loss factor from miles to kilometers. 

• Total SOL Loss w/o Connectors—The start of life link fiber loss for each span, without the 
connector concentrated loss. The total SOL loss without connectors is equal to the loss factor 
multiplied by the length. In the Length Based model, this value is calculated automatically.

• Total SOL Loss—The start of life link fiber loss for each span with the connector concentrated loss 
contributions. The total SOL loss is equal to the total SOL loss without connectors added to the 
connector loss west and connector loss east. In the Length Based model, this value is calculated 
automatically.

• Total EOL Loss—The end of life link fiber loss for each span. In the Length Based model, this value 
is calculated automatically.

• Total Chromatic Dispersion—The overall link fiber chromatic dispersion for each span. In the 
Length Based model, this value is calculated automatically.

• Total PMD (DGD)—The differential group delay (DGD) is the difference in arrival times of the two 
polarization modes at a particular wavelength and time with a specific PMD coefficient. In the 
Length Based model, this value is calculated automatically.

Step 21 If you chose Absolute Model in Step 19, enter values in value fields for the following properties listed 
in the table at the bottom of the window:

• Total SOL Loss w/o Connectors—The start of life link fiber loss for each span, without the 
connector concentrated loss. The total SOL loss without connectors is equal to the loss factor 
multiplied by the length.

Step 22 Click Finish. MetroPlanner performs a check for fiber factor valid values. If the fiber factor values are 
within the valid range (refer to Table 2-3 on page 2-20), MetroPlanner creates a visual representation of 
the network (Figure 2-18 on page 2-19). If the values are out of range, MetroPlanner issues a warning, 
asking you to confirm the input values.
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2.3.1 Adding Networks Using the Network Wizard
Figure 2-18 Initial Network View
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2.3.2 Adding Networks Manually
2.3.2 Adding Networks Manually
You can manually add network design elements using the following network design functions: adding 
sites, adding spans, and adding services.

2.3.2.1 Adding Sites

Use the Site Dialog window to place an empty site in the network design. You can also use the 
Site Dialog window to build a network manually, bypassing the Network Wizard, or to add new sites to 
an existing design. A site is a customer premises location where any equipment can be collocated in a 
rack within a building.

Table 2-3 Valid Ranges for Fiber Coefficient Values

Fiber Type Parameter Min Error 
Value

Min 
Warning 
Value

Default 
Value

Max 
Warning 
Value

Max 
Error 
Value

G..652-SMF Loss factor 0

dB/km

0.2

dB/km

(*)

dB/km

0.4

dB/km

10
dB/km

Chromatic 
Dispersion factor 

@ 1545.3 nm

0

ps/nm/km

16.2

ps/nm/km

16.7

ps/nm/km

17.1

ps/nm/km

30
ps/nm/km

PMD factor 0 0.0 0.1 0.5 10

G.655-E-LEAF Loss factor 0

dB/km

0.2

dB/km

(*)

dB/km

0.4

dB/km

10
dB/km

Chromatic 
Dispersion factor 

@ 1545.3 nm

0

ps/nm/km

3.4

ps/nm/km

3.80

ps/nm/km

4.2

ps/nm/km

10
ps/nm/km

PMD factor 0 0 0.1 0.5 10

G.655-TW-RS Loss factor 0

dB/km

0.2

dB/km

(*)

dB/km

0.4

dB/km

10
dB/km

Chromatic 
Dispersion factor 

@ 1545.3 nm

0

ps/nm/km

3.8

ps/nm/km

4.19

ps/nm/km

4.6

ps/nm/km

10
ps/nm/km

PMD factor 0 0 0.1 0.5 10
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2.3.2 Adding Networks Manually
Note MetroPlanner supports up to 60 sites. However, the ONS 15454 DWDM platform will only support up 
to 16 non-passthrough sites on any given network. Although MetroPlanner will allow you to add more 
than 16 sites, it will generate errors when the network analysis runs.

Note MetroPlanner R2.5.1 only supports two fiber spans per site (east and west). 

Step 1 Click Add Site Mode on the menu bar. Alternatively, you can right-click in the main window and select 
Add New Default Site or Add New Site from the shortcut menu. The cursor then changes to a hand 
holding a blue circle.

Step 2 Double-click the MetroPlanner window at the point where you want to place the new site. The 
Site Dialog window appears (Figure 2-19).

Figure 2-19 Site Dialog Window

Step 3 Enter the name of the site in the Site Name field.

Step 4 Enter the site IP address (if desired) in the Site IP Address field.

Step 5 Enter the site MTTR hours in the Site MTTR field.
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2.3.2 Adding Networks Manually
Step 6 Select the maintenance center that will support this site in the Maint. Centre Name field. If there are no 
listed maintenance centers, create one using the steps in the “2.9.6 Establishing Maintenance Centers” 
section on page 2-73.

Step 7 Select an ANSI or ETSI shelf layout in the Shelf Layout field.

Step 8 Select a network element (NE) site type in the Configuration field. The choices are:

• Auto—The site type is determined based on the network analysis.

• Hub—The site is a hub site.

• Terminal—The site is a full (32 channel) terminal site.

• ROADM—The site is an ROADM site with a single- or double-slot 32 DMX demultiplexer.

• OADM Full—The site is a full OADM site.

• OADM Active—The site is an active (amplified) OADM site.

• OADM Passive—The site is a passive (non-amplified) OADM site.

• Pass-Through—The site is a pass-through site.

• Line Amplifier—The site is a line amplifier site.

• Central Office—The site is a central office site.

• Glass Through—a node with no associated equipment.

If MetroPlanner determines that an amplifier is required in the network, it automatically places it on a 
Glass Through node.

Note Glass Through configuration is not fully managed in Metro-Access. In Metro-Access, the 
analyzer always automatically maps the Glass Through on a Line Amplifier configuration.

MetroPlanner forces pre- and boosteramplifiers for each direction on a Glass Through node.

Hub, terminal, and ROADM sites support the equipment listed in Table 2-4. OADM Full Configuration 
sites are always implemented using 32 MUX-O and 32 DMX-O cards.

Table 2-4 Site Equipment

Site Configuration Supported Equipment

Hub Auto (default)

32MUX-O/32DMX-O

32 WSS/32 DMX

32 WSS/32 DMX-O

Terminal Auto (default)

32MUX-O/32DMX-O

32 WSS/32 DMX

32 WSS/32 DMX-O

ROADM Auto (default)

32 WSS/32 DMX 

32 WSS/32 DMX-O
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Step 9 Select the set of cards required for the selected configuration from the list in the Equipment field. 
Available choices are Auto, 32 Channel Mux/Demux, 32WSS/32DMX, and 32WSS/32DMX-O.

Step 10 If this site is part of a hybrid node configuration, check the Hybrid Node Config check box. Hybrid node 
configuration is only available if you select Auto, OADM Active, OADM Passive, Line Amplifier, or 
Terminal.

Step 11 In the Preamplifier West Side field, select whether to place a preamplifier on the west side of the node. 
If you select Auto, MetroPlanner decides whether to place the item automatically. This option is not 
available if you selected OADM Passive as the site type.

Step 12 In the Booster West Side field, select whether to place a booster amplifier on the west side of the node. 
If you select Auto, MetroPlanner decides whether to place the item automatically. This option is not 
available if you selected OADM Passive as the site type.

Step 13 In the Preamplifier East Side field, select whether to place a preamplifier on the east side of the node. If 
you select Auto, MetroPlanner decides whether to place the item automatically. This option is not 
available if you selected OADM Passive as the site type.

Step 14 In the Booster East Side field, select whether to place a booster amplifier on the east side of the node. If 
you select Auto, MetroPlanner decides whether to place the item automatically. This option is not 
available if you selected OADM Passive as the site type.

Step 15 Click OK to place the site, or Cancel to quit. The site appears as a blue icon, with the site name appearing 
below it. 

Step 16 To edit the site, click Edit Mode on the menu bar, then double-click the site you want to edit. The 
Site Dialog window (Figure 2-19) appears, allowing you to make changes to the site.

2.3.2.2 Adding Fiber Spans

After adding the sites, use the Add Fibre Mode feature to draw the fiber spans between sites. A fiber span 
consists of a pair of fibers (one transmit and one receive) between two sites. 

Step 1 Click Add Fibre Mode on the menu bar. The cursor changes to a pencil with a series of numbers beside 
it.

Step 2 Click one of the sites you want to connect with a fiber span. This site will be the source site for later 
network analysis output.

Step 3 Move the cursor to the other site. When you move the cursor, a line appears between the two sites. This 
site will be the destination site for later network analysis output. 

Step 4 Click the destination site. The Fibres Dialog window appears (Figure 2-20).
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Figure 2-20 Fibres Dialog Window

Step 5 Enter the name of the span displayed on the network design in the Span Label field. MetroPlanner 
automatically generates a default span name, starting with “Span 1”, and numbering sequetially. A 
second span would have the default name of “Span 2”. 

Step 6 Select the fiber type from the Span Fibre Type drop-down list. 

Step 7 Enter the length of the span, in kilometers, in the Span Length field.

Step 8 Enter the EOL aging factor in the Ageing Factor field. 

Step 9 Enter the EOL aging loss in the Ageing Loss field. The EOL loss per span value is added at the EOL to 
each discrete fiber in the network.

Step 10 Enter the concentrated loss at the east end of the span in the Connector Loss East field.

Step 11 Enter the concentrated loss at the west end of the span in the Connector Loss West field.

Step 12 Choose either the Length Based Model or the Absolute Model radio button. 

Step 13 If you choose Length Based Model in Step 12, enter values in value fields for the following properties 
listed in the table at the bottom of the window:

• Loss Factor—The value of the start of life fiber loss per kilometer used to calculate the loss of each 
span in the network. The fiber loss factor is always entered in dB/km, even if you selected miles as 
the span measurement unit. MetroPlanner automatically converts the loss factor from miles to 
kilometers.

• Chromatic Dispersion factor—The fiber chromatic dispersion factor. The default value is dependent 
on the selected fiber type. Any value you enter is lost whenever you change the fiber type. Chromatic 
dispersion is always entered in ps/nm/km, even if you selected miles as the span measurement unit. 
MetroPlanner automatically converts the loss factor from miles to kilometers. Fiber chromatic 
dispersion is defined for the middle of the wavelength band. It is defined at approximately 
1545.3 nm.
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• PMD factor—The PMD factor. The default value is dependent on the selected fiber type. Any value 
you enter is lost whenever you change the fiber type. PMD is always entered in , even if 
you selected miles as the span measurement unit. MetroPlanner automatically converts the loss 
factor from miles to kilometers. 

• Total SOL Loss w/o Connectors—The start of life link fiber loss for each span, without the 
connector concentrated loss. The total SOL loss without connectors is equal to the loss factor 
multiplied by the length. This field is read-only.

• Total SOL Loss—The start of life link fiber loss for each span with the connector concentrated loss 
contributions. The total SOL loss is equal to the total SOL loss without connectors added to the 
connector loss west and connector loss east. This field is read-only.

• Total EOL Loss—The end of life link fiber loss for each span. This field is read-only.

• Total Chromatic Dispersion—The overall link fiber chromatic dispersion for each span. This field 
is read-only.

• Total PMD (DGD)—The DGD is the difference in arrival times of the two polarization modes at a 
particular wavelength and time with a specific PMD coefficient. This field is read-only.

Step 14 If you chose Absolute Model in Step 13, enter values in value fields for the following properties listed 
in the table at the bottom of the window:

• Total SOL Loss w/o Connectors—The start of life link fiber loss for each span, without the 
connector concentrated loss. The total SOL loss without connectors is equal to the loss factor 
multiplied by the length.

Step 15 Click OK to place the span. The span length appears between the selected sites (Figure 2-21).

Figure 2-21 Sample Span Length Between Two Sites
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2.3.2.3 Adding Services

Adding services between sites allows you to specify the fixed service requests that are needed between 
two sites.

Step 1 Click Add Channel Mode on the menu bar. The cursor changes to a pencil with arrows pointing in 
opposite directions beside it.

Step 2 Click and release on one of the sites to which you want to add a channel.

Step 3 Move the cursor to the other site. When you move the cursor, a line appears between the two sites. 

Step 4 Click the destination site. The Service Demand Dialog window appears (Figure 2-22).

Figure 2-22 Service Demand Dialog Window

Step 5 Enter a label for identifying the service in the Service Label field.

Step 6 In the Present Demand area, enter the present number of demand channels required in the 
Num of Channels field.

Step 7 In the Forecast Demand area, enter the total number of channels that will be needed in the future in the 
Num of Channels field. The value should be the number of channels needed on day one plus the number 
of channels the network will need to accommodate future growth.

Step 8 Select a Client Service Type for the channel. The choices are:

• OC-3/12/48/192 (ANSI)

• STM-1/4/16/64 (ETSI)

• Gigabit Ethernet

• 10GE—10 Gigabit Ethernet
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• Fibre Channel

• Fibre Channel 2G

• Fibre Channel 10G

• 1G FICON (1 Gigabit Ethernet–FICON)

• 2G FICON (2 Gigabit Ethernet–FICON)

• ISC-Compat (ISC-1)

• ISC-Peer (ISC-3)

• Sysplex ETR (Sysplex External Time Reference)

• Sysplex CLO (Sysplex Control Link Oscillator)

• ESCON—Enterprise System Connection

• D1 Video

• SDI—Serial digital interface

• HDTV—High-definition television

• DV-6000

• 2R Any Rate

• 15530 10-Gbps Aggregate

• 15530 2.5-Gbps Aggregate

• 15530 MR Transport

• 15530 Data MXP

Note The Sysplex CLO and Sysplex ETR services are only supported on the following topologies: 

• Single span—Two terminal sites with 32MUX-O and 32DMX-O, or 32WSS and32DMX or 
32-DMX-O cards installed and no intermediate sites in between.

• Point-to-Point—Two terminal sites with 32MUX-O and 32DMX-O or 32WSS and32DMX or 
32-DMX-O cards installed. Line amplifiers can be installed between the terminal sites, but 
intermediate (traffic terminating) sites cannot be installed.

• Two hubs—Two hub nodes in a ring with 32MUX-O and 32DMX-O 32WSS and32DMX or 
32-DMX-O cards installed. Line amplifiers can be installed between the hubs.

Refer to the Cisco ONS 15454 DWDM Installation and Operations Guide for more infomation about the 
supported topologies for the ETR and CLO services.

Step 9 Select a protection type from the Protection Type field. The four protection types are Client 1+1, 
Fiber Switched, Unprotected, and Y-Cable. 

Step 10 In the Optical Bypass area, enter the number of channels for the optical bypass in the Num. of Ch. field. 
The number of optical bypass channels must be less than the number of channels listed in the 
Present Demand area.

Step 11 Select an optical bypass site name from the Site Name drop-down list.

Step 12 Choose a DWDM interface type. The two choices are Transponder and Line Card.

Step 13 Select a DWDM Card Type from the drop-down list. If the Service Type is 10GE, the 10GE WDM 
XenPak card type becomes available.
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Step 14 Select a Client Interface Source from the drop-down list.

Step 15 Select a Client Interface Destination from the drop-down list.

Step 16 Click OK to place the channel, or Cancel to quit. If you click OK, a line representing the channel appears 
between the two sites (Figure 2-23). The line has a number above it that indicates the number of channels 
present.

Figure 2-23 Sample Channel Between Two Sites

2.3.3 Creating an ROADM Traffic Group
MetroPlanner allows you to create ROADM traffic groups for a defined list of nodes. 

Step 1 Right-click the Network folder in the traffic view. A menu appears.

Step 2 Select Add ROADM Group from the menu. The ROADM Group window appears (Figure 2-24).

Figure 2-24 ROADM Group Window

Step 3 Enter a name for the group in the Group Name field. 

Step 4 Click the check boxes beside the nodes you want to include in the ROADM group. Only Auto, ROADM, 
and Terminal sites are available. Refer to the “2.3.2.1 Adding Sites” section on page 2-20 for more 
information. 

Step 5 Click All to add all the sites to the group.

Step 6 Click None to remove all the sites from the group.
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Step 7 Click OK to create the group, or Cancel to close the window without creating the group.

2.3.4 Creating an ROADM Demand
MetroPlanner allows you to manually create ROADM demands for the selected ROADM traffic group.

Step 1 Right-click on an ROADM traffic group. A menu appears.

Step 2 Select Add Demand > Roadm from the menu. The Demand Dialog window appears (Figure 2-25).

Figure 2-25 Demand Dialog Window

Step 3 Enter a name for the demand in the Demand Name field. 

Step 4 Select a traffic type from the drop-down list. If you select Hub, the First Site drop-down button becomes 
available. If you selected Meshed, skip to Step 6.

Step 5 For Hub traffic types, select the originating site from the First Site drop-down list.

Step 6 Select a connectivity type from the Connectivity drop-down list. The connectivity choices are Protected, 
Unprotected Minimum Hop, Unprotected Optimum Path, and Unprotected Subnet. Refer to the 
“1.6.3 ROADM Traffic Groups” section on page 1-9 for more information on the connectivity choices. 
If you select Unprotected Subnet, the two drop-down buttons to the right of the Connectivity drop-down 
button become available. Skip to Step 8 if you selected any other connectivity type.

Step 7 Select the subnet starting node and outgoing side from the two drop-down buttons beside the 
Connectivity drop-down button.

Step 8 Check the boxes for one or more service types for the ROADM demand from the list in the left panel. 

Step 9 You can further refine your choices in the right panel by adding client interfaces, and by choosing 
protection types. You can select more than one client interface to support the same service type. All the 
client interfaces supporting each selected service type are shown in the right panel. Client interfaces that 
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only support unrequired service types are unavailable. MetroPlanner, by default, checks the best client 
interface to support each service. The protection check boxes allow you to define the type of protection 
that is supported for the selected client interface. These check boxes are only available when:

• The selected connectivity type is Protected

• The client interface is not Fiber Switched

• The Yes/No check box is checked

Step 10 Click OK to create the demand, or Cancel to close the window without saving any changes.

2.3.5 Creating a Protected Ring Network
MetroPlanner allows you to create protected ring networks.

Step 1 Create a ring network using either the procedures in the “2.3.1 Adding Networks Using the Network 
Wizard” section on page 2-15 or by manually placing sites into a ring configuration.

Step 2 Select Tools > Create P-Ring from the menu. The New Protected Ring window appears (Figure 2-26).

Figure 2-26 New Protected Ring Window

Step 3 Enter the number of present demand channels in the Num. of Channels field.

Step 4 Enter the number of forecasted demand channels in the second Num. of Channels field.

Step 5 Select a service type from the Client Service Type drop-down list. 

Note Refer to the “2.3.2.3 Adding Services” section on page 2-26 for a detailed list of the items in 
the Client Equipment Type and Client Service Type fields.

Step 6 In the Protection Sites area, click All Sites to add all the sites in the ring as protection sites, or click Edit 
to add individual sites. Clicking Edit displays the Protection Sites window (Figure 2-27).
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Note If you click All Sites, skip to Step 13.

Figure 2-27 Protection Sites Window

Step 7 Select one or more sites in the List of Sites area.

Step 8 Click Add to add the sites to the Selected Sites area.

Step 9 Click Add All to add all of the sites to the Selected Sites area.

Step 10 Select one or more sites in the Selected Sites are and click Remove to remove sites from the area.

Step 11 Click Remove All to remove all of the sites from the Selected Sites area.

Step 12 Click OK to display the selected protection sites in the Protection Sites area of the New Protected Ring 
window. Click Cancel to close the window without making any changes.

Step 13 If you want to add optical bypass sites, click Edit in the Optical Bypass area. The Optical Bypass Sites 
window appears (Figure 2-28). If you do not want to add optical bypass sites, proceed to Step 20.
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Figure 2-28 Optical Bypass Sites Window

The Optical Bypass Sites window lists any sites that are not part of the protection scheme. 

Step 14 Select one or more sites in the List of Sites area.

Step 15 Click Add to add the sites to the Selected Sites area.

Step 16 Click Add All to add all of the sites to the Selected Sites area.

Step 17 Select one or more sites in the Selected Sites are and click Remove to remove sites from the area.

Step 18 Click Remove All to remove all of the sites from the Selected Sites area.

Step 19 Click OK to display the bypass sites in the Optical Bypass area of the New Protected Ring window. Click 
Cancel to close the window without making any changes.

Step 20 Choose a DWDM interface type.

Step 21 Select a DWDM card type from the drop-down list.

Step 22 Select a client interface source from the drop-down list.

Step 23 Click OK to create the protected ring group, or click Cancel to close the window without saving any 
changes.

2.4 Analyzing the Network
After you have placed the desired sites, spans, and service demands, click Analyze Network to examine 
the network performance. MetroPlanner automatically optimizes the design and summarizes the optical 
transmission performance in a summary report.

The Analyzer perform the following checks concerning the Any-to-Any and Any Client pattern:

• ROADM nodes cannot be used in conjunction with following node types:

– HUB/Full-OADM (multi-hubbed ring cannot have ROADM units)
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– OADM (both active and passive)

Note These constraints allows MetroPlanner to simultaneously define ROADM (Any-to-Any), fixed and 
P-Ring traffic on the same network if all the added/dropped sites are ROADM, and if neither OADM nor 
Hub/Full-OADM sites are defined in the same network (with the exception of linear networks, where 
end sites must be terminal sites).

• Networks with Any-to-Any clients only support 32-channel Metro-Core algorithms.

After the network has been analyzed, MetroPlanner changes the appearance of the boosters and 
preamplifiers associated with the sites (Figure 2-29).

Figure 2-29 Booster and Preamplifier Examples

2.4.1 Network Analysis Summary Tab
The Summary tab (Figure 2-30) is divided into four areas: Design Info, Optical Results, Design Cost 
Info, and Other Reports. The Design Info area displays information about the network. It is similar to 
the information found in the Add Network Wizard window (Figure 2-15). 

Table 2-5 Booster and Preamplifier Example Legend

Number Description

1 East booster—unforced

2 East preamplifier—unforced

3 West booster—forced

4 West preamplifier—forced

1

2

3

4

12
47

46
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Figure 2-30 Summary Tab

The Optical Results area displays the number of fixed, BLSR, and ROADM demands. The color in the 
columns indicate whether or not the current network design meets the requirements for the start to end 
of the equipment life. If a cell is green, the current design meets the requirements. If a cell is yellow or 
orange, the design is marginal. If the cell is red, the current network design does not meet the 
requirements for proper operation. Click the blue Optical Results Report text to view the Optical Results 
tab. 

The Design Cost Info area displays the global discount percentage, the discounted required parts cost, 
the discounted spare parts cost, and the total discounted network cost. Click the blue Network Bill Of 
Material text to view the network bill of materials. 

The Other Reports area allows you to view other MetroPlanner reports by clicking on the different 
selections in the area.

2.4.2 Viewing the Optical Results Tab
The Optical Results tab allows you to view the optical results of the network you created and analyzed. 

Step 1 You can launch the Optical Results tab from the Summary window, or by selecting Reports > Optical 
Results from the menu. The Optical Results tab (Figure 2-31) appears.
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Figure 2-31 Optical Results Tab

Table 2-6 displays the various buttons and lists that appear on all the tabs.

Table 2-6 Tab Icons

Button Description

Expand Header—Shows an expanded view of the header, including design 
information.

Shrink Header—Shows the default view of the header, without the additional design 
information.

Dock View to Bottom Area—Moves the tab information to the bottom of the screen.

Dock View to Center Area—Moves the tab information from the bottom area to the 
default center view.

Undock View on Desktop—Moves the tab information to a separate window on the 
desktop. Click Dock View to Center Area or Dock View to Bottom Area to move the 
tab information back to the tab view.

Export Report—Opens the Export Report window, which allows you to export the tab 
information to a text or HTML file.

Show Messages Detail—Opens the Analyzer Messages window, which shows you 
any messages pertinent to the current network design.
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Step 2 To change the table view to show SOL information, EOL information, or both, chooses a view from the 
SOL/EOL Filter drop-down list. 

Each row in the tab shows the performance of one optical path. A protected channel has two paths, and 
therefore four rows. Table 2-7 describes the information in the columns.

Show Errors Detail—Opens the Analyzer Messages window, which displays any 
error messages that occurred when you analyzed the network. It indicates that the 
network may not be feasible.

Run New Query—Opens the Optical Results Query Dialog Window.

The EOL drop-down list allows you to filter the tab information. You can select 
start-of-life (SOL) information, EOL information, or both.

The P/F drop-down list allows you to filter the tab information for present 
information, forecast information, or both.

Go to the first page of the report.

Go back 10 pages in the report.

Go to the previous page.

Displays the current page number and the total number of pages in the report.

Go to the next page.

Go forward 10 pages in the report.

Go to the last page in the report.

Table 2-6 Tab Icons (continued)

Button Description

Table 2-7 Network Optical Channel Results Tab Columns

Column Label Description

# Displays the identification number automatically given to each path in the order 
that the channels were entered into the design.

SOL Displays the results of the start of life analysis. The indicator displays the optical 
performance for the path. Green indicates success, yellow indicates success with 
a marginal failure risk (between 0-16%), orange indicates the channel has a 
higher risk of failure (between 16-50%), and red indicates failure. 
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EOL Displays the end of life analysis. The indicator displays the optical performance 
for the path at the end of the fiber’s life. Green indicates success, yellow indicates 
success with a marginal failure risk (between 0-16%), orange indicates the 
channel has a higher risk of failure (between 16-50%), and red indicates failure.

System Error Displays a red flag to indicate that a system limitation or untested configuration 
prevents the connection from working properly. This system error condition is 
summarized as all the other existing anomalous conditions on the connection. For 
an analyzed MetroPlanner 2.5 network, this system error indicationis gray.

Traffic Group 
Label

Displays the Traffic Group name for ROADM and P-Ring traffic. Displays the 
predefined string "Fixed" for fixed traffic.

Srv Circuit Label Displays the service circuit name. This field is optionally entered from the 
Channel Dialog window.

P/F Displays the present/forecast services indication.

Source Displays the name of the source site.

Dest Displays the name of the destination site.

Side Identifies the side of the source site that each path of the service circuit leaves.

Protect Displays the protection type of the channel. For a protected channel, both paths 
are shown. The path leaving the east side of the source is shown first.

Wavelength Displays the assigned wavelength of the optical path.

Span (km) Displays the total span (source -> destination) for this path in kilometers.

TX type Displays the type of transceiver that is the DWDM Card Type (see 
2.3.2.3 Adding Services).

BER target Displays the bit error rate (BER) target for this channel based on the capability 
of the channel’s optical interface. It is 1.0E-15 for the interfaces using forward 
error correction (FEC) and 1.0E-12 for interfaces without FEC.

OSNR (dB) Displays the SOL/EOL average OSNR value at the receiver. OSNR refers to the 
selected RBW bandwidth.

OSNR Margin Displays the OSNR margin.

RX (dBm) Displays the SOL and EOL received average power at the destination site.

Power Margin 
(dB)

Displays the power budget margin at the receiver. It is defined as the offset 
between the receiver working point and the “BER curve with margin.” A positive 
value indicates no power problems.

Overload Margin 
(dB)

Displays the overload margin at the receiver. A positive value indicates no 
overload problems.

RX atten Displays the attenuator at the input of the receiver.

PMD (ps) Displays the calculated total PMD for each circuit. If the overall PMD for the link 
overcomes the maximum allowed, the PMD value is colored red. The maximum 
allowed value depends on the client interface. For these special cases, the 
network must be manually resolved by contacting a Cisco optical sales engineer.

Latency Displays the latency time for the current circuit. 

Chr Disp Check Displays the status of the chromatic dispersion check. Green indicates that the 
dispersion check passed. Red indicates that the dispersion check failed.

Table 2-7 Network Optical Channel Results Tab Columns (continued)

Column Label Description
2-37
Cisco MetroPlanner DWDM Operations Guide, Release 2.5.1

September 2005



 

Chapter 2      Designing Networks with MetroPlanner
2.4.2 Viewing the Optical Results Tab
Step 3 Use the directional buttons at the bottom of the tab to scroll forward and backward through the optical 
results pages. 

Step 4 Click Shrink Header to hide all the table header information.

Step 5 Click Export Report to export the optical results information to a file. You can save the file as an HTML 
file, or as a tab-separated text file that can be opened by several applications.

Step 6 Click New Query to open the Optical Results Query Dialog window (Figure 2-32). The Optical Results 
Query Dialog window allows you to filter the optical results using a variety of parameters and templates.

Figure 2-32 Optical Results Query Dialog Window

Table 2-8 describes the fields on the Optical Results Query Dialog Window.

Table 2-8 Optical Results Query Dialog Window Fields

Column Label Description

Group Selecting a traffic group filters the report to include only the data in the selected 
group. You can also view groups on the tree view under the Network root. 

Demand Selecting a traffic demand filters the report to include only the data in the 
selected demand. The demand field is available only when you select a specific 
traffic group.

DWDM Card Type Selecting a card type filters the report to include only the data in the selected 
DWDM card type. 
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Step 7 To perform a query using individual parameters, select the desired parameters from the 10 drop-down 
lists in the Query Definition area. The selected parameters appear in the Query Preview area at the 
bottom of the screen.

Step 8 To perform a query using a pre-defined query template, select a template from the Query Templates 
drop-down list and click Init From Template. The parameters included in the template appear in the 
Query Preview area.

Step 9 Click Run Query. The window closes, and the query results appear in the Optical Results tab. The 
parameters of the query appear in the horizontal area just below the button bar.

Step 10 Click Reset Query to clear your selections in the Optical Results Query Dialog window, or click Close 
to close the window without running a query.

Step 11 To view a demand’s optical channel result at any time, right-click on the desired traffic demand in the 
tree view and select Optical Results. 

Step 12 Click Messages on the tab to view the Analyzer Messages window (Figure 2-33), which displays any 
messages that occurred during the network analysis. If there are any errors in the analysis, click Errors 
to view the error messages in the window.

Note You can also select Reports > Show Messages to view the Analyzer Messages window.

Figure 2-33 Analyzer Messages Window

Step 13 Click OK to close the Analyzer Messages window.

Site A / Site B Allows you to filter only the results of incoming/outgoing services to or from a 
specific site (if you select Any), or between a pair of sites (if both are specified).

Direction Allows you to filter for services that are routed in the specified direction. The 
direction refers to the fiber transmitting direction.

Wavelength Allows you to filter for services using the specified wavelength.

Alarm Allows you to filter for services flagged with a green, yellow, orange, or red 
indicator.

P/F Allows you to filter for present services, forecast services, or both.

Virtual Allows you to include or exclude virtual channels in the Optical Results Table.

Table 2-8 Optical Results Query Dialog Window Fields (continued)

Column Label Description
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Step 14 Click Dock View to Bottom Area to position the Optical Results tab below the Network tab. Click it 
again to return to the previous view.

Step 15 Click Undock View on Desktop to detach the Optical Results tab and view it as a stand-alone window.

Step 16 Click Dock View to Center Area to return to the previous view.

2.5 Editing and Viewing Network Components
MetroPlanner allows you to edit and view the network components either before or after the analysis. 
Error messages that occur during the analysis often cannot be resolved until you edit one or more 
network components.

2.5.1 Editing Site Parameters
Editing the site parameters allows you to make changes to the current site configuration.

Step 1 Create or open a network design.

Step 2 Click Edit on the menu bar. 

Step 3 Double-click a site in the main MetroPlanner window, or right-click a site and select Edit Site from the 
menu. The Site Dialog window (Figure 2-19) appears. 

The window displays site, rack, shelf, slot, and card information, in addition to the site parameters, type, 
and amplifier information you selected when you created the site. The window is divided into three areas. 
The area on the far left contains the information you entered when you created the site. The middle area 
contains a button bar and expandable nodes that represent the site, racks, shelves, and additional 
equipment. The area at the far right contains a graphical representation of the site, racks, and shelves.

Step 4 Make any changes to the fields as described in the “2.3.2.1 Adding Sites” section on page 2-20.

Step 5 To change the layout of the node graphic, right-click on the tree root site icon and select Layout 
Customization. A sub-menu opens, displaying the following custimization options: AIC, Fibre Storage, 
Patch Panels, and Ethernet Switch. 

Step 6 Select the items you want to display on the node graphic. The node graphic updates in real-time to 
display the selected item. 

Although there are two distinct patch panel options, the final network design only contains a single 
option that applies to both. The patch panel options are only available for Hub, Full OADM and Terminal 
site types. For Terminal types, only one patch panel is added/removed. For Hub and Full-OADM types, 
both patch panels are added/removed. 

If you selected Ethernet Switch, you can override the network-wide setting in the Project Options 
window (Figure 2-6 on page 2-7).

Note If you change the network design after the design has been analyzed, the changes are applied 
immediately to the site layout without having to re-analyze the network.

Step 7 Click OK to save the changes and close the window.
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Note You can only make site changes before running the network analysis. If you need to make changes to a 
site that is a part of an analyzed network, click Design Mode on the menu bar to revert the network to 
the design mode, where you can edit the site. You must then run the Network Analyzer again to obtain 
a valid network configuration.

2.5.2 Displaying Shelf Configurations
After analyzing the network design, you can examine the shelf configuration for each of the sites using 
the Edit Site dialog box.

Step 1 Click Edit and double-click a site in the Network tab to display the Site Dialog window (Figure 2-34).

Figure 2-34 Site Dialog Window Showing Shelf Configuration 

Step 2 Double-click different areas of the graphic on the far right of the window to see information specific to 
that rack, shelf, or card. A separate window appears, displaying information for the selected item. 
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Figure 2-35 Sample Report Window

The information displayed in the window varies from item to item. See Table 2-9 for a complete listing 
of the tabs and columns available in the window.

Table 2-9 Site Dialog Report Window Tabs and Columns

Tab Column Description

Info Property Displays the categories of information available 
for the selected item.

Value Displays the actual item description.

Modules P/F Displays the present and forecast module 
information.

Module PID Displays the module part number.

Ch # Displays the channel number.

Description Displays the description of the module.

Items Item PID Displays the item part number.

Category Displays the category to which the item belongs.

Description Displays a description of the item.

Count Indicates the number of these items present.

Notes Displays any notes available for the item.

Connections Port Displays the port name.

Conn. Port Displays the connection port name.

Conn. Card Displays the connection card name.

Conn. Position Displays the position of the connection.
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Step 3 Click Zoom In and Zoom Out on the button bar to view more or less detail on the graphic.

Step 4 Click either the left or right arrow button to view information for the next or previous site in the network.

Step 5 To view the site layout in table format, click View Layout As Table. The site information appears as a 
separate window in table format, allowing you to export to an external application, if you desire.

Step 6 To export the layout to an image file, click Export View To Image. 

Step 7 To exit the shelf layout window, click Cancel.

2.5.3 Deleting a Site
Perform the following steps to delete an existing site from the network design.

Step 1 Right-click the site in the main MetroPlanner window and select Delete Site from the menu. A 
confirmation message appears, asking you to confirm the deletion of the site.

Step 2 Click Yes to delete the site. 

Services Service Filtering Option Select a filtering option for the services. Choices 
are None, Only Added, Only Dropped, Only 
Express, and Only Optical Bypass.

Service Label Displays the service label.

Src Site Displays the source site name.

Src Pos Displays the source rack and shelf position.

Src Unit Displays the source card (unit) name.

Src Port Displays the source port.

Dest Site Displays the destination site name.

Dest Pos Displays the destination rack and shelf position.

Dest Unit Displays the destination card (unit) name.

Dest Port Displays the destination port.

Cl. Service Displays the client service type.

Protection Displays the current protection scheme.

ITU Ch. Displays the ITU channel. 

Op. Bypass Displays the name of the optical bypass site.

Cl. Interf. Displays the DWDM interface type (transponder 
or line card).

Cl. Card Displays the DWDM card type.

Table 2-9 Site Dialog Report Window Tabs and Columns (continued)

Tab Column Description
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Note If the site has associated service demands or channels, you must first delete those demands or channels 
before deleting the site. 

2.5.4 Editing Service Demand Allocations
You can change the distribution of services in a group of fixed or P-ring service demands as well as view 
the service requests between to sites using the following steps.

Step 1 Create or open a network design.

Step 2 Click Edit Mode on the menu bar. 

Step 3 Double-click a channel/service in the main MetroPlanner window, or right-click a service and select Edit 
Service from the menu. The Service Table window (Figure 2-36) appears. 

Figure 2-36 Service Table Window

The Services Table window displays information about the selected service. Table 2-10 lists the fields 
and columns and their descriptions.

Table 2-10 Service Table Columns

Column/Field 
Label

Description

Srv. Demand Label Displays the service demand label.

Source Displays the name of the source node.

Destination Displays the name of the destination node.

P/F Present and Forecast. This column displays “P&F” if services are configured 
both currently and in the future. If services are for future only, “F” is displayed. 
If services are configured only for current activity, “P” is displayed.

Cl Srv. Type Displays the client service type.

Protection Type Specifies the protection type, if any. You can force routing of service by selecting 
Unprotected-East or Unprotected-West from the drop-down list.
2-44
Cisco MetroPlanner DWDM Operations Guide, Release 2.5.1

September 2005



 

Chapter 2      Designing Networks with MetroPlanner
2.5.5 Editing Fiber Span Parameters
Step 4 To display the Service Demand Dialog window, double-click a row, or select a row and click 
Edit Service Circuit. The Service Demand Dialog window (Figure 2-22) appears, allowing you make 
changes to the service.

Note You can only make service changes before running the network analysis. If you need to make 
changes to a service that is a part of an analyzed network, click Design Mode on the menu bar 
to revert the network to the design mode, where you can edit the service. You must then run the 
Network Analyzer again to obtain a valid network configuration.

Step 5 Make any changes to the fields as described in the “2.3.2.3 Adding Services” section on page 2-26.

Step 6 To delete a service, select the service and click Remove Service Circuit.

Step 7 To add a service group, click the Add Service Group button. The Service Demand Dialog window 
appears, allowing you to create a new service. 

Step 8 Click OK to save the changes and close the window.

2.5.5 Editing Fiber Span Parameters
Editing the fiber span parameters allows you make changes to fiber type, span length, and other 
fiber-related items.

Step 1 Create or open a network design.

Step 2 Click Edit Mode on the menu bar. 

Step 3 Double-click a fiber span in the main MetroPlanner window, or right-click the fiber span and select 
Edit Fibre from the menu. The Fibres Dialog window (Figure 2-20) appears, allowing you to make 
changes to the fiber span.

Note You can only make fiber changes before running the network analysis. If you need to make 
changes to a fiber that is a part of an analyzed network, click Design Mode on the menu bar to 
revert the network to the design mode, where you can edit the fiber. You must then run the 
Network Analyzer again to obtain a valid network configuration.

ITU Ch (opt) Displays the ITU channel of the service demand. You can force the channel 
number by selecting a new channel from the drop-down list in the field.

Op. Bypass Site 
Name

Displays the name of the optical bypass site, if one is assigned.

DWDM Interface 
Type

Displays the DWDM interface type.

DWDM Card Type 
(opt)

Displays the DWDM card type.

Table 2-10 Service Table Columns (continued)

Column/Field 
Label

Description
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Step 4 Make any changes to the fields as described in the “2.3.2.2 Adding Fiber Spans” section on page 2-23.

Step 5 To save the changes, click OK.

2.5.6 Deleting a Fiber Span
Perform the following steps to delete a fiber span from the network design.

Step 1 Right-click the fiber and select Delete Fibre from the menu. A confirmation dialog box appears, asking 
you to confirm the fiber deletion.

Step 2 Click Yes to confirm the fiber deletion.

2.5.7 Viewing the Traffic Matrix
The Traffic Matrix window displays information about the external connections on the client side.

Note When opened from the menu, the Traffic Matrix appears blank until after you run a query from the 
Traffic Matrix tab. See Step 6 of “2.4.2 Viewing the Optical Results Tab” section on page 2-34 for 
information on running a query.

Step 1 Create or open an analyzed network. 

Step 2 Select Reports > Traffic Matrix. The Traffic Matrix window appears (Figure 2-37). The query runs 
automatically, displaying information based on the selected item in the tree view. You can also view the 
traffic matrix for a specific demand by right-clicking the desired traffic demand in the tree view
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Figure 2-37 Traffic Matrix Window

Table 2-11 describes the information in the Traffic Matrix window.

Table 2-11 Traffic Matrix Columns

Column Name Description

Traffic Group Label Displays the traffic group name for ROADM and P-Ring traffic. Displays 
the predefined string "Fixed" for fixed traffic.

Srv. Circuit Label Displays the service circuit label.

Source Displays the source site name.

Src. Side Displays the source side of the site (east or west).

Src. IP Address Displays the IP address of the source site.

Src. Position Displays the source rack and shelf position.

Src. Unit Displays the source card (unit) name.

Src. Port Displays the source port.

Destination Displays the destination site name.

Dest. Side Displays the destination side of the site (east or west).

Dest. IP Address Displays the IP address of the destination site.

Dest. Position Displays the destination rack and shelf position.

Dest. Unit Displays the destination card (unit) name.

Dest. Port Displays the destination port.

Cl. Service Type Displays the client service type.

Protection Type Displays the current protection scheme.
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Step 3 Click Shrink Header to hide the text that appears above the table rows.

Step 4 Click Export Report to save the information to an external file. The Save Table window appears, 
allowing you to enter or select an HTML or text file name.

Step 5 Click Messages to view the Analyzer Messages window (Figure 2-33).

Step 6 Click Dock View to Bottom Area to position the tab below the Network tab. Click it again to return to 
the previous view.

Step 7 Click Undock View on Desktop to detach the tab and view it as a stand-alone window.

Step 8 Click Dock View to Center Area to return to the previous view.

2.5.8 Viewing the Wavelength Routing
The Wavelength Routing Map allows you to view a graphical traffic display of all the present and 
forecast, fixed and protected ring routed circuits in the network. 

Step 1 Create or open an analyzed network.

Step 2 Select Reports > Wavelength Routing from the menu. Alternatively, you can open the Wavelength 
Routing window by clicking View Reports and selecting Wavelength Routing from the drop-down. The 
Wavelength Routing tab appears (Figure 2-38).

Wavelength Displays the wavelength.

Op. Bypass Site Name Displays the name of the optical bypass site.

DWDM Interface Type Displays the DWDM interface type (transponder or line card).

DWDM Card Type Displays the DWDM card type (10G MR TXP w/FEC or 10G MR TXP 
w/o FEC).

Table 2-11 Traffic Matrix Columns (continued)

Column Name Description
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Figure 2-38 Wavelength Routing Tab

Each row represents a wavelength. The Wavelength Routing tab displays all the wavelengths, not just 
the wavelengths used by the network design. Each column represents the sites and each bidirectional 
span. The site columns are subdivided into two other columns, which represent the east and west side of 
the site. 

Each bidirectional routed channel is represented by a line starting from the source site to the destination 
site through the sites and spans traversed by the channel. Protected circuits are represented by two 
distinct routes. 

Step 3 Place the cursor over the different sections of the map to display tool tip information about the routed 
circuits. The tool tips display the circuit label, service circuit type, protection type, and the DWDM card 
type.

Step 4 Click Shrink Header to hide the text that appears above the table rows.

Step 5 Click Export Report to save the information to an external file. The Save Table window appears, 
allowing you to enter or select an HTML or text file name.

Step 6 Click Export Report As Image to save the information in the map to an external image file.

Step 7 Click Messages to view the Analyzer Messages window (Figure 2-33).

Step 8 Click Dock View to Bottom Area to position the tab below the Network tab. Click it again to return to 
the previous view.

Step 9 Click Undock View on Desktop to detach the tab and view it as a stand-alone window.

Step 10 Click Dock View to Center Area to return to the previous view.
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2.5.9 Viewing the Link Availability
MetroPlanner provides the ability to view a link availability table listing an availability value (as a 
percentage) for each circuit in the network. MetroPlanner defines the value globally for the circuit, and 
factors in both paths for protected circuits. For BLSR/MSP-Ring-type ring protection, link availability 
is provided for each individual service circuit. 

Step 1 Create or open an analyzed network.

Step 2 Select Reports > Link Availability. Alternatively, click View Report and select Link Availability from 
the list, or right-click an item in the tree view and select Link Availability.

Note Opening the Link Availability window via right-click displays all the circuits in the subtree in 
the window.

The Link Availability tab appears (Figure 2-39).

Figure 2-39 Link Availability Tab

Table 2-12 describes the information in the Link Availability tab.

Table 2-12 Link Availability Tab Columns

Column Name Description

Traffic Group Label Displays the traffic group name for ROADM and P-Ring 
traffic. For fixed traffic, it displays the predefined string 
“Fixed”.

Service Circuit Label Displays the service circuit label.

Source Displays the service circuit source site name.

Destination Displays the service circuit destination site name.

Protection Type Displays the service circuit protection type.
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Step 3 Click Shrink Header to hide the text that appears above the table rows.

Step 4 Click Export Report to save the information to an external file. The Save Table window appears, 
allowing you to enter or select an HTML or text file name.

Step 5 Click Messages to view the Analyzer Messages window (Figure 2-33).

Step 6 Click Dock View to Bottom Area to position the tab below the Network tab. Click it again to return to 
the previous view.

Step 7 Click Undock View on Desktop to detach the tab and view it as a stand-alone window.

Step 8 Click Dock View to Center Area to return to the previous view.

2.5.10 Modifying the Filter Wavelengths
After analyzing the network, you can force channels to any one of the wavelength bands supported by 
the ONS 15454.

Step 1 Create or open an analyzed network. 

Step 2 Choose Network > Bands Shifting from the menu bar. The Resulting Bands Map window will display 
(Figure 2-40).

DWDM Card Type Displays the client DWDM card type.

Link Availability% Complete Displays the link availability, in percentage complete.

Table 2-12 Link Availability Tab Columns (continued)

Column Name Description
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Figure 2-40 Resulting Bands Map Window

The Resulting Bands Map window shows which wavelengths are in use in which bands. A used 
wavelength is indicated by light blue shading in the cell. 

Step 3 To switch the wavelengths to any available band, click on the drop down list in the Shifted Band column 
to the right of the wavelength. 

Step 4 Select a wavelength from the drop-down list. The new wavelength then appears in the Shifted Band 
column.

Note The drop-down list only appears after you click in the cell.

Step 5 After switching bands, click OK to close the window, or click Cancel to close the window without 
saving any changes.

2.5.11 Viewing the Design Notes
The Design Notes function allows you to add and view any notes about the selected network design, 
regardless of the current design status. 

Step 1 Create or open a network design.

Step 2 Select Reports > Notes. The Notes tab appears.

Step 3 Enter any notes you have for the network design.
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Step 4 Click Dock View to Bottom Area to position the tab below the Network tab. Click it again to return to 
the previous view.

Step 5 Click Undock View on Desktop to detach the tab and view it as a stand-alone window.

Step 6 Click Dock View to Center Area to return to the previous view.

Step 7 Click Clear Notes to clear any existing notes.

2.5.12 Viewing the Sites Table
The Sites Table displays a list of the sites in the network and their IP addresses.

Step 1 Create or open a network design.

Step 2 Select Network > Sites Table. The Sites Table appears (Figure 2-41).

Figure 2-41 Sites Table

Step 3 To copy the information in the window, right-click any row and select Copy Table.

Step 4 To export the information to an external file, right-click any row and select Export Table. A Save Table 
window appears, allowing you to enter or select a file name for the exported information. You can save 
site table files as either HTML or text files.

Step 5 Click Save.

Step 6 Click OK or Cancel to close the Sites Table window.

2.5.13 Viewing the Span Table
The Span table displays a list of the spans in the network.

Step 1 Create or open a network design.

Step 2 Select Network > Span Table. The Fibres Dialog window appears (Figure 2-20).
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Step 3 Click OK to close the window.

2.5.14 Arranging Sites in the Network View
After creating a network, you can use MetroPlanner to automatically arrange the sites into several 
configurations. MetroPlanner offers six different configurations.

2.5.14.1 Using the Square Configuration

The square configuration displays the network in a square format.

Step 1 Create or open a network design.

Step 2 Select Network > Arrange Sites > Square. The Square Shape Data Input window appears 
(Figure 2-42).

Figure 2-42 Square Shape Data Input Window

Step 3 Enter a number indicating the amount of space to place between the sites in the Sites Spacing field. 
Higher numbers create larger spaces between sites. 

Alternatively, click Auto to allow MetroPlanner to automatically place the sites at a predetermined 
distance from each other. 

Step 4 Click OK to create the spacing, or click Cancel to close the window without applying the square 
configuration. Refer to Figure 2-43.
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Figure 2-43 Example of a Square Configuration

2.5.14.2 Using the Ring Configuration

The ring configuration displays the network in a circular, or ring format.

Step 1 Create or open a network design.

Step 2 Select Network > Arrange Sites > Ring. The Ring Shape Data Input window appears (Figure 2-44).

Figure 2-44 Ring Shape Data Input Window

Step 3 Enter a number indicating the radius of the ring in the Ray field. A higher numbers creates a larger ring. 

Alternatively, click Auto to allow MetroPlanner to automatically create a ring at a predetermined size.

Step 4 Click OK to create the ring, or click Cancel to close the window without applying the ring configuration. 
Refer to Figure 2-45.
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Figure 2-45 Ring Configuration Example

2.5.14.3 Using the Ellipse Configuration

The ellipse configuration displays the network in a oval, or ellipse format.

Step 1 Create or open a network design.

Step 2 Select Network > Arrange Sites > Ellipse. The Ellipse Shape Data Input window appears 
(Figure 2-46).

Figure 2-46 Ellipse Shape Data Input Window

Step 3 Enter a number indicating the length of the ellipse in the X Ray field. Higher numbers create longer 
ellipses.

Step 4 Enter a number indicating the height of the ellipse in the Y Ray field. Higher numbers create wider 
ellipses.

Alternatively, click Auto to allow MetroPlanner to automatically create an ellipse of a predetermined 
size.

Step 5 Click OK to create the spacing, or click Cancel to close the window without applying the ellipse 
configuration. Refer to Figure 2-47.
2-56
Cisco MetroPlanner DWDM Operations Guide, Release 2.5.1

September 2005



 

Chapter 2      Designing Networks with MetroPlanner
2.5.14 Arranging Sites in the Network View
Figure 2-47 Ellipse Configuration Example

2.5.14.4 Using the Snake Configuration

The snake configuration displays the network in a serpentine, linear format.

Step 1 Create or open a network design.

Step 2 Select Network > Arrange Sites > Snake. The Snake Shape Data Input window appears (Figure 2-48).

Figure 2-48 Snake Shape Data Input Window

Step 3 Enter a number indicating the number of sites to appear in each row in the Sites Per Row field. 

Step 4 Enter a number indicating the amount of space required between each site in the Horizontal Spacing 
field. Higher numbers create wider spaces between sites.

Step 5 Enter a number indicating the amount of space required between each row in the Vertical Spacing field. 
Higher numbers create wider spaces between rows.

Alternatively, click Auto to allow MetroPlanner to automatically create a snake configuration of a 
predetermined layout.

Step 6 Click OK to create the spacing, or click Cancel to close the window without applying the snake 
configuration. Refer to Figure 2-49.
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Figure 2-49 Snake Configuration Example

2.5.14.5 Using the Double Ring Configuration

The double ring configuration displays the network in a dual ring format.

Step 1 Create or open a network design.

Step 2 Select Network > Arrange Sites > Double Ring. The Double Ring Shape Data Input window appears 
(Figure 2-50).

Figure 2-50 Double Ring Shape Data Input Window

Step 3 Enter a number indicating the radius of the inner ring in the Inner Ray field. Higher numbers create 
bigger rings.

Step 4 Enter a number indicating the radius of the outer ring in the Outer Ray field. Higher numbers create 
bigger rings.

Alternatively, click Auto to allow MetroPlanner to automatically create a double ring configuration of a 
predetermined size.

Step 5 Click OK to create the spacing, or click Cancel to close the window without applying the double ring 
configuration. Refer to Figure 2-51.
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Figure 2-51 Double Ring Configuration Example

2.5.14.6 Using the Fit to Window Configuration

Use the Fit to Window configuration to adjust any existing configuration so that it fills the MetroPlanner 
window.

Step 1 Create or open a network design.

Step 2 Select Network > Arrange Sites > Fit to Window. The configuration expands or contracts to fit within 
the MetroPlanner window.

2.6 Saving and Loading Network Designs
MetroPlanner provides the capability to save network designs for future reference. 

Step 1 To save a network design to disk, click Save. If the design has not yet been saved to a file, a File 
dialog box appears, asking you to select a file path and specify a file name. MetroPlanner saves network 
designs with the extension “cmn”. 

Step 2 To load a network design from disk, click Open. The Select Network File dialog box appears, asking 
you to select a file path and specify a file name. 
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Note Network designs that were created in releases of MetroPlanner prior to Release 2.3 are 
incompatible with MetroPlanner R2.5.1.

Step 3 To save the existing design with a new name, choose File > Save As. A File dialog box appears, asking 
you to select a file path and specify a file name.

2.7 Completing the Network Design
After creating, analyzing, and modifying the network design, you must prepare the design for installation 
at a customer site. 

2.7.1 Freezing and Unfreezing the Network Layout
When the network design is in Install status, you can freeze and unfreeze the network layout, or the 
individual sites in the layout. Freezing a site forces the presence or absence of all preamplifiers, boosters, 
add/drop filters, and DCU units required by the site/network as a result of running the Network Analyzer 
previously. 

The Install status refers to the current state of the network design. Network designs have several states, 
as follows.

• Design—The initial status for any new network design. You can add, delete, or change any aspect 
of the network design. 

• Design-Analyzed—The status of the network design after you run the Network Analyzer. All the 
result tables are available and updated. You cannot change any aspect of the network design. You 
can also modify BOM aspects, such as global discounts and spare part management.

• Install—The status of the network after clicking Install Mode. Moving into the Install state from 
the Design-Analyzed state automatically freezes all the sites in the design. You cannot modify any 
aspect of the network design except the span parameters and (on unfrozen sites) amplifier forcing. 
You can modify the BOM. All routed circuits are fixed, and cannot be changed while in this state.

• Installed-Analyzed—The status of the network after running the Network Analyzer on a network in 
the Install state. MetroPlanner updates the results tables. You cannot modify any aspect of the 
network design except the span parameters and the amplifier forcing. All routed circuits are fixed, 
and cannot be changed while in this state.

MetroPlanner saves the state of the network along with the network itself. 

Step 1 Create or open a network design.

Step 2 Click Install Mode to move the design into the Install state. All the sites in the network automatically 
freeze. Frozen sites are indicated by a closed padlock on the site (Figure 2-52).
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Figure 2-52 Frozen Site Example

Step 3 To unfreeze all the sites in the network, select Network > Install > Layout Unfreezing. The padlock 
disappears.

Step 4 To unfreeze an individual site, right-click the frozen site and select Network > Install > 
Site Layout Un-Freezing. 

Step 5 To freeze the entire network, select Network > Install > Layout Freezing.

2.7.2 Viewing Internal Connections
You can view the network internal connections after the network has been analyzed, and when it is in the 
Install state. You can also view the patch cord connections between transponders and Y-Cable Protection 
FlexLayer modules. The Y-Cable Protection FlexLayer position is defined using the rack and shelf 
number resulting from the layout position, and the slots are numbered from left to right on each of the 
four FlexLayer modules that can be placed in a shelf.

Step 1 Create or open a network design.

Step 2 Analyze the network.

Step 3 Select Reports > Internal Connections from the menu. The Internal Connections tab appears 
(Figure 2-53).
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Figure 2-53 Internal Connections Tab 

Table 2-13 lists the columns in the Internal Connections tab and their descriptions. Click on the columns 
to sort the table information by the selected column.

Table 2-13 Internal Connections Tab Columns

Column Name Description

Site Displays the name of the site.

IP Address Displays the site IP address.

Position-1 Displays the rack, shelf, and slot position of the unit (card) from which the patch 
cord originates.

Unit-1 Displays the name of the unit (card).

Port #-1 Displays the port number from which the patch cord originates.

Port ID-1 Displays the port ID.

Port Label-1 Displays the name of the port.

Attenuator When indicated, it is the PID of the bulk attenuator to be equipped on this 
connection. It also reports information for when an internal attenuator must be 
placed, between the DC-TX and DC-RX ports on the preamplifier when no DCU is 
equipped.

Position-2 Displays the rack, shelf, and slot position of the unit (card) where the patch cord 
terminates.

Unit-2 Displays the name of the unit (card).

Port #-2 Displays the port number where the patch cord terminates.

Port ID-2 Displays the port ID.

Port Label-2 Displays the name of the port.
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Step 4 Click Shrink Header to hide the text that appears above the table rows.

Step 5 Click Export Report to save the information to an external file. The Save Table window appears, 
allowing you to enter or select an HTML or text file name.

Step 6 Click Messages to view the Analyzer Messages window (Figure 2-33).

Step 7 Click Dock View to Bottom Area to position the tab below the Network tab. Click it again to return to 
the previous view.

Step 8 Click Undock View on Desktop to detach the tab and view it as a stand-alone window.

Step 9 Click Dock View to Center Area to return to the previous view.

2.7.3 Viewing Installation Parameters
You can view the installation parameters of networks after the network has been analyzed, and when it 
is in the Install state. The network installation parameters report the parameter values to be set 
(provisioned) at installation time on each site in the network. 

Step 1 Create or open a network design.

Step 2 Click Install Mode to move the design into the Install state.

Step 3 Select Reports > Installation Parameters from the menu. The Installation Parameters tab appears 
(Figure 2-54).

Manually Set Defines when the internal connection must be manually set by means of the local 
craft terminal (CTC). The allowed values are:

• No—This connection is automatically set on the site by the TL1 agent software.

• Yes—This connection must be manually set using CTC (or TL1).

• Remove—This connection must be manually removed using CTC (or TL1).

Note Every connection listed in the report must be connected with patch cords, 
except for connections marked “Remove”. 

P/F Displays whether the connection relates to a present or forecast circuit.

Table 2-13 Internal Connections Tab Columns (continued)

Column Name Description
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Figure 2-54 Installation Parameters Tab

Table 2-14 lists the columns in the Installation Parameters tab and their descriptions.

Table 2-14 Installation Parameters Tab Columns

Column Name Description

Site Name Displays the name of the site.

IP Address Displays the site IP address.

Side Indicates the side of the site from which the parameter originates (east or west).

Position Displays the rack, shelf, and slot position of the unit (card) from which the 
parameter originates.

Unit Displays the name of the unit (card). 

Port # Displays the port number (IDL port identifier) of the parameter. 

Port ID Displays the port ID (TL1 identifier). 

Port Label Displays the name of the port as displayed on the front panel of the unit. 

Parameter Displays the name of the parameter.

Value Displays the value to be set for the installation parameter.
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The installation parameters vary, depending on whether they apply to the network, system, or site. 

Step 4 Click Shrink Header to hide the text that appears above the table rows.

Step 5 Click Export Report to save the information to an external file. The Save Table window appears, 
allowing you to enter or select an HTML or text file name.

Step 6 Click Messages to view the Analyzer Messages window (Figure 2-33).

Step 7 Click Dock View to Bottom Area to position the tab below the Network tab. Click it again to return to 
the previous view.

Step 8 Click Undock View on Desktop to detach the tab and view it as a stand-alone window.

Step 9 Click Dock View to Center Area to return to the previous view.

2.7.4 Saving the Installation Assisted Configuration File
After MetroPlanner calculates the installation parameters, it can create a separated ASCII configuration 
file for each site in the network. This file can be directly imported to a site using the NE Update feature 
in Cisco Transport Controller (CTC). MetroPlanner generates one text file for each site in the network 
in the MetroPlanner installation folder. Each file is named with the site name string by default.

Step 1 Create or open a network design.

Step 2 Click Install Mode to move the design into the Install state.

Step 3 Select Network > Install > Assisted Conf Setup. The Assisted Configuration Setup Save File window 
appears (Figure 2-55).

Measurement Unit Displays the unit of measure for the parameter.

Manual Set Defines when the installation parameter must be manually set by means of the 
local craft terminal (CTC). The allowed values are:

• No—This parameter is automatically set on the site using the assisted 
configuration file.

• Yes—This parameter must be manually set using CTC (or TL1).

• Troubleshooting—This parameters is used to check if the measured value in 
the specified point is the expected value.

Table 2-14 Installation Parameters Tab Columns (continued)

Column Name Description
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Figure 2-55 Assisted Configuration Setup Save File Window

Step 4 Click Save to save the file to disk. 

Step 5 To change the directory, choose a new directory from the list, or use the drop-down list to select a 
directory.

Step 6 Click Cancel to close the window without saving a configuration setup file.

2.8 Ordering the Equipment
MetroPlanner provides features to help you order your Cisco ONS 15454 DWDM equipment. After you 
complete the network design, you must create a unique order code (also referred to as an order 
description). This allows the order to be placed via Cisco.com. The following steps describe the process 
for creating an order code.

Step 1 Choose Options > Order Parameters. The Order Parameters window appears (Figure 2-56).
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Figure 2-56 Order Parameters Window

Step 2 Enter the version of the design in the Design Version field.

Step 3 Enter the description in the Design Description field.

Step 4 Enter the name of the customer in the Customer Name field.

Step 5 Enter the name of the designer in the Prepared By field.

Step 6 Click OK. Click Cancel to close the window without saving any changes.

2.9 Generating a BOM
You can generate a BOM after you have successfully analyzed your network design.

2.9.1 Generating a Network BOM
Use the following steps to generate a BOM for the network.
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Step 1 Choose Reports > Network Bill Of Material to generate a BOM for the entire network. The Network 
BOM window (Figure 2-57) appears.

Figure 2-57 Network BOM Window

Step 2 To change the global discount for the entire network, enter a new global discount in the form of a 
percentage in the Global Discount Percentage field. The field shows the percentage from the 
Global Discount Percentage option in the Default Project Options window. The global discount is 
applied to all components in the BOM. 

Step 3 To change the global discount percentage for an individual network component, click the 
Network Unit Discount cell of the component you wish to change, and enter a new discount percentage.

Table 2-15 describes the columns.
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2.9.2 Generating a Site BOM
Use the following steps to generate a BOM for a site.

Step 1 Right-click on a site and select Generate Site BOM. The Site BOM window (Figure 2-58) appears.

Table 2-15 BOM Window Columns

Column Label Description

Shelf ID Displays the ID string of the shelf (for site BOMs only).

Product ID Displays the ID string of the product.

Description Displays a description of the product.

Quantity Displays the number of specific products in the BOM.

Unit Price Displays the price per unit.

Network/Site Unit 
Discount

Displays the per unit discount amount that you assigned in the Global Discount 
Percentage field. If you leave the field blank, the discount amount is zero.

Total Price Displays the total price of the products before applying the discount.

Discounted Total 
Price

Displays the total price of the products after applying the discount.

Site Displays the number of products to be assigned to a particular site. The number 
of Site columns is the same as the number of sites in the network.
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Figure 2-58 Site BOM Window

Step 2 To change the discount percentage for a site component, click the Site Unit Discount cell of the 
component you wish to change, and enter a new discount percentage.

Table 2-15 describes the columns.

2.9.3 Exporting a BOM
MetroPlanner allows you to export the BOM to an external file (such as an HTML or text file).

Step 1 Click Export. The Save Table dialog box appears.

Step 2 Navigate to the destination folder and select or type the file name. MetroPlanner creates an HTML or 
text file containing the BOM.

Step 3 Click Save. To cancel saving the BOM, click Cancel. 

2.9.4 Importing a BOM to an Excel Spreadsheet 
You can import a BOM that has been exported to a text file into a Microsoft Excel spreadsheet. For 
information about creating BOM text files, see the “2.9.3 Exporting a BOM” section.

Step 1 Launch the MicroSoft Excel application.

Step 2 Select File > Open.
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Step 3 Select the saved BOM file. 

Step 4 The BOM information appears in the Excel spreadsheet (Figure 2-59).

Figure 2-59 BOM in Microsoft Excel Example

Step 5 To improve the formatting, increase the column widths.

2.9.5 Managing Network Spare Parts
After you generate the BOM, use the Spare Parts Manager to determine the spare parts required by the 
network.

Step 1 Select Tools > Spares Management > Network Spare Parts. The Spare Parts Manager window appears 
(Figure 2-60). To open the Spare Parts Manager window for a site, right-click the site and select 
Manage Site Spare Part from the shortcut menu.
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Figure 2-60 Spare Parts Manager Window

Step 2 Click Add Item to add an item to the Network (Site) Additional Spare List area. An empty row appears 
in the area. 

Step 3 Click the new row. The Spare Parts Manager List Dialog window (Figure 2-61) appears.

Figure 2-61 Spare Parts Manager List Dialog Window

Step 4 Select a product and click OK, or click Search to open the Find Item in Price List Table window 
(Figure 2-62). 
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Figure 2-62 Find Item in Price List Table Window

If you selected a product, it appears as a row in the Network (Site) Additional Spare List area. If you 
clicked search, complete the following substeps:

a. Enter a search criteria in the Find What field.

b. Select All Fields, Description, or Product from the Look In area.

c. Click Find, or click Cancel to close the window without performing a search. The Spare Parts 
Manager List Dialog window appears, with the item highlighted.

d. Select the product and click OK. The product appears as a row in the Network (Site) Additional 
Spare List area.

Step 5 To delete the item, select the row and click Delete Item.

Step 6 Click Update BOM Spare Parts to add the spare parts to the BOM. The BOM tab opens in the main 
window, displaying the spare parts in the lower portion of the tab.

Step 7 Click Export to File to save the list of spare parts to an external HTML or text file.

Step 8 Click Close to close the Spare Parts Manager window.

2.9.6 Establishing Maintenance Centers
You can identify maintenance centers that will supply your network with spare parts in the event of a 
failure. This feature helps your customer determine the quantity of spares that should be purchased, 
depending on their maintenance centers and their availability.

Step 1 Select Tools > Spares Management > Maintenance Center List. The Maintenance Center List window 
appears (Figure 2-63).
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Figure 2-63 Maintenance Centre List Window

Step 2 Click Add to add a maintenance center. A new row appears in the window.

Step 3 Enter the center name in the Centre Name field.

Step 4 Select the probability of finding the spare part in the selected maintenace center (represented by a 
percentage) from the Probability field. Probabilities are 50%, 75%, 95%, and 99%.

Step 5 Enter the approximate time it takes to stock a maintenance center with a part (represented in months) in 
the Reparation/Replacing field.

Step 6 To remove a maintenance center, select a center and click Remove.

Step 7 Click OK.

2.9.7 Viewing Maintenance Center Assignments
After creating and assigning maintenance centers, you can use the Network Maintenance Centres 
Assignment window to view all the maintenance center assignments for each site in the network.

Step 1 Select Tools > Spares Management > Maintenance Center Assignment. The Network Maintenance 
Centres Assignment window appears (Figure 2-64).
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Figure 2-64 Network Maintenance Centres Assignment Window

The window displays the site name, IP address, and assigned maintenance center of each site.

Step 2 To copy the information in the window, right-click any row and select Copy Table.

Step 3 To export the information to an external file, right-click any row and select Export Table. A Save Table 
window appears, allowing you to enter or select a file name for the exported information. You can save 
maintenance center assignment files as either HTML or text files.

Step 4 Click Save.

Step 5 Click OK to close the Network Maintenance Centres Assignment window.
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