Ethernet Card Software Feature and Configuration Guide for the Cisco ONS 15454 SDH, ONS 15454, and ONS 15327, Release 6.2
Chapter 17, Configuring Resilient Packet Ring
Downloads: This chapterpdf (PDF - 631.0KB) The complete bookPDF (PDF - 7.42MB) | Feedback

Configuring Resilient Packet Ring

Table Of Contents

Configuring Resilient Packet Ring

Understanding RPR

Role of SONET/SDH Circuits

Packet Handling Operations

Ring Wrapping

RPR Framing Process

MAC Address and VLAN Support

RPR QoS

CTM and RPR

Configuring RPR

Connecting the ML-Series Cards with Point-to-Point STS/STM Circuits

Configuring CTC Circuits for RPR

CTC Circuit Configuration Example for RPR

Configuring RPR Characteristics and the SPR Interface on the ML-Series Card

Assigning the ML-Series Card POS Ports to the SPR Interface

Creating the Bridge Group and Assigning the Ethernet and SPR Interfaces

RPR Cisco IOS Configuration Example

Verifying Ethernet Connectivity Between RPR Ethernet Access Ports

CRC threshold configuration and detection

Monitoring and Verifying RPR

Add an ML-Series Card into an RPR

Adding an ML-Series Card into an RPR

Delete an ML-Series Card from an RPR

Deleting an ML-Series Card from an RPR

Understanding RPR Link Fault Propagation

LFP Sequence

Propagation Delays

Configuring LFP

LFP Configuration Requirements

Monitoring and Verifying LFP

RPR Keep Alive

Configuring RPR Keep Alive

Monitoring and Verifying RPR Keep Alives

RPR Shortest Path

Configuring Shortest Path and Topology Discovery

Monitoring and Verifying Topology Discovery and Shortest Path Load Balancing

Understanding Dual RPR Interconnect

Configuring DRPRI

DRPRI IOS Configuration Example

Monitoring and Verifying DRPRI


Configuring Resilient Packet Ring



Note The terms "Unidirectional Path Switched Ring" and "UPSR" may appear in Cisco literature. These terms do not refer to using Cisco ONS 15xxx products in a unidirectional path switched ring configuration. Rather, these terms, as well as "Path Protected Mesh Network" and "PPMN," refer generally to Cisco's path protection feature, which may be used in any topological network configuration. Cisco does not recommend using its path protection feature in any particular topological network configuration.


This chapter describes how to configure resilient packet ring (RPR), RPR Link Fault Propagation, and Dual RPR Interconnect (DRPRI) for the ML-Series card.

This chapter contains the following major sections:

Understanding RPR

Configuring RPR

Monitoring and Verifying RPR

Add an ML-Series Card into an RPR

Delete an ML-Series Card from an RPR

Understanding RPR Link Fault Propagation

Configuring LFP

RPR Keep Alive

RPR Shortest Path

Understanding Dual RPR Interconnect

Configuring DRPRI

Understanding RPR

RPR is a new MAC protocol operating at the Layer 2 level. It is well suited for transporting Ethernet over a SONET/SDH ring topology and enables multiple ML-Series cards to become one functional network segment or shared packet ring (SPR). RPR overcomes the limitations of earlier schemes, such as IEEE 802.1D Spanning Tree Protocol (STP), IEEE 802.1W Rapid Spanning Tree Protocol (RSTP), and SONET/SDH, when used in this role. Although the IEEE 802.17 draft was used as reference for the Cisco ML-Series RPR implementation, the current ML-Series card RPR protocol does not comply with all clauses of IEEE 802.17.

Role of SONET/SDH Circuits

The ML-Series cards in an SPR must connect directly or indirectly through point-to-point STS/STM circuits. The point-to-point STS/STM circuits are configured on the ONS node and are transported over the ONS node's SONET/SDH topology with either protected or unprotected circuits.

On circuits unprotected by the SONET/SDH mechanism, RPR provides resiliency without using the capacity of the redundant protection path that a SONET/SDH protected circuit would require. This frees this capacity for additional traffic. RPR also utilizes the bandwidth of the entire ring and does not block segments like STP or RSTP.

Packet Handling Operations

When an ML-Series card is configured with RPR and is made part of an SPR, the ML-Series card assumes a ring topology. If a packet is not destined for network devices bridged through the Ethernet ports of a specific ML-Series card, the ML-Series card simply continues to forward this transit traffic along the SONET/SDH circuit, relying on the circular path of the ring architecture to guarantee that the packet will eventually arrive at the destination. This eliminates the need to queue and process the packet flowing through the nondestination ML-Series card. From a Layer 2 or Layer 3 perspective, the entire RPR looks like one shared network segment.

An ML-Series card configured with RPR has three basic packet-handling operations: bridge, pass-through, and strip. Figure 17-1 illustrates these operations. Bridging connects and passes packets between the Ethernet ports on the ML-Series and the packet-over-SONET/SDH (POS) ports used for the SONET/SDH circuit circling the ring. Pass-through lets the packets continue through the ML-Series card and along the ring, and stripping takes the packet off the ring and discards it.

The RPR protocol, using the transmitted packet's header information, allows the interfaces to quickly determine the operation that needs to be applied to the packet. It also uses both the source and destination addresses of a packet to choose a ring direction. Flow-based load sharing helps ensure that all packets populated with equal source-and destination-address pairs will be sent in the same direction, and arrive at their destination in the correct order. Ring direction also enables the use of spatial reuse to increase overall ring aggregate bandwidth. Unicast packets are destination stripped. Destination stripping provides the ability to have simultaneous flows of traffic between different parts of an RPR. Traffic can be concurrently transmitted bidirectionally between adjacent nodes. It can also can span multiple nodes, effectively reusing the same ring bandwidth. Multicast packets are source stripped.

The ML-Series card supports three load-balancing schemes for unicast packets. The port-based load balancing option maps even ports to the POS 0 interface and odd ports to the POS 1 interface. The default auto option balances the load based on the MAC addresses or source and destination addresses of the IP packet. The ML-Series card also supports an RPR shortest path option. This option is covered in detail in the "RPR Shortest Path" section.

Figure 17-1 RPR Packet Handling Operations

Ring Wrapping

RPR initiates ring wraps in the event of a fiber cut, node failure, node restoration, new node insertion, or other traffic problem. This protection mechanism redirects traffic to the original destination by sending it in the opposite direction around the ring after a link state change or after receiving SONET/SDH path level alarms. Ring wrapping on the ML-Series card allows convergence times of less than 50 ms for unicast and pass-through traffic. RPR convergence times are comparable to SONET/SDH and much faster than STP or RSTP.

RPR on the ML-Series card survives both unidirectional and bidirectional transmission failures within the ring. Unlike STP or RSTP, RPR restoration is scalable. Increasing the number of ML-Series cards in a ring does not increase the convergence time.

Ring wraps occur within 50 msec after the failure condition with the default spr wrap immediate configured. If spr wrap delay is configured, the wrap is delayed until the POS interface goes link-down. The link goes down after the time specified with the CLI pos trigger delay <msec>. If the circuits are VCAT then the Cisco IOS CLI command pos vcat defect delayed also needs to be configured. The delay helps ensure that when RPR is configured with SONET/SDH bandwidth protection, this Layer 1 protection has a chance to take effect before the Layer 2 RPR protection. If the interface goes down without a SONET error, then the carrier delay also take effect. Figure 17-2 illustrates ring wrapping.

Figure 17-2 RPR Ring Wrapping

In case of a ring failure, the ML-Series cards connected to the failed section of the RPR detect the failure through the SONET/SDH path alarms. When any ML-Series card receives this path-AIS signal, it wraps the POS interface that received the signal.


Note ML-Series card RPR convergence times might exceed 50 ms in the case of multiple failures in the same ring, if traffic passes through an ML-Series card configured with DRPRI (in active mode) during the reloading of the ML-Series card, or in the case of mismatched microcode images on ML-Series cards.



Note If the carrier delay time is changed from the default, the new carrier delay time must be configured on all the ML-Series card interfaces, including the SPR, POS, and Gigabit Ethernet or Fast Ethernet interfaces.



Note ML-Series card POS interfaces normally send an alarm for signal label mismatch failure in the ONS 15454 STS path overhead (PDI-P) to the far end when the POS link goes down or when RPR wraps. ML-Series card POS interfaces do not send PDI-P to the far-end when PDI-P is detected, when a remote defection indication alarm (RDI-P) is being sent to the far end, or when the only defects detected are generic framing procedure (GFP)-loss of frame delineation (LFD), GFP client signal fail (CSF), virtual concatenation (VCAT)-loss of multiframe (LOM), or VCAT-loss of sequence (SQM).


RPR Framing Process

The ML-Series card uses a proprietary RPR frame and HDLC or GFP-F framing. It attaches the RPR frame header to each Ethernet frame and encapsulates the RPR frame into the SONET/SDH payload for transport over the SONET/SDH topology. The RPR header is removed at the egress ML-Series card. Figure 17-3 illustrates the RPR frame.

Figure 17-3 RPR Frame for ML-Series Card

The RPR framing and header includes a number of fields, including four bytes for source and destination station information and another four bytes for RPR control and quality of service (QoS). Figure 17-4 illustrates the RPR frame format. Table 17-1 defines the most important fields.

Figure 17-4 RPR Frame Fields

Table 17-1 Definitions of RPR Frame Fields

Destination Station

An eight-bit field specifying the MAC address of a specific ML-Series card in the RPR as the destination. It has two well-known addresses, 0xff for Multicast DA-MAC and 0x00 for Unknown DA-MAC.

Source Station

An eight-bit field specifying the MAC address of a specific ML-Series card in the RPR as the source.

PRI

A three-bit QoS class of service (CoS) field that establishes RPR priority.

DE

A one-bit field for the discard eligible flag.

TTL

A nine-bit field for the frame's time to live.

Type

A field indicating whether the packet is data or control.


MAC Address and VLAN Support

RPR increases the total number of MAC addresses supported because the MAC IDs of packets that pass through an ML-Series card are not recorded by that ML-Series card. The ML-Series card only records the MAC IDs of the packets that are bridged or stripped by that ML-Series card. This allows a greater number of MAC addresses in the collective address tables of the RPR.

VLANs on RPR require less interface configuration than VLANs on STP and RSTP, which require configuration on all the POS interfaces in the ring. RPR VLANs only require configuration on SPR interfaces that bridge or strip packets for that VLAN.

The ML-Series card still has an architectural maximum limit of 255 VLAN/bridge-group per ML-Series card. But because the ML-Series card only needs to maintain the MAC address of directly connected devices, a greater total number of connected devices are allowed on an RPR network.

RPR QoS

The ML-Series card's RPR relies on the QoS features of the ML-Series card for efficient bandwidth utilization with service level agreement (SLA) support. ML-Series card QoS mechanisms apply to all SONET/SDH traffic on the ML-Series card, whether passed-through, bridged, or stripped. For detailed RPR QoS information see the QoS on RPR section of Chapter 14 "Configuring Quality of Service."

CTM and RPR

The Cisco Transport Manager (CTM) is an element management system (EMS) designed to integrate into an overall network management system (NMS) and interface with other higher level management tools. CTM supports RPR provisioning on ML-Series cards. For more information, refer to the Cisco Transport Manager User Guide at:

http://www.cisco.com/en/US/products/sw/opticsw/ps2204/products_user_guide_list.html

Configuring RPR

You need to use both CTC and Cisco IOS to configure RPR for the ML-Series card. CTC is the graphical user interface (GUI) that serves as the enhanced craft tool for specific ONS node operations, including the provisioning of the point-to-point SONET/SDH circuits required for RPR. Cisco IOS is used to configure RPR on the ML-Series card and its interfaces.

Successfully creating an RPR requires several consecutive procedures:

1. Connecting the ML-Series Cards with Point-to-Point STS/STM Circuits (CTC or TL1)

2. Configuring CTC Circuits for RPR (CTC or TL1)

3. Configuring RPR Characteristics and the SPR Interface on the ML-Series Card (Cisco IOS)

4. Assigning the ML-Series Card POS Ports to the SPR Interface (Cisco IOS)

5. Creating the Bridge Group and Assigning the Ethernet and SPR Interfaces (Cisco IOS)

6. Verifying Ethernet Connectivity Between RPR Ethernet Access Ports (Cisco IOS)

7. CRC threshold configuration and detection


Note Transaction Language One (TL1) can be used to provision the required SONET/SDH point-to-point circuits instead of CTC.


Connecting the ML-Series Cards with Point-to-Point STS/STM Circuits

You connect the ML-Series cards in an RPR through point-to-point STS/STM circuits. These circuits use the ONS 15454 SONET/SDH network and are provisioned using CTC in the normal manner for provisioning optical circuits.

Configuring CTC Circuits for RPR

These are the guidelines for configuring the CTC circuits required by RPR:

Leave all CTC Circuit Creation Wizard options at their default settings, except Fully Protected Path in the Circuit Routing Preferences dialog box. Fully Protected Path provides SONET/SDH protection and should be unchecked. RPR normally provides the Layer 2 protection for SPR circuits.

Check Using Required Nodes and Spans to route automatically in the Circuit Routing Preferences dialog box. If the source and destination nodes are adjacent on the ring, exclude all nodes except the source and destination in the Circuit Routing Preferences dialog box. This forces the circuit to be routed directly between source and destination and preserves STS/STM circuits, which would be consumed if the circuit routed through other nodes in the ring. If there is a node or nodes that do not contain an ML-Series card between the two nodes containing ML-Series cards, include this node or nodes in the included nodes area in the Circuit Routing Preference dialog box, along with the source and destination nodes.

Keep in mind that ML-Series card STS/STM circuits do not support unrelated circuit creation options, such as the following check box titles in CTC, unidirectional traffic, creating cross-connects only (TL1-like), interdomain (unified control plane [UCP]), protected drops, subnetwork connection protection (SCNP), or path protection selectors.

A best practice is to configure SONET/SDH circuits in an east-to-west or west-to-east configuration, from Port 0 (east) to Port 1 (west) or Port 1 (east) to Port 0 (west), around the SONET/SDH ring. Do not configure Port 0 to Port 0 or Port 1 to Port 1. The east-to-west or west-to-east setup is also required in order for the CTM network management software to recognize the ML-Series configuration as an SPR.

Detailed CTC circuit procedures are available in the "Create Circuits and VT Tunnels" chapter of the Cisco ONS 15454 Procedure Guide and the "Create Circuits and Tunnels" chapter of the Cisco ONS 15454 SDH Procedure Guide.

CTC Circuit Configuration Example for RPR

Figure 17-5 illustrates an example of a three-node RPR.

Figure 17-5 Three Node RPR Example

The three-node RPR in Figure 17-5 is used for all of the examples in the consecutive RPR procedures. Combining the examples will give you an end-to-end example of creating an RPR. It is assumed that the SONET/SDH node and its network is already active.


Caution The specific steps in the following procedure are for the topology shown in the example. Your own specific steps will vary according to your network. Do not attempt this procedure without obtaining a detailed plan or method of procedure from an experienced network architect.

To configure the circuits, you need to create three circuits in CTC:

Create a circuit from Node 1, POS Port 0 to Node 2, POS Port 1.

Create a circuit from Node 2, POS Port 0 to Node 3, POS Port 1.

Create a circuit from Node 3, POS Port 0 to Node 1, POS Port 1.


Step 1 In CTC, log into Node 1 and navigate to the CTC card view for the ML-Series card that will be in the RPR.

Figure 17-6 CTC Card View for ML-Series Card

Step 2 Click the Circuits > Create tabs.

The first page of the Circuit Creation wizard appears.

Figure 17-7 CTC Circuit Creation Wizard

Step 3 In the Circuit Type list, select STS.

Step 4 Click Next.

The Circuit Attributes page appears.

Step 5 Type a circuit name in the Name field.

Step 6 Select the relevant size of the circuit from the Size drop-down list, and the appropriate state from the State list.

Step 7 Verify the SD threshold is set to 1E-6 (default) or in the 1E-6 to 1E-9 range in the SD threshold field.

a. If the SD threshold is the default 1E-6 or within the acceptable range, proceed to Step 8.

b. If the SD threshold is not the default 1E-6 or within the acceptable range, select 1E-6 or a threshold within the acceptable range from the menu.


Note Lower SD thresholds increase the speed of CTC convergence, but also increase the possibility of interface flapping (repeatedly enabling and disabling) in some situations.


Step 8 Click Next.

The Source page appears.

Step 9 Select Node 1 as the source node from the node drop-down list.

Step 10 Select the ML-Series card from the Slot drop-down list, and choose 0 (POS) from the Port drop-down list.

Step 11 Click Next.

The Destination page appears.

Step 12 Select Node 2 as the destination node from the Node drop-down list.

Step 13 Select the ML-Series card from the Slot drop-down list, and choose 1 (POS) from the Port drop-down list.

Step 14 Click Next.

The Circuit Routing Preferences page appears.

Step 15 Uncheck the Fully Protected Path check box.

Step 16 Click Next.

The Circuit Constraints for Automatic Routing page appears.

Step 17 Click the Node 1 icon to select it and click Next.

The Route Review/Edit page appears.

Step 18 Click Finish.

You have now completed the initial circuit for the RPR.


Note A TPTFAIL alarm might appear on CTC when the circuit is created. This alarm will disappear after the POS ports are enabled during the "Assigning the ML-Series Card POS Ports to the SPR Interface" procedure.


Step 19 Build the second circuit between POS 0 on Node 2 and POS 1 on Node 3. Use the same procedure described in Steps 1 through 18, but substitute Node 2 for Node 1 and Node 3 for Node 2.

Step 20 Build the third circuit between POS 0 on Node 3 and POS 1 on Node 1. Use the same procedure described in Steps 1 through 18, but substitute Node 3 for Node 1 and Node 1 for Node 2.

Now all of the POS ports in all three nodes are connected by STS point-to-point circuits in an east-to-west pattern, as shown in Figure 17-5.

Step 21 The CTC circuit process is complete.


Configuring RPR Characteristics and the SPR Interface on the ML-Series Card

You configure RPR on the ML-Series cards by creating an SPR interface using the Cisco IOS command-line interface (CLI). The SPR interface is a virtual interface for the SPR. An ML-Series card supports a single SPR interface with a single MAC address. It provides all the normal attributes of a Cisco IOS virtual interface, such as support for default routes.

An SPR interface is configured similarly to a EtherChannel (port-channel) interface. Instead of using the channel-group command to define the members, you use the spr-intf-id command. Like the port-channel interface, you configure the virtual SPR interface instead of the physical POS interface. An SPR interface is considered a trunk port, and like all trunk ports, subinterfaces must be configured for the SPR interface for it to join a bridge group.

The physical POS interfaces on the ML-Series card are the only members eligible for the SPR interface. One POS port is associated with the SONET/SDH circuit heading east around the ring from the node, and the other POS port is associated with the circuit heading west. When the SPR interface is used and the POS ports are associated, RPR encapsulation is used on the SONET/SDH payload.


Caution In configuring an SPR, if one ML-Series card is not configured with an SPR interface, but valid STS/STM circuits connect this ML-Series card to the other ML-Series cards in the SPR, no traffic will flow between the properly configured ML-Series cards in the SPR, and no alarms will indicate this condition. Cisco recommends that you configure all of the ML-Series cards in an SPR before sending traffic.


Caution Do not use native VLANs for carrying traffic with RPR.


Note RPR on the ML-Series card is only supported with the default LEX encapsulation, a special CISCO-EOS-LEX encapsulation for use with Cisco ONS Ethernet line cards.


RPR needs to be provisioned on each ML-Series card that is in the RPR. To provision RPR, perform the following procedure, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# bridge irb

Enables the Cisco IOS software to both route and bridge a given protocol on separate interfaces within a single ML-Series card.

Step 2 

Router(config)# interface spr 1

Creates the SPR interface on the ML-Series card or enters the SPR interface configuration mode. The only valid SPR number is 1.

Step 3 

Router(config-if)# spr station-id 
station-ID-number

Configures a station ID. The user must configure a different number for each SPR interface that attaches to the RPR. Valid station ID numbers range from 1 to 254.

Step 4 

Router(config-if)# spr wrap 
immediate | delayed }

(Optional) Sets the RPR ring wrap mode to either wrap traffic the instant it detects a SONET/SDH path alarm or to wrap traffic after the 200 msec delay, which gives the SONET/SDH protection time to register the defect and declare the link down. Use immediate if RPR is running over unprotected SONET/SDH circuits. Use delayed for bidirectional line switched rings (BLSR), path protection, multiplex section-shared protection ring (MS-SPRing), or SNCP protected circuits.

The default setting is immediate.

Step 5 

Router(config-if)# carrier-delay msec 
milliseconds

(Optional) Sets the carrier delay time. The default setting is 200 milliseconds, which is optimum for SONET/SDH protected circuits.

Note If the carrier delay time is changed from the default, the new carrier delay time must be configured on all the ML-Series card interfaces, including the SPR, POS, and Gigabit Ethernet or Fast Ethernet interfaces.

Step 6 

Router(config-if)# [no] spr 
load-balance { auto | port-based } 

(Optional) Specifies the RPR load-balancing scheme for unicast packets. The port-based load balancing option maps even ports to the POS 0 interface and odd ports to the POS 1 interface. The default auto option balances the load based on the MAC addresses or source and destination addresses of the IP packet.

Step 7 

Router(config-if)# end

Exits to privileged EXEC mode.

Step 8 

Router# copy running-config 
startup-config

(Optional) Saves configuration changes to NVRAM.

Assigning the ML-Series Card POS Ports to the SPR Interface


Caution The SPR interface is the routed interface. Do not enable Layer 3 addresses or assign bridge groups on the POS interfaces assigned to the SPR interface.


Caution When traffic coming in on an SPR interface needs to be policed, the same input service policy needs to be applied to both POS ports that are part of the SPR interface.

The POS ports require LEX encapsulation to be used in RPR. The first step of RPR configuration is to set the encapsulation of POS 0 and POS 1 ports to LEX.

Each of the ML-Series card's two POS ports must also be assigned to the SPR interface. To configure LEX encapsulation and assign the POS interfaces on the ML-Series card to the SPR, perform the following procedure, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos 0

Enters the interface configuration mode to configure the first POS interface that you want to assign to the SPR.

Step 2 

Router(config-if)# encapsulation lex

Sets POS interface encapsulation as LEX (default). RPR on the ML-Series card requires LEX encapsulation.

Step 3  (

Router(config-if)# spr-intf-id 
shared-packet-ring-number

Assigns the POS interface to the SPR interface. The shared packet ring number must be 1, which is the only shared packet ring number that you can assign to the SPR interface.

Step 4 

Router(config-if)# carrier-delay msec 
milliseconds 

(Optional) Sets the carrier delay time. The default setting is 200 msec, which is optimum for SONET/SDH protected circuits.

Note The default unit of time for setting the carrier delay is seconds. The msec command resets the time unit to milliseconds.

Step 5 

Router(config-if)# pos trigger defect 
ber_sd-b3

(Optional) Configures a trigger to bring down the POS interface when the SONET/SDH bit error rate exceeds the threshold set for the signal degrade alarm. Bringing the POS interface down initiates the RPR wrap.

This command is recommended for all RPR POS interfaces, since excessive SONET/SDH bit errors can cause packet loss on RPR traffic.


Note This command should not be used when a Cisco ONS 15310 is part of the ring. It may cause inconsistent RPR wrapping.


Step 6 

Router(config-if)# no shutdown

Enables the POS port.

Step 7 

Router(config-if)# interface pos 1

Enters the interface configuration mode to configure the second POS interface that you want to assign to the SPR.

Step 8 

Router(config-if)# encapsulation lex

Sets POS interface encapsulation as LEX (default). RPR on the ML-Series card requires LEX encapsulation.

Step 9 

Router(config-if)# spr-intf-id 
shared-packet-ring-number

Assigns the POS interface to the SPR interface. The shared packet ring number must be 1 (the same shared packet ring number that you assigned in Step 3), which is the only shared packet ring number that you can assign to the SPR interface.

Step 10 

Router(config-if)# carrier-delay msec 
milliseconds

(Optional) Sets the carrier delay time. The default setting is 200 milliseconds, which is optimum for SONET/SDH protected circuits.

Step 11 

Router(config-if)# pos trigger defect 
ber_sd-b3

(Optional) Configures a trigger to bring down the POS interface when the SONET/SDH bit error rate exceeds the threshold set for the signal degrade alarm. Bringing the POS interface down initiates the RPR wrap.

This command is recommended for all RPR POS interfaces since excessive SONET/SDH bit errors can cause packet loss on RPR traffic.

Step 12 

Router(config-if)# no shutdown

Enables the POS port.

Step 13 

Router(config-if)# end

Exits to privileged EXEC mode.

Step 14 

Router# copy running-config 
startup-config

(Optional) Saves the configuration changes to NVRAM.

Creating the Bridge Group and Assigning the Ethernet and SPR Interfaces

The default behavior of the ML-Series cards is that no traffic is bridged over the RPR even with the interfaces enabled. This is in contrast to many Layer 2 switches, including the Cisco Catalyst 6500 and the Cisco Catalyst 7600, which forward VLAN 1 by default. The ML-Series card will not forward any traffic by default, including untagged or VLAN 1 tagged packets.

For any RPR traffic to be bridged on an ML-Series card, a bridge group needs to be created for that traffic. Bridge groups maintain the bridging and forwarding between the interfaces on the ML-Series card and are locally significant. Interfaces not participating in a bridge group cannot forward bridged traffic.

To create a bridge group for RPR, you determine which Ethernet interfaces need to be in the same bridge group, create the bridge group, and associate these interfaces with the bridge group. Then associate the SPR interface with the same bridge group to provide transport across the RPR infrastructure.

Figure 17-8 illustrates a bridge group spanning the ML-Series card interfaces, including the SPR virtual interface of RPR.

Figure 17-8 RPR Bridge Group


Caution All Layer 2 network redundant links (loops) in the connecting network, except the RPR topology, must be removed for correct RPR operation. Or if loops exist, you must configure STP/RSTP.

To configure the needed interfaces, perform the following procedure, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type number

Enters interface configuration mode for the Ethernet interface joining the bridge group.

Step 2 

Router(config-if)# no shutdown

Enables the interface.

Step 3 

Router(config-if)# bridge-group 
bridge-group-number

Creates the specified bridge group and assigns the bridge group to the interface. Creating the bridge from the interface configuration disables STP or RSTP (spanning-disabled), which is recommended for RPR.

Step 4 

Router(config)# interface spr1
 
        

Enters interface configuration mode for the SPR

Step 5 

Router(config-subif)# bridge-group 
bridge-group-number

Associates the SPR interface to the specified bridge group.

RPR Cisco IOS Configuration Example

Figure 17-5 shows a complete example of an RPR Cisco IOS configuration. The associated Cisco IOS code is provided in Examples 17-1, 17-2, and 17-3. The configuration assumes that ML-Series card POS ports are already linked by point-to-point SONET/SDH circuits configured through CTC.

Example 17-1 SPR Station-ID 1 Configuration

bridge irb
 
   
interface SPR1
no ip address
no keepalive
spr station-id 1 
bridge-group 10
bridge-group 10 spanning-disabled
hold-queue 150 in
 
   
interface GigabitEthernet0
no ip address
bridge-group 10
bridge-group 10 spanning-disabled
 
   
interface GigabitEthernet1
no ip address
shutdown
 
   
interface POS0
no ip address
carrier-delay msec 0
spr-intf-id 1
crc 32
 
   
interface POS1
no ip address
carrier-delay msec 0
spr-intf-id 1
crc 32
!

Example 17-2 SPR Station-ID 2 Configuration

bridge irb
 
   
interface SPR1
no ip address
no keepalive
spr station-id 2 
bridge-group 10
bridge-group 10 spanning-disabled
 
   
interface GigabitEthernet0
no ip address
bridge-group 10
bridge-group 10 spanning-disabled
 
   
interface GigabitEthernet1
no ip address
shutdown
 
   
interface POS0
no ip address
shutdown
spr-intf-id 1
crc 32
 
   
interface POS1
no ip address
spr-intf-id 1
crc 32

Example 17-3 SPR Station-ID 3 Configuration

bridge irb
 
   
interface SPR1
no ip address
no keepalive
spr station-id 3 
bridge-group 10
bridge-group 10 spanning-disabled
hold-queue 150 in
 
   
interface GigabitEthernet0
no ip address
bridge-group 10
bridge-group 10 spanning-disabled
 
   
interface GigabitEthernet1
no ip address
shutdown
 
   
interface POS0
no ip address
spr-intf-id 1
crc 32
 
   
interface POS1
no ip address
spr-intf-id 1
crc 32
!

Verifying Ethernet Connectivity Between RPR Ethernet Access Ports

After successfully completing the procedures to provision an RPR, you can test Ethernet connectivity between the Ethernet access ports on the separate ML-Series cards using your standard Ethernet connectivity testing.

CRC threshold configuration and detection

You can configure a span shutdown when the ML-Series card receives CRC errors at a rate that exceeds the configured threshold and configured soak time. For this functionality to work in an SPR ring, make the configurations on the POS members of SPR interface as specified in CRC Threshold Configuration.

Monitoring and Verifying RPR

After RPR is configured, you can monitor its status using the show interface spr 1 command (Example 17-4) or the show run interface spr 1 command (Example 17-5).

Example 17-4 Example of show interface spr 1 Output

ML-Series# show interfaces spr 1
 
   
SPR1 is up, line protocol is up 
  Hardware is POS-SPR, address is 0005.9a39.77f8 (bia 0000.0000.0000)
  MTU 1500 bytes, BW 290304 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation: Cisco-EoS-LEX, loopback not set
  Keepalive not set
  DTR is pulsed for 27482 seconds on reset, Restart-Delay is 65 secs
  ARP type: ARPA, ARP Timeout 04:00:00
    No. of active members in this SPR interface: 2 
        Member 0 : POS1 
        Member 1 : POS0 
  Last input 00:00:38, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/80 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     37385 packets input, 20993313 bytes
     Received 0 broadcasts (0 IP multicast)
     0 runts, 0 giants, 0 throttles
              0 parity
     2 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     37454 packets output, 13183808 bytes, 0 underruns
     0 output errors, 0 applique, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

Example 17-5 Example of show run interface spr 1 Output

ML-Series# show run interface spr 1
 
   
Building configuration...
Current configuration : 141 bytes
interface SPR1
 no ip address
 no keepalive
 spr station-id 2 
 bridge-group 10
 bridge-group 10 spanning-disabled
 hold-queue 150 in
end

Add an ML-Series Card into an RPR

An existing RPR might need an ML-Series card added. This can be done without taking down data traffic due to the RPR wrapping capability and ring architecture. You can add the ML-Series card in concert with the addition of the node containing the card into the underlying SONET/SDH architecture. You can also add an ML-Series card to a node that is already part of the SONET/SDH topology.

The following example has a two-node RPR with two STS circuits connecting the ML-Series cards. One circuit will be deleted. The RPR will wrap traffic on the remaining circuit with as little as a one ping loss. The third node and ML-Series card are then added in, and the spans and circuits for this card are created.

Figure 17-9 shows the existing two-node RPR with the single STS circuit and span that will be deleted. Figure 17-10 shows the RPR after the third node is added with the two new STS circuits and spans that will be added.

Figure 17-9 Two-Node RPR Before the Addition

Figure 17-10 Three Node RPR After the Addition

To add an ML-Series card to the RPR, you need to complete several general actions:

Force away any existing non-ML-Series card circuits, such as DS-1, that use the span that will be deleted.

Shut down the POS ports on the adjacent ML-Series cards for the STS circuit that will be deleted to initiate the RPR wrap.

Test Ethernet connectivity between the access ports on the existing adjacent ML-Series cards with a test set to ensure that the RPR wrapped successfully.

Delete the STS circuit that will be replaced by the new circuits. (In Figure 17-9, this is the circuit between Adjacent Node 2, POS 0 and Adjacent Node 1, POS 1.)

Insert the new node into the ring topology if the node is not already part of the topology.

Install the ML-Series card and load your initial configuration file or otherwise do an initial configuration of the ML-Series card.

Ensure the new node is configured with RPR before its POS ports are manually enabled or enabled through the configuration file.

Create an STS circuit from one of the POS ports of an existing adjacent ML-Series card to a POS port on the new ML-Series card. (In Figure 17-10, this is the circuit between Adjacent Node 2, POS Port 0 and New Node, POS Port 1.)

Create a second STS circuit from one of the POS ports of the other existing adjacent ML-Series card to the remaining POS port on the new ML-Series card. (In Figure 17-10, this is the circuit between New Node, POS Port 0 and Adjacent Node 1, POS Port 1.)

Configure the new ML-Series card to join the RPR and enable the POS ports, if the initial configuration file did not already do this.

Enable the POS ports on the existing adjacent ML-Series cards that connect to the new ML-Series card. (In Figure 17-10, these are Adjacent Node 1, POS Port 1 and Adjacent Node 2, POS Port 0.)

Test Ethernet connectivity between the access ports on the new ML-Series card with a test set to validate the newly created three-node RPR.

Monitor Ethernet traffic and existing routing protocols for at least an hour after the node insertion.


Caution The specific steps in the following procedure are for the topology in the example. Your own steps will vary according to your network design. Do not attempt this procedure without obtaining a detailed plan or method of procedure from an experienced network architect.

Adding an ML-Series Card into an RPR

To add an ML-Series card to the RPR in the example, complete the following procedure:


Step 1 Start a Cisco IOS CLI session for the ML-Series card in the first adjacent node. This is Adjacent Node 1 in Figure 17-9.

Step 2 Complete the following Cisco IOS configuration on the ML-Series card in the first adjacent node, beginning in global configuration mode:

a.

Router(config)# interface pos 
interface-number

Enters interface configuration mode for the POS port at one endpoint of the circuit to be deleted.

b.

Router(config-if)# shutdown

Closes the interface, which initiates the RPR wrap.

Step 3 Start a Cisco IOS CLI session for the ML-Series card in Adjacent Node 2, as shown in Figure 17-9.

Step 4 Complete the following Cisco IOS configuration on the Adjacent Node 2 ML-Series card, beginning in global configuration mode:

a.

Router(config)# interface pos 
interface-number

Enters interface configuration mode for the POS port at one endpoint of the circuit to be deleted.

b.

Router(config-if)# shutdown

Closes the interface.

Step 5 In CTC, log into Adjacent Node 1.

Step 6 Double-click the ML-Series card in Adjacent Node 1.

The card view appears.

Step 7 Click the Circuits tab.

Step 8 Click the Circuits subtab.

Step 9 Identify the appropriate STS circuit by looking under the source column and destination column for the circuit entry that matches the POS ports at the endpoints of the circuit to be deleted.

The circuit entry is in node-name/card-slot/port-number format, such as Node-1/s12(ML100T)/pPOS-0.

Step 10 Click the circuit entry to highlight it.

Step 11 Click Delete.

A confirmation dialog box appears.

Step 12 Click Yes.

Step 13 Use a test set to verify that Ethernet connectivity still exists between the Ethernet access ports on Adjacent Node 1 and Adjacent Node 2.


Note The SPR interface and the Ethernet interfaces on the ML-Series card must be in a bridge group in order for RPR traffic to bridge the RPR.


Step 14 If the new node is not already an active node in the SONET/SDH ring topology, add the node to the ring. Refer to the "Add and Remove Nodes" chapter of the Cisco ONS 15454 Procedure Guide or the "Add and Remove Nodes" chapter of the Cisco ONS 15454 SDH Procedure Guide for procedures for installing ONS nodes.

Step 15 If the ML-Series card in the new node is not already installed, install the card in the node. Refer to the "Install Cards and Fiber-Optic Cable" chapter of the Cisco ONS 15454 Procedure Guide or the "Install Cards and Fiber-Optic Cable" chapter of the Cisco ONS 15454 SDH Procedure Guide for procedures for installing cards in ONS nodes.

Step 16 Upload the initial startup configuration file for the new ML-Series card (see the "CTC and the Startup Configuration File" section.) If you do not have a prepared startup configuration file, see the "Manually Creating a Startup Configuration File Through the Serial Console Port" section.


Caution Ensure the new node is configured with RPR before its POS ports are manually enabled or enabled through the configuration file.

Step 17 Build an STS circuit with a circuit state of In Service (IS) from the available POS port on Adjacent Node 1 to the New Node, as shown in Figure 17-10. On the New Node, use the POS port with the interface-number that does not match the interface-number of the available POS port on Adjacent Node 1. For example, POS Port 0 on Adjacent Node 1would connect to POS Port 1 on the New Node.

For detailed steps for building the circuit, see the "Configuring CTC Circuits for RPR" section.


Note A best practice is to configure SONET/SDH circuits in an east-to-west or west-to-east configuration, from Port 0 (east) to Port 1 (west) or Port 1 (east) to Port 0 (west), around the SONET/SDH ring.


Step 18 Build an STS circuit with a circuit state of IS from the available POS port on Adjacent Node 2 to the remaining POS port on the New Node, as shown in Figure 17-10.

Step 19 Start or resume a Cisco IOS CLI session for the ML-Series card in Adjacent Node 1, as shown in Figure 17-9.

Step 20 Complete the following Cisco IOS configuration, beginning in global configuration mode:

a.

Router(config)# interface pos 
interface-number

Enters interface configuration mode for the POS port at one endpoint of the first newly created circuit.

b.

Router(config-if)# no shutdown

Enables the port.

Step 21 Start a Cisco IOS CLI session for the ML-Series card in Adjacent Node 2, as shown in Figure 17-9.

Step 22 Complete the following Cisco IOS configuration on the Adjacent Node 2 ML-Series card, beginning in global configuration mode:

a.

Router(config)# interface pos 
interface-number

Enters interface configuration mode for the POS port at one endpoint of the second newly created circuit.

b.

Router(config-if)# no shutdown

Enables the port.

Step 23 Use a test set to verify that Ethernet connectivity exists on the RPR.

Step 24 Monitor Ethernet traffic and routing tables for at least one hour after the node insertion.

Stop. You have completed this procedure.


Delete an ML-Series Card from an RPR

An existing RPR might need an ML-Series card deleted. This can be done without taking down data traffic due to the RPR wrapping capability and ring architecture.

The following example has a three-node RPR with three STS circuits connecting the ML-Series cards. Two circuits will be deleted. The RPR will wrap traffic on the remaining circuit with as little as a one ping loss. The third node and ML-Series card are then deleted and a new STS circuit is created between the two remaining cards.

Figure 17-11 shows the existing three-node RPR with all three STS circuits and spans. Figure 17-12 shows the RPR after the third node, circuits, and spans are deleted and the new STS circuit and span are added.

Figure 17-11 Three Node RPR Before the Deletion

Figure 17-12 Two Node RPR After the Deletion

To delete an ML-Series card from the RPR, you need to complete several general actions:

Shut down the POS ports on the ML-Series card to be deleted with the POS interface level configuration shut command.

Force away any existing non-ML-Series card circuits, such as DS-1, that use the spans that will be deleted.

Shut down the POS ports on the adjacent ML-Series cards for the STS circuits that will be deleted to initiate the RPR wrap.

Test Ethernet connectivity between the access ports on the existing adjacent ML-Series cards with a test set to ensure that the RPR wrapped successfully.

Delete the two STS circuits that will be replaced by the new circuits. (In Figure 17-11, this is the circuit between the Delete Node and one Adjacent Node, and the circuit between the Delete Node and the other Adjacent Node.)

Remove the Delete Node from the ring topology if desired.

Physically remove the delete ML-Series card from the node if desired.

Create an STS circuit from the available POS port of one of the remaining adjacent ML-Series cards to the available POS port on the other remaining adjacent ML-Series card. (In Figure 17-12, this is the circuit between Adjacent Node 2, POS Port 0 and Adjacent Node 1, POS Port 1.)

Enable the POS ports on the existing adjacent ML-Series cards.(In Figure 17-12, this is the Adjacent Node 2, POS Port 0 and the Adjacent Node 1, POS Port 1.)

Test Ethernet connectivity between the access ports on the adjacent ML-Series card with a test set to validate the two-node RPR.

Monitor Ethernet traffic and existing routing protocols for at least an hour after the node deletion.


Caution When taking an ML-Series card POS port out of an in-service RPR, you must first shut down the POS interface using the POS interface level configuration shut command. Do this before entering any addition commands.


Caution The specific steps in the following procedure are for the topology in the example. Your own steps will vary according to your network design. Do not attempt this procedure without obtaining a detailed plan or method of procedure from an experienced network architect.

Deleting an ML-Series Card from an RPR

To delete an ML-Series card from an RPR, complete the following procedure:


Step 1 Start a Cisco IOS CLI session for the ML-Series card on the delete node. This is the Delete Node in Figure 17-11.

Step 2 Complete the following Cisco IOS configuration on the ML-Series card in the node to be deleted, beginning in global configuration mode:

a.

Router(config)# interface pos 0

Enters interface configuration mode for the POS port 0 on the Delete Node.

b.

Router(config-if)# shutdown

Closes the interface.

c.

Router(config)# interface pos 1

Enters interface configuration mode for the POS port 1 on the Delete Node.

d.

Router(config-if)# shutdown

Closes the interface.

Step 3 Start a Cisco IOS CLI session for the ML-Series card on the first adjacent node. This is Adjacent Node 1 in Figure 17-11.

Step 4 Complete the following Cisco IOS configuration on the ML-Series card in the first adjacent node, beginning in global configuration mode:

a.

Router(config)# interface pos 
interface-number

Enters interface configuration mode for the POS port at the end of the circuit directly connected to the Delete Node.

b.

Router(config-if)# shutdown

Closes the interface, which initiates the RPR wrap.

Step 5 Start a Cisco IOS CLI session for the ML-Series card in Adjacent Node 2, as shown in Figure 17-11.

Step 6 Complete the following Cisco IOS configuration on the Adjacent Node 2 ML-Series card, beginning in global configuration mode:

a.

Router(config)# interface pos 
interface-number

Enters interface configuration mode for the POS port at the end of the circuit directly connected to the Delete Node.

b.

Router(config-if)# shutdown

Closes the interface.

Step 7 Log into Adjacent Node 1 with CTC.

Step 8 Double-click the ML-Series card in Adjacent Node 1.

The card view appears.

Step 9 Click the Circuits tab.

Step 10 Click the Circuits subtab.

Step 11 Identify the appropriate STS circuit by looking under the source column and destination column for the circuit entry that matches the POS ports at the endpoints of the first circuit to be deleted.

The circuit entry is in node-name/card-slot/port-number format, such as Node-1/s12(ML100T)/pPOS-0.

Step 12 Click the circuit entry to highlight it.

Step 13 Click Delete.

A confirmation dialog box appears.

Step 14 Click Yes.

Step 15 Verify that Ethernet connectivity still exists between the Ethernet access ports on Adjacent Node 1 and Adjacent Node 2 by using a test set.


Note The SPR interface and the Ethernet interfaces on the ML-Series card must be in a bridge group in order for RPR traffic to bridge the RPR.


Step 16 Log into Adjacent Node 2 with CTC.

Step 17 Double-click the ML-Series card in Adjacent Node 2.

The card view appears.

Step 18 Click the Circuits tab.

Step 19 Click the Circuits subtab.

Step 20 Identify the appropriate STS circuit by looking under the source column and destination column for the circuit entry that matches the POS ports at the endpoints of the second circuit to be deleted.

The circuit entry is in node-name/card-slot/port-number format, such as Node-1/s12(ML100T)/pPOS-0.

Step 21 Click the circuit entry to highlight it.

Step 22 Click Delete.

The confirmation dialog box appears.

Step 23 Click Yes.

Step 24 If the new node will no longer be an active node in the SONET/SDH ring topology, delete the node from the ring. Refer to the "Add and Remove Nodes" chapter of the Cisco ONS 15454 Procedure Guide or the "Add and Remove Nodes" chapter of the Cisco ONS 15454 SDH Procedure Guide for procedures for removing ONS nodes.

Step 25 If the ML-Series card in the new node is to be deleted in CTC and physically removed, do so now. Refer to the "Install Cards and Fiber-Optic Cable" chapter of the Cisco ONS 15454 Procedure Guide or the "Install Cards and Fiber-Optic Cable" chapter of the Cisco ONS 15454 SDH Procedure Guide for procedures for installing cards in ONS nodes.

Step 26 Build an STS circuit with a circuit state of IS from the available POS port on Adjacent Node 1 to the available POS port on Adjacent Node 2, as shown in Figure 17-12. For detailed steps on building the circuit, see "Configuring CTC Circuits for RPR" section.


Note A best practice is to configure SONET/SDH circuits in an east-to-west or west-to-east configuration, from Port 0 (east) to Port 1 (west) or Port 1 (east) to Port 0 (west), around the SONET/SDH ring.


Step 27 Start or resume a Cisco IOS CLI session for the ML-Series card in Adjacent Node 1.

Step 28 Complete the following Cisco IOS configuration for the ML-Series card in Adjacent Node 1, beginning in global configuration mode:

a.

Router(config)# interface pos 
interface-number

Enters interface configuration mode for the POS port at one endpoint of the first newly created circuit.

b.

Router(config-if)# no shutdown

Enables the port.

Step 29 Start a Cisco IOS CLI session for the ML-Series card in Adjacent Node 2.

Step 30 Complete the following Cisco IOS configuration on the Adjacent Node 2 ML-Series card, beginning in global configuration mode:

a.

Router(config)# interface pos 
interface-number

Enters interface configuration mode for the POS port at one endpoint of the second newly created circuit.

b.

Router(config-if)# no shutdown

Enables the port.

Step 31 Use a test set to verify that Ethernet connectivity exists on the RPR.

Step 32 Monitor Ethernet traffic and routing tables for at least one hour after the node deletion.

Stop. You have completed this procedure.


Understanding RPR Link Fault Propagation

Link fault propagation (LFP), also known as link pass-through, decreases convergence times in networks where routers interconnect through ML-Series card RPRs. It quickly relays link faults from a master Gigabit Ethernet link to a remote slave link, either Gigabit Ethernet or Fast Ethernet. LFP greatly improves the time it takes for a router connected to the slave link to fail over to an alternate path. Under normal protection schemes, convergence might take as long as forty seconds. Using LFP, the slave interface reflects the state of the master interface in less than a second. This feature is often used to enable a link failure at a far-end hub site in order to trigger a link down state at a near-end access site. Figure 17-13 illustrates LFP.

Figure 17-13 RPR Link Fault Propagation Example

LFP Sequence

LFP updates are done through a CDP packet extension. The update is sent periodically and immediately after the master interface goes into a link-down state. LFP updates are sent separately from normal Cisco discovery packets (CDP), and the two types do not interact. Configuring or disabling CDP on the interface has no effect on LFP updates.

When the master interface goes down, including an administrative shutdown, the slave interface is forced down. When the master interface goes up, the slave interface goes back up. Administrative shutdown on a slave interface will suspend the LFP function on that interface, and removing the shutdown will reactivate LFP.

A link-down fault is also forced onto the slave link if the connection from the master to the slave fails. Any of the following can cause a loss of connection:

Removing or resetting the master ML-Series card.

Shutdown or failure on both of the RPR paths between master and slave.

Disabling LFP on the master interface.

Link faults only propagate from master to slave. Normal slave link faults are not propagated. RPR wrapping and unwrapping has no effect on LFP.

Propagation Delays

Propagation delay includes the carrier-delay time on the slave interface. The carrier-delay time is configureable and has a default of 200 ms. See the "Configuring RPR" section for more information on configuring carrier-delay time.

Different propagation delays apply to different LFP scenarios:

Propagation delay between master link-down and slave link-down is 50 ms plus the carrier-delay time on the slave interface.

Propagation delay between master link-up and slave link-up has an additional built-in delay at the master interface to prevent interface flapping. Link-up propagation takes approximately 50 to 200 ms plus the carrier-delay time on the slave interface.

Propagation delay from when the master-to-slave link fails until slave link-down occurs is approximately 600 ms plus the carrier-delay time on the slave interface.

Configuring LFP

Figure 17-13 illustrates an example of RPR configured with LFP. The process of configuring LFP consists of the following tasks:

1. Configure one ML-Series card Gigabit Ethernet interface as a master link.

2. Configure other ML-Series cards' Gigabit Ethernet or Fast Ethernet interfaces as slave links.

To enable and configure the LFP master link, perform the following procedure, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router# interface gigabit ethernet number

Activates interface configuration mode to configure the Gigabit Ethernet interface.

Step 2 

Router(config-if)# link-fault rpr-master

Enables link-fault master status on the interface.

The no form of this command disables link-fault master status.

Step 3 

Router(config-if)# no shutdown

Enables the interface by preventing it from shutting down.

Step 4 

Router(config)# end

Returns to privileged EXEC mode.

Step 5 

Router# copy running-config startup-config

(Optional) Saves configuration changes to the TCC2/TCC2P flash database.

To enable and configure the LFP slave link, perform the following procedure on an ML-Series card in the RPR other than the ML-Series card configured for the master link. Begin in global configuration mode:

 
Command
Purpose

Step 1 

Router# interface [gigabit ethernet | 
fastethernet] number

Activates interface configuration mode to configure the Gigabit Ethernet or Fast Ethernet interface.

Step 2 

Router(config-if)# link-fault rpr-slave

Enables link-fault slave status on the interface.

The no form of this command disables link-fault slave status.

Step 3 

Router(config-if)# no shutdown

Enables the interface by preventing it from shutting down.

Step 4 

Router(config)# end

Returns to privileged EXEC mode.

Step 5 

Router# copy running-config startup-config

(Optional) Saves configuration changes to the TCC2/TCC2P flash database.

LFP Configuration Requirements

LFP has these configuration requirement:

A link-fault master and slave should not be configured on the same card.

The ML-Series card must be running the Enhanced microcode image.

All ML-Series cards in the RPR must be running Software Release 5.0 or later.

ML-Series card configured for DRPRI should not be configured for LFP, and LFP on DRPRI is unsupported.

Only ML-Series card Gigabit Ethernet interfaces are eligible to become link-fault masters.

Only one link-fault master is allowed per RPR.

Gigabit Ethernet and Fast Ethernet interfaces are both eligible to become link-fault slaves.

There is no configuration limit on link-fault slaves on an RPR.

Monitoring and Verifying LFP

A slave interface in link-down state raises a carrier loss (CARLOSS) alarm in CTC. CTC does not distinguish between a local loss on the slave link and loss due to LFP. For more information on CARLOSS, refer to refer to the "Alarm Troubleshooting" chapter of the Cisco ONS 15454 Troubleshooting Guide or the "Alarm Troubleshooting" chapter of the Cisco ONS 15454 SDH Troubleshooting Guide.

The Cisco IOS status of link-down interface is shown as protocol down/link down. Neither the show controller command nor the show interface command reveals the difference between a local loss on the link and an LFP loss.

After LFP is configured, you can monitor the LFP status of each master or slave link using the show link-fault command. Use this command to determine whether LFP caused the link down on a slave interface. Example 17-6 illustrates the output from this command on a slave interface.

Example 17-6 Monitor and Verify LFP

Router# show link-fault
Link Fault Propagation Configuration:
-------------------------------------
    LFP Config Mode  : LFP_SLAVE
    LFP Master State : LFP_STATUS_DOWN
    Interfaces configured for LFP:
        FastEthernet0 (down)

RPR Keep Alive

The keep alive mechanism for RPR POS interfaces sends keep alive packets onto SPR links connecting adjacent nodes. This mechanism protects against failures undetected by the SONET/SDH layer. Keep alive is off by default.

With this feature enabled, the RPR POS port wraps when it fails to receive three consecutive keep-alives.When a link is down due to an interruption in keep-alive reception, it raises a critical LINK-KEEPALIVE alarm on SONET/SDH. The RPR POS port unwraps and the alarm clears only after receiving ten consecutive keep-alive packets. Keep alive failures are not dependant on CRC errors. Keep-alive is also supported on DRPRI for POS interfaces. It is not supported on Gigabit EtherChannel (GEC).

Keep alive detection takes more than 50ms. This time is added to the standard under 50 ms switching time of SONET/SDH to result in a total recovery time of greater than 50 ms.

Configuring RPR Keep Alive


Caution When enabling the keep alive feature on an RPR carrying traffic, it is highly recommended that users first set the underlying POS circuit to OOS,DSBLD, which will wrap the RPR in the standard sub-50 msec. They can then enable the keep alive and put the circuit back to IS state. This ensures that traffic experiences a sub-50 msec hit when RPR keep alives are enabled.


Note The RPR keep alive requires the spr or mpls working microcode image for the ML-Series card.


To enable and configure the RPR keep alives, perform the following procedure, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router# interface pos 0

Activates interface configuration mode to configure the POS interface.

Step 2 

Router(config-if)# [no] spr keepalive

Enables RPR keep alives on the POS interface.

The no form of this command disables the RPR keep alives. You must shut down both ends of the link before disabling keep alives. The keepalive timer is not configurable in proprietary RPR it is by default set to 5 msec


Caution It is strongly recommended that keep alives are enabled on RPR.

Step 3 

Router# interface pos 1

Activates interface configuration mode to configure the POS interface.

Step 4 

Router(config-if)# [no] spr keepalive

Enables RPR keep alives on the POS interface.

The no form of this command disables the RPR keep alives. You must shut down both ends of the link before disabling keep alives.


Caution It is strongly recommended that keep alives are enabled on RPR.

Step 5 

Router(config-if)# no shutdown

Enables the interface by preventing it from shutting down.

Step 6 

Router(config)# end

Returns to privileged EXEC mode.

Step 7 

Router# copy running-config startup-config

(Optional) Saves configuration changes to the TCC2/TCC2P flash database.

Monitoring and Verifying RPR Keep Alives

After RPR keep alives are configured, you can monitor their status using the global command show interface spr 1 and the global command show ons spr keepalive-info pos <0-1>. Example 17-7 and Example 17-8 illustrate the output of these commands.

Example 17-7 Monitor and Verify RPR keep alives

Router> show interface spr 1>
SPR1 is down, line protocol is down 
	Hardware is POS-SPR, address is 0005.9a3b.c140 (bia 0000.0000.0000)
	MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, 
	reliability 255/255, txload 1/255, rxload 1/255
	Encapsulation: Cisco-EoS-LEX, loopback not set
	Keepalive not set
	Unknown duplex, Unknown Speed, unknown media type
	ARP type: ARPA, ARP Timeout 04:00:00
	SPR Wrapped information:
		POS0 : SONET 
		POS1 : SONET KEEPALIVE 
	No. of active members in this SPR interface: 0 
	Last input never, output never, output hang never
	Last clearing of "show interface" counters never
	Input queue: 0/0/0/0 (size/max/drops/flushes); Total output drops: 0
	Queueing strategy: fifo
	Output queue: 0/0 (size/max)
	5 minute input rate 0 bits/sec, 0 packets/sec
 
   
	5 minute output rate 0 bits/sec, 0 packets/sec
	0 packets input, 0 bytes
	Received 0 broadcasts (0 IP multicast)
 
   
	0 runts, 0 giants, 0 throttles
	0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
	0 watchdog, 0 multicast
	0 input packets with dribble condition detected
 
   
	0 packets output, 0 bytes, 0 underruns
	0 output errors, 0 collisions, 0 interface resets
	0 babbles, 0 late collision, 0 deferred
	0 lost carrier, 0 no carrier
	0 output buffer failures, 0 output buffers swapped out

Example 17-8 Monitor and Verify RPR keep alives

Router> show ons spr keepalive-info pos 1
	Keep-alive is configured and operational
	Keep-alive state is up
	Interface State: UP 							 External Memory Location: 0xD
	Num. KA pkts recvd: 461033198 Num KA pkts with KAF set: 930
	StreamId: 79         							 Src Node: 040
	KA Dead Val: 3        		 			 		 KA Restore Val: 10
	Curr FSM State: FULL 							 Prev FSM State: KAF COUNT
	Prev FSM Event: RX KA 							 Wrap/Unwrap Event: STATE_UP
	Defect Soak Count: 200 							 KA Fail Count: 0

RPR Shortest Path

The RPR shortest path feature determines the shorter hop-count of the two possible paths that can take traffic from location A to location B. Figure 17-14 illustrates a shortest path and longest path for the same source and destination on an RPR. The shortest path from A to B on the RPR is counter-clockwise or east-to-west. The longest path is the opposite direction, clockwise or west-to-east along the RPR.

Figure 17-14 Shortest and Longest Path

By always using the shortest path, traffic between two nodes can achieve the lowest possible latency. This is especially important for delay-sensitive traffic such as VoIP or Video broadcast TV.

The ML-Series card implements shortest path through a hop-based topology discovery mechanism based on the IEEE 802.17 standard. Each RPR station bi-directionally floods local topology data around the RPR to it peers through a control frame. The topology state machine process all the received control frames and builds a map based on the collective data. Layer 2 unicast traffic direction relies on this map.

The ML-Series card can also bases its Layer 2 unicast traffic load-balancing on the shortest discovered path, although MAC address load-balancing is the default, and port-based load balancing is also an option.

The topology discovery mechanism also reroutes data during a protection event, such as a fiber cut. The station that detects the failure of an RPR link starts restoring the traffic with RPR wrapping. This causes partial traffic reorder and delivery through the reverse, sub-optimal path along the RPR to the destination. Once all the stations get updated with the new topology, which includes the link failure, they steer the traffic away from the failed span.

These are the guidelines for configuring RPR shortest path and topology discovery:

You must configure spr topology discovery-enable on all the nodes on the RPR for accurate topology discovery.

When topology discovery is configured, keep alives will automatically enable, if not already enabled.

Disabling topology discovery does not disable keep alives, but a keep alive enabled warning message is displayed.

DRPRI nodes do not support topology discovery.

Shortest path load balancing requires the spr or mpls working microcode image for the ML-Series card. Attempting to enable shortest path load balancing with another microcode image, which doesn't support it, displays a warning message. The denied configuration is saved.

If topology discovery is enabled, enable shortest path load balancing.

You can enable shortest path load balancing on a per node basis. It is not dependant on the type of load balancing running on other nodes.

Configuring Shortest Path and Topology Discovery

To enable and configure shortest path and topology discovery, perform the following procedure, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router# interface spr1

Activates interface configuration mode to configure the POS interface.

Step 2 

Router(config-if)# [no] spr topology 
discovery

Enables topology discovery on RPR.

Step 3 

Router(config-if)# [no] spr load-balance 
shortest-hop

Configures shortest path load-balancing for L2 unicast packets being added to the ring.

Step 4 

Router(config-if)# no shutdown

Enables the interface by preventing it from shutting down.

Step 5 

Router(config)# end

Returns to privileged EXEC mode.

Step 6 

Router# copy running-config startup-config

(Optional) Saves configuration changes to the TCC2/TCC2P flash database.

Monitoring and Verifying Topology Discovery and Shortest Path Load Balancing

After configuring topology discovery, you can monitor the status using the global command show spr topology 1 to display the RPR topology information. Example 17-7 and Example 17-8 illustrate the output of these commands.

Router> show spr topology 1
***** ML-RPR Topology Map **************
Local Station Topology Info
Node Id : 40
West Span  neighbor : 0
East Span  neighbor : 0
Ring Topology: OPEN (UNSTABLE)
Advertised Protection requests: 
ringlet0: IDLE	ringlet1: IDLE
Active Edges:
	ringlet0: NO 	ringlet1: NO 
	Sequence Number: 0
=======================================================================
	East Interface: POS1    West Interface: POS0
	Number of nodes on east: 2
	Number of nodes on west: 2
	Active Topology Defects:
1. Topology Instability
Hops (POS 0)       Node Id        Edge W/E       Request W/E
		4                  20          NO/NO        IDLE/IDLE
		6                  40          NO/NO        IDLE/IDLE
Hops (POS 1)       Node Id        Edge W/E       Request W/E
		2                  20          NO/NO        IDLE/IDLE
		6                  40          NO/NO        IDLE/IDLE

Understanding Dual RPR Interconnect

Cisco ML-Series RPR includes the bridge-group protocol DRPRI, which is a mechanism to interconnect rings for protection from node failure. DRPRI supports redundant pairs of back-to-back Ethernet connections between different RPR networks. One connection is the active node and the other is the standby node. During a failure of the active node, link, or card, a proprietary algorithm detects the failure and causes a switchover to the standby node.

DRPRI provides a recovery time of less than 200 ms for Layer 2 bridged traffic when the ML-Series card employs the enhanced microcode image. When the ML-Series card employs the spr or Multiprotocol Label Switching (MPLS) microcode image, the recovery time for Layer 2 bridged traffic is up to 12 seconds. With any microcode image, the recovery time for Layer 3 unicast and multicast traffic also depends on the convergence time of the routing protocol implemented. Customer routing protocols and spanning tree instances are not touched, regardless of DRPRI hops.

The paired ML1000-2 cards share the same station ID and are viewed by other members of the RPR as a single card. In Figure 17-15, paired cards A and B have the same SPR station ID, and paired cards C and D have the same station ID. The interconnected nodes do not need to be adjacent on the RPR. Bridging, IP routing, policing, and bandwidth allocations can still be provisioned on DRPRI ML1000-2 cards. Bridge group 100 in the example carries the DRPRI traffic. Bridge group 10 in the example carries data traffic.

Figure 17-15 Dual RPR Interconnect Network and Paired Cards

DRPRI has these characteristics:

The DRPRI bridge-group cannot also be used to carry data traffic.

The DRPRI bridge-group is limited to one protocol, so a bridge-group with DRPRI implemented cannot also implement RSTP or STP.

Four ML1000-2 cards are required.

All four ML1000-2 cards must be part of the same bridge-group (VLAN).

Each paired set of ML1000-2 cards must have the same SPR station ID.

The bridge-group must be configured on SPR subinterfaces.

On each of the four ML1000-2 cards, both Gigabit Ethernet ports must be joined in a Gigabit EtherChannel (GEC) and the GEC interface must be included in the DRPRI bridge-group. Alternatively, one Gigabit Ethernet port must be shut down and the other one must be included in the DRPRI bridge-group. We recommend the GEC method.

A manual shutdown on subinterfaces or the GEC interface included in the DRPRI bridge-group must be issued on the interfaces at both ends of the GEC or Ethernet connection between the rings.

A DRPRI node can only be used for interconnecting two RPRs. The front ports of the cards should not be used to carry other traffic.

Non-DRPRI bridge-groups carrying traffic between rings should not have STP or RSTP configured.

Non-DRPRI bridge-groups carrying traffic between rings must be configured on each of the four ML-Series cards.

802.1 Q tunnels (QinQ) and protocol tunnels cannot be started on DRPRI nodes, but DRPRI nodes can bridge QinQ and protocol tunnels across the connected rings.

Users should not change the pathcost of members of the DRPRI bridge-group. The pathcost is assigned by the ML-Series card to ensure proper operation of DRPRI. A user-configured pathcost is overwritten by the assigned default DRPRI pathcost.

Configuring DRPRI

DRPRI requires two pairs of ML-Series cards with one pair configured as an RPR and belonging to the first of two adjacent RPRs, and the second pair configured as an RPR and belonging to the second RPR (Figure 17-15). DRPRI is configured on each of the four ML1000-2 cards that connect the two adjacent RPRs. The process of configuring DRPRI consists of the following major steps, which are detailed in the Cisco IOS procedure:


Step 1 Configure a bridge-group with the DRPRI protocol.

Step 2 Configure the SPR interface.

a. Assign a station ID number.

b. Assign a DRPRI ID of 0 or 1.

Step 3 Create an SPR subinterface and assign the bridge-group to the subinterface.

Step 4 Create a GEC interface.

Step 5 Create a GEC subinterface and assign the bridge-group to the subinterface.

To enable and configure DRPRI, perform the following procedure, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# bridge crb

Concurrent routing and bridging is enabled. When concurrent routing and bridging has been enabled, the default behavior is to bridge all protocols that are not explicitly routed in a bridge group.

Step 2 

Router(config)# bridge bridge-group-number 
protocol drpri-rstp

Creates the bridge-group number shared by the four ML1000-2 cards and assigns the protocol for DRPRI to the bridge-group. The same command using the same bridge group number must be given on each of the four cards.


Caution Do not use the DRPRI bridge group to carry data traffic. Data traffic on the DRPRI bridge group can cause instability and traffic hits.

Step 3 

Router(config)# interface spr 1

Creates the SPR interface for RPR or enters the SPR interface configuration mode on a previously created SPR interface. The only valid SPR number is 1.

Step 4 

Router(config-if)# spr station-ID 
station-ID-number

Configures a station identification number. The user must configure the same station ID on both the paired cards. Valid station ID numbers range from 1 to 254.

Step 5 

Router(config-if)# spr drpri-ID {0 | 1}

Creates a DRPRI identification number of 0 or 1 to differentiate between the ML1000-2 cards paired for DRPRI. A DRPRI identification number of 0 is the default.

Step 6 

Router(config-if)# interface spr 
shared-packet-ring-subinterface-number

Creates the SPR subinterface.

Step 7 

Router(config-subif)# encapsulation dot1q 
vlan-ID

Sets the SPR subinterface encapsulation to IEEE 802.1Q.

Step 8 

Router(config-subif)# bridge-group 
bridge-group-number

Assigns the SPR subinterface to the DRPRI bridge-group.

Step 9 

Router(config)# interface port-channel 
channel-number

Creates the GEC interface or channel-group.

Step 10 

Router(config-if)# interface Gigabit 
Ethernet number

Enters interface configuration mode for the first Gigabit Ethernet interface that you want to assign to the GEC subinterface.

Step 11 

Router(config-if)# channel-group 
channel-number

Assigns the Gigabit Ethernet interfaces to the GEC. The channel number must be the same channel number that you assigned to the EtherChannel interface.

Step 12 

Router(config-if)# interface Gigabit 
Ethernet number

Enters interface configuration mode for the second Gigabit Ethernet interface that you want to assign to the GEC subinterface.

Step 13 

Router(config-if)# channel-group 
channel-number

Assigns the Gigabit Ethernet interfaces to the GEC. The channel number must be the same channel number that you assigned to the EtherChannel interface.

Step 14 

Router(config-subif)# interface 
port-channel channel-sub-interface-number

Creates the GEC subinterface.

Step 15 

Router(config-subif)# encapsulation dot1q 
vlan-ID

Sets subinterface encapsulation to IEEE 802.1Q. The VLAN ID used should be the same VLAN ID used in Step 7.

Step 16 

Router(config-subif)# bridge-group 
bridge-group-number

Assigns the GEC subinterface to the DRPRI bridge-group.

Step 17 

Router(config-if)# end

Exits to privileged EXEC mode.

Step 18 

Router# copy running-config startup-config

(Optional) Saves configuration changes to NVRAM.

DRPRI IOS Configuration Example

Figure 17-15 shows an example of RPR configuration. The output from the show run command is provided in Examples 17-9, 17-10, 17-11, and 17-12.


Caution Do not use the DRPRI bridge group to carry data traffic. Data traffic on the DRPRI bridge group can cause instability and traffic hits.


Note To differentiate between the ML1000-2 cards paired for DRPRI, the cards have a DRPRI identification number of either 0 or 1. A show run command on a card with a DRPRI ID of 1 will display spr drpr-ID 1 in the Cisco IOS CLI output. But a show run command on a card with a DRPRI ID of 0 will not display any DRPRI ID in the Cisco IOS CLI output.


Example 17-9 ML-Series Card A Configuration

hostname ML-Series A
bridge crb
bridge 100 protocol drpri-rstp
bridge 100 forward-time 4
!
!
interface SPR1
no ip address
no keepalive
spr station-id 1
spr drpri-id 0
hold-queue 150 in
!
interface SPR1.1
encapsulation dot1Q 100
bridge-group 100
!
interface SPR1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
!         
interface Port-channel1
no ip address
hold-queue 150 in
!
interface Port-channel1.1
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 path-cost 32000
!
interface Port-channel1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
!
interface GigabitEthernet0
no ip address
channel-group 1
!
interface GigabitEthernet1
no ip address
channel-group 1
!
interface POS0
no ip address
spr interface-id 1
crc 32
!
interface POS1
no ip address
spr interface-id 1
crc 32
!
ip classless
no ip http server

Example 17-10 ML-Series Card B Configuration

hostname ML-Series B
nodeB_ML1000#
bridge crb
bridge 100 protocol drpri-rstp
bridge 100 forward-time 4
!
!
interface SPR1
no ip address
no keepalive
spr station-id 1
spr drpri-id 1
hold-queue 150 in
!
interface SPR1.1
encapsulation dot1Q 100
bridge-group 100
!
interface SPR1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
!
interface Port-channel1
no ip address
hold-queue 150 in
!
interface Port-channel1.1
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 path-cost 32000
!
interface Port-channel1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
!
interface GigabitEthernet0
no ip address
channel-group 1
!
interface GigabitEthernet1
no ip address
channel-group 1
!
interface POS0
no ip address
spr interface-id 1
crc 32
!
interface POS1
no ip address
spr interface-id 1
crc 32
!
ip classless
no ip http server

Example 17-11 ML-Series Card C Configuration

hostname ML-Series C
bridge crb
bridge 100 protocol drpri-rstp
bridge 100 forward-time 4
bridge 100 priority 0
!
!
interface SPR1
no ip address
no keepalive
spr station-id 2
spr drpri-id 0
hold-queue 150 in
!
interface SPR1.1
encapsulation dot1Q 100
bridge-group 100
!
interface SPR1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
!
interface Port-channel1
no ip address
hold-queue 150 in
!
interface Port-channel1.1
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 path-cost 32000
!
interface Port-channel1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
!
interface GigabitEthernet0
no ip address
channel-group 1
!
interface GigabitEthernet1
no ip address
channel-group 1
!
interface POS0
no ip address
spr interface-id 1
crc 32
!
interface POS1
no ip address
spr interface-id 1
crc 32
!
ip classless
no ip http server

Example 17-12 ML-Series Card D Configuration

hostname ML-Series D
bridge crb
bridge 100 protocol drpri-rstp
bridge 100 forward-time 4
!
!
interface SPR1
no ip address
no keepalive
spr station-id 2
spr drpri-id 1
hold-queue 150 in
!
interface SPR1.1
encapsulation dot1Q 100
bridge-group 100
!
interface SPR1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
!
interface Port-channel1
no ip address
hold-queue 150 in
!
interface Port-channel1.1
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 path-cost 65535
!
interface Port-channel1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
!
interface GigabitEthernet0
no ip address
channel-group 1
!
interface GigabitEthernet1
no ip address
channel-group 1
!
interface POS0
no ip address
spr interface-id 1
crc 32
!
interface POS1
no ip address
spr interface-id 1
crc 32
!
ip classless
no ip http server

Monitoring and Verifying DRPRI

After DRPRI is configured, you can monitor its status by using the show bridge verbose command (Example 17-13).

Example 17-13 show bridge verbose Command

Router# show bridge bridge-group-number verbose