Cisco Provisioning Center User's Guide, 4.2
Common Tasks
Downloads: This chapterpdf (PDF - 362.0KB) | Feedback

Common Tasks

Table Of Contents

Common Tasks

Working with Lister and Object Views

Navigating to Lister and Object Views

Getting a Count

Filtering a List

Multiple Page Lister

Get List Concurrency

Filtering a Transaction or Security User Lister View

Using the "Jump To" Box to Filter Objects

Working with Ordered Lists

Ordered List Viewer

Creating an Ordered List

Creating an Ordered List Entry

Modifying an Ordered List

Modifying an Ordered List Entry

Using the Find and Choose Buttons

Find and Choose with Create

Sorting a List

Minimizing the GUI Response Time for Listers

Exporting to a File

Exporting from Microsoft Internet Explorer

Exporting from Netscape Navigator

Working with Transactions

Transaction Lister

Viewing Transaction Logs

Viewing Objects Modified by Transactions

Deleting Transactions

Selecting a Transactions

Deselecting a Transactions

Saving and Applying Transactions

Applying a Transaction

Saving a Transaction

Applying a Transaction in a New GUI Session

Current and Pending Views

Blocking and No Blocking Usage During Apply

Scheduling Transactions

Abandoning Transactions

Automatic Transaction Handling

Working with Profiles

Creating a New Profile

Modifying a Service or Network Element Profile

Deleting a Service or Network Element Profile

Using Your Profile

Creating Objects Via Templates


Common Tasks


This chapter describes some common tasks you can perform with Cisco Provisioning Center, regardless of which Equipment Module or Service Application you are using.

The first section, "Working with Lister and Object Views", includes the following tasks:

Navigating to Lister and Object Views

Getting a Count

Filtering a List

Using the Find and Choose Buttons

Sorting a List

Exporting to a File

Working with Ordered Lists

The second section, "Working with Transactions" includes the following tasks:

Transaction Lister

Saving and Applying Transactions

Scheduling Transactions

Scheduling Transactions

Abandoning Transactions

Automatic Transaction Handling

The third section, "Working with Profiles" includes the following tasks:

Creating a New Profile

Modifying a Service or Network Element Profile

Deleting a Service or Network Element Profile

Using Your Profile

Creating Objects Via Templates

Working with Lister and Object Views

This section describes how to use Cisco Provisioning Center to view, filter, and sort data. It also describes how to group multiple changes into a single transaction, and how to schedule a transaction for a specific date and time.

Navigating to Lister and Object Views

In this document, procedures are shortened to simplify tasks. Following is an example of how a procedure is shortened.


Step 1 Navigate to networks > Cisco WAN Manager Equipment Module > Elements > Network > Your Network.

Translates to:

Step 2 Click the networks button on the Navigation Bar.

The Networks Tree View appears.

Step 3 Click the Cisco WAN Manager Equipment Module folder.

The folder expands, showing all of the elements and profiles under the Cisco WAN Manager folder.

Step 4 Click the Network object class.

Step 5 Click the Get List button.

A list of Cisco WAN Manager networks is displayed.


Note Do not attempt to perform any other actions until the list has been completely loaded. If you try to select another class from the tree view or perform another action, a metadata error will be displayed.


Step 6 Click the hyperlink Item# or the hyperlink name of <Your Network>.

The Object View for <Your Network> appears in Content Area.


Getting a Count

In some cases, you might want to know how many objects in the database, match a set of criteria, without actually listing those objects. Click the Get Count button to find out how many objects match your specified criteria. If necessary, you can then refine your search to return fewer objects.

Even if Cisco Provisioning Center is configured to limit the number of objects that appear when you click Get List button, the Get Count button returns the total number of matching objects in the database.

Filtering a List

You can specify data retrieval criteria before clicking the Get List button. Filtering fields appear at the top of any Lister View, and a Selection Box Filter appears with a transaction Lister and Security User Lister.

You can enter multiple search criteria for the same attribute in the filtering field. This means that if you want to search for an objects called SILVER and GOLD, then you can enter SILVER, GOLD in the filtering field. The separator between SILVER and GOLD can be configured during installation. By default, it is a comma.

To filter a Lister View, follow these steps:


Step 1 Navigate to Navigation Bar Option > Tree View Folder > Object.

The object specific Lister appears in the Content Area. A filtering field appears at the top of each column.

Step 2 Enter the value or pattern to match in any of the filtering fields. See the table below for supported pattern matching characters.

When you are filtering lists that contain integer types, the Lister supports the less than (<), greater than (>), equal to criteria (=).

Step 3 Click the Get List button. Only the objects that match the value or pattern in the filtering fields appear.

Repeat steps 2 and 3 to refine your search. The table below lists characters that are supported by Cisco Provisioning Center and the database for pattern matching:


Table 5-1 Transaction Selection Box Filter Options  

You enter this character
Equivalent SQL string
Result

*

%

Everything

%

\%

%

?

_ (underscore)

One character

_ (underscore)

\_

_ (underscore)

\*

*

*

\?

?

?

\\

\\

\

\x

\\x if x is not * or ?

x


In addition to the object attribute information in the lister table there are three additional columns shown in the resultant lister. The first column contains a selection toggle button, that is used to select the object for further actions. You can perform group operations using the selection box to select multiple items and then performs provisioning operations such as upload or delete on all of the selected items.

The second column contains the item number of lister result. The item number contains a hyperlink, which will take you to the Object Viewer page for this object instance. Hyperlinks, to the Object Viewer page, are available for many objects in the lister table.

The third column contains version information of the object. You may see icons indicating that the object is in a pending state or current state. See the "Lister View" section on page 4-9 for more details and for samples of the icons.

Multiple Page Lister

You can page through the listers when there are more records than will fit on one page.

When the total number of records exceeds the page size, then a row of hyper-linked pages will be at the top and bottom of the lister. Click the page number to go to that page.

In the case where there are too many pages to fit within a single row, the pages are bundled together and the hyper-linked bundles are shown at the top and bottom of the lister, e.g. "Previous # Pages" and "Next # Pages".

Figure 5-1 Multiple Page Lister

The GUI also provides a "Start:" input field to let you specify the starting point for retrieving records. If the start number is just the first number of a page, then the number of that page is displayed in square bracket without a hyperlink.

The page size, i.e. the maximum rows for the lister page, can be configured in default.cfg file, with parameter Max_Page_Numbers. For embedded listers the page size is set with parameter EmbeddedLister_Max_Rows.

If you have enabled the GUI optimization feature, the displayed information will be displayed differently. Refer to the "Minimizing the GUI Response Time for Listers" section for more details.

Get List Concurrency

The GUI limits the concurrency of the get list calls to the database for each user. This prevents you from performing many, long get list calls that degrade database performance. The exact number of concurrent get list calls can be configured in the default.cfg file. Refer to the CPC Installation Guide for details.

Filtering a Transaction or Security User Lister View

To filter Transaction Listers and Security User Listers, follow these steps:


Step 1 Navigate to administration > Transactions > Provisioning Transactions.

The selected Lister appears in the Content Area.

Step 2 In the Selection Box, select a radio button from the options available.

If necessary, fill in the criteria fields.

Table 5-2 lists the options available for the Transaction Lister and Table 5-3 lists options available for the Security User Lister.

Step 3 Click the Get List button.


Only the data that match the specified criteria appear.

Table 5-2 Transaction Selection Box Filter Options

Option Label
Description

All Transactions

Retrieves all transactions regardless of their state.

All Approved Transactions

Retrieves all transactions in the current or scheduled state.

My Approved Transactions

Retrieves only transactions created by the current user, which are in the current or scheduled state.

Last

Specifies the number of the last provisioned transactions to display. Enter the number of transactions to display in the Last field. You cannot use the wildcard character (*) in this field.

Dates

Specifies the date range for the displayed transactions. Enter the date range in the From and To fields. You cannot use the wildcard character (*) in this field.

Numbers

Specifies the number range for the displayed transactions. Enter the number range in the From and To fields. You cannot use the wildcard character (*) in this field.


Table 5-3 Security User Filter Selection Box Filter Options

Option Label
Description

Active Users

Matches all the users that are logged into the Cisco Provisioning Center system.

All Users

Matches all users.


Using the "Jump To" Box to Filter Objects

You can drill down on certain network elements to see which other network elements they contain by using the Jump To dropdown box. For example, from a network object Lister, you can invoke a Lister that displays all of the nodes in that network. This function is only available for a subset of the network elements listed in each Equipment Module folder.

To filter objects using the Jump To dropdown box, follow these steps:


Step 1 Navigate to networks > Equipment Module Folder > Elements > Specific EM object class.

The object specific lister appears in the Content Area.

Step 2 Click the Get List button. A list of matching objects will be displayed in the object specific lister. A Jump To dropdown box appears below the Action Bar.

Step 3 Check the Select box beside the object you want to drill down on.

Step 4 Select an object class to view from the Jump To dropdown box.

A Lister appears that corresponds to the object class you selected. In some cases, the Lister will perform an automatic Get List of the object class. If not, you must then click the Get List button. Only the objects that are contained by the selected object will be displayed.

If you selected the Network from the standard resource model, you can jump to an EM-Specific Node or Physical Port Lister according to the selected network instance.

If you selected a Node from the standard resource model, you can jump to an EM-Specific Physical Port or Logical Port Lister according to the selected node instance

If you selected a Physical Port from the standard resource model, you can jump to an EM-Specific Logical Port or Physical Connection according to the selected Physical Port instance

If you selected a Logical Port from the standard resource model, can jump to an EM-specific PVC according to the selected Logical Port instance

If you selected a particular link instance from the standard resource model Link Lister, you can jump to lister that displays all PVCs whose endpoints are either the A side or the Z side of that link.


Working with Ordered Lists

An ordered list contains a set of list entries whose order is significant. These lists are not necessarily restricted in size, so it is not possible to model these lists using a single object. Instead, a list is modelled as an object representing the list itself and a set of objects representing the list entries. For example the AS Path List and the Filter List are used by the CR Equipment Module.

The procedures below cover the basic methodology for creating an ordered list and adding entries. The steps may vary slightly depending on the type of list that you are creating. Refer to the specific Equipment Module Configuration Guide for details. The UA AS Path List is used in the following examples.

Ordered List Viewer

The GUI also supports a lister and an object viewer for the ordered list classes that have been combined into a single view. An embedded lister is a lister view contained within an object view. For ordered lists, the embedded lister is used to display a lister view of the ordered list items. These are the members of the ordered list that is being displayed in the object viewer. See Figure 5-2.

Once the object viewer page is loaded, the embedded lister will be displayed automatically, if it is required. When you perform a Get List or Get Count operation on an embedded lister, the whole object viewer page is reloaded. The number of rows displayed in an embedded lister is configured in the GUI default configuration file. If the total number of returned rows is greater than this limit, you will be able to specify a starting row for the query.

Each item in the embedded list will have a hyperlink that will take you to the corresponding list instance. Clicking any of the hyperlinks inside the embedded list will open another window.

Figure 5-2 Ordered List Viewer

Within the embedded lister, you have Get List and Get Count buttons. The layout of this lister is the same as the standard lister, with one exception: the columns containing parent information are not displayed. The order attribute will still be displayed in the search criteria and list entries will be sorted by this attribute by default. No popup menu will be displayed in the embedded lister because only a small number of getlist results will be shown.

Two operations, Insert Before and Insert After, are available specifically for ordered lists. These buttons will be displayed together with the modify and delete buttons for the embedded lister. The create operation is not available.

Creating an Ordered List

To create an AS Path ordered list, follow these steps:


Step 1 Navigate to networks > Universal Access Equipment Module > Elements > AS Path List.

The object specific lister appears in the Content Area.

Step 2 Press the Create Button and enter the a name and containing node for your list. Enter any other relevant information. Refer to the specific Equipment Module Configuration Guide for details and descriptions of specific attributes.

Step 3 Click the save or apply now button to save or apply your list.


Creating an Ordered List Entry

To create an AS Path list entry, follow these steps:


Step 1 Navigate to networks > Universal Access Equipment Module > Elements > AS Path List. The object specific lister is displayed in the Content Area.

Step 2 Click the Get List button to see the list object that you created above.

Step 3 Click on the Item # or Name hyperlink to open an ordered list viewer. The ordered list viewer is a combination viewer that contains an object view for the list and an embedded lister for the list entries. You will be using the embedded lister to add entries to your list.

Step 4 Click the Insert Before or Insert After to create an entry. The object viewer for the AS Path Entry is displayed in the Content Area.

Step 5 Enter the required attributes. Refer to the specific Equipment Module Configuration Guide for details and descriptions of specific attributes.

Step 6 Click the save or apply now button to save or apply your entry. If the provisioning secedes, the new entry will be displayed in the embedded listed.


You can create and use entry templates to create many similar entries. Refer to the specific Equipment Module Configuration Guide for details and descriptions of specific attributes.

Modifying an Ordered List

To modify an ordered list use the following procedure:


Step 1 Navigate to networks > Universal Access Equipment Module > Elements > AS Path List. The object specific lister is displayed in the Content Area.

Step 2 Press the Get List button. The lister view will be displayed. Select an ordered list instance.

Step 3 Select the list to be modified and click on the Modify button. Make the required changes and click the save or apply now button to save or apply your changes.


Modifying an Ordered List Entry

To re-order or move an ordered list item you must use the modify operation. To modify an ordered list use the following procedure:


Step 1 Navigate to networks > Universal Access Equipment Module > Elements > AS Path List. The object specific lister is displayed in the Content Area.

Step 2 Press the Get List button. The lister view will be displayed. Select an ordered list instance.

Step 3 Click on the hyperlink of the list that contains the entries to be modified.

Step 4 The ordered list view will be displayed. In the embedded lister, select the list entry to be modified and click the Modify button. To re-order or move an ordered list item, select the item in the embedded lister and click Modify. You can modify the New Item Number attribute to re-order or move the ordered list item into the desired position.

Step 5 Click the save or apply now button to save or apply your changes.


Using the Find and Choose Buttons

In some Lister Views and Object Views, the Find button appears beside a field. The Find and Choose feature enables you to fill in the exact value of the field by including the values of an existing object.

If the Find button appears beside an attribute that represents some other service or fabric element, you must use it; you cannot enter the value manually. Only attributes that call for Service object names can be entered manually.

To populate a field using the Find and Choose feature, follow these steps:


Step 1 Click the Find button.

The Choose page appears, displaying the Lister View for the object required to populate the field.

Step 2 Click the Get List button

Step 3 Check the check-box beside the required object.

Step 4 Click the Choose Object button. The Choose page closes. The field is populated with the selected object.


Find and Choose with Create

The Find/Choose with Create feature allows you to create an object during a find/choose search when you are provisioning the parent object. In other words, you can select an existing object or create a new object during find/choose in a provisioning operation. The create button is available on the find/choose lister page.

To populate a field using the Find and Choose with Create feature, follow these steps:


Step 1 Click the Find button.

The Choose page appears, displaying the Lister View for the object required to populate the field.

Step 2 Click the Create button. Alternatively you can click the GetList button and select an existing object to use as a template and then click the Create button.

After you click the Create button, the Choose lister page is replaced and the provisioning form is displayed.


Note You can not apply the transaction in the non-blocking mode, since the new object must be available during provisioning.


Step 3 Click the apply now or save to save or apply the transaction. If the operation is successful, then you can use this new object in the source provisioning form by clicking the hyperlink "Bring Object Back to Provisioning Form".

Information from the new object will be used to populate the required fields in the source provisioning form. This is identical to the standard find/choose behavior.


Figure 5-3 Find /Choose with Create Results Page

When you use this method to provision an object you must use one of either the save or apply now button throughout the entire find/choose/create process. If you have used the save button to create the object then you must save again when you are provisioning.

This is necessary for proper transaction management. If you click the save button to create a new find/choose object, then this newly created object is pending. If you then click the apply now button in the source provisioning window, a new transaction is created, that is unaware of the pending object in first transaction.

If the operation fails after you click either save or apply now, then normal the provisioning failed page will be displayed, and you will be returned to the previous page where you correct the information that you have entered.

Sorting a List

In most Lister Views, you can sort the order in which the objects appear. A dropdown list appears at the top of each Lister column. Select a value from any of the dropdown lists before clicking Get List, to choose the sort criteria.

The available values are described in Table 5-4.

Table 5-4 Sort Criteria

Code
Description
1ASND

Sort in ascending order, using the contents of this column as the first priority.

1DSND

Sort in descending order, using the contents of this column as the first priority.

2ASND/2DSND to 9ASND/9DSND

Sort in ascending/descending order, using the contents of this column as the second/third/fourth etc. up to ninth priority.

None

Inherit the order from the Cisco Provisioning Center database.


Minimizing the GUI Response Time for Listers

Currently, the response time of GUI's Get List command depends on two things: whether or not the returned items are sorted and whether the query needs to count how many items are returned. The greater the number of returned items, that are sorted and counted, the longer it will take to return the results. To minimize the response time, sorting and iterating of the entire query result can be eliminated.

This features is now available for both the ordered list and the normal listers such as the object, transaction or upload listers. One system-wide configuration parameter called "Lister_Performance_Optimization" controls this behavior. By default, the parameter will be turned off so the GUI functions as in previous releases. If the option is enabled the following changes will be made to the operation and appearance of he GUI.

The returned list is not sorted unless you have specified filtering criteria. All of the sort order combination boxes will be set to "NONE".

The returned results will not be counted from listers. The total number of items of the query result will not be shown in the Get List result page.

The Start Number will be removed from listers. There will be no input field of for "Start Number" in the lister pages.

The GUI pages will look different.

Exporting to a File

If you want to create a static HTML file that represents a Lister or Object View, click the Export to File button on the Action bar. You can perform this action from either Microsoft Internet Explorer or Netscape Navigator.

Exporting from Microsoft Internet Explorer

To export a Lister or Object View to a file from Microsoft Internet Explorer, follow these steps:


Step 1 Click the Export to File button.

The Content Area changes to a static HTML page.

Step 2 Right-click on the Content Area and select View Source.

The HTML code opens in your HTML or text editor.

Step 3 Save the file (i.e. xxx.htm), then open it in Microsoft Excel.


Exporting from Netscape Navigator

To export a Lister or Object View to a file from Netscape Navigator, follow these steps:


Step 1 Click the Export to File button

The Content Area changes to a static HTML page.

Step 2 Select Save Frame As from the File menu.

The file is saved with a .jsp extension

Step 3 Open the file in Microsoft Excel.


Working with Transactions

Transaction Lister

The transaction lister allows you to view and manipulate existing transactions in the Cisco Provisioning Center database.

To select from a list of existing transactions, follow these steps:


Step 1 Navigate to administration > Transaction > Provisioning Transactions or Upload Transactions.

Step 2 From the selection box that appears, choose how many transactions you want listed. You can select all transactions, all approved transaction or all transactions that were applied by the current user.

To further limit the number of transactions that are returned, you can specify the number of the of the most recent transactions that you want to view. You can also enter a date range or a transaction number range.

The selection box allows you to filter the list of transactions. The default is to return all provisioning or upload transactions.

Figure 5-4 Transaction Selection Box

Step 3 Click the Get List button.

A list of transactions appears. See Figure 5-5.

Figure 5-5 Transaction Lister View

Step 4 Check the Select box beside the desired transaction. Alternatively, you could click the transaction's item number to invoke an Object View for the transaction. See Figure 5-6.

At this point you can perform a variety of actions on the transaction that you selected depending on the transaction's state. For detailed instructions, see the procedures below.


Figure 5-6 Transaction Object View

Viewing Transaction Logs

You can view transaction logs, which are also referred to as audit logs for each transaction. To view a transaction's log, follow these steps:


Step 1 Navigate to administration > Transaction > Provisioning Transactions or Upload Transactions.

Step 2 Click the Get List button.

A list of transactions appears. See Figure 5-5.

Step 3 Check the Select box beside the desired transaction.

Step 4 Click the Log Info button on the Action Bar. The transaction log is displayed in the Content Area.


Viewing Objects Modified by Transactions

You can view the Service objects and Service elements modified or created within the context of each transaction.

To view the objects modified by a transaction, follow these steps:


Step 1 Navigate to administration > Transaction > Provisioning Transactions or Upload Transactions.

Step 2 Click the Get List button.

A list of transactions appears. See Figure 5-5.

Step 3 Check the Select box beside the desired transaction.

Step 4 Click the Modified Objects Info button on the Action Bar. The objects that have been modified within the transaction are displayed in the Content Area.


Deleting Transactions

You can delete transactions from the database if they are in the rejected or succeeded state. It is not possible to delete a transaction that is in the open state. You must close or apply it and then delete it. To delete transactions, follow these steps:


Step 1 Navigate to administration > Transaction > Provisioning Transactions or Upload Transactions.

Step 2 Click the Get List button.

A list of transactions appears. See Figure 5-5.

Step 3 Check the Select box beside the transaction(s) you want to delete. You can select more than one.

Step 4 Click the Delete button on the Action Bar.

A message will appear in the Content Area asking you to confirm whether or not you want to delete the transaction(s).

Step 5 Click the Yes, I Agree button if you are sure you want to delete the transaction(s). A message will appear in the Content Area if the delete action is successful.


Selecting a Transactions


Step 1 Navigate to administration > Transaction > Provisioning Transactions or Upload Transactions.

Step 2 Click the Get List button.

A list of transactions appears. See Figure 5-5.

Step 3 Check the Select box beside the required transaction. Normally, only one transaction in the approved state can be manipulated at a time.

Step 4 Click the Select button on the Action Bar. This will take you to the transaction details content area.


Deselecting a Transactions

In order to select another transaction, you must first deselect the current transaction:


Step 1 If you are not currently in the transaction details content area, navigate to transaction details.

Step 2 The currently selected transaction will be displayed in the content area.

Step 3 Click the De-Select button on the Action Bar. A message will appear in the content area if the deselect action is successful.


Pending versions of Service objects cannot be saved again. You can, however use this pending service object as a template for creating other objects. See the "Creating Objects Via Templates" section.

Saving and Applying Transactions

Whenever you press the apply now button a transaction is opened automatically. When you press the save button a new transaction will be opened automatically, unless there is one open already, in which case, your new change will be saved to the existing transaction.

If the transaction is saved or applied and succeeds, the Content Area displays an Object View for the object that you have created, modified, etc. including an Action Bar for the transaction.

If the object is saved or applied and fails, an error message is displayed in the Content area, including an Action Bar for the transaction. It is important to note that actions available on this Action Bar are specific to the transaction, and not the object.

If you want to bundle one or more changes together and apply them to the network at the same time, you can open a transaction and click the save button after each change, until you are ready to apply the change(s) to the network.


Note If for any reason, a change request fails, then all of the changes included in the transaction are rolled back.


Applying a Transaction

The apply now button is available to any session, and performs all of the steps required for transaction processing. It allows a single session to carry a transaction through all phases from Ready to Applied or to Abandoned.


Step 1 Navigate to the object to be created or modified and make the required changes.

Step 2 To apply the transaction immediately, click the apply now button on the Action Bar. A message will appear in the content area if the apply action is successful.


Saving a Transaction


Step 1 Navigate to the object to be created or modified and make the required changes.

Step 2 Press the save button. If the requested change is valid, then the Content Area displays an updated Object Viewer for selected object. A transaction is opened automatically and the number is displayed here.

Step 3 Navigate to the next object to be created or modified and make the required change to the object.

Step 4 Press the save button. If the requested change is valid, then this change will be added to the open transaction. The Object Viewer for selected object is displayed in the Content Area.

Step 5 To apply your transaction, click the transaction details button on the Navigation Bar. A list of pending objects, that are contained in the current transaction, is displayed.

Step 6 Select whether or not this transaction will be Blocking or Non-Blocking. For more information on blocking and non-blocking transactions, see the "Blocking and No Blocking Usage During Apply" section.

At this point, you can apply, schedule, abandon, or deselect the selected transaction.


Applying a Transaction in a New GUI Session

You can also apply transactions after you've logged out of the system and logged back in. For example, you can save a number of operations on one day, log out of the system, and come back the next day to apply them.

To make multiple changes in a single transaction, within a new GUI session, follow these steps:


Step 1 Navigate to administration > Transaction > Provisioning Transactions.

Step 2 Click the Get List button.

A list of transactions appears.

Step 3 Check the Select box beside the transaction that you want to apply. Only one transaction in the approved state can be manipulated at a time.

If you have already selected the transaction, the locked (selected by me) icon will appear in the Select column and you can proceed.

If someone else has selected the transaction, the locked (selected by others) icon will appear in the Select column and you will be unable to proceed.

This prevents different users from working with the same transaction at the same time.

Step 4 Click the select button on the Action Bar to view the contents of the transaction.

A list of pending objects appears in the Content Area.

Step 5 Select whether or not this transaction will be Blocking or Non-Blocking. For more information on blocking and non-blocking transactions, see the "Blocking and No Blocking Usage During Apply" section.


At this point, you are actually in the transaction details content area and you can apply, schedule, un-schedule, re-schedule, abandon, or deselect the chosen transaction.

Current and Pending Views

Each object that will be affected by the transaction appears as "pending" in the Content Area until the transaction is applied.

Click the Compare Pending and Current hyperlink to learn more about the pending changes. You can also click the View Pending Version or View Current Version hyperlinks to bring up a separate Object View for each version.

Blocking and No Blocking Usage During Apply

Whether a transaction is applied in a blocking or no-blocking mode affects other system operations. Transactions that are applied using the apply now button in blocking mode are processed immediately in the foreground. As a result, all other transactions are blocked. If another transaction is scheduled for a future date/time, that transaction will be processed at a later date/time in the background.

If you choose to block the system (by selecting the Blocking option during Service object creation), you will not be able to continue working in the GUI until the transaction has succeeded or failed.

If you select the No Blocking option, the transaction will be carried out in the background and you can continue working in the current session.

Scheduling Transactions

To schedule the transaction to be applied at a later time, follow these steps:


Step 1 Navigate to administration > Transaction > Provisioning Transactions.

Step 2 Click the Get List button.

A list of transactions appears.

Step 3 Check the Select box beside the required transaction. Click the Schedule button on the Action Bar.

A scheduling screen appears in the content area.

Step 4 Fill in the date and time in the format yyyy/mm/dd hh:mm. If no information is entered, the current date and time is used.

Step 5 Click the Submit This Schedule button. A message will appear in the content area if the scheduled action is successful.


Abandoning Transactions

Abandoning a transaction will change the transaction from approved to rejected. This is useful when you have a transaction that no longer needs to be applied.

To abandon an approved or failed transaction, follow these steps:


Step 1 Navigate to administration > Transaction > Provisioning Transactions.

Step 2 Click the Get List button.

A list of transactions appears.

Step 3 Check the Select box beside the required transaction. Click the Abandon button on the Action Bar.

A message will appear in the Content Area asking you to confirm whether or not you want to abandon the transaction.

Step 4 Click the Yes, I Agree button if you are sure you want to abandon the transaction. A message will appear in the Content Area if the abandon action is successful.


You can also abandon a transaction from the transaction details content area.

Automatic Transaction Handling

Cisco Provisioning Center helps maximize transaction throughput by preventing the accumulation of transactions in the ALERT state.

After entering the processing state, a transaction will proceed to one of two end states, APPLIED or ABANDONED, without user intervention. By default, Cisco Provisioning Center automatically abandons transactions that encounter errors (i.e. those in the ALERT state).

For ABANDONED transactions, the system checks whether or not rollback was successful for each affected site. If Rollback fails it is logged to the system event log.

Transactions enter an end state even if the client process that applied or scheduled the transaction ends before the transaction terminates.

If you must restart your system, Cisco Provisioning Center handles transactions that are not in an end state as follows:

Transactions in the BUSY or SCHEDULED state are resumed and handled as described above

Transactions in the READY remain in the READY state

Transactions in the CURRENT state are ABANDONED

Transactions in the ALERT state are set to the ABANDONED state

Upload requests that are not already in the FAILED or SUCCEEDED state are set to FAILED

Working with Profiles

For a given Service, service element, or network element, you can create many different profiles. An object instance may only have one assigned profile at a time.

Since profiles themselves are objects which you can create, modify and delete, they provide a means to store commonly used sets of attributes and provide a reliable method for quickly configuring any number of new objects. Using profiles also provides consistency when you are creating services or service elements.

A profile contains most of the attributes of the corresponding object. Those object attributes that are not included in the profile, are expected to be unique for each object. For example, an object's name cannot be profiled.

The attributes of a profile are referred to as initial value attributes because they are used to assign the initial values to the corresponding object. Once a new object has been created based on a profile, changes to profile attribute values do not cause any changes to objects that have already been created. The only time the profile attributes affect the object is when you create a new object or when you assign a new profile to an existing object.

Creating a New Profile


Step 1 Navigate to networks or services > specific Equipment Module or Service Application > Profiles > Specific Object.

Step 2 The specified Object Lister is displayed in the Content Area.

Step 3 Click the Create button on the Action Bar.

Step 4 An Object View appears in the Content Area.

Step 5 Enter a name for your profile.

Step 6 Enter the desired attribute values.

You can set the mode for attributes that are significant to your objects and services. An additional attribute on the profile's provisioning page allows you to set an attribute to Read-Only or Read-Write.

If a profiled attribute is set to read-only, then when you use this profile to create an object, you will not be able to edit, the objects read-only attributes.

Step 7 Click the save or apply now button to save or apply the profile.


Modifying a Service or Network Element Profile

To modify a Service or network element profile, complete the following steps:


Step 1 Navigate to networks > Cisco Provisioning Center > Profiles > Specific Object > Specific Object Instance.

The Specific Object Lister is displayed in the Content Area.

Step 2 In the Lister View, click the Get List button.

Optionally, use the field filters to narrow your selection before you click the Get List button.

Step 3 Check the box in the Select column next to the node element you want to modify.

Step 4 Click the Modify button on the Action Bar.

A Provisioning View appears in the Content Area.

Step 5 Modify the attribute value(s) that you want to change.

Step 6 Click the save or apply now button to save or apply the modification to the profile.


Deleting a Service or Network Element Profile

To delete a Service or network element profile, complete the following steps:


Step 1 Navigate to networks > Cisco Provisioning Center > Profiles > Specific Object > Specific Object Instance.

The Specific Object Lister is displayed in the Content Area.

Step 2 In the Lister View, click the Get List button.

Optionally, use the field filters to narrow your selection before you click the Get List button.

Step 3 Check the box in the Select column next to the node element you want to delete.

Step 4 Click the Delete button on the Action Bar.

Step 5 Click the save or apply now button to delete the profile.


Using Your Profile


Step 1 Navigate to networks or services > Specific Object > Elements > Specific Object >.

Step 2 The specified Object Lister is displayed in the Content Area.

Step 3 Click the Create button on the Action Bar.

Step 4 An Object View appears in the Content Area.

Step 5 Enter a name for your service or service element.

Enter the required profile name in Profile Name Input Field and press Enter, or use the Find/Choose feature to select the profile. The GUI will use the attribute values specified in the profile to populate the fields of your service object or service element.

The GUI will then refresh the provisioning page to show not only, fields with the value from the specified profile, but also the modes of various attributes, if they have been set by the profile. If the specified profile cannot be used, or if not profile is provided, then the default profile is used.

Step 6 Click the save or apply now button to save or apply the new object.

If the object's profile field is defined as Refresh, then when you enter the name of the profile to be used the GUI will automatically refresh the provisioning view to show the updated attribute values and modes.


Creating Objects Via Templates

You can create objects using an existing object's attribute values. This feature is invoked from another object's Object View by initiating a Create action. The following is a generic procedure for creating an object from an existing Object View.


Step 1 Navigate to Navigation Bar Option > Tree View Folder > Object Class.

Step 2 Click the Get List button.

Step 3 Select the object you would like to use as a template for the new object you are creating.

The Content Area displays the Object View for the object you selected.

Step 4 Click the Create button on the Action Bar.

The Content Area displays an Object View with some attributes filled in with values from the existing object.

Step 5 Fill in the other required attribute values.

Step 6 Click the apply now button, or click the save button if you are making multiple changes.

You can also create objects from templates using the popup menu. See the "Lister Popup Menu" section on page 4-11.