
Get Started With Cisco Prime Infrastructure

This section contains the following topics:

• Prime Infrastructure Organization, on page 1
• Setup Tasks to Complete Before Using Prime Infrastructure, on page 2
• Log In and Out, on page 3
• Change Your Password, on page 3
• Use the Main Window Controls, on page 3
• Change Your Default Home Page, on page 4
• Set Up and Use the Dashboards, on page 4
• Troubleshoot Network Health Using Dashboards, on page 14
• Work In a Different Virtual Domain , on page 20
• Manage Jobs Using the Jobs Dashboard, on page 20
• Extend Cisco Prime Infrastructure Functions, on page 22
• Check Cisco.com for the Latest Documentation, on page 22

Prime Infrastructure Organization
The Prime Infrastructure web interface is organized into a lifecycle workflow that includes the high-level task
areas described in the following table. This document follows the same general organization.

You are strongly advised not to enable third-party browser extensions. In Internet Explorer, you can disable
third-party browser extensions by choosing Tools > Internetoption and unselecting the Enable third-party
browser extensions check box in the Advanced tab.

Caution

Table 1: Prime Infrastructure Task Areas

Used ByDescriptionTask Area

Network Operators and Network
Engineers

Dashboard gives you a quick view of devices, performance information,
and various incidents.

Dashboard
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Used ByDescriptionTask Area

Network Engineers, Designers, and
Architects

Monitor your network on a daily basis and perform other day-to-day or
ad hoc operations related to network device inventory and configuration
management. The Monitor tab includes dashboards and tools that you
need for day-to-day monitoring, troubleshooting, maintenance, and
operations.

Monitor

Network Engineers, Designers, and
Architects

Design feature or device patterns, or templates. You create reusable design
patterns, such as configuration templates, in the Design area. You may
use predefined templates or create your own. Patterns and templates are
used in the deployment phase of the lifecycle. You can also design Plug
and Play profiles and mobility services.

Configuration

Network Engineers, NOCOperators and
Service Operators

Perform all devicemanagement operations such as adding devices, running
discovery, managing software images, configuring device archives, and
auditing configuration changes on devices.

Inventory

Network Engineers, NOCOperators, and
Service Operators

View network topology and wireless maps.Maps

Network Engineers, NOCOperators and
Service Operators

Access mobility services, Application Visibility and Control services, and
IWAN features.

Services

Network Engineers, NOCOperators, and
Service Operators

Create reports, view saved report templates, and run scheduled reports.Report

Network EngineersSpecify system configuration settings and data collection settings, and
manage access control. You can view and approve jobs, specify health
rules, and manage licenses. You can also perform software updates and
configure high availability.

Administration

Setup Tasks to Complete Before Using Prime Infrastructure
Before you can use the features, these tasks should be completed by an administrator:

Table 2: Setup Tasks and References

For information, see:Tasks to complete before using Prime Infrastructure

"Server Setup Tasks" in the Prime Infrastructure
Administrator Guide

Set up and configure the Prime Infrastructure server.

Add and Organize DevicesAdd devices to and create device groups to simplify device
and network management.

Monitor Device and Network Health and
Performance

Enable monitoring for interfaces and technologies used by
the network.
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For information, see:Tasks to complete before using Prime Infrastructure

Set Alarm and Event Management PreferencesCustomize alarm and event behavior for your deployment
(for example, alarm and event refresh rates and e-mail and
trap receivers).

Log In and Out
To log into the GUI, enter the following in your web browser address field, where server-ip is the IP address
of the server:

Depending on your network configuration, the first time your browser connects to the web server, you may
have to update your client browser to trust the security certificate of the server. You can also generate and
import user-specific client certificates to your browser, which allows the user to log into Cisco EPNManager.
These generated client certificates allow you to log in without specifying a username or password. These
generated client certificates require a passcode when you update them to your browser. This ensures the
security of the connection between your client and the web server.

To log out, click at the top right of the window and choose Log Out.

For information on users and the actions they can perform, see:

• How to Transition Between the CLI User Interfaces in Prime Infrastructure—Describes all classes of
users supported by , including the various CLI user accounts.

Change Your Password
You can change your password at any time by clicking at the top right of the Prime Infrastructure window
and choosing Change Password. Click the ? (help) icon to review the password policy.

(Optional) Click theGenerate New Password button to set a secured system-generated password. On clicking
this button, a new password will be displayed in the adjacent text box. The same is also displayed in the New
Password and Confirm Password text boxes. Click the eye icon in the text box to view or hide the password.
You can also copy the password to clipboard by clicking the Copy button.

Click the Reset button to clear the values in the text box.

Use the Main Window Controls
The top left of the title bar provides the following controls.

Menu button—Toggles the main navigation menu on the left (also called the left sidebar
menu)

Home button—Returns you to the home page (normally the Overview Dashboard)

The right side of the title bar displays your user name and the virtual domain you are working in. A virtual
domain is a logical grouping of devices. Virtual domains are used to control who has access to devices and
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areas of the network. To switch between virtual domains that are assigned to you, see Work In a Different
Virtual Domain , on page 20.

Web GUI global settings button—Log out, change password, view your Cisco.com account
profile, adjust your GUI preferences, check a Cisco.com support case, launch online help

The Alarm Summary gives you a visual indicator of number of alarms in your network. The color indicates
the highest severity alarm.

Alarm Summary—Provides a visual count of alarms in the categories that you specify.
Clicking this area opens the Alarm Summary popup window.

Change Your Default Home Page
You can specify which page you want to display when you perform either of the following tasks:

• You click from the left side of the web GUI title bar.

• You log in to the Prime Infrastructure web GUI.

This setting is saved on a per-user basis. You can change it at any time without affecting other users.

Step 1 While you have the page you want displayed, click at the top right of the Prime Infrastructure web GUI.
Step 2 Choose Set Current Page as Home.

Set Up and Use the Dashboards
Dashboards provide at-a-glance views of the most important data in your network. They provide status as
well as alerts, monitoring, performance, and reporting information. You can customize these dashboards so
they contain only the information that is important to you. It may be helpful to set the Network Summary
dashboard as your default home page. By doing so, this dashboard is displayed after you log in and you can
quickly check overall network health before you do anything else. To set any dashboard as your default home
page, see Change Your Default Home Page, on page 4.

Use the following dashboards to monitor and manage your network:

• Network Summary dashboard—To check the health of the entire network. See Check the Health of the
Entire Network Using the Network Summary Dashboard, on page 7.

• Wireless dashboard—Provides wireless information, including details about wireless Security, Mesh,
CleanAir, and ContextAware networking.

• Performance dashboard—To check the performance of a specific device or interface. See Check the
Performance of a Specific Device or Interface Using the Performance Dashboard, on page 9.

Users with administrator privileges can also use the following dashboards:

Get Started With Cisco Prime Infrastructure
4

Get Started With Cisco Prime Infrastructure
Change Your Default Home Page



• Licensing dashboard—See the section View the Licencing Dashboard in Cisco Prime Infrastructure
Administrator Guide.

• Jobs dashboard—See Manage Jobs Using the Jobs Dashboard, on page 20.

Note the following:

• For an explanation of the parts of the dashboard window and how to use dashboard filters, see How to
Use the Dashboards, on page 5.

How to Use the Dashboards
The following figure illustrates the key parts of a dashboard window and the controls you can use to adjust
them.

Table 3: Dashboard Elements

Dashboard filters—Filters all dashlets in the dashboard according to the selection. In this example, a
time-based filter is used. The filters displayed depend on the dashboard type. For example, in the
performance dashboards, you must select a specific interface, device, circuit, or VC.

1

Metric dashlets—Provides quick metrics for alarms, available devices, and so forth.2
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Dashboard settings and controls:

• Dashboard icons—Allows you to launch online help, refresh the entire dashboard, and open the
Dock window.

• Dashboard Settings menu—Allows you to add or rename a dashboard tab, add new dashlets (both
standard and metric), adjust the dashboard's layout, reset all dashboards to their default settings,
clone a dashboard (applicable only for Network Summary dashboard),and export data from the
selected dashlets.

The newly added or a renamed dashboard tab can be viewed only in the Tab view.This
change is not reflected in the Dashboard menu.

Note

3

Standard dashlets—Provides at-a-glance data that is relevant to the dashboard.4

In the top right corner of each dashlet are icons that are activated when you use that dashlet. The dashlet type
determines the icons that are available. The most common icons are displayed in the following figure:

Edit the dashlet options. This includes editing the dashlet title, refreshing the dashlet, or changing the
dashlet refresh interval. (To disable refresh, unselect Refresh Dashlet.) Hover your cursor over this
tool icon to display the current filters applied to the dashlet.

1

Dashlet popup help window—Provides a picture and description of the dashlet, the data sources used
to populate it, and any filters you can apply to the dashlet's content.

2

Refresh the dashlet.3

Detach the dashlet and display it in a new browser window. If you edit the dashlet in the separate
browser window, the changes are applied in that window only and are not saved.

4

Minimize the dashlet so that only its title appears. A maximize (+) icon appears in place of this tool
icon when the dashlet is minimized.

5

Remove the dashlet from dashboard.6

See these topics for additional information on dashboards:

• Types of Dashboards, on page 7

• Add Dashlets to Dashboards, on page 11

• Add a New Dashboard, on page 13
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Customize the Dock Window
Use the Dock window for quick navigation to frequently used web GUI pages and pop-up windows (such as
the 360 view for a particular device). From here, you can also access links to the 15 most recently visited
pages and Prime Infrastructure training materials. To open this window, click the Dock icon (located in the
top right area of the page).

Complete the following procedure to update the links provided in the Dock window:

Step 1 Add a web GUI page link to the Favorites tab (Dock icon > Links Visited > Favorites):
a) Open the web GUI page you want to add.
b) Click its star (Favorite) icon, which is located in the top left area of the page.

Step 2 Add a pop-up window link to the Docked Items area (Dock icon > Docked Items):
a) Open the pop-up window you want to add, then open its 360 view.
b) From the top right corner of the pop-up window, click the Add to Dock icon.

Types of Dashboards
The following topics describe the dashboards you can use to monitor your network.

Prime Infrastructure filters the monitoring data for virtual domains, based on the end points assigned to the
sites and not based on the datasource. Hence, the dashboards display information for all virtual domains
irrespective of the virtual domain assigned to the user.

Note

Check the Health of the Entire Network Using the Network Summary Dashboard
The Network Summary dashboard alerts you to the most important network issues. It provides alarm, status,
and usage information for all devices and interfaces in the network, including wireless devices like controllers
and APs. You can also display a small network topology dashlet on this dashboard.

To understand the types of information provided by the Metrics dashlets at the top of the dashboard, hover
your mouse cursor over a Metrics dashlet and when the popup help button (? ) appears, click it to open the
dashlet help. For descriptions of the other dashlets on the page, click the popup help button shown with the
dashlet controls in the upper right corner of each dashlet.

To open and customize the Network Summary dashboard:

Step 1 Choose Dashboard > Network Summary, then click:

• The Overview tab to check all devices.

Users will now be able to view the description of ports by hovering over the interface names for the
Top N Interface Utilization and Top N WAN Interfaces by Utilization interface dashlets.

Note

• The Incidents tab to focus on alarms and events, including syslogs.
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• The Client Summary tab to check Client Distribution, Client Count, and Client Traffic.

Client summary dashboard is accessible only to ROOT and SUPERUSERs by default. If Admin and
Config Users need access, you need to give NBI READ access while creating the Admin/Config user.

Note

• The Site Summary tab to check all devices at particular sites.

• The Network Health tab to check network health against a set of health rules.

Step 2 Adjust the dashboard as needed. You can drag dashlets to different locations on the dashboard, or use the Settings menu
to add new dashlets, change the dashboard style, and so forth. If you want to add dashlets to the dashboard, see Add a
Predefined Dashlet To a Dashboard, on page 11.

Step 3 Select the time frame you want to view from the Filters Time Frame drop-down list, then click Apply. Selected time
frame will be updated in all dashlets.

Check the Health of All Devices or All Interfaces Using the Overview Dashboard
The Overview dashboard helps you maintain the health of your network by providing summarized and
aggregated data on the health of all network devices, interfaces, clients, and application services, including
their availability, status, utilization, and the alarms and events affecting them.

To understand the types of information provided by the Metrics dashlets at the top of the dashboard, hover
your mouse cursor over a Metrics dashlet and when the popup help button (? ) appears, click it to open the
dashlet help. For descriptions of the other dashlets on the page, click the popup help button shown with the
dashlet controls in the upper right corner of each dashlet.

To open and customize the Overview dashboard:

Step 1 Choose Dashboard > Overview, then click:

• The General tab to check on the health of all devices and interfaces, including coverage areas, which devices are
reachable, and top users of CPU and memory.

• The Incidents tab to focus on alarms and events, including sites with the most alarms, device reachability, types of
alarms, and syslog details.

• TheClient tab to focus on the health of network clients. This tab hosts a variety of client-oriented dashlets, including
a troubleshooting tool, distribution and speed graphs for wired and wireless clients, and client posture.

• The Network Devices tab to check device availability, CPU and memory use, and temperature issues.

• The Network Interfaces tab to check interface availability, status, CPU and memory use, and interfaces with the
most errors and discards.

• The Service Assurance tab to check on identified network services and the applications, servers, and
Netflow-monitored resources that support them, as well as the clients consuming them.

Users will now be able to view the description of ports by hovering over the interface names for the Top N
Interface Utilization, Top N WAN Interfaces by Utilization, and Top N Interface Errors and Discards
interface dashlets.

Note
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Step 2 Adjust the dashboard as needed. You can drag dashlets to different locations on the dashboard, or use the Settings menu
to add new dashlets, change the dashboard style, and so forth. If you want to add dashlets, see Add a Predefined Dashlet
To a Dashboard, on page 11.

Step 3 Select the time frame you want to view from the Filters Time Frame drop-down list, then click Apply.

Check the Health of Wireless Networks Using the Wireless Dashboard
TheWireless dashboard helps you maintain the health of your wireless network by providing aggregated data
on network security status and attacks, mesh network efficiency, air quality, interferers, and so on.

To understand the types of information provided by the Metrics dashlets at the top of the dashboard, hover
your mouse cursor over a Metrics dashlet and when the popup help button (? ) appears, click it to open the
dashlet help. For descriptions of the other dashlets on the page, click the popup help button shown with the
dashlet controls in the upper right corner of each dashlet.

To open and customize the Wireless dashboard:

Step 1 Choose Dashboard > Wireless, then click:

• The Security tab to check on top security issues, detected rogues of all types, CleanAir security, and rogue
containment, and Cisco Adaptive Wireless Intrusion Prevention (wIPS) data.

• The Mesh tab to focus on mesh network alarms, and links with the worst SNR, number of node hops and packet
errors.

• The CleanAir tab to focus on non-802.11 interference sources, including the total count of and worst interferers,
CAS interferer notifications, and general air quality.

• The ContextAware tab to focus on Cisco Context-Aware Mobility data supported by Mobility Service Engines,
including MSE tracking counts, location-assisted client troubleshooting, and detected rogue elements.

Step 2 Adjust the dashboard as needed. You can drag dashlets to different locations on the dashboard, or use the Settings menu
to add new dashlets, change the dashboard style, and so forth. If you want to add dashlets, see Add a Predefined Dashlet
To a Dashboard, on page 11.

Step 3 Select the time frame you want to view from the Filters Time Frame drop-down list, then click Apply.

Check the Performance of a Specific Device or Interface Using the Performance Dashboard
If the Performance dashboard is not displaying the information you are interested in, you can create your own
customized dashlet. See Add a Customized Dashlet to the Device Trends Dashboard, on page 12 for more
information.
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Table 4: Performance Dashboard

Provides:Dashboard Tab

• Device availability during the specified timeline

• CPU utilization for each device CPU

• Memory utilization

• Port count, and ports that have been operationally up or down

• Device alarms and events

• Device temperature

Devices

• Properties of the interface (IfType, IfIndex, and so forth)

• Interface availablity during the specified timeline

• Interface CPU and memory utilization

• Tx and Rx utilization, and packet errors and discards

• QoS class map statistics

Interface

• Client traffic, Device with most alarms, Top N applications and Device reachability
status

• For the specified access point:

• Access point details
• Top clients and applications
• Channel utilization
• Client count

• For the specified application:

• Top clients and servers
• Application traffic analysis graph
• Application server performance
• Top interfaces over time

Users will now be able to view the description of ports by hovering over
the interface names for the Top N Interface Utilization, Top N WAN
Interfaces by Utilization, and Top N Interface Errors and Discards
interface dashlets.

Note

Site, Access
Point,
Application, etc.

Some of the dashlets (for example Top N Clients, Top N Servers, Top N Applications, Number of Clients
Over Time and Client Traffic dashlets) include the link click here to launch the corresponding report to
go to the respective Report page, if the number of records exceeds 100 million in the relevant tables. This link
will appear in the dashlets, only if you select Enable from the drop-down list and click Apply under the
Dashboard Settings menu. By default, this setting will remain disabled.

Some of the relevant filters will be prefilled in the Reports page. For example for Top N Clients dashlet,
Location Groups, Network Aware and Reporting Period parameters will get prefilled.
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Even if the number of records exceeds 100 million in the relevant tables, the Report page may not show any
data, if there is no data corresponding to the selected filter such as reporting period and Application etc.

Note

By default, the refresh interval period is set to 30 mins for the Performance Dashboard Dashlets. Users can
change the interval period by clicking the Edit Dashlet Options, if needed.

Note

Use this procedure to open and customize the Performance dashboard:

Step 1 Choose Dashboards > Performance, then do one of the following:

• To check a specific device, click the Device tab, then select a device from the Filters Device drop-down list.

• To check a specific interface, click the Interfaces tab, then click the Filters Interface drop-down list and navigate
to the interface you want to check.

Step 2 Adjust the dashboard as needed. You can drag dashlets to different locations on the dashboard, or use the Settings menu
to add new dashlets, change the dashboard style, and so forth. If you want to add dashlets, see Add Dashlets to Dashboards,
on page 11.

Step 3 Select the time frame you want to view from the Filters Time Frame drop-down list, then click Go.

Add Dashlets to Dashboards
• Prepackaged dashlets that are provided with Prime Infrastructure—Some of the dashlets are displayed
on dashboards by default; others are listed in the Settings menu, and you can add them as needed. These
dashlets provide information you will likely monitor (for example, device CPU utilization, interface
errors and discards, and traffic statistics). See Add a Predefined Dashlet To a Dashboard, on page 11.

• Customized dashlets that you create to monitor device performance—These dashlet types can only be
added to the Device Trends dashboard. See Add a Customized Dashlet to the Device Trends Dashboard.

Add a Predefined Dashlet To a Dashboard
Prime Infrastructure provides a predefined set of dashlets that will provide you with commonly-sought network
data. By default, a subset of these dashlets is already included in the dashboards, to help you get started.
Complete the following procedure to add another of these predefined dashlets to your dashboards.

To edit or remove a dashlet, click the appropriate icon from the top right corner of that dashlet. (See How to
Use the Dashboards.)

Note

Step 1 From the sidebar menu, choose Dashboard, then select the dashboard you want to add a dashlet to.
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For example, to add aDevice Memory Utilization dashlet to theDevice Trends dashboard, chooseDashboard >Device
Trends > Device.

Step 2 Identify the dashlet you want to add, then add it:
a) From the top right corner of the dashboard, click Settings and then click Add Dashlet(s). Prime Infrastructure lists

the dashlets that can be added to that dashboard.
b) To open a pop-up window that provides an overview of a particular dashlet, hover your cursor over dashlet's name.

The pop-up window also lists the sources for the data the dashlet provides and the filters you can apply to the dashlet.
c) Click Add to add the selected dashlet to the dashboard.

Step 3 Verify that the dashlet is populated with data.

If it is not, check whether the requiredmonitoring policy is enabled. (Only the Device Health monitoring policy is enabled
by default. It checks device availability, CPU and memory pool utilization, and environmental temperature.)

a) From the top right corner of the dashlet, click its ? (Help) icon to open the dashlet's pop-up window.
b) Check the information provided in the Data Sources area. If it lists a monitoring policy, check whether the policy is

activated. See Check What Prime Infrastructure Is Monitoring.

Add a Customized Dashlet to the Device Trends Dashboard
If none of the dashlets in theDevice Trends dashboard provide the device performance information you need,
you can add a dashlet that uses a customized template to poll devices for their SNMPMIB attributes. Complete
the following procedure to add this dashlet to the dashboard.

Before you begin

Check the available monitoring policies to determine which policy collects the information you need. You
will have to specify a policy during the dashlet creation process. If none of the policies meet your needs, you
can create a policy that polls new parameters. See Create a Monitoring Policy for Unsupported Parameters
and Third-Party Devices.

Step 1 Choose Dashboard > Device Trends > Device.
Step 2 From the top right corner of the dashboard, click Settings and then click Add Dashlet(s).
Step 3 Expand the Device Dashlets list.
Step 4 Locate Generic Dashlet, then click Add.

Prime Infrastructure adds a blank generic dashlet to the Device Trends dashboard.

Step 5 Configure the new dashlet as needed.
At a minimum, you should:

• Enter a meaningful title in the Dashlet Title field.

• Check the Override Dashboard Time Filter check box if you do not want to apply the time filters to all of the
dashlets in the dashboard.

• In the Type drop-down list, choose whether the dashlet will display its data as a table or line chart. (Regardless of
your choice, Prime Infrastructure will display a toggle at the bottom of the dashlet that allows you to change the
format.)

• In the Policy Name drop-down list, choose the monitoring policy that will collect the data for this dashlet.
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Step 6 Click Save And Close.

Add a New Dashboard
Use this procedure to create a new dashboard. Your new dashboard will appear as a new tab under one of the
dashboards listed in Types of Dashboards, on page 7.

Step 1 Open the relevant existing dashboard.

For example, if you want to create a new tab under the Performance dashboard, click any tab under Dashboard >
Performance.

Step 2 Click the + (Add New Dashboard) tab.

The Settings menu opens.

Step 3 Enter a name for the new dashboard, then click Apply.
Step 4 Click the new dashboard tab, then add dashlets as described in Add a Predefined Dashlet To a Dashboard, on page 11.

Add a Customized Dashlet to the Performance Dashboard
If device performance information is not available on any of the dashlets in the Performance screen, you can
add a new dashlet. These dashlets use a customized template to poll devices for their SNMP MIB attributes.

Complete the following procedure to add a new dashlet to the dashboard.

Before you begin

Check the available monitoring policies to determine which policy collects the information you need. You
will have to specify a policy during the dashlet creation process. If none of the policies meet your needs, you
can create a policy that polls new parameters. See Create a Monitoring Policy for Unsupported Parameters
and Third-Party Devices.

SUMMARY STEPS

1. Choose Dashboard > Performance > Device.
2. From the top right corner of the dashboard, click Settings and then click Add Dashlet(s).
3. Expand the Device Dashlets list.
4. Locate Generic Dashlet, then click Add.
5. Configure the new dashlet as needed.
6. Click Save And Close.

DETAILED STEPS

Step 1 Choose Dashboard > Performance > Device.
Step 2 From the top right corner of the dashboard, click Settings and then click Add Dashlet(s).
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Step 3 Expand the Device Dashlets list.
Step 4 Locate Generic Dashlet, then click Add.

Prime Infrastructure adds a blank generic dashlet to the Performance dashboard.

Step 5 Configure the new dashlet as needed.
At a minimum, you should:

• Enter a meaningful title in the Dashlet Title field.

• Check the Override Dashboard Time Filter check box if you do not want to apply the time filters to all of the
dashlets in the dashboard.

• In the Policy Name drop-down list, choose the monitoring policy that will collect the data for this dashlet.

• In the Type drop-down list, check if the dashlet will display its data as a table or line chart.

In the line chart view, Prime Infrastructure will display a toggle at the bottom of the dashlet that allows you to change
the format.

a) Select Type as Table. This provides a consolidated view of all devices for the selected policy. Atleast 500 latest
polled entries will be displayed in the dashlet.

b) Select Type as Line Chart. It helps user to choose specific inputs per device level and get latest of 1000 entries
displayed in the dashlet.

Step 6 Click Save And Close.

Troubleshoot Network Health Using Dashboards
Prime Infrastructure provides a quick way to view the health of your network and sites by choosing
Dashboard > Network Summary > Nework Health. You must create location groups and then add devices
to the locations. Prime Infrastructure displays a map indicating the overall health of all the sites. TheNetwork
Health page allows you to toggle the view between wired and wireless devices. By default, all locations and
a maximum of 500 APs per location group are displayed. If you choose Wired view, the Network Health
page shows the WAN Inteface Utilizatoin details and a map indicating the overall health status of the wired
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devices of all the locations. If you chooseWireless view, theNetwork Health page shows theWireless Client
Count details and a map indicating the overall health status of the wireless devices of all the sites. In the
Wireless view, click theExecutive View expand icon to choose any one of the client, access points, environment
(clean air), and application dashboards. The Network Health page displays the dashlets corresponding to the
selected dashoard. You can click the settings icon to add more dashlets. Click more to cross launch the
Dashboard.

Related Topics
Define Health Rules, on page 15
Network Health Map Features, on page 16
Network Health Summary, on page 17
Define QoS and Interface Settings, on page 15
QoS Metrics, on page 18
Traffic Conversation, on page 19
Creating Location Groups

Define Health Rules
You can specify rules and threshold values for your sites. The rules you specify determine the notifications
that appear in Dashboard > Network Summary > Network Health.

Step 1 Choose Services > Application Visibility & Control > Health Rule. There are 3 tabs where you can specify health
rules:

• Service Health—Define health rules for services such as Jitter, MOS score, Network Time, Packet Loss, Traffic
Rate, etc.

• Infrastructure Health—Define health rules for wired devices.
• Wireless Health—Define health rules for wireless devices.

The default critical and warning threshold set for client count is 40 and 36 respectively. The maximum critical
threshold for client count can be set as 1000.

Note

Step 2 To add a new health rule, click the plus icon, then specify the location, metric, and threshold. You can add new Infrastructure
Health and Wireless Health rules only.

Step 3 To edit an existing health rule, select the health rule you want to modify, then click Edit.
Step 4 Enter the details for the health rule, then click Save.

The values you enter apply to all devices and interfaces in the location group for which the health rule applies.

Related Topics
Network Health Map Features, on page 16
Network Health Summary, on page 17
Create Location Groups

Define QoS and Interface Settings
The Health Rule page allows you the define the QoS and Interface settings for the heatmap displayed in the
Network Health page.
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Step 1 Choose Services > Application Visibility & Control > Health Rule.

Alternately, click the Launch Health Rules link in the Network Health page.

Step 2 Click the Infrastructure Health tab.
Step 3 Check the QoS Settings check boxes which you want to exclude from the heatmap. By default, the Exclude Scavenger

check box will be checked and not shown in the heatmap.
Step 4 Uncheck the Exclude Admin Down Interface if you want to include the Admin down interfaces in the heatmap. By

default, the Exclude Admin Down Interface will be checked and not shown in the heatmap.
Step 5 Click Save.

TheQoS and Interface settings will get immediately applied to the heatmap in theNetwork Health page. The corresponding
health rule job will get updated after 30 minutes.

Network Health Map Features
When you choose Dashboard > Network Summary > Network Health, the map displays all the location
groups with geographic attributes that you previously added. By default, a maximum of 500 APs per location
group are displayed.

The location groups are colored according to the overall health of the location:

• Red—indicates there are critical issues in the specified location.
• Yellow—indicates there are warnings in the specified location.
• Green—indicates there are no errors or warnings.
• Gray—indicates there are no devices or data in the specified location.

In addition to the color indicating the health, the icon can be:

• Solid—indicates a parent site, meaning there are children locations associated with the site.
• Outlined—indicates there are no children associated with this location.

Hover your mouse over any location on the map to view a popup window that lists the sites in that location
and the corresponding errors or warnings, by device type, in each location.

Click on a site name to view in a zoomed-in map of the site.

Related Topics
Define Health Rules, on page 15
Network Health Display Options, on page 16
Network Health Summary, on page 17
Creating Location Groups

Network Health Display Options
When you choose Dashboard > Network Summary > Network Health, display options appear on the right
side of the page as show in the below figure.
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Table 5: Network Health Display

Filter options. The options you select affect what is displayed in the map and the Health Summary pane.
Click Clear > Selection to remove all filters.

1

Time frame. By default, information from the last 6 hours is displayed in the Site Visibility map and
Health Summary pane.

2

Displays the map in the left pane.3

Displays the Network Health summary details in the Health Index view.4

Displays the Network Health summary details in a table format.5

Shows or hides the Health Summary pane on the right.6

Related Topics
Define Health Rules, on page 15
Network Health Map Features, on page 16
Network Health Summary, on page 17
Creating Location Groups

Network Health Summary
The Health Summary pane displays errors and threshold violations for all devices across all locations. Prime
Infrastructure aggregates health data from the devices and services to the site summary every 15 minutes.
Click on any of the sites or devices listed in the Health Summary pane to viewmore information. For example,
click on the site(s) listed under Service Health Issues. A new pane opens listing the sites with service health
issues where you can easily see in which area(s) the errors or warnings are occurring.

: Displays the areas in which service health related errors or warnings are occurring.

Click on a site name to have the map zoom in on that particular site and display additional information specific
to that site. You can edit the health rule settings of a site by clicking the settings icon next to the site name.
The modified health rule settings will get automatically updated in the Health Rules page. If a site doesn't
have assinged health rules, then the health rules displayed for that site represent the health rules of its parent
site.
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Related Topics
Define Health Rules, on page 15
Network Health Map Features, on page 16
Creating Location Groups

QoS Metrics
The Network Health page shows the QoS metrics for routers and switches. You can launch the QoS tab for
routers, switches and interfaces in the Network Health page by clicking the QoS hyperlink in the heatmap,
the Health summary view, Health index view, and Table view. The heatmap for routers and switches, shows
the aggregated QoS data per interface level and the average of dropOctetsRate across all QoS classes and all
directions for each interface.

Click the QoS tab in the Network Health page to viewmore granular data per class map for the chosen interface.
The QoS tab shows the following details:

• QoS class Map Statistics

• Top QoS class Map statistics Trend

• QoS drop Octets rate over time

The QoS tab shows more granular and is shown per class map for a given interface.
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Traffic Conversation
You can launch the Conversation tab in the Network Health page by clicking the traffic hyperlink in the
heatmap or the Conversations hyperlink as shows in the below image.

The conversation tab shows the following details:

• Top N Interface By Netflow chart
• Top N Other Sites graph
• Real Time Conversation table

The Real Time Conversation table shows the conversations based on the global filters (Site, Application
Data Source, and Time filter). If you want to view the real time conversations of a particular site or an interface,
click the site in the Top N Other Sites graph or the interface in the Top N Interface By Netflow chart. You
can view up to 4000 records in the Real Time Conversation table and the records get automatically refreshed
every minute.
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Work In a Different Virtual Domain
Virtual domains are logical groupings of devices and are used to control your access to specific sites and
devices. Virtual domains can be based on physical sites, device types, user communities, or any other
designation the administer chooses. All devices belong to ROOT-DOMAIN, which is the parent domain for
all new virtual domains. For more information about virtual domains, see "Create Virtual Domains to Control
User Access" in the Cisco Prime Infrastructure Administrator Guide.

If you are allowed access to more than one virtual domain, you can switch to a different domain by completing
the following procedure:

Step 1 Click from the right side of the title bar.
Step 2 Choose Virtual Domain: current-domain.
Step 3 From the Virtual Domain drop-down list, choose a different domain.

Prime Infrastructure immediately changes your working domain.

Manage Jobs Using the Jobs Dashboard
If you have the appropriate user account privileges, you can manage Prime Infrastructure jobs using the Jobs
dashboard. To view the Jobs dashboard, choose Administration > Dashboards > Job Dashboard. From
here, you can quickly see if a job was successful, partially successful, or failed.

If too many jobs are already running, Prime Infrastructure will hold other jobs in the queue until resources
are available. If this delays a scheduled job past its normal starting time, the job will not run. You will have
to run it manually.

Get Started With Cisco Prime Infrastructure
20

Get Started With Cisco Prime Infrastructure
Work In a Different Virtual Domain



Some jobs may require approval. In such cases, Prime Infrastructure sends an email to users with Administrator
privileges notifying them that a job was scheduled and needs approval. The job will only run after it is approved.

The following table describes the buttons displayed in the Jobs dashboard.

Table 6: Jobs Dashboard Buttons

DescriptionButton

Removes a job from the Jobs dashboard.Delete Job

Edit the settings configured for the selected job.Edit Job

Displays the series schedule and lets you edit it (start time, interval, and end time).

Editing the schedule of an already-scheduled job will change the status of
that job to Pending for Approval since each edit requires an approval
from the user who created the job.

Note

Edit Schedule

Runs a new instance of the selected job. Use this to rerun partially successful or failed
jobs; the job will only run for the failed or partially successful components.

Run

Stops a currently-running job, but allows you to rerun it later. Not all jobs can be aborted;
Prime Infrastructure will indicate when this is the case.

Abort

Stops a currently-running job and does not allow anyone to rerun it. If the job is part of
a series, future runs are not affected.

Cancel Series

Pauses a scheduled job series. When a series is paused, you cannot run any instances
of that series (using Run).

Pause Series

Resumes a scheduled job series that has been paused.Resume Series

The Delete Job, Abort, and Cancel Series buttons are not available for system and poller jobs.Note

If you have logged in as a root user, then you can view all the jobs under Job Dashboard. If you have logged
in as a non-root user, then you can only view the jobs performed by you.

Note

To view the details of a job, follow these steps:

Step 1 Choose Administration > Dashboards > Job Dashboard.
Step 2 From the Jobs pane, choose a job series to get basic information (such as job type, status, job duration, and next start

time).
Step 3 To view the job interval, click a job instance hyperlink.

At the top of the job page, the Recurrence field indicates how often the job recurs. Job interval details will be added for
every job that triggers.
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Step 4 To get details about a failed or partially successful job, click the job instance hyperlink and expand the entries provided
on the resulting page.

This is especially helpful for inventory-related jobs. For example, if a user imported devices using a CSV file (a bulk
import), the job will be listed in the Jobs sidebar menu under User Jobs > Device Bulk Import. The job details will list
the devices that were successfully added and the devices that were not.

Example

To troubleshoot a failed software image import job:

1. Choose User Jobs > Software Image Import from the Jobs sidebar menu.

2. Locate the failed job in the table and then click its hyperlink.

3. Expand the job's details (if not already expanded) to view the list of devices associated with the
job and the status of the image import for each device.

4. To view the import details for a specific device, click that device's i (information) icon in the
Status column. This opens an Image Management Job Results pop-up window.

5. Examine each step and its status. For example, the Collecting image with Protocol: SFTP
column might report that SFTP is not supported on the device.

Extend Cisco Prime Infrastructure Functions
Advanced users can extend Cisco Prime Infrastructure functions and manage administrative options using
the Cisco Prime Infrastructure REST API.

To get information about this tool, click at the top right of the Prime Infrastructure web GUI, and then
choose Help > REST APIs. You can also download the Cisco Prime Infrastructure API Reference Guide
directly from Cisco.com.

Check Cisco.com for the Latest Documentation
Refer to Cisco Prime Infrastructure Documentation Overview for information about and links to all of the
documentation that is provided with Prime Infrastructure.

We sometimes update the documentation after original publication. Therefore, you should also review the
documentation on Cisco.com for any updates.

Note
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