
Get Started With Cisco EPN Manager

If you are an administrator and need to set up Cisco EPN Manager for its initial use, see Server Setup Tasks.Note

• Web Client Requirements, on page 1
• Log In and Out, on page 2
• Setup Tasks to Complete Before Using Cisco EPN Manager, on page 2
• Change Your Password, on page 3
• Use the Main Window Controls, on page 3
• Change Your Default Home Page, on page 4
• Set Up and Use the Dashboards, on page 4
• Work In a Different Virtual Domain , on page 23
• Manage Jobs Using the Jobs Dashboard, on page 23
• Change User Preferences, on page 25
• Extend Cisco EPN Manager Functions, on page 28
• Check Cisco.com for the Latest Cisco EPN Manager Documentation, on page 29

Web Client Requirements
The following are the client and browser requirements for the Cisco EPN Manager Web GUI:

• Hardware—Mac orWindows laptop or desktop compatible with one of the tested and supported browsers
that are listed below.

• Browsers:

You can have up to three Cisco EPN Manager tabs open simultaneously in a
single browser session.

Note

• Google Chrome versions 70 onwards

• Mozilla Firefox ESR version 78

• Mozilla Firefox versions 70 onwards
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• Recommended display resolution—1600x900 pixels or higher (minimum: 1366x768)

To improve loading time and reduce network bandwidth usage, Cisco EPN Manager caches static files (js,
css) in the browser in the same version of Cisco EPN Manager (Firefox browsers).

Google Chrome ignores all caching directives and reloads page content because of known limitations about
self-signed certificates.

Note

Log In and Out
To log into the GUI, enter the following in your web browser address field, where server-ip is the IP address
of the Cisco EPN Manager server:

https://server-ip

Do not autofill or save any username and password in the browser when you log in to Cisco EPN Manager.Note

Depending on your network configuration, the first time your browser connects to the Cisco EPN Manager
web server, you may have to update your client browser to trust the security certificate of the server. You can
also generate and import user-specific client certificates to your browser, which allows the user to log into
Cisco EPN Manager. These generated client certificates allow you to log in without specifying a username
or password. These generated client certificates require a passcode when you update them to your browser.
This ensures the security of the connection between your client and the Cisco EPN Manager web server.

To log out, click at the top right of the Cisco EPN Manager window and choose Log Out.

For information on Cisco EPN Manager users and the actions they can perform, see:

• How to Transition Between the CLI User Interfaces in Cisco Evolved Programmable Network Manager
—Describes all classes of users supported by Cisco EPN Manager, including the various CLI user
accounts.

• Types of User Groups—Describes the user group mechanism which allows you to control the functions
that everyday web GUI users can perform. What you can see and do in the user interface is controlled
by your user account privileges. This topic also describes the virtual domain mechanism, which manages
Role-Based Access Control (RBAC) for devices.

Setup Tasks to Complete Before Using Cisco EPN Manager
Before you can use the Cisco EPN Manager features, these tasks should be completed by an administrator:

Table 1: Setup Tasks and References

For information, see:Tasks to complete before using Cisco EPN Manager

Server Setup TasksSetup and configure the Cisco EPN Manager server.
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For information, see:Tasks to complete before using Cisco EPN Manager

Add and Organize DevicesAdd devices to Cisco EPN Manager and create device
groups to simplify device and network management.

Monitor Device and Network Health and
Performance

Enable monitoring for interfaces and technologies used by
the network.

Set Alarm and Event Management PreferencesCustomize alarm and event behavior for your deployment
(for example, alarm and event refresh rates, and e-mail and
trap receivers).

Change Your Password
To change your domain password,

• Click at the top right of the Cisco EPN Manager window and choose Change Password or navigate
to Administration > Users > Change Password. Click the ? (Help) icon to review the password policy.

• Enter the Current Password and the New Password. Confirm the new password.

• Click the Change Password button to save the password.

Use the Main Window Controls
The top left of the Cisco EPN Manager title bar provides the following controls.

Menu button—Toggles themain Cisco EPNManager navigationmenu on the left (also called
the left sidebar menu)

Home button—Returns you to the home page (normally the Overview Dashboard)

The right side of the title bar displays your username and the virtual domain you are working in. A virtual
domain is a logical grouping of devices. Virtual domains are used to control who has access to the devices
and areas of the network. To switch between virtual domains that are assigned to you, see Work In a Different
Virtual Domain , on page 23.

Web GUI global settings—log out, change password, view your Cisco.com account profile,
adjust your GUI preferences, check a Cisco.com support case, and so on.

Current Server Time—displays the current server time and date.

Online Help—launches the online help (User and Admin guide) for Cisco EPN Manager.

Refresh—refreshes the page.

Dock—opens a side dock window that displays your recent searches and navigational history.
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The Alarm Summary gives you a visual indicator of number of alarms in your network. The color indicates
the highest severity alarm.

Alarm Summary—Provides a visual count of alarms in the categories that you specify.
Clicking this area opens the Alarm Summary popup window.

When you click theAlarm Summary button, Cisco EPNManager opens theAlarm Summary popupwindow.
You can customize the data that is displayed in both the button and the pop-up window.

Application Search—Global search tab that can be used
to search the entire Cisco EPN Manager database. You
can also use the filters for Advanced Search and Saved
Search.

Application Search cannot be used to search
any data underRaw Configuration Archive.

Note

Change Your Default Home Page
You can specify which page you want to display when you perform either of the following tasks:

• You click from the left side of the web GUI title bar.

• You log in to the Cisco EPN Manager web GUI.

This setting is saved on a per-user basis. You can change it at any time without affecting other users.

Step 1 While you have the page you want displayed, click at the top right of the Cisco EPN Manager web GUI.
Step 2 Choose Set Current Page as Home.

Set Up and Use the Dashboards
Dashboards provide at-a-glance views of the most important data in your network. They provide status, alerts,
monitoring, performance, and reporting information. You can customize these dashboards so they contain
only the information that is important to you. It may be helpful to set the Network Summary dashboard as
your default home page. By doing so, this dashboard is displayed after you log in and you can quickly check
overall network health before you do anything else. To set any dashboard as your default home page, see
Change Your Default Home Page, on page 4.

Use the following dashboards to monitor and manage your network:

To view data on the dashboards, you must enable the relevant monitoring policies. By default, only device
health monitoring (Device Health monitoring policy) is enabled. See How Device Health and Performance
Is Monitored: Monitoring Policies for more information.

Note
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• Network Summary dashboard—To check the health of the entire network. See Network Summary
Dashboard Overview.

• Service Performance dashboard—To monitor Carrier Ethernet and optical service performance. See
Service Performance Dashboard Overview.

• Performance dashboard—To view high-level performance metrics for network components such as
interfaces, QoS policies, and ITU-T Y.1731 probes. See Performance Dashboard Overview.

• DWDM/OTN Performance dashboard—To view performance information for the dense wavelength
division multiplexing (DWDM) and Optical Transport Network (OTN) interfaces in your network. See
DWDM/OTN Performance Dashboard Overview.

Users with administrator privileges can also use the following dashboards (Administration > Dashboards):

• Licensing dashboard—See View the Licensing Dashboard.

• Jobs dashboard—See Manage Jobs Using the Jobs Dashboard, on page 23.

• System Monitoring dashboard—See Check Cisco EPNManager Server Health, Jobs, Performance, and
API Statistics Using the System Monitoring Dashboard.

• For details of the dashboard window and how to use dashboard filters, see How to Use the Dashboards,
on page 18.

• To troubleshoot dashboard data issues, see Find Out Why Data Is Missing from a Dashboard.

Types of Dashboards
The following topics describe the dashboards available in Cisco EPN Manager.

Service Performance Dashboard Overview
From the Service Performance dashboard, you can view the performance statistics for a particular circuit,
VC, or service during the time frame you specify. To open this dashboard, choose Dashboard > Service
Performance > any of the tabs described in the following table.

Get Started With Cisco EPN Manager
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Information ProvidedDashboard Tab

For the selected Circuit Emulation (CEM) circuit:

• Details such as its name, type, and creation date

• Statistics (you can toggle between the statistics for the circuit's
endpoints)

• Number of packets lost during transmission

• Number of packets reordered in the jitter buffer before they reached
their destination

• Number of jitter buffer overruns and underruns

• Number of packets ordered incorrectly and subsequently dropped

• Number of malformed packets

• Number of seconds that were errored, severely errored, or unavailable

• Failed events

• Dashlets that chart the number of Explicit Pointer Adjustment Relay
counters (such L-bits and P-bits) that have been generated and received

To view these dashlets, both the CEM and Pseudowire
Emulation Edge to Edge monitoring policies must be
enabled. See Monitoring Policies Reference.

Note

CEM

For the selected Traffic Engineering (TE) tunnel circuit:

• Details such as its name, serviceability state, and associated endpoint

• Service statistics

• Outgoing traffic, bandwidth utilization, and reserved bandwidth

• Service availability

TE Tunnel

For the selected Segment Routing (SR) policy:

• Details such as its name, serviceability state, and associated endpoint

• Service statistics

• Outgoing traffic, bandwidth utilization, and reserved bandwidth

• Service availability

SR Policy

Get Started With Cisco EPN Manager
6

Get Started With Cisco EPN Manager
Service Performance Dashboard Overview

bk_cisco_epnm_7_0_0_user_and_administrator_guide_ga_appendix4.pdf#nameddest=unique_29


Information ProvidedDashboard Tab

For the selected circuit or VC:

• Details such as its name, discovery state, and the last time it was
modified

• Lists the circuits and VCs with the highest values for the following
parameters:

• Average traffic between endpoints

• QoS class traffic and drops

You can toggle between inbound and outbound data. In
the Top N Service QoS Class Traffic dashlet, you can
also toggle between pre and postpolicy data.

Note

• Inbound and outbound QoS drops

• Service traffic and availability

• Two-way delay, one-way jitter, and service loss

• End-to-end performance statistics for service probes with a
cross-launch to the IPSLA dashboard for EVCs or to the Y.1731
dashboard for L3VPN services.

CE/L3VPN

Lists the circuits and VCs with the highest values for the following
parameters:

• Delay

• Jitter

• Service loss

• Traffic (both inbound and outbound)

You can toggle between CE and L3VPN services information.

For large L3VPN circuits with more than 2000 endpoints,
data cannot be displayed.

Note

Top CE/L3VPN

From release 7.0 onwards, for Cisco NCS 2000 series devices, Cisco EPN Manager utilizes the device
timestamp data to store and display the historical PMON metric records. Earlier, local timestamp data was
used, which displayed inaccurate (old) data in the graphs. Therefore, to avoid getting false data, always set
the device timestamps to current date and time.

For a description of how to customize the contents and layout of a dashboard tab, see Customize a Dashboard
Tab.

Note

Get Started With Cisco EPN Manager
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Performance Dashboard Overview
From the Performance dashboard, you can view high-level performance metrics for network components
such as device, interfaces, QoS policies, and ITU-T Y.1731 probes. To open this dashboard, choose
Dashboard > Performance > any of the tabs described in the following table.

Information ProvidedDashboard Tab

For the selected device:

• Device Memory Utilization Trend—displays the memory
utilization graphs for the device. You can choose the required
time frame and dates from the drop-down/checkboxes (Zoom
and Date).

• DeviceMemory Utilization Trend—displays the CPU utilization
graphs for the device. You can choose the required time frame
and dates from the drop-down/checkboxes (Zoom and Date).

• Device Health information—displays various device health
information such as temperature, alarms, events, and reachability.
You can choose the required time frame and dates from the
drop-down/checkboxes (Zoom and Date).

• Device Port Summary—displays the port summary. You can
click the Down Ports to view details about ports that are down.

• Device Availability Trend—displays the device availability
graphs (against time) for the device. You can choose the required
time frame and dates from the drop-down/checkboxes (Zoom
and Date).

• Custom MIB Table View and Custom MIB Graph
View—displays custom MIB information (if any).

Device

Get Started With Cisco EPN Manager
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Information ProvidedDashboard Tab

For the selected interface:

• Details such as its name, the IP address of the device it is located
on, and its configured speed.

• The average, minimum, and maximum values for the following
performance metrics (you can toggle between the metrics
collected for inbound and outbound data):

• Traffic

• Utilization

• Errors

• Discards

• Cyclic redundancy check (CRC) errors

CRC error data is not polled by default. To
enable the collection of this data, choose a
polling frequency for the Interface Health
monitoring policy's CRC parameter (see
Change the Polling for a Monitoring Policy).

Note

• Individual graphs that chart the performance metrics listed in the
Interface Statistics dashlet

• Interface availability

• Top N QoS class map policy graph (inbound and outbound
prepolicy rate, postpolicy rate, and drops percentage)

• QoS class map policy statistics (inbound and outbound)

Interfaces

For the selected QoS policy:

• Summary information

• Statistics and graphs for prepolicy, postpolicy, and dropped class
map traffic.

• Statistics and graphs for conforming, exceeding, and violating
class map traffic

QoS

For Layer 3 services on the selected probe:

• Summary information

• IP Service Level Agreement (SLA) statistics

• Delay, jitter, and frame loss between endpoints

• Endpoint availability

IP SLA

Get Started With Cisco EPN Manager
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Information ProvidedDashboard Tab

For Layer 2 services on the selected probe:

• Summary information

• ITU-T Y.1731 statistics

• Delay, jitter, frame loss, and CCM frame loss between endpoints

• Jitter Bins Statistics

• Delay Bins Statistics

• Endpoint availability

Bins statistics data is not polled by default. To enable
the collection of this data, choose a polling frequency
for Bins Statistics parameters in IP SLA Y.1731
Monitoring Policy (see Change the Polling for a
Monitoring Policy).

Note

Y1731

Broadband Network Gateway (BNG) information for the selected
device:

• Details such as its name, IP address, product type, and software
version

• Names of configured IP pools, and the number and percentage
of available addresses used by each pool

• Chart that graphs the number of used or free addresses for the
selected IP pools

• Charts that graph the number of sessions for authenticated and
up subscribers by line card and session type

Note • Use the check boxes below the charts to select the
items you want to view.

• Place your cursor over any point in the graphs to
view the values for the selected items at that
particular time.

BNG Statistics (deprecated)
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Information ProvidedDashboard Tab

Quality of Service (QoS) information for the selected service on a
Cisco ME 1200 device:

• Details such as the name of the device, the customer associated
with this device, and its user-network interface (UNI) port.

• Average bit and frame rates for green (conforming), yellow
(exceeding), red (violating), and discard traffic. You can toggle
between inbound and outbound traffic data.

• Graphs that chart the traffic measured for the traffic types listed
in the ME1200 QoS Statistics dashlet.

Note the following:

• Five traffic graphs are provided: one for each traffic type
and one consolidated graph.

• You can toggle between viewing the data by frame rate (in
frames per second) or bit rate (in kilobits per second).

• You can specify the elements you want to view in a chart
by checking the appropriate check box below that chart. In
the consolidated traffic dashlet, you can specify traffic types.
And in the individual traffic dashlets, you can specify one
or multiple EVC Control Entries (ECEs) associated with
the service.

ME1200 QoS (deprecated)
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Information ProvidedDashboard Tab

For the selected Small Form-Factor Pluggable (SFP) Transceiver
Module interface:

• Details such as its name, the name, and IP address of the device
on which the interface is located, and its configured speed.

• The average, minimum, and maximum values for the following
operating metrics for a device:

• Optical input and output power

• Operating temperature

• Transceiver supply voltage

• Laser bias current

For the selected Quad Small Form-Factor Pluggable (QSFP)
Transceiver Module interface:

Individual lane average, minimum, and maximum values for:

• Temperature

• Voltage

• Current

• Tx power

• Rx power

• Individual graphs that chart the operating metrics listed in the
SFP Statistics dashlet

Optical SFPs

Get Started With Cisco EPN Manager
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Information ProvidedDashboard Tab

For the selected SONET or time-division multiplexing (TDM)
interface:

• Details such as its name, configured speed, and the IP address
of the device it is located on.

• The average, minimum, and maximum values for the following
performance metrics:

• Errored seconds

• Severely errored seconds

• C-bit severely errored seconds

• P-bit severely errored seconds

• Unavailable seconds

Values are provided for both the near-end (the receiving end)
and far-end (the transmitting end) of the interface.

• Individual graphs that chart the performance metrics listed in the
SONET/TDM Statistics dashlet

SONET/TDM Interfaces

For each sensor of the selected device:

• Name

• Description

• Measurement type

• Current value

Click the i icon on the current value to view the trend over last 6 hours.

Device Sensors

You can get the following details for the link you select:

• Link details such as the link name, endpoint device and interface.

• Link delay (one-way and two-way).

You can click Link Name in the Top N MPLS Links
Table to launch the MPLS links dashboard on the
selected link.

Note

MPLS Links Latency

Note the following:

• Interface monitoring is not enabled by default. For information on how to check this, see Check What
Cisco Evolved Programmable Network Manager Is Monitoring.

• For a description of how to customize the contents and layout of a dashboard tab, see Customize a
Dashboard Tab.
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Network Summary Dashboard Overview
The Network Summary dashboard alerts you to the most important issues currently affecting your network.
It also collects metrics from various sources to display a set of key performance indicators (KPIs). To open
this dashboard, choose Dashboard > Network Summary > any of the tabs described in the following table.

Information ProvidedDashboard Tab

• Status (ICMP reachability, SNMP reachability, devicemanageability), system health,
and alarm summary metric dashlets

Note the following:

• To open a pop-up window that describes the information provided by a metric
dashlet, place your cursor over its name and then click the ? icon.

• To open a page that lists the alarms or devices that correspond to a particular
metric, click a dashlet value. For example, if the SNMP Reachability Status
dashlet indicates that 50 devices are currently reachable via SNMP, click 50
to open the Network Devices page and view a listing of these devices.

• Top N devices by CPU utilization, memory utilization, and environmental
temperature

For the Top N Environmental Temperature dashlet, note the following:

• Two temperature values are provided for each device: its highest recorded
internal temperature (displayed in theMax Inlet Temp column) and its highest
recorded ambient temperature (displayed in the Max Other Temp column).
By default, devices are sorted by their internal temperature.

• To identify the sensor that recorded a particular temperature value, place your
cursor over its i (information) icon.

Network Devices

Get Started With Cisco EPN Manager
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Information ProvidedDashboard Tab

• System health and alarm summary metric dashlets

Note the following:

• To open a pop-up window that describes the information provided by a metric
dashlet, place your cursor over its name and then click the ? icon.

• To open a page that lists the alarms that correspond to a particular metric, click
a dashlet value. For example, if the Alarm Summary dashlet indicates that 12
critical alarms have been raised in your network, click 12 to open the Alarms
page and view a listing of these alarms.

• Alarm count for the entire network and the Cisco EPN Manager server

• Top N alarm types

• Syslog summary

• Top N event types and their count

• Top N devices by number of syslogs sent

• Syslog details such as the corresponding device, severity, and message text

• Top N devices by number of alarms raised

Incidents

For the selected port group:

• Interface availability and utilization summaries

• Top N devices by interface traffic, errors and discards, cyclic redundancy check
(CRC) errors, and utilization

CRC error data is not polled by default. To enable the collection of
this data, choose a polling frequency for the Interface Healthmonitoring
policy's CRC parameter (see Change the Polling for a Monitoring
Policy).

Note

• Bottom N devices by interface availability

Also note that the dashlets in this tab (except for the summary dashlets) allow you to
open the 360 view for a device's adjacent device or interface by clicking its i (information)
icon.

Top N Interfaces

For the selected port group:

• Top N devices by QoS prepolicy, postpolicy, and drop rates

• Top N devices by conforming, exceeding, and violating traffic rates

You can toggle between inbound and outbound traffic data.

Top N QoS

Get Started With Cisco EPN Manager
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Information ProvidedDashboard Tab

Endpoints with the highest values for the following parameters:

• Delay (one-way and two-way)

• Jitter (one-way and two-way)

• Frame loss

Top N Y1731

• Delay (one-way and two-way)

You can click Link Name in the Top N MPLS Links Table to launch the
MPLS links dashboard on the selected link.

Note

Top N MPLS
Links Latency

• PTP Clock Class over time

• Servo State over time

• SyncE Quality Level over time

Cisco EPN Manger uses the values that you have configured in the
PTP/SyncE System Settings page to display data in the dashboard. See
PTP/SyncE Dashboard Settings, on page 17 for more information.

Note

PTP/SyncE

• GNSS Module Satellite ID and SNR detailsGNSS

You can view specific data by adding or removing columns in the dashlets. In the Top N Interfaces, Top N
QoS, and Top N Y1731 tabs, you can also use the Sort by option to sort the data displayed in the columns.

In the Top N Interfaces and Top N QoS tabs you can:

• Choose a specific device group and/or port group to view only information for those devices/ports.

• To filter data for all the dashlets based on port/device groups, use the Port Groups filter at the top
of the dashboard.

• To filter data for a specific dashlet only, click the dashlet's Edit icon and choose a device/port group
from the Port Groups and/or Device Groups drop-down list.

• Filter the data in the dashlets by Class Map (and you can choose to exclude the class-default).

• Filter the data in the dashlets using the Time Frame (default is Past 6 hours).

• Click an interface's name link to view performance information for that interface in the Performance
dashboard. If you click a link in the Top N Interfaces tab, the Interfaces tab opens. If you click a link
in the Top N QoS tab, the QoS tab opens instead.

• Interface monitoring is not enabled by default. For information on how to check this, see Check What
Cisco Evolved Programmable Network Manager Is Monitoring.

• For a description of how to customize the contents and layout of a dashboard tab, see Customize a
Dashboard Tab.
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PTP/SyncE Dashboard Settings

To configure metrics that are used by Cisco EPN Manger to display data in the PTP/SyncE dashboard,
navigate to Administrator > System Settings > Performance > PTP/SyncE. Configure the metrics as
required and click Save.

ActionDescriptionSection

Enter values from the entire range
of 0–255. Ensure that there is no

Allows you to define the range of
values of PTP Clock Class that

PTP Clock Class

overlap in values between the three
categories.

should be reported as Ok or
Degraded or Failure.

Configure each of the five states in
this section to Ok or Degraded or
Failure.

Allows you to define how Cisco
EPN Manager reports each of the
five possible PTP Servo states.

PTP Servo State

Choose a value from the drop-down
list.

Allows you to define the SyncE
quality levels that Cisco EPN
Manager reports as Ok. By default,

SyncE Quality level

Cisco EPN Manger allows you to
define two values as Ok. You can
add a third value if required by
selecting the check-box next to the
grayed out field. Any other SyncE
QL values apart from the ones that
you have defined as Ok is reported
as Degraded.

Enter a value between 0–65535.You can define the correct UTC
offset in the system. Cisco EPN

UTC Offset

Manger reports the devices
configured with the matching value
of UTC offset as Correct UTC
offset and devices configured with
offset not matching this value as
Incorrect UTC Offset.

DWDM/OTN Performance Dashboard Overview
The DWDM/OTN Performance dashboard displays performance information for the Dense Wavelength
Division Multiplexing (DWDM) and Optical Transport Network (OTN) interfaces that are traversed by a
specific circuit. This includes Circuit, Optical physical, Optical Data Unit (ODU), Optical Transport Unit
(OTU), Ethernet, Synchronous Optical Network (SONET), and Synchronous Digital Hierarchy (SDH)
interfaces.

To open this dashboard, perform one of the following actions:

• Choose Dashboard > DWDM/OTN Performance > Circuit. Click an interface name in the Interfaces
dashlet. The relevant tab for the type of interface opens. For example, if you click an OTU interface, the
OTU tab opens.

• From an Interface 360 view, choose View > Performance.

Get Started With Cisco EPN Manager
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For IOS-XR devices, the dashboard displays performance information of the collected OTN 15mins interface
or the chosen specific OTN 15 mins parameter. The different parameters are:

• OTU FEnd

• OTU NEnd

• ODU FEnd

• ODU NEnd

• OTN GFP

• OTN FEC

Note

Note the following:

• Interface monitoring is not enabled by default. For information on how to check this, see Check What
Cisco Evolved Programmable Network Manager Is Monitoring.

• For a description of how to customize the contents and layout of a dashboard tab, see Customize a
Dashboard Tab.

How to Use the Dashboards
The following figure illustrates the key parts of a dashboard window and the controls that you can use to
adjust them.
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Table 2: Dashboard Elements

Dashboard filters—Filters all dashlets in the dashboard according to the selection. In this example, a
time-based filter is used. The filters displayed depend on the dashboard type. For example, in the
performance dashboards, you must select a specific interface, device, circuit, or VC.

1

Metric dashlets—Provides quick metrics for alarms, available devices, and so forth.2

Dashboard settings and controls:

• Dashboard icons—Allows you to launch online help, refresh the entire dashboard, provide feedback,
and open the Dock window.

• Dashboard Settings menu—Allows you to add or rename a dashboard tab, add new dashlets (both
standard and metric), adjust the dashboard's layout, reset all dashboards to their default settings,
and export data from the selected dashlets.

The newly added or a renamed dashboard tab can be viewed only in the Tab view.
This change is not reflected in the Dashboard menu.

Note

3

Standard dashlets—Provides at-a-glance data that is relevant to the dashboard.4

The top-right corner of each dashlet has icons that are activated when you use that dashlet. The dashlet type
determines the icons that are available. The most common icons are displayed in the following figure:

Edit icon—Click to change a dashlet's properties, such as its title, refresh interval, and the number of
devices that are displayed (applicable only to Top N and Bottom N dashlets).

1

Help icon—Click to open a pop-up window that describes the dashlet, indicates the monitoring policy
that must be activated to collect data by the dashlet, and lists the filters that can be applied to the dashlet.

2

Refresh icon—Click to refresh the information displayed in the dashlet.3

Collapse/Expand icon—Click to toggle between a maximized and minimized dashlet.4

Close icon—Click to remove the dashlet from the dashboard.5

The bottom-left corner of each dashlet has icons that can be used to change the display type of the data and
export them. The most common icons are given in the following table:

DescriptionIcon

• Chart View—Click to view the dashlet information as a chart.

• Table View—Click to view the dashlet information as a table.
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DescriptionIcon

Chart Type—Click to choose the type of chart a dashlet displays (such as displaying a unique
fill pattern for each element).

Actions—Click to print the information provided by the dashlet or export the information.

You can also see the current date, time, and time zone, which is displayed in the standard time format of
DD-MMM-YYYY hh:mm:ss AM/PM Z, where Z is the time zone.

Add a New Dashboard
Use this procedure to create a new dashboard. Your new dashboard appears as a new tab under one of the
dashboards listed in Types of Dashboards, on page 5.

Step 1 Open the relevant existing dashboard.

For example, if you want to create a new tab under the Performance dashboard, click any tab under Dashboard >
Performance.

Step 2 Click the Settings menu and choose Add New Dashboard.
Step 3 Enter a name for the new dashboard and click Apply.
Step 4 Click the new dashboard tab, and then add dashlets as described in Add a Predefined Dashlet To a Dashboard, on page

21.

Customize a Dashboard Tab
To customize a tab in any of the dashboards that Cisco EPN Manager provides, complete the following
procedure:

Step 1 Choose the dashboard tab that you want to customize.

For example, if you want to customize the Performance dashboard's Device tab, choose Dashboard > Performance >
Device.

Step 2 Adjust the dashboard tab as needed.

You can perform the following actions:

• Drag dashlets to a different location on the dashboard.

• From the tab's Settings menu, rename a tab, add new dashlets (see Add Dashlets to Dashboards), and change the
tab's layout.

The newly added or renamed dashboard tab can be viewed only in the Tab view. This change is not reflected in the
Dashboard menu.

To open a pop-up window that provides an overview of a dashlet you are thinking about adding, expand
the Add Dashlets drop-down list, locate the dashlet, and then hover your cursor over its name.

Note

• Use the filters to specify the information you want to view and the appropriate time frame, then click Apply.
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Step 3 If necessary, troubleshoot why the tab is not displaying any data.

See Find Out Why Data Is Missing from a Dashboard for more information.

Add Dashlets to Dashboards
You can add two types of dashlets to your dashboards:

• Prepackaged dashlets that are provided with Cisco EPN Manager—Some of the dashlets are displayed
on dashboards by default; others are listed in the Settings menu, and you can add them as needed. These
dashlets provide information you will likely monitor (for example, device CPU utilization, interface
errors and discards, and traffic statistics). See Add a Predefined Dashlet To a Dashboard, on page 21.

Add a Predefined Dashlet To a Dashboard

Cisco EPN Manager provides a predefined set of dashlets that provides you with commonly sought network
data. By default, a subset of these dashlets is already included in the dashboards, to help you get started.
Complete the following procedure to add another of these predefined dashlets to your dashboards.

To edit or remove a dashlet, click the appropriate icon from the top-right corner of that dashlet. (See How to
Use the Dashboards.)

Note

Step 1 From the sidebar menu, choose Dashboard, then select the dashboard you want to add a dashlet to.

For example, to add aDevice Memory Utilization dashlet to theDevice dashboard, chooseDashboard > Performance >
Device.

Step 2 Identify the dashlet that you want to add, then add it:
a) From the top-right corner of the dashboard, click Settings and then click Add Dashlet(s). Cisco EPN Manager lists

the dashlets that can be added to that dashboard.
b) To open a pop-up window that provides an overview of a particular dashlet, hover your cursor over dashlet's name.

The pop-up window also lists the sources for the data that the dashlet provides and the filters you can apply to the
dashlet.

c) Click Add to add the selected dashlet to the dashboard.

Step 3 Verify that the dashlet is populated with data.

If it is not, check whether the requiredmonitoring policy is enabled. (Only the Device Health monitoring policy is enabled
by default. It checks device availability, CPU and memory pool utilization, and environmental temperature.)

a) From the top-right corner of the dashlet, click its ? (Help) icon to open the dashlet's pop-up window.
b) Check the information provided in the Data Sources area. If it lists a monitoring policy, check whether the policy is

activated. See Check What Cisco Evolved Programmable Network Manager Is Monitoring.
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Customize the Dock Window
Use the Dock window for quick navigation to frequently used web GUI pages and pop-up windows (such as
the 360 view for a particular device). From here, you can also access links to the 15 most recently visited
pages and Cisco EPN Manager training materials. To open this window, click the Dock icon (located in the
top right area of the page).

Complete the following procedure to update the links provided in the Dock window:

Step 1 Add a web GUI page link to the Favorites tab (Dock icon > Links Visited > Favorites):
a) Open the web GUI page you want to add.
b) Click its star (Favorite) icon, which is located in the top left area of the page.

Step 2 Add a pop-up window link to the Docked Items area (Dock icon > Docked Items):
a) Open the pop-up window you want to add, then open its 360 view.
b) From the top right corner of the pop-up window, click the Add to Dock icon.

Find Out Why Data Is Missing from a Dashboard
If data is missing from a dashboard or dashlet, Cisco EPN Manager displays possible reasons in an error
message in the dashlet such as:

• Monitoring policy not enabled

• Unmanaged or unreachable devices in the system

• Technology isn’t supported on the device

• Inaccurate server time or server time not synced with the device

Perform the following steps to identify the cause:

Step 1 Check whether the dashlet data is filtered.

If you see Edited next to the dashlet name, do the following:

a) Click the Edit icon and adjust the current filter settings.
b) Click Save and Close.

Step 2 Check whether there is a problem with the device.

See Get Basic Device Information: Device 360 View.

Step 3 Check whether the device inventory is being collected properly.

See Find Devices With Inventory Collection or Discovery Problems.

Step 4 Check whether Cisco EPN Manager is collecting the required data by viewing the monitoring policies it is using:
a) Open the dashlet's overview pop-up window by clicking its Help icon.
b) Note the monitoring policy listed under Data Sources.

Monitoring policies are described in Monitoring Policies Reference.

c) Verify that this policy is listed and active in the Monitoring Policies page.
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To open this page, choose Monitor > Monitoring Tools > Monitoring Policies, then choose My Policies.

• If the policy is not listed, proceed to Step 4d.

• If the policy is listed and its status is Active, click Details to open the Collection Data pop-up window and see
if the device is being monitored by the policy. If it is not, you must adjust the policy as described in Change the
Device Set a Policy is Monitoring. If the device is included in the policy, proceed to Step 5.

• If the policy is listed and its status is Inactive, select the policy and click Activate.

d) Create a new monitoring policy and activate it.

See Adjust What Is Being Monitored.

Step 5 Check whether the relevant data was purged from the system.

See How Data Retention Settings Affect Web GUI Data.

Work In a Different Virtual Domain
Virtual domains are logical groupings of devices and are used to control your access to specific sites and
devices. Virtual domains can be based on physical sites, device types, user communities, or any other
designation the administer chooses. All devices belong to ROOT-DOMAIN, which is the parent domain for
all new virtual domains. For more information about virtual domains, see Create Virtual Domains to Control
User Access to Devices.

If you are allowed access to more than one virtual domain, you can switch to a different domain by completing
the following procedure:

Step 1 Click from the right side of the title bar.
Step 2 Choose Virtual Domain: current-domain.
Step 3 From the Virtual Domain drop-down list, choose a different domain.

Cisco EPN Manager immediately changes your working domain.

Manage Jobs Using the Jobs Dashboard
If you have the appropriate user account privileges, you can manage Cisco EPNManager jobs using the Jobs
dashboard. To view the Jobs dashboard, choose Administration > Dashboards > Job Dashboard. From
here, you can quickly see if a job was successful, partially successful, or failed.

If too many jobs are already running, Cisco EPN Manager will hold other jobs in the queue until resources
are available. If this delays a scheduled job past its normal starting time, the job will not run. You will have
to run it manually.
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Some jobs may require approval. In such cases, Cisco EPNManager sends an email to users with Administrator
privileges notifying them that a job was scheduled and needs approval. The job will only run after it is approved.
See Configure Job Approvers and Approve Jobs.

You can set a time interval at which the jobs table is auto-refreshed. Click Settings in the upper corner of the
page, select a value from the drop-down list in the field Set Auto Refresh Rate and click Save.

To disable auto-refresh of the jobs table, select OFF from the drop-down list.Note

The following table describes the buttons displayed in the Jobs dashboard.

Table 3: Jobs Dashboard Buttons

DescriptionButton

Removes a job from the Jobs dashboard.Delete Job

Edit the settings configured for the selected job.Edit Job

Displays the series schedule and lets you edit it (start time, interval, and end time).

Editing the schedule of an already-scheduled job will change the status of
that job to Pending for Approval since each edit requires an approval
from the user who created the job.

Note

Edit Schedule

Runs a new instance of the selected job. Use this to rerun partially successful or failed
jobs; the job will only run for the failed or partially successful components.

Run

Stops a currently-running job, but allows you to rerun it later. Not all jobs can be aborted;
Cisco EPN Manager will indicate when this is the case.

Abort

Stops a currently-running job and does not allow anyone to rerun it. If the job is part of
a series, future runs are not affected.

Cancel Series

Pauses a scheduled job series. When a series is paused, you cannot run any instances
of that series (using Run).

Pause Series

Resumes a scheduled job series that has been paused.Resume Series

The Delete Job, Abort, and Cancel Series buttons are not available for system and poller jobs.Note

If you have logged in as a root user, then you can view all the jobs under Job Dashboard. If you have logged
in as a non-root user, then you can only view the jobs performed by you.

Note

To view the details of a job, follow these steps:
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Step 1 Choose Administration > Dashboards > Job Dashboard.
Step 2 From the Jobs pane, choose a job series to get basic information (such as job type, status, job duration, and next start

time).
Step 3 To view the job interval, click a job instance hyperlink.

At the top of the job page, the Recurrence field indicates how often the job recurs. Job interval details will be added for
every job that triggers. The job details page is refreshed every 5 seconds until the job is completed.

Step 4 To get details about a failed or partially successful job, click the job instance hyperlink and expand the entries provided
on the resulting page.

This is especially helpful for inventory-related jobs. For example, if a user imported devices using a CSV file (a bulk
import), the job will be listed in the Jobs sidebar menu under User Jobs > Device Bulk Import. The job details will list
the devices that were successfully added and the devices that were not.

Example

To troubleshoot a failed software image import job:

1. Choose User Jobs > Software Image Import from the Jobs sidebar menu.

2. Locate the failed job in the table and then click its hyperlink.

3. Expand the job's details (if not already expanded) to view the list of devices associated with the
job and the status of the image import for each device.

4. To view the import details for a specific device, click that device's i (information) icon in the
Status column. This opens an Image Management Job Results pop-up window.

5. Examine each step and its status. For example, the Collecting image with Protocol: SFTP
column might report that SFTP is not supported on the device.

Change User Preferences
To change the User Preferences, click the icon at the top-right corner of the screen, and choose My
Preferences > General.
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DescriptionUser Preference SettingCategory

Use this setting to define the
number of entries displayed on the
Monitoring pages for APs,
Controllers, Site Maps, Roles &
AAA > Active Sessions.

By default, 50 entries are listed.

This setting does not
apply to Network
Devices, Alarms and
Events, configuration
archive, software
image management,
or configuration.

Note

Items Per Page ListList pages

Use this setting to automatically
switch device group selection to
view all participating devices in
topology view. By default, this
setting is not enabled.

Automatically switch device
group selection to show all
participating devices

Network Topology

Use this setting to define the time
interval at which the maps and
tables in the network topology view
are refreshed. You can set the
refresh interval to 30 seconds, 1
minute, 2 minutes, or 5 minutes.
Select No auto-refresh if you do
not want to refresh the maps and
tables.

By default, the refresh interval is 1
minute.

Auto-Refresh Interval (Map,
Tables)
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DescriptionUser Preference SettingCategory

Use this setting to define the
Technology that is selected by
default when you go to the service
provisioning page to create a new
service.

If this user preference
is not set, Carrier
Ethernet will be set as
the default value.

Note

Default TechnologyService Provisioning

Use this setting to define the
Service Type that is selected by
default when you go to the service
provisioning page to create a new
service.

If this user preference
is not set, Access
EPL will be set as the
default value.

Note

Default Service Type

Use this setting to define how often
the data in the UI is refreshed in the
chassis view.

By default, the UI refresh interval
is 1 minute.

UI Refresh IntervalChassis View Configuration

Use this setting to define the
number of chassis racks Cisco EPN
Manager should display.

By default, this value is 2.

Chassis racks to display

Use this setting to define the time
interval at which the table in the
Network Devices page is refreshed.
You can set the refresh interval to
1 minute, 2 minutes, 5 minutes, 10
minutes, 15minutes, or 30minutes.
SelectDo not refresh if you do not
want to refresh the table.

The default value of this setting is
Do not refresh.

Device List Table Refresh
Interval

Device Inventory List View

By default, this setting is enabled.Use MSE Admin ViewMobility Services Engine
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DescriptionUser Preference SettingCategory

Use this setting to define whether
an idle user should be automatically
logged out. By default, this option
is enabled.

To disable this
setting, first ensure
that the Global idle
user is unchecked
under System
Settings.

Note

Logout idle userUser Idle Timeout

This setting also enables you to set
the idle time for auto logout. By
default, the value is 15 minutes.

This value cannot
exceed the value in
the Global Idle
timeout field under
System Settings.

Note

Logout idle user after

After you make the desired changes, click Save to apply your changed settings.

To clear the page level customization and setting, click Clear GUI State Settings on the top-right corner of
the EPNM window. This deletes the custom settings made to Network Summary Dashboard, Performance
Graphs, Network Devices, and so on, pages and refreshes the application to the default values.

For information about user preference settings in Alarms and Events, see Set Up Your Alarm and Event
Display Preferences.

Extend Cisco EPN Manager Functions
Advanced users can extend Cisco EPN Manager using the following tools:

• Cisco EPNManagerMTOSI API—Integrates Cisco EPNManager with your Operations Support System
(OSS).

• Cisco EPN Manager REST API—Manages additional administrative operations.

To get information about these tools, click from the right side of the title bar and then choose Help > API
Help. You can also download the following documents from Cisco.com:

• Cisco Evolved Programmable Network Manager MTOSI API Guide for OSS Integration

• Cisco Evolved Programmable Network Manager RESTCONF NBI Guide
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Check Cisco.com for the Latest Cisco EPN Manager
Documentation

Refer to Cisco Evolved Programmable Network Manager Documentation Overview for information about
and links to all of the documentation that is provided with Cisco EPN Manager.

We sometimes update the documentation after original publication. Therefore, you should also review the
documentation on Cisco.com for any updates.

Note
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