Configuration Management with Cisco Prime LAN Management Solution 4.1
Chapter 11: Configuring Virtual Routing and Forwarding
Downloads: This chapterpdf (PDF - 496.0KB) The complete bookPDF (PDF - 7.53MB) | Feedback

Configuring Virtual Routing and Forwarding (VRF)

Table Of Contents

Configuring Virtual Routing and Forwarding (VRF)

Configuring VRF

Create VRF

Interface Mapping to VRF

Routing Protocol Configuration

Summary of VRFs to be Configured

Understanding VRF Configurations for Create VRF

Editing VRF

Interface Mapping to VRF in Edit VRF

Routing Protocol Configuration in Edit VRF

Summary of Edit VRF

Extend VRF

Interface Mapping to VRF in Extend VRF

Routing Protocol Configuration in Extend VRF

Summary of Extend VRF

Deleting VRF

Delete VRF - Summary

Edge VLAN Configuration

VLAN to VRF Mapping

Edge VLAN Configuration Summary

Using VRF Lite Job Browser


Configuring Virtual Routing and Forwarding (VRF)


Using LMS, you can perform end-to-end VRF configurations in an enterprise network. You can perform the VRF Configurations using the following configuration workflows:

Configuring VRF

Editing VRF

Extend VRF

Deleting VRF

You can assign multiple VLANs to a single VRF instance using Edge VLAN Configuration workflow.

To view and manage VRF configuration jobs, see Using VRF Lite Job Browser.

This section also details the following:

Scalability Limits

Pre-requisites

Scalability Limits

In an Enterprise network, LMS is tested to support the configuration of 32 VRFs with VRF configuration supported in 550 devices in your network. However, at a given time, you can select up to 20 devices and configure VRF using the Create, Edit and Extend VRF workflow.

Pre-requisites

The pre-requisites to perform VRF configurations are:

1. The device must be managed by LMS.

2. The device must either be L2/L3 or an L3 device

3. The device must have the necessary hardware support. For more information on hardware support, see http://www.cisco.com/en/US/partner/products/sw/cscowork/ps563/products_device_support_tables_list.html

If the device hardware is not supported then the device will be classified as Other devices

4. If a device does not support MPLS VPN MIB, it is classified as a Capable device.

5. VTP Server must be support MPLS VPN MIB. If the VTP Server does not support MPLS VPN MIB, LMS will not manage VTP Clients.

Configuring VRF

VRF configurations comprises workflows used to create, edit, extend, delete and assign Edge VLAN to VRF. The VRF Create wizard enables you to create new VRF instances on the selected devices.

To navigate through the Configuration workflows, click Back or Next. To exit the Configuration workflow, click Cancel.

This section explains the Device Selector

Device Selector

To configure VRF on the devices, the devices are selected using the Device Selector. The Device Selector in all the configuration workflows displays the devices that satisfy the following condition:

Layer2/Layer3 devices

Layer3 devices

To create VRF, the VRF Creation wizard directs you through:

1. Create VRF

2. Interface Mapping to VRF

3. Routing Protocol Configuration

4. Summary of VRFs to be Configured

Create VRF

In the Create VRF workflow, you can select the Layer2/Layer3 or Layer 3 devices from the Distribution Layer or the Core Layer. At a given time, you can select up to 20 devices and configure VRF on the selected devices.

After selecting the devices, you can provide following details of VRF: VRF Name, Route Distinguisher and description of VRF that helps you identify the VRF that you have created.

In order to understand the workflows while configuring VRF, consider the topology as shown in Figure 11-1 to demonstrate various stages involved in the VRF creation process. The topology includes devices from Distribution Layer and Core Layer.

Figure 11-1 LMS Topology

Here, the devices selected are 10.77.241.2 and 10.77.241.4. The interface connecting the two devices is a routed interface.

If you select only one device, the VRF creation prompts you to exit the Create VRF wizard, without mapping any interface to the VRF created on the selected device.

To provide end-to-end virtualization for the selected devices, you must virtualize the interfaces connecting devices selected. An interface can be mapped to a VRF in the Interface Mapping to VRF workflow.

To map an interface to the VRF created (virtualize an interface), you must select at least two devices in the VRF creation wizard.

Only users with Network Administrator privileges can create VRFs.

To create VRF:


Step 1 Select Configuration > Workflows > VRF-lite > Create VRF.

The Create VRF page appears.

Step 2 Enter the details as mentioned below:

Table 11-1 Settings in Create VRF 

Window Element
Description
Device Selector

Device Selector

The Device Selector displays the devices under the following groups:

All Devices - Represents VRF Supported devices managed by LMS

Device Type Groups - Represents the devices that are grouped as Routers, Switches and Hubs, and Unknown Device Type

User Defined Groups - Represents the devices that are in the user-defined groups.

The Device Selector enables you to search and select the devices on which VRF is to be configured.

Select the devices using the Device Selector.

Check the checkbox to select the device in the groups listed and click Select.

If you select only one device, the VRF creation wizard is completed without mapping any interface to the VRF created on the selected device.

To map an interface to the VRF created, you must select at least two devices in the VRF creation wizard.

See Inventory Management with Cisco Prime LAN Management Solution 4.1 for information on how to use the Device Selector.

VRF Details

VRF Name

Name of the VRF to be created. Valid values are alphanumeric characters. This field is mandatory.

Route Distinguisher (RD)

Value used to distinguish routes configured in a VRF. Valid values are numeric characters in the format X:Y.

The valid values for X are autonomous numbers. X can take values from 1 to 65535 or an IP Address.

The valid values for Y are numeric values. Y can take values from 1 to 65535. For example X:Y is in the form 32:66 or 10.10.10.10:22.

Note: You must enter a unique value for each VRF that is configured.

Description

Description of VRF to be created. Valid values are alphanumeric characters.

With no entry, the default description provided by LMS is "VRF Created by LMS"

Finish

Click Finish to create VRF on the selected devices without interface mapping.


Step 3 Click Next

The Interface Mapping to VRF window appears. For information on Interface Mapping to VRF, see Interface Mapping to VRF


Interface Mapping to VRF

The Interface Mapping to VRF window displays the Source and the Destination devices selected using Device Selector. The page also displays a list of links in the form of rows.

This section contains:

Current Mode

Preferred Virtual Interfaces

Native VLAN

The Interface Mapping to VRF window is used to map an interface to a VRF. The links displayed are the interfaces connecting a Source device to the Destination device. The mapping is performed from the devices in the Distribution Layer and Core Layer.

Current Mode

The current mode is the existing mode of an interface connecting any two selected devices. The current mode of an interface can be either a Switched or Routed mode.

Preferred Virtual Interfaces

In the Interface Mapping to VRF page, while you are assigning an interface to a VRF, you are prompted to create preferred virtual interfaces on the device. LMS suggests a preferred virtual interface, in scenarios where the current mode cannot be considered for configuring VRF.

The preferred virtual interfaces decide the type of virtual interface to be created, to virtualize an interface that connects the selected devices while you create VRF. The preferred virtual interfaces are based on the family of the selected devices.

The preferred virtual interface type is a part of the metadata XML file. The metadata XML file is used as a repository to store information on the device types and their associated metadata while creating VRF.

LMS has defined the following preferred virtual interfaces for the devices belonging to:

Cat3k and Cat4k family, SVI is the preferred virtual interface

Cat 6k and Router category, Sub-interface is the preferred virtual interface

Consider an example where two devices are selected. The virtual interfaces are created based on the current mode.


Note The interfaces that are virtualized using VRF-lite must be Layer 3 interfaces.


IIn the Interface Mapping to VRF page, an interface is virtualized based on the current mode of the interface.

The Interface Configuration modes are mentioned in the Table 11-2

Table 11-2 IInterface Configuration Modes

Current Mode
Trunk is configured
Preferred Mode
LMS Configures

Switched

Yes

SVI

SVI

Switched

Yes

SI

SVI

Switched

No

SVI

Trunk, SVI

Switched

No

SI

Trunk, SVI

Routed 1

N/A

SVI

Trunk, SVI

Routed 2

N/A

SI

SI

Routed with Sub-interface configured

N/A

SI

SI. LMS configures with current mode

Routed with Sub-interface configured

N/A

SVI

SI.LMS configures with current mode

1 Interface is in Routed mode and the Sub-interface is not configured.

2 Interface is in Routed mode and the Sub-interface is not configured.


Native VLAN

In the Interface mapping to VRF page, when you configure the VRF details on an interface, the VRF configurations might affect the global configurations in some scenarios. Therefore, Native VLANs are used for the global configuration traffic.

Consider the source device as 10.77.241.4 with source interface as Gi 1/1 and the destination device as 10.77.241.2 with destination interface as Gi 1/1 as shown in Figure 11-2

Figure 11-2 Native VLAN Configuration

Scenario 1: If both source and destination interfaces are in routed mode, Trunk cannot be configured on the interfaces. To configure Trunk, LMS converts the routed port of the destination interface to switch port. If a free VLAN exists, VNM converts the free VLAN to Native VLAN.

Table 11-3 Scenario 1

Source Interface IP
with port mode
Is Trunk
Preferred Mode
Sub-interface configured
Destination Interface IP
with port mode
Is Trunk
Preferred Mode
Sub-interface configured

10.77.241.4, Routed

False

SI

Yes

10.77.241.2, Routed

False

SVI

No



Note The IP Address provided for the source and the destination interface must be within the same network. For example: If the source interface IP Address is 10.10.10.2, then the destination interface IP Address must be configured as 10.10.10.3.



Step 1 In the Interface Mapping to VRF window, enter the details as in Table 11-4:

Table 11-4 Interface Mapping to VRF Settings 

Window Element
Description

VRF Details

VRF Name

Name of the VRF to be created.

Source

Source Device Name

Displays the Source Device name as in Device Credentials and Repository (DCR).

Click the arrow icon to view or hide details of the interfaces that are a part of the Source device.

Checkbox

To assign a link to a VRF, check the check box against the interfaces listed under the device name to which they are connected.

Interface

Interface connecting the Source device.

IP Address

Source interface IP Address. Valid IP values are the IPv4 Addresses.

This field is blank if the source physical interface is not configured with an IP Address.

If you newly configure an IP Address, the corresponding network IP Address must be advertised. You must advertise the IP Address by manually updating the Commands field in the Routing Protocol Configuration page.

Destination

Device Name

Displays the Destination Device name as entered in Device Credentials and Repository (DCR).

Interface

Interface connecting the Destination device.

IP Address

Destination interface IP Address. Valid IP values are the IPv4 Addresses.

If the destination physical interface is not configured with an IP Address, this field is blank.

If you newly configure an IP Address, the corresponding network IP Address must be advertised. You must advertise the IP Address by manually updating the Commands field in the Routing Protocol Configuration page.

Subnet Mask

Subnet mask of the interface

is Trunk

Provides the status of the Trunk configuration on the associated physical interface. The following status is displayed:

Not Applicable — In some scenarios, Trunk configuration is not required to configure VRF

True — Trunk is configured on the associated physical interface

Create — Trunk is not configured on the associated physical interface.

Click Create to create a Trunk.

VLAN ID

VLAN ID on which VRF is configured. VLAN ID is auto-generated.

The allowed range is from 1 to 4095. You can edit VLAN ID

VLAN Name

VLAN Name on which VRF is configured.VLAN Name is auto-generated. You can edit VLAN Name

Finish

Click Finish to create VRF on the devices selected and maps the interfaces (connected to the devices) to VRF without deploying the routing protocol configuration details.


Step 2 Click Next.

The Routing Protocol Configuration window appears.

For information on Routing Protocol Configuration, see Routing Protocol Configuration.


Warning Messages

In the Create VRF workflow, when you assign an interface to a VRF, in the following scenarios, the Warning messages displayed are:

Table 11-5 Information on Warning Messages 

Warning Message
Scenario

One link is not configured as Trunk

Trunk is not configured on the selected physical interfaces displayed in the Interface Mapping to VRF window. You cannot assign VRF to the non-trunk interfaces.

Some of the selected devices are isolated

Reasons for warning about isolated devices are:

Devices selected are not in series:

At least one or more devices selected are not connected in series, so the unconnected devices get isolated. You can view these device details in Topology (Layer 2 View).

or

Devices with no physical connection:

At least one or more selected devices is not physically connected. These devices are isolated device. You can view these device details in Topology (Unconnected View)

You cannot assign VRF to interfaces for isolated devices.


Routing Protocol Configuration

The Routing Protocol Configuration window is used to configure the Routing protocol to the selected devices on which VRF is configured.

By default, the Routing Protocol information from the global configuration for OSPF and EIGRP protocols is displayed.

Static Route Configuration

LMS currently supports the following Routing Protocols: OSPF and EIGRP. You can enter the static route configuration using the Configuration Icon in the Routing Protocol Configuration page.

Command Syntax

ip route vrf vrfname Destination IP Address Subnet Mask Router IP Address

For example:

ip route vrf Red 172.16.30.0 255.255.255.0 172.16.20.2

To configure static route directly using a device, you must enter the command as mentioned in the Command Syntax in the configuration mode.


Step 1 In the Routing Protocol Configuration window, enter the details as given in Table 11-6:

Table 11-6 Routing Protocol Configuration Settings 

Window Element
Description

Device Name

Device name to which routing protocol is associated.

IP Address

IP Address of the device.

Routing Protocol

Routing Protocol

You can configure the routing protocols on the VRF-configured devices.

The drop-down list displays the routing protocols running on the selected device. LMS supports following routing protocols:

OSPF

EIGRP

Routing Protocols listed are the protocols present in global Configuration details.

View Global

Displays the VRF configuration and the global configuration details of the device name.

You cannot edit these details.

Commands

Commands

Displays the commands used to configure routing protocol configuration on the VRF to be created.

Configuration Icon

Enables you to edit the commands displayed in the Commands field.

Restore Default

Restores Protocol configuration and clear edited Commands details to default global configuration values.

Finish

Enables you to finish the Create VRF workflow without viewing the commands used to deploy the VRF Configurations in the Summary page.

Upon clicking finish, a job is created to deploy the VRF Configuration details to the selected devices.


Step 2 Click Next

The Summary page appears. For information on Summary, see Summary of VRFs to be Configured.


Summary of VRFs to be Configured

The Summary page summarizes the VRF and the Protocol configuration details to be deployed on the devices selected.

This section contains:

Sample Summary

Understanding VRF Configurations for Create VRF


Note Upon successful completion of Create VRF workflow, LMS triggers the Data Collection process. After the Data Collection process is complete, LMS initiates the VRF Collection process.


The Sample Summary summarizes the VRF configuration details on the devices 10.77.241.2 and 10.77.241.4, connected by an interface Gi1/1. For more information, see Figure 11-2.

A sample of the summary is displayed below.

Sample Summary

Device:10.77.241.2
 
   
ip vrf Green
description Green VRF
rd 60:70
vlan 4
name Vlan_4
vlan 3000
name VLANforGreenVRF
interface Vlan4
ip address 20.20.20.1 255.255.255.252
no shutdown
interface Gi1/1
switchport trunk native vlan 4
switchport trunk allowed vlan add 4
switchport trunk allowed vlan add 3000
no shutdown
interface VLAN3000
ip vrf forwarding GreenVRF
ip address 20.20.20.1 255.255.255.252
no shutdown
 
   
router eigrp 10
address-family ipv4 vrf GreenVRF
autonomous-system 10
 
   
network 10.0.0.0
network 20.0.0.0
auto-summary
eigrp router-id 10.77.241.2
eigrp stub connected summary
exit-address-family
Device:10.77.241.4
 
   
ip vrf GreenVRF
description Green VRF
rd 60:70
interface Gi1/1
no switchport
interface Gi1/1.1
encapsulation dot1Q 3000
ip vrf forwarding GreenVRF
ip address 20.20.20.2 255.255.255.252
no shutdown
 
   
router eigrp 10
address-family ipv4 vrf GreenVRF
autonomous-system 10
network 10.0.0.0
network 20.0.0.0
auto-summary
eigrp router-id 10.77.241.2
eigrp stub connected summary
exit-address-family

Understanding VRF Configurations for Create VRF

The following VRF configuration details are deployed on the selected devices and corresponding interfaces. The description of the VRF configuration details is given in Table 11-7.

Table 11-7 Create VRF Configuration

Command
Purpose

Device device name

Name of the selected device

ip vrf vrf-name

Allows you to enter VRF configuration mode and assigns a VRF name

description vrf-name

Provides description of the VRF created

rd route-distinguisher

Creates a VPN route distinguisher

interface interface-id

Allows you to enter the interface configuration mode and specify the Layer 3 interface to be associated with the VRF. The interface can be a routed port or SVI.

encapsulation dot1Q vlan-identifier

Allows you to define the encapsulation format as IEEE 802.1Q and specify the VLAN identifier.

The VLAN identifier takes values ranging from 1 to 4095.

ip vrf forwarding vrf-name

Associates a VRF with an interface or sub-interface

ip address ip-address mask

Configure IP Address on an interface or sub-interface.

no shutdown

Enables an interface.

no switchport

Converts Layer 2 switch port interface to a Layer 3 routed physical interface



Step 1 Click Finish

A job is created to deploy the VRF configuration details to the selected devices. A confirmation message appears with the Job ID in the Information dialog box.

For example, if you create VRF Red, the message appears, Successfully created job for confirmation deployment 1051

Step 2 Click Job ID to check status of the Create VRF Configuration Job in the Information dialog box.

Step 3 Click OK in the Info dialog box.

To view the VRF configuration job status, go to Configuration > Job Browsers > VRF Lite. See Using VRF Lite Job Browser.



Note To exit the VRF Create wizard without deploying the VRF details on the devices selected, click Cancel.


Editing VRF

Edit VRF enables you to edit the VRF details on the devices participating in a VRF.

The Edit VRF workflow is used to edit the following details:

IP Address of the interface connecting the devices that are a part of the selected VRF

VLAN ID and VLAN Name

Routing Protocol Configuration

Exclude an interface that is a part of the selected VRF

Only users with Network Administrator privileges can edit VRF details.

To edit VRF details of the VRF configured devices, the VRF Edit wizard directs you through:

1. Interface Mapping to VRF in Edit VRF

2. Routing Protocol Configuration in Edit VRF

3. Summary of Edit VRF

To edit VRF:


Step 1 Select Configuration > Workflows > VRF-lite > Edit VRF.

The Edit VRF page appears. Table 11-8 describes the fields on the Edit VRF page.

Table 11-8 Edit VRF Settings

Window Element
Description
VRF Details

VRF Name

Shows the list of VRFs as a drop-down list.

You can edit the VRF by selecting the VRF from the drop-down list.

Route Distinguisher (RD)

Display only. Shows the RD value of the selected VRF in the format X:Y.

For more information on RD, see Route Distinguisher (RD).

Description

Display only. Description of the selected VRF. You cannot edit the description.

Device Selector

Device Selector

Device Selector displays pre-selected devices, participating in the selected VRF.

The Device Selector displays the devices under the following groups:

All Devices - Represents VRF Configured devices

Device Type Groups - Represents the devices that are grouped as Routers, Switches and Hubs, and Unknown Device Type

User-defined Groups - Represents the devices that are in the user-defined groups.

The Device Selector enables you to search and select the devices on which VRF must be configured to edit the VRF functionality.

Select the checkbox to select the device in the groups listed and click Select.

You must select at least two devices to edit the virtualization of the link connecting devices participating in the selected VRF.

For more information on the devices listed, see Device Selector.



Note The Device Selector does not display the devices that are not managed by LMS.


Step 2 Click Next

The Interface Mapping to VRF window appears.

For information on Interface Mapping to VRF, see Interface Mapping to VRF in Edit VRF.


Consider the devices selected for Edit VRF workflow are: source device 10.77.241.4 with source interface as Gi 1/1 and the destination device as 10.77.241.2 with destination interface as Gi 1/1 as shown in Figure 11-2.

Interface Mapping to VRF in Edit VRF

The Interface Mapping to VRF window displays a list of links connecting the devices, selected in the Edit VRF page, participating in the VRFs to be edited.

The link details are:

The links displayed, can either be virtualized with the selected VRF or unvirtualized. You can use the Interface checkbox to deselect a link. This unvirtualizes a virtualized link.

The corresponding negate command is displayed in the Summary of Edit VRF page indicating that the SI or SVI has been removed. You must manually update the negate command for the routing protocols in the Commands in Edit VRF workflow.

If both interfaces on either side of a link, are virtualized with a VRF, the Interface Mapping to VRF page displays the values of VLAN,Switch Virtual Interfaces (SVIs) or Sub-Interface (SIs) IP address and so on.

If a link is virtualized only on one side of the interface, the same VLAN is used to virtualize the interface on the other end of the link. LMS application will not use a new VLAN. You can edit the VLAN details in this page.

The Interface Mapping to VRF window is used to map an interface to a VRF. The mapping is performed from the Distribution layer to the Core layer. It also provides information on the Source and the Destination devices associated with a link.

In the Interface Mapping to VRF in Edit VRF page, while assigning an interface to a VRF, LMS suggests preferred virtual interfaces to be created on the device. For more information, see Preferred Virtual Interfaces.


Step 1 In the Interface Mapping to VRF window, enter the details as given in Table 11-9:

Table 11-9 Settings in Interface Mapping to VRF in Edit VRF

Window Element
Description

VRF Details

VRF Name

Display only. Name of the VRF selected.

Source

Source Device Name

Displays the Source Device name as entered in Device Credentials and Repository (DCR).

Click the arrow icon to view or hide SIs or SVIs that are a part of the source device, participating in the VRF selected.

Checkbox

To assign an SI or SVI to a VRF, check the check box against the SVIs or SIs listed under the device name to which they are connected.

When you uncheck the checkbox to deselect a link to unvirtualize a virtualized link, the corresponding Negate command appears in the Summary of Edit VRF page.

You must manually update the negate command for the routing protocols in the Commands in Edit VRF workflow.

Interface

Display only. Shows the SVIs or SIs name in the Source device.

IP Address

If the interface is virtualized with a configured IP Address, it displays an SI or SVI.

You can edit the IP Address. Valid IP values are the IPv4 Addresses.

This field will be empty if the source physical interface is not configured. If you configure an IP Address newly, you must advertise the corresponding network IP Address by manually updating the Commands in Edit VRF field.

Destination

Device Name

Display only. Shows the Destination Device name as it appears in the Device Credentials and Repository (DCR).

Interface

Display only. Shows the name of the SVIs or SIs in the Destination device.

IP Address

If the interface is virtualized with a configured IP Address, it displays an SI or SVI. You can edit the IP Address. Valid IP values are the IPv4 Addresses.

This field will be empty if the source physical interface is not configured. If you configure an IP Address newly, you must advertise the corresponding network IP Address by manually updating the Commands in Edit VRF field.

Subnet Mask

Subnet mask of the IP Address of SVI or SI.

is Trunk

Provides the status of the Trunk configuration on the associated physical interface. The following status appears:

True — Trunk is configured on the associated physical interface

Create — Trunk is not configured on the associated physical interface.
To configure a Trunk, click Create hyperlink. A message appears if the Trunk creation fails.

VLAN Name

VLAN Name on which VRF is configured. VLAN Name is auto-generated.

VLAN ID

VLAN ID on which VRF is configured. VLAN ID is auto-generated. You can edit VLAN ID.


Step 2 Click Next

The Routing Protocol Configuration window appears.

For information on Routing Protocol Configuration, see Routing Protocol Configuration in Edit VRF.


Routing Protocol Configuration in Edit VRF

The Routing Protocol Configuration window displays details of the configured Routing protocols. These protocols are associated to the individual devices that you selected. VRF is configured on these devices.

The details of the routing protocol running in the global configuration, are also displayed.


Step 1 In the Routing Protocol Configuration window, enter the details as given in Table 11-10

Table 11-10 Routing Protocol Configuration Settings 

Window Element
Description
Usage Notes

Device Name

Device name to which routing protocol is associated.

Display only.

IP Address

IP Address of the device.

Display only.

Routing Protocol

Routing Protocol

You can configure the Routing protocols on VRF-configured devices.

The drop-down list displays the routing protocols running on the selected device.

LMS supports following routing
protocols:

OSPF

EIGRP

Routing Protocols listed are the protocols in global configuration details.

You can choose the desired routing protocol.

View Global

Displays the global routing protocol configuration details of the device name.

You cannot edit these details.

Click View Global to view the global configuration details.

Commands in Edit VRF

Commands

Displays the commands used to configure routing protocol configuration on the VRF to be edited.

You cannot enter a value in this field. To edit the command details:

Click Configuration Icon

The newly configured IP Address for SIs or SVIs entered in the Interface Mapping to VRF in Edit VRF page, must be advertised using this field.

To edit the command details:

1. Click Configuration Icon and enter the IP Address to be advertised. Valid IP values are the IPv4 Addresses.

2. Click the tick mark to save the changes.

3. Click the close mark to close without saving the changes.

Configuration Icon

Enables you to edit the commands displayed in the Commands field.

Click Configuration Icon to edit the Commands field details.

Or

To enter Static Route Configuration, click Configuration Icon, delete the commands displayed in the commands field and enter the commands mentioned in the Command Syntax.

Restore Default

Restores the edited Routing Protocol configuration details to the configuration values computed in the Edit VRF workflow.

Click Restore Default to restore VRF Configuration details to default Global values.


Step 2 Click Next

The Summary page appears.

For information on Summary, see Summary of Edit VRF


Summary of Edit VRF

The Summary page provisions you with the VRF and the Protocol configuration details to be deployed to the selected devices.

This section contains Sample Summary for Edit VRF


Note Upon successful completion of Edit VRF workflow, LMS triggers the Data Collection process. After the Data Collection process is complete, LMS initiates the VRF Collection process.


The Sample Summary summarizes the VRF configuration details on the devices 10.77.241.2 and 10.77.241.4, connected by an interface Gi1/1. For more information, see Figure 11-2.

A sample of the summary is displayed below.

Sample Summary for Edit VRF

Device:10.77.241.2
 
   
ip vrf Green
description Green VRF
rd 60:70
vlan 4
name Vlan_4
vlan 3000
name VLANforGreenVRF
interface Vlan4
ip address 20.20.20.1 255.255.255.252
no shutdown
interface Gi1/1
switchport trunk native vlan 4
switchport trunk allowed vlan add 4
switchport trunk allowed vlan add 3000
no shutdown
interface VLAN3000
ip vrf forwarding GreenVRF
ip address 20.20.20.1 255.255.255.252
no shutdown
 
   
router eigrp 10
address-family ipv4 vrf GreenVRF
autonomous-system 10
 
   
network 10.0.0.0
network 20.0.0.0
auto-summary
eigrp router-id 10.77.241.2
eigrp stub connected summary
exit-address-family
Device:10.77.241.4
 
   
ip vrf GreenVRF
description Green VRF
rd 60:70
interface Gi1/1
no switchport
interface Gi1/1.1
encapsulation dot1Q 3000
ip vrf forwarding GreenVRF
ip address 20.20.20.2 255.255.255.252
no shutdown
 
   
router eigrp 10
address-family ipv4 vrf GreenVRF
autonomous-system 10
network 10.0.0.0
network 20.0.0.0
auto-summary
eigrp router-id 10.77.241.2
eigrp stub connected summary
exit-address-family
 
   

Understanding VRF Configurations for Edit VRF

The VRF configuration details edited are deployed on the selected devices and corresponding interfaces. To understand the VRF configuration details edited, see Understanding VRF Configurations for Create VRF.


Step 1 Click Finish

A job is created to deploy the edited VRF configurations details to the selected devices. A confirmation message appears with the Job ID in the Information dialog box.

For example, if you edit VRF Red, the message appears, Successfully created job for confirmation deployment. 1053

Step 2 Click Job ID to check status of the Job in the Info dialog box.

Step 3 Click OK in the Info dialog box.

To view the VRF configuration job status, go to Configuration > Job Browsers > VRF Lite. See Using VRF Lite Job Browser.


Extend VRF

Extend VRF enables you to extend the VRF functionality across the network. You can extend VRF configuration details by selecting the devices that are neighbors to the VRF-configured devices in a network.

Only the following users have privileges to extend VRF details: Network Administrator, System Administrator and Super Admin.

To extend VRF functionality to other devices, the VRF Extend wizard directs you through:

1. Extending VRF

2. Interface Mapping to VRF in Extend VRF

3. Routing Protocol Configuration in Extend VRF

4. Summary of Extend VRF

To extend VRF:


Step 1 Select Configuration > Workflows > VRF-lite > Extend VRF.

The Extend VRF page appears. Table 11-11 describes the Extend VRF page.

Table 11-11 Settings in Extend VRF 

Window Element
Description
Usage Notes
VRF Details

VRF Name

Name of the VRF selected.

You can select the VRF from the VRF Name drop-down list.

Route Distinguisher (RD)

Displays the RD value of the VRF entered while creating a VRF.

Note: You must enter a unique value for each VRF that is configured.

For more information on RD, see Route Distinguisher (RD).

Displays the RD value of the VRF selected in the format X:Y.

You can edit the RD value. The edited RD value is applied only to the new devices that were added while extending the VRF.

Description

Displays the description of the VRF entered while creating a VRF.

Displays the description of the VRF selected. You can edit the description.

The edited description is applied only to the new devices that were added while extending the VRF.

Device Selector

Device Selector

Device Selector displays all the devices, except the devices participating in the selected VRF. It does not display any device that is configured with the VRF selected.

The Device Selector also displays the devices under the following groups:

All Devices—Devices which are not participating in the selected VRF

Device Type Groups—Devices that are grouped as Routers, Switches and Hubs, and Unknown Device Type

User-defined Groups—Represents the devices that are in the user-defined groups.

The Device Selector enables you to search and select the devices on which VRF must be configured to extend the VRF functionality.

See Inventory Management with Cisco Prime LAN Management Solution 4.1 for information on how to use the Device Selector

Select the devices using the Device Selector.

Click the checkbox to select the device in the groups listed and click Select.



Note The Device Selector does not display the devices that are not managed by LMS.


Step 2 Click Next

The Interface Mapping to VRF window appears.

For information on Interface Mapping to VRF, see Interface Mapping to VRF in Extend VRF.


In Extend VRF, consider the devices selected are 10.77.241.4 and 10.77.241.6. For more information, see Figure 11-3.

Figure 11-3 Extend VRF workflow

Interface Mapping to VRF in Extend VRF

The Interface Mapping to VRF window displays a list of links that connect the devices. These are the devices that you selected using Device Selector in the Extend VRF window.

The links displayed are:

Links that connect the devices selected in Device Selector (in Extend VRF page)

Links that connect the devices selected in Device Selector (in Extend VRF page) and the L2 neighboring VRF-configured device that is not selected in Device Selector (in Extend VRF page)

If the links associated with the L2 neighboring device are configured with the selected VRF, only the link is displayed.

If the neighbor device is not configured with the selected VRF and it is not selected in Device Selector, the device is not displayed in the Interface Mapping to VRF page.

Note the following about links:

If both interfaces on either side of a link are not virtualized with a VRF, the Interface Mapping to VRF page displays the values of VLAN, SI or SVI, IP address configured.

If a link is virtualized only on one side of the interface, the same VLAN is used to virtualize the interface on the other end of the link. LMS will not use a new VLAN. You can edit the VLAN details in this page.

You cannot exit out the extend VRF workflow while it is running by clicking Finish in the Interface Mapping to VRF window.

The Interface Mapping to VRF window is used to map an interface to a VRF. The mapping is performed from the Distribution layer to the Core layer. It also provides information on the Source and the Destination devices associated with a link.

In the Interface Mapping to VRF in Extend VRF page, while assigning an interface to a VRF, LMS suggests preferred virtual interfaces to be created on the device. For more information, see Preferred Virtual Interfaces.


Step 1 In the Interface Mapping to VRF window, enter the details as given in Table 11-12:

Table 11-12 Settings in Interface Mapping to VRF in Extend VRF

Window Element
Description
Usage Notes

VRF Details

VRF Name

Name of the VRF selected.

You cannot edit this field.

Source

Source Device Name

Displays the Source Device name as entered in Device Credentials and Repository (DCR).

Click the arrow icon to view or hide details of the SIs or SVIs that are a part of the source device and participating in the VRF selected.

Checkbox

Allows you to select or deselect an SVI or SI that must be assigned to a VRF.

To select, check against the SVIs or SIs listed under the device name to which they are connected.

Or

To deselect, uncheck against the SVIs or SIs listed under the device name to which they are connected.

Interface

Switch Virtual Interfaces (SVIs) or Sub-Interface (SIs) name in the source device.

Display only.

IP Address

If the interface is virtualized, with IP Address configured, it displays an SI or SVI. You can edit the IP Address.

This field is empty if the source physical interface is not configured.

If you newly configure an IP Address, the corresponding network IP Address must be advertised. You must advertise the IP Address by manually updating the Commands in Extend VRF field.

Enter the IP Address. Valid IP values are the IPv4 Addresses.

Destination

Device Name

Displays the Destination Device name as entered in Device Credentials and Repository (DCR).

Display only.

Interface

Switch Virtual Interfaces (SVIs) or Sub-Interface (SIs) name in the Destination device.

Display only.

IP Address

If the interface is virtualized, with IP Address configured, it displays an SI or SVI. You can edit the IP Address.

This field is empty if the source physical interface is not configured.

If you newly configure an IP Address, the corresponding network IP Address must be advertised. You must advertise the IP Address by manually updating the Commands in Extend VRF field.

Enter the IP Address. Enter the IP Address of the

Subnet Mask

Subnet mask of IP Address of SVI or SI

Enter the subnet mask

is Trunk

Provides the status of the Trunk configuration on the associated physical interface. The following status is displayed:

True — Trunk is configured on the associated physical interface

Create — Trunk is not configured on the associated physical interface.

To configure Trunk, click Create hyperlink.

After clicking Create, Trunk is created.

VLAN Name

VLAN Name on which VRF is configured.VLAN Name is auto-generated.

You can edit VLAN Name.

VLAN ID

VLAN ID on which VRF is configured.VLAN ID is auto-generated or configured.

You can edit VLAN ID.


Step 2 Click Next

The Routing Protocol Configuration window appears.

For information on Routing Protocol Configuration, see Routing Protocol Configuration in Extend VRF.


Routing Protocol Configuration in Extend VRF

The Routing Protocol Configuration window displays details of the configured Routing protocols. These protocols are associated to the individual devices that you selected. VRF is configured on these devices.

Details about the Routing protocol running in the global configuration table are also displayed.


Step 1 In the Routing Protocol Configuration window, enter the details as given in Table 11-6:

Table 11-13 Routing Protocol Configuration Settings 

Window Element
Description
Usage Notes

Device Name

Device name to which routing protocol is associated.

Display only.

IP Address

IP Address of the device.

Display only.

Routing Protocol

Routing Protocol

You can configure the routing protocols on VRF-configured devices.

The drop-down list displays the routing protocols running on the device selected. LMS supports following routing protocols:

OSPF

EIGRP

Routing Protocols listed are the protocols present in global configuration details.

You can choose the Routing protocol that you want.

View Global

Displays the VRF configuration and the global configuration details of the device name.

You cannot edit these details.

Click View Global to view the Global Configuration details.

Commands in Extend VRF

Commands

Displays the commands used to configure routing protocol configuration on the VRF to be extended.

You cannot enter a value in this field. To edit the command details:

The newly configured IP Address for SIs or SVIs entered in the Interface Mapping to VRF in Extend VRF page, must be advertised using this field. Valid IP values are the IPv4 Addresses

To edit the command details, Click Configuration Icon and enter the IP Address to be advertised. After entering the details, click the tick mark to save the changes.

Click Configuration Icon and click the tick mark to save the changes.

Configuration Icon

Enables you to edit the commands displayed in the Commands field.

Click Configuration Icon to edit the Commands field details.

Or

To enter Static Route Configuration, click Configuration Icon, delete the commands displayed in the commands field and enter the commands mentioned in the Command Syntax.

Restore Default

Restores Protocol configuration and clears edited Commands details to default Global Configuration values.

Click Restore Default to restore VRF Configuration details to default Global values.


Step 2 Click Next

The Summary window appears.

For information on Summary, see Summary of Extend VRF


Summary of Extend VRF

The Summary window displays the VRF and the Protocol configuration details to be deployed on the selected devices.

This section contains:

Sample Summary for Extend VRF

Understanding VRF Configurations for Extend VRF


Note Upon successful completion of Extend VRF workflow, LMS triggers the Data Collection process. After the Data Collection process is complete, LMS initiates the VRF Collection process.


The Sample Summary summarizes the VRF configuration details on the devices 10.77.241.4 and 10.77.241.6. For more information, see Figure 11-3.

A sample of the summary is displayed below.

Sample Summary for Extend VRF

Device:10.77.241.4
vlan 5
name Vlan_5
interface Gi1/3
switchport trunk allowed vlan add 5
interface Vlan5
ip vrf forwarding GreenVRF
ip address 5.5.5.1 255.255.255.252
no shutdown
 
   
router eigrp 10
address-family ipv4 vrf GreenVRF
autonomous-system 10
 
   
network 5.0.0.0
auto-summary
eigrp router-id 10.77.241.4
eigrp stub connected summary
exit-address-family
 
   
Device:10.77.241.6
 
   
ip vrf GreenVRF
description Green VRF
rd 70:80
vlan 5
name Vlan_5
interface Gi4/9
switchport trunk allowed vlan add 5
interface Vlan5
ip vrf forwarding GreenVRF
ip address 5.5.5.2 255.255.255.252
no shutdown
 
   
router eigrp 10
address-family ipv4 vrf GreenVRF
autonomous-system 10
 
   
network 5.0.0.0
auto-summary
eigrp router-id 10.77.241.4
eigrp stub connected summary
exit-address-family

Understanding VRF Configurations for Extend VRF

To extend VRFs to selected devices and corresponding interfaces, the VRF configuration details are deployed on the selected devices and corresponding interfaces. To understand the VRF configuration details edited, see Understanding VRF Configurations for Create VRF


Step 1 Click Finish

A job is created to deploy the VRF configurations details to the selected devices. A confirmation message appears with the Job ID in the Information dialog box.

For example, if you extend VRF Red, the message appears, Successfully created job for confirmation deployment.1052

Step 2 Click Job ID to check status of the Job in the Info dialog box.

Step 3 Click OK in the Information dialog box.

To view the VRF configuration job status, go to Configuration > Job Browsers > VRF Lite. See Using VRF Lite Job Browser.


Deleting VRF

Delete VRF workflow is used to delete the VRFs present on your network.

The Delete VRF workflow enables you to:

Delete VRF from the selected devices

Delete virtual interfaces that are virtualized by the VRF of the selected device

Delete virtualized virtual interfaces from the devices, at the other end of the physical interface that connects the selected device.

For example, Device A with virtual interface (Gig5/1.1) is connected to Device B with virtual interface (Gig4/1.1). (Assume that the virtual interfaces of both devices are virtualized with the selected VRF.)

If you select Device A using Device Selector, Device B will be on the other end of the physical interface that is connected to Device A. In this case, the virtual interface(Gig5/1.1) on Device A, and virtual interface(Gig4/1.1) on Device B will be deleted.

You cannot delete Layer2 VLANs using the Delete VRF feature.

Delete internal VLANs created for Sub-Interfaces (SIs)

The following users have the privilege to delete VRF: Network Administrator and Super Admin. The user privileges mentioned is applicable for local mode only.

To delete VRF:


Step 1 Select Configuration > Workflows > VRF-lite > Delete VRF.

The Delete VRF: VRF and Device Selection page appears. Table 11-14 details the Delete VRF: VRF and Device Selection page.

Table 11-14 Delete VRF: VRF and Device Selection

Window Element
Description
VRF Details

VRF Name

Shows the list of VRFs as a drop-down list.

You can delete the VRF by selecting the VRF from the drop-down list.

Route Distinguisher (RD)

Display only. Shows the RD value of the selected VRF in the format X:Y.

For more information on RD, see Route Distinguisher (RD).

Description

Display only. Description of the selected VRF. You cannot edit the description.

Device Selector

Device Selector

Device Selector displays VRF-configured devices with selected VRF.

The Device Selector displays the devices under the following groups:

All Devices - Represents VRF Configured devices

Device Type Groups - Represents the devices that are grouped as Routers, Switches and Hubs, and Unknown Device Type

User-defined Groups - Represents the devices that are in the user-defined groups.

The Device Selector enables you to search and select the devices on which VRF functionality must be deleted.

Select the checkbox to select the device in the groups listed.

For more information on the devices listed, see Device Selector.


Step 2 Click Next

The Summary window appears.

For information on Summary, see Delete VRF - Summary.


Delete VRF - Summary

The Summary window summarizes the commands that will be deployed on the devices to withdraw participation in a VRF.

This section contains:

Sample Summary for Delete VRF

Understanding VRF Configurations for Delete VRF


Note Upon successful completion of Delete VRF workflow, LMS triggers the Data Collection process. After the Data Collection process is complete, LMS initiates the VRF Collection process. The VRF Collection process initiated depends on the settings provided in Admin. See Administration of Cisco Prime LAN Management Solution 4.1 for more information.


The Sample Summary summarizes the VRF configuration details on the devices 10.77.241.4 and 10.77.241.6. For more information, see Figure 11-3.

A sample of the summary is displayed below.

Sample Summary for Delete VRF

Device:10.77.241.4
 
   
no interface Vlan5
no ip vrf GreenVRF
 
   
Device:10.77.241.6
 
   
no interface Vlan5
no ip vrf GreenVRF

Understanding VRF Configurations for Delete VRF

The VRF configuration details pushed in the devices is explained in Table 11-15

Table 11-15 Delete VRF Configuration details

Command
Purpose

Device device name

Name of the device

no interface interface-id

Removes the interface_id from device name. For example, vlan 5 will be removed from device IP 10.77.241.6.

no ip vrf vrf-name

Deletes the VRF from the device


To delete VRF, present on the selected devices, Click Finish in the Summary page.

A job is created to delete the VRF configurations details from the selected devices. A confirmation message appears with the Job ID in the Information dialog box.

To view the VRF configuration job status, go to Configuration > Job Browsers > VRF Lite. See Using VRF Lite Job Browser.


Edge VLAN Configuration

In an Enterprise network, end-to-end virtualization is achieved by associating a VRF instance with an SVI to map VLANs to different logical or physical VPN connections.

The Edge VLAN Configuration workflow allows you to map the Access VLANs to a VRF instance there by providing end-to-end virtualization. The Access VLANs are mapped to single VRF instance by assigning it to existing Switch Virtual Interface (SVI) or new SVIs created at the Distribution Layer.

A VRF instance is associated with an Switch Virtual Interface (SVI) to map VLANs to different logical or physical VPN connections.


Note You can associate at most one SVI with a VLAN.


The following users have the privilege to assign Edge VLAN to VRF: Network Administrator and Super Admin. These user privileges apply only to the local mode.

The Edge VLAN Configuration wizard directs you through:

5. VLAN to VRF Mapping

6. Edge VLAN Configuration Summary

To perform Edge VLAN Configuration:


Step 1 Select Configuration > Workflows > VRF-lite > Edge VLAN Configuration.

The Edge VLAN Configuration: VRF and Device Selection page appears. Table 11-16 details the Edge VLAN Configuration: VRF and Device Selection page.

Table 11-16 Edge VLAN Configuration: VRF and Device Selection

Window Element
Description
VRF Details

VRF Name

Shows the list of VRFs as a drop-down list.

Select the VRF from the drop-down list.

Route Distinguisher (RD)

Display only. Shows the RD value of the selected VRF in the format X:Y.

For more information on RD, see Route Distinguisher (RD).

Description

Display only. Description of the selected VRF. You cannot edit the description.

Device Selector

Device Selector

Device Selector displays VRF-configured devices with selected VRF.

The Device Selector displays the devices under the following groups:

All Devices - Represents VRF Configured devices

Device Type Groups - Represents the devices that are grouped as Routers, Switches and Hubs, and Unknown Device Type

User-defined Groups - Represents the devices that are in the user-defined groups.

The Device Selector enables you to search and select the devices. Select the checkbox to select the device in the groups listed.

For more information on the devices listed, see Device Selector.


Step 2 Click Next

The Edge VLAN Configuration: VLAN to VRF Mapping page appears.

For information on VLAN to VRF Mapping, see VLAN to VRF Mapping.


VLAN to VRF Mapping

The Edge VLAN Configuration: VLAN to VRF Mapping page is used to map the Access VLANs to a VRF instance thereby providing an end-to-end virtualization. You can assign Edge VLAN to a VRF by associating it to a Switch Virtual Interface (SVI).

The Edge VLAN Configuration: VLAN to VRF Mapping page is used to:

1. Configure SVI for new or already existing VLANs in the Distribution Layer

2. Allow VLANs in available trunk in Access Layer

3. Configure Layer 3 features

The devices selected in Edge VLAN Configuration: Select Devices page are the devices from the Distribution Layer.

The Edge VLAN Configuration: VLAN to VRF Mapping page displays a list of Switch Virtual Interfaces (SVIs) that are

Virtualized with the VRF selected

Unfertilized

This section contains:

Trunk Configuration

Layer 3 Features

The Edge VLAN Configuration: VLAN to VRF Mapping page includes the following icons:

Existing VLAN icon: Used to display existing VLANs (VLAN Name) on the device.

Configurations icon: Used to perform Trunk and Layer 3 feature configuration.

Upon clicking the Configurations icon, the Trunk Configuration tab is selected by default and the Available Trunks page appears.


Step 1 The Edge VLAN Configuration: VLAN to VRF Mapping window appears. The window displays the name of the selected VRF in the Edge VLAN Configuration: Select Devices page. In this window, enter the details as given in Table 11-17.

Table 11-17 Details of VLAN to VRF Mapping

Window Element
Description
Usage Notes
VRF Details

VRF Name : Selected VRF

Name of the VRF selected.

Display only.

Device Details

Device Name (Hyperlink)

Represents the device selected in the Device Selector.

Device name of the device is displayed as a hyperlink.

Click the arrow icon to view or hide details of the SVIs that are a part of the device name.

If you right-click the Device name hyperlink, it displays Add SVI option. Click Add SVI option to add an SVI

Name

Represents a Switch Virtual Interface that is the logical Layer 3 interface on a switch. It displays the multiple VLANs that are carried by the physical interface. The corresponding VLAN ID and VLAN Name is populated in this page.

You can view the status of the interface. It displays a tick mark if the status is up and cross mark if the status is down.

Enter the SVI value. Valid values of SVI ranges from 2 to 4096.

Or

Select existing VLANs on your network by clicking the icon.

If the existing VLAN Name is displayed in this field, you can edit this field.

Edited entries will overwrite the existing VLAN Name.

If the VLAN value entered is not in your network, LMS creates VLAN.

Checkbox

Allows you to virtualize or un-virtualize SVIs using the selected VRF.

To virtualize an interface, check against the SVIs listed under the Device Name

To un-virtualize, un-check an interface that is already virtualized with a VRF

Existing VLAN icon

When you click this icon, the Existing VLAN Selector page appears. This page displays the existing VLANs on the device.

You can also search existing VLANs by entering the VLAN Name in the Search field.

The VLANs displayed do not have an SVI/SI in the selected device.

Select the desired VLAN. Upon selecting the VLAN, the corresponding VLAN Name and VLAN ID is populated in the VLAN ID and VLAN Name field.

IP Address

IP Address of the SVI.

Enter the IP Address. Valid IP values are the IPv4 Addresses

Subnet Mask

Subnet mask of the SVI.

Enter the Subnet mask

VLAN ID

VLAN ID to be assigned to a VRF.

Valid values of VLAN ID ranges from 1 to 4094.

Enter the VLAN ID. You cannot edit this field.

VLAN Name

VLAN Name to be assigned to a VRF.

Enter the VLAN Name.

Configurations

Enables you to perform the following configurations to be associated to the corresponding SVI: Trunk and Layer 3 feature configuration.

Click the Edge Interface Configuration icon to configure Trunk and Layer 3 features.

For more information, see Trunk Configuration and Layer 3 Features.


Trunk Configuration

The Available Trunks page displays the trunks available in the selected device. It also displays the device that are neighbors to the selected device. If no trunk is available in the selected device, the Available Trunks page is blank.

The VLANs in any corresponding, existing or newly created SVIs will be allowed on all the trunk interfaces, that are selected in the Trunk Configuration page. The values displayed in the Trunk Configuration page are not fetched from the selected devices.

Step 2 In the Trunk Configuration page, enter the details as given in Table 11-18.

Table 11-18 Settings of Trunk Configuration 

Window Element
Description
Usage Notes
Available Trunks

Interface Name

Interface name on which Trunk exist.

Display only.

Neighbor Name

Neighbor device to the selected device.

Select the desired trunk in which VLAN needs to be allowed and click Apply. The Trunk configuration details entered are saved.

The VLANs in the corresponding SVI will be allowed on all the trunk interfaces that are selected in the Trunk Configuration page.


Layer 3 Features

Upon clicking the Layer 3 Features tab, the Layer 3 Feature page appears which enables you to configure the following Protocols and DHCP Server details for any corresponding, existing or newly created SVIs. The values displayed under Layer 3 Features tab are not fetched from the selected devices.

HSRP : Hot Standby Router Protocol

VRRP : Virtual Router Redundancy Protocol

GLBP: Gateway Load Balancing Protocol


Note The layer 3 features details are not fetched from the devices.


Step 3 In the Layer 3 Feature Configuration page, enter the details as given in Table 11-18

Table 11-19 Settings of Layer 3 Feature Configuration 

Window Element
Description
Usage Notes
Layer 3 Redundancy Protocol

Select Type

Represents the Redundancy protocol types.

HSRP : Hot Standby Router Protocol

VRRP : Virtual Router Redundancy Protocol

GLBP: Gateway Load Balancing Protocol

Select the desired Redundancy protocol Type.

Group Number

Represents the group number of the protocol.

A valid group number is an integer. Valid range values for corresponding Redundancy Protocols is as follows:

HSRP : 0 - 4095

VRRP : 1 - 255

GLBP : 0 - 1023

Enter the Standby Group Number.

Virtual Router IP Address

IP Address of the Virtual Router at the edge.

Enter the Virtual Router IP Address. Valid IP values are the IPv4 Addresses.

DHCP Server IP Address

IP Address of the DHCP Server

Enter the DHCP Server IP Address and click Apply. Valid IP values are the IPv4 Addresses.

After applying the Layer 3 Features configuration details, the values are saved. Click Close.

The Edge VLAN Configuration: VLAN to VRF Mapping page appears.


After entering the Trunk and Layer 3 Features, a new row is added on the Edge VLAN Configuration: VLAN to VRF Mapping page appears. You can enter the details in the new row to create an SVI for newly created VLAN.

Step 4 Click Next

The Edge VLAN Configuration: Summary page appears.

For information on Summary, see Edge VLAN Configuration Summary.


Edge VLAN Configuration Summary

The Edge VLAN Configuration: Summary page summarizes the VRF configuration details to be deployed to the selected devices.

This section contains:

Sample Summary for Edge VLAN Configuration

Understanding Edge VLAN Configuration Details


Note Upon successful completion of Edge VLAN Configuration workflow, LMS triggers the Data Collection process. After the Data Collection process is complete, LMS initiates the VRF Collection process.


The Sample Summary summarizes the VRF configuration details on the device 10.77.241.2. For more information, see Figure 11-2.

A sample of the summary is displayed below.

Sample Summary for Edge VLAN Configuration

Device:10.77.241.4
 
   
vlan 3
name VLAN0003
interface VLAN3
ip vrf forwarding GreenVRF
ip address 10.77.22.3 255.255.255.2
no shutdown
glbp 1 ip 10.77.22.23
ip helper-address 255.255.255.0

Understanding Edge VLAN Configuration Details

The following VRF configuration details are pushed in the selected devices. The description of the Edge VLAN Configuration details is given in Table 11-20.

Table 11-20 Edge VLAN Configuration details

Command
Purpose

ip vrf forwarding vrf-name

Enters VRF configuration mode and assigns a VRF name

description vrf-name

Provides description of the VRF created

ip address vrf-name

Associates a VRF with an interface or sub-interface

no shutdown

Converts Layer 2 switch port interface to a Layer 3 routed physical interface

glbp

Enables IEEE 802.1Q encapsulation of traffic on a specified sub- interface in virtual LANs. IEEE 802.1 Q is a standard protocol for interconnecting multiple switches and routers, and for defining VLAN topologies.

ip helper-address

Used to enable an interface


To assign VLANs on the selected interfaces, to a VRF, click Finish in the Edge VLAN Configuration: Summary page.

A job is created to assign edge VLAN to the selected VRF. A confirmation message appears with the Job ID in the Information dialog box.

To view the VRF configuration job status, go to Configuration > Job Browsers > VRF Lite. See Using VRF Lite Job Browser.


Using VRF Lite Job Browser

The VRF Lite Configuration Jobs browser enables you to view the status of all VRF configuration Jobs. VRF configuration jobs are the jobs that are created for the VRF configuration workflows like Create, edit, extend and delete VRF as well as Edge VLAN Configuration jobs.

The job details that you can view here, include the job ID, the job type, the job description, the job owner, the time the job is scheduled to run at, the time of job completion, the schedule type, the job status, run status. Table 11-21 describes the fields in the VRF Lite Configuration Jobs browser.

To access the VRF Lite Configuration Jobs browser, select Configuration > Job Browsers > VRF Lite. The VRF Lite Configuration Jobs browser page appears.

You can manage the VRF configuration jobs using the VRF Lite Configuration Jobs browser.


Note View the Permission Report (Reports > System > Users > Permission) to check whether you have the required privileges to perform this task.


The VRF Lite Configuration Jobs browser is used to perform the following:

View—Used to launch reports. See View.

Stop—Stop a scheduled or running job. See Stop Job.

Retry—Retry a job. See Retry Job.

Delete—Delete a job. See Delete Job.

Table 11-21 VRF Lite Configuration Jobs Browser

Field
Description

Job ID

Unique ID assigned to the VRF configuration job when it is created.

Clicking the Job ID hyperlink provides a report page with the job details of the job.

Job Type

Type of VRF configuration job such as Create VRF, Edit VRF, Extend VRF, Delete VRF and Edge VLAN Configuration.

Description

Description of the job provided by the job creator.

Owner

User who created the job.

Scheduled At

Date and time the job was scheduled at.

Completed At

Date and time the job was completed at.

Run Status

Job states include:

Running

Waiting for approval

Scheduled (pending)

Succeeded

Succeeded with Info

Failed

Crashed

Cancelled

Suspended

Rejected

Missed Start

Failed at Start

Schedule Type

Specifies the type of schedule for the job:

Once—Runs once at the specified date and time.

Daily—Runs daily at the specified time.

Weekly—Runs weekly on the day of the week and at the specified time.

Monthly—Runs monthly on the day of the month and at the specified time.

Immediate—Runs immediately.

Status

Provides the status of the current jobs. The status of the current jobs is displayed as succeded or failed.


View

Use to launch the respective report of the VRF configuration job selected in the VRF Lite Configuration Jobs Browser page.

Stop Job

You can stop a scheduled or running job from the VRF Lite Configuration Jobs Browser.

Select the job and click Stop. You are prompted for a confirmation before the job is stopped. You can select only one job to stop at a given time.

Delete Job

You can delete a VRF configuration job from the VRF Lite Configuration Jobs Browser.

Select the job and click Delete. You are prompted for a confirmation before the job is deleted. You can select more than one job to delete.

Retry Job

You can retry a VRF configuration job related to VRF configuration from the VRF Lite Configuration Jobs Browser. You can retrieve only failed jobs.Select the job and click Retry. You are prompted for a confirmation before retrying the job. You can select only one job to be retried at a given time.