Guest

Cisco WAN Manager

Release Notes for the Cisco WAN Modeling Tools, 15.4.00 P1

  • Viewing Options

  • PDF (140.5 KB)
  • Feedback
Release Notes for the Cisco WAN Modeling Tools, Release 15.4.00 Patch 1

Table Of Contents

Release Notes for the Cisco WAN Modeling Tools, Release 15.4.00 Patch 1

New Features and Enhancements

Installing the Software

Installing the WAN Modeling Tools on a Solaris Platform

Installing the NMT Software on Solaris

Creating a Working Directory

Installing the NMT on a Windows Platform

Installing the Excel Macros on the Windows Platform

Related Documentation

Obtaining Documentation, Support, and Security Guidelines


Release Notes for the Cisco WAN Modeling Tools, Release 15.4.00 Patch 1


June 2007

Rev. A0

These release notes are for use with the Cisco WAN Modeling Tools, which includes the following subsystems:

NMT (Network Modeling Tools)

Provisions Cisco WAN products based on topology and permanent virtual circuit (PVC) and soft PVC (SPVC) demand.

Verifies connection admission control (CAC)-based quality of service (QoS) and rerouting capabilities for trunk and switch failures.

Supports MGX software release 5.x and all earlier releases.

Supports BPX and IGX switch software releases 9.4.1 back to 8.1.

Supports MGX 8220 release 5.0 back to release 3.0.

Provides a graphical map interface.

Runs on UNIX or a standalone version for PC without the map.

CET (Configuration Extraction Tool)

Extracts NMT topology data from the Cisco WAN Manager (CWM).

Compatible with CWM 9.2 and later.

TPI (Third-Party Interface)

Translates NMT data to and from WANDL network files.

Tested with WANDL 3.2.0.

SSI (Spread Sheet Interface)

Translates NMT data to and from the DBF file format.

Includes Microsoft macros for loading and unloading tables in the DBF file format.

NMT2CND (Cisco Network Designer Interface)

Loads NMT data into a project in Cisco Network Designer (CND).

Supports CND 3.0 and 5.0.

Cisco WAN Modeling Tools run on these platforms:

The NMT runs on Solaris and Windows platforms.

The NMT map interface is available only on the Solaris platform.

The TPI and SSI functionality is fully integrated into the NMT user interface.

Standalone UNIX command line utilities are used to provide TPI and SSI functionality, as well as various ways to manage and modify NMT topology files and produce reports.

The CET should reside on the CWM platform to have direct access to the database. After data is extracted from the CWM database, it can be processed on the standalone Solaris platform.

The NMT2CND tools are available only on PC and require CND installation.

New Features and Enhancements

The following new features and enhancements were introduced in Release 15.4.00 Patch 1:

NMT and TPI

Added functionality and enhanced user interface for modeling class-of-service (CoS) scalable, private network-to-network interface (PNNI) networks.

Provided interface for CoS-scalable PNNI parameters to and from WANDL data files.

Added provisioning for SPVC connections on VXSM cards.

CET

The following data is now extracted directly from the CWM database:

- PNNI interface parameters by CoS: minimum and maximum ingress bandwidth, minimum and maximum egress bandwidth, administrative weight, booking factor.

- Interface parameters for VXSM virtual ports.

Added processing for SPVC connections that originate or terminate on the VXSM card.

Installing the Software

This section describes how to install the WAN Modeling Tools software. See these sections:

Installing the WAN Modeling Tools on a Solaris Platform

Installing the NMT on a Windows Platform

Installing the Excel Macros on the Windows Platform

For additional information, see the Cisco WAN Modeling Tools User Guide.

Installing the WAN Modeling Tools on a Solaris Platform

Use this procedure to install the Cisco WAN Modeling Tools on a Solaris platform and set up the Cisco WAN Modeling Tools workspace.

See these sections:

Installing the NMT Software on Solaris

Creating a Working Directory

Installing the NMT Software on Solaris

Use this procedure to install the software on the Solaris platform.


Step 1 Log on to the same Solaris platform as the account that will own the software. Move into the directory that will hold all WAN Modeling Tool releases, such as the following:

mkdir /usr/users/NMT
cd /usr/users/NMT 

Step 2 Download or copy the NMT15.4.00.Patch1.tar.Z installation file to the installation directory.

Step 3 Uncompress the installation tar file:

uncompress NMT15.4.00.Patch1.tar.Z 

Step 4 Extract the archived files:

tar xvpf NMT15.4.00.Patch1.tar 

This creates the "/usr/users/NMT/154" directory that contains all of the software.


Creating a Working Directory

Use this procedure to create a working directory on the Solaris platform.

You need to perform this procedure only one time. After you create the working directory, you can launch the NMT from it.


Step 1 Log into the account that will be using the WAN Modeling Tools for designing and modeling networks. (This account can be the same account that owns the software directory, or it can be a different account.)

Step 2 Create a working directory and move into it, such as the following:

mkdir my_net_plans 
cd my_net_plans 

Step 3 If your terminal window is not running CShell, enter the following command:

csh

Step 4 Set the NMTHOME environment variable to the software installation directory:

setenv NMTHOME /usr/users/NMT/154 

Step 5 Link the working directory to the software installation directory:

$NMTHOME/nmtlink  

For details on how to run various software components, see the Cisco WAN Modeling Tools User Guide.


Installing the NMT on a Windows Platform

Use this procedure to install the NMT on a Windows platform.


Step 1 Download and run the NMT15.4.00.Patch1_PC.exe installation file, which is a self-extracting zip file. It requires about 20 MB of disk space.

By default, the zip file installs the NMT in the C:\NMT directory path, which Cisco recommends that you use.

However, you can change the directory to D:\NMT if you do not have a version of the NMT installed in the C:\NMT directory.

To install the NMT in a directory other than C:\NMT or D:\NMT (if no version is installed in C:\NMT), go to Step 2.

If you are using C:\NMT or D:\NMT (if no version is installed in C:\NMT), go to Step 3.

Step 2 If you choose to change an installation directory to one than specified above, you need to set the NMTHOME environment variable, as follows:

For Windows XP or 2000:

a. For Windows XP or 2000, double-click My Computer on the desktop and then double-click Control Panel > System.

b. Click the Advanced tab.

c. Click Environment Variables.

d. Add the new environment variable, "NMTHOME," and set it to the NMT installation directory path.

e. Before running the NMT, reboot your machine to enable the environment variables.

For an earlier version of Windows:

a. For an earlier version of Windows, modify the autoexec.bat file to add a line that sets the drive and directory of NMTHOME to the NMT installation directory, as shown in this example:

set NMTHOME=e:\myalternatepath\ciscoproducts\nmt 

b. Before running the NMT, reboot your machine to enable the environment variables.

Step 3 Install the shortcut:

a. In Windows Explorer, navigate to C:\NMT\install and then to the subdirectory that corresponds to the operating system of your PC.

b. Drag and drop the Cisco WAN Modeling Tools shortcut to your desktop.

If you need to create a shortcut from scratch, do the following:

a. In Windows Explorer, navigate to the C:\NMT\install\nmt.exe file and drag and drop its icon to the desktop.

b. Right-click the shortcut icon and select Properties.

c. In the "Start in" field, enter the working directory. For the default directory to store your network configuration files, enter C:\NMT\data. You can also enter a different directory path.

d. Click Change Icon, and then click Browse.

e. Select the file C:\NMT\bin\nmt_icon.exe and pick the desired icon.

f. In the Properties window, click the Layout tab and set the Screen Buffer and the Width and Window sizes to 100. This sets the correct width of the NMT GUI window.

g. In the Properties window, click the Options tab and uncheck the Quick Edit and Insert Mode check boxes. This enables mouse navigation in the NMT GUI window.

h. Click OK.

Step 4 To start the NMT, click the Cisco WAN Modeling Tools icon. You can also start the NMT from the command prompt (Start > Run) and enter C:\NMT\bin\nmt.exe. In this case, you need to make sure the properties of the NMT window are set as described in Steps 3f and 3g.


Installing the Excel Macros on the Windows Platform

If you want to use the Microsoft Excel interface to edit your NMT data (tables or reports), copy the SSI file into your Microsoft Excel macro startup directory. This directory is called "xlstart" and is usually found in this directory path: C:\Program Files\Microsoft Office\Office\exstart. The SSI file is located in the C:\nmt\ssi directory.

After this file is installed, Microsoft Excel has access to these SSI macros:

NMT_Load

NMT_Unload

NMT_PrettySheet

You can access these macros from the Microsoft Excel Tools > Macros > Macros menu.

Related Documentation

These documents comprise the CWM documentation set:

Release Notes for Cisco WAN Manager, 15.4.00 P1

Cisco WAN Manager Installation Guide, 15.4.00

Cisco WAN Manager User Guide, 15.4.00

Cisco WAN Manager SNMP Service Agent Guide, 15.4.00

Cisco WAN Manager Database Interface Guide, 15.4.00

Cisco WAN Data Extraction and Synchronization Tool User Guide, 2.8

You can access all CWM documentation at this website:

http://www.cisco.com/en/US/products/sw/netmgtsw/ps2340/tsd_products_support_series_home.html

These documents are also available on Cisco.com:

Release Notes for the Cisco WAN Modeling Tools, 15.4.00 P1

Cisco WAN Modeling Tools User Guide, 15.4.00 P1

Release Notes for Cisco Automated Bulk Provisioning, 15.4.00

Cisco Automated Bulk Provisioning Software Guide, 15.4.00

The Cisco WAN Modeling Tools and Automated Bulk Provisioning user guides are also available on their software CDs and ordered separately.

Refer to the current CWM release notes for information on all the switch products that the CWM supports and that are certified in this release. In addition, a Guide to Cisco Multiservice Switch Documentation ships with your product.

You can access the MGX switch documentation at this website. See MGX Switches:

http://www.cisco.com/en/US/products/hw/switches/tsd_products_support_category_home.html

On www.Cisco.com, you can search for any product and topic documentation. On the main page, enter the word or phrase in the Search window and click the Documentation link. For example, you can search for "configuring MGX 8850" or "PXMIE." On the results page, you can click Advanced Options to refine your search.

Obtaining Documentation, Support, and Security Guidelines

For information on obtaining documentation, obtaining support, providing documentation feedback, security guidelines, recommended aliases, and general Cisco documents, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html