Guest

Cisco WAN Manager

Release Notes for the Cisco WAN Modeling Tools, 15.4.00

  • Viewing Options

  • PDF (129.5 KB)
  • Feedback
Release Notes for the Cisco WAN Modeling Tools, Release 15.4.00

Table Of Contents

Release Notes for the Cisco WAN Modeling Tools, Release 15.4.00

New Features and Enhancements

Installing the WAN Modeling Tools

Installing the NMT on Solaris

Installing the NMT on a PC

Installing the Excel Macro

Related Documentation

Obtaining Documentation, Support, and Security Guidelines


Release Notes for the Cisco WAN Modeling Tools, Release 15.4.00


March 2007

Rev. A0

These release notes are for use with the Cisco WAN Modeling Tools, which include the following subsystems:

NMT (Network Modeling Tool)

Provisions Cisco WAN products based on topology and permanent virtual circuit (PVC) and soft PVC (SPVC) demand.

Verifies connection admission control (CAC)-based quality of service (QoS) and rerouting capabilities for trunk and switch failures.

Supports MGX software release 5.x and all earlier releases.

Supports BPX and IGX switch software releases 9.4.1 back to 8.1.

Supports MGX 8220 release 5.0 back to release 3.0.

Provides a graphical map interface.

Runs on UNIX or a standalone version for PC without the map.

CET (Configuration Extraction Tool)

Extracts NMT topology data from the Cisco WAN Manager (CWM).

Compatible with CWM 9.2 and later.

TPI (Third-Party Interface)

Translates NMT data to and from WANDL network files.

Tested with WANDL 3.2.0.

SSI (Spread Sheet Interface)

Translates NMT data to and from Excel spreadsheets, included MS Excel Macro for loading tables into a workbook.

NMT2CND (Cisco Network Designer Interface)

Loads NMT data into a project in Cisco Network Designer (CND).

Supports CND 3.0 and 5.0.

As of Release 15.3.00, versions 15.0 and earlier are obsolete. Release 15.3 and later are backward compatible with the topology files that previous NMT versions use.

Cisco WAN Modeling Tools run on these platforms:

The TPI and SSI functionality is fully integrated into NMT, and UNIX command line utilities are provided.

CET should reside on the CWM platform.

NMT runs on UNIX and Windows platforms.

The map interface is only available on UNIX platform.

The NMT2CND tools are available only on PC and require CND installation.

New Features and Enhancements

These new features and enhancements were added for Release 15.4.00:

NMT

Resolved an issue related to modeling explicitly specified ports with multiple partitions. Allocated partition bandwidth and logical-channel-number resources are accounted for even although some partitions are not used for links or connection provisioning.

Corrected the connection limits for various types of AXSM cards.

Switch software release support added for MGX 5.4.0

CET

The following data is now extracted directly from the CWM database:

Routing priority for PNNI connections

Booking factor for the PNNI interface, which is derived from a set of booking factors for the classes of service (CoSs)

Administrative weight for the PNNI link, which is derived from a set of administrative weights for the CoSs

Aggregation token for the PNNI link

Installing the WAN Modeling Tools

Installing the Cisco WAN Modeling Tools on a UNIX platform consists of these two steps:

1. Platform installation—Copying the Tools software from a CD onto the Solaris platform.

2. Working directory setup—Linking the working directory to the Cisco WAN Modeling Tools software. This is done once for each working directory when it is first created.

Installing the NMT on Solaris

Use this procedure to install the software on the Solaris platform:


Step 1 Log on as the account that will own the software. Move into the directory that will hold all WAN Modeling Tool releases, such as the following:

mkdir /usr/users/NMT
cd /usr/users/NMT 

Step 2 Copy the installation file from the CD to the installation directory:

cp -p /cdrom/cdrom0/15.4.00.tar.Z  ./  

Step 3 Uncompress the installation tar file:

uncompress 15.4.00.tar.Z 

Step 4 Extract the archived files:

tar xvpf 15.4.00.tar 

This creates the "/usr/users/NMT/154" directory that contains all of the software.


Installing the NMT on a PC

Use this procedure to install the NMT.

The installation requires about 20 MB of disk space.


Step 1 Run the provided NMT installation file, which is a self-extracting zip file. On the CD, the NMT_Install.exe installation file can be found in the /cdrom/cdrom0/PC directory.

Step 2 By default, the zip file installs NMT in the C:\NMT directory path.

Cisco recommends that you keep this path as the NMT installation directory. However, you can change it to D:\NMT if you do not have a version of NMT installed under C:\NMT. If you accept this default selection, or you change the path to the D drive and have no NMT installed on the default path for the C: drive, please proceed to Step 3.

If you choose to change an installation directory other than specified above, you need to set the environment variable "NMTHOME" to that path.

For Windows 2000:

a. Navigate to Start > Settings > Control Panel > System.

b. Click the Advanced tab.

c. Click Environment Variables.

d. Add "NMTHOME" as a new environment variable and set it to the path that you have selected when unzipping the installation file.

e. Log out and then log back in before starting NMT.

For earlier version of Windows:

a. Add a line to the end of your autoexec.bat file. The autoexec.bat file is found in the C: main directory.

b. Set the drive and directory of NMTHOME to the path you entered for the unzip command; for example, your autoexec.bat file may now have the following line:

set NMTHOME=e:\myalternatepath\ciscoproducts\nmt 

c. Before running NMT, you need to reboot your machine.

Step 3 Install the shortcut:

a. Navigate to C:\NMT\install and then to the subdirectory of the operating system of your PC.

b. Drag and drop the Cisco WAN Modeling Tools shortcut to your desktop.

If you need to create a shortcut from scratch:

a. Open Windows Explorer and navigate to the file C:\NMT\install\nmt.exe.

b. Create a shortcut to the file and then drag and drop it to the desktop.

c. Right-click the shortcut icon and select Properties. In the Start field, enter C:\NMT\data, which is the default directory for storing your network configuration files. You can also enter a different directory path for storing your configuration files.

d. Click Change Icon, and then click Browse.

e. Select the file C:\NMT\bin\nmt_icon.exe and pick the icon on the left.

f. In the Properties window, click the Layout tab and set the Screen Buffer and the Width and Window sizes to 100. This sets the correct width of the NMT GUI window.

g. In the Properties window, click the Options tab and uncheck the Quick Edit and Insert Mode check boxes. This enables mouse navigation in the NMT GUI window.

h. Click OK to finish the icon configuration.

Step 4 Click the Cisco WAN Modeling Tools icon to start NMT. You can also start NMT from the command prompt (Start > Run) and enter C:\NMT\bin\nmt.exe. In this case, you need to make sure the properties of the NMT window are set as described in Step 3f and Step 3g.

Installing the Excel Macro

If you want to use the MS Excel interface for your NMT tables or reports, copy the SSI file into your Excel macro startup directory. The SSI file is located in C:\NMT\ssi directory. This Excel macro startup directory is usually found in C:\Program Files\Microsoft Office\Office\xlstart. Copy the SSI file into this directory before starting MS Excel.

Once installed, Excel will have access to the NMT_Load and NMT_Unload macros. Access these macros from the Excel Tools > Macros > Macros menu.

Related Documentation

These documents comprise the CWM documentation set:

Release Notes for Cisco WAN Manager, 15.4.00

Cisco WAN Manager Installation Guide, 15.4.00

Cisco WAN Manager User Guide, 15.4.00

Cisco WAN Manager SNMP Service Agent Guide, 15.4.00

Cisco WAN Manager Database Interface Guide, 15.4.00

Cisco WAN Data Extraction and Synchronization Tool User Guide, 2.8

You can access all CWM documentation at this website:

http://www.cisco.com/en/US/products/sw/netmgtsw/ps2340/tsd_products_support_series_home.html

These documents are also available on Cisco.com:

Release Notes for the Cisco WAN Modeling Tools, 15.4.00

Cisco WAN Modeling Tools User Guide, 15.4.00

Release Notes for Cisco Automated Bulk Provisioning, 15.4.00

Cisco Automated Bulk Provisioning Guide, 15.4.00

The Cisco WAN Modeling Tools and Automated Bulk Provisioning user guides are also available on their software CDs and ordered separately.

Refer to the current CWM release notes for information on all the switch products that the CWM supports and that are certified in this release. In addition, a Guide to Cisco Multiservice Switch Documentation ships with your product.

You can access the MGX switch documentation at this website. See MGX Switches:

http://www.cisco.com/en/US/products/hw/switches/tsd_products_support_category_home.html

On www.Cisco.com, you can search for any product and topic documentation. On the main page, enter the word or phrase in the Search window and click the Documentation link. For example, you can search for "configuring MGX 8850" or "PXMIE." On the results page, you can click Advanced Options to refine your search.

Obtaining Documentation, Support, and Security Guidelines

For information on obtaining documentation, obtaining support, providing documentation feedback, security guidelines, recommended aliases, and general Cisco documents, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html