Cisco IOS XR Interface and Hardware Component Configuration Guide, Release 3.6
Configuring Channelized SONET on Cisco IOS XR Software
Downloads: This chapterpdf (PDF - 695.0KB) The complete bookPDF (PDF - 4.93MB) | Feedback

Configuring Channelized SONET on Cisco IOS XR Software

Table Of Contents

Configuring Channelized SONET on
Cisco IOS XR Software

Contents

Prerequisites for Configuring Channelized SONET

Information About Configuring Channelized SONET

Channelized SONET Overview

Channelized SDH Overview

Default Configuration Values for Channelized SONET/SDH

How to Configure Channelized SONET

Configuring SONET T3 and VT1.5-Mapped T1 Channels

Prerequisites

Restrictions

Configuring Packet over Sonet Channels

Prerequisites

Restrictions

Configuring Clear Channel T3

Prerequisites

Restrictions

Configuring Channelized SONET APS

Prerequisites

Restrictions

Configuring SDH AU-3

Prerequisites

Restrictions

Configuring SDH AU-4

Prerequisites

Restrictions

Configuration Examples for Channelized SONET

Channelized SONET T3 to T1 Configuration: Example

Channelized Packet over SONET Configuration: Example

Clear Channel T3 Configuration: Example

Channelized SONET APS Configuration: Example

Channelized SDH AU-3 Configuration: Example

Channelized SDH AU-4 Configuration: Example

Where to Go Next

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance


Configuring Channelized SONET on
Cisco IOS XR Software


This module describes the configuration of Channelized SONET.

Feature History for Configuring Channelized SONET on Cisco IOS XR Software

Release
Modification

Release 3.5.0

This feature was introduced on the Cisco XR 12000 Series Router.

Release 3.6.0

No modifications.


Contents

Prerequisites for Configuring Channelized SONET

Information About Configuring Channelized SONET

How to Configure Channelized SONET

Configuration Examples for Channelized SONET

Prerequisites for Configuring Channelized SONET

Before configuring Channelized SONET, be sure that the following tasks and conditions are met:

You must be in a user group associated with a task group that includes the proper task IDs for SONET commands. Task IDs for commands are listed in Cisco IOS XR Interface and Hardware Component Command Reference.

You have at least one of the following shared port adapters (SPAs) installed in your chassis:

Cisco 1-Port Channelized STM-1/OC-3 shared port adapter

Cisco 1-Port Channelized DS0/OC-12 shared port adapter

Cisco 1-Port Channelized DS3/OC-48 Shared Port Adapter

You should know how to apply and specify the SONET controller name and instance identifier with the generalized notation rack/slot/module/port. The SONET controller name and instance identifier are required with the controller sonet command.

Information About Configuring Channelized SONET

To configure Channelized SONET, you must understand the following concepts:

Channelized SONET Overview

Channelized SDH Overview

Default Configuration Values for Channelized SONET/SDH

Channelized SONET Overview

Synchronous Optical Network (SONET) is an American National Standards Institute (ANSI) specification format used in transporting digital telecommunications services over optical fiber.

Synchronous Digital Hierarchy (SDH) is the international equivalent of SONET.

Channelized SONET provides the ability to transport SONET frames across multiplexed T3/E3 and virtual tributary group (VTG) channels.

Channelized SONET is supported on the following shared port adapters (SPAs):

Cisco 1-Port Channelized STM-1/OC-3 shared port adapter

Cisco 1-Port Channelized DS0/OC-12 shared port adapter

Cisco 1-Port Channelized DS3/OC-48 Shared Port Adapter

Channelized SDH is supported only on the following shared port adapter (SPA):

Cisco 1-Port Channelized STM-1/OC-3 shared port adapter

SONET uses Synchronous Transport Signal (STS) framing. An STS is the electrical equivalent to an optical carrier 1 (OC1).

SDH uses Synchronous Transport Mode (STM) framing. An STM1 is the electrical equivalent to 3 optical carrier 1s (OC1s).

A channelized SONET interface is a composite of STS streams, which are maintained as independent frames with unique payload pointers. The frames are multiplexed before transmission.

When a line is channelized, it is logically divided into smaller bandwidth channels called paths. These paths carry the SONET payload. The sum of the bandwidth on all paths cannot exceed the line bandwidth.

When a line is not channelized, it is called Clear Channel, and the full bandwidth of the line is dedicated to a single channel that carries broadband services.

An STS stream can be channelized into the following types of channels:

T3/E3

VT1.5 mapped T1

Packet over SONET/SDH (POS) (OC12 and OC48 only)

The T3/E3 channels can be channelized further into T1s, and the T1s can be channelized into time slots (DS0s).

Channelizing a SONET line consists of two primary processes:

Configuring the controller

Configuring the interface into channelized paths

You configure the controller first by setting the mode of the STS path. The mode can be set to T3, VT1.5-mapped T1, or POS.


Note POS is supported only on the STS-3c and STS-12c paths on the Cisco 1-Port Channelized DS0/OC-12 SPA and on the STS-3c, STS-12c, and STS-48c paths on the Cisco 1-Port Channelized DS3/OC-48 SPA.


When the mode is specified, the respective controller is created, and the remainder of the configuration is applied on that controller. For example, mode T3 creates a T3 controller. The T3 controller can then be configured to a serial channel, or it can be further channelized to carry T1s, and those T1s can be configured to serial interfaces.

On a Cisco 1-Port Channelized STM-1/OC-3 SPA, the default configuration consists of the following paths that are already configured when the SONET card is installed.

STS 1

STS 2

STS 3

Each STS path can be independently configured into T3s, E3s, or VTGs and so on.

Figure 1 shows the SONET controller default configuration that is in place when the card is installed.

Figure 2 shows SONET controller configuration combinations.

Figure 3 shows the T3 paths that can be configured.

Figure 4 shows the VTG paths that can be configured.

Figure 1 SONET Controller Default Configuration

Figure 2 SONET Controller Configuration Combinations

Figure 3 SONET T3 Channelized Paths

Figure 4 SONET VTG Channelized Paths

Channelized SDH Overview

Synchronous Digital Hierarchy (SDH) is the international equivalent of SONET.

Channelized SDH is supported only on the following shared port adapter (SPA):

Cisco 1-Port Channelized STM-1/OC-3 shared port adapter

A Synchronous Transport Module (STM) signal is the Synchronous Digital Hierarchy (SDH) equivalent of the SONET STS, but the numbers are different for each bandwidth. In this guide, the STM term refers to both path widths and optical line rates. The paths within an STM signals are called administrative units (AUs).

A summary of the basic terminology differences between he SONET and SDH is as follows:

SONET STS is equivalent to SDH administrative unit (AU)

SONET VT is equivalent to SDH tributary unit (TU)

SDH basic building block are STM1 (equivalent to STS-3) and STM-0 (equivalent to STS-1)

An administrative unit (AU) is the information structure that provides adaptation between the higher-order path layer and the multiplex section layer. It consists of an information payload (the higher-order virtual container) and an administrative unit pointer, which indicates the offset of the payload frame start relative to the multiplex section frame start.

An AU can be channelized into tributary units (TUs) and tributary unit groups (TUGs).

An administrative unit 4 (AU-4) consists of three STM-1s or an STM-3.

An administrative unit 3 (AU-3) consists of one STM-1.

An administrative unit group (AUG) consists of one or more administrative units occupying fixed, defined positions in an STM payload.

Table 1 SONET and SDH Terminology Equivalencies

SONET Term
SDH Term

SONET

SDH

STS-3c

AU-4

STS-1

AU-3

VT

TU

SPE

VC

Section

Regenerator Section

Line

Multiplex Section

Path

Path


Figure 5 shows the SDH AU3 paths that can be configured.

Figure 6 shows the SDH A4 paths that can be configured.

Figure 5 SDH AU3 Paths

Figure 6 SDH AU4 Paths

Default Configuration Values for Channelized SONET/SDH

Table 2 describes the default configuration parameters that are present on the Channelized SONET/SDH.

Table 2 SONET/SDH Controller Default Configuration Values

Parameter
Default Value
Configuration File Entry

clock source

line

clock source {internal | line}

SONET framing

sonet

framing {sdh | sonet}


How to Configure Channelized SONET

This section contains the following procedures:

Configuring SONET T3 and VT1.5-Mapped T1 Channels

Configuring Packet over Sonet Channels

Configuring Clear Channel T3

Configuring Channelized SONET APS

Configuring SDH AU-3

Configuring SDH AU-4

Configuring SONET T3 and VT1.5-Mapped T1 Channels

This task explains how to configure a SONET line into T3 and VT-mapped T1 Channels.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the "Configuring Clear Channel SONET Controllers on Cisco IOS XR Software" module.

Restrictions

The following restrictions apply for Cisco IOS XR Release 3.5.0:

STS paths can be channelized into T3s on:

Cisco 1-Port Channelized STM-1/OC-3 shared port adapter

Cisco 1-Port Channelized DS0/OC-12 shared port adapter

Cisco 1-Port Channelized DS3/OC-48 Shared Port Adapter.

STS paths can be channelized into VTG mapped T1s on:

Cisco 1-Port Channelized STM-1/OC-3 shared port adapter

Cisco 1-Port Channelized DS0/OC-12 shared port adapter

T3 paths can be channelized into T1s or E1s on:

Cisco 1-Port Channelized STM-1/OC-3 shared port adapter

Cisco 1-Port Channelized DS0/OC-12 shared port adapter (No E1 support in this release)

T1s are not supported on:

Cisco 1-Port Channelized DS3/OC-48 Shared Port Adapter

SUMMARY STEPS

1. configure

2. controller sonet instance

3. clock source {internal | line}

4. framing {sdh | sonet}

5. sts number

6. mode mode

7. width number

8. root

9. controller controllerName instance

10. mode mode

11. root

12. controller t1 instance

13. channel-group number

14. timeslots num1:num2:num3:num4
or
timeslots range1-range2

15. show configuration

16. root

17. interface serial interfaceNumber

18. encapsulation frame-relay | hdlc | ppp

19. ipv4 ip-address mask

20. no shutdown

21. end
or
commit

22. show

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/0/CPU0:router# configure

Enters global configuration mode.

Step 2 

controller sonet instance

Example:

RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0

Enters SONET controller configuration submode and specifies the SONET controller name and instance identifier with the rack/slot/module/port notation.

Step 3 

clock source {internal | line}

Example:

RP/0/0/CPU0:router(config-sonet)# clock source internal

Configures the SONET port transmit clock source, where the internal keyword sets the internal clock and the line keyword sets the clock recovered from the line.

Use the line keyword whenever clocking is derived from the network. Use the internal keyword when two routers are connected back to back or over fiber for which no clocking is available.

line is the default keyword.

Note Internal clocking is required for SRP interfaces.

Step 4 

framing {sdh | sonet}

Example:

RP/0/0/CPU0:router(config-sonet)# framing sonet

(Optional) Configures the controller framing with either the sdh keyword for Synchronous Digital Hierarchy (SDH) framing or the sonet keyword for SONET framing.

SONET framing (sonet) is the default.

Step 5 

sts number

Example:

RP/0/0/CPU0:router(config-sonet)# sts 1

Configures the STS stream specified by number. The ranges are:

1 to 3 on the 1-Port OC-3/STM-1 SPA

1 to 12 on the 1 Port Channelized OC12->DS0 SPA

1 to 48 on the 1 Port Channelized OC48->DS3 SPA

Step 6 

mode mode

Example:

RP/0/0/CPU0:router(config-stsPath)# mode t3

Sets the mode of interface at the STS level. The possible modes are:

t3—SONET path carrying T3

vt15-t1—SONET path carrying virtual tributary 1.5 T1s (VT15 T1)

pos—Packet over SONET (OC12 and OC48 only)

Step 7 

width number

Example:

RP/0/0/CPU0:router(config-stsPath)# width 3

Configures the number of the STS streams that are concatenated.
The possible values for number are:

1—Indicating one STS stream

3—Indicating three STS streams (STS-3c)

12—Indicating concatenation of 12 STS streams (STS-12c)

48—Indicating concatenation of 48 STS streams (STS-48c)

Widths 3, 12, and 48 are configured on STS paths at natural boundaries, which coincide with the following path numbers:

1, 4, 7, 10, and so on, for STS-3c

1, 13, 25, and 37 for STS-12c

1 for STS-48c

Step 8 

root
Example:

RP/0/0/CPU0:router(config-stsPath)# root

Exits to global configuration mode.

Step 9 

controller controllerName instance

Example:

RP/0/0/CPU0:router(config)# controller t3 0/1/0/0/0

Enters controller configuration submode and specifies the controller name and instance identifier with the rack/slot/module/port/controllerName notation. The controller names are:

t3—SONET path carrying T3

vt15-t1—SONET path carrying virtual tributary 1.5 T1s (VT15 T1)

Step 10 

mode mode

Example:

RP/0/0/CPU0:router(config-t3)# mode t1

Sets the mode of interface at this level. The possible modes are:

t1—Channelized into 28 T1s

e1—Channelized into 21 E1s

serial—Clear Channel carrying an HDLC-like payload

Step 11 

root
Example:

RP/0/0/CPU0:router(config-t3)# root

Exits to global configuration mode.

Step 12 

controller t1 instance

Example:

RP/0/0/CPU0:router(config)# controller t1 0/1/0/0/0/0

Enters T1 controller configuration submode and specifies the T1 controller name and instance identifier with the rack/slot/module/port/T3Num/T1num notation.

Step 13 

channel-group number

Example:

RP/0/0/CPU0:router(config-t1)# channel-group 1

Sets the channel group number to which time slots are assigned. The range is from 1 to 24.

Step 14 

timeslots num1:num2:num3:num4

or

timeslots range1-range2

Example:

RP/0/0/CPU0:router(config-t1-channel_grou p)# timeslots 1:3:7:9

RP/0/0/CPU0:router(config-t1-channel_grou p)# timeslots 1-12

Specifies the time slots for the interface by number with the num1:num2:num3:num4 notation, or by range with the range1-range2 notation.

Step 15 

show configuration

Example:

RP/0/0/CPU0:router(config-t1-channel_grou p)# show configuration

Displays the contents of uncommitted configuration.

Step 16 

root
Example:

RP/0/0/CPU0:router(config-t3)# root

Exits to global configuration mode.

Step 17 

interface serial interfaceNumber

Example:

RP/0/0/CPU0:router(config)# interface serial 0/1/0/0/0/0:0

Specifies the complete interface number with the rack/slot/module/port/T3Num/T1num:instance notation.

Step 18 

encapsulation frame-relay | hdlc | ppp

Example:

Router(config-if)# encapsulation frame-relay | hdlc | ppp

Specifies the encapsulation type with the one of the following keywords:

frame-relay—Frame Relay network protocol

hdlc—High-level Data Link Control (HDLC) synchronous protocol

ppp—Point-to-Point Protocol

Step 19 

ipv4 ip-address mask

Example:

Router(config-if)# ip address 10.10.10.10 255.255.255.255

Assigns an IP address and subnet mask to the interface.

Step 20 

no shutdown

Example:

RP/0/0/CPU0:router (config-if)# no shutdown

Removes the shutdown configuration.

Note Removal of the shutdown configuration eliminates the forced administrative down on the interface, enabling it to move to an up or down state (assuming that the parent SONET layer is not configured administratively down).

Step 21 

end

or

commit

Example:

RP/0/0/CPU0:router(config-sonet)# end

or

RP/0/0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 22 

show controllers sonet instance

Example:

RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Verifies the SONET controller configuration.

Configuring Packet over Sonet Channels

This task explains how to configure Packet over SONET (POS) channels.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the "Configuring Clear Channel SONET Controllers on Cisco IOS XR Software" module.

Restrictions

POS is only supported on the following SPAs:

Cisco 1-Port Channelized DS0/OC-12 shared port adapter

Cisco 1-Port Channelized DS3/OC-48 Shared Port Adapter

SUMMARY STEPS

1. configure

2. controller sonet instance

3. clock source {internal | line}

4. framing {sdh | sonet}

5. sts number

6. width number

7. mode mode

8. root

9. interface pos instance

10. encapsulation [hdlc | ppp | frame-relay [IETF]]

11. pos crc {16 | 32}

12. mtu value

13. no shutdown

14. end
or
commit

15. show interfaces pos instance

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/0/CPU0:router# configure

Enters global configuration mode.

Step 2 

controller sonet instance

Example:

RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0

Enters SONET controller configuration submode and specifies the SONET controller name and instance identifier with the rack/slot/module/port notation.

Step 3 

clock source {internal | line}

Example:

RP/0/0/CPU0:router(config-sonet)# clock source internal

Configures the SONET port transmit clock source, where the internal keyword sets the internal clock and the line keyword sets the clock recovered from the line.

Use the line keyword whenever clocking is derived from the network. Use the internal keyword when two routers are connected back to back or over fiber for which no clocking is available.

line is the default keyword.

Note Internal clocking is required for SRP interfaces.

Step 4 

framing {sdh | sonet}

Example:

RP/0/0/CPU0:router(config-sonet)# framing sonet

(Optional) Configures the controller framing with either the sdh keyword for Synchronous Digital Hierarchy (SDH) framing or the sonet keyword for SONET framing.

SONET framing (sonet) is the default.

Step 5 

sts number

Example:

RP/0/0/CPU0:router(config-sonet)# sts 1

Configures the STS stream specified by number. The ranges are:

1 to 3 on the 1-Port OC-3/STM-1 SPA

1 to 12 on the 1 Port Channelized OC12->DS0 SPA 1 to 48 on the 1 Port Channelized OC48->DS3 SPA

Step 6 

width number

Example:

RP/0/0/CPU0:router(config-stsPath)# width 3

Configures the number of the STS streams that are concatenated.
The possible values for number are:

3—Indicating three STS streams (STS-3c)

12—Indicating concatenation of 12 STS streams (STS-12c)

48—Indicating concatenation of 48 STS streams (STS-48c)

Widths 3, 12, and 48 are configured on STS paths at natural boundaries, which coincide with the following path numbers:

1, 4, 7, 10, and so on, for STS-3c

1, 13, 25, and 37 for STS-12c

1 for STS-48c

Note POS interfaces are not supported when width is 1.

Step 7 

mode mode

Example:

RP/0/0/CPU0:router(config-stsPath)# mode pos

Sets the mode of interface at the STS level. Set the mode to pos to create POS interface (OC12 and OC48 only).

Step 8 

root
Example:

RP/0/0/CPU0:router(config-stsPath)# root

Exits to global configuration mode.

Step 9 

interface pos instance

Example:

RP/0/0/CPU0:router(config)# interface POS 0/1/0/0

Specifies the POS interface name and notation rack/slot/module/port, and enters interface configuration mode.

Step 10 

encapsulation [hdlc | ppp | frame-relay [IETF]]

Example:

RP/0/0/CPU0:router(config-if)# encapsulation hdlc

(Optional) Configures the interface encapsulation parameters and details such as HDLC or PPP.

Note The default encapsulation is hdlc.

Note The frame-relay option is available on the Cisco XR 12000 Series Router only.

Step 11 

pos crc {16 | 32}

Example:

RP/0/0/CPU0:router(config-if)# pos crc 32

(Optional) Configures the CRC value for the interface. Enter the 16 keyword to specify 16-bit CRC mode, or enter the 32 keyword to specify 32-bit CRC mode.

The default CRC is 32.

Step 12 

mtu value

Example:

RP/0/0/CPU0:router(config-if)# mtu 4474

(Optional) Configures the POS MTU value.

The range is 64-65535.

Step 13 

no shutdown

Example:

RP/0/0/CPU0:router (config-if)# no shutdown

Removes the shutdown configuration.

Note Removal of the shutdown configuration eliminates the forced administrative down on the interface, enabling it to move to an up or down state (assuming that the parent SONET layer is not configured administratively down).

Step 14 

end

or

commit

Example:

RP/0/0/CPU0:router(config-sonet)# end

or

RP/0/0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 15 

show interfaces pos instance

Example:

RP/0/0/CPU0:router# show interfaces pos 0/1/0/0

(Optional) Displays the interface configuration.

Configuring Clear Channel T3

This task explains how to configure a SONET line into one T3 serial channel called Clear Channel.

Clear Channel is established by setting the T3 controller mode to serial.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the "Configuring Clear Channel SONET Controllers on Cisco IOS XR Software" module.

Restrictions

On the Cisco 1-Port Channelized STM-1/OC-3 shared port adapter, Clear Channel is supported only on STS 1 and STS 2.

SUMMARY STEPS

1. configure

2. controller sonet instance

3. clock source {internal | line}

4. framing {sdh | sonet}

5. sts number

6. mode mode

7. root

8. controller t3 instance

9. mode mode

10. root

11. interface serial interfaceNumber

12. encapsulation frame-relay | hdlc | ppp

13. ipv4 ip-address mask

14. no shutdown

15. end
or
commit

16. show controllers sonet instance

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/0/CPU0:router# configure

Enters global configuration mode.

Step 2 

controller sonet instance

Example:

RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0

Enters SONET controller configuration submode and specifies the SONET controller name and instance identifier with the rack/slot/module/port notation.

Step 3 

clock source {internal | line}

Example:

RP/0/0/CPU0:router(config-sonet)# clock source internal

Configures the SONET port transmit clock source, where the internal keyword sets the internal clock and the line keyword sets the clock recovered from the line.

Use the line keyword whenever clocking is derived from the network. Use the internal keyword when two routers are connected back to back or over fiber for which no clocking is available.

line is the default keyword.

Note Internal clocking is required for SRP interfaces.

Step 4 

framing {sdh | sonet}

Example:

RP/0/0/CPU0:router(config-sonet)# framing sonet

(Optional) Configures the controller framing with either the sdh keyword for Synchronous Digital Hierarchy (SDH) framing or the sonet keyword for SONET framing.

SONET framing (sonet) is the default.

Step 5 

sts number

Example:

RP/0/0/CPU0:router(config-sonet)# sts 1

Configures the STS stream specified by number. The ranges are:

1 to 3 on the 1-Port OC-3/STM-1 SPA

1 to 12 on the 1 Port Channelized OC12->DS0 SPA

1 to 48 on the 1 Port Channelized OC48->DS3 SPA

Step 6 

mode mode

Example:

RP/0/0/CPU0:router(config-stsPath)# mode t3

Sets the mode of interface at the STS level. The possible modes are:

t3—SONET path carrying T3

Step 7 

root
Example:

RP/0/0/CPU0:router(config-stsPath)# root

Exits to global configuration mode.

Step 8 

controller t3 instance

Example:

RP/0/0/CPU0:router(config)# controller t3 0/1/0/0/0

Enters T3 controller configuration submode and specifies the T3 controller name and instance identifier with the rack/slot/module/port/T3Num notation.

Step 9 

mode mode

Example:

RP/0/0/CPU0:router(config-t3)# mode serial

Sets the mode of interface. To establish Clear Channel, set the mode to serial.

Step 10 

root
Example:

RP/0/0/CPU0:router(config-t3)# root

Exits to global configuration mode.

Step 11 

interface serial interfaceNumber

Example:

RP/0/0/CPU0:router(config)# interface serial 0/1/0/0/0/0:0

Specifies the complete interface number with the rack/slot/module/port/T3Num/T1num:instance notation.

Step 12 

encapsulation frame-relay | hdlc | ppp

Example:

Router(config-if)# encapsulation frame-relay | hdlc | ppp

Specifies the encapsulation type with the one of the following keywords:

frame-relay—Frame Relay network protocol

hdlc—High-level Data Link Control (HDLC) synchronous protocol

ppp—Point-to-Point Protocol

Step 13 

ipv4 ip-address mask

Example:

Router(config-if)# ip address 10.10.10.10 255.255.255.255

Assigns an IP address and subnet mask to the interface.

Step 14 

no shutdown

Example:

RP/0/0/CPU0:router (config-if)# no shutdown

Removes the shutdown configuration.

Note Removal of the shutdown configuration eliminates the forced administrative down on the interface, enabling it to move to an up or down state (assuming that the parent SONET layer is not configured administratively down).

Step 15 

end

or

commit

Example:

RP/0/0/CPU0:router(config-sonet)# end

or

RP/0/0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 16 

show controllers sonet instance

Example:

RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Verifies the SONET controller configuration.

Step 17 

end

or

commit

Example:

RP/0/0/CPU0:router(config-sonet)# end

or

RP/0/0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 18 

show controllers sonet instance

Example:

RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Verifies the SONET controller configuration.

Configuring Channelized SONET APS

This task explains how to configure APS for channelized SONET lines. Both local (one router) and remote (two routers) options are given.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the "Configuring Clear Channel SONET Controllers on Cisco IOS XR Software" module.

You should know how to configure the SONET APS as specified in the "Configuring SONET APS" section of the "Configuring Clear Channel SONET Controllers on Cisco IOS XR Software" module.

Restrictions

TBD

SUMMARY STEPS

1. aps group number

2. channel {0 | 1} local sonet interface
or
channel {0 | 1} remote ip-address

3. channel {0 | 1} local sonet interface
or
channel {0 | 1} remote ip-address

4. signalling {sonet | sdh}

5. end
or
commit

6. show aps

7. show aps group [number]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

aps group number

Example:

RP/0/0/CPU0:router(config)# aps group 1

Adds an APS group with a specified number and enters APS group configuration mode.

Use the aps group command in global configuration mode.

To remove a group, use the no form of this command, as in: no aps group number, where the value range is from 1 to 255.

Note To use the aps group command, you must be a member of a user group associated with the proper task IDs for APS commands.

Note The aps group command is used even when a single protect group is configured.

Step 2 

channel {0 | 1} local sonet interface

or

channel {0 | 1} remote ip-address

Example:

RP/0/0/CPU0:router(config-aps)# channel 0 local SONET 0/0/0/1

or

RP/0/0/CPU0:router(config-aps)# channel 0 remote 172.18.69.123

Creates a channel for the APS group:

0 designates a protect channel.

1 designates an active channel.

Note The protect channel must be assigned before the active channel can be assigned.

Note To configure APS where both channels are on one router, use the channel local command for both the protect and active channels.
To configure APS using two different routers where the active channel is on one router and the protect channel is on another router, use the channel local command for either the protect or the active channel, but use the channel remote command for the other channel.

Step 3 

channel {0 | 1} local sonet interface

or

channel {0 | 1} remote ip-address

Example:

RP/0/0/CPU0:router(config-aps)# channel 1 local SONET 0/0/0/2

or

RP/0/0/CPU0:router(config-aps)# channel 1 remote 172.18.69.123

Creates a channel for the APS group:

0 designates a protect channel.

1 designates an active channel.

Note The active channel must be assigned after the protect channel is assigned.

Note To configure APS where both channels are on one router, use the channel local command for both the protect and active channels.
To configure APS using two different routers where the active channel is on one router and the protect channel is on another router, use the channel local command for either the protect or the active channel, but use the channel remote command for the other channel.

Step 4 

signalling {sonet | sdh}

Example:
RP/0/0/CPU0:router(config-aps)# 
signalling sonet

Configures the K1K2 overhead byte signaling protocol used for automatic protection switching (APS). The keyword options are:

sonet—Sets signaling to SONET.

sdh—Sets signaling to Synchronous Digital Hierarchy (SDH).

Step 5 

end

or

commit

Example:

RP/0/0/CPU0:router(config-sonet)# end

or

RP/0/0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 6 

show aps

Example:

RP/0/0/CPU0:router# show aps

(Optional) Displays the operational status for all configured SONET APS groups.

Step 7 

show aps group [number]

Example:

RP/0/0/CPU0:router# show aps group 3

(Optional) Displays the operational status for configured SONET APS groups.

Note The show aps group command is more useful than the show aps command when multiple groups are defined.

Configuring SDH AU-3

This task explains how to configure SDH AU-3 into T1 channels.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the "Configuring Clear Channel SONET Controllers on Cisco IOS XR Software" module.

Restrictions

Channelized SDH is supported only on the Cisco 1-Port Channelized STM-1/OC-3 shared port adapter (SPA).

In this release, AU-3 paths can be mapped only to C11-T1.

SUMMARY STEPS

1. configure

2. controller sonet instance

3. clock source {internal | line}

4. framing {sdh | sonet}

5. au number

6. mode mode

7. root

8. controller t1 instance

9. channel-group number

10. timeslots num1:num2:num3:num4
or
timeslots range1-range2

11. show configuration

12. root

13. interface serial interfaceNumber

14. encapsulation frame-relay | hdlc | ppp

15. ipv4 ip-address mask

16. no shutdown

17. end
or
commit

18. show controllers sonet instance

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/0/CPU0:router# configure

Enters global configuration mode.

Step 2 

controller sonet instance

Example:

RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0

Enters SONET controller configuration submode and specifies the SONET controller name and instance identifier with the rack/slot/module/port notation.

Step 3 

clock source {internal | line}

Example:

RP/0/0/CPU0:router(config-sonet)# clock source internal

Configures the SONET port transmit clock source, where the internal keyword sets the internal clock and the line keyword sets the clock recovered from the line.

Use the line keyword whenever clocking is derived from the network. Use the internal keyword when two routers are connected back to back or over fiber for which no clocking is available.

line is the default keyword.

Note Internal clocking is required for SRP interfaces.

Step 4 

framing {sdh | sonet}

Example:

RP/0/0/CPU0:router(config-sonet)# framing sdh

(Optional) Configures the controller framing with either the sdh keyword for Synchronous Digital Hierarchy (SDH) framing or the sonet keyword for SONET framing.

SONET framing (sonet) is the default.

Step 5 

au number

Example:

RP/0/0/CPU0:router(config-sonet)# au 1

Specifies the administrative unit (AU) number and enters the config-auPath mode. The range is 1 to 3.

Step 6 

mode mode

Example:

RP/0/0/CPU0:router(config-auPath)# mode c11-t1

Sets the mode of interface at the AU level. Currently only C11-T1 is supported.

Step 7 

root
Example:

RP/0/0/CPU0:router(config-auPath)# root

Exits to global configuration mode.

Step 8 

controller t1 instance

Example:

RP/0/0/CPU0:router(config)# controller T1 0/1/0/0/0/0/0

Enters T1 controller configuration submode and specifies the T1 controller name and instance identifier with the rack/slot/module/port/auNum/t1Num notation.

Step 9 

channel-group number

Example:

RP/0/0/CPU0:router(config-t1)# channel-group 0

Sets the channel-group number to which time slots are assigned. The range is from 1 to 28.

Step 10 

timeslots num1:num2:num3:num4

or

timeslots range1-range2

Example:

RP/0/0/CPU0:router(config-t1-channel_grou p)# timeslots 1:3:7:9

RP/0/0/CPU0:router(config-t1-channel_grou p)# timeslots 1-12

Specifies time slots for the interface by number with the num1:num2:num3:num4 notation, or by range with the range1-range2 notation.

Step 11 

show configuration

Example:

RP/0/0/CPU0:router(config-t1-channel_grou p)# show configuration

Displays the contents of uncommitted configuration.

Step 12 

root
Example:

RP/0/0/CPU0:router(config-t3)# root

Exits to global configuration mode.

Step 13 

interface serial interfaceNumber

Example:

RP/0/0/CPU0:router(config)# interface serial 0/1/0/0/0/0:0

Specifies the complete interface number with the rack/slot/module/port/T3Num/T1num:instance notation.

Step 14 

encapsulation frame-relay | hdlc | ppp

Example:

Router(config-if)# encapsulation frame-relay | hdlc | ppp

Specifies the encapsulation type with the one of the following keywords:

frame-relay—Frame Relay network protocol

hdlc—High-level Data Link Control (HDLC) synchronous protocol

ppp—Point-to-Point Protocol

Step 15 

ipv4 ip-address mask

Example:

Router(config-if)# ip address 10.10.10.10 255.255.255.255

Assigns an IP address and subnet mask to the interface.

Step 16 

no shutdown

Example:

RP/0/0/CPU0:router (config-if)# no shutdown

Removes the shutdown configuration.

Note Removal of the shutdown configuration eliminates the forced administrative down on the interface, enabling it to move to an up or down state (assuming that the parent SONET layer is not configured administratively down).

Step 17 

end

or

commit

Example:

RP/0/0/CPU0:router(config-sonet)# end

or

RP/0/0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 18 

show controllers sonet instance

Example:

RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Verifies the SONET controller configuration.

Configuring SDH AU-4

This task explains how to configure an SDH AU-4 stream into a TUG3 channel mapped to E3s.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the "Configuring Clear Channel SONET Controllers on Cisco IOS XR Software" module.

Restrictions

Channelized SDH is supported only on the Cisco 1-Port Channelized STM-1/OC-3 shared port adapter (SPA).

In this release, AU-4 paths can only be channelized into TUG3s.

SUMMARY STEPS

1. configure

2. controller sonet instance

3. clock source {internal | line}

4. framing {sdh | sonet}

5. au number

6. mode mode

7. width number

8. tug3 number

9. mode mode

10. root

11. controller name instance

12. mode mode

13. root

14. controller name instance

15. channel-group number

16. timeslots num1:num2:num3:num4
or
timeslots range1-range2

17. show configuration

18. root

19. interface serial interfaceNumber

20. encapsulation frame-relay | hdlc | ppp

21. ipv4 ip-address mask

22. no shutdown

23. end
or
commit

24. show controllers sonet instance

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/0/CPU0:router# configure

Enters global configuration mode.

Step 2 

controller sonet instance

Example:

RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0

Enters SONET controller configuration submode and specifies the SONET controller name and instance identifier with the rack/slot/module/port notation.

Step 3 

clock source {internal | line}

Example:

RP/0/0/CPU0:router(config-sonet)# clock source internal

Configures the SONET port transmit clock source, where the internal keyword sets the internal clock and the line keyword sets the clock recovered from the line.

Use the line keyword whenever clocking is derived from the network. Use the internal keyword when two routers are connected back to back or over fiber for which no clocking is available.

line is the default keyword.

Note Internal clocking is required for SRP interfaces.

Step 4 

framing {sdh | sonet}

Example:

RP/0/0/CPU0:router(config-sonet)# framing sdh

(Optional) Configures the controller framing with either the sdh keyword for Synchronous Digital Hierarchy (SDH) framing or the sonet keyword for SONET framing.

SONET framing (sonet) is the default.

Step 5 

au number

Example:

RP/0/0/CPU0:router(config-sonet)# au 1

Specifies the administrative unit (AU) number and enters the config-auPath mode. The range is 1 to 3.

Step 6 

mode mode

Example:

RP/0/0/CPU0:router(config-auPath)# mode tug3

Sets the mode of interface at the AU level. Currently only TUG3 is supported.

Step 7 

width number

Example:

RP/0/0/CPU0:router(config-auPath)# width 3

Configures the number of the AU streams. The range is 1 to 3.

Step 8 

tug3 number

Example:

RP/0/0/CPU0:router(config-auPath)#tug3 1

Specifies the Tributary Unit Group (TUG) number and enters the config-tug3Path mode. The range is 1 to 3.

Step 9 

mode mode

Example:

RP/0/0/CPU0:router(config-tug3Path)# mode e3

Sets the mode of interface at the tug3 level. The modes are:

e3—TUG3 path carrying E3

t3—TUG3 path carrying T3

Step 10 

root
Example:

RP/0/0/CPU0:router(config-tug3Path)# root

Exits to global configuration mode.

Step 11 

controller name instance

Example:

RP/0/0/CPU0:router(config)# controller e3 0/1/0/0/0/0

Enters controller configuration submode and specifies the controller name and instance identifier with the rack/slot/module/port/name/instance notation. The controller names are:

e3—TUG3 path carrying E3

t3—TUG3 path carrying T3

Step 12 

mode mode

Example:

RP/0/0/CPU0:router(config-e3)#mode e1

Sets the mode of interface. The modes are:

e1—Channelized into 21 E1s

serial—Clear Channel carrying hdlc-like payload

t1—Channelized into 28 T1s

Step 13 

root
Example:

RP/0/0/CPU0:router(config-e3)# root

Exits to global configuration mode.

Step 14 

controller name instance

Example:

RP/0/0/CPU0:router(config)# controller E1 0/1/0/0/0/0/0/0

Enters controller configuration submode and specifies the controller name and instance identifier with the rack/slot/module/port/name/instance1/instance2 notation. The controller names are:

e1—channelized into 32 E1s

serial—Clear Channel carrying hdlc-like payload

t1—Channelized into 24 T1s

Step 15 

channel-group number

Example:

RP/0/0/CPU0:router(config-e1)# channel-group 0

Sets the channel-group number to which time slots are assigned.

For t1, the range is from 1 to 24.

For e1, the range is from 1 to 32.

Step 16 

timeslots num1:num2:num3:num4

or

timeslots range1-range2

Example:

RP/0/0/CPU0:router(config-e1-channel_grou p)# timeslots 1:3:7:9

RP/0/0/CPU0:router(config-e1-channel_grou p)# timeslots 1-12

Specifies time slots for the interface by number with the num1:num2:num3:num4 notation, or by range with the range1-range2 notation.

Step 17 

show configuration

Example:

RP/0/0/CPU0:router(config-e1-channel_grou p)# show configuration

Displays the contents of uncommitted configuration.

Step 18 

root
Example:

RP/0/0/CPU0:router(config-e1-channel_grou p)# root

Exits to global configuration mode.

Step 19 

interface serial interfaceNumber

Example:

RP/0/0/CPU0:router(config)# interface serial 0/1/0/0/0/0:0

Specifies the complete interface number with the rack/slot/module/port/T3Num/T1num:instance notation.

Step 20 

encapsulation frame-relay | hdlc | ppp

Example:

Router(config-if)# encapsulation frame-relay | hdlc | ppp

Specifies the encapsulation type with the one of the following keywords:

frame-relay—Frame Relay network protocol

hdlc—High-level Data Link Control (HDLC) synchronous protocol

ppp—Point-to-Point Protocol

Step 21 

ipv4 ip-address mask

Example:

Router(config-if)# ip address 10.10.10.10 255.255.255.255

Assigns an IP address and subnet mask to the interface.

Step 22 

no shutdown

Example:

RP/0/0/CPU0:router (config-if)# no shutdown

Removes the shutdown configuration.

Note Removal of the shutdown configuration eliminates the forced administrative down on the interface, enabling it to move to an up or down state (assuming that the parent SONET layer is not configured administratively down).

Step 23 

end

or

commit

Example:

RP/0/0/CPU0:router(config-sonet)# end

or

RP/0/0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 24 

show controllers sonet instance

Example:

RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Verifies the SONET controller configuration.

Configuration Examples for Channelized SONET

This section contains the following examples:

Channelized SONET T3 to T1 Configuration: Example

Channelized Packet over SONET Configuration: Example

Clear Channel T3 Configuration: Example

Channelized SONET APS Configuration: Example

Channelized SDH AU-3 Configuration: Example

Channelized SDH AU-4 Configuration: Example

Channelized SONET T3 to T1 Configuration: Example

The following example shows SONET T3 to T1 configuration.

RP/0/0/CPU0:router# configure
RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0
RP/0/0/CPU0:router(config-sonet)# clock source internal
RP/0/0/CPU0:router(config-sonet)# framing sonet
RP/0/0/CPU0:router(config-sonet)# sts 1
RP/0/0/CPU0:router(config-stsPath)# mode t3
RP/0/0/CPU0:router(config-stsPath)# width 3
RP/0/0/CPU0:router(config-stsPath)# root
RP/0/0/CPU0:router(config)# controller t3 0/1/0/0/0
RP/0/0/CPU0:router(config-t3)# mode t1
RP/0/0/CPU0:router(config-t3)# framing auto-detect
RP/0/0/CPU0:router(config-t3)# root
RP/0/0/CPU0:router(config)# controller t1 0/1/0/0/0/0
RP/0/0/CPU0:router(config-t1)# framing esf
RP/0/0/CPU0:router(config-t1)# channel-group 0
RP/0/0/CPU0:router(config-t1-channel_group)# timeslots 1:3:7:9
RP/0/0/CPU0:router(config-t1-channel_group)# show configuration
RP/0/0/CPU0:router(config-t3)# root
RP/0/0/CPU0:router(config)# interface serial 0/1/0/0/0/0:0
Router(config-if)# encapsulation frame-relay | hdlc | ppp 
Router(config-if)# ip address 10.10.10.10 255.255.255.255
Router(config-if)# no shutdown
RP/0/0/CPU0:router(config-sonet)# commit
RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Channelized Packet over SONET Configuration: Example

The following example shows Channelized Packet over SONET configuration.

RP/0/0/CPU0:router# configure
RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0
RP/0/0/CPU0:router(config-sonet)# clock source internal
RP/0/0/CPU0:router(config-sonet)# framing sonet
RP/0/0/CPU0:router(config-sonet)# sts 1
RP/0/0/CPU0:router(config-stsPath)# mode pos
RP/0/0/CPU0:router(config-stsPath)# width 3
RP/0/0/CPU0:router(config-stsPath)# root
RP/0/0/CPU0:router(config)# interface POS 0/1/0/0
RP/0/0/CPU0:router(config-if)# encapsulation hdlc
RP/0/0/CPU0:router(config-if)# pos crc 32
RP/0/0/CPU0:router(config-if)# mtu 4474
RP/0/0/CPU0:router (config-if)# no shutdown
RP/0/0/CPU0:router(config-sonet)# commit
RP/0/0/CPU0:router# show interfaces pos 0/1/0/0

Clear Channel T3 Configuration: Example

The following example shows SONET Clear Channel configuration.

RP/0/0/CPU0:router# configure
RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0
RP/0/0/CPU0:router(config-sonet)# clock source internal
RP/0/0/CPU0:router(config-sonet)# framing sonet
RP/0/0/CPU0:router(config-sonet)# sts 1
RP/0/0/CPU0:router(config-stsPath)# mode t3
RP/0/0/CPU0:router(config-stsPath)# root
RP/0/0/CPU0:router(config)# controller t3 0/1/0/0/0
RP/0/0/CPU0:router(config-t3)# mode serial
RP/0/0/CPU0:router(config-t3)# root
RP/0/0/CPU0:router(config)# interface serial 0/1/0/0/0/0:0
Router(config-if)# encapsulation frame-relay | hdlc | ppp 
Router(config-if)# ip address 10.10.10.10 255.255.255.255
Router(config-if)# no shutdown
RP/0/0/CPU0:router(config-sonet)# commit
RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Channelized SONET APS Configuration: Example

The following example shows SONET Local (one router) APS configuration.

RP/0/0/CPU0:router(config)# aps group 1

RP/0/0/CPU0:router(config-aps)# channel 0 local SONET 0/0/0/1

RP/0/0/CPU0:router(config-aps)# channel 1 local SONET 0/0/0/2

RP/0/0/CPU0:router(config-aps)# signalling sonet

RP/0/0/CPU0:router(config-sonet)# commit

RP/0/0/CPU0:router# show aps

RP/0/0/CPU0:router# show aps group 3

 
   

The following example shows SONET Remote (two routers) APS configuration.

RP/0/0/CPU0:router(config)# aps group 1

RP/0/0/CPU0:router(config-aps)# channel 0 local SONET 0/0/0/1

RP/0/0/CPU0:router(config-aps)# channel 1 remote 172.18.69.123

RP/0/0/CPU0:router(config-aps)# signalling sonet

RP/0/0/CPU0:router(config-sonet)# commit

RP/0/0/CPU0:router# show aps

RP/0/0/CPU0:router# show aps group 3

Channelized SDH AU-3 Configuration: Example

The following example shows SDH AU-3 configuration.

RP/0/0/CPU0:router# configure
RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0
RP/0/0/CPU0:router(config-sonet)# clock source internal
RP/0/0/CPU0:router(config-sonet)# framing sdh
RP/0/0/CPU0:router(config-sonet)# au 1
RP/0/0/CPU0:router(config-auPath)# mode c11-t1
RP/0/0/CPU0:router(config-auPath)# root
RP/0/0/CPU0:router(config)# controller T1 0/1/0/0/0/0/0
RP/0/0/CPU0:router(config-t1)# channel-group 0
RP/0/0/CPU0:router(config-t1-channel_group)# timeslots 1-12
RP/0/0/CPU0:router(config-t1-channel_group)# show configuration
RP/0/0/CPU0:router(config-t3)# root
RP/0/0/CPU0:router(config)# interface serial 0/1/0/0/0/0:0
Router(config-if)# encapsulation frame-relay | hdlc | ppp 
Router(config-if)# ip address 10.10.10.10 255.255.255.255
Router(config-if)# no shutdown
RP/0/0/CPU0:router(config-sonet)# commit
RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Channelized SDH AU-4 Configuration: Example

The following example shows SDH AU-4 configuration.

RP/0/0/CPU0:router# configure
RP/0/0/CPU0:router(config)# controller sonet 0/1/0/0
RP/0/0/CPU0:router(config-sonet)# clock source internal
RP/0/0/CPU0:router(config-sonet)# framing sdh
RP/0/0/CPU0:router(config-sonet)# au 1
RP/0/0/CPU0:router(config-auPath)# mode tug3
RP/0/0/CPU0:router(config-auPath)# width 3
RP/0/0/CPU0:router(config-auPath)# tug3 1
RP/0/0/CPU0:router(config-tug3Path)# mode e3
RP/0/0/CPU0:router(config-tug3Path)# root
RP/0/0/CPU0:router(config)# controller e3 0/1/0/0/0/0
RP/0/0/CPU0:router(config-e3)# mode e1
RP/0/0/CPU0:router(config-e3)# root
RP/0/0/CPU0:router(config)# controller E1 0/1/0/0/0/0/0/0
RP/0/0/CPU0:router(config-e1)# channel-group 0
RP/0/0/CPU0:router(config-e1-channel_group)# timeslots 1-12
RP/0/0/CPU0:router(config-e1-channel_group)# show configuration
RP/0/0/CPU0:router(config-e1-channel_group)# root
RP/0/0/CPU0:router(config)# interface serial 0/1/0/0/0/0:0
Router(config-if)# encapsulation frame-relay | hdlc | ppp 
Router(config-if)# ip address 10.10.10.10 255.255.255.255
Router(config-if)# no shutdown
RP/0/0/CPU0:router(config-sonet)# commit
RP/0/0/CPU0:router# show controllers sonet 0/1/0/0

Where to Go Next

After configuring SONET channels, you can configure other controllers and interfaces, such as clear channel T3/E3 or channelized T3 controllers and interfaces as described in:

Configuring Clear Channel T3/E3 Controllers and Channelized T3 Controllers on Cisco IOS XR Software

Additional References

The following sections provide references related to channelized SONET configuration.

Related Documents

Related Topic
Document Title

Cisco IOS XR master command reference

Cisco IOS XR Master Commands List

Cisco IOS XR interface configuration commands

Cisco IOS XR Interface and Hardware Component Command Reference

Initial system bootup and configuration information for a router using the Cisco IOS XR Software

Cisco IOS XR Getting Started Guide

Information about user groups and task IDs

Configuring AAA Services on Cisco IOS XR Software module of Cisco IOS XR System Security Configuration Guide

Information about configuring router interfaces and other components from a remote Craft Works Interface (CWI) client management application

Cisco Craft Works Interface Configuration Guide


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

There are no applicable MIBs for this module.

To locate and download MIBs for selected platforms using
Cisco IOS XR Software, use the Cisco MIB Locator found at the following URL:

http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport