Cisco IOS XR Getting Started Guide, Release 3.3
Chapter 3 - Bringing Up the Cisco IOS XR Software on a Multishelf System
Downloads: This chapterpdf (PDF - 0.98MB) The complete bookPDF (PDF - 6.76MB) | Feedback

Bringing Up the Cisco IOS XR Software on a Multishelf System

Table Of Contents

Bringing Up the Cisco IOS XR Software on a Multishelf System

Contents

Prerequisites

Software Requirements

Hardware Requirements

Restrictions

Information About Bringing Up a Multishelf System

Bringup Overview

Preparing a Rack Number Plan

Configuring the External Cisco Catalyst 6509 Switches

Prerequisites

Restrictions

Before You Begin

Information About the Catalyst Switch Configuration

Configuring the Catalyst Switches

Summary Steps

Detailed Steps

Example to Configure a Single-FCC Multishelf System

Example Configuration for a Four-FCC Multishelf System

Verifying the Catalyst Switch

Verify the Interface Status

Verify Communication Between the Catalyst Switch and an LCC or FCC

Verify that the Links are Not Unidirectional

Bringing Up and Configuring Rack 0

Summary Steps

Detailed Steps

Examples

Bringing Up and Verifying FCCs

Summary Steps

Detailed Steps

Examples

Bringing Up and Verifying the Non-DSC LCC

Summary Steps

Detailed Steps

Verifying the Spanning Tree

Summary Steps

Detailed Steps

Examples

Verifying Fabric Cabling Connections

Where to Go Next


Bringing Up the Cisco IOS XR Software on a Multishelf System


This chapter describes how to bring up the Cisco IOS XR software on a Cisco CRS-1 Carrier Routing System Multishelf System for the first time.

Contents

This chapter contains the following sections:

Prerequisites

Restrictions

Information About Bringing Up a Multishelf System

Configuring the External Cisco Catalyst 6509 Switches

Bringing Up and Configuring Rack 0

Bringing Up and Verifying FCCs

Bringing Up and Verifying the Non-DSC LCC

Verifying the Spanning Tree

Verifying Fabric Cabling Connections

Where to Go Next

Prerequisites

The following sections describe the software and hardware requirements for bringing up a multishelf system.

Software Requirements

The multishelf system requires the following software:

Cisco IOS XR Software Release 3.3.1

ROMMON 1.40 or higher on each RP in the system


Caution The ROM Monitor software must be upgraded to version 1.40 or higher on all RPs before a Cisco CRS-1 system is upgraded to Cisco IOS XR Software Release 3.3.1 or higher release. If the router is brought up with an incompatible version of the ROM Monitor software, then the standby RP may fail to boot. For instructions to overcome a boot block in the standby RP in a single chassis system, see Cisco IOS XR ROM Monitor Guide. If a boot block occurs in a multishelf system, contact your Cisco Systems support representative for assistance. See Obtaining Technical Assistance.

In addition, Cisco CRS-1 Multishelf systems should be upgraded to ROMMON release 1.40 before being upgraded to IOS XR Release 3.3.1 to ensure RPs are assigned the correct rack numbers during system boot.

For more information, see Cisco IOS XR ROM Monitor Guide.

Hardware Requirements

Before you can bring up a multishelf system, the system components must be physically installed and tested. Three multishelf system configurations are supported. Both systems require the following components:

Two 16-slot line card chassis containing eight FC/M (S13) fabric cards

Two external Gigabit Ethernet Cisco Catalyst 6509 Switches

Single-FCC systems require one FCC containing eight SFC (S2) fabric cards. Two-FCC systems require two FCCs, and four-FCC systems require four FCCs. In two- and four-FCC configurations, the eight SFC (S2) fabric cards are distributed equally in the FCCs.

For instructions to install, cable, and verify a multishelf system, see the documents listed on the Cisco CRS-1 documentation web page listed in the "Related Documents" section.

Restrictions

The following restrictions apply to multishelf systems in Cisco IOS XR Software Release 3.3.

The multishelf system supports:

Two 16-slot line card chassis.

One, two, or four FCCs.

Two external Catalyst switches to form a control Ethernet plane used for administrative management and monitoring of the system.

The 8-slot LCCs are not supported.

Although Cisco IOS XR Software Release 3.3 supports the addition of a second line card chassis, the removal of a line card chassis is restricted. Consult your Cisco Systems support representative for more information (see the "Obtaining Technical Assistance" section).

Information About Bringing Up a Multishelf System

The following sections provide information that is good to know before you bring up a multishelf system:

Bringup Overview

Preparing a Rack Number Plan

Bringup Overview

The bringup procedure for a multishelf system starts after the hardware installation is complete. The bringup procedure tasks configure the system components to work together and verify the operation and configuration of system components. To bring up the multishelf system, complete the following procedures in the sequence shown:

1. Configuring the External Cisco Catalyst 6509 Switches

2. Bringing Up and Configuring Rack 0

3. Bringing Up and Verifying FCCs

4. Bringing Up and Verifying the Non-DSC LCC

5. Verifying the Spanning Tree

During the bringup procedure, you need the information presented in the following section.

Preparing a Rack Number Plan

In a multishelf system, each chassis must be assigned a unique rack number, as shown in Figure 3-1. This rack number is used to identify a chassis in the system, and maintain the software and configurations for the chassis.


Caution Failure to assign a unique rack number to each chassis in the system can result in serious system error and potential downtime. Unique rack numbers must be assigned and committed on Rack 0 before the additional chassis are powered on and brought on line.

Figure 3-1 DSC in a CRS-1/M-F1 Multishelf System


Note Chassis, shelf, and rack are used interchangeably. Each term refers to the physical tower that contains the installed cards, power, and cooling equipment. In general, chassis describes the system components. Rack is used in software to assign a rack number to each chassis.


A rack number plan lists each chassis in a system with the correct chassis serial ID and an assigned rack number. The serial ID is the chassis serial number, which can be accessed by the software and uniquely identifies the chassis. The rack number for an LCC is a number in the range of 0 to 255, which is easier to remember and read than serial numbers in display messages.

The rack number plan is used during the startup and configuration of Rack 0. The LCC that hosts the DSC must be configured as Rack 0. The non-DSC LCC must be configured to use a rack number in the range of 1 to 255. FCC rack numbers range from F0 to F3, as shown in Table 1, Table 2 and Table 3.

Table 1 shows a sample rack number plan for a single-FCC system.

Table 1 Sample Rack Number Plan for a Single-FCC Multishelf System

Chassis
Serial ID
Rack Number

LCC containing the active DSC

 

0

Non-DSC LCC

 

1

Fabric chassis

 

F0


Table 2 shows a sample rack number plan for a two-FCC system.

Table 2 Sample Rack Number Plan for a Two-FCC Multishelf System

Chassis
Serial ID
Rack Number

LCC containing the active DSC

 

0

Non-DSC LCC

 

1

Fabric chassis 0

 

F0

Fabric chassis 1

 

F1


Table 3 shows a sample rack number plan for a four-FCC system.

Table 3 Sample Rack Number Plan for a Four-FCC Multishelf System

Chassis
Serial ID
Rack Number

LCC containing the active DSC

 

0

Non-DSC LCC

 

1

Fabric chassis 0

 

F0

Fabric chassis 1

 

F1

Fabric chassis 2

 

F2

Fabric chassis 3

 

F3


To complete the rack number plan, change the rack number for the non-DSC LCC if you want, and record the serial number for each chassis. The chassis serial number is attached to the back of the chassis, as shown in Figure 3-2 and Figure 3-3.

Figure 3-2 Location of the Serial Number on a Fabric Card Chassis

Figure 3-3 Location of the Serial Number on a Line Card Chassis


Caution Always assign a rack number to each chassis in the system before the chassis is booted. If a chassis is not assigned a rack number, or if the rack number conflicts with an existing chassis, it may not be recognized by the system or cause other operational difficulties.

If you cannot locate or read the chassis serial number on a chassis, you can view the serial number stored in software as described in the following documents:

To display the chassis serial numbers in administration EXEC mode, see Cisco IOS XR System Management Configuration Guide, Release 3.4.

To display the configured chassis serial numbers in administration EXEC mode, see Cisco IOS XR System Management Configuration Guide, Release 3.4.

To display the chassis serial numbers in ROM Monitor, see Cisco IOS XR ROM Monitor Guide.

See the "Bringing Up and Configuring Rack 0" section for complete instructions to bring up a new router and configure the rack numbers.

Configuring the External Cisco Catalyst 6509 Switches

The control Ethernet network is formed by interconnecting each RP and shelf controller Gigabit Ethernet (SCGE) card in the system through two external Catalyst switches. (The SCGE card is the control card in an FCC.) The Catalyst switches are also directly connected using one or more Gigabit Ethernet links (see Figure 4).

These Catalyst switches must also be configured for operation with the Cisco CRS-1 multishelf router. This section includes instructions to configure and verify the Catalyst switches using the Cisco IOS Software. For instructions to install and cable the Catalyst switches, see CRS-1 Multishelf System Interconnection and Cabling Guide.

This section includes the following topics:

Prerequisites

Restrictions

Before You Begin

Information About the Catalyst Switch Configuration

Configuring the Catalyst Switches

Verifying the Catalyst Switch

Figure 4 Control Ethernet Network Connections in a Single-FCC System

Prerequisites

The following sections describe the software and hardware requirements for bringing up Catalyst 6509 Switches in a multishelf system.

Software Requirements

Each Cisco Catalyst 6509 Switch requires the same software:

Cisco IOS Release 12.2(14r)S9 with SUP720 Supervisor Engine controller module

System Bootstrap (ROMMON), Version 1.3 or later

BOOTLDR: s72033_rp Software (s72033_rp-PSV-M), Version 12.2(17d)SXB7

Both switches should use the same software. The filename of the software is 72033-psv-mz.122-17d.SXB8.bin, and is available on CCO at:

http://www.cisco.com/kobayashi/sw-center/lan/cat6000.shtml

Hardware Requirements

Two external Cisco Catalyst 6509 Switches correctly cabled to the Cisco CRS-1 multishelf router.

The recommended hardware configuration for an AC-powered Cisco Catalyst 6509 system is shown in the following table:

Quantity
Description
Part

1

Catalyst 6509 Chassis, 9slot, 15RU, No Pow Supply, No Fan Tray

WS-C6509

1

Cisco CAT6000-SUP720 IOS IP
(see Software Requirements for complete details).

S733Z-12217SXB

1

Catalyst 6500/Cisco 7600 Supervisor 720 Fabric MSFC3 PFC3B

WS-SUP720-3B

1

Catalyst 6500 Sup720 Compact Flash Mem 256MB

MEM-C6K-CPTFL256M

1

Catalyst 6000 16-port Gig-Ethernet Mod. (Req. GBICs)

WS-X6416-GBIC

8

1000BASE-LX/LH long haul GBIC (singlemode or multimode)

WS-G5486

1

Catalyst 6509 High Speed Fan Tray

WS-C6K-9SLOT-FAN2

2

Catalyst 6000 2500W AC Power Supply

WS-CAC-2500W

2

Power Cord, 250Vac 16A, straight blade NEMA 6-20 plug, US

CAB-AC-2500W-US1


Restrictions

The following restrictions apply to Cisco Catalyst 6509 Switches that are installed in a multishelf system:

Both Catalyst switches must operate with the same Cisco IOS software release.

The spanning tree implementation of Cisco CRS-1 control Ethernet assumes that all Catalyst switch ports connected to the multishelf system are kept in VLAN 1.

The Gigabit Interface Converter (GBIC) transceiver module used on the Catalyst switches must match the SFP optic used on each RP and SCGE card in the system. The GBIC can be either LX/LH or SX, but the same type must be used on both ends.


Note Both Catalyst switches must be dedicated for use with the multishelf system. The Catalyst switches should not be used for any other purpose.


Before You Begin

Before you begin to bring up the Catalyst 6509 switches, consider the following:

The Catalyst switches must be installed, including all cables properly connected between the switches and the Cisco CRS-1 router.

See the "Related Documents" section for a hyperlink to documents on installing and connecting the Catalyst switches.

For additional information regarding Cisco IOS commands and usage, see the "Cisco IOS Software Configuration" page at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/index.htm

Information About the Catalyst Switch Configuration

The configuration described in the following sections places all Catalyst ports in VLAN 1. The configuration on the Catalyst switches is the same as the configuration on the Cisco CRS-1 router internal Broadcom switches—they all participate in a Multiple Spanning Tree (MST) region with one MST instance.

The Catalyst switches are made the root of the network by assigning them the highest priority. Because there are two Catalyst switches, one is selected as the root-bridge device. Configure the primary Catalyst switch with priority 0 to make the switch the root of the network. Configure the second Catalyst switch with a number greater than 0 and less than 32768. If the primary Catalyst switch (priority 0) fails, the second switch becomes the root of the network.

Configuring the Catalyst Switches

The Cisco IOS software configuration must be applied to both external Catalyst switches.


Note Configure the primary Catalyst switch with priority 0 to make the switch the root of the network. Configure the second Catalyst switch with a number greater than 0 and less than 32768. If the primary Catalyst switch (priority 0) fails, the second switch becomes the root of the network.


To configure the Catalyst 6509 Switches, use the following procedure:

Summary Steps

1. configure

2. spanning-tree portfast default

3. spanning-tree mode mst

4. spanning-tree mst configuration

5. name mst_region

6. revision number

7. instance instance_id vlan range

8. end

9. spanning-tree mst hello-time seconds

10. spanning-tree mst forward-time seconds

11. spanning-tree mst max-age seconds

12. spanning-tree mst max-hops hops

13. spanning-tree mst instance_id priority priority

14. udld aggressive

15. udld message time interval

16. interface gigabitethernet slot/port

17. switchport

18. switchport mode access

19. switchport access vlan 1

20. end

21. Repeat Step 16 to Step 20 for all interfaces.

22. Repeat all steps for the second switch.

Detailed Steps

 
Command or Action
Purpose

Step 1 

configure

Example:

router# configure

Places the switch in global configuration mode.

Step 2 

spanning-tree mode mst

Example:

router(config)# spanning-tree mode mst

Selects the MST mode for the spanning tree protocol.

Step 3 

spanning-tree portfast default

Example:

router(config)# spanning-tree portfast default

Enables PortFast by default on all access ports.

Step 4 

spanning-tree mst configuration

Example:

router(config)# spanning-tree mst configuration

Places the router in spanning tree MST configuration mode.

Step 5 

name mst_region

Example:

router(config-mst)# name STP_1

Defines a name for an MST region.

Step 6 

revision number

Example:

router(config-mst)# revision 1

Sets a revision number for the MST configuration.

This number must be identical on both switches.

Step 7 

instance instance_id vlan range

Example:

router(config-mst)# instance 1 vlan 1

Maps the MST instance to a range of VLANs.

Step 8 

end

Example:

router(config-mst)# end

Exits spanning tree MST configuration mode.

Step 9 

spanning-tree mst hello-time seconds

Example:

router(config)# spanning-tree mst hello-time 1

Sets the hello-time delay timer for all instances on the switch.

We recommend 1 second.

Step 10 

spanning-tree mst forward-time seconds

Example:

router(config)# spanning-tree mst forward-time 6

Sets the forward-delay timer for all MST instances on the switch.

We recommend 6 seconds.

Step 11 

spanning-tree mst max-age seconds

Example:

router(config)# spanning-tree mst max-age 8

Sets the max-age timer for all MST instances on the switch.

We recommend 8 second.

Step 12 

spanning-tree mst max-hops hops

Example:

router(config)# spanning-tree mst max-hops 4

Specifies the number of possible hops in the region before a BPDU is discarded.

We recommend 4 hops.

Step 13 

spanning-tree mst instance_id priority priority

Example:

router(config)# spanning-tree mst 0-1 priority 28672

Sets the spanning tree priority for the switch.

The primary Catalyst switch should be configured with priority 0. This makes the switch the root of the network.

The second Catalyst switch should be configured with a number greater than 0 and less than 32768. If the primary Catalyst switch (priority 0) fails, the second switch becomes the root of the network.

Step 14 

udld aggressive

Example:

router(config)# udld aggressive

Enables the Unidirectional Link Detection (UDLD) protocol aggressive mode.

Step 15 

udld message time interval

Example:

router(config)# udld message time 7

Configures the time between UDLD probe messages on ports that are in advertisement mode and are currently determined to be bidirectional

Valid values are from 7 to 90 seconds.

We recommend 7 seconds.

Step 16 

interface gigabitethernet slot/port

Example:

router(config)# interface GigabitEthernet3/1

Enters interface configuration mode for the specified interface.

Step 17 

switchport

Example:

router(config-if)# switchport

Configures a LAN interface as a Layer 2 interface in preparation for additional switchport commands.

Step 18 

switchport mode access

Example:

router(config-if)# switchport mode access

Specifies a nontrunking, nontagged single-VLAN Layer-2 interface.

Step 19 

switchport access vlan 1

Example:

router(config-if)# switchport access vlan 1

(Optional) Assigns ports to VLAN 1, which is the default selection.

Step 20 

end

Example:

router(config-if)# end

Exits interface configuration mode and returns to global configuration mode.

Step 21 

Repeat Step 16 to Step 20 for all interfaces.

Configures remaining interfaces.

Repeat this configuration for each port, including ports that are not currently being used (for example, interface gigabitethernet 0/1).

Step 22 

Repeat all steps for the second switch.

Configures a second switch for redundancy.

Example to Configure a Single-FCC Multishelf System


Note When configuring the Catalyst 6509 Switches, the difference between configuring single-, two-, and four-FCC multishelf systems is the number of interfaces that require configuring. When additional FCCs are present, additional interfaces must be configured for the connections to those FCCs.


Example to Configure the First Catalyst Switch:

CAT6k-1# configure
CAT6k-1(config)# spanning-tree portfast default
CAT6k-1(config)# spanning-tree mode mst
CAT6k-1(config)# no spanning-tree optimize bpdu transmission
CAT6k-1(config)# spanning-tree mst configuration
CAT6k-1(config-mst)# name STP_1
CAT6k-1(config-mst)# revision 1
CAT6k-1(config-mst)# instance 1 vlan 1
CAT6k-1(config-mst)# end
CAT6k-1(config)# spanning-tree mst hello-time 1
CAT6k-1(config)# spanning-tree mst forward-time 6
CAT6k-1(config)# spanning-tree mst max-age 8
CAT6k-1(config)# spanning-tree mst max-hops 4
CAT6k-1(config)# spanning-tree mst 0-1 priority 0
CAT6k-1(config)# udld aggressive
CAT6k-1(config)# udld message time 7
CAT6k-1(config)# interface gigabitethernet 0/1
CAT6k-1(config-if)# switchport
CAT6k-1(config-if)# switchport mode access
CAT6k-1(config-if)# switchport access vlan 1 
 
   
CAT6k-1(config-if)# end

Example to Configure the Second Catalyst Switch:

CAT6k-2# configure
CAT6k-2(config)# spanning-tree portfast default
CAT6k-2(config)# spanning-tree mode mst
CAT6k-2(config)# no spanning-tree optimize bpdu transmission
CAT6k-2(config)# spanning-tree mst configuration
CAT6k-2(config-mst)# name STP_1
CAT6k-2(config-mst)# revision 1
CAT6k-2(config-mst)# instance 1 vlan 1
CAT6k-2(config-mst)# end
CAT6k-2(config)# spanning-tree mst hello-time 1
CAT6k-2(config)# spanning-tree mst forward-time 6
CAT6k-2(config)# spanning-tree mst max-age 8
CAT6k-2(config)# spanning-tree mst max-hops 4
CAT6k-2(config)# spanning-tree mst 0-1 priority 28672
CAT6k-2(config)# udld aggressive
CAT6k-2(config)# udld message time 7
CAT6k-2(config)# interface gigabitethernet 0/1
CAT6k-2(config-if)# switchport
CAT6k-2(config-if)# switchport mode access
CAT6k-2(config-if)# switchport access vlan 1 
 
   
CAT6k-2(config-if)# end
 
   

Example Configuration for a Four-FCC Multishelf System


Note When configuring the Catalyst 6509 Switches, the difference between configuring single-, two-, and four-FCC multishelf systems is the number of interfaces that require configuring. When additional FCCs are present, additional interfaces must be configured for the connections to those FCCs.


The following configuration display shows an example configuration for one of the Catalyst 6509 Switches in a four-FCC multishelf system:

Router# show running-config 
Building configuration...
 
   
Current configuration : 2873 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service counters max age 10
!
hostname Router
!
logging snmp-authfail
!
ip subnet-zero
!
!
!
mpls ldp logging neighbor-changes
no mls flow ip
no mls flow ipv6
mls cef error action freeze
!
power redundancy-mode combined
!         
spanning-tree mode mst
spanning-tree portfast default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
spanning-tree mst configuration
 name STP_1
 revision 1
 instance 1 vlan 1
!
spanning-tree mst hello-time 1
spanning-tree mst forward-time 6
spanning-tree mst max-age 8
spanning-tree mst 0-1 priority 28672
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!         
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
!
interface GigabitEthernet1/1
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/2
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/3
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/4
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/5
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/6
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/7
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!         
interface GigabitEthernet1/8
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/9
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/10
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/11
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/12
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/13
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/14
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/15
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/16
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet5/1
 no ip address
 shutdown
!
interface GigabitEthernet5/2
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
no ip http server
!         
!
!
!
!
line con 0
line vty 0 4
 login
!
End
 
   

Verifying the Catalyst Switch

As each rack in the multishelf system is brought up, verify that the Catalyst switch links are operating correctly by completing the tasks in the following sections:

Verify the Interface Status

Verify Communication Between the Catalyst Switch and an LCC or FCC

Verify that the Links are Not Unidirectional

Verify the Interface Status

To verify that the interfaces are connected, enter the command show interfaces status. Enter the command on a terminal connected to each Catalyst switch.

CAT6k-1show interfaces status 
 
   
Port Name Status Vlan Duplex Speed Type
Gi1/1 connected 1 full 1000 1000BaseLH
Gi1/2 connected 1 full 1000 1000BaseLH
Gi1/3 connected 1 full 1000 1000BaseLH
Gi1/4 connected 1 full 1000 1000BaseLH
Gi1/5 connected 1 full 1000 1000BaseLH
Gi1/6 connected 1 full 1000 1000BaseLH
Gi1/7 disabled 1 full 1000 1000BaseSX
Gi1/8 disabled 1 full 1000 1000BaseSX
Gi1/9 disabled 1 full 1000 1000BaseSX
Gi1/10 disabled 1 full 1000 1000BaseSX
Gi1/11 disabled 1 full 1000 1000BaseSX
Gi1/12 disabled 1 full 1000 1000BaseSX
Gi1/13 disabled 1 full 1000 1000BaseSX
Gi1/14 disabled 1 full 1000 1000BaseSX
Gi1/15 disabled 1 full 1000 1000BaseSX
Gi1/16 disabled 1 full 1000 1000BaseSX
Gi5/1 disabled 1 full 1000 1000BaseSX
Gi5/2 connected routed a-full a-100 10/100/1000BaseT
CAT6k-1

Verify Communication Between the Catalyst Switch and an LCC or FCC

To verify that the Catalyst switch is communicating with an LCC or FCC in forwarding mode, enter the command show spanning tree.

This command displays the states of the spanning tree ports. Verify that the ports used to connect the DSC, remote LCC RP, and FCC SCGE are in the FWDG state.

The listed interfaces should include the port to which you have connected. If the port is not listed, contact Cisco Technical Support. For contact information, see the "Obtaining Technical Assistance" section.

CAT6k-1# show spanning-tree 
 
   
MST00
 
   
Spanning tree enabled protocol mstp
Root ID Priority 0
Address 0013.1a4f.75c0
This bridge is the root
Hello Time 1 sec Max Age 8 sec Forward Delay 6 sec
Bridge ID Priority 0 (priority 0 sys-id-ext 0)
Address 0013.1a4f.75c0
Hello Time 1 sec Max Age 8 sec Forward Delay 6 sec
Interface Role Sts Cost Prio.Nbr Type
 
   
---------------- ---- --- --------- -------- --------------------------------
 
   
Gi1/1 Desg FWD 20000 128.1 P2p 
Gi1/2 Desg FWD 20000 128.2 P2p 
Gi1/3 Desg FWD 20000 128.3 P2p 
Gi1/4 Desg FWD 20000 128.4 P2p 
Gi1/5 Desg FWD 20000 128.5 P2p 
Gi1/6 Desg FWD 20000 128.6 P2p 
 
   
 
   
MST01
Spanning tree enabled protocol mstp
Root ID Priority 1
Address 0013.1a4f.75c0
This bridge is the root
Hello Time 1 sec Max Age 8 sec Forward Delay 6 sec
Bridge ID Priority 1 (priority 0 sys-id-ext 1)
Address 0013.1a4f.75c0
Hello Time 1 sec Max Age 8 sec Forward Delay 6 sec
Interface Role Sts Cost Prio.Nbr Type
 
   
---------------- ---- --- --------- -------- --------------------------------
 
   
Gi1/1 Desg FWD 20000 128.1 P2p 
Gi1/2 Desg FWD 20000 128.2 P2p 
Gi1/3 Desg FWD 20000 128.3 P2p 
Gi1/4 Desg FWD 20000 128.4 P2p 
Gi1/5 Desg FWD 20000 128.5 P2p 
Gi1/6 Desg FWD 20000 128.6 P2p 
CAT6k-1#
 
   

Verify that the Links are Not Unidirectional

After an LCC or FCC is brought up, verify that the Catalyst links are operating correctly. If a link has a partial fiber cut or a bad optic, the control Ethernet network can become unidirectional and cause a loop.

To verify the links in a Catalyst switch using the Cisco IOS software, enter the command show interface in EXEC mode.

In the following example, the command is entered for a specific port. The keywords | inc Gig narrows the output to Gigabit Ethernet ports.

Router# show interface gi 6/1 | inc Gig
 
   
GigabitEthernet6/1 is up, line protocol is up (connected)
Router#
 
   

The output of this command should display "connected." If it does not, then the connector may have a partial fiber cut or a bad optic. You may need to jiggle the GBIC wire to ensure that it is firmly inserted. Re-enter the command show interface until the port displays a status of "connected" or "disabled" for every port that displays a connector type.


Caution If this problem is not resolved and the Cisco CRS-1 router enters the forwarding state, a loop occurs.

Bringing Up and Configuring Rack 0

When the control network has been established by installing, cabling, and configuring the Catalyst switches, it is time to bring up and configure Rack 0 in the multishelf system, as described in the following procedure.

Summary Steps

1. Power down all LCCs and FCCs.

2. Apply power to the LCC that contains the DSC.

3. Connect to the DSC console port and log in.

4. admin

5. configure

6. dsc serial serial ID rack 0

7. dsc serial serial ID rack rackNumber

8. dsc serial serial ID rack Fn

9. commit

10. show running-config | include dsc

11. controllers fabric plane planeNumber
oim count 1
oim instance 0 location F
rack/slot/FM

12. commit

13. end

Detailed Steps

 
Command or Action
Purpose

Step 1 

Power down all LCCs and FCCs.

Prepares the LCCs and FCCs for startup in the proper sequence.

Each LCC and FCC should be powered up in the order specified in this chapter.

Step 2 

Apply power to the LCC that contains the DSC.

Boots the LCC containing the DSC.

Allow the rack to fully boot.

Verify that "IOS XR RUN" appears on the RP faceplates.

See the Cisco CRS-1 documentation web page listed in the "Related Documents" section for site planning information including DSC placement.

Step 3 

Connect to the DSC console port and log in.

Establishes a CLI management session with the router.

For more information, see the "Connecting to the Router Through the Console Port" section.

Step 4 

admin

Example:

RP/0/RP0/CPU0:router# admin

Places the router in administration EXEC mode.

Step 5 

configure

Example:

RP/0/RP0/CPU0:router(admin)# configure

Places the router in administration configuration mode.

Step 6 

dsc serial serial ID rack 0

Example:

RP/0/RP0/CPU0:router(admin-config)# dsc serial TBA00000001 rack 0

Defines which LCC is Rack 0.

The LCC containing the DSC should be configured with the lowest rack number.

Replace serial ID with the serial number of the LCC you want to configure as Rack 0.

See the "Preparing a Rack Number Plan" section for information on locating the serial number.

Step 7 

dsc serial serial ID rack rackNumber

Example:

RP/0/RP0/CPU0:router(admin-config)# dsc serial TBA00000002 rack 1

Defines the rack number for the second LCC.

See the "Preparing a Rack Number Plan" section for information on locating the serial numbers and selecting rack numbers.

Replace serial ID with the serial number of the second LCC.

Replace rackNumber with a number in the range of 1 to 255.

When each subsequent LCC comes on line, the DSC examines the chassis serial number and automatically assigns the correct rack number to that chassis.

Step 8 

dsc serial serial ID rack Fn

Example:

RP/0/RP0/CPU0:router(admin-config)# dsc serial TBA00000003 rack F0

Defines the rack number for an FCC.

See the "Preparing a Rack Number Plan" section for information on locating the serial numbers and selecting rack numbers.

Enter this command for every FCC in the multishelf system.

Replace serial ID with the serial number of the FCC.

Replace n with the FCC rack number. These numbers begin with F0 and increment to F1, F2, and F3.

When each subsequent rack comes on line, the DSC examines the chassis serial number and automatically assigns the correct rack number to that chassis.

Step 9 

commit

Example:

RP/0/RP0/CPU0:router(admin-config)# commit

Commits the target configuration to the router running configuration.

Step 10 

show running-config | include dsc

Example:

RP/0/RP0/CPU0:router(admin-config)# show running-config | include dsc

Displays the committed rack number configuration. Verify that the serial numbers entered for each chassis are correct.

Step 11 

controllers fabric plane planeNumber

oim count 1

oim instance 0 location Frack/SMslot/FM

Example:
RP/0/RP0/CPU0:router(admin-config)# controllers fabric 
plane 0
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 
location F0/SM9/FM

Configures a plane to operate in an FCC slot.

Enter this command sequence for each of the eight fabric planes.

Replace planeNumber with the number of the plane (0 to 7) you want to configure.

Replace rack with the FCC rack number assigned to the FCC that hosts the plane.

Replace slot with the FCC slot number that supports the fabric plane you are configuring. Valid slot numbers are SM0 to SM23.

The plane numbers and slot numbers are determined by the hardware installation and cabling. The software configuration must match the hardware configuration. For more information, see Cisco CRS-1 Carrier Routing System Multishelf System Interconnection and Cabling Guide.

Step 12 

commit

Example:

RP/0/RP0/CPU0:router(admin-config)# commit

Commits the target configuration to the router running configuration.

Step 13 

end

Example:

RP/0/RP0/CPU0:router(admin-config)# end

RP/0/RP0/CPU0:router(admin)# 

Exits administration configuration mode and enters administration EXEC mode.

Examples

This section contains examples for the following subjects:

Example: Configuring and Verifying the Rack Numbers in a Single-FCC Multishelf System

Example: Mapping Each Fabric Plane in a Single-FCC Multishelf System

Example: Mapping Each Fabric Plane in a Two-FCC Multishelf System

Example: Mapping Each Fabric Plane in a Four-FCC Multishelf System

Example: Configuring and Verifying the Rack Numbers in a Single-FCC Multishelf System

In the following example, rack numbers are assigned to each LCC and FCC in administration configuration mode:

RP/0/RP0/CPU0:router# admin
RP/0/RP0/CPU0:router(admin)# configure
RP/0/RP0/CPU0:router(admin-config)# dsc serial TBA00000001 rack 0
RP/0/RP0/CPU0:router(admin-config)# dsc serial TBA00000002 rack 1
RP/0/RP0/CPU0:router(admin-config)# dsc serial TBA00000003 rack F0
RP/0/RP0/CPU0:router(admin-config)# commit
RP/0/RP0/CPU0:router(admin-config)# show running-config | include dsc
 
   
Building configuration...
dsc serial TBA00000003 rack F0
dsc serial TBA00000001 rack 0
dsc serial TBA00000002 rack 1
RP/0/RP0/CPU0:router(admin-config)# 

Example: Mapping Each Fabric Plane in a Single-FCC Multishelf System

In the following example, each fabric plane is assigned to an FCC slot in administration configuration mode:

RP/0/RP0/CPU0:router(admin-config)# controllers fabric plane 0 
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 location F0/SM9/FM
 
   
RP/0/RP0/CPU0:router(admin-config)# controllers fabric plane 1 
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 location F0/SM6/FM
 
   
RP/0/RP0/CPU0:router(admin-config)# controllers fabric plane 2 
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 location F0/SM3/FM
 
   
RP/0/RP0/CPU0:router(admin-config)# controllers fabric plane 3 
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 location F0/SM0/FM
 
   
RP/0/RP0/CPU0:router(admin-config)# controllers fabric plane 4 
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 location F0/SM12/FM
 
   
RP/0/RP0/CPU0:router(admin-config)# controllers fabric plane 5 
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 location F0/SM15/FM
 
   
RP/0/RP0/CPU0:router(admin-config)# controllers fabric plane 6 
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 location F0/SM18/FM
 
   
RP/0/RP0/CPU0:router(admin-config)# controllers fabric plane 7 
RP/0/RP0/CPU0:router(admin-config)# oim count 1
RP/0/RP0/CPU0:router(admin-config)# oim instance 0 location F0/SM21/FM
 
   
RP/0/RP0/CPU0:router(admin-config)# commit
RP/0/RP0/CPU0:router(admin-config)# end
RP/0/RP0/CPU0:router(admin)# 

Example: Mapping Each Fabric Plane in a Two-FCC Multishelf System

The following configuration display is an example of a configuration for a four-FCC multishelf system:

P/0/RP0/CPU0:R2D2-L0(admin)# show running-config 
 
   
Building configuration...
username admin
 secret 5 $1$iGx3$0BI/8hOKRUMqtfWC4IUn50
 group root-system
 group cisco-support
!
dsc serial TBA09250241 rack 1
dsc serial TBA09270100 rack F0
dsc serial TBA09300128 rack F1
controllers fabric plane 0
 oim count 1
 oim instance 0 location F0/SM0/FM
!
controllers fabric plane 1
 oim count 1
 oim instance 0 location F0/SM9/FM
!
controllers fabric plane 2
 oim count 1
 oim instance 0 location F0/SM12/FM
!
controllers fabric plane 3
 oim count 1
 oim instance 0 location F0/SM21/FM
!
controllers fabric plane 4
 oim count 1
 oim instance 0 location F1/SM0/FM
!
controllers fabric plane 5
 oim count 1
 oim instance 0 location F1/SM91/FM
!
controllers fabric plane 6
 oim count 1
 oim instance 0 location F1/SM12/FM
!
controllers fabric plane 7
 oim count 1
 oim instance 0 location F1/SM21/FM
!
end
 
   

Example: Mapping Each Fabric Plane in a Four-FCC Multishelf System

The following configuration display is an example of a configuration for a four-FCC multishelf system:

P/0/RP0/CPU0:R2D2-L0(admin)# show running-config 
 
   
Building configuration...
username admin
 secret 5 $1$iGx3$0BI/8hOKRUMqtfWC4IUn50
 group root-system
 group cisco-support
!
dsc serial TBA09250241 rack 1
dsc serial TBA09270100 rack F0
dsc serial TBA09300128 rack F1
dsc serial TBA09460027 rack F3
dsc serial TBA09460028 rack F2
controllers fabric plane 0
 oim count 1
 oim instance 0 location F0/SM0/FM
!
controllers fabric plane 1
 oim count 1
 oim instance 0 location F0/SM9/FM
!
controllers fabric plane 2
 oim count 1
 oim instance 0 location F1/SM0/FM
!
controllers fabric plane 3
 oim count 1
 oim instance 0 location F1/SM9/FM
!
controllers fabric plane 4
 oim count 1
 oim instance 0 location F2/SM0/FM
!
controllers fabric plane 5
 oim count 1
 oim instance 0 location F2/SM9/FM
!
controllers fabric plane 6
 oim count 1
 oim instance 0 location F3/SM0/FM
!
controllers fabric plane 7
 oim count 1
 oim instance 0 location F3/SM9/FM
!
end
 
   

Bringing Up and Verifying FCCs

When Rack 0 is up and configured to support the rack number and FCC fabric plane plans, it is time to bring up and configure the FCC in the multishelf system as described in the following procedure.

Summary Steps

1. Apply power to all FCCs.

2. show controllers fabric rack all detail

3. show controllers fabric plane all detail

4. show controllers fabric connectivity all detail

5. On the external Catalyst switches, verify that the links are not unidirectional.

Detailed Steps

 
Command or Action
Purpose

Step 1 

Apply power to all FCCs.

Starts the FCCs.

Allow each FCC to fully boot.

Verify that "IOS XR RUN" appears on the SC faceplates.

Verify that the indicator LED on the OIM LED panel is green for each fabric cable connected to Rack 0.

Each FCC loads any required software and configurations from the DSC, including the rack number and appropriate Cisco IOS XR software packages.

Do not proceed until both SCGEs in each FCCs display "IOS XR RUN." This indicates that each SCGE has successfully loaded the Cisco IOS XR software.

Step 2 

show controllers fabric rack all detail

Example:

RP/0/RP0/CPU0:router(admin)# show controllers fabric rack all detail

Displays the status of all racks in the system.

In a properly operating system, the rack status for all racks should be Normal, and the server status should be Present.

Step 3 

show controllers fabric plane all detail

Example:

RP/0/RP0/CPU0:router(admin)# show controllers fabric plane all detail

Displays the status of all racks and additional information for racks in installation mode.

Wait for the status in the Admin State and Oper State columns to change to UP for all planes.

Step 4 

show controllers fabric connectivity all detail

Example:

RP/0/RP0/CPU0:router(admin)# show controllers fabric connectivity all detail

Displays the LCC cards that can communicate with all eight fabric planes.

The expected output should contain a series of `1's for each of the fabric planes active in the system. If a fabric plane is administratively "shutdown" the output of the command above remains the same. If the fabric card is physically removed or powered down, the "1" changes to "."

Step 5 

On the external Catalyst switches, verify that the links are not unidirectional.

Verifies that the links from the chassis to the external Catalyst switches are operating correctly.

If a unidirectional link is present, a loop may occur.

For instructions to verify the Catalyst links, see the "Verifying the Catalyst Switch" section. The verification commands must be entered from a terminal directly connected to the external Catalyst switches, using Cisco IOS CLI commands.

Examples

This section contains an example for the following task:

Verify That All Fabric Planes Are Ready to Handle Data

Verify That All Fabric Planes Are Ready to Handle Data

In the following examples, the fabric planes are examined in administration EXEC mode to ensure that they are ready to handle traffic.

show controllers fabric rack all detail

In the following example, the rack status is normal and the server status is present.

RP/0/RP0/CPU0:router(admin)# show controllers fabric rack all detail
 
   
Rack   Rack       Server
Num    Status     Status
----   ------     ------
 
   
 0       NORMAL    PRESENT
 1       NORMAL    PRESENT
 F0      NORMAL    PRESENT
RP/0/RP0/CPU0:router(admin)#

show controllers fabric plane all detail

In the following example, all eight planes are displayed, and the administrative and operational state of each plane is up.

RP/0/RP0/CPU0:CRS-8_P1(admin)# show controllers fabric plane all detail
 
   
  Flags: P - plane admin down,       p - plane oper down 
         C - card admin down,        c - card  oper down 
         L - link port admin down,   l - linkport oper down 
         A - asic admin down,        a - asic oper down 
         B - bundle port admin Down, b - bundle port oper down 
         I - bundle admin down,      i - bundle oper down 
         N - node admin down,        n - node down 
         o - other end of link down  d - data down
         f - failed component downstream 
         m - plane multicast down 
 
   
 Plane  Admin   Oper       Down       Total     Down   
 Id     State   State      Flags      Bundles   Bundles
 ------------------------------------------------------
 0      UP      UP                    0         0      
 1      UP      UP                    0         0      
 2      UP      UP                    0         0      
 3      UP      UP                    0         0      
 4      UP      UP                    0         0      
 5      UP      UP                    0         0      
 6      UP      UP                    0         0      
 7      UP      UP                    0         0 
 
   

show controllers fabric connectivity all detail

The expected output should contain a series of 1s for each of the fabric planes active in the system. If a fabric plane is administratively shut down, the output of the command remains the same. If the fabric card is physically removed or powered down, the 1 changes to a dot (.).

RP/0/RP0/CPU0:CRS-8_P1(admin)# show controllers fabric connectivity all detail
 
   
Flags: P - plane admin down,       p - plane oper down 
         C - card admin down,        c - card  oper down 
         L - link port admin down,   l - linkport oper down 
         A - asic admin down,        a - asic oper down 
         B - bundle port admin Down, b - bundle port oper down 
         I - bundle admin down,      i - bundle oper down 
         N - node admin down,        n - node down 
         o - other end of link down  d - data down
         f - failed component downstream 
         m - plane multicast down 
 
   
 Card       In  Tx Planes  Rx Planes  Monitored        Total            Percent
 R/S/M      Use 01234567   01234567   For (s)          Uptime (s)       Uptime 
-------------------------------------------------------------------------------
0/1/CPU0    1   11111111   11111111   1245608          1245608          100.0000
0/6/CPU0    1   11111111   11111111   1245608          1245608          100.0000
0/RP0/CPU0  1   11111111   11111111   1245608          1245608          100.0000
0/RP1/CPU0  1   11111111   11111111   1245608          1245608          100.0000
 
   

Bringing Up and Verifying the Non-DSC LCC

When all FCCs are up and properly supporting Rack 0, it is time to bring up and configure the next LCC in the multishelf system as described in the following procedure:

Summary Steps

1. Apply power to the second LCC.

2. show controllers fabric rack all detail

3. show controllers fabric plane all detail

4. show controllers fabric connectivity all detail

5. On the external Catalyst switches, verify that the links are not unidirectional.

6. exit

Detailed Steps

 
Command or Action
Purpose

Step 1 

Apply power to the second LCC.

Starts up the LCC.

Allow the chassis to fully boot.

Verify that "IOS XR RUN" appears on the RP faceplates.

In each FCC, verify that the indicator LED on the OIM LED panel is green for each fabric cable connected to the non-DSC LCC.

The LCC loads any necessary software and configurations from the DSC, including the rack number and appropriate Cisco IOS XR software packages.

Do not proceed until both RPs in the LCC display "IOS XR RUN." This indicates that the RP has successfully loaded the Cisco IOS XR software.

Step 2 

show controllers fabric rack all detail

Example:

RP/0/RP0/CPU0:router(admin)# show controllers fabric rack all detail

Displays the status of all racks in the system.

In a properly operating system, the rack status for all racks should be Normal, and the server status should be Present.

Step 3 

show controllers fabric plane all detail

Example:

RP/0/RP0/CPU0:router(admin)# show controllers fabric plane all detail

Displays the status of all racks and additional information for racks in install mode.

Wait for the status in the Admin State and Oper State columns to change to UP for all planes.

Step 4 

show controllers fabric connectivity all detail

Example:

RP/0/RP0/CPU0:router(admin)# show controllers fabric connectivity all detail

Displays the LCC cards that can communicate with all eight fabric planes.

The expected output should contain a series of `1's for each of the fabric planes active in the system. If a fabric plane is administratively "shutdown" the output of the command above remains the same. If the fabric card is physically removed or powered down, the "1" changes to "."

Step 5 

On the external Catalyst switches, verify that the links are not unidirectional.

Verifies that the links from the chassis to the external Catalyst switches are operating correctly.

If a unidirectional link is present, a loop may occur.

For instructions to verify the Catalyst links, see the "Verifying the Catalyst Switch" section. The verification commands must be entered from a terminal directly connected to the external Catalyst switches, using Cisco IOS CLI commands.

Step 6 

exit

Example:

RP/0/RP0/CPU0:router(admin)# exit

RP/0/RP0/CPU0:router#

Exits administration EXEC mode and returns to EXEC mode.

Verifying the Spanning Tree

When the both LCCs and all FCCs are up and running, it is time to verify the spanning tree on the control network as described in the following procedure.

Summary Steps

1. admin

2. show platform

3. show spantree mst 1 detail location rack/slot/cpu0

Detailed Steps

 
Command or Action
Purpose

Step 1 

admin

Example:

RP/0/RP0/CPU0:router# admin

Places the router in administration EXEC mode.

All commands listed in this procedure should be entered on the pre-existing single-chassis system.

Step 2 

show platform

Example:

RP/0/RP0/CPU0:router(admin)# show platform

Displays the status of all hardware components.

The state for all modules should be IOS XR RUN or OK.

It can take a few minutes for all LCC modules to start up.

Note To view the status of all cards and modules, the show platform command must be executed in administration EXEC mode.

Step 3 

show spantree mst 1 detail location rack/slot/cpu0

Example:

RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location 0/rp0/cpu0

RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location 0/rp1/cpu0

RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location 1/rp0/cpu0

RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location 1/rp1/cpu0

RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location F0/SC0/cpu0

RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location F0/SC1/cpu0

Verifies the spanning tree.

Enter this command for each RP and SCGE card in the system.

The output for each RP and SCGE card should display the following:

In the Switched Interface column, one GE port should be in the forwarding (FWD) state.

Each RP and SCGE card should display the same designated root MAC address.

Verify that the designated root address matches the expected Catalyst switch, as defined by the Catalyst switch configuration. The root address should be the switch with the lowest priority number (0).

For more information to configure and verify the external Catalyst switches, see the "Verifying the Catalyst Switch" section.

Examples

This section contains examples for the following subjects:

Verify That the FCCs and Non-DSC LCC Are Communicating with the DSC

Verify the Spanning Tree

Verify That the FCCs and Non-DSC LCC Are Communicating with the DSC

In the following EXEC mode example, all modules are displayed and the state for all modules is "IOS XR RUN."

RP/0/RP0/CPU0:router# admin
 
   
RP/0/RP0/CPU0:router(admin)# show platform
 
   
 
   
Node            Type            PLIM            State           Config State
-----------------------------------------------------------------------------
0/3/SP          MSC(SP)         N/A             IOS XR RUN      PWR,NSHUT,MON
0/3/CPU0        MSC             16OC48-POS/DPT  IOS XR RUN      PWR,NSHUT,MON
0/RP0/CPU0      RP(Active)      N/A             IOS XR RUN      PWR,NSHUT,MON
0/RP1/CPU0      RP(Standby)     N/A             IOS XR RUN      PWR,NSHUT,MON
0/FC0/SP        LCC-FAN-CT(SP)  N/A             IOS XR RUN      PWR,NSHUT,MON
0/FC1/SP        LCC-FAN-CT(SP)  N/A             IOS XR RUN      PWR,NSHUT,MON
0/AM0/SP        ALARM(SP)       N/A             IOS XR RUN      PWR,NSHUT,MON
0/AM1/SP        ALARM(SP)       N/A             IOS XR RUN      PWR,NSHUT,MON
0/SM0/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
0/SM1/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
0/SM2/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
0/SM3/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
0/SM4/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
0/SM5/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
0/SM6/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
0/SM7/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
1/3/SP          MSC(SP)         N/A             IOS XR RUN      PWR,NSHUT,MON
1/3/CPU0        MSC             8-10GbE         IOS XR RUN      PWR,NSHUT,MON
1/RP0/CPU0      RP(Active)      N/A             IOS XR RUN      PWR,NSHUT,MON
1/FC0/SP        LCC-FAN-CT(SP)  N/A             IOS XR RUN      PWR,NSHUT,MON
1/FC1/SP        LCC-FAN-CT(SP)  N/A             IOS XR RUN      PWR,NSHUT,MON
1/AM0/SP        ALARM(SP)       N/A             IOS XR RUN      PWR,NSHUT,MON
1/AM1/SP        ALARM(SP)       N/A             IOS XR RUN      PWR,NSHUT,MON
1/SM0/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
1/SM1/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
1/SM2/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
1/SM3/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
1/SM4/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
1/SM5/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
1/SM6/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
1/SM7/SP        FC/M(SP)        N/A             IOS XR RUN      PWR,NSHUT,MON
F0/SM0/SP       FCC-SFC(SP)     FCC-FM-1S       IOS XR RUN      PWR,NSHUT,MON
F0/SM3/SP       FCC-SFC(SP)     FCC-FM-1S       IOS XR RUN      PWR,NSHUT,MON
F0/SM6/SP       FCC-SFC(SP)     FCC-FM-1S       IOS XR RUN      PWR,NSHUT,MON
F0/SM9/SP       FCC-SFC(SP)     FCC-FM-1S       IOS XR RUN      PWR,NSHUT,MON
F0/SM12/SP      FCC-SFC(SP)     FCC-FM-1S       IOS XR RUN      PWR,NSHUT,MON
F0/SM15/SP      FCC-SFC(SP)     FCC-FM-1S       IOS XR RUN      PWR,NSHUT,MON
F0/SM18/SP      FCC-SFC(SP)     FCC-FM-1S       IOS XR RUN      PWR,NSHUT,MON
F0/SM21/SP      FCC-SFC(SP)     FCC-FM-1S       IOS XR RUN      PWR,NSHUT,MON
F0/SC0/CPU0     FCC-SC(Active)  N/A             IOS XR RUN      PWR,NSHUT,MON
F0/SC1/CPU0     FCC-SC(Standby) N/A             PRESENT         PWR,NSHUT,MON
F0/AM1/SP       ALARM(SP)       N/A             IOS XR RUN      PWR,NSHUT,MON
 
   
RP/0/RP0/CPU0:router(admin)# end
 
   

Verify the Spanning Tree

For each RP and SCGE card in the system, verify that:

One GE port in the Switched Interface column is in the forwarding (FWD) state.

Each RP and SCGE card displays the same designated root MAC address.

The designated root address matches the expected Catalyst switch, as defined by the Catalyst switch configuration. The root address should be the switch with the lowest priority number (0).

The following EXEC commands display RP and SCGE card information that you can use to verify the spanning tree:

RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location 0/rp0/cpu0
 
   
Instance                 1
Vlans mapped:            1
 
   
Designated Root          00-0e-39-fe-70-00
Designated Root Priority 1 (0 + 1)
Designated Root Port     GE_Port_0
 
   
Bridge ID MAC ADDR       00-05-9a-3e-89-4f
Bridge ID Priority       32769 (32768 + 1)
Bridge Max Age  8 sec    Hello Time  1 sec   Forward Delay  6 sec   Max Hops 4
 
   
Switched Interface   State Role   Cost    Prio Type
-------------------- ----- ---- --------- ---- --------------------------------
FE_Port_1              BLK altn    200000  128  P2P 
GE_Port_0              FWD root     20000  128  P2P 
GE_Port_1              BLK altn     20000  128  P2P 
 
   
 
   
 
   
RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location 0/rp1/cpu0
 
   
Instance                 1
Vlans mapped:            1
 
   
Designated Root          00-0e-39-fe-70-00
Designated Root Priority 1 (0 + 1)
Designated Root Port     GE_Port_0
 
   
Bridge ID MAC ADDR       00-05-9a-39-91-14
Bridge ID Priority       32769 (32768 + 1)
Bridge Max Age  8 sec    Hello Time  1 sec   Forward Delay  6 sec   Max Hops 4
 
   
Switched Interface   State Role   Cost    Prio Type
-------------------- ----- ---- --------- ---- --------------------------------
FE_Port_0              FWD desg    200000  128  P2P 
GE_Port_0              FWD root     20000  128  P2P 
GE_Port_1              BLK altn     20000  128  P2P 
 
   
RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location 1/rp0/cpu0
 
   
Instance                 1
Vlans mapped:            1
 
   
Designated Root          00-0e-39-fe-70-00
Designated Root Priority 1 (0 + 1)
Designated Root Port     GE_Port_0
 
   
Bridge ID MAC ADDR       00-05-9a-3e-89-2a
Bridge ID Priority       32769 (32768 + 1)
Bridge Max Age  8 sec    Hello Time  1 sec   Forward Delay  6 sec   Max Hops 4
 
   
Switched Interface   State Role   Cost    Prio Type
-------------------- ----- ---- --------- ---- --------------------------------
FE_Port_1              FWD desg    200000  128  P2P 
GE_Port_0              FWD root     20000  128  P2P 
GE_Port_1              BLK altn     20000  128  P2P 
 
   
 
   
 
   
RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location 1/rp1/cpu0
 
   
Instance                 1
Vlans mapped:            1
 
   
Designated Root          00-0e-39-fe-70-00
Designated Root Priority 1 (0 + 1)
Designated Root Port     GE_Port_0
 
   
Bridge ID MAC ADDR       00-05-9a-3e-89-fe
Bridge ID Priority       32769 (32768 + 1)
Bridge Max Age  8 sec    Hello Time  1 sec   Forward Delay  6 sec   Max Hops 4
 
   
Switched Interface   State Role   Cost    Prio Type
-------------------- ----- ---- --------- ---- --------------------------------
FE_Port_0              BLK altn    200000  128  P2P 
GE_Port_0              FWD root     20000  128  P2P 
GE_Port_1              BLK altn     20000  128  P2P 
 
   
 
   
 
   
RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location F0/SC0/cpu0
 
   
Instance                 1
Vlans mapped:            1
 
   
Designated Root          00-0e-39-fe-70-00
Designated Root Priority 1 (0 + 1)
Designated Root Port     GE_Port_1
 
   
Bridge ID MAC ADDR       00-05-9a-39-91-be
Bridge ID Priority       32769 (32768 + 1)
Bridge Max Age  8 sec    Hello Time  1 sec   Forward Delay  6 sec   Max Hops 4
 
   
Switched Interface   State Role   Cost    Prio Type
-------------------- ----- ---- --------- ---- --------------------------------
FE_Port_1              BLK altn    200000  128  P2P 
GE_Port_0              BLK altn     20000  128  P2P 
GE_Port_1              FWD root     20000  128  P2P 
 
   
 
   
 
   
RP/0/RP0/CPU0:router(admin)# show spantree mst 1 detail location F0/SC1/cpu0
 
   
Instance                 1
Vlans mapped:            1
 
   
Designated Root          00-0e-39-fe-70-00
Designated Root Priority 1 (0 + 1)
Designated Root Port     GE_Port_1
 
   
Bridge ID MAC ADDR       00-05-9a-39-91-68
Bridge ID Priority       32769 (32768 + 1)
Bridge Max Age  8 sec    Hello Time  1 sec   Forward Delay  6 sec   Max Hops 4
 
   
Switched Interface   State Role   Cost    Prio Type
-------------------- ----- ---- --------- ---- --------------------------------
FE_Port_0              FWD desg    200000  128  P2P 
GE_Port_0              BLK altn     20000  128  P2P 
GE_Port_1              FWD root     20000  128  P2P 
 
   

Verifying Fabric Cabling Connections

When the fabric cabling is complete and the power is on for all LCCs and FCCs, you can verify the fabric cabling connections, as described in this section.

Figure 3-5 shows the faceplate of the CRS-FCC- LED panel. The CRS-FCC-LED is also called an optical interface module (OIM) LED panel. This panel goes into slot LM0 or LM1 in a fabric card chassis.The OIM LED panel provides connectivity information on how the fabric chassis cards are functioning in the multishelf system. LEDs 0 through 11 correspond to OIM 0 through OIM 11 (FM 0 through FM 11 in software). Table 3-4 describes the possible states of the LEDs shown in Figure 3-5.

Table 3-4 LED Status Interpretation

LED State and Color
Meaning

Off

If the LED is off, it can mean:

The board to which the fabric cable is connected is powered off at one end or the other

The board is not present

The fabric cable is not connected at one end or the other.

Green

The fabric cable is properly connected at both ends, and data transmission is okay.

Yellow

The fabric cable is properly connected at both ends, but there are some data errors.

Red

The fabric cable is not connected to the correct place (when more than one fabric cable is incorrect).

Blinking red

The fabric cable is not connected to the correct place (when the fabric cable is the only or "first" such fabric cable)

Blinking green

The blinking LED indicates the place where the first and only incorrect fabric cable should be connected (corresponds to the blinking red above).


Figure 3-5 Optical Interface Module LED Panel (Part CRS-FCC-LED)

Because the OIM LED panel is present only in the fabric card chassis, the LEDs indicate the status of the bundles in the fabric card chassis only. Therefore, if a connection is wrong, the equipment assumes that the connection at the line card chassis is fixed, and the connection at the fabric card chassis is the one that needs to be relocated to the correct position as indicated by the LEDs.

Bundles are mapped to LEDs as follows:

The OIM LED panel has 9 rows of 12 LEDs— the 9 rows correspond to the 9 connectors for each slot, and 12 LEDs correspond to the 12 slots in the cage. Separate OIM LED panels provide status for the upper and lower card cages. The LED rows map to the connector number, and the LEDs in each LED row map to the slot number.

The following description helps explain the states of LEDs on the OIM LED panel. In Figure 3-6, fabric cables should connect an LCC S13 card to the FCC S2 card as follows: A0 to J0, A1 to J1, and A2 to J2. Instead, A1 is incorrectly connected to J2. This incorrect connection causes the LED corresponding to J2 to blink red, indicating that the cable connection is incorrect. The LED corresponding to J1 blinks green to show where the misplaced cable should be connected.

Figure 3-6 Illustration of How OIM LED Panel LEDs Map to Bundles and Slots (Single-Module Cabling)

1

OIM LED card

6

S13 card—This card is installed in an LCC.

2

Solid green LED—Indicates that the fabric cable connected to the corresponding port (J0) is connected correctly.

7

Correct fabric cable connection between FCC and LCC.

3

Flashing green LED—Indicates that a single fabric cable is incorrectly connected and should be connected to the corresponding connector (J1).

8

Incorrect fabric cable connection between FCC and LCC.

4

Flashing red LED—Indicates that a single fabric cable is incorrectly connected to the corresponding connector (J2).

9

Fabric card chassis

5

OIM card

 

 


Where to Go Next

For information on configuring basic router features, see Chapter 4 "Configuring General Router Features."