This documentation has been moved
Configuring SGCP RSIP and AUEP Enhancements
Downloads: This chapterpdf (PDF - 120.0KB) The complete bookPDF (PDF - 0.97MB) | Feedback

Configuring SGCP RSIP and AUEP Enhancements

Table Of Contents

Configuring SGCP RSIP and AUEP Enhancements

Contents

Prerequisites for Configuring SGCP RSIP and AUEP Enhancements

Restrictions for Configuring SGCP RSIP and AUEP Enhancements

Information About Configuring SGCP RSIP and AUEP Enhancements

How to Configure SGCP RSIP and AUEP Enhancements

Configuring SGCP RSIP and AUEP Enhancements

Verifying SGCP RSIP Configuration

Configuration Examples for Configuring SGCP RSIP and AUEP Enhancements

Disconnected RSIP Messaging Example


Configuring SGCP RSIP and AUEP Enhancements


This section provides information on configuring the Simple Gateway Control Protocol (SGCP) Restart In Progress (RSIP) and Audit Endpoint (AUEP) Enhancements feature. The feature provides enhancements to SGCP for disconnected RSIP and audit endpoints requested by call agents.

Feature benefits include the following:

Provides SGCP 1.5 gateways with the ability to synchronize endpoints with call agents after the disconnected procedure has occurred.


Note For more information about this and related Cisco IOS voice features, see the following:

"Overview of MGCP and Related Protocols" on page 3

Entire Cisco IOS Voice Configuration Library—including library preface and glossary, other feature documents, and troubleshooting documentation—at http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_voice_configuration_library_glossary/vcl.htm


Release
Modification

12.2(11)T

This feature was introduced on the following platforms: Cisco IAD2420 series, Cisco 2600 series, and Cisco MC3810.


Feature History for SGCP RSIP and AUEP Enhancements

Contents

Prerequisites for Configuring SGCP RSIP and AUEP Enhancements

Restrictions for Configuring SGCP RSIP and AUEP Enhancements

Information About Configuring SGCP RSIP and AUEP Enhancements

How to Configure SGCP RSIP and AUEP Enhancements

Configuration Examples for Configuring SGCP RSIP and AUEP Enhancements

Prerequisites for Configuring SGCP RSIP and AUEP Enhancements

Configure SGCP 1.5 on the gateway.

Restrictions for Configuring SGCP RSIP and AUEP Enhancements

This feature applies only to SGCP 1.5 gateways.

This feature does not apply to MGCP gateways.

Information About Configuring SGCP RSIP and AUEP Enhancements

The SGCP RSIP and AUEP Enhancements feature provides additional messaging capabilities that allow an endpoint on a Simple Gateway Control Protocol (SGCP) 1.5 gateway to synchronize with a call agent after the endpoint returns to service from the disconnected procedure. The additional messaging capabilities provide the following:

A special disconnected Restart In Progress (RSIP) message that the gateway sends to the call agent as a result of the disconnected procedure.

Additional fields in the Audit Endpoint (AUEP) command that the call agent uses to query the endpoint's status when contact is reestablished.

Media Gateway Control Protocol (MGCP) provides this ability automatically, but it must be explicitly configured for SGCP networks, as described in the "How to Configure SGCP RSIP and AUEP Enhancements" section.

An endpoint may lose contact with its call agent because the call agent is temporarily off line or because of faults in the network. When a gateway recognizes that an endpoint has lost its communication with the call agent, it initiates the disconnected procedure. The disconnected procedure requires the endpoint to send RSIPs to the call agent and also to guarantee that the first message that the call agent sees from the endpoint is an RSIP command. The endpoint continues to attempt to send RSIPs at the intervals prescribed by the disconnected procedure until an attempt is successful. The RSIP identifies itself as an RSIP that was generated from a disconnected procedure rather than from a restart. The following output is seen on the gateway:

Disconnected RSIP sent from gateway

00:04:27:RSIP 7 ds1-3/2@RouterA SGCP 1.5
RM:disconnected

On receipt of a disconnected RSIP message, the call agent may decide to send an AUEP command to query the status of endpoints and synchronize endpoints. The SGCP RSIP and AUEP Enhancements feature provides the following additional fields of information in the AUEP:

I—List of connection identifiers for current connections on the endpoint

ES—Event state of the endpoint (off-hook or on-hook)

RM—Restart method for the endpoint, which is one of the following:

Graceful—Endpoints are being taken out of service after a delay; the call agent should not make new connections.

Forced—Endpoints were abruptly taken out of service; connections were lost.

Restart—Endpoints with no connections will be returned to service after a delay.

Disconnected—Endpoints are being returned to service after the disconnected procedure.

How to Configure SGCP RSIP and AUEP Enhancements

See the following sections for configuration tasks for the SGCP RSIP and AUEP Enhancements feature. Each task in the list is identified as either required or optional.

Configuring SGCP RSIP and AUEP Enhancements (required)

Verifying SGCP RSIP Configuration (required)

Configuring SGCP RSIP and AUEP Enhancements

To configure enhanced restart and endpoint audit messaging capabilities on an SGCP gateway, use the following command in global configuration mode:

 
Command
Purpose
 

Router(config)# mgcp sgcp disconnect notify

Enables enhanced endpoint synchronization with a call agent after a disconnected procedure. The command is disabled by default.

Verifying SGCP RSIP Configuration

To verify your configuration, enter the show mgcp command. The following example shows that disconnected RSIP is enabled.

Router# show mgcp

MGCP Admin State ACTIVE, Oper State ACTIVE - Cause Code NONE
MGCP call-agent:172.16.193.148 Initial protocol service is SGCP 1.5
MGCP block-newcalls DISABLED
MGCP send SGCP RSIP:forced/restart/graceful DISABLED, disconnected ENABLED
MGCP quarantine mode discard/step
MGCP quarantine of persistent events is ENABLED
MGCP dtmf-relay for VoIP disabled for all codec types
MGCP dtmf-relay for VoAAL2 disabled for all codec types
MGCP voip modem passthrough mode:NSE, codec:g711ulaw, redundancy:DISABLED,
MGCP voaal2 modem passthrough mode:NSE, codec:g711ulaw
MGCP TSE payload:0
MGCP Named Signalling Event (NSE) response timer:200
MGCP Network (IP/AAL2) Continuity Test timer:200
MGCP 'RTP stream loss' timer:5
MGCP request timeout 500
MGCP maximum exponential request timeout 4000
MGCP gateway port:2427, MGCP maximum waiting delay 3000
MGCP restart delay 0, MGCP vad DISABLED
MGCP rtrcac DISABLED
MGCP system resource check DISABLED
MGCP xpc-codec:DISABLED, MGCP persistent hookflash:DISABLED
MGCP persistent offhook:ENABLED, MGCP persistent onhook:DISABLED
MGCP piggyback msg ENABLED, MGCP endpoint offset DISABLED
MGCP simple-sdp DISABLED
MGCP undotted-notation DISABLED
MGCP codec type g711ulaw, MGCP packetization period 20
MGCP JB threshold lwm 30, MGCP JB threshold hwm 150
MGCP LAT threshold lmw 150, MGCP LAT threshold hwm 300
MGCP PL threshold lwm 1000, MGCP PL threshold hwm 10000
MGCP CL threshold lwm 1000, MGCP CL threshold hwm 10000
MGCP playout mode is adaptive 60, 4, 200 in msec
MGCP IP ToS low delay disabled, MGCP IP ToS high throughput disabled
MGCP IP ToS high reliability disabled, MGCP IP ToS low cost disabled
MGCP IP RTP precedence 5, MGCP signaling precedence:3
MGCP default package:line-package
MGCP supported packages:gm-package dtmf-package trunk-package line-package
			hs-package atm-package ms-package dt-package res-package
			mt-package
MGCP Digit Map matching order:shortest match
SGCP Digit Map matching order:always left-to-right
MGCP VoAAL2 ignore-lco-codec DISABLED

Configuration Examples for Configuring SGCP RSIP and AUEP Enhancements

This section contains the following example:

Disconnected RSIP Messaging Example

Disconnected RSIP Messaging Example

The following example shows the configuration of disconnected RSIP messaging on a Cisco MC3810.

version 12.2
no parser cache
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot system tftp smithj/mc3810-r3jjl 172.16.206.10
logging buffered 2000000 debugging
no logging console
enable password lab
!
network-clock base-rate 56k
ip subnet-zero
!
no ip domain-lookup
ip host corona 172.16.206.10
ip host redlands 172.31.140.33
ip host rialto 172.16.193.147
!
voice service voip
 fax protocol t38 ls-redundancy 0 hs-redundancy 0
!
no voice confirmation-tone
voice-card 0
!
controller T1 0
 mode cas
 framing esf
 clock source internal
 linecode ami
 ds0-group 0 timeslots 1-24 type fxs-ground-start
!
interface Ethernet0
 ip address 172.16.193.162 255.255.255.0
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface FR-ATM20
 no ip address
 shutdown
ip classless
ip route 10.0.0.0 10.0.0.0 172.16.193.1
ip route 172.16.0.0 255.255.0.0 172.16.193.1
no ip http server
!
!
call rsvp-sync
!
voice-port 0:0
!
voice-port 1/1
!
voice-port 1/2
 description package
!
mgcp
mgcp call-agent 172.16.193.148 service-type sgcp version 1.5
mgcp sgcp disconnect notify
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/1
!
dial-peer voice 2 pots
 application mgcpapp
 port 1/2
!
dial-peer voice 3 pots
 application mgcpapp
 port 0:0
!
gatekeeper
 shutdown
!
line con 0
 exec-timeout 0 0
line aux 0
line 2 3
line vty 0 4
 exec-timeout 0 0
 password hemet
 login
!
end

CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.