This documentation has been moved
Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles
Downloads: This chapterpdf (PDF - 337.0KB) The complete bookPDF (PDF - 0.97MB) | Feedback

Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Table Of Contents

Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Contents

Prerequisites for Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Information About MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

MGCP Model

How to Configure MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Identifying Endpoints and Configuring the MGCP Application

Analog CAS and POTS Lines

Digital CAS Trunks

ISUP Signaling Trunks

FGD-OS Trunks

Digital VoATM with AAL2 PVC

Configuring Global MGCP Parameters

Configuring an MGCP Profile and Profile-Related MGCP Parameters

Verifying the Configuration

Troubleshooting Tips

Configuration Examples for Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Cisco uBR925 Using Radio Frequency Interface Example

Cisco uBR925 Using Ethernet0 Interface Example

Cisco CVA122 Using Radio Frequency Interface Example

Cisco 2600 Series as a Residential Gateway Example

Cisco 3660 Platform as a Trunking Gateway Example

Cisco MC3810 as a Residential Gateway Example

Cisco MC3810 as a VoAAL2 Gateway using AAL2 PVCs Example


Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles


This chapter provides configuration information on configuring the MGCP 1.0 Including Network-based Call Signaling (NCS) 1.0 and Trunking Gateway Control Protocol (TGCP) 1.0 Profiles feature. The feature implements MGCP 1.0, NCS 1.0, and TGCP 1.0 support in existing MGCP stacks.

Feature benefits include the following:

MGCP 1.0 provides flexible interoperability with a wide variety of call agents, thus enabling a wide range of solutions.

MGCP 1.0 contains many improvements over its previous release.

NCS 1.0 and TGCP 1.0 allow participation in packet cable solutions.

The ability to interoperate with H.323 and Session Initiation Protocol (SIP) control agents allows leverage of the feature sets available in the different protocols and provides the ability to migrate smoothly from one protocol to another.


Note For more information about this and related Cisco IOS voice features, see the following:

"Overview of MGCP and Related Protocols" on page 3

Entire Cisco IOS Voice Configuration Library—including library preface and glossary, other feature documents, and troubleshooting documentation—at http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_voice_configuration_library_glossary/vcl.htm


Release
Modification

12.2(2)XA

This feature was introduced on the following platforms: Cisco CVA122, Cisco uBR924, and Cisco AS5300.

12.2(2)XA1

This feature was implemented on the following platforms: Cisco CVA122, Cisco uBR925, and Cisco AS5300

12.2(2)XB

This feature was implemented on the following platforms: Cisco AS5350 and Cisco AS5400.

12.2(4)T

This feature was implemented on the following platforms: Cisco CVA122, Cisco CVA122E, Cisco uBR925, Cisco 2600 series, Cisco 2650, Cisco 3660, and Cisco MC3810. AAL2 PVC support was introduced for MGCP 1.0 on the Cisco MC3810. Certain gateway features were integrated into MGCP 1.0.

Note The Cisco AS5300 is not supported in this release.

12.2(8)T

The voice-port (MGCP profile) command was changed to port (MGCP profile) for all platforms supported in this release.

Note The Cisco AS5300 is not supported in this release.

12.2(13)T

The fax keyword was added to the mgcp playout command.

12.4(24)T3

The maximum number of MGCP profiles that can be configured was increased from 13 (12 plus 1 default) to 29 (28 plus 1 default).


Feature History for MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Contents

Prerequisites for Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Information About MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

How to Configure MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Configuration Examples for Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Prerequisites for Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

Prerequisites are described in the "Prerequisites for Configuring MGCP and Related Protocols" section on page 3. In addition, the following apply:

Ensure that the minimum software requirements are met.Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn.

Configure Voice over ATM AAL2 PVC (optional step that applies to Cisco MC3810 only). Refer to Cisco IOS Release 12.3 Configuration Guides and Command References. The router that is intending to use the VoAAL2 features must have hardware support for VoAAL2.

Set up the cable modems, if any. See the documentation for the cable product as listed in the "Preface".


Note IP addresses and host names in these examples are fictitious.


Information About MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

This feature implements the following MGCP protocols on supported Cisco media gateways:

MGCP 1.0 (RFC 2705)

Network-based Call Signaling (NCS) 1.0, the MGCP 1.0 profile for residential gateways (RGWs)

Trunking Gateway Control Protocol (TGCP) 1.0, the MGCP 1.0 profile for trunking gateways (TGWs)

VoIP—Includes signaling methods under VoIP.

AAL2 PVC—Includes signaling methods under ATM adaptation layer 2 (AAL2) permanent virtual circuit (PVC).

Basic/Extended RGW—Includes a collection of residential gateway features supporting channel-associated signaling (CAS). Digital CAS (recEive and transMit, or E&M) interfaces and analog (Foreign Exchange Office [FXO], Foreign Exchange Station [FXS], and E&M) interfaces are supported on platforms with the appropriate voice hardware.

ISUP—Supports ISDN user part signaling for SS7 trunks.

FGD-OS—Supports Feature Group D Operator Services signaling over T1 or E1 trunks.

Incoming CAS—Supports digital CAS interfaces for digital incoming multifrequency tones (MF) CAS wink-start trunks in which an operator at an Operator Services Console can initiate the Operator Interrupt and Busy Line Verify (OI and BLV) functions.

CAS PBX—Includes CAS private branch exchange (PBX) trunks, digit maps, CAS events, and quarantine buffer software. These features are supported on digital CAS interfaces.

MGCP1.0 is a protocol for the control of VoIP calls by external call-control elements known as media gateway controllers (MGCs) or call agents (CAs). It is described in the informational RFC 2705, published by the Internet Society.

PacketCable is an industry-wide initiative for developing interoperability standards for multimedia services over cable facilities using packet technology. PacketCable developed the NCS and TGCP protocols, which contain extensions and modifications to MGCP while preserving basic MGCP architecture and constructs. NCS is designed for use with analog, single-line user equipment on residential gateways, while TGCP is intended for use in VoIP-to-PSTN trunking gateways in a cable environment. To meet European cable requirements and equipment characteristics, the EuroPacketCable working group has adapted PacketCable standards under the name IP Cablecom.

MGCP Model

MGCP bases its call control and intelligence in centralized call agents, also called media gateway controllers. The call agents issue commands to simple, low-cost endpoints, which are housed in media gateways (MGs), and the call agents also receive event reports from the gateways. MGCP messages between call agents and media gateways are sent with Internet Protocol over User Datagram Protocol (IP/UDP).

The MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles feature provides protocols for RGWs and TGWs, which sit at the border of the packet network to provide an interface between traditional, circuit-based voice services and the packet network. Residential gateways offer a small number of analog line interfaces, while trunking gateways generally manage a large number of digital trunk circuits.

Two basic MGCP constructs are endpoints and connections. An endpoint is a source or sink for call data (RTP/IP) that is flowing through the gateway. A common type of endpoint is found at the physical interface between the POTS (plain old telephone service) or Public Switched Telephone Network (PSTN) service and the gateway; this type of endpoint might be an analog voice port or a digital DS0 group. There are other types of endpoints as well, and some are logical rather than physical. An endpoint is identified by a two-part endpoint name that contains the name of the entity on which it exists (for example, an access server or router) and the local name by which it is known (for example, a port identifier).

A connection is a temporary allocation of resources that enables a call to be completed. One or more connections is necessary to complete a call. Connections have names that identify them with the call to which they belong. Connections can be one-to-one or multipoint. Calls and connections are initiated, modified, and deleted on instructions from call agents.

Call agents manage call flow through standard MGCP commands that are sent to the endpoints under their control. The commands are delivered in standard ASCII text, and may contain session descriptions transmitted in Session Description Protocol (SDP), a text-based protocol. These messages are sent over IP/UDP.

Call agents keep track of endpoint and connection status through the gateway's reporting of standard events that are detected from endpoints and connections. Call agents also direct gateways to apply certain standard signals when a POTS or PSTN connection expects them. For example, when someone picks up a telephone handset, an off-hook event is detected on an endpoint on the residential gateway to which the telephone is connected. The gateway reports the event to a call agent, which orders the gateway to apply the dial-tone signal to the endpoint reporting the off-hook event. The person picking up the handset hears dial tone.

Related events and signals are grouped into standard packages that apply to particular types of endpoints. For instance, the off-hook event is found in the line package, which is associated with analog-line endpoints, which in turn are associated with residential gateways. Standard events, signals, and packages are defined in the NCS, TGCP, and MGCP standards and RFCs listed in the "Preface."

Figure 3 shows a hypothetical MGCP network with both residential and trunking gateways. The residential gateway has telephone sets connected to the gateway's FXS voice ports. MGCP or NCS over IP/UDP is used for call control and reporting to the call agent, while Real-Time Transport Protocol (RTP) is used to transmit the actual voice data.

Figure 3 also shows two trunking gateways with T1 (or E1) connections to the PSTN. Incoming time-division multiplexing (TDM) data is sent through the gateway into the packet network using RTP. MGCP or TGCP over IP/UDP is used for call control and reporting to the call agent. Signaling System 7 (SS7) data travels a different route, however, bypassing the trunking gateway entirely in favor of a specialized signaling gateway, where the signaling data is transformed to ISUP/IP format and relayed to the call agent. Communication between two signaling gateways in the same packet network can be done with Integrated Services Digital Networks User Part over Internet Protocol (ISUP/IP), H.323, or Session Initiation Protocol (SIP).

Figure 3 MGCP Network Model

How to Configure MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

The three tasks listed below configure the MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles feature on a media gateway. The first task names the voice ports or DS1 groups that are serving as MGCP endpoints. This task also associates the ports with an MGCP service type or application and starts the MGCP daemon.

The last two tasks allow you to configure MGCP parameters to meet your requirements. Each MGCP parameter is either a global parameter or a profile-related parameter. When you configure a global MGCP parameter value, it applies to all the MGCP endpoints on the gateway. When you configure a profile-related MGCP parameter value, it applies only to the endpoints associated with the MGCP profile that you are configuring at that moment (an MGCP profile is a user-defined subset of all the MGCP endpoints on the gateway). There is also a predefined MGCP profile named default that you can use to configure profile-related parameters for endpoints that do not belong to a user-defined MGCP profile.

See the following sections for configuration tasks for the MGCP 1.0 including NCS 1.0 and TGCP 1.0 Profiles feature. Each task in the list is identified as either required or optional:

Identifying Endpoints and Configuring the MGCP Application (required)

Configuring Global MGCP Parameters (optional)

Configuring an MGCP Profile and Profile-Related MGCP Parameters (optional)

Identifying Endpoints and Configuring the MGCP Application

This task is required. Voice ports or DS0 groups that are acting as MGCP endpoints must be identified and associated with the MGCP application. The commands to identify MGCP endpoints depend on the type of endpoint that you are configuring.

To identify endpoints and configure the MGCP application, use the commands in the appropriate table, beginning in global configuration mode:

Analog CAS and POTS Lines

Digital CAS Trunks

ISUP Signaling Trunks

FGD-OS Trunks

Digital VoATM with AAL2 PVC

Analog CAS and POTS Lines

To identify endpoints and configure the MGCP application for use with analog CAS and POTS lines, use these commands, beginning in global configuration mode:

SUMMARY STEPS

1. dial-peer voice tag pots

2. application mgcpapp

3. port port-number

4. exit

5. mgcp [gw-port]

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# dial-peer voice tag pots

Enters dial-peer configuration mode and specifies the method of voice encapsulation.

Step 2 

Router(config-dial-peer)# application mgcpapp

Enables the MGCP application on this dial peer.

Step 3 

Router(config-dial-peer)# port port-number

Associates a dial peer with a specific voice port.

Step 4 

Router(config-dial-peer)# exit

Exits the current mode.

Step 5 

Router(config)# mgcp [gw-port]

Initiates the MGCP daemon. The optional argument is the UDP port over which the gateway receives messages from the call agent (the gateway MGCP port number).

Default is 2427.

Digital CAS Trunks

To identify endpoints and configure the MGCP application for use with digital CAS trunks, use these commands, beginning in global configuration mode:

SUMMARY STEPS

1. controller {t1 | e1} cntlr-number

2. mode cas

3. framing {sf | esf} (T1 lines) or framing {crc4 | no-crc4} [australia] (E1 lines)

4. linecode {ami | b8zs} (T1 lines only) or linecode {ami | hdb3} (E1 lines only)

5. ds0-group channel-number timeslots range type type

6. exit

7. voice-port slot/port:ds0-group-no (Cisco 2600 and Cisco 3600 series) or voice-port slot:ds0-group-no (Cisco MC3810)

8. dial-type {dtmf | mf | pulse}

9. exit

10. dial peer voice tag pots

11. application mgcpapp

12. port port-number

13. exit

14. mgcp [gw-port]

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# controller {t1 | e1} cntlr-number

Configures a T1 or E1 controller and enters controller configuration mode for the digital CAS port.

Step 2 

Router(config-controller)# mode cas

(Required for Cisco MC3810 only) Configures the T1 or E1 controller to support CAS mode.

Step 3 

T1 Lines

Router(config-controller)# framing {sf | esf}

E1 Lines

Router(config-controller)# framing {crc4 | no-crc4} [australia]


Selects frame type for T1 or E1 line.

T1 default is sf. E1 default is crc4.

Step 4 

T1 Lines

Router(config-controller)# linecode {ami | b8zs}

E1 Lines

Router(config-controller)# linecode {ami | hdb3}

Specifies the line encoding to use.

T1 default is ami. E1 default is hdb3.

Step 5 

Router(config-controller)# ds0-group channel-number timeslots range type type

Specifies the DS0 time slots that make up a logical voice port on a T1 or E1 controller and specifies the signaling type by which the router connects to the PBX or PSTN. Use command-line interface (CLI) help (enter ? after type) for valid signaling types.

Step 6 

Router(config-controller)# exit

Exits the current mode.

Step 7 

Cisco 2600 and Cisco 3600 Series

Router(config)# voice-port slot/port:ds0-group-no

Cisco MC3810

Router(config)# voice-port slot:ds0-group-no

Enters voice-port configuration mode.

Step 8 

Router(config-voiceport)# dial-type {dtmf | mf | pulse}

(Required for MF trunks) Specifies the type of out-dialing for voice port interfaces.

Default is dtmf.

Step 9 

Router(config-voiceport)# exit

Exits the current mode.

Step 10 

Router(config)# dial peer voice tag pots

Enters dial-peer configuration mode and specifies the method of voice encapsulation.

Step 11 

Router(config-dial-peer)# application mgcpapp

Enables the MGCP application on this dial peer.

Step 12 

Router(config-dial-peer)# port port-number

Associates a dial peer with a specific voice port.

Step 13 

Router(config-dial-peer)# exit

Exits the current mode.

Step 14 

Router(config)# mgcp [gw-port]

Initiates the MGCP daemon. The optional port-number argument is the UDP port over which the gateway receives messages from the call agent (the gateway MGCP port number).

Default is 2427.

ISUP Signaling Trunks

To identify endpoints and configure the MGCP application for use with Integrated Services Digital Network Upper Part (ISUP) signaling trunks, use these commands, beginning in global configuration mode:

SUMMARY STEPS

1. controller {t1 | e1} cntlr-number

2. ds0-group channel-number timeslots range type none service mgcp

3. exit

4. mgcp [gw-port]

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# controller {t1 | e1} cntlr-number

Configures a T1 or E1 controller and enters controller configuration mode for the ISUP trunk port.

Step 2 

Router(config-controller)# ds0-group channel-number timeslots range type none service mgcp

Specifies the DS0 time slots that make up a logical voice port on a T1 or E1 controller and specifies the signaling type by which the router connects to the PBX or PSTN.

Specify the type none and service mgcp options to identify this voice port as an MGCP endpoint.

Step 3 

Router(config-controller)# exit

Exits the current mode.

Step 4 

Router(config)# mgcp [gw-port]

Initiates the MGCP daemon. The optional port number argument allows you to specify the UDP port over which the gateway receives messages from the call agent (the gateway MGCP port number).

Default UDP port number for gateways is 2427.

FGD-OS Trunks

To identify endpoints and configure the MGCP application for use with Feature Group D Operator Services (FGD-OS) signaling over T1 or E1 trunks, use these commands, beginning in global configuration mode:

SUMMARY STEPS

1. controller {t1 | e1} cntlr-number

2. ds0-group channel-number timeslots range type fgd-os service mgcp

3. exit

4. mgcp [gw-port]

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# controller {t1 | e1} cntlr-number

Configures a T1 or E1 controller and enters controller configuration mode for the FGD-OS trunk port.

Step 2 

Router(config-controller)# ds0-group channel-number timeslots range type fgd-os service mgcp

Specifies the DS0 time slots that make up a logical voice port on a T1 or E1 controller and specifies the signaling type by which the router connects to the PBX or PSTN.

Specify the type fgd-os option for FGD-OS signaling, and the service mgcp option to identify this voice port as an MGCP endpoint.

Step 3 

Router(config-controller)# exit

Exits the current mode.

Step 4 

Router(config)# mgcp [gw-port]

Initiates the MGCP daemon. The optional argument is the UDP port over which the gateway receives messages from the call agent (the gateway MGCP port number).

Default is 2427.

Digital VoATM with AAL2 PVC

To identify endpoints and configure the MGCP application for use with digital Voice over Asynchronous Transfer Mode (VoATM) with ATM Adaptation Layer 2 (AAL2) Permanent Virtual Circuit (PVC), use these commands, beginning in global configuration mode:

SUMMARY STEPS

1. controller {t1 | e1} cntlr-number

2. mode atm

3. framing {sf | esf} (T1 lines) or framing {crc4 | no-crc4} [australia] (E1 lines)

4. linecode {ami | b8zs} (T1 lines) or linecode {ami | hdb3} (E1 lines)

5. exit

6. dial peer voice tag pots

7. application mgcpapp

8. port port-number

9. exit

10. mgcp [gw-port]

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# controller {t1 | e1} cntlr-number

Enters dial-peer configuration mode and specifies the method of voice encapsulation.

Step 2 

Router(config-controller)# mode atm

Specifies that the controller supports ATM encapsulation and create ATM interface 0.

When the controller is set to ATM mode, the following takes place:

Controller framing is automatically set to Extended Superframe (ESF).

The line code is automatically set to B8ZS.

Step 3 

T1 Lines

Router(config-controller)# framing {sf | esf}

E1 Lines

Router(config-controller)# framing {crc4 | no-crc4} [australia]


Selects frame type for T1 or E1 line.

T1 default is sf. E1 default is crc4.

Step 4 

T1 Lines

Router(config-controller)# linecode {ami | b8zs}

E1 Lines

Router(config-controller)# linecode {ami | hdb3}

Specifies the line encoding to use.

T1 default is ami. E1 default is hdb3.

Step 5 

Router(config-controller)# exit

Exits the current mode.

Step 6 

Router(config)# dial peer voice tag pots

Enters dial-peer configuration mode and specifies the method of voice encapsulation.

Step 7 

Router(config-dial-peer)# application mgcpapp

Enables the MGCP application on this dial peer.

Step 8 

Router(config-dial-peer)# port port-number

Associates a dial peer with a specific voice port.

Step 9 

Router(config-dial-peer)# exit

Exits the current mode.

Step 10 

Router(config)# mgcp [gw-port]

Initiates the MGCP daemon. The optional argument is the UDP port over which the gateway receives messages from the call agent (the gateway MGCP port number).

Default is 2427.

Configuring Global MGCP Parameters

This optional task configures global MGCP parameters on the gateway so that you can set these values to conform to the requirements of the call agent, trunks, or lines that are being used with this gateway. The global parameter values that you configure are associated with every MGCP endpoint that you have identified on this gateway.

In addition to the global MGCP parameters, there are other MGCP parameters that apply only to MGCP profiles on the gateway. For configuration of profile-related parameters, see the "Configuring an MGCP Profile and Profile-Related MGCP Parameters" section.


Note The only parameter that is common to both profile and global configurations is the call-agent parameter, which is configured with the call-agent command for MGCP profile configuration and with the mgcp call-agent command for the global configuration. These commands are mutually exclusive; whichever command you configure first blocks configuration of the other. For example, if the MGCP profile call-agent command is configured on an endpoint, then you are not allowed to configure the global mgcp call-agent command.


To configure global MGCP parameters, complete these steps as needed, beginning in global configuration mode:

SUMMARY STEPS

1. mgcp call-agent {dns-name | ip-address} [port] [service-type type] [version protocol-version]

2. mgcp behavior {auep | signal} v0.1

3. mgcp sdp simple

4. mgcp sdp xpc-codec

5. mgcp codec type [packetization-period value]

6. no mgcp timer receive-rtcp

7. no mgcp piggyback message

8. mgcp endpoint offset

9. mgcp persistent {hookflash | offhook | onhook}

10. mgcp request timeout {timeout-value | max maxtimeout-value}

11. mgcp dtmf-relay voip codec {all | low-bit-rate} mode {cisco | nse | out-of-band}

12. mgcp max-waiting-delay value

13. mgcp restart-delay value

14. mgcp vad

15. mgcp ip-tos {high-reliability | high-throughput | low-cost | low-delay | rtp precedence value | signaling precedence value}

16. mgcp quality-threshold {hwm-cell-loss value | hwm-jitter-buffer value | hwm-latency value | hwm-packet-loss value | lwm-cell-loss value | lwm-jitter-buffer value | lwm-latency value | lwm-packet-loss value}

17. mgcp playout {adaptive init-value min-value max-value | fax value | fixed init-value}

18. mgcp package-capability [package-type]

19. mgcp default package [package-type]

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# mgcp call-agent {dns-name | ip-address} [port] [service-type type] [version protocol-version]

Configures parameters for communicating with the call agent (media gateway controller).

Note You can define a call agent globally with the mgcp call-agent command, or locally for each MGCP profile with the call-agent command, but not both. Whichever command you configure first blocks configuration of the other.

Step 2 

Router(config)# mgcp behavior {auep | signal} v0.1

(Optional) Forces a gateway to follow the MGCP Version 0.1 protocol for a specified behavior. All other MGCP functionality continues to behave according to the version of MGCP that is specified in the mgcp call-agent command.

auep—Forces the gateway to reply to an Audit Endpoint (AUEP) command according to the MGCP Version 0.1 specification. If this keyword is used, an AUEP command on an out-of-service endpoint results in a return code of 501. Use this keyword with Cisco IOS Release 12.3(2)T1 or a later release.

signal—Forces the gateway to handle signaling tones according to the MGCP Version 0.1 specification. The MGCP 0.1 specification treats call signaling tones as on-off tones, which terminate only after a specific MGCP message has been sent to stop the signal. The specifications for MGCP 1.0 and later versions treat call signaling tones as timeout tones, which terminate when the appropriate timeout timer expires. Use this keyword with Cisco IOS Release 12.3(4)T or a later release.

v0.1—Selects MGCP Version 0.1.

Step 3 

Router(config)# mgcp sdp simple

Specifies that a subset of the SDP fields should be used.

Step 4 

Router(config)# mgcp sdp xpc-codec

Enables codec negotiation in the SDP.

Step 5 

Router(config)# mgcp codec type [packetization-period value]

Selects the default codec type and its optional packetization period value.

Step 6 

Router(config)# no mgcp timer receive-rtcp

Disables the timer used by a gateway to disconnect a VoIP call when the IP connectivity is lost with the remote gateway. The timer is known as the RTP Control Protocol (RTCP) transmission interval timer.

Step 7 

Router(config)# no mgcp piggyback message

Disables piggyback messages.

Step 8 

Router(config)# mgcp endpoint offset

Increments the voice-port or DS0-group portion of the endpoint name for NCS 1.0.

Step 9 

Router(config)# mgcp persistent {hookflash | offhook | onhook}

Enables call-agent notification of the specified type of event.

Step 10 

Router(config)# mgcp request timeout {timeout-value | max maxtimeout-value}

Specifies how long the gateway waits for a call-agent response to a request before retransmitting the request.

Step 11 

Router(config)# mgcp dtmf-relay voip codec {all | low-bit-rate} mode {cisco | nse | out-of-band}

Ensures accurate forwarding of digits with a compressed codec.

Step 12 

Router(config)# mgcp max-waiting-delay value

Specifies the number of milliseconds to wait after a restart before connecting with the call agent. Range is from 0 to 600,000 (600 seconds). Default is 3000.

If used, these values should be staggered among gateways to avoid having large numbers of gateways connecting with the call agent at the same time after a mass restart.

Step 13 

Router(config)# mgcp restart-delay value

Sets the delay value sent in the RestartInProgress (RSIP) graceful teardown, in seconds. Range is from 0 to 600. Default is 0.

Step 14 

Router(config)# mgcp vad

Enables voice activity detection (VAD) as a default for MGCP calls. Default is disabled.

Step 15 

Router(config)# mgcp ip-tos {high-reliability | high-throughput | low-cost | low-delay | rtp precedence value | signaling precedence value}

Enables the IP type of service (ToS) for MGCP-controlled connections.

Step 16 

Router(config)# mgcp quality-threshold {hwm-cell-loss value | hwm-jitter-buffer value | hwm-latency value | hwm-packet-loss value | lwm-cell-loss value | lwm-jitter-buffer value | lwm-latency value | lwm-packet-loss value}

Sets the jitter buffer size threshold, latency threshold, and packet-loss threshold parameters.

Step 17 

Router(config)# mgcp playout {adaptive init-value min-value max-value | fax value | fixed init-value}

Configures the jitter buffer packet size in milliseconds for MGCP calls. The default is adaptive 60 4 200

adaptive init-value min-value max-value—Defines the range for the jitter-buffer packet size. The range for each value is 4 to 250. Default is 60 4 200. Note that init-value must be between min-value and max-value.

fax value—Defines the fax playout buffer size. The range is 0 to 700. The default value is 300. The range and default value might vary with different platforms. See the platform digital signal processor (DSP) specifications before setting this value.

fixed init-value—Defines the fixed size for the jitter-buffer packet size. The range is 4 to 250. There is no default value.

Step 18 

Router(config)# mgcp package-capability [package-type]

Specifies an MGCP package to be supported on this gateway. Configure one package at a time and repeat this command to configure support for more than one package. Available package types vary with the type of gateway.

Step 19 

Router(config)# mgcp default package [package-type]

Defines the package to be used as the default when no package is named with an event. Available package types vary with the type of gateway.

Configuring an MGCP Profile and Profile-Related MGCP Parameters

This optional task creates a named, user-defined MGCP profile that consists of a subset of all the MGCP endpoints on this gateway. More than one MGCP profile can be configured on a gateway. Each MGCP profile is associated with a call agent and one or more endpoints. When multiple MGCP profiles are configured, endpoints on a single media gateway can be controlled by different call agents. When each endpoint comes on line, an RSIP (RestartInProgress) message notifies the appropriate call agent of the endpoint's presence.


Note When partitioning a gateway for multiple call-agent control, the call agents must be coordinated so that there are no overlapping transaction identification numbers.


In addition, this task allows you to configure profile-related MGCP parameters to conform to the requirements of the call agent, trunks, or lines that are being used with the profile's endpoints. These parameters are called profile-related MGCP parameters because they are associated with a particular MGCP profile, or subset of endpoints, and they are configured in MGCP profile configuration mode. Other parameters are considered global MGCP parameters; when they are configured, they apply to all the endpoints on a gateway. Global MGCP parameters are discussed in the "Configuring Global MGCP Parameters" section.

The parameters for an MGCP profile are configured in a special MGCP profile configuration mode that you enter with the mgcp profile command. One or more endpoints are associated with the profile by using the voice-port command in MGCP profile configuration mode.


Note The only parameter that can be configured in both profile configuration mode and in global configuration mode is call agent, which is configured with the call-agent command for MGCP profiles, and with the mgcp call-agent command for global configurations. These commands are mutually exclusive; whichever command you configure first blocks configuration of the other. For example, if the MGCP profile call-agent command is configured on an endpoint, then you are not allowed to configure the global mgcp call-agent command.


You do not have to define MGCP profiles to configure profile-related parameters. For endpoints that are not associated with a user-defined MGCP profile, the values for profile-related parameters are provided by a predefined profile with the name default. The default profile is configured in the same way that a user-defined MGCP profile is configured, except that the keyword default is used in place of a profile name in the mgcp profile command. The default profile has no association with voice ports or a call agent (the call agent for these endpoints is defined by the global mgcp call-agent command).

In the excerpt below from a show running-config command output, two MGCP profiles are defined: MAX1 and MAX2. Each profile is associated with a different call agent and a different voice port. The MAX1 profile is configured with a value of 3 for the max1 retries parameter and 5 for max2 retries. The MAX2 profile uses the values in the default profile for those parameters. In the MAX2 profile, the MT package is configured as a persistent package. The max1 retries parameter for the default profile is configured with a value of 2. The max2 retries parameter is not configured, so the value used is the default value, which is 7. The MAX2 profile has a value of 2 for the max1 retries parameter and 7 for max2 retries.

!
mgcp profile MAX1
 call agent ca1.example.com 4022 service-type mgcp version 1.0
 max1 retries 3
 max2 retries 5
 voice-port 2/1:1
!
mgcp profile MAX2
 call-agent ca2.example.com 50031 service-type mgcp version 0.1
 package persistent mt-package
 voice-port 2/0:1
!
mgcp profile default
 max1 retries 2

To configure parameters for a user-defined MGCP profile or for the default profile, use the following commands as appropriate, beginning in global configuration mode:

SUMMARY STEPS

1. mgcp profile {profile-name | default}

2. description {text}

3. call-agent {dns-name | ip-address} [port] [service-type type] [version protocol-version]

4. voice-port port-number

5. default {command}

6. package persistent package-name

7. timeout tsmax tsmax-value

8. timeout tdmax tdmax-value

9. timeout tdinit tdinit-value

10. timeout tcrit tcrit-value

11. timeout tpar tpar-value

12. timeout thist thist-value

13. timeout tone mwi mwitone-value

14. timeout tone ringback ringbacktone-value

15. timeout tone ringback connection connectiontone-value

16. timeout tone network congestion congestiontone-value

17. timeout tone busy busytone-value

18. timeout tone dial dialtone-value

19. timeout tone dial stutter stuttertone-value

20. timeout tone ringing ringingtone-value

21. timeout tone ringing distinctive distinctivetone-value

22. timeout tone reorder reordertone-value

23. timeout tone cot1 continuity1tone-value

24. timeout tone cot2 continuity2tone-value

25. max1 lookup

26. max1 retries value

27. max2 lookup

28. max2 retries value

29. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# mgcp profile {profile-name | default}

Initiates MGCP profile mode, in which you create and configure a named MGCP profile associated with one or more endpoints, or configure the default profile. Effective with Cisco IOS Release 12.4(24)T3, the maximum number of MGCP profiles that can be configured is increased from 13 (12 plus 1 default) to 29 (28 plus 1 default).

Step 2 

Router(config-mgcp-profile)# description {text}

Provides a description for the profile.

Step 3 

Router(config-mgcp-profile)# call-agent {dns-name | ip-address} [port] [service-type type] [version protocol-version]

Defines the call agent's DNS name or IP address, UDP port number, service type, and protocol version. (Not used when configuring the default profile.)

Note You can define a call agent globally with the mgcp call-agent command, or locally for each MGCP profile with the call-agent command, but not both. Whichever command you configure first blocks configuration of the other.

Step 4 

Router(config-mgcp-profile)# voice-port port-number

Provides the voice port number or DS0 group number for the endpoint to be associated with this MGCP profile. Repeat this command to add more than one endpoint to the profile. (Not used when configuring the default profile.)

Step 5 

Router(config-mgcp-profile)# default {command}

Restores the parameter represented by command to its default value.

Step 6 

Router(config-mgcp-profile)# package persistent package-name

Configures the package type used when reporting persistent events for an MF CAS endpoint type. Valid types are ms-package and mt-package. Default is ms-package.

Step 7 

Router(config-mgcp-profile)# timeout tsmax tsmax-value

Configures the maximum timeout value after which MGCP messages are removed from the retransmission queue, in seconds. Range is from 1 to 1000. Default is 20.

Step 8 

Router(config-mgcp-profile)# timeout tdmax tdmax-value

Configures the maximum timeout value for the disconnected procedure (Tdmax), in seconds. Range is from 300 to 600. Default is 600.

Step 9 

Router(config-mgcp-profile)# timeout tdinit tdinit-value

Configures the initial waiting delay value (Tdinit) used as the timer for the disconnect procedure, in seconds. Range is from 1 to 30. Default is 15.

Step 10 

Router(config-mgcp-profile)# timeout tcrit tcrit-value

Configures the critical timeout value (Tcritical) for the interdigit timer used in digit map matching, in seconds. Range is from 1 to 600. Default is 4.

Step 11 

Router(config-mgcp-profile)# timeout tpar tpar-value

Configures the partial timeout value (Tpartial) for the interdigit timer used in digit map matching, in seconds. Range is from 1 to 60. Default is 16.

Step 12 

Router(config-mgcp-profile)# timeout thist thist-value

Configures the packet storage timeout value, in seconds. Range is from 1 to 1100. Default is 30.

Step 13 

Router(config-mgcp-profile)# timeout tone mwi mwitone-value

Configures the message waiting indicator timeout value, in seconds. Range is from 1 to 600. Default is 16.

Step 14 

Router(config-mgcp-profile)# timeout tone ringback ringbacktone-value

Configures the ringback tone timeout value, in seconds. Range is from 1 to 600. Default is 180.

Step 15 

Router(config-mgcp-profile)# timeout tone ringback connection connectiontone-value

Configures the timeout value for ringback tone on connection, in seconds. Range is from 1 to 600. Default is 180.

Step 16 

Router(config-mgcp-profile)# timeout tone network congestion congestiontone-value

Configures the network congestion tone timeout value, in seconds. Range is from 1 to 600. Default is 180.

Step 17 

Router(config-mgcp-profile)# timeout tone busy busytone-value

Configures the busy tone timeout value, in seconds. Range is from 1 to 600. Default is 3.

Step 18 

Router(config-mgcp-profile)# timeout tone dial dialtone-value

Configures the dial tone timeout value, in seconds. Range is from 1 to 600. Default is 16.

Step 19 

Router(config-mgcp-profile)# timeout tone dial stutter stuttertone-value

Configures the stutter dial tone timeout value, in seconds. Range is from 1 to 600. Default is 16.

Step 20 

Router(config-mgcp-profile)# timeout tone ringing ringingtone-value

Configures the ringing tone timeout value, in seconds. Range is from 1 to 600. Default is 180.

Step 21 

Router(config-mgcp-profile)# timeout tone ringing distinctive distinctivetone-value

Configures the distinctive ringing tone timeout value, in seconds. Range is from 1 to 600. Default is 180.

Step 22 

Router(config-mgcp-profile)# timeout tone reorder reordertone-value

Configures the reorder tone timeout value, in seconds. Range is from 1 to 600. Default is 30.

Step 23 

Router(config-mgcp-profile)# timeout tone cot1 continuity1tone-value

Configures the continuity1 tone timeout value, in seconds. Range is from 1 to 600. Default is 3.

Step 24 

Router(config-mgcp-profile)# timeout tone cot2 continuity2tone-value

Configures the continuity2 tone timeout value, in seconds. Range is from 1 to 600. Default is 3.

Step 25 

Router(config-mgcp-profile)# max1 lookup

Enables the DNS lookup procedure after the suspicion threshold is reached. Default is enabled.

Step 26 

Router(config-mgcp-profile)# max1 retries value

Sets the suspicion threshold number of retries. Range is from 3 to 30. Default is 5.

Step 27 

Router(config-mgcp-profile)# max2 lookup

Enables the DNS lookup procedure after the disconnect threshold is reached. Default is enabled.

Step 28 

Router(config-mgcp-profile)# max2 retries value

Sets the disconnect threshold number of retries. Range is from 3 to 30. Default is 7.

Step 29 

Router(config-mgcp-profile)# exit

Exits the current mode.

Verifying the Configuration

To verify configuration, use the following commands.

SUMMARY STEPS

1. show running-configuration

2. show mgcp [connection | endpoint | profile [profile-name] | statistics]

DETAILED STEPS

 
Command
Purpose

Step 1 

Router# show running-configuration

Displays the current configuration settings.

Step 2 

Router# show mgcp [connection | endpoint | profile [profile-name] | statistics]

Displays the current MGCP settings.

Troubleshooting Tips

The following suggestions help with troubleshooting:

Use the show running-config command to verify that the following are properly configured:

For CAS and POTS endpoints, POTS dial peers are configured with the mgcpapp application.

The correct packages are enabled in the mgcp package-capability command.

The mgcp call-agent or call-agent command defines the call agent and service type correctly.

Reset the MGCP statistical counters with the clear mgcp statistics command.

If RTP traffic is not getting through, make sure that IP routing is enabled. Use the show rtp statistics command, then use the debug ip udp command and track down the MGCP RTP packets.

Router# show rtp statistics

RTP Statistics info:
No. CallId Xmit-pkts Xmit-bytes Rcvd-pkts  Rcvd-bytes Lost pkts  Jitter Latenc
1   17492  0x8A      0x5640     0x8A       0x5640     0x0        0x0      0x0

Router# show rtp statistics

RTP Statistics info:
No. CallId Xmit-pkts Xmit-bytes Rcvd-pkts  Rcvd-bytes Lost pkts  Jitter Latenc
1   17492  0xDA      0x8840     0xDB       0x88E0     0x0        0x160    0x0

If an RSIP message is not received by the call agent, make sure that the mgcp call-agent command or the MGCP profile call-agent command is configured with the correct call agent name or IP address and UDP port. Use the show mgcp command or the show mgcp profile command to display this information:

Router# show mgcp

MGCP Admin State ACTIVE, Oper State ACTIVE - Cause Code NONE
MGCP call-agent: 172.29.248.51  Initial protocol service is MGCP, v. 1.0
...
MGCP gateway port: 2727, MGCP maximum waiting delay 3000
...

Router# show mgcp profile

MGCP Profile nycprofile
Description: NY branch office configuration
Call-agent: 10.14.2.200 Initial protocol service is MGCP, v. 1.0

To verify connections and endpoints, use the show mgcp command:

Router# show mgcp connection

Endpoint  Call_ID(C) Conn_ID(I) (P)ort (M)ode (S)tate (C)odec (E)vent[SIFL] 
(R)esult[EA]
1. S0/DS1-1/5      C=F123AB,5,6  I=0x3  P=16506,16602  M=3  S=4  C=1 E=2,0,0,2  R=0,0
2. S0/DS1-1/6      C=F123AB,7,8  I=0x4  P=16602,16506  M=3  S=4  C=1 E=0,0,0,0  R=0,0

Router# show mgcp endpoint

T1/0 ds0-group 0 timeslots 1-24
T1/1 ds0-group 0 timeslots 1-24
T1/2 ds0-group 0 timeslots 1-24
T1/3 ds0-group 0 timeslots 1-24

If an MGCP message is rejected, it may be because the remote media gateway does not support SDP mandatory parameters (the o=, s=, and t= lines). If this is the case, configure the mgcp sdp simple command to send SDP messages without those parameters.

If you notice problems with voice quality, make sure that the cptone (voice-port configuration) command is set for the correct country code. Capturing RTP packets from the sniffer may help to debug the problem, such as whether the payload type or timestamps are set correctly, and so forth.

To check operation of interfaces, use the show interface command.

To view information about activity on the T1 or E1 line, use the show controllers command. Alarms, line conditions, and other errors are displayed. The data is updated every 10 seconds; and every 15 minutes, the cumulative data is stored and retained for 24 hours.

When necessary, you can enable debug traces for errors, events, media, packets, and parser. The command debug mgcp packets can be used to verify that your packets are arriving at the gateway and to monitor message flow in general. Note that there is always a performance penalty when using debug commands. The sample output below shows the use of the optional input-hex keyword to enable display of hexadecimal values.

Router# debug mgcp packets input-hex

Media Gateway Control Protocol input packets in hex value debugging is on
MGCP Packet received -
DLCX 49993 * MGCP 0.1
MGCP Packet received in hex -
44 4C 43 58 20 34 39 39 39 33 20 2A 20 4D 47 43 50 20 30 2E 31 A
send_mgcp_msg, MGCP Packet sent --->
250 49993

Configuration Examples for Configuring MGCP 1.0 Including NCS 1.0 and TGCP 1.0 Profiles

This section provides the following configuration examples:

Cisco uBR925 Using Radio Frequency Interface Example

Cisco uBR925 Using Ethernet0 Interface Example

Cisco CVA122 Using Radio Frequency Interface Example

Cisco 2600 Series as a Residential Gateway Example

Cisco 3660 Platform as a Trunking Gateway Example

Cisco MC3810 as a Residential Gateway Example

Cisco MC3810 as a VoAAL2 Gateway using AAL2 PVCs Example

Cisco uBR925 Using Radio Frequency Interface Example

This example shows how to set up a Cisco uBR925 as an MGCP residential gateway. The call agent is specified to the cable router (Cisco uBR925, Cisco CVA122, or Cisco CVA122E) by a Dynamic Host Configuration Protocol (DHCP) offer on a cable radio frequency (RF) network. On completion of the DHCP offer, the call agent is set in the MGCP profile on the cable modem. This setting is displayed with the show mgcp profile command. The router does not show the call agent in the CLI.


version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname hydepark
!
logging rate-limit console 10 except errors
!
clock timezone - 0 6
ip subnet-zero
no ip routing
ip domain-name example.com
ip name-server 10.0.0.229
!
ip ssh time-out 120
ip ssh authentication-retries 3
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 192.168.0.11 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 no ip route-cache
 no ip mroute-cache
 cable-modem boot admin 2
 cable-modem boot oper 5
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip classless
no ip http server
no ip http cable-monitor
!
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
mgcp
! Use this CLI with NCS 1.0
mgcp endpoint offset
!
mgcp profile default
!
dial-peer voice 100 pots
 application MGCPAPP
 port 0
!
dial-peer voice 101 pots
 application MGCPAPP
 port 1
!
line con 0
line vty 0 4
 login
!
end

Cisco uBR925 Using Ethernet0 Interface Example

This example shows how to set up a Cisco uBR925 as a residential gateway:

version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname monticello
!
logging rate-limit console 10 except errors
!
clock timezone - 0 6
ip subnet-zero
ip domain-name example.com
ip name-server 10.0.0.229
!
ip ssh time-out 120
ip ssh authentication-retries 3
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 192.168.0.11 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 no ip route-cache
 no ip mroute-cache
 shutdown
 cable-modem boot admin 2
 cable-modem boot oper 5
 no cable-modem compliant bridge
 cable-modem voip clock-internal
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip classless
no ip http server
no ip http cable-monitor
!
ip default-gateway 172.16.1.1
!
! We are using the cable modem without its RF interface. So
! route IP traffic out the Ethernet0 interface.
!
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
mgcp
!
! The ip address of call agent below can be a FQDN as well.
mgcp call-agent 10.0.0.224 service-type ncs version 1.0
! Use this CLI with NCS 1.0
mgcp endpoint offset
!
mgcp profile default
!
dial-peer voice 100 pots
 application MGCPAPP
 port 0
!
dial-peer voice 101 pots
 application MGCPAPP
 port 1
!
line con 0
line vty 0 4
 login
!
end

Cisco CVA122 Using Radio Frequency Interface Example

The call agent is specified to the cable router (Cisco uBR925, Cisco CVA122, or Cisco CVA122E) by a DHCP offer on a cable RF network. On completion of the DHCP offer, the call agent is set in the MGCP profile on the cable modem. This setting is displayed with the show mgcp profile command. The router does not show the call agent in the CLI.



version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
hostname mtvernon
!
no logging buffered
logging rate-limit console 10 except errors
!
clock timezone - -5
ip subnet-zero
no ip routing
ip domain-name example.com
ip name-server 10.0.0.229
!
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 10.20.0.59 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 shutdown
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 no ip route-cache
 no ip mroute-cache
 cable-modem boot admin 2
 cable-modem boot oper 5
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface usb0
 ip address 10.20.0.59 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 arp timeout 0
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 deny   10.0.0.254
access-list 1 permit any
snmp-server packetsize 4096
snmp-server manager
call rsvp-sync
!
voice-port 0
 input gain -2
 output attenuation 0
 timeouts interdigit 2
!
voice-port 1
 input gain -2
 output attenuation 0
 timeouts interdigit 2
!
mgcp
!
mgcp profile default
!
mgcp profile test
 call-agent test service-type ncs version 1.0
!
dial-peer voice 100 pots
 application MGCPAPP
 port 0
!
dial-peer voice 101 pots
 application MGCPAPP
 port 1
!
line con 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 login
!
end

Cisco 2600 Series as a Residential Gateway Example

This example shows a Cisco 2620 router being configured as an analog residential gateway:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname betty-2620
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1 pots
application mgcpapp
destination-pattern 100
port 1/0/0
!
dial-peer voice 2 pots
application mgcpapp
destination-pattern 101
port 1/0/1
!
process-max-time 200
!
mgcp 4000
mgcp call-agent 10.14.2.200 4000 service-type mgcp version 1.0
mgcp sdp simple
no mgcp timer receive-rtcp
mgcp sdp xpc-codec
no mgcp piggyback message
mgcp endpoint offset
no mgcp persistent hook on
no mgcp persistent hook flash
mgcp request timeout 1000
mgcp dtmf-relay codec all mode cisco
mgcp max-waiting-delay 600000
mgcp restart-delay 500
mgcp codec g711ulaw packetization-period 10
mgcp ip-tos rtp precedence 7
mgcp quality-threshold lwm-jitter-buffer 59
mgcp quality-threshold lwm-latency 199
mgcp quality-threshold lwm-packet-loss 2
mgcp playout adaptive 100 50 150
mgcp package-capability dtmf-package
mgcp package-capability mf-package
mgcp package-capability rtp-package
mgcp package-capability as-package
isdn voice-call-failure 0
srcp 2428
cns event-service server
!
mgcp profile cisco
 call-agent 10.14.2.200 4000 service-type mgcp version 1.0
 voice-port 0:1
 package persistent mt-package
 timeout tsmax 100
 timeout tdinit 30
 timeout tcrit 600
 timeout tpar 600
 timeout thist 60
 timeout tone mwi 600
 timeout tone ringback 600
 timeout tone ringback connection 600
 timeout tone network congestion 600
 timeout tone busy 600
 timeout tone dial 600
 timeout tone dial stutter 600
 timeout tone ringing 600
 timeout tone ringing distinctive 600
 timeout tone reorder 600
 timeout tone cot1 600
 timeout tone cot2 600
 max1 retries 10
 no max2 lookup
 max2 retries 10
!
interface Ethernet0/0
 ip address 10.14.12.9 255.0.0.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.14.0.1
no cdp run
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
 password test
 login
!
end

Cisco 3660 Platform as a Trunking Gateway Example

This example shows a Cisco 3660 that is being configured for CAS trunks. The association of endpoints with the MGCP application is made in the dial-peer configuration.

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname charley-3660
!
controller t1 1/0
 linecode b8zs
 clock source line secondary 1
 ds0-group 0 timeslots 1-24 type e&m-winkstart
!
controller t1 1/1
 linecode b8zs
 clock source line secondary 1
 ds0-group 0 timeslots 1-24 type e&m-winkstart
!
ip subnet-zero
!
voice-port 1/0:0
 dial-type mf
!
voice-port 1/1:0
 dial-type mf
!
dial-peer voice 1 pots
 application mgcpapp
 destination-pattern 100
 port 1/0:0
!
dial-peer voice 2 pots
 application mgcpapp
 destination-pattern 101
 port 1/1:0
!
mgcp 4000
mgcp call-agent 10.14.2.200 4000 service-type mgcp version 1.0
mgcp sdp simple
no mgcp timer receive-rtcp
mgcp sdp xpc-codec
no mgcp piggyback message
mgcp endpoint offset
mgcp persistent hook on
mgcp persistent hook flash
mgcp request timeout 1000
mgcp dtmf-relay codec all mode cisco
mgcp max-waiting-delay 600000
mgcp restart-delay 500
mgcp codec g711ulaw packetization-period 10
mgcp ip-tos rtp precedence 7
mgcp quality-threshold lwm-jitter-buffer 59
mgcp quality-threshold lwm-latency 199
mgcp quality-threshold lwm-packet-loss 2
mgcp playout adaptive 100 50 150
mgcp package-capability dtmf-package
mgcp package-capability mf-package
mgcp package-capability rtp-package
mgcp package-capability as-package
isdn voice-call-failure 0
srcp 2428
cns event-service server
!
mgcp profile cisco
 call-agent 10.14.2.200 4000 service-type mgcp version 1.0
 voice-port 1/0:0
 package persistent mt-package
 timeout tsmax 100
 timeout tdinit 30
 timeout tcrit 600
 timeout tpar 600
 timeout thist 60
 timeout tone mwi 600
 timeout tone ringback 600
 timeout tone ringback connection 600
 timeout tone network congestion 600
 timeout tone busy 600
 timeout tone dial 600
 timeout tone dial stutter 600
 timeout tone ringing 600
 timeout tone ringing distinctive 600
 timeout tone reorder 600
 timeout tone cot1 600
 timeout tone cot2 600
 max1 retries 10
 no max2 lookup
 max2 retries 10
!
interface FastEthernet0/0
 ip address 10.14.12.12 255.0.0.0
 speed auto
 duplex auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.14.0.1
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 password trial
 login
!
end

Cisco MC3810 as a Residential Gateway Example

The following example shows a Cisco MC3810 being configured as a residential gateway:

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log uptime
!
hostname harry
!
logging buffered
!
ip subnet-zero
ip host buffalo 192.168.254.254
!
mgcp
mgcp call-agent 10.14.90.1
!
voice-card 0
 codec complexity high
!
controller T1 0
 framing esf
 linecode b8zs
!
interface Ethernet0
 ip address 10.14.92.3 255.255.0.0
!
interface Serial0
 shutdown
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface FR-ATM20
 no ip address
 shutdown
!
ip default-gateway 10.14.0.1
ip route 192.168.254.0 255.255.255.0 10.14.0.1
!
voice-port 1/1
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/1
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line 2 3
line vty 0 4
login
!
end

Cisco MC3810 as a VoAAL2 Gateway using AAL2 PVCs Example

This example shows a Cisco MC3810 being configured as a VoAAL2 gateway using AAL2 PVCs:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname stella-mc3810
!
network-clock base-rate 56k
ip subnet-zero
no ip domain-lookup
ip host camel 192.168.254.254
ip host buffalo 192.168.254.253
!
mgcp
mgcp call-agent 10.14.117.4 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode nse
mgcp dtmf-relay voaal2 codec all
mgcp modem passthrough nse
mgcp package-capability rtp-package
mgcp tse payload 100
mgcp timer receive-rtcp 100
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
voice-card 0
!
controller T1 0
    mode atm
    framing esf
    linecode b8zs
!
interface Ethernet0
    ip address 10.14.121.1 255.255.0.0
!
interface Serial0
    no ip address
    no ip mroute-cache
    shutdown
    no fair-queue
!
interface Serial1
    no ip address
    shutdown
!
interface ATM0
    no ip address
    ip mroute-cache
    no atm ilmi-keepalive 
!
interface ATM0.2 point-to-point
   pvc 2/200
      vbr-rt 760 760 100
      encapsulation aal2
      vcci 2
!
interface FR-ATM20
     no ip address
     shutdown
!
router igrp 1
    redistribute connected
    network 1.0.0.0
!
ip default-gateway 10.14.0.1
no ip http server
ip classless
ip route 192.168.254.0 255.255.255.0 10.14.0.1
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
voice-port 1/1
!
voice-port 1/2
     shutdown
!
voice-port 1/6
     shutdown
!
dial-peer voice 1 pots
    application mgcpapp
    port 1/1
!
line con 0
    transport input none
line aux 0
   line 2 3
 line vty 0 4
    password lab
    login
!
end


TipSee the "Additional References for MGCP and SGCP" section in the Preface for related documents, standards, and MIBs.

See "Glossary" for definitions of terms in this guide.


CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.