This documentation has been moved
Configuring MGCP CAS MD Package
Downloads: This chapterpdf (PDF - 145.0KB) The complete bookPDF (PDF - 0.97MB) | Feedback

Configuring MGCP CAS MD Package

Table Of Contents

Configuring MGCP CAS MD Package

Contents

Prerequisites for MGCP CAS MD Package

Restrictions for MGCP CAS MD Package

Information About MGCP CAS MD Package

MD Package

How to Configure the MGCP CAS MD Package

Configuring the Incoming Called Number in the MGCP Dial Peer

Modifying ANI and DNIS Order when Using CAS MD Package

Configuration Examples for MGCP CAS MD Package

CAS MD Package Configuration: Example

Cisco AS5850 Configuration: Example


Configuring MGCP CAS MD Package


This chapter provides information on configuring the MGCP channel-associated signaling (CAS) MD Package feature. This feature introduces support for Feature Group D (FGD) Exchange Access North American (EANA) protocol signaling. The CAS MD package adds support for the reporting of automatic number identification (ANI) and dialed number identification service (DNIS) digits to enable the MGCP call agent to better handle customer billing.


Note For more information about this and related Cisco IOS voice features, see the following:

"Overview of MGCP and Related Protocols" on page 3

Entire Cisco IOS Voice Configuration Library—including library preface and glossary, other feature documents, and troubleshooting documentation—at http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/voice_c/vcl.htm.


Feature History for MGCP CAS MD Package

Release
Modification

12.4(4)T

This feature was introduced on the Cisco AS5850.

12.4(15)T

Support was added for the Cisco AS5350, Cisco AS5350XM, Cisco AS5400XM, and Cisco AS5400HPX platforms.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for MGCP CAS MD Package

Restrictions for MGCP CAS MD Package

Information About MGCP CAS MD Package

How to Configure the MGCP CAS MD Package

Configuration Examples for MGCP CAS MD Package

Prerequisites for MGCP CAS MD Package

Prerequisites are described in "Prerequisites for Configuring MGCP and Related Protocols" on page 3.

Restrictions for MGCP CAS MD Package

FGD Exchange Access International (EAIN) signaling is not supported.

Information About MGCP CAS MD Package

To configure the MGCP CAS MD Package feature, you should understand the following concept:

MD Package

MD Package

The MD package supports the FGD EANA protocol for T1 CAS interfaces as defined in RFC 3064. It includes support for ANI and DNIS reporting that enables the MGCP call agent to improve its handling of customer billing. The MD package is enabled automatically when a T1 interface is configured using the ds0-group command with the fgd-eana keyword. The order in which the voice gateway sends the ANI and DNIS digits can be controlled by using the notify command in the MGCP profile.

How to Configure the MGCP CAS MD Package

This section contains the following tasks for configuring the MGCP CAS MD package:

Configuring the Incoming Called Number in the MGCP Dial Peer (required)

Modifying ANI and DNIS Order when Using CAS MD Package (optional)


Note You do not have to enable the CAS MD package with the mgcp package-capability command. The CAS MD package is enabled automatically when a T1 controller is configured for FGD EANA signaling using the ds0-group command.


Configuring the Incoming Called Number in the MGCP Dial Peer

Perform this procedure to specify the dial string to use for matching incoming calls to the MGCP dial peer.

SUMMARY STEPS

1. enable

2. configure terminal

3. dial-peer voice tag pots

4. service mgcpapp

5. incoming called-number string

6. port port

7. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

dial-peer voice tag pots

Example:

Router(config)# dial-peer voice 1003 pots

Defines a dial peer as a POTS device and enters dial-peer configuration mode.

Step 4 

service mgcpapp

Example:

Router(config-dial-peer)# service mgcpapp

Enables MGCP on the dial peer.

Note Do not use this command in dial peers that support PRI backhaul or BRI backhaul.

Step 5 

incoming called number string

Example:

Router(config-dial-peer)# incoming called number .

Specifies the digit string that is used to match incoming calls to the dial peer.

Step 6 

port port

Example:

Router(config-dial-peer)# port 0/0:3:0

Binds the MGCP application to the specified voice port.

Step 7 

end

Example:

Router(config-dial-peer)# end

Exits to privileged EXEC mode.

Modifying ANI and DNIS Order when Using CAS MD Package

Perform this procedure to specify the order in which ANI and DNIS digits are sent in notify messages to the call agent when using the CAS MD package.

SUMMARY STEPS

1. enable

2. configure terminal

3. mgcp profile {profile-name | default}

4. notify {ani-dnis | dnis-ani}

5. end

6. show mgcp profile [profile-name]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mgcp profile {profile-name | default}

Example:

Router(config)# mgcp profile default

Defines an MGCP profile to be associated with one or more MGCP endpoints.

Step 4 

notify {ani-dnis | dnis-ani}

Example:

Router(config-mgcp-profile)# notify dnis-ani

Specifies the order in which ANI and DNIS digits are reported to the MGCP call agent.

ani-dnis—ANI digits are sent in the first notify message. This is the default order.

dnis-ani—DNIS digits are sent in the first notify message.

Step 5 

end

Example:

Router(config-mgcp-profile)# end

Exits to privileged EXEC mode.

Step 6 

show mgcp profile [profile-name]

Example:

Router# show mgcp profile default

Displays configuration information for MGCP profiles including the setting of the notify command.

Configuration Examples for MGCP CAS MD Package

This section contains the following configuration examples:

CAS MD Package Configuration: Example

Cisco AS5850 Configuration: Example

CAS MD Package Configuration: Example

The following example shows the significant portions of a configuration for the CAS MD package.

...
controller T1 0/0:3
 framing esf
 ds0-group 0 timeslots 1 type fgd-eana mf ani-dnis
!
controller T1 0/0:4
 framing esf
 ds0-group 0 timeslots 1 type fgd-eana mf ani-dnis
...
mgcp profile default
 notify dnis-ani
!
!
dial-peer voice 1003 pots
 service mgcpapp
 incoming called-number .
 port 0/0:3:0
!
dial-peer voice 1004 pots
 service mgcpapp
 incoming called-number .
 port 0/0:4:0
...

Cisco AS5850 Configuration: Example

The following example shows a complete running configuration for a Cisco AS5850 universal gateway that is using the CAS MD package.

Current configuration : 2636 bytes
!
version 12.4 
no service pad 
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption 
service internal
!
hostname Sample
!
boot-start-marker
boot system flash:c5850-p9-mz
boot-end-marker
!
!
redundancy
 mode classic-split
logging buffered 20000000 debugging
no logging console
enable password temp
!
no aaa new-model
!
resource policy
!
!
!
resource-pool disable
dial-tdm-clock priority 1 external t1 120ohm
spe default-firmware spe-firmware-1
!
!
!
!
ip subnet-zero
ip cef distributed
!
!
!
isdn switch-type primary-5ess
!
!
!
!
!
!
controller T3 0/0
 framing c-bit
 cablelength 224
 t1 1-7 controller
!
controller T1 0/0:1
 shutdown
 framing sf
 ds0-group 0 timeslots 1 type fgd-eana mf ani-dnis
!
controller T1 0/0:2
 shutdown
 framing sf
 ds0-group 0 timeslots 1 type fgd-eana mf ani-dnis
!
controller T1 0/0:3
 framing esf
 ds0-group 0 timeslots 1 type fgd-eana mf ani-dnis
!
controller T1 0/0:4
 framing esf
 ds0-group 0 timeslots 1 type fgd-eana mf ani-dnis
!
controller T1 0/0:5
 framing esf
!
controller T1 0/0:6
 shutdown
 framing esf
!
controller T1 0/0:7
 framing esf
!
!
!
interface Loopback0
 no ip address
 no ip route-cache cef
 no ip route-cache distributed
 no ip route-cache
!
interface FastEthernet6/0
 ip address 172.16.0.46 255.255.255.0
 no ip proxy-arp
 logging event link-status
 speed 100
 full-duplex
 no keepalive
!
interface GigabitEthernet6/0
 no ip address
 logging event link-status
 shutdown
 negotiation auto
!
interface GigabitEthernet6/1
 no ip address
 logging event link-status
 shutdown
 negotiation auto
!
interface Group-Async0
 no ip address
 encapsulation ppp
 group-range 0/00 3/323
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.200
no ip http server
!
!
!
!
!
!
voice-port 0/0:1:0
!
voice-port 0/0:2:0
!
voice-port 0/0:3:0
!
voice-port 0/0:4:0
!
mgcp
mgcp call-agent 172.16.0.200 18384 service-type mgcp version 0.1
mgcp package-capability dtmf-package
mgcp package-capability mf-package
mgcp package-capability rtp-package
no mgcp piggyback message
mgcp persistent onhook
mgcp fax t38 inhibit
!
mgcp profile default
!
!
dial-peer voice 1003 pots
 service mgcpapp
 incoming called-number .
 port 0/0:3:0
!
dial-peer voice 1004 pots
 service mgcpapp
 incoming called-number .
 port 0/0:4:0
!
!
!
line con 0
 exec-timeout 0 0
 transport output all
line aux 0
 exec-timeout 0 0
 transport output all
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
 transport input all
 transport output all
line 0/00 0/215
 modem InOut
 transport input all
line 3/00 3/323
 modem InOut
 transport input all
!
end

CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.