This documentation has been moved
Basic MGCP Configuration
Downloads: This chapterpdf (PDF - 202.0KB) The complete bookPDF (PDF - 0.97MB) | Feedback

Basic MGCP Configuration

Table Of Contents

Basic MGCP Configuration

Finding Feature Information

Contents

How to Configure MGCP and Related Protocols

Configuring a TGW for MGCP

Configuring a TGW for SGCP

Configuring an RGW

Configuring a SDP Aware NSE Mode

Restrictions

Verifying NSE Mode Configuration

Verifying the TGW or RGW Configuration

Blocking New Calls

Configuration Examples for MGCP and Related Protocols

Configuring a Cisco AS5300 as a TGW with MGCP Example

Configuring a Cisco AS5300 as a TGW with SGCP Example

Configuring a Cisco 3660 as a TGW with MGCP Example

Configuring a Cisco uBR924 as an RGW Example

Configuring a Cisco 2620 as an RGW Example

Additional References

Related Documents

Technical Assistance

Feature Information for Basic MGCP Configuration


Basic MGCP Configuration


First Published: September 20, 2004
Last Updated: November 15, 2010

This chapter provides basic configuration information for Media Gateway Control Protocol (MGCP) and related protocols.


Note For more information about related Cisco IOS voice features, see the following:

"Overview of MGCP and Related Protocols" on page 3

Entire Cisco IOS Voice Configuration Library—including library preface and glossary, other feature documents, and troubleshooting documentation—at http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_voice_configuration_library_glossary/vcl.htm


Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for Basic MGCP Configuration" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

How to Configure MGCP and Related Protocols

Configuration Examples for MGCP and Related Protocols

Feature Information for Basic MGCP Configuration

How to Configure MGCP and Related Protocols

To configure MGCP, perform the tasks in the following sections. Each task is identified as either optional or required.

Do at least one of the following tasks, depending on your network configuration (required):

Configuring a TGW for MGCP

Configuring a TGW for SGCP

Configuring an RGW

Configuring a SDP Aware NSE Mode (optional)

Verifying NSE Mode Configuration (optional)

Blocking New Calls (optional)


Note RGWs are configured only with MGCP.


Configuring a TGW for MGCP

To configure a trunking gateway (TGW) for MGCP, perform this task:

SUMMARY STEPS

1. mgcp

2. mgcp call-agent [ipaddr|hostname] [port] service-type mgcp

3. controller t1 number

4. ds0-group channel-number timeslots range type none service mgcp

5. exit

6. mgcp restart-delay value

7. mgcp package-capability {s-package | dtmf-package | gm-package | lcs-package | rtp-package | trunk-package | script-package}

8. mgcp default-package {as-package | dtmf-package | gm-package | rtp-package | trunk-package}

9. mgcp dtmf-relay {codec | low-bit-rate} mode {cisco | out-of-band}

10. mgcp modem passthru {cisco | ca}

11. gcp sdp simple

12. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# mgcp

Initiates the MGCP application.

Step 2 

Router(config)# mgcp call-agent [ipaddr|hostname] [port] service-type mgcp

Specifies the call agent's IP address or domain name, the port, and gateway control service type.

Step 3 

Router(config)# controller t1 number

Specifies the channel number of the T1 trunk to be used for analog calls and enters controller configuration mode.

Step 4 

Router(config-controller)# ds0-group 
channel-number timeslots range type none service 
mgcp

Configures the channelized T1 time slots to accept the analog calls.

Step 5 

Router(config-controller)# exit

Exits the current mode.

Step 6 

Router(config)# mgcp restart-delay value

(Optional) Specifies the delay value sent in the RSIP graceful teardown method, in seconds. Range is from 0 to 600. Default is 0.

Step 7 

Router(config)# mgcp package-capability {trunk-package | dtmf-package | gm-package | lcs-package | rtp-package | as-package}

(Optional) Specifies the event packages that are supported on the trunking gateway. Default is trunk-package.

Step 8 

Router(config)# mgcp default-package {as-package | dtmf-package | gm-package | rtp-package | trunk-package}

(Optional) Specifies the default event package. Overrides the mgcp package-capability default package.

Step 9 

Router(config)# mgcp dtmf-relay {codec | low-bit-rate} mode {cisco | out-of-band}

(Optional) Used for relaying digits through the IP network. Default is no mgcp dtmf-relay for all codecs.

Step 10 

Router(config)# mgcp modem passthru {cisco | ca}

(Optional) Configures the gateway for modem and fax data.

Step 11 

Router(config)# mgcp sdp simple

(Optional) Specifies use of a subset of the session description protocol (SDP). Some call agents require this subset to send data through the network. Default is no mgcp sdp simple.

Step 12 

Router(config)# exit

Exits the current mode.

Configuring a TGW for SGCP

Perform this task to configure a trunking gateway (TGW) for Simple Gateway Control Protocol (SGCP):

SUMMARY STEPS

1. mgcp

2. mgcp call-agent [ipaddr | hostname] [port] service-type sgcp

3. controller t1 number

4. ds0-group channel-number timeslots range type {none | fgdos} [tone_type] [addr_info] service {sgcp | voice}

5. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# mgcp

Initiates the MGCP application.

Step 2 

Router(config)# mgcp call-agent [ipaddr | hostname] [port] service-type sgcp

Specifies the call agent's IP address or domain name, the port, and gateway control service type.

Step 3 

Router(config)# controller t1 number

Specifies the channel number of the T1 trunk to be used for analog calls and enters controller configuration mode.

Step 4 

Router(config-controller)# ds0-group channel-number timeslots range type {none | fgdos} [tone_type] [addr_info] service {sgcp | voice}

Configures the channelized T1 time slots to accept the analog calls. For type none, use service sgcp. For type fgdos, use service voice.

Step 5 

Router(config-controller)# exit

Exits the current mode.

Configuring an RGW

To configure a residential gateway (RGW), perform this task:

SUMMARY STEPS

1. mgcp

2. mgcp call-agent [ipaddr | hostname] [port] service-type mgcp

3. dial-peer voice number pots

4. application MGCPAPP

5. exit

6. mgcp package-capability {line-package | dtmf-package | gm-package | rtp-package}

7. mgcp default-package [line-package | dtmf-package | gm-package]

8. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# mgcp

Initiates the MGCP application.

Note RGWs are configured only with MGCP.

Step 2 

Router(config)# mgcp call-agent [ipaddr | hostname] [port] service-type mgcp

Specifies the call-agent IP address or domain name, port, and gateway control service type.

Step 3 

Router(config)# dial-peer voice number pots

Sets up the dial peer for a voice port.

Step 4 

Router(config-dial-peer)# application MGCPAPP

Selects the MGCP application to run on the voice port.

Step 5 

Router(config-dial-peer)# exit

Exits the current mode.

Step 6 

Router(config)# mgcp package-capability {line-package | dtmf-package | gm-package | rtp-package}

(Optional) Specifies event packages that are supported on the residential gateway. Default is line-package.

Step 7 

Router(config)# mgcp default-package [line-package | dtmf-package | gm-package]

(Optional) Specifies the default event package. Overrides the mgcp package-capability command.

Step 8 

Router(config)# exit

Exits the current mode.

Configuring a SDP Aware NSE Mode

The Cisco IOS MGCP gateway relies only on the local modem or fax configuration to determine whether Named Signaling Event (NSE) should be used or not for the current call. SDP-aware NSE mode enables the Cisco IOS MGCP gateway to negotiate NSE-based modem and fax features by considering both the local configuration and the remote support for NSE.

Restrictions

Cisco Unified Call Manager (UCM) does not support modem or fax passthrough. This feature should not be enabled when Cisco UCM is the call agent.

SUMMARY STEPS

1. mgcp

2. mgcp behavior negotiate-nse enable

3. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# mgcp

Initiates the MGCP application.

Step 2 

Router(config)# mgcp behavior negotiate-nse enable

Enables SDP-aware NSE mode.

Step 3 

Router(config)# exit

Exits global configuration mode and returns to privileged EXEC mode.

Verifying NSE Mode Configuration

To verify NSE mode configuration, use the following command.

SUMMARY STEPS

1. show mgcp

DETAILED STEPS


Step 1 show mgcp

Use the show mgcp command to display the state of the mgcp behavior command.

Router# show mgcp

MGCP Admin State ACTIVE, Oper State ACTIVE - Cause Code NONE
MGCP call-agent: 10.7.0.200 Initial protocol service is MGCP 0.1

The following lines show that the mgcp behavior negotiate-nse enable command is enabled:

mgcp modem passthrough voip mode nse
mgcp codec g723ar53 packetization-period 30
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
mgcp package-capability mdste-package
mgcp package-capability srtp-package
mgcp package-capability fm-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp sdp mdcx-ack
mgcp fax t38 ecm
mgcp fax t38 ls_redundancy 5
mgcp fax t38 hs_redundancy 2
mgcp behavior mdcx-sdp ack-with-sdp
mgcp behavior dynamically-change-codec-pt disable
mgcp behavior negotiate-nse enable
mgcp rtp payload-type nte 101

Verifying the TGW or RGW Configuration

To verify TGW or RGW configuration, use the following command.

SUMMARY STEPS

1. show running-configuration

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# show running-configuration

Displays the current configuration settings.

Blocking New Calls

You can block all new MGCP calls to the router (Step 1) and terminate all existing active calls (Step 2), which means that an active call is not terminated until the caller hangs up.

To block all new calls, use the following commands in global configuration mode:

SUMMARY STEPS

1. mgcp block-newcalls

2. no mgcp block-newcalls

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# mgcp block-newcalls

Prevents the gateway from accepting new calls.

Step 2 

Router(config)# no mgcp block-newcalls

Restarts normal MGCP call operation.

Configuration Examples for MGCP and Related Protocols

This section provides configuration examples for each of the supported platforms:

Configuring a Cisco AS5300 as a TGW with MGCP Example

Configuring a Cisco AS5300 as a TGW with SGCP Example

Configuring a Cisco 3660 as a TGW with MGCP Example

Configuring a Cisco uBR924 as an RGW Example

Configuring a Cisco 2620 as an RGW Example

Configuring a Cisco AS5300 as a TGW with MGCP Example

The following example illustrates a configuration only for MGCP calls. FGD-OS calls are not supported.

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
resource-pool disable
!
ip subnet-zero
ip ftp username smith
ip host B 209.165.200.225
ip host C 209.165.200.226
ip domain-name cisco.com
ip name-server 209.165.202.129
!
mgcp
mgcp request timeout 10000
mgcp call-agent 192.168.10.10 2302
mgcp restart-delay 5
mgcp package-capability gm-package
mgcp package-capability dtmf-package
mgcp package-capability trunk-package
mgcp package-capability rtp-package
mgcp package-capability as-package
mgcp package-capability mf-package
mgcp package-capability script-package
mgcp default-package trunk-package
mta receive maximum-recipients 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 1
 framing esf
 clock source line secondary 1
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 2
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 3
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
voice-port 0:0
!
voice-port 1:0
!
voice-port 2:0
!
voice-port 3:0
!
interface Ethernet0
 ip address 192.168.10.9 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 172.22.91.73 255.255.255.0
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
no ip classless
ip route 0.0.0.0 0.0.0.0 172.22.91.1
ip route 209.165.200.225 255.255.255.255 192.168.0.1
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Configuring a Cisco AS5300 as a TGW with SGCP Example

The following example illustrates a configuration that supports MGCP and FGD-OS calls:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
resource-pool disable
!
ip subnet-zero
ip ftp username smith
ip host B 209.165.200.225
ip host C 209.165.200.226
ip domain-name cisco.com
ip name-server 209.165.202.129
!
mgcp
mgcp request timeout 10000
mgcp call-agent 192.168.10.10 2302 sgcp
mta receive maximum-recipients 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 1
 framing esf
 clock source line secondary 1
 linecode b8zs
 ds0-group 0 timeslots 1-24 type fgd-os mf dnis-ani service voice
!
controller T1 2
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 3
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
!voice-port 0:0
!
voice-port 1:0
!
voice-port 2:0
!
voice-port 3:0
!
interface Ethernet0
 ip address 192.168.10.9 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 172.22.91.73 255.255.255.0
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
no ip classless
ip route 0.0.0.0 0.0.0.0 172.22.91.1
ip route 209.165.200.225 255.255.255.255 192.168.0.1
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Configuring a Cisco 3660 as a TGW with MGCP Example

The following example illustrates a platform that does not support FGD-OS calls.

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
memory-size iomem 40
voice-card 1
!
ip subnet-zero
!
mgcp 4000
mgcp call-agent 209.165.202.129 4000
mgcp package-capability gm-package
mgcp package-capability dtmf-package
mgcp package-capability rtp-package
mgcp package-capability as-package
isdn voice-call-failure 0
cns event-service server
!
controller T1 1/0
 framing esf
 clock source internal
 ds0-group 1 timeslots 1-24 type none service mgcp
!
controller T1 1/1
 framing esf
 clock source internal
 ds0-group 1 timeslots 1-24 type none service mgcp
!
voice-port 1/0:1
!
voice-port 1/1:1
!
interface FastEthernet0/0
 ip address 209.165.202.140 255.255.255.0
 no ip directed-broadcast
 load-interval 30
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 load-interval 30
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 209.165.202.130
ip classless
ip route 209.165.200.225 255.255.255.255 FastEthernet0/0
no ip http server
!
snmp-server engineID local 00000009020000107BD8CD80
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Configuring a Cisco uBR924 as an RGW Example

The following example illustrates a platform that does not support FGD-OS calls.

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
logging buffered 200000 debugging
!
clock timezone - -8
ip subnet-zero
no ip routing
no ip domain-lookup
ip host A 192.168.147.91
ip host C 209.165.200.224
ip host D 209.165.200.225
!
mgcp
mgcp call-agent 192.168.10.10 2490
mgcp package-capability gm-package
mgcp package-capability dtmf-package
mgcp package-capability line-package
mgcp default-package line-package
!
voice-port 0
 input gain -3
!
voice-port 1
 input gain -3
!
dial-peer voice 1 pots
 application MGCPAPP
 port 1
!
dial-peer voice 2 pots
 application MGCPAPP
 port 0
!
interface Ethernet0
 ip address 192.168.147.91 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface cable-modem0
 ip address negotiated
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 cable-modem downstream saved channel 459000000 20
cable-modem downstream saved channel 699000000 19 2
 cable-modem mac-timer t2 100000
 no cable-modem compliant bridge
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.1
ip classless
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line vty 0 4
 login
!
end

Configuring a Cisco 2620 as an RGW Example

The following example illustrates a platform that does not support FGD-OS calls.

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname D
!
memory-size iomem 10
ip subnet-zero
!
mgcp
mgcp call-agent 172.20.5.20
mgcp package-capability gm-package
mgcp package-capability dtmf-package
mgcp package-capability line-package
mgcp package-capability rtp-package
mgcp default-package line-package
cns event-service server
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1 pots
 application MGCPAPP
 port 1/0/0
!
dial-peer voice 2 pots
 application MGCPAPP
 port 1/0/1
!
interface Ethernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Ethernet0/1
 ip address 172.20.5.25 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip default-gateway 209.165.202.130
ip classless
ip route 209.165.200.225 255.255.255.224 Ethernet0/1
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

TipSee the "Additional References for MGCP and SGCP" section on page x for related documents, standards, and MIBs.

See the "Glossary" for definitions of terms in this guide.

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS Voice commands

Cisco IOS Voice Command Reference

Cisco IOS Voice Configuration Library

For more information about Cisco IOS voice features, including feature documents, and troubleshooting information—at

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/
cisco_ios_voice_configuration_library_glossary/vcl.htm


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for Basic MGCP Configuration

Table 3 lists the features in this module and provides links to specific configuration information. Only features that were introduced or modified in Cisco IOS Release 12.3(1) or a later release appear in the table.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS, Catalyst OS, and Cisco IOS XE software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 3 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 3 Feature Information for MGCP Basic Configuration 

Feature Name
Releases
Feature Information

Configuring a TGW and RGW for MGCP

12.4(22)Y

The following section provides information about this feature:

Configuring a TGW for MGCP

Configuring an RGW

SDP Aware NSE Mode

15.1(3)T

Support was added for negotiating remote NSE support by configuring modem pass through on the gateway.

The following section provides information about this feature:

Configuring a SDP Aware NSE Mode