This documentation has been moved
Appendix A: Configuring MGCP CAS PBX and AAL2 PVC
Downloads: This chapterpdf (PDF - 429.0KB) The complete bookPDF (PDF - 0.97MB) | Feedback

Appendix A: Configuring MGCP CAS PBX and AAL2 PVC

Table Of Contents

Appendix A: Configuring MGCP CAS PBX and AAL2 PVC

Contents

Prerequisites for Configuring MGCP CAS PBX and AAL2 PVC

Restrictions for Configuring MGCP CAS PBX and AAL2 PVC

Information About Configuring MGCP CAS PBX and AAL2 PVC Feature

How to Configure MGCP CAS PBX and AAL2 PVC Feature

Configuring the Gateway

Configuring Subcell Multiplexing for AAL2 Voice

Configuring the Cisco uBR924 Cable Access Router for SGCP and MGCP Functionality

Verifying the MGCP CAS PBX and AAL2 PVC Configurations

Configuration Examples for Configuring MGCP CAS PBX and AAL2 PVC Feature

Example 1: MGCP Residential Gateway

Example 2: MGCP Gateway using Voice over ATM AAL2

Example 3: MGCP/SGCP E&M Wink-Start

Example 4: SGCP 1.5 CAS PBX using Voice over ATM AAL2

Example 5: SGCP 1.5 CAS PBX using Voice over IP over ATM AAL5

Example 6: SGCP 1.5 Analog E&M PBX using Voice over ATM AAL2

Example 7: SGCP 1.5 Analog E&M PBX using Voice over IP over ATM AAL5

Example 8: SGCP 1.5 RGW using Voice over ATM AAL2

Example 9: SGCP 1.5 RGW using Voice over IP over ATM AAL5


Appendix A: Configuring MGCP CAS PBX and AAL2 PVC


This section provides information on configuring the MGCP Channel-Associated Signaling (CAS) Private-Branch-Exchange (PBX) and ATM Adaptation Layer 2 (AAL2) Permanent Virtual Circuit (PVC) feature.

Feature benefits include the following:

The merged Simple Gateway Control Protocol/Media Gateway Control Protocol (SGCP/MGCP) software for residential gateways (RGWs), business gateways (BGWs), and trunking gateways (TGWs) enables easier development and growth of Cisco and customer solutions.

MGCP CAS PBX and AAL2 PVC software meets customer requirements for CAS connectivity to traditional PBXs and regulatory requirements for support of 911, Barge In, and Busy Line Verify features.


Note For more information about this and related Cisco IOS voice features, see the following:

"Overview of MGCP and Related Protocols" on page 3

Entire Cisco IOS Voice Configuration Library—including library preface and glossary, other feature documents, and troubleshooting documentation—at http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_voice_configuration_library_glossary/vcl.htm


Release
Modification

12.1(5)XM

This feature was introduced on the following platforms: Cisco 1750, Cisco 2600 series, Cisco 3600 series, Cisco AS5300, Cisco MC3810, and Cisco uBR924.

12.2(2)T

This feature was integrated into this release on all previously supported platforms except the Cisco AS5300. A new command was added (mgcp rtp unreachable timeout) and an existing command was modified (mgcp sdp).

12.2(11)T

This feature was implemented on the Cisco AS5300 and Cisco AS5850.

Note AAL2 PVC is not supported on the Cisco AS5850.


Feature History for MGCP CAS PBX and AAL2 PVC

Contents

Prerequisites for Configuring MGCP CAS PBX and AAL2 PVC

Restrictions for Configuring MGCP CAS PBX and AAL2 PVC

Information About Configuring MGCP CAS PBX and AAL2 PVC Feature

How to Configure MGCP CAS PBX and AAL2 PVC Feature

Configuration Examples for Configuring MGCP CAS PBX and AAL2 PVC Feature

Prerequisites for Configuring MGCP CAS PBX and AAL2 PVC

Prerequisites are described in the "Prerequisites for Configuring MGCP and Related Protocols" section on page 3.

Restrictions for Configuring MGCP CAS PBX and AAL2 PVC

MGCP CAS PBX and AAL2 PVC Software Caveats

Only the Cisco MC3810 series platform supports MGCP 0.1 control of AAL2 voice transport in this Cisco IOS release.

For the Cisco MC3810 series platform, the AAL2 PVC functionality is supported on an high-performance compression module (HCM) version of an digital signal processor (DSP) card; it is not supported on an voice compression module (VCM) version.

To check the type of DSP card, enter a show version command at the EXEC prompt. For example: Router# show version

If you have an HCM card, the following line appears as part of the show version information:

1 6-DSP (slot 2) High Performance Compression Module(v01.A0)

If you have an VCM card, the following line appears as part of the show version information:

1 6-DSP (slot 2) Voice Compression Module(v255.V7)

If you have an HCM card, the MGCP Basic CLASS and Operator Services (BCOS) features will function correctly. If you have an VCM card, the AAL2 PVC feature is not supported.

The Cisco AS5300 multiservice platform supports only the Feature Group-D Operator Services (FGD-OS) Barge-In/Busy Line Verify and 911 features of the MGCP CAS PBX and AAL2 PVC software.

Features Not Supported

Basic CLASS and Operator features are covered in the MGCP Basic CLASS and Operator Services software. For more information on these capabilities, see Configuring MGCP Basic CLASS and Operator Services.

The MGCP CAS PBX and AAL2 PVC software has not implemented DSP clock slotting changes, Comfort Noise Indication, ATM SVCs, TGCP, AAL1, FXO support in SGCP, ATM on the Cisco 3660 platform, and VoIP Call Admission Control (CAC). These capabilities are part of other Cisco development efforts.

Information About Configuring MGCP CAS PBX and AAL2 PVC Feature

The MGCP CAS PBX and AAL2 PVC features extend the earlier Simple Gateway Control Protocol (SGCP) Channel Associated Signaling (CAS) and AAL2 support onto the merged SGCP/MGCP software base to enable various service provider solutions.

MGCP CAS PBX and AAL2 PVC Features

CAS termination and translation to MGCP on Business Gateways (BGWs) and Trunking Gateways (TGWs).

Digital CAS (E&M) interfaces are supported in addition to the analog (FXO, FXS, and E&M) interfaces.

For this feature release, the BGWs are the Cisco 3810 series and Cisco 2600 series routers. The TGWs are the Cisco 3600 series multiservice platforms.

Support for CAS PBX and Feature Group D CAS Functions.

MGCP 0.1 has been expanded to support CAS packages that handle CAS PBX and Feature Group D CAS functions, including Barge-In/Busy Line Verify, and 911 capabilities on the TGW.

Expanding MGCP 0.1 to control AAL2 voice transport.

The earlier version of the merged SGCP/MGCP stack supported only Voice over IP. The merged stack will now support both VoIP and VoAAL2.

Only the Cisco MC3810 series platforms supports this feature in this release.

Addition of SGCP CAS PBX support to the existing merged SGCP/MGCP software stack.

The CAS PBX gateway features include CAS PBX trunks, digit maps, CAS events, and quarantine buffer software. These features were available in the existing standalone SGCP software; now they are supported in the merged stack.

Consolidation of various SGCP and MGCP feature sets onto one software image for Residential Gateways (RGWs), BGWs, and TGWs.

For this feature release, the RGWs are the Cisco uBR924 cable router and Cisco 1750 access router.

The essential difference for current SGCP users is that support for the SGCP application has been replaced with the MGCP application. The MGCP application supports both SGCP commands and MGCP commands, permitting access to a larger feature set than with the SGCP application alone. The MGCP CAS PBX and AAL2 PVC software assumes the MGCP mode as the default environment. This allows the gateway to recognize both MGCP and SGCP messages sent by the call agent. However, the user can specify SGCP mode for certain messages that will be sent by the gateway (by using the sgcp option as the service type in the mgcp call-agent command).

Examples of Service Provider Solutions

MGCP CAS PBX and AAL2 PVC features support several types of service provider solutions:

Residential cable access

A CLEC can use residential cable access to provide residential customers with basic telephony and data services. Figure 12 illustrates a possible residential cable access solution:

Figure 12 Residential Cable Access Solution

Note that in Figure 12, the trunking gateway (the Cisco 3660 platform) requires support of incoming and outgoing MF signaling for the Barge-In and Busy-Line Verify features. The residential gateway (the Cisco uBR924 cable access router) must support the CLASS features and 911 capability.

IP Centrex and IP PBX

In these solutions, a call agent provides business voice services traditionally offered by a circuit-based PBX. Figure 13 illustrates an IP Centrex solution:

Figure 13 IP Centrex Solution

In Figure 13, the BGW (the Cisco 2600 platform) requires PBX connectivity to interface with the legacy PBX.

Integrated Access

A CLEC or IXC can provide small, medium, and large businesses with integrated voice and data access services. The integrated access device can be located at the central office or on the customer's premises. Access to the subscriber can be analog or digital T1 interfaces in addition to DSL. Transport of voice and data can be over IP, Frame Relay, or ATM. Figure 14 illustrates an integrated access solution:

Figure 14 Integrated Access Solution

In Figure 14, MGCP control of calls over the AAL2 PVCs is required on the BGWs (the Cisco 2600 series, Cisco 3600, and Cisco 3810 series platforms) to connect into the ATM network for VToA.

Telecommuter or Small Office-Home Office

Figure 15 illustrates a telecommuter/small office-home office solution:

Figure 15 Telecommuter or Small Office-Home Office Solution

In Figure 15, MGCP must control the calls over AAL2 PVCs, and an analog FXS interface is required.

How to Configure MGCP CAS PBX and AAL2 PVC Feature

See the following sections for configuration tasks for the MGCP CAS PBX and AAL2 PVC feature. Each task in the list indicates if the task is optional or required.

Configuring the Gateway (required)

Configuring Subcell Multiplexing for AAL2 Voice (optional)

Configuring the Cisco uBR924 Cable Access Router for SGCP and MGCP Functionality (optional)

Verifying the MGCP CAS PBX and AAL2 PVC Configurations (optional)

Some tasks indicate one or more configuration examples affected by the command. See the specific configuration example listing for the parameter values.

Configuring the Gateway

SUMMARY STEPS

1. mgcp

2. mgcp call-agent {ipaddr | hostname} [port] [service-type type] version version-number

3. mgcp dtmf-relay voip codec {all | low-bit-rate} mode {cisco | nse | out-of-band}

4. mgcp package-capability {as-package | atm-package | dtmf-package | gm-package | hs-package | nas-package | rtp-package | script-package | trunk-package}

5. mgcp sgcp restart notify

6. mgcp modem passthrough [voip | voaal2] mode [cisco | nse]

7. mgcp tse payload type

8. mgcp rtp unreachable timeout timer-value

9. no mgcp timer receive-rtcp

10. mgcp timer net-cont-test timer

11. controller T1 0

12. mode atm

13. no shutdown

14. exit

15. mgcp quarantine mode process

16. controller T1 1

17. mode cas

18. ds0-group channel-number timeslots range type signaling-type tone type addr info service service-type

19. exit

20. interface atm0 [subinterface-number [multipoint | point-to-point]]

21. pvc [name] vpi/vci

22. encapsulation aal-encap

23. vbr-rt peak-rate average-rate [burst]

24. vcci pvc-identifier

25. exit

26. exit

27. dial-peer voice number pots

28. application MGCPAPP

29. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# mgcp

Starts the MGCP daemon.

Step 2 

Router(config)# mgcp call-agent {ipaddr | hostname} [port] [service-type type] version version-number

Configures the MGCP call agent and service type. If you want SGCP mode, use sgcp as the service type.

Step 3 

Router(config)# mgcp dtmf-relay voip codec {all | low-bit-rate} mode {cisco | nse | out-of-band}

(Optional. See Configuration Example 2.) Specifies compressed codecs for digit forwarding.

Step 4 

Router(config)# mgcp package-capability {as-package | atm-package | dtmf-package | gm-package | hs-package | nas-package | rtp-package | script-package | trunk-package}

(Optional. See Configuration Example 2.) Assigns packages to the gateway. Also refer to the mgcp default-package command.

Step 5 

Router(config-if)# mgcp sgcp restart notify

(Required only for SGCP mode with a call agent supporting RSIP. See Configuration Examples 4 through 9.) Causes MGCP to send SGCP RSIP messages.

Step 6 

Router(config-if)# mgcp modem passthrough [voip | voaal2] mode [cisco | nse]

(Optional for nse mode) Enables the gateway to process fax or modem messages. VoAAL2 does not support cisco.

Step 7 

Router(config)# mgcp tse payload type

(Required for nse mode. See Step 6.) Enables the TSE payload for fax and modem messages.

Step 8 

Router(config)# mgcp rtp unreachable timeout timer-value

(Optional) Enables detection of unreachable remote VoIP endpoints.

Step 9 

Router(config)# no mgcp timer receive-rtcp

(Required for non-RGWs. See Configuration Examples 2 through 9.) Turns off the RTP RTCP receive timeout interval at the gateway.

Step 10 

Router(config)# mgcp timer net-cont-test timer

(Optional for non-RGWs. See Configuration Examples 2 through 9.) Turns on the continuity test timeout interval at the gateway.

Step 11 

Router(config)# controller T1 0

(Required for ATM mode. See Configuration Examples 2 through 9.) Select s the T1 controller 0.

Step 12 

Router(config-controller)# mode atm

(Required for ATM mode. See Configuration Examples 2 through 9.) Specifies that the controller will support ATM encapsulation and create ATM interface 0.

When the controller is set to ATM mode, the following takes place:

Controller framing is automatically set to Extended SuperFrame (ESF).

The linecode is automatically set to B8ZS.

Step 13 

Router(config-controller)# no shutdown

(Optional for ATM mode. See Configuration Examples 2 through 9.) Ensures that the controller is activated.

Step 14 

Router(config-controller)# exit

(Required for ATM mode. See Configuration Examples 2 through 9.) Exits the current mode.

Step 15 

Router(config)# mgcp quarantine mode process

(Optional) Turns on processing for SGCP quarantine mode.

Step 16 

Router(config)# controller T1 1

(Required for CAS PBX. See Configuration Examples 3, 4, and 5.) Select the T1 controller 1.

Step 17 

Router(config-controller)# mode cas

(Required for CAS PBX. See Configuration Examples 3, 4, and 5.) Specify that the controller will support CAS.

Step 18 

Router(config-controller)# ds0-group channel-number timeslots range type signaling-type tone type addr info service service-type

(Required for CAS PBX. See Configuration Examples 3, 4, and 5.) Configure the T1 timeslots for CAS calls.

Step 19 

Router(config-controller)# exit

(Required for CAS PBX. See Configuration Examples 3, 4, and 5.) Exit controller configuration mode.

Step 20 

Router(config)# interface atm0 [subinterface-number [multipoint | point-to-point]]

(Required for ATM mode. See Configuration Examples 2 through 9.) Enter interface configuration mode to configure ATM interface 0 or an ATM subinterface.

Default for subinterfaces is multipoint.

For all scenarios: Set up three subinterfaces for point-to-point.

Step 21 

Router(config-if)# pvc [name] vpi/vci

(Required for ATM mode. See Configuration Examples 2 through 9.) Create an ATM PVC for voice traffic and enter ATM virtual circuit configuration mode.

Note The ilmi and qsaal options are not supported for AAL2.

Step 22 

Router(config-if-atm-vc)# encapsulation aal-encap

(Required for ATM mode. See Configuration Examples 2 through 9.) Set the encapsulation of the PVC for voice traffic. aal2 automatically creates channel identifiers (CIDs) 1 through 255.

Some of the Scenarios use aal5snap for ATM0.1 and ATM0.3. Use aal2 for ATM0.2.

Step 23 

Router(config-if-atm-vc)# vbr-rt peak-rate average-rate [burst]

(Required for ATM mode. See Configuration Examples 2 through 9.) Configures the PVC for the variable-bit-rate real-time (voice) traffic.

Step 24 

Router(config-if-atm-vc)# vcci pvc-identifier

(Optional for ATM mode. See Configuration Examples 2 through 9.) Assigns a unique identifier to the PVC.

Step 25 

Router(config-if-atm-vc)# exit

(Required for ATM mode. See Configuration Examples 2 through 9.) Exits the current mode.

Step 26 

Router(config-if)# exit

(Required for ATM mode. See Configuration Examples 2 through 9.) Exits the current mode.

Step 27 

Router(config)# dial-peer voice number pots

Enter dial peer configuration mode for the POTS dial peer.

Step 28 

Router(config-dial-peer)# application MGCPAPP

Initiates the MGCP protocol for the voice ports.

Step 29 

Router(config-dial-peer)# exit

Exits the current mode.

Configuring Subcell Multiplexing for AAL2 Voice

This section describes the configuration tasks necessary to enable AAL2 common part sublayer (CPS) subcell multiplexing when the Cisco MC3810 series platform interoperates with a voice interface service module (VISM) in an MGX switch.

SUMMARY STEPS

1. voice service voatm

2. session protocol aal2

3. subcell-mux

4. end

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config)# voice service voatm

(Required) Enters voice-service configuration mode.

Step 2 

Router(config-voice-service)# session protocol aal2

(Required) Enters voice-service-session configuration mode and specifies AAL2 trunking.

Step 3 

Router(config-voice-service-session)# subcell-mux

(Required) Enables subcell multiplexing.

By default, subcell multiplexing is not enabled.

Step 4 

Router(config-voice-service-session)# end

(Required) Exits the current mode.

Configuring the Cisco uBR924 Cable Access Router for SGCP and MGCP Functionality

The Cisco uBR924 cable access router requires standard per-port provisioning to work with MGCP CAS PBX and AAL2 PVC:

To access SGCP functionality, use the command:

S|0|ca1@call-agent.abc.com:2427|S|1|ca2@call-agent.abc.com:2427

To access MGCP functionality, use the command:

M|0|ca1@call-agent.abc.com:2427|M|1|ca2@call-agent.abc.com:2427

For either functionality type, port 0 points to call agent 1 and port 1 points to call agent 2. If needed, both ports can point to the same call agent.

Verifying the MGCP CAS PBX and AAL2 PVC Configurations

To verify configuration, use the following commands.

SUMMARY STEPS

1. show dial-peer voice sum

2. show running-configuration

DETAILED STEPS

 
Command
Purpose

Step 1 

Router# show dial-peer voice sum

Displays the status of the dial peer. The dial peer should be active. If it is not, use the no shut command to make it so.

Step 2 

Router# show running-configuration

Displays the current configuration settings.

Configuration Examples for Configuring MGCP CAS PBX and AAL2 PVC Feature

This section provides the following configuration diagrams and software examples:

Example 1: MGCP Residential Gateway

Example 2: MGCP Gateway using Voice over ATM AAL2

Example 3: MGCP/SGCP E&M Wink-Start

Example 4: SGCP 1.5 CAS PBX using Voice over ATM AAL2

Example 5: SGCP 1.5 CAS PBX using Voice over IP over ATM AAL5

Example 6: SGCP 1.5 Analog E&M PBX using Voice over ATM AAL2

Example 7: SGCP 1.5 Analog E&M PBX using Voice over IP over ATM AAL5

Example 8: SGCP 1.5 RGW using Voice over ATM AAL2

Example 9: SGCP 1.5 RGW using Voice over IP over ATM AAL5

Example 1: MGCP Residential Gateway

The following example illustrates the configuration for a Cisco MC3810 series platform with CAS running the MGCP application:

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log uptime
!
hostname Router
!
logging buffered
!
ip subnet-zero
ip host first 192.168.254.254
!
mgcp
mgcp call-agent 172.16.90.1
!
voice-card 0
  codec complexity high
!
controller T1 0
  framing esf
  linecode b8zs
!
interface Ethernet0
  ip address 172.16.92.3 255.255.0.0
!
interface Serial0
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface FR-ATM20
  no ip address
  shutdown
!
ip default-gateway 172.16.0.1
ip route 198.168.254.0 255.255.255.0 172.16.0.1
!
voice-port 1/1
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1/1
!
line con 0
  exec-timeout 0 0
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Example 2: MGCP Gateway using Voice over ATM AAL2

The following configuration illustrates a Cisco MC3810 series platform running the MGCP application using ATM AAL2 to carry voice traffic:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname main.office
!
network-clock base-rate 56k
ip subnet-zero
no ip domain-lookup
ip host second 192.168.254.254
ip host first 192.168.254.253
!
mgcp
mgcp call-agent 172.16.117.4 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode nse
mgcp dtmf-relay voaal2 codec all
mgcp package-capability rtp-package
mgcp tse payload 100
mgcp timer receive-rtcp 100
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Ethernet0
  ip address 171.16.121.1 255.255.0.0
!
interface Serial0
  no ip address
  no ip mroute-cache
  shutdown
  no fair-queue
!
interface Serial1
  no ip address
  shutdown
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive 

interface ATM0.2 point-to-point
  pvc 2/200
   vbr-rt 760 760 100
   encapsulation aal2
vcci 2
!
interface FR-ATM20
  no ip address
  shutdown
!
router group1 1
  redistribute connected
  network 172.0.0.0
!
ip default-gateway 172.16.0.1
no ip http server
ip classless
ip route 192.168.254.0 255.255.255.0 172.16.0.1
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
voice-port 1/1
  codec g711ulaw
!
voice-port 1/2
  shutdown
!
voice-port 1/6
  shutdown
!
dial-peer voice 1 pots
  application MGCPAPP
  destination-pattern 2220001
  port 1/1
!
line con 0
  transport input none
line aux 0
  line 2 3
line vty 0 4
login
!
end

Example 3: MGCP/SGCP E&M Wink-Start

The following example illustrates an E&M wink-start configuration on the Cisco MC3810 series platform that can be defined for either the SGCP or MGCP modes:

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sales
!
network-clock base-rate 56k
ip subnet-zero
!
mgcp
no mgcp timer receive-rtcp
call rsvp-sync
!
voice service voatm
!
 session protocol aal2
  subcell-mux
!
voice-card 0
!
controller T1 0
 mode atm
 framing esf
 clock source internal
 linecode b8zs
!
controller T1 1
 mode cas
 framing esf
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-wink-start
!
interface Ethernet0
 ip address 172.29.248.199 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip route-cache
 no ip mroute-cache
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface ATM0
 no ip address
 ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM0.2 point-to-point
 pvc 2/200
  vbr-rt 1536 1536 100
  encapsulation aal2
  vcci 10
!
interface FR-ATM20
 no ip address
 no ip route-cache
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.29.248.1
no ip http server
!
voice-port 1:1
 dial-type mf
!
dial-peer cor custom
!
dial-peer voice 1 pots
 application mgcpapp
 destination-pattern 1
 port 1:1
!
gatekeeper
 shutdown
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line 2 3
line vty 0 4
login
 length 0
!
ntp clock-period 17248569
ntp server 172.29.1.129
end

Example 4: SGCP 1.5 CAS PBX using Voice over ATM AAL2

The following figure and configuration illustrate the network connections for a Cisco MC3810 series platform with CAS running the MGCP application in SGCP 1.5 mode. ATM AAL2 carries voice traffic.

T1/0 is configured to run ATM with three permanent virtual circuits (PVCs):

1 PVC with encapsulation AAL5 carries SGCP messages (signaling VC)

1 PVC with encapsulation AAL5 carries data traffic (data VC)

1 PVC with encapsulation AAL2 carries voice traffic (bearer VC)

This bearer VC has a vcci of 2 assigned to it. The service manager uses this vcci value and a selected channel identifier (CID) value for a voice call on this router.

For AAL2, allocate 200 ATM cells/sec (84.8K bits/sec) for each G711u no vad call, 100 ATM cells/sec (42.4K bits/sec) for each G726-32 no vad or G729a no vad call.

In this configuration, T1/1 is configured as three DS-0 groups:

1 FXS ground start group

1 E&M immediate start group

1 E&M wink start group

For these voice ports, the dial type is set to mf to support mf dialing.

mgcp sdp is configured to enable SGCP RSIP messages notification.

mgcp modem passthrough mode is configured to allow nse processing of fax or modem calls.

Figure 16 SGCP 1.5 CAS PBX using Voice over ATM AAL2 Configuration

Router A Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp sgcp restart notify
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  clock source line
  linecode b8zs
!
controller T1 1
  mode cas
  framing esf
  clock source line
  linecode b8zs
  ds0-group 1 timeslots 1-8 type e&m-immediate-start
  ds0-group 2 timeslots 9-16 type e&m-wink-start
  ds0-group 3 timeslots 17-24 type fxs-ground-start
!
interface Ethernet0
  ip address 172.16.24.103 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
  no cdp enable
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.2 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  pvc 2/200
   vbr-rt 1536 1400 100
   encapsulation aal2
   vcci 2
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.5 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
no ip http server
!
voice-port 1:1
!
voice-port 1:2
  dial-type mf
!
voice-port 1:3
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1:1
!
dial-peer voice 2 pots
  application MGCPAPP
  port 1:2
!
dial-peer voice 3 pots
  application MGCPAPP
  port 1:3
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Router B Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname B
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp sgcp restart notify
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  clock source line
  linecode b8zs
!
controller T1 1
  mode cas
  framing esf
  clock source line
  linecode b8zs
  ds0-group 1 timeslots 1-8 type e&m-immediate-start
  ds0-group 2 timeslots 9-16 type e&m-wink-start
  ds0-group3 timeslots 17-24 type fxs-ground-start
!
interface Ethernet0
  ip address 172.17.24.103 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
  no cdp enable
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.3 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  pvc 2/200
   vbr-rt 1536 1400 100
   encapsulation aal2
   vcci 2
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.8 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
no ip http server
!
voice-port 1:1
!
voice-port 1:2
  dial-type mf
!
voice-port 1:3
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1:1
!
dial-peer voice 2 pots
  application MGCPAPP
  port 1:2
!
dial-peer voice 3 pots
  application MGCPAPP
  port 1:3
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Example 5: SGCP 1.5 CAS PBX using Voice over IP over ATM AAL5

The following figure and configuration illustrate the network connections for a Cisco MC3810 series platform with CAS running the MGCP application in SGCP 1.5 mode. Voice over IP over ATM AAL5 carries voice traffic.

This configuration is very similar to the AAL2 example in the previous section except that an AAL5 PVC is the bearer PVC for voice traffic.

This configuration has a loopback interface with an IP address assigned to it. During voice calls, the gateway gives this IP address to the service manager as the address for the other gateway of the voice connection to use as the destination IP address.

In the example below, Router A's loopback address is 192.168.1.0 and Router B's address is 192.168.5.0. If Router A originated a call to Router B, A would give 192.168.1.0 to the Service Manager and B would give 192.168.5.0. The IP route configuration commands of both routers direct the IP traffic into the voice bearer PVC since the loopback addresses are on different IP subnets.

For Voice over IP, allocate 300 ATM cells/sec (127.2K bits/sec) for each G711u no vad call, and 200 ATM cells/sec (84.8K bits/sec) for each G726-32 no vad or G729a no vad call.


Note For G711u no vad calls, a T1 running ATM does not have enough bandwidth to carry 24 voice calls.


Figure 17 SGCP 1.5 CAS PBX using Voice over IP over ATM AAL5 Configuration

Router A Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp modem passthrough nse
mgcp sgcp restart notify
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
controller T1 1
  mode cas
  framing esf
  clock source line
  linecode b8zs
  ds0-group 1 timeslots 1-8 type e&m-immediate-start
  ds0-group 2 timeslots 9-16 type e&m-wink-start
  ds0-group 3 timeslots 17-24 type fxs-ground-start
  framing esf
  linecode b8zs
!
interface Loopback0
  ip address 192.168.1.0 255.255.255.0
!
interface Ethernet0
  ip address 172.16.24.103 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
  no cdp enable
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.2 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  ip address 10.0.0.5 255.0.0.0
  pvc 1/2
   vbr-rt 1536 1400 100
   encapsulation aal5mux ip
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.8 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
ip route 10.0.0.15 255.0.0.0 ATM0.2
no ip http server
!
!
voice-port 1:1
!
voice-port 1:2
  dial-type mf
!
voice-port 1:3
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1:1
!
dial-peer voice 2 pots
  application MGCPAPP
  port 1:2
!
dial-peer voice 3 pots
  application MGCPAPP
  port 1:3
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Router B Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname B
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp modem passthrough nse
mgcp sgcp restart notify
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
controller T1 1
  mode cas
  ds0-group 1 timeslots 1-8 type e&m-immediate-start
  ds0-group 2 timeslots 9-16 type e&m-wink-start
  ds0-group3 timeslots 17-24 type fxs-ground-start
  framing esf
  linecode b8zs
!
interface Loopback 0
  ip address 192.168.5.0 255.255.255.0
!
interface Ethernet0
  ip address 172.17.24.103 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
  no cdp enable
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.3 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  ip address 10.0.0.6 255.0.0.0
  pvc 1/2
   vbr-rt 1536 1400 100
   encapsulation aal5mux ip
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.9 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
ip route 10.0.0.16 255.0.0.0 ATM0.2
no ip http server
!
!
voice-port 1:1
!
voice-port 1:2
  dial-type mf
!
voice-port 1:3
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1:1
!
dial-peer voice 2 pots
  application MGCPAPP
  port 1:2
!
dial-peer voice 3 pots
  application MGCPAPP
  port 1:3
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Example 6: SGCP 1.5 Analog E&M PBX using Voice over ATM AAL2

The following figure and configuration illustrate the network connections for a Cisco MC3810 series platform with Analog E&M running the MGCP application in SGCP 1.5 mode. ATM AAL2 carries voice traffic.

This configuration is similar to the SGCP 1.5 CAS PBX using Voice over ATM AAL2 configuration, with these exceptions:

No DS-0 groups are configured for T1/1 because the slot is used by analog voice.

The E&M port must be configured to match the type of analog PBX to which the port is connected.

E&M protocol is set to either E&M immediate or wink start. For wink start, set the dial-type to mf.

Operation must be set to 2-w (for 2-wire) or 4-w (for 4-wire).

Type is set to I, II, IV, or V.

In this example, the bearer PVC has enough bandwidth for two G711u no vad calls because the router has only two voice ports.

Figure 18 SGCP 1.5 Analog E&M PBX using Voice over ATM AAL2 Configuration

Router A Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
mgcp sgcp restart notify
isdn voice-call-failure 0
!
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Ethernet0
  ip address 172.16.24.101 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
  no cdp enable
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.2 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  pvc 1/2
   vbr-rt 1536 170 8
   encapsulation aal2
   vcci 2
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.5 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
no ip http server
!
voice-port 1/3
  operation 4-wire
  type 2
  signal immediate
!
voice-port 1/4
  operation 4-wire
  type 2
  dial-type mf
!
!
dial-peer voice 3 pots
  application MGCPAPP
  port 1/3
!
dial-peer voice 4 pots
  application MGCPAPP
  port 1/4
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Router B Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname B
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
mgcp sgcp restart notify
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Ethernet0
  ip address 172.17.24.101 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
  no cdp enable
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.3 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  pvc 1/2
   vbr-rt 1536 170 8
   encapsulation aal2
   vcci 2
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.6 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
no ip http server
!
voice-port 1/3
  operation 2-wire
  type 1
  signal immediate
!
voice-port 1/4
  operation 4-wire
  type 2
  dial-type mf
!
dial-peer voice 3 pots
  application MGCPAPP
  port 1/3
!
dial-peer voice 4 pots
  application MGCPAPP
  port 1/4
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Example 7: SGCP 1.5 Analog E&M PBX using Voice over IP over ATM AAL5

The following Figure 19 and configuration illustrate the network connections for a Cisco MC3810 series platform RGW with analog FXS loopstart ports running the MGCP application in SGCP 1.5 mode. Voice over IP over ATM AAL5 carries voice traffic.

This configuration is similar to the SGCP 1.5 CAS PBX using Voice over IP over ATM AAL5 configuration, with these exceptions:

No DS-0 groups are configured for T1/1 because the slot is used by analog voice.

The E&M port must be configured to match the type of analog PBX to which the port is connected.

E&M protocol is set to either E&M immediate or wink start. For wink start, set the dial-type to mf.

Operation must be set to 2-w (for 2-wire) or 4-w (for 4-wire).

Type is set to I, II, IV, or V.

In this example, the bearer PVC has enough bandwidth for two G711u no vad calls because the router has only two voice ports.

Figure 19 SGCP 1.5 Analog E&M PBX using Voice over IP over ATM AAL5 Configuration

Router A Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
mgcp sgcp restart notify
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Loopback0
  ip address 10.0.0.2 255.0.0.
!
interface Ethernet0
  ip address 172.16.24.101 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.5 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  ip address 10.0.0.6 255.0.0.0
  pvc 1/2
   vbr-rt 1536 260 8
   encapsulation aal5mux ip
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.8 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
ip route 10.0.0.0 255.0.0.0 ATM0.2
no ip http server
!
voice-port 1/3
  operation 4-wire
  type 2
  signal immediate
!
voice-port 1/4
  operation 4-wire
  type 2
  dial-type mf
!
dial-peer voice 3 pots
  application MGCPAPP
  port 1/3
!
dial-peer voice 4 pots
  application MGCPAPP
  port 1/4
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Router B Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname B
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
mgcp sgcp restart notify
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Loopback0
  ip address 10.0.0.3 255.0.0.0

interface Ethernet0
  ip address 172.17.24.101 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.7 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  ip address 10.0.0.9 255.0.0.0
  pvc 1/2
   vbr-rt 1536 170 8
   encapsulation aal5mux ip
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.10 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
ip route 10.0.0.20 255.0.0.0 ATM0.2
no ip http server
!
voice-port 1/3
  operation 4-wire
  type 2
  signal immediate
!
voice-port 1/4
  operation 4-wire
  type 2
  dial-type mf
!
dial-peer voice 3 pots
  application MGCPAPP
  port 1/3
!
dial-peer voice 4 pots
  application MGCPAPP
  port 1/4
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Example 8: SGCP 1.5 RGW using Voice over ATM AAL2

The following Figure 20 and configuration illustrate the network connections for a Cisco MC3810 series platform RGW with analog FXS port running the MGCP application in SGCP 1.5 mode. ATM AAL2 carries voice traffic.

This configuration is similar to the SGCP 1.5 CAS PBX using Voice over ATM AAL2 configuration, with these exceptions:

No DS-0 groups are configured for T1/1 because the slot is used by analog voice.

For RGW, the FXS ports' signaling are set to loop start, which is the default.

In this example, the bearer PVC has enough bandwidth for two G711u no vad calls because the router has only two voice ports.

Figure 20 SGCP 1.5 RGW using Voice over ATM AAL2 Configuration

Router A Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp sgcp restart notify
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Ethernet0
  ip address 172.16.24.101 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
  no cdp enable
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.2 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  pvc 1/2
   vbr-rt 1536 170 8
   encapsulation aal2
   vcci 2
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.5 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
no ip http server
!
!
voice-port 1/1
!
voice-port 1/2
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1/1
!
dial-peer voice 2 pots
  application MGCPAPP
  port 1/2
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Router B Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname B
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp sgcp restart notify
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Ethernet0
  ip address 172.17.24.101 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
  no cdp enable
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.3 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  pvc 1/2
   vbr-rt 1536 170 8
   encapsulation aal2
   vcci 2
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.6 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
no ip http server
!
voice-port 1/1
!
voice-port 1/2
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1/1
!
dial-peer voice 2 pots
  application MGCPAPP
  port 1/2
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Example 9: SGCP 1.5 RGW using Voice over IP over ATM AAL5

The following Figure 21 and configuration illustrate the network connections for a Cisco MC3810 series platform RGW with analog FXS port running the MGCP application in SGCP 1.5 mode. Voice over IP over ATM AAL5 carries voice traffic.

This configuration is similar to the SGCP 1.5 CAS PBX Voice Over ATM AAL5 configuration, with these exceptions:

No DS-0 groups are configured for T1/1 because the slot is used by analog voice.

For RGW, the FXS ports' signaling are set to loop start, which is the default.

In this example, the bearer PVC has enough bandwidth for two G711u no vad calls because the router has only two voice ports.

Figure 21 SGCP 1.5 RGW using Voice over IP over ATM AAL5 Configuration

Router A Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp sgcp restart notify
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Ethernet0
  ip address 172.16.24.101 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.2 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  ip address 10.0.0.5 255.0.0.0
  pvc 1/2
   vbr-rt 1536 260 8
   encapsulation aal5mux ip
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.8 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
ip route 10.0.0.10 255.0.0.0 ATM0.2
no ip http server
!
voice-port 1/1
!
voice-port 1/2
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1/1
!
dial-peer voice 2 pots
  application MGCPAPP
  port 1/2
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

Router B Configuration

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname B
!
network-clock base-rate 56K
ip subnet-zero
!
mgcp
mgcp call-agent 10.0.0.1 service-type sgcp version 1.5
mgcp sgcp restart notify
mgcp tse payload 100
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
isdn voice-call-failure 0
!
!
cns event-service server
voice-card 0
!
controller T1 0
  mode atm
  framing esf
  linecode b8zs
!
interface Ethernet0
  ip address 172.17.24.101 255.255.0.0
!
interface Serial0
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface Serial1
  no ip address
  no ip route-cache
  no ip mroute-cache
  shutdown
!
interface ATM0
  no ip address
  ip mroute-cache
  no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
  description signaling vc
  ip address 10.0.0.3 255.0.0.0
  pvc 1/1
   vbr-rt 1536 64
   encapsulation aal5snap
!
interface ATM0.2 point-to-point
  description bearer vc
  ip address 10.0.0.6 255.0.0.0
  pvc 1/2
   vbr-rt 1536 260 8
   encapsulation aal5mux ip
!
interface ATM0.3 point-to-point
  description data vc
  ip address 10.0.0.7 255.0.0.0
  pvc 1/100
   encapsulation aal5snap
!
interface FR-ATM20
  no ip address
  no ip route-cache
  shutdown
!
ip classless
ip route 10.0.0.12 255.0.0.0 ATM0.2
no ip http server
!
voice-port 1/1
!
voice-port 1/2
!
dial-peer voice 1 pots
  application MGCPAPP
  port 1/1
!
dial-peer voice 2 pots
  application MGCPAPP
  port 1/2
!
line con 0
  exec-timeout 0 0
  privilege level 15
  transport input none
line aux 0
line 2 3
line vty 0 4
  login
!
end

TipSee the "Additional References for MGCP and SGCP" section for related documents, standards, and MIBs.

See "Glossary" for definitions of terms in this guide.


CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.