This documentation has been moved
QSIG Support for Tcl IVR 2.0
Downloads: This chapterpdf (PDF - 160.0KB) The complete bookPDF (PDF - 1.58MB) | Feedback

QSIG Support for Tcl IVR 2.0

Table Of Contents

QSIG Support for Tcl IVR 2.0

Contents

Prerequisites for Configuring QSIG for Tcl IVR 2.0

Restrictions for Configuring QSIG for Tcl IVR 2.0

Information About QSIG for Tcl IVR 2.0

How to Configure QSIG for Tcl IVR 2.0

Configuring QSIG

Configuring Supplementary Service for a POTS Dial Peer

Configuring Supplementary Service for a VoIP Dial Peer

Verifying QSIG and Supplementary Service

Configuration Example for QSIG for Tcl IVR 2.0

Additional References


QSIG Support for Tcl IVR 2.0


This chapter describes how to implement the QSIG for Tool Command Language Interactive Voice Response (Tcl IVR) 2.0 feature. Q.SIG support is required for European countries to interconnect enterprise customers to a wholesale voice solution. The feature provides transparent Q.SIG interworking with a Tcl IVR 2.0 voice application on a Cisco IOS voice gateway. This functionality can be enabled using a new CLI on the POTS or VoIP dial-peer. Prior to this feature, Q.SIG messages were interpreted by the Tcl IVR 2.0 application, rather than passed transparently to the remote endpoint.

Feature benefits include the following:

Increased interconnection options for VoIP wholesale providers

Elimination of unnecessary decoding

Release
Modification

12.2(11)T

This feature was introduced.


Feature History for QSIG for Tcl IVR 2.0

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note For more information about related Cisco IOS voice features, see the following:

"Overview of ISDN Voice Interfaces" on page 3

Entire Cisco IOS Voice Configuration Library—including library preface and glossary, other feature documents, and troubleshooting documentation—at http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_voice_configuration_library_glossary/vcl.htm.

For a list of references cited in this chapter, see the "Additional References" section.


Contents

Prerequisites for Configuring QSIG for Tcl IVR 2.0

Restrictions for Configuring QSIG for Tcl IVR 2.0

Information About QSIG for Tcl IVR 2.0

How to Configure QSIG for Tcl IVR 2.0

Configuration Example for QSIG for Tcl IVR 2.0

Additional References

Prerequisites for Configuring QSIG for Tcl IVR 2.0

Perform the prerequisites that are listed in the "Prerequisites for Configuring an ISDN Voice Interface" section on page 15.

Establish a working IP network. For more information, see the Cisco IOS documentation set. See specifically the Cisco IOS IP and IP Routing Configuration Guide and the Cisco IOS Voice, Video, and Fax Configuration Guide.

Configure VoIP. For more information, see the Cisco IOS Voice, Video, and Fax Configuration Guide.

Download the Tcl scripts required for this feature from the following website:
http://www.cisco.com/cgi-bin/tablebuild.pl/tclware

Ensure that the VCWare version used for the Cisco AS5300 is compatible with the Cisco IOS image being used.


Note VCWare applies only to the Cisco AS5300.


Before configuring IVR Version 2.0 features, do the following:

Download the Tcl scripts and audio files to be used with this feature. Store them on a TFTP server configured to interact with your gateway access server.

Create the IVR/Tcl application script to use when configuring IVR. Store it on a server or at a location where it can be retrieved by the gateway access server. Then configure the server to use IVR with the application that you created.

Configure the dial peer on incoming POTS or VoIP dial peers.

Restrictions for Configuring QSIG for Tcl IVR 2.0

Restrictions are described in the Restrictions for Configuring ISDN Voice Interfaces, page 4. In addition, the following apply:

This feature is applicable to only the following:

VoIP and POTS dial peers

Tcl IVR version 2.0 only; not version 1.0

Information About QSIG for Tcl IVR 2.0

Q.SIG support is required for European countries to interconnect enterprise customers to a wholesale voice solution. The Q.SIG for Tcl IVR 2.0 feature provides transparent Q.SIG interworking when using a Tcl IVR version 2.0 voice application on a Cisco IOS voice gateway. This functionality can be enabled using a new CLI on the POTS or VoIP dial-peer. Prior to this feature, Q.SIG messages were interpreted by the Tcl IVR 2.0 application, rather than passed transparently to the remote endpoint.


Note General information about ISDN voice interfaces is presented in the "Information About ISDN Voice Interfaces" section on page 4.


How to Configure QSIG for Tcl IVR 2.0

Configuring QSIG (required)

Configuring Supplementary Service for a POTS Dial Peer (optional)

Configuring Supplementary Service for a VoIP Dial Peer (optional)

Verifying QSIG and Supplementary Service (optional)

Configuring QSIG

To configure QSIG, perform the following steps.


Note You must create the application that is to be called to interact with the dial peer (that collects the digits from the caller) before you configure the dial peer that will call this application.


SUMMARY STEPS

1. enable

2. configure terminal

3. call application voice

4. exit

DETAILED STEPS
 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

call application voice application-name location

Example:

Router(config)# call application voice ap1 172.16.4.4

Creates the application to be used with your IVR script and indicates the location of the corresponding Tcl files that implement this application. The location can be a URL, directory, or TFTP server.

Step 4 

exit

Example:

Router(config)# exit

Exits the current mode.

Configuring Supplementary Service for a POTS Dial Peer

To configure supplementary service for a POTS dial peer, perform the following steps.


NoteThe supplementary-service pass-through command controls the interpretation of supplementary service (QSIG, H.450, and so on) on a gateway. When the CLI is enabled (that is, set to passthrough mode), the supplementary service message (usually in Q.931 facility message) is transparently sent to the destination gateway without any interpretation (raw). When the CLI is not enabled (the default), the supplementary service message is decoded and interpreted by the gateway. This CLI is available under VoIP or POTS dial peers.

This CLI has effect only if a Tcl IVR 2.0 application is configured on the same dial peer. The default session application always performs transparent Q.SIG interworking. Tcl IVR 1.0 applications always interpret and consume the Q.SIG supplementary services messages.


SUMMARY STEPS

1. enable

2. configure terminal

3. dial-peer voice pots

4. application

5. supplementary-service pass-through

6. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

dial-peer voice tag pots

Example:

Router(config)# dial-peer voice 99 pots

Enters voice dial-peer configuration mode for the specified POTS dial peer.

Step 4 

application application-name

Example:

Router(config-dial-peer)# application ap1

Specifies the application that handles incoming voice calls associated with this dial-peer.

Step 5 

supplementary-service pass-through

Example:

Router(config-dial-peer)# supplementary-service pass-through

Configures supplementary service feature to transparently pass supplementary service to the next gateway.

Step 6 

exit

Example:

Router(config-dial-peer)# exit

Exits the current mode.

Configuring Supplementary Service for a VoIP Dial Peer

To configure supplementary service for a VoIP dial peer, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. dial-peer voice voip

4. application

5. supplementary-service pass-through

6. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

dial-peer voice tag voip

Example:

Router(config)# dial-peer voice 96 voip

Enters voice dial-peer configuration mode for the specified VoIP dial peer.

Step 4 

application application-name

Example:

Router(config-dial-peer)# application ap5

Specifies the application that handles incoming voice calls associated with this dial-peer.'

Step 5 

supplementary-service pass-through

Example:

Router(config-dial-peer)# supplementary-service pass-through

Configures supplementary service feature to transparently pass supplementary service to the next gateway.

Step 6 

exit

Example:

Router(config-dial-peer)# exit

Exits the current mode.

Verifying QSIG and Supplementary Service

To verify QSIG and supplementary service, perform the following steps (listed alphabetically).

SUMMARY STEPS

1. show isdn status

2. show running-config

DETAILED STEPS


Step 1 show isdn status

Use this command to display the status of all ISDN interfaces, including active layers, timer information, and switch-type settings.

Step 2 show running-config

Use this command to display the basic router configuration.


Configuration Example for QSIG for Tcl IVR 2.0

The following sample output is typical of that for implementation of supplementary service. ISDN supplementary service messages from PBX 1 are sent transparently to PBX 2 by routers 1 and 2 as if PBX 1 and PBX  2 were connected directly to each other.

Figure 16 QSIG for Tcl IVR 2.0: Sample Network Topology

Router# show running-config

Building configuration...

Current configuration :3531 bytes
!
version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
!
hostname router
!
no logging buffered
!
resource-pool disable
!
ip subnet-zero
ip host jurai 223.255.254.254
ip host dirt 223.255.254.254
ip host CALLGEN-SECURITY-V2 15.90.60.59 1.82.0.0
!
trunk group  323
!
isdn switch-type primary-ni
!
voice service pots
!
fax interface-type modem
mta receive maximum-recipients 0
partition flash 2 8 8
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 1 timeslots 1-4 type e&m-fgb dtmf dnis
 cas-custom 1
!
translation-rule 1
 Rule 1 ^.% 1
!
interface Ethernet0
 ip address 172.19.140.96 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 squelch reduced
!
interface Serial1:23
 no ip address
 no keepalive
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.140.1
ip route 223.255.254.254 255.255.255.255 1.8.0.1
no ip http server
!
snmp-server community public RW
snmp-server packetsize 4096
!
call rsvp-sync
!
voice-port 0:1
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 650 voip
 destination-pattern 650.......
 session target ipv4:1.8.50.14
!
dial-peer voice 100 pots
 application debit-card
 incoming called-number 650233....
 direct-inward-dial
 supplementary-service pass-through
 port 0:1
!
dial-peer voice 1001 voip
 incoming called-number 650233....
!
dial-peer voice 12345602 voip
 supplementary-service pass-through
!
dial-peer hunt 6
!
line con 0
 exec-timeout 0 0
 logging synchronous level all
line aux 0
line vty 0 4
 exec-timeout 60 0
 password lab
 login
!
end

Additional References

General ISDN References

"ISDN Features Roadmap" on page 1—Describes how to access Cisco Feature Navigator; also lists and describes, by Cisco IOS release, ISDN features for that release

"Overview of ISDN Voice Interfaces" on page 3—Describes relevant underlying technology; lists related documents, standards, MIBs, and RFCs; and describes how to obtain technical assistance

"Additional References" section on page 64—Lists additional ISDN references

References Mentioned in This Chapter

Cisco IOS IP and IP Routing Configuration Guide at http://www.cisco.com/univercd/cc/td/doc/product/access/acs_serv/as5400/sw_conf/ios_121/pulvoip1.htm

Cisco IOS Voice, Video, and Fax Configuration Guide at http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fvvfax_c/index.htm

Tcl scripts at http://www.cisco.com/cgi-bin/tablebuild.pl/tclware


CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.