This documentation has been moved
Basic ISDN Voice-Interface Configuration
Downloads: This chapterpdf (PDF - 487.0KB) The complete bookPDF (PDF - 1.58MB) | Feedback

Basic ISDN Voice-Interface Configuration

Table Of Contents

Basic ISDN Voice-Interface Configuration

Contents

Prerequisites for Configuring an ISDN Voice Interface

Restrictions for Configuring an ISDN Voice Interface

Information About ISDN Voice Interfaces

How to Configure an ISDN Voice Interface

Configuring a Router for ISDN BRI Voice-Interface Support

Configuring BRI NT and TE Interfaces

Verifying BRI Interfaces

Examples

Troubleshooting Tips

Configuring ISDN PRI Voice-Interface Support

Configuring PRI Interfaces

Configuring PRI Voice Ports

Verifying PRI Interfaces

Troubleshooting Tips

Configuring QSIG Support

Configure Global QSIG Support for BRI or PRI

Configure Controllers for QSIG over PRI

Configure PRI Interfaces for QSIG

Configure BRI Interfaces for QSIG

Verify the QSIG Configuration

Troubleshooting Tips

Examples

Configuring ISDN PRI Q.931 Support

Configuration Examples for ISDN Voice Interfaces

ISDN-to-PBX and ISDN-to-PSTN: Examples

QSIG Support: Examples

Q.931-Support: Example

Additional References


Basic ISDN Voice-Interface Configuration


This chapter describes how to configure ISDN BRI and PRI ports to support voice traffic.


Note For more information about related Cisco IOS voice features, see the following:

"Overview of ISDN Voice Interfaces" on page 3

Entire Cisco IOS Voice Configuration Library—including library preface and glossary, other feature documents, and troubleshooting documentation—at http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_voice_configuration_library_glossary/vcl.htm

For a list of references cited in this chapter, see the "Additional References" section.


Contents

Prerequisites for Configuring an ISDN Voice Interface

Restrictions for Configuring an ISDN Voice Interface

Information About ISDN Voice Interfaces

How to Configure an ISDN Voice Interface

Configuration Examples for ISDN Voice Interfaces

Additional References

Prerequisites for Configuring an ISDN Voice Interface

Perform the prerequisites that are listed in the "Prerequisites for Configuring ISDN Voice Interfaces" section on page 3.

Obtain PRI or BRI service and T1 or E1 service from your service provider, as required. Ensure that the BRI lines are provisioned at the switch to support voice calls.

Establish a working IP, Frame Relay, or ATM network. Ensure that at least one network module or WAN interface card is installed in the router to provide connection to the LAN or WAN.

Complete your company's dial plan.

Establish a working telephony network based on your company's dial plan and configure the network for real-time voice traffic.

Cisco 2600 series and Cisco 3600 series—Install digital T1 or E1 packet-voice trunk network modules, BRI voice interface cards, and other voice interface cards as required on your network.

Cisco 7200 series—Install a single-port 30-channel T1/E1 high-density voice port adapter.

Cisco MC3810—Install the required digital voice modules (DVMs), BRI voice module (BVM), and multiflex trunk modules.

Configure, for all platforms (as required), the following:

Voice card and controller settings

Serial and LAN interfaces

Voice ports

Voice dial peers

Restrictions for Configuring an ISDN Voice Interface

Restrictions are described in the "Restrictions for Configuring ISDN Voice Interfaces" section on page 4.

Information About ISDN Voice Interfaces

General information about ISDN voice interfaces is presented in the "Information About ISDN Voice Interfaces" section on page 4.

How to Configure an ISDN Voice Interface

Configuring a Router for ISDN BRI Voice-Interface Support

Configuring ISDN PRI Voice-Interface Support

Configuring QSIG Support

Configuring ISDN PRI Q.931 Support

Configuring a Router for ISDN BRI Voice-Interface Support

This section contains the following procedures:

Configuring BRI NT and TE Interfaces

Verifying BRI Interfaces

Configuring BRI NT and TE Interfaces

To configure BRI NT and TE interfaces, perform the following steps.


Note Set up each channel for either user side or network side.


SUMMARY STEPS

1. enable

2. configure terminal

3. isdn switch-type

4. interface bri

5. no ip address

6. isdn overlap-receiving

7. isdn twait-disable

8. isdn spid1

9. isdn spid2

10. isdn incoming-voice

11. shutdown

12. isdn layer1-emulate

13. no shutdown

14. network-clock-priority

15. line-power

16. isdn protocol-emulate

17. isdn sending-complete

18. isdn static-tei

19. isdn point-to-point-setup

20. exit

21. clear interface bri

22. Repeat for other interfaces

DETAILED STEPS
 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

isdn switch-type switch-type

Example:

Router(config)# isdn switch-type basic-qsig

Configures the telephone-company ISDN switch type. Table 3 on page 9 shows a list of switch types.

Note The only switch types currently supported for an NT interface are basic-net3 and basic-qsig.

Step 4 

Cisco MC3810

interface bri number

Other Supported Routers

interface bri slot/port

Example:

Router(config)# interface bri 1/1

Enters interface configuration mode for the specified port, connector, or interface card number (location of voice module) or slot/port (location of voice network module and voice interface card).

Step 5 

no ip address

Example:

Router(config-if)# no ip address

Specifies that there is no IP address for this interface.

Step 6 

isdn overlap-receiving
Example:

Router(config-if)# isdn overlap-receiving

(Optional) Activates overlap signaling to send to the destination PBX. In this mode, the interface waits for possible additional call-control information.

Step 7 

isdn twait-disable

Example:

Router(config-if)# isdn twait-disable

(Optional) Delays a national ISDN BRI switch for a random length of time before activating the Layer 2 interface at switch startup. Use this command when the ISDN switch type is basic-ni1. Twait time is enabled by default.

Step 8 

isdn spid1 spid-number [ldn]

Example:

Router(config-if)# isdn spid1 40855501220101

(Optional; TE only) Service-profile identifier (SPID) and optional local directory number for the B1 channel. Currently, only DMS-100 and NI-1 switch types require SPIDs. Although some switch types might support a SPID, Cisco recommends that you set up ISDN service without SPIDs.

Step 9 

isdn spid2 spid-number [ldn]

Example:

Router(config-if)# isdn spid2 40855501220102

(Optional; TE only) Specifies SPID and optional local directory number for the B2 channel.

Step 10 

isdn incoming-voice {voice | modem}

Example:

Router(config-if)# isdn incoming-voice voice

Configures the port to treat incoming ISDN voice calls as voice calls that are handled by either a modem or a voice DSP, as directed by the call-switching module.

Step 11 

shutdown

Example:

Router(config-if)# shutdown

Turns off the port (before setting port emulation).

Step 12 

isdn layer1-emulate user


or

isdn layer1-emulate network

Example:

Router(config-if)# isdn layer1-emulate user


or

Example:

Router(config-if)# isdn layer1-emulate network

(User side only) Configures Layer 1 port mode emulation and clock status for the user—that is, the TE (clock slave).

or

(Network side only) Configures Layer 1 port mode emulation and clock status for the network—that is, the NT (clock master).

Step 13 

no shutdown

Example:

Router(config-if)# no shutdown

Turns on the port.

Step 14 

network-clock-priority {low | high}

Example:

Router(config-if)# network-clock-priority low

(Optional; TE only) Sets priority for recovering clock signal from the network NT device for this BRI voice port. Keywords are as follows:

high—First priority (default for BRI voice interface cards)

low—Low priority (default for BRI voice modules)

Note Do not use this command if the port is configured as NT in Step 12.

Step 15 

Cisco MC3810 Only

line-power

Example:

Router(config-if)# line-power

Turns on the power supplied from an NT-configured port to a TE device.

Step 16 

isdn protocol-emulate user


or

isdn protocol-emulate network

Example:

Router(config-if)# isdn protocol-emulate user


or

Example:

Router(config-if)# isdn protocol-emulate network

(User side only) Configures Layer 2 and Layer 3 port mode emulation and clock status for the user—that is, the TE (clock master).

or

(Network side only) Configures Layer 2 and Layer 3 port mode emulation and clock status for the network—that is, the NT (clock slave).

Step 17 

isdn sending-complete

Example:

Router(config-if)# isdn sending-complete

(Optional) Configures the voice port to include the "Sending Complete" information element in the outgoing call-setup message. This command is used in some geographic locations, such as Hong Kong and Taiwan, where the "Sending Complete" information element is required in the outgoing call setup message.

Step 18 

isdn static-tei tei-number

Example:

Router(config-if)# isdn static-tei 0

(Optional) Configures a static ISDN Layer 2 terminal endpoint identifier (TEI).

Step 19 

isdn point-to-point-setup

Example:

Router(config-if)# isdn point-to-point-setup

(Optional) Configures the ISDN port to send SETUP messages on the static TEI (point-to-point link).

Note A static TEI must be configured in order for this command to be effective.

Step 20 

exit

Example:

Router(config-if)# exit

Exits the current mode.

Step 21 

Cisco MC3810

clear interface bri number

Other Supported Routers

clear interface bri slot/port

Example:

Router# clear interface bri 1/1

(Optional) Resets the specified port, connector, or interface card number (location of voice module) or slot/port (location of voice network module and voice interface card). The interface needs to be reset if the static TEI number was configured in Step 18.

Step 22 

Repeat the appropriate steps for the other BRI NT/TE interfaces.


Note To complete voice configuration, set up your voice ports and dial peers.


Verifying BRI Interfaces

To verify BRI interfaces, perform the following steps (listed alphabetically).

SUMMARY STEPS

1. show controllers bri

2. show interfaces bri

3. show isdn {active | history}

4. show isdn {memory | status | timers}

5. show isdn status

6. show running-config

7. show voice port

DETAILED STEPS


Step 1 show controllers bri number or show controllers bri slot/port

Use this command to display information about the specified BRI port, connector, or interface card number (location of voice module) or slot/port (location of voice network module and voice interface card).

Step 2 show interfaces bri

Use this command to display information about the physical attributes of the BRI B and D channels. In the output, look for the term spoofing, which indicates that the interface presents itself to the Cisco IOS software as operational.

Step 3 show isdn {active [serial-number] | history [serial-number]}

Use this command to display current (active keyword) or both historic and current (history keyword) call information for all ISDN interfaces or, optionally, a specific ISDN PRI interface (created and configured as a serial interface). Information displayed includes called number, remote node name, seconds of connect time, seconds of connect time remaining, seconds idle, and advice of charge (AOC) charging time units used during the call.

Step 4 show isdn {memory | status | timers}

Use this command to display information about memory, status, and Layer 2 and Layer 3 timers.

Step 5 show isdn status

Use this command to display the status of all ISDN interfaces, including active layers, timer information, and switch-type settings.

Step 6 show running-config

Use this command to display basic router configuration.

Step 7 show voice port [slot/port | summary]

Use this command to display information about BRI voice ports.


Examples

This section provides the following output examples:

Sample Output for the show running-config Command

Sample Output for the show interfaces bri Command

Sample Output for the show running-config Command

The following is sample output from a Cisco 2600 series system. Note that BRI1/0 and BRI1/1 are configured as ISDN user side and BRI2/0 and BRI2/1 are configured as ISDN network side. Table 4 describes significant fields shown in this output

Router# show running-config

Building configuration...
Current configuration:
!
version 12.2
!
no service udp-small-servers
service tcp-small-servers
!
hostname Router
!
username xxxx password x 11x5xx07
no ip domain-lookup
ip host Labhost 172.22.66.11
ip host Labhost2 172.22.66.12
ip name-server 172.22.66.21
!
.
.
.
interface BRI1/0
no ip address
no ip directed-broadcast
isdn switch-type basic-net3
isdn overlap-receiving
isdn T306 30000
isdn skipsend-idverify
isdn incoming-voice voice
!
interface BRI1/1
no ip address
no ip directed-broadcast
isdn switch-type basic-net3
isdn overlap-receiving
isdn T306 30000
isdn skipsend-idverify
isdn incoming-voice voice
!
interface BRI2/0
no ip address
isdn switch-type basic-net3
isdn overlap-receiving
isdn protocol-emulate network
isdn layer1-emulate network
isdn T306 30000
isdn sending-complete
isdn skipsend-idverify
isdn incoming-voice voice
!
interface BRI2/1
no ip address
isdn switch-type basic-net3
isdn overlap-receiving
isdn protocol-emulate network
isdn layer1-emulate network
isdn T306 30000
isdn sending-complete
isdn skipsend-idverify
isdn incoming-voice voice
!
.
.
.

The following is sample output from a Cisco MC3810 system. Table 4 describes significant fields shown in this output.

Router# show running-config

Building configuration...
Current configuration:
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
no logging console
!
network-clock base-rate 56k
network-clock-select 2 T1 0
network-clock-select 3 system(SCB)
network-clock-select 1 BVM
ip subnet-zero
!
isdn switch-type basic-net3
isdn voice-call-failure 0
call rsvp-sync
!
voice-card 0
!
controller T1 0
 mode atm
 framing esf
 linecode b8zs
!
interface BRI1
no ip address
isdn switch-type basic-net3
isdn protocol-emulate network
isdn layer1-emulate network
isdn incoming-voice voice
isdn T306 30000
isdn skipsend-idverify
no cdp enable
!
interface BRI2
no ip address
isdn switch-type basic-net3
isdn protocol-emulate network
isdn layer1-emulate network
isdn incoming-voice voice
isdn T306 30000
isdn skipsend-idverify
no cdp enable
!
interface BRI3
no ip address
shutdown
network-clock-priority low
isdn switch-type basic-net3
isdn T306 30000
no cdp enable
!
interface BRI4
no ip address
shutdown
network-clock-priority low
isdn switch-type basic-net3
isdn T306 30000
no cdp enable
!
.
.
.

Table 4 describes significant fields shown in these outputs.

Table 4 Significant Fields from the show running-config Command

Field
Description

isdn T306 timer-value

Value of the T306 timer, in ms.

An ISDN timer is started when a Q.931 Disconnect message with progress indicator number 8 is sent. The timer is stopped when a ISDN Release/Disconnect message is received from the other end. The call clears on expiration of the T306 timer.

isdn T310 timer-value

Value of the T310 timer, in ms.

An ISDN timer is started when a Q.931 Call Proceeding message is received. The timer is stopped when a Q.931 Alerting/Connect/Disconnect message is received from the other end. The call clears on expiration of the T310 timer.


Sample Output for the show interfaces bri Command

The following shows sample output for a Cisco 2610. Table 5 describes significant fields shown in this output.

Router# show interfaces bri 1/0

BRI3/1 is up, line protocol is up (spoofing)
  Hardware is Voice NT or TE BRI
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation VOICE, loopback not set
  Last input 00:00:02, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     26110 packets input, 104781 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 output buffer failures, 0 output buffers swapped out
     9 carrier transitions

The following shows sample output for a Cisco MC3810. Table 5 describes significant fields shown in this output.

Router# show interfaces bri 1

BRI1 is up, line protocol is up (spoofing)
  Hardware is BVM
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Last input 19:32:19, output 19:32:27, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     13282 packets input, 53486 bytes, 0 no buffer
     Received 1 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     13292 packets output, 53515 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 output buffer failures, 0 output buffers swapped out
     33 carrier transitions

Table 5 Significant Fields from the show interfaces bri Command 

Field (in alpha order)
Description

abort

Illegal sequence of one bits on a serial interface. This usually indicates a clocking problem between the serial interface and the data link equipment.

BRI... is {up | down | administratively down}

Whether the interface hardware is currently active (whether line signal is present) and whether it has been taken down by an administrator.

broadcasts

Total number of broadcast or multicast packets received by the interface.

BW

Bandwidth of the interface in kbps.

bytes

Total number of bytes, including data and media access control (MAC) encapsulation, in the error-free packets sent or received by the system.

carrier transitions

Number of times that the carrier detect signal of a serial interface has changed state. Check for modem or line problems if the carrier detect line is changing state often.

collisions

Number of collisions. These can occur when you have several devices connected on a multiport line.

CRC

Cyclic redundancy checksum generated by the originating station or far-end device does not match the checksum calculated from the data received. On a serial link, CRCs usually indicate noise, gain hits, or other transmission problems on the data link.

DLY

Delay of the interface in microseconds.

encapsulation

Encapsulation method assigned to interface.

five-minute input/output rate

Average number of bits and packets transmitted per second in the last 5 minutes.

frame

Number of packets that are received incorrectly having a CRC error and a noninteger number of octets. On a serial line, this is usually the result of noise or other transmission problems.

giants

Number of packets that are discarded because they exceed the medium's maximum packet size.

Hardware is...

Hardware type.

ignored

Number of received packets that are ignored by the interface because the interface hardware ran low on internal buffers. Broadcast storms and bursts of noise can increase the ignored count.

input errors

Total number of no buffer, runts, giants, CRCs, frame, overrun, ignored, and abort counts. Other input-related errors can also increment the count, so this sum may not balance with the other counts.

input/output queue, drops

Number of packets in output and input queues. Each number is followed by a slash (/), the maximum size of the queue, and the number of packets dropped due to a full queue.

interface resets

Number of times that an interface has been completely reset. This can happen if packets queued for transmission were not sent within several seconds. On a serial line, this can be caused by a malfunctioning modem that is not supplying the transmit clock signal or by a cable problem. If the system recognizes that the carrier detect line of a serial interface is up, but the line protocol is down, it periodically resets the interface in an effort to restart it. Interface resets can also occur when an interface is looped back or shut down.

Internet address is...

IP address and subnet mask, followed by packet size.

keepalive

Whether keepalives are set.

last input

Number of hours, minutes, and seconds since the last packet was successfully received by an interface. Useful for knowing when a nonfunctioning interface failed.

line protocol is {up | down | administratively down}

Whether the software processes that handle the line protocol consider the line usable (that is, whether keepalives are successful).

load

Load on the interface as a fraction of 255 (255/255 is completely saturated), calculated as an exponential average over 5 minutes.

loopback

Whether loopback is set.

MTU

Maximum transmission unit of the interface.

no buffer

Number of received packets that are discarded because there was no buffer space in the main system. Compare with ignored count. Broadcast storms on Ethernets and bursts of noise on serial lines are often responsible for no input buffer events.

output

Number of hours, minutes, and seconds since the last packet was successfully transmitted by an interface.

output errors

Sum of all errors that prevented the final transmission of datagrams out of the interface being examined. Note that this may not balance with the sum of the enumerated output errors, because some datagrams may have more than one error, and others may have errors that do not fall into any of the specifically tabulated categories.

output hang

Number of hours, minutes, and seconds (or never) since the interface was last reset because of a transmission that took too long. When the number of hours in any of the "last" fields exceeds 24 hours, the number of days and hours is printed. If that field overflows, asterisks (**) are printed.

output/input queue, drops

Number of packets in output and input queues. Each number is followed by a slash (/), the maximum size of the queue, and the number of packets dropped due to a full queue.

overrun

Number of times that the serial receiver hardware was unable to hand received data to a hardware buffer because the input rate exceeded the receiver's ability to handle the data.

packets input/output

Total number of error-free packets received or sent by the system.

rely

Reliability of the interface as a fraction of 255 (255/255 is 100 percent reliability), calculated as an exponential average over 5 minutes.

restarts

Number of times that the controller was restarted because of errors

runts

Number of packets that are discarded because they are smaller than the medium's minimum packet size.

underruns

Number of times that the transmitter has been running faster than the router can handle. This may never be reported on some interfaces.


Troubleshooting Tips

Use the debug isdn q921 command to display Layer 2 access procedures that are taking place at the router on the D channel (LAPD) of its ISDN interface.

Use the debug isdn q931 command to display information about call setup and teardown of ISDN network connections (Layer 3) between the local router (user side) and the network.

For information on these and additional debug commands, see the following references:

Cisco IOS Debug Command Reference, Release 12.3T at http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123tcr/123dbr/index.htm

Cisco IOS Voice Troubleshooting and Monitoring Guide at http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/vvfax_c/voipt_c/index.htm

Configuring ISDN PRI Voice-Interface Support

This section contains the following procedures:

Configuring PRI Interfaces

Configuring PRI Voice Ports

Verifying PRI Interfaces

Troubleshooting Tips

Configuring PRI Interfaces

To configure PRI interfaces, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. isdn switch-type

4. controller

5. description

6. framing esf

7. linecode

8. pri-group timeslots

9. exit

10. interface serial

11. isdn incoming-voice modem

12. description

13. isdn-bchan-number-order

14. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

isdn switch-type switch-type

Example:

Router(config)# isdn switch-type basic-qsig

Configures the telephone company ISDN switch type. Table 3 on page 9 shows a list of switch types.

Note The only switch types currently supported for an NT interface are basic-net3 and basic-qsig.

Step 4 

Cisco AS5300

controller {t1 | e1} 0

Cisco AS5800 (T1 card)

controller t1 1/0/0

Cisco AS5800 (T3 card)

controller t1 1/0/0:1

Example:

Router(config)# controller t1 1/0/0

Enters T1/E1 controller configuration mode for the specified (as appropriate) dial shelf, slot, port (or T3 port), and timeslot as follows:

Cisco AS5300: T1 0 or E1 0 controller

Cisco AS5800 (T1 card): T1 0 controller

Cisco AS5800 (T3 card): T1 1 controller

Step 5 

description string

Example:

Router(config-if)# description interface01

Includes a specific description about the digital signal processor (DSP) interface.

Step 6 

framing esf

Example:

Router(config-controller)# framing esf

Defines the framing characteristics.

Step 7 

linecode {ami | b8zs | hdb3}

Example:

Router(config-controller)# linecode ami

Sets the line-encoding method to match that of your telephone-company service provider. Keywords are as follows:

ami—Alternate mark inversion (AMI), valid for T1 or E1 controllers. Default for T1 lines.

b8zs—B8ZS, valid for T1 controllers only.

hdb3—High-density bipolar 3 (hdb3), valid for E1 controllers only. Default for E1 lines.

Step 8 

pri-group timeslots range

Example:

Router(config-controller)# pri-group timeslots 1-23

Specifies PRI on the specified or timeslots that make up the PRI group. Maximum T1 range: 1 to 23. Maximum E1 range: 1 to 31. Separate low and high values with a hyphen.

Note You can configure the PRI group to include all available timeslots, or you can configure a select group of timeslots for the PRI group.

Step 9 

exit

Example:

Router(config-controller)# exit

Exits the current mode.

Step 10 

Cisco AS5300

interface serial 0:channel-number

Cisco AS5800

interface serial 1/0:channel-number

Example:

Router(config)# interface serial 0:23

Enters interface configuration mode for the specified PRI slot/port and D-channel ISDN interface. D-channel ISDN interface is (for T1) 23 and (for E1) 15.

Step 11 

isdn incoming-voice modem

Example:

Router(config-if)# isdn incoming-voice modem

Enables incoming ISDN voice calls.

The modem keyword specifies that incoming voice calls are passed over to digital modems, where they negotiate the appropriate modem connection with the far-end modem. Its use here is required.

Step 12 

description string

Example:

Router(config-if)# description interface02

Includes a specific description about the digital signal processor (DSP) interface.

Step 13 

isdn-bchan-number-order {ascending | descending}

Example:

Router(config-if)# isdn-bchan-number-order descending

Configures an ISDN PRI interface to make outgoing call selection in ascending or descending order—that is, to select the lowest or highest available B channel starting at either channel B1 (ascending) or channel B23 for a T1 and channel B30 for an E1 (descending). Default: descending.

Note Before configuring ISDN PRI on your router, check with your service vendor to determine if ISDN trunk call selection is configured for ascending or descending order. A mismatch between router and switch causes the switch to send an error message stating that the channel is not available.

Step 14 

exit

Example:

Router(config-if)# exit

Exits the current mode.

Configuring PRI Voice Ports

Under most circumstances, default voice-port command values are adequate to configure voice ports to transport voice data over your existing IP network. However, because of the inherent complexities of PBX networks, you might need to configure specific voice-port values, depending on the specifications of the devices in your network.

Verifying PRI Interfaces

To verify PRI interfaces, perform the following steps (listed alphabetically).

SUMMARY STEPS

1. show isdn {active | history}

2. show isdn status

3. show vfc version

4. show voice port

DETAILED STEPS


Step 1 show isdn {active [serial-number] | history [serial-number]}

Use this command to display current (active keyword) or both historic and current (history keyword) call information for all ISDN interfaces or, optionally, a specific ISDN PRI interface (created and configured as a serial interface). Information displayed includes called number, remote node name, seconds of connect time, seconds of connect time remaining, seconds idle, and advice of charge (AOC) charging time units used during the call.

Step 2 show isdn status

Use this command to display the status of all ISDN interfaces, including active layers, timer information, and switch-type settings.

Step 3 show vfc slot version

Use this command to display the version of software residing on the voice feature card in the specified slot.

Step 4 show voice port [slot/port | summary]

Use this command to display configuration information about a specific voice port.


Troubleshooting Tips

Verify that you have dial tone and connectivity.

If you have not configured your device to support Direct Inward Dialing (DID), do the following:

1. Dial in to the router and verify that you have dial tone.

2. Enter a dual-tone multifrequency (DTMF) digit. If dial tone stops, you have verified two-way voice connectivity with the router.

If you have trouble connecting a call and suspect that the problem is associated with voice-port configuration, do the following:

1. Confirm connectivity by pinging the associated IP address.


Note For more information, see the Cisco IOS IP Configuration Guide chapter on configuring IP.


2. Determine if the voice feature card (VFC) is installed correctly.


Note For more information, see the instructions that came with your voice network module.


3. Ensure that your (T1-line) a-law or (E1-line) mu-law setting is correct.

If dialing cannot occur, use the debug isdn q931 command to check the ISDN configuration.


Note For T1 troubleshooting information, see http://www.cisco.com/en/US/tech/tk713/tk628/technologies_tech_note09186a00800a5f40.shtml


Configuring QSIG Support

This section contains the following procedures:

Configure Global QSIG Support for BRI or PRI

Configure Controllers for QSIG over PRI (required for PRI)

Configure PRI Interfaces for QSIG (required for PRI)

Configure BRI Interfaces for QSIG (required for BRI)

Verify the QSIG Configuration (required)

Configure Global QSIG Support for BRI or PRI

To configure global QSIG support for BRI or PRI, perform the following steps.


Note For additional guidance on switch-type configuration, see the "ISDN Switch Types for Use with QSIG" section on page 9.


SUMMARY STEPS

1. enable

2. configure terminal

3. isdn switch-type

4. dspint dspfarm

5. card type

6. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

BRI on Cisco MC3810, Cisco 2600 Series, and Cisco 3600 Series

isdn switch-type basic-qsig

PRI on Any Supported Router

isdn switch-type primary-qsig

Example:

Router(config)# isdn switch-type basic-qsig

(Optional) Configures the global ISDN switch type to support QSIG signaling. Table 2 on page 9 shows a list of switch types.

Note You can configure all interfaces at once by using this command in global configuration mode. Or you can configure one interface at a time by using this command in interface configuration mode.

Step 4 

BRI or PRI on Cisco 7200 Series

dspint dspfarm slot/port

Example:

Router(config)# dspint dspfarm 1/1

Configures the digital signal processor (DSP) farm at the specified slot/port.

Step 5 

BRI or PRI on Cisco 7200 Series

card type {t1 | e1} slot

Example:

Router(config)# card type t1 0

Configures card type (T1 or E1) at the specified slot.

Step 6 

exit

Example:

Router(config)# exit

Exits the current mode.

Configure Controllers for QSIG over PRI

To configure controllers for QSIG over PRI, perform the following steps.


Note Steps in this section apply to PRI only, and not to BRI.


SUMMARY STEPS

1. enable

2. configure terminal

3. controller

4. pri-group timeslots

5. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

Cisco MC3810

controller {t1 | e1} controller-number

Other Supported Routers

controller {t1 | e1} slot/port

Example:

Router(config)# controller t1 1/1

Enters T1 or E1 controller configuration mode for the specified controller number o r slot/port.

Note Cisco MC3810 supports QSIG only on controller 1.

Step 4 

pri-group timeslots range

Example:

Router(config-controller)# pri-group timeslots 1-23

Specifies PRI on the specified or timeslots that make up the PRI group. Maximum T1 range: 1-23. Maximum E1 range: 1-31. Separate low and high values with a hyphen.

Note You can configure the PRI group to include all available timeslots, or you can configure a select group of timeslots for the PRI group.

Step 5 

exit

Example:

Router(config-controller)# exit

Exits the current mode.

Configure PRI Interfaces for QSIG

To configure PRI interfaces for QSIG, perform the following steps.


Note Set up each channel for either user side or network side.


SUMMARY STEPS

1. enable

2. configure terminal

3. interface serial

4. isdn switch-type primary-qsig

5. isdn contiguous-bchan

6. isdn protocol-emulate

7. isdn overlap-receiving

8. isdn network-failure-cause

9. exit

DETAILED STEPS
 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

Cisco MC3810

interface serial 1:channel-number

Other Supported Routers

interface serial slot/port:channel-number

Example:

Router(config)# interface serial 1/1:23

Enters interface configuration mode for the specified PRI slot/port and D-channel ISDN interface. D-channel ISDN interface is (for T1) 23 and (for E1) 15.

Step 4 

isdn switch-type primary-qsig

Example:

Router(config-if)# isdn switch-type primary-qsig

If you did not configure the global PRI ISDN switch type for QSIG support in global configuration mode, configures the interface ISDN switch type to support QSIG signaling.

Conditions that apply to this command in global configuration mode also apply in interface configuration mode. For more information, see the "ISDN Switch Types for Use with QSIG" section on page 9.

Note For this interface, this interface configuration command overrides the setting of the isdn switch-type command entered in global configuration mode.

Step 5 

isdn contiguous-bchan

Example:

Router(config-if)# isdn contiguous-bchan

(E1 only) Sets contiguous bearer-channel handling, causing B channels 1 to 30 to map to timeslots 1 to 31, skipping timeslot 16.

Step 6 

isdn protocol-emulate user


or

isdn protocol-emulate network

Example:

Router(config-if)# isdn protocol-emulate user


or

Example:

Router(config-if)# isdn protocol-emulate network

(User side only) Configures Layer 2 and Layer 3 port mode emulation and clock status for the user—that is, the TE (clock slave). This is the default.

or

(Network side only) Configures Layer 2 and Layer 3 port mode emulation and clock status for the network—that is, the NT (clock master).

Note On the Cisco MC3810, the isdn protocol-emulate command replaces the isdn switch-type command.

Step 7 

isdn overlap-receiving

Example:

Router(config-if)# isdn overlap-receiving

(Optional) Activates overlap signaling to send to the destination PBX. The interface waits for possible additional call-control information from the preceding PBX.

Note You can leave the default mode of enbloc, in which all call-setup information is sent in the setup message without need for additional messages from the preceding PINX.

Step 8 

isdn network-failure-cause value

Example:

Router(config-if)# isdn network-failure-cause 1

(Optional) Specifies the cause code to pass to the PBX when a call cannot be placed or completed because of internal network failures.

Step 9 

exit

Example:

Router(config-if)# exit

Exits the current mode.

Configure BRI Interfaces for QSIG

To configure BRI interfaces for QSIG, perform the following steps.


Note Set up each interface for either user side or network side.


SUMMARY STEPS

1. enable

2. configure terminal

3. interface bri

4. isdn static-tei tei-number

5. isdn layer1-emulate user

6. isdn layer1-emulate network

7. network-clock-priority

8. isdn incoming-voice voice

9. isdn sending-complete

10. isdn switch-type basic-qsig

11. isdn protocol-emulate

12. isdn overlap-receiving

13. isdn network-failure-cause

14. exit

DETAILED STEPS
 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

Cisco MC3810

interface bri number

Cisco 2600 Series and Cisco 3600 Series

interface bri slot/port

Example:

Router(config)# interface bri 1/1

Enters interface configuration mode for the specified port, connector, or interface card number (location of voice module) or slot/port (location of voice network module and voice interface card).

Step 4 

Cisco MC3810, Cisco 2600 Series, and Cisco 3600 Series Only

isdn static-tei tei-number

Example:

Router(config-if)# isdn static-tei 0

Enables use of the ISDN lines.

Note This command is required. In previous releases, it was set automatically with use of the isdn switch-type basic-qsig command.

Step 5 

Cisco MC3810 Only

isdn layer1-emulate user

Example:

Router(config-if)# isdn layer1-emulate user

Configures Layer 1 port mode emulation and clock status for the user—that is, the TE (clock slave).

Step 6 

Cisco MC3810 Only

isdn layer1-emulate network

Example:

Router(config-if)# isdn layer1-emulate network

Configures Layer 1 port mode emulation and clock status for the network—that is, the NT (clock master).

Step 7 

Cisco MC3810 Only

network-clock-priority {low | high}

Example:

Router(config-if)# network-clock-priority high

(TE only) Sets priority for recovering clock signal from the network NT device for this BRI voice port. Keywords are as follows:

high—First priority

low—Low priority

Note Do not use this command if the port is configured as NT in Step 5.

Step 8 

Cisco 2600 Series and Cisco 3600 Series Only

isdn incoming-voice voice

Example:

Router(config-if)# isdn incoming-voice voice

Routes incoming voice calls. This is set for voice-capable BRI interfaces by default. The exception is for Cisco 2600 series and Cisco 3600 series BRI S/T TE voice interface cards, where, in the absence of this command, the isdn incoming-voice modem configuration setting converts to isdn incoming-voice voice when it receives an incoming call.

Step 9 

isdn sending-complete

Example:

Router(config-if)# isdn sending-complete

(Optional) Configures the voice port to include the "Sending Complete" information element in the outgoing call-setup message. This command is used in some geographic locations, such as Hong Kong and Taiwan, where the "Sending Complete" information element is required in the outgoing call-setup message.

Step 10 

Cisco MC3810, Cisco 2600, and Cisco 3600 Series Only

isdn switch-type basic-qsig

Example:

Router(config-if)# isdn switch-type basic-qsig

(Optional) If the service-provider switch type for this BRI port differs from the global ISDN switch type, set the interface ISDN switch type to match the service-provider switch type. The interface ISDN switch type overrides the global ISDN switch type on this interface.

For more information, see the "ISDN Switch Types for Use with QSIG" section on page 9.

Step 11 

isdn protocol-emulate user


or

isdn protocol-emulate network

Example:

Router(config-if)# isdn protocol-emulate user


or

Example:

Router(config-if)# isdn protocol-emulate network

(User side only) Configures Layer 2 and Layer 3 port mode emulation and clock status for the user—that is, the TE (clock slave).

or

(Network side only) Configures Layer 2 and Layer 3 port mode emulation and clock status for the network—that is, the NT (clock master).

Note On the Cisco MC3810, the isdn protocol-emulate command replaces the isdn switch-type command.

Step 12 

isdn overlap-receiving

Example:

Router(config-if)# isdn overlap-receiving

(Optional) Activates overlap signaling to send to the destination PBX and causes the interface to wait for possible additional call-control information from the preceding PINX.

Note You can leave the default mode of enbloc, in which all call-setup information is sent in the setup message without need for additional messages from the preceding PINX.

Step 13 

isdn network-failure-cause value

Example:

Router(config-if)# isdn network-failure-cause 1

(Optional) Specifies the cause code to pass to the PBX when a call cannot be placed or completed because of internal network failures.

Step 14 

exit

Example:

Router(config-if)# exit

Exits the current mode.

Verify the QSIG Configuration

To verify the QSIG configuration, perform the following steps (listed alphabetically).

SUMMARY STEPS

1. show call history voice record

2. show cdapi

3. show controllers t1 or show controllers e1

4. show dial-peer voice

5. show isdn

6. show isdn {active | history}

7. show isdn service

8. show isdn status

9. show rawmsg

10. show running-config

11. show voice port

DETAILED STEPS


Step 1 show call history voice record

Use this command to display information about calls made to and from the router.

Step 2 show cdapi

Use this command to display Call Distributor Application Programming Interface (CDAPI) information.

Step 3 show controllers t1 or show controllers e1

Use this command to display information about T1 and E1 controllers.

Step 4 show dial-peer voice

Use this command to display how voice dial peers are configured.

Step 5 show isdn

Use this command to display information about switch type, memory, status, and Layer 2 and Layer 3 timers.

Step 6 show isdn {active [serial-number] | history [serial-number]}

Use this command to display current (active keyword) or both historic and current (history keyword) call information for all ISDN interfaces or, optionally, a specific ISDN PRI interface (created and configured as a serial interface). Information displayed includes called number, remote node name, seconds of connect time, seconds of connect time remaining, seconds idle, and advice of charge (AOC) charging time units used during the call.

Step 7 show isdn service

Use this command to display the state and the service status of each ISDN channel.

Step 8 show isdn status

Use this command to display the status of all ISDN interfaces, including active layers, timer information, and switch-type settings.

Step 9 show rawmsg

Use this command to display information about memory leaks.

Step 10 show running-config

Use this command to display basic router configuration.

Step 11 show voice port [slot/port | summary]

Use this command to display summary information about voice-port configuration.


Troubleshooting Tips

Use the debug cdapi {events | detail} command to display information about CDAPI application events, registration, messages, and more.

Use the debug isdn event command to display events occurring on the user side (on the router) of the ISDN interface. ISDN events that can be displayed are Q.931 events (call setup and teardown of ISDN network connections).

Use the debug tsp command to display information about the telephony-service provider (TSP).

Examples

This section provides the following output examples:

Sample Output for the show cdapi Command

Sample Output for the show controller Command

Sample Output for the show isdn service Command

Sample Output for the show isdn status Command


Sample Output for the show cdapi Command

The following shows sample output for a PRI voice port on a Cisco 3660 series.

Router# show cdapi

Registered CDAPI Applications/Stacks
====================================

Application: TSP CDAPI Application Voice
        Application Type(s) : Voice Facility Signaling
        Application Level   : Tunnel
        Application Mode    : Enbloc

Signaling Stack: ISDN
        Interface: Se5/0:15

Signaling Stack: ISDN
        Interface: Se5/1:15

Signaling Stack: ISDN
        Interface: Se6/0:15

Signaling Stack: ISDN
        Interface: Se6/1:15

CDAPI Message Buffers
=====================

Used Msg Buffers: 0, Free Msg Buffers: 9600
Used Raw Buffers: 0, Free Raw Buffers: 4800
Used Large-Raw Buffers: 0, Free Large-Raw Buffers: 480

The following shows sample output for a PRI voice port on a Cisco MC3810.

Router# show cdapi

Registered CDAPI Applications/Stacks
====================================

Application: TSP CDAPI Application Voice
        Application Type(s) : Voice Facility Signaling
        Application Level   : Tunnel
        Application Mode    : Enbloc

Signaling Stack: ISDN
        Interface: Se1:15

CDAPI Message Buffers
=====================

Used Msg Buffers: 2, Free Msg Buffers: 1198
Used Raw Buffers: 2, Free Raw Buffers: 598
Used Large-Raw Buffers: 0, Free Large-Raw Buffers: 60

Sample Output for the show controller Command

The following shows sample output for a T1 line (not having problems).

Router# show controller T1

T1 3/0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20020812, FPGA: 11
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  Data in current interval (425 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

The following shows sample output for a T1 line (having problems).

Router# show controller T1 2

T1 2 is down.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  Transmitter is sending remote alarm.
  Receiver has loss of signal.
  alarm-trigger is not set
  Version info of slot 0:  HW: 4, PLD Rev: 0

Manufacture Cookie Info:
 EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x42,
 Board Hardware Version 1.32, Item Number 800-2540-02,
 Board Revision A0, Serial Number 15264519,
 PLD/ISP Version 0.0,  Manufacture Date 24-Sep-1999.

  Framing is SF, Line Code is AMI, Clock Source is Internal.
  Data in current interval (329 seconds elapsed):
     1 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 329 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 329 Unavail Secs
  Total Data (last 24 hours)
     543 Line Code Violations, 0 Path Code Violations,
     3 Slip Secs, 86400 Fr Loss Secs, 364 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 86400 Unavail Secs

Sample Output for the show isdn service Command

The following shows sample output for a PRI on a T1 controller.

Router# show isdn service

PRI Channel Statistics:
ISDN Se0:15, Channel (1-31)
  Activated dsl 8
  State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

Sample Output for the show isdn status Command

The following shows sample output for a BRI voice port on a Cisco 3600 series.

Router# show isdn status

Global ISDN Switchtype = primary-qsig
ISDN Serial3/1:15 interface
        dsl 0, interface ISDN Switchtype = primary-qsig
         **** Master side configuration ****
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        29 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 29
        CCB:callid=89BF, sapi=0, ces=0, B-chan=5, calltype=VOICE
.
.
.
CCB:callid=89C8, sapi=0, ces=0, B-chan=14, calltype=VOICE
.
.
.
        CCB:callid=89D9, sapi=0, ces=0, B-chan=1, calltype=VOICE
        CCB:callid=89DA, sapi=0, ces=0, B-chan=2, calltype=VOICE
        CCB:callid=89DB, sapi=0, ces=0, B-chan=3, calltype=VOICE
    The Free Channel Mask: 0x80000018
ISDN Serial3/0:15 interface
        dsl 1, interface ISDN Switchtype = primary-qsig
         **** Master side configuration ****
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI = 0, Ces = 9, SAPI = 16, State = TEI_ASSIGNED
    Layer 3 Status:
        28 Active Layer 3 Call(s)
    Activated dsl 1 CCBs = 28
        CCB:callid=BDF, sapi=0, ces=0, B-chan=2, calltype=VOICE
        CCB:callid=BE0, sapi=0, ces=0, B-chan=1, calltype=VOICE
        CCB:callid=BE1, sapi=0, ces=0, B-chan=3, calltype=VOICE
.
.
.
CCB:callid=BFA, sapi=0, ces=0, B-chan=31, calltype=VOICE
    The Free Channel Mask: 0xB0000000
    Total Allocated ISDN CCBs = 54

Total Allocated ISDN CCBs = 0
.
.
.
CCB:callid=89C8, sapi=0, ces=0, B-chan=14, calltype=VOICE
.
.
.
        CCB:callid=89D9, sapi=0, ces=0, B-chan=1, calltype=VOICE
        CCB:callid=89DA, sapi=0, ces=0, B-chan=2, calltype=VOICE
        CCB:callid=89DB, sapi=0, ces=0, B-chan=3, calltype=VOICE
    The Free Channel Mask: 0x80000018
ISDN Serial3/0:15 interface
        dsl 1, interface ISDN Switchtype = primary-qsig
         **** Master side configuration ****
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI = 0, Ces = 9, SAPI = 16, State = TEI_ASSIGNED
    Layer 3 Status:
        28 Active Layer 3 Call(s)
    Activated dsl 1 CCBs = 28
        CCB:callid=BDF, sapi=0, ces=0, B-chan=2, calltype=VOICE
        CCB:callid=BE0, sapi=0, ces=0, B-chan=1, calltype=VOICE
        CCB:callid=BE1, sapi=0, ces=0, B-chan=3, calltype=VOICE
.
.
.
CCB:callid=BFA, sapi=0, ces=0, B-chan=31, calltype=VOICE
    The Free Channel Mask: 0xB0000000
    Total Allocated ISDN CCBs = 54

The following shows sample output for a BRI voice port and a PRI voice port on a Cisco MC3810.

Router# show isdn status

Global ISDN Switchtype = basic-qsig
ISDN BRI1 interface
dsl 1, interface ISDN Switchtype = basic-qsig
**** Slave side configuration ****
    Layer 1 Status:
DEACTIVATED
    Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
NLCB:callid=0x0, callref=0x0, state=31, ces=0 event=0x0
0 Active Layer 3 Call(s)
    Activated dsl 1 CCBs = 0
ISDN BRI2 interface
.
.
.

Router# show isdn status

     Global ISDN Switchtype = primary-qsig
     ISDN Serial1:23 interface
             dsl 0, interface ISDN Switchtype = primary-qsig
              **** Slave side configuration ****
         Layer 1 Status:
             DEACTIVATED
         Layer 2 Status:
             TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
         Layer 3 Status:
             0 Active Layer 3 Call(s)
         Activated dsl 0 CCBs = 0
         The Free Channel Mask: 0x7FFFFF

The following shows sample output for a PRI voice port on a Cisco 7200 series.

Router# show isdn status

Global ISDN Switchtype = primary-qsig
ISDN Serial1/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-qsig
         **** Slave side configuration ****
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask:  0x7FFF7FFF
ISDN Serial1/1:15 interface
        dsl 1, interface ISDN Switchtype = primary-qsig
         **** Slave side configuration ****
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 1 CCBs = 0
    The Free Channel Mask:  0x7FFF7FFF
    Total Allocated ISDN CCBs = 0

Configuring ISDN PRI Q.931 Support

To configure ISDN PRI Q.931 support, perform the following steps.


NoteUse these commands on Cisco 2600 series and Cisco 3600 series only.

Set up each interface for either user side or network side.


SUMMARY STEPS

1. enable

2. configure terminal

3. isdn switch-type primary-net5

4. controller

5. pri-group timeslots

6. exit

7. interface serial

8. isdn protocol-emulate

9. line-power

10. isdn incoming-voice voice

11. exit

DETAILED STEPS
 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters configuration mode.

Step 3 

isdn switch-type primary-net5

Example:

Router(config)# isdn switch-type primary-net5

(Optional) Selects a service-provider switch type that accommodates PRI.

You can set the ISDN switch type in either global configuration mode or interface configuration mode.

Global configuration mode (this step): specify the switch type for all PRI ports.

Interface configuration mode: specify the switch type for a single interface. The type specified in this mode for any individual interface overrides the type specified in global configuration mode.

Step 4 

controller {t1 | e1} slot/port

Example:

Router(config)# controller t1 1/1

Enters T1 or E1 controller configuration mode for the specified slot/port.

Step 5 

pri-group timeslots range

Example:

Router(config-controller)# pri-group timeslots 1-23

Specifies PRI on the specified or timeslots that make up the PRI group. Maximum T1 range: 1-23. Maximum E1 range: 1-31. Separate low and high values with a hyphen.

Note You can configure the PRI group to include all available timeslots, or you can configure a select group of timeslots for the PRI group.

Step 6 

exit

Example:

Router(config-controller)# exit

Exits the current mode.

Step 7 

interface serial 0/0:channel-number

Example:

Router(config)# interface serial 0/0:23

Enters interface configuration mode for the specified PRI slot/port and D-channel ISDN interface. D-channel ISDN interface is (for T1) 23 and (for E1) 15.

Step 8 

isdn protocol-emulate user


or

isdn protocol-emulate network

Example:

Router(config-if)# isdn protocol-emulate user


or

Example:

Router(config-if)# isdn protocol-emulate network

(User side only) Configures Layer 2 and Layer 3 port mode emulation and clock status for the user—that is, the TE (clock slave).

or

(Network side only) Configures Layer 2 and Layer 3 port mode emulation and clock status for the network—that is, the NT (clock master).

Step 9 

line-power

Example:

Router(config-if)# line-power

Turns on the power supplied from an NT-configured port to a TE device.

Step 10 

isdn incoming-voice voice

Example:

Router(config-if)# isdn incoming-voice voice

Routes incoming ISDN voice calls to the voice module.

Step 11 

exit

Example:

Router(config-if)# exit

Exits the current mode.

Configuration Examples for ISDN Voice Interfaces

ISDN-to-PBX and ISDN-to-PSTN: Examples

QSIG Support: Examples

Q.931-Support: Example

ISDN-to-PBX and ISDN-to-PSTN: Examples

This section contains the following configuration examples:

ISDN Connection to a PBX Configuration (Network-Side Emulation)

ISDN Connection to the PSTN Configuration (User-Side Emulation)

Configuration examples included in this section correspond to the topology shown in Figure 4. The routers each include a BRI voice interface card and a two-slot voice network module, along with other voice interface cards and modules that are included for completeness. Router A is connected to a PBX through the BRI voice interface card and to Router B by a serial interface. Router B includes a BRI voice interface card for connection to the PSTN in order to process voice calls from off-premises terminal equipment. Router A is configured for ISDN BRI network-side emulation and Router B is configured for ISDN BRI user-side emulation.

Figure 4 Configuration Example Topology

ISDN Connection to a PBX Configuration (Network-Side Emulation)

The following illustrates the configuration of the BRI interfaces on a Cisco 3640 (Router A in Figure 4) connected to a PBX:

interface BRI1/0
no ip address
isdn switch-type basic-net3
isdn overlap-receiving
isdn protocol-emulate network
isdn layer1-emulate network
isdn T306 30000
isdn sending-complete
isdn skipsend-idverify
isdn incoming-voice voice
!
interface BRI1/1
	no ip address
isdn switch-type basic-net3
isdn overlap-receiving
isdn protocol-emulate network
isdn layer1-emulate network
isdn T306 30000
isdn sending-complete
isdn skipsend-idverify
isdn incoming-voice voice
!
ip default-gateway 1.14.0.1
ip classless
ip route 2.0.0.0 255.0.0.0 Ethernet0/1
ip route 2.0.0.0 255.0.0.0 Serial0/1
ip route 172.22.66.33 255.255.255.255 Ethernet0/0
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login

ISDN Connection to the PSTN Configuration (User-Side Emulation)

The following illustrates the configuration of the BRI interfaces on a Cisco 2600 series (Router B in Figure 4) connected to the public ISDN telephone network:

interface BRI1/0
no ip address
 no ip directed-broadcast
 isdn switch-type basic-ni1
 isdn twait-disable
 isdn spid1 14085552111 5552111
 isdn spid2 14085552112 5552112
 isdn incoming-voice voice

interface BRI1/1
 no ip address
 no ip directed-broadcast
 isdn switch-type basic-ni1
 isdn twait-disable
 isdn spid1 14085552111 5552111
 isdn spid2 14085552112 5552112
 isdn incoming-voice voice
!
ip classless
ip route 3.0.0.0 255.0.0.0 Ethernet0/1
ip route 3.0.0.0 255.0.0.0 Serial0/1
ip route 172.21.66.0 255.255.255.0 Ethernet0/0
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login

QSIG Support: Examples

The following show QSIG configurations on a variety of supported routers:

QSIG Support on Cisco 3600 Series Routers

QSIG Support on Cisco 7200 Series Routers

QSIG Support on Cisco MC3810 Multiservice Concentrators

QSIG Support on Cisco 3600 Series Routers

The following shows how a Cisco 3660 series can be configured for E1 and PRI with QSIG signaling support using VoIP and VoATM. Note that Serial5/0, Serial5/1, Serial6/0, and Serial6/1 are configured as ISDN E1 PRI (user side).

.
.
.
hostname router3660
!
memory-size iomem 20
voice-card 5
!
voice-card 6
!
ip subnet-zero
!
isdn switch-type primary-qsig
isdn voice-call-failure 0
!
controller E1 5/0
 pri-group timeslots 1-5,16
!
controller E1 5/1
 pri-group timeslots 1-31
!
controller E1 6/0
 pri-group timeslots 1-31
!
controller E1 6/1
 pri-group timeslots 1-31
!
interface FastEthernet0/0
 ip address 10.7.72.9 255.255.255.0
 speed auto
 half-duplex
!
interface FastEthernet0/1
 ip address 10.100.100.7 255.255.255.0
 no keepalive
 duplex auto
 speed auto
 hold-queue 1000 in
!
interface Serial2/0
 no ip address
 shutdown
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface ATM3/0
 no ip address
 atm clock INTERNAL
 no atm ilmi-keepalive
 pvc 10/40
  vbr-rt 155000 50000 64000
  encapsulation aal5mux voice
 !
interface Serial5/0:15
 no ip address
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn overlap-receiving
 isdn incoming-voice voice
 no cdp enable
!
interface Serial5/1:15
 no ip address
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 fair-queue 64 256 0
 no cdp enable
!
interface Serial6/0:15
 no ip address
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 fair-queue 64 256 0
 no cdp enable
!
interface Serial6/1:15
 no ip address
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 fair-queue 64 256 0
 no cdp enable
!
ip classless
ip route 192.168.17.125 255.255.255.255 FastEthernet0/0
no ip http server
!
map-class frame-relay frs0
 frame-relay voice bandwidth 1260000
 frame-relay fragment 200
 no frame-relay adaptive-shaping
 frame-relay cir 1260000
 frame-relay fair-queue
!
voice-port 1/0/0
 modem passthrough system
 timing hookflash-in 0
!
voice-port 1/0/1
 modem passthrough system
 timing hookflash-in 0
!
voice-port 5/0:15
 compand-type a-law
!
voice-port 5/1:15
 compand-type a-law
 cptone DE
!
voice-port 6/0:15
 compand-type a-law
 cptone DE
!
voice-port 6/1:15
 no echo-cancel enable
 compand-type a-law
 cptone DE
!
dial-peer voice 1 pots
 shutdown
 destination-pattern 21...
 modem passthrough system
 direct-inward-dial
!
dial-peer voice 51 voip
 shutdown
 destination-pattern 6504007
 modem passthrough system
 session target ipv4:100.100.100.3
!
dial-peer voice 2 pots
 shutdown
 destination-pattern 21...
 modem passthrough system
 direct-inward-dial
 port 5/1:15
!
dial-peer voice 3 voip
 shutdown
 destination-pattern 22...
 modem passthrough system
 session target ipv4:100.100.100.6
!
dial-peer voice 5 pots
 shutdown
 destination-pattern 22...
 modem passthrough system
 direct-inward-dial
 prefix 4006
!
dial-peer voice 13 pots
 shutdown
 destination-pattern 21...
 modem passthrough system
 direct-inward-dial
 port 6/0:15
!
dial-peer voice 6 pots
 destination-pattern 21...
 modem passthrough system
 direct-inward-dial
 port 6/1:15
!
dial-peer voice 44 voatm
 destination-pattern 22...
 modem passthrough system
 session target ATM3/0 pvc 10/40
!
dial-peer voice 20 pots
 incoming called-number 4...
 destination-pattern 4007
 modem passthrough system
 direct-inward-dial
 port 5/0:15
 prefix 4007
!
dial-peer voice 21 pots
 destination-pattern 4006
 modem passthrough system
 direct-inward-dial
 port 5/0:15
 prefix 4006
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

QSIG Support on Cisco 7200 Series Routers

The following shows how QSIG protocol support is configured with VoFR on Router A (where calls originate) and Router B (where calls terminate). Note that Serial3/0:15, Serial3/1:15, Serial4/0:15, and Serial4/1:15 are configured as ISDN E1 PRI (user side).

Router A: Originating Configuration
Router B: Terminating Configuration

.

.

.

hostname 7200_RouterA

!

card type e1 3

card type e1 4

!

dspint DSPfarm3/0

!

dspint DSPfarm4/0

!

ip subnet-zero

no ip domain-lookup

ip host routerC 192.168.17.125

ip host routerD 10.1.1.2

!

multilink virtual-template 1

frame-relay switching

isdn switch-type primary-qsig

isdn voice-call-failure 0

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 3 g729br8

!

controller E1 3/0

pri-group timeslots 1-31

description qsig connected to PCG 1

!

controller E1 3/1

pri-group timeslots 1-31

description cas connected to PCG 2

!

controller E1 4/0

pri-group timeslots 1-31

description qsig group connected PCG slot3

!

controller E1 4/1

pri-group timeslots 1-31

description qsig group connected PCG slot4

!

!

!

!

!

.

.

.

hostname 7200_RouterB

!

card type e1 3

card type e1 4

!

dspint DSPfarm3/0

!

dspint DSPfarm4/0

!

ip subnet-zero

ip cef

no ip domain-lookup

ip host routerC 192.168.17.125

!

multilink virtual-template 1

isdn switch-type primary-qsig

isdn voice-call-failure 0

!

!

!

!

!

!

controller E1 3/0

pri-group timeslots 1-31

description qsig connected to PCG 5

!

controller E1 3/1

pri-group timeslots 1-31

description cas connected to PCG 6

!

controller E1 4/0

pri-group timeslots 1-31

description cas connected to PCG slot7

!

controller E1 4/1

pri-group timeslots 1-31

description cas connected to PCG slot8

!

interface Loopback0

no ip address

no ip directed-broadcast

!

interface FastEthernet0/0

no ip address

no ip directed-broadcast

shutdown

half-duplex

!

!

!

!

!

interface Serial1/0

bandwidth 512

ip address 10.1.1.104 255.255.255.0

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

load-interval 30

no keepalive

shutdown

no fair-queue

clockrate 2015232

ppp multilink

!

interface Serial1/1

description vofr connection to 7200_RouterB_s1/1

ip address 10.0.0.2 255.0.0.0

ip broadcast-address 10.0.0.0

no ip directed-broadcast

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

no keepalive

frame-relay traffic-shaping

frame-relay map ip 10.0.0.1 100 broadcast

frame-relay interface-dlci 100

class vofr_class

vofr data 4 call-control 5

!

interface Serial1/2

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial1/3

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

clockrate 2015232

!

interface FastEthernet0/0

description VOIP_10.0.0.1_maxstress to 7200_RouterAgate

ip address 10.0.0.1 255.0.0.0

no ip directed-broadcast

no ip mroute-cache

shutdown

media-type MII

full-duplex

!

interface Serial1/0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

!

!

!

!

!

!

!

!

!

interface Serial1/1

description vofr connection to 7200_RouterA

ip address 10.0.0.1 255.0.0.0

ip broadcast-address 10.0.0.0

no ip directed-broadcast

encapsulation frame-relay

no keepalive

clockrate 8060928

frame-relay traffic-shaping

frame-relay map ip 10.0.0.2 100 broadcast

frame-relay interface-dlci 100

class vofr_class

vofr data 4 call-control 5

!

!

interface Serial1/2

no ip address

no ip directed-broadcast

shutdown

clockrate 2015232

!

!

interface Serial1/3

no ip address

no ip directed-broadcast

shutdown

!

!

!

!

interface Ethernet2/0

ip address 10.1.50.77 255.255.0.0

ip broadcast-address 10.1.0.0

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

interface Ethernet2/1

ip address 10.0.0.2 255.255.0.0

ip broadcast-address 10.0.0.0

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Ethernet2/2

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Ethernet2/3

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial3/0:15

no ip address

no ip directed-broadcast

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

!

!

interface Serial3/1:15

no ip address

no ip directed-broadcast

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

!

!

interface Ethernet2/0

ip address 10.5.192.123 255.255.0.0

ip helper-address 192.168.17.125

no ip directed-broadcast

no ip mroute-cache

!

!

interface Ethernet2/1

ip address 10.0.0.1 255.255.0.0

no ip directed-broadcast

no ip mroute-cache

shutdown

!

!

!

interface Ethernet2/2

no ip address

no ip directed-broadcast

shutdown

!

!

!

interface Ethernet2/3

no ip address

no ip directed-broadcast

shutdown

!

!

!

interface Serial3/0:15

no ip address

no ip directed-broadcast

no ip route-cache cef

ip mroute-cache

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

interface Serial3/1:15

no ip address

no ip directed-broadcast

no ip route-cache cef

ip mroute-cache

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

interface Serial4/0:15

no ip address

no ip directed-broadcast

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

!

!

interface Serial4/1:15

no ip address

no ip directed-broadcast

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

!

!

interface ATM5/0

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

no atm ilmi-keepalive

!

!

!

!

!

interface Virtual-Template1

ip address 10.0.0.2 255.255.255.0

no ip directed-broadcast

load-interval 30

fair-queue 64 256 1

ppp multilink

ppp multilink fragment-delay 20

ppp multilink interleave

ip rtp priority 16384 16383 92

!

router igrp 144

network 10.0.0.0

!

ip default-gateway 10.21.75.10

ip classless

no ip http server

!

interface Serial4/0:15

no ip address

no ip directed-broadcast

no ip route-cache cef

ip mroute-cache

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

interface Serial4/1:15

no ip address

no ip directed-broadcast

no ip route-cache cef

ip mroute-cache

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

interface ATM5/0

no ip address

no ip directed-broadcast

shutdown

no atm ilmi-keepalive

!

interface FastEthernet6/0

no ip address

no ip directed-broadcast

shutdown

half-duplex

!

interface Virtual-Template1

ip unnumbered Loopback0

no ip directed-broadcast

no ip route-cache cef

ip mroute-cache

ppp multilink

ppp multilink fragment-delay 20

ppp multilink interleave

!

!

router igrp 144

network 10.0.0.0

!

!

ip classless

no ip http server

!

map-class frame-relay vofr_class

no frame-relay adaptive-shaping

frame-relay cir 4400000

frame-relay bc 1000

frame-relay fair-queue

frame-relay voice bandwidth 4000000

frame-relay fragment 256

!

voice-port 3/0:15

compand-type a-law

cptone DE

!

voice-port 3/1:15

compand-type a-law

cptone DE

!

voice-port 4/0:15

compand-type a-law

cptone DE

!

voice-port 4/1:15

compand-type a-law

cptone DE

!

dial-peer voice 5552222 pots

destination-pattern +5552...

direct-inward-dial

port 3/1:15

prefix 5552

!

dial-peer voice 5551111 vofr

destination-pattern +6......

sequence-numbers

session target Serial1/1 100

codec g729br8

!

dial-peer voice 5554 pots

destination-pattern 5554...

direct-inward-dial

port 4/1:15

prefix 5554

!

dial-peer voice 5553 pots

destination-pattern 5553...

direct-inward-dial

port 4/0:15

prefix 5553

!

dial-peer voice 5551 pots

destination-pattern +5551...

direct-inward-dial

port 3/0:15

prefix 5551

.

.

.

map-class frame-relay vofr_class

no frame-relay adaptive-shaping

frame-relay cir 4400000

frame-relay bc 1000

frame-relay fair-queue

frame-relay voice bandwidth 4000000

frame-relay fragment 256

!

voice-port 3/0:15

compand-type a-law

!

!

voice-port 3/1:15

compand-type a-law

!

!

voice-port 4/0:15

compand-type a-law

!

!

voice-port 4/1:15

compand-type a-law

!

!

dial-peer voice 5552222 pots

destination-pattern +6662...

direct-inward-dial

port 3/1:15

prefix 6662

!

dial-peer voice 5551111 vofr

destination-pattern +5......

sequence-numbers

session target Serial1/1 100

codec g729br8

!

dial-peer voice 6661 pots

destination-pattern +6661...

direct-inward-dial

port 3/0:15

prefix 6661

!

dial-peer voice 6663 pots

destination-pattern +6663...

direct-inward-dial

port 4/0:15

prefix 6663

!

dial-peer voice 6664 pots

destination-pattern +6664...

direct-inward-dial

port 4/1:15

prefix 6664

.

.

.


QSIG Support on Cisco MC3810 Multiservice Concentrators

The following shows how a Cisco MC3810 can be configured for E1 and PRI with QSIG signaling support and VoIP and VoFR. Note that Serial1:15 is configured as ISDN E1 PRI (user side).

.
.
.
hostname Router3810
!
network-clock base-rate 56k
ip subnet-zero
!
isdn switch-type primary-qsig
isdn voice-call-failure 0
!
controller T1 0
 mode atm
 framing esf
 clock source internal
 linecode b8zs
!
controller E1 1
 pri-group timeslots 1-7,16
!
interface Ethernet0
 ip address 100.100.100.6 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 bandwidth 2000
 ip address 10.168.14.1 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no keepalive
 clockrate 2000000
 cdp enable
 frame-relay traffic-shaping
 frame-relay interface-dlci 100
  class frs0
  vofr cisco
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1:15
 no ip address
 no ip directed-broadcast
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn overlap-receiving
 isdn incoming-voice voice
 fair-queue 64 256 0
 no cdp enable
!
interface ATM0
 no ip address
 no ip directed-broadcast
 ip mroute-cache
 no atm ilmi-keepalive
 pvc 10/42
  encapsulation aal5mux voice
 !
!
interface FR-ATM20
 no ip address
 no ip directed-broadcast
 shutdown
!
no ip http server
ip classless
ip route 223.255.254.0 255.255.255.0 Ethernet0
!
map-class frame-relay frs0
 frame-relay voice bandwidth 1260000
 frame-relay fragment 200
 no frame-relay adaptive-shaping
 frame-relay cir 1260000
 frame-relay fair-queue
!
map-class frame-relay frsisco
!
voice-port 1:15
 compand-type a-law
!
dial-peer voice 100 voatm
 shutdown
 destination-pattern 4...
 session target ATM0 pvc 10/42
 codec g729ar8
 no vad
!
dial-peer voice 1 pots
 shutdown
 destination-pattern 3001
!
dial-peer voice 42 vofr
 destination-pattern 4006
 session target Serial0 100
 signal-type ext-signal
!
dial-peer voice 21 pots
 destination-pattern 4007
 direct-inward-dial
 port 1:15
 prefix 4007
!
dial-peer voice 12 voip
 shutdown
 destination-pattern 4006
 session target ipv4:100.100.100.7
.
.
.

Q.931-Support: Example

The following shows how a Cisco 3660 can be configured for E1 and PRI with network-side support using VoIP. Note that Serial5/0:15 and Serial6/0:15 are configured as ISDN E1 PRI (network side) and that Serial5/1:15 and Serial6/1:15 are configured as ISDN E1 PRI (user side).

.
.
.
hostname router3660
!
memory-size iomem 20
voice-card 5
!
voice-card 6
!
ip subnet-zero
!
isdn switch-type primary-net5
isdn voice-call-failure 0
!
controller E1 3/0
 pri-group timeslots 1-5,16
!
controller E1 3/1
 pri-group timeslots 1-31
!
controller E1 4/0
 pri-group timeslots 1-31
!
controller E1 4/1
 pri-group timeslots 1-31
!
interface FastEthernet0/0
 ip address 10.7.72.9 255.255.255.0
 speed auto
 half-duplex
!
interface FastEthernet0/1
 ip address 10.100.100.7 255.255.255.0
 no keepalive
 duplex auto
 speed auto
 hold-queue 1000 in
!
interface Serial2/0
 no ip address
 shutdown
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial5/0:15
 no ip address
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn overlap-receiving
 isdn incoming-voice voice
 isdn protocol-emulate network
 no cdp enable
!
interface Serial5/1:15
 no ip address
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 fair-queue 64 256 0
 no cdp enable
!
interface Serial6/0:15
 no ip address
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 fair-queue 64 256 0
 isdn protocol-emulate network
 no cdp enable
!
interface Serial6/1:15
 no ip address
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 fair-queue 64 256 0
 no cdp enable
!
ip classless
ip route 223.255.254.254 255.255.255.255 FastEthernet0/0
no ip http server
!
voice-port 1/0/0
timing hookflash-in 0
!
voice-port 1/0/1
	timing hookflash-in 0
!
voice-port 5/0:15
 compand-type a-law
!
voice-port 5/1:15
 compand-type a-law
 cptone DE
!
voice-port 6/0:15
 compand-type a-law
 cptone DE
!
voice-port 6/1:15
 no echo-cancel enable
 compand-type a-law
 cptone DE
!
dial-peer voice 1 pots
 shutdown
 destination-pattern 21...
direct-inward-dial
!
dial-peer voice 51 voip
 shutdown
 destination-pattern 6504007
session target ipv4:100.100.100.3
!
dial-peer voice 2 pots
 shutdown
 destination-pattern 21...
direct-inward-dial
 port 5/1:15
!
dial-peer voice 3 voip
 shutdown
 destination-pattern 22...
session target ipv4:100.100.100.6
!
dial-peer voice 5 pots
 shutdown
 destination-pattern 22...
 modem passthrough system
 direct-inward-dial
 prefix 4006
!
dial-peer voice 13 pots
 shutdown
 destination-pattern 21...
direct-inward-dial
 port 6/0:15
!
dial-peer voice 6 pots
 destination-pattern 21...
direct-inward-dial
 port 6/1:15
!
dial-peer voice 20 pots
 incoming called-number 4...
 destination-pattern 4007
direct-inward-dial
 port 5/0:15
 prefix 4007
!
dial-peer voice 21 pots
 destination-pattern 4006
direct-inward-dial
 port 5/0:15
 prefix 4006
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Additional References

General ISDN References

"ISDN Features Roadmap" on page 1—Describes how to access Cisco Feature Navigator; also lists and describes, by Cisco IOS release, ISDN features for that release

"Overview of ISDN Voice Interfaces" on page 3—Describes relevant underlying technology; lists related documents, standards, MIBs, and RFCs; and describes how to obtain technical assistance

"Additional References" section—Lists additional ISDN references

References Mentioned in This Chapter

Cisco IOS Debug Command Reference, Release 12.3T at http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123tcr/123dbr/index.htm

Cisco IOS IP Configuration Guide at http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/

Cisco IOS Voice Troubleshooting and Monitoring Guide at http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/vvfax_c/voipt_c/index.htm

Cisco IOS Voice, Video, and Fax Command Reference at http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/

E1 PRI Troubleshooting at http://www.cisco.com/warp/public/116/E1_pri.html

Installing VoIP Cards at http://www.cisco.com/univercd/cc/td/doc/product/access/acs_serv/5300/hw_inst/6271voip.htm

T1 PRI Troubleshooting at http://www.cisco.com/warp/public/116/T1_pri.html

T1 troubleshooting information at http://www.cisco.com/en/US/tech/tk713/tk628/technologies_tech_note09186a00800a5f40.shtml

Using the show isdn status Command for BRI Troubleshooting at http://www.cisco.com/warp/public/129/bri_sh_isdn_stat.html

Troubleshooting ISDN at http://www.cisco.com/cisco/web/solutions/small_business/index.html?Referring_site=PrintTv&Country_Site=us&Campaign=SAMBA&Position=Vanity&Creative=go/smb&Where=go/smb


CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.