This documentation has been moved
Digital J1 Voice Interface Card
Downloads: This chapterpdf (PDF - 214.0KB) The complete bookPDF (PDF - 1.58MB) | Feedback

Digital J1 Voice Interface Card

Table Of Contents

Digital J1 Voice Interface Card

Contents

Prerequisites for Configuring the Digital J1 VIC

Restrictions for Configuring the Digital J1 VIC

Information About the Digital J1 VIC

How to Configure the Digital J1 VIC

Configuring the J1 VIC

Configuring CAS

Configuring the Clock Source

Configuring Loopback

Configuring T-CCS for a Clear-Channel Codec

Verifying Digital J1 VIC Configuration

Monitoring and Maintaining the Digital J1 VIC

Troubleshooting Tips

Configuration Examples for the Digital J1 VIC

Controller (J1): Example

Channel-Associated Signaling: Example

Clock Source: Example

Loopback: Example

Transparent Common-Channel Signaling for a Clear-Channel Codec: Example


Digital J1 Voice Interface Card


This chapter describes how to implement the Digital J1 Voice Interface Card (VIC) feature. The digital J1 VIC provides the proper interface for directly connecting Cisco multiservice access routers to PBXs throughout Japan that use a J1 (2.048-Mbps time-division-multiplexed [TDM]) interface.

Feature History for Digital J1 Voice Interface Card

Release
Modification

12.2(8)T

This feature was introduced on the Cisco 2600 series and Cisco 3600 series.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for Configuring the Digital J1 VIC

Restrictions for Configuring the Digital J1 VIC

Information About the Digital J1 VIC

How to Configure the Digital J1 VIC

Configuration Examples for the Digital J1 VIC

Prerequisites for Configuring the Digital J1 VIC

Ensure that you have Cisco IOS Release 12.2(8)T or later.

Restrictions for Configuring the Digital J1 VIC

Voice-only applications are supported.

Separate clock output is not supported.

Alarm-relay output is not supported.

Per-channel loopback is not supported.

Voice ports on the J1 interface cannot be configured using network-management software. They must be configured manually.

Information About the Digital J1 VIC

The digital J1 VIC provides the proper interface for directly connecting Cisco multiservice access routers to PBXs throughout Japan that use a J1 (2.048-Mbps TDM) interface.

It provides the software and hardware features required to connect to over 80 percent of the PBXs within Japan that use digital interfaces. This new J1 voice interface card (VIC) provides a TTC JJ-20.11 compliant interface between high-density voice network modules (NM-HDV) and a Japanese PBX.

The card supports 30 voice channels per port. It provides a single-port line interface in a VIC form factor. It is specifically designed to conform to the TTC JJ-20.10-12 standards that define the interface between a PBX and a time-division multiplexer.

Figure 19 shows the earlier solution offered to customers in Japan. A J1/T1 adapter box installed between the PBX and router provides the translation between J1 using coded mark inversion (CMI) line coding at a bit rate of 2.048 Mbps and a T1 line using either alternate mark inversion (AMI) or B8ZS line coding at a bit rate of 1.544 Mbps. Note that, with this solution, only 24 channels are supported instead of the full 30 channels of the J1 interface.

Figure 19 Solution Without J1 VIC

Figure 20 shows the solution using the digital J1 VIC. The interface is now between J1 and the VIC's TDM access (TDMA) bus. Note that now all 30 channels of the J1 interface are supported.

Figure 20 Solution with J1 VIC

Feature benefits include the following:

Supports Media Gateway Control Protocol (MGCP), H.248, H.323 (versions 1, 2, and 3), Session Initiation Protocol (SIP), and Cisco CallManager (with Cisco IP phones) in association with VoIP, VoFR, and VoATM

Provides Alarm Indication Signal (AIS) alarm signaling per TTC JJ-20.11

Delivers the same performance as the existing 30-channel E1 NM-HDV

Allows enabling and disabling of individual DS0s or channels

How to Configure the Digital J1 VIC

Configuring the J1 VIC

Configuring CAS (optional)

Configuring the Clock Source (optional)

Configuring Loopback (optional)

Configuring T-CCS for a Clear-Channel Codec (optional)

Verifying Digital J1 VIC Configuration (optional)

Monitoring and Maintaining the Digital J1 VIC (optional)

Troubleshooting Tips


Note For related information on VIC installation, see Installing and Configuring 1-Port J1 Voice Interface Cards.


Configuring the J1 VIC

To configure the digital J1 VIC, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. controller j1

4. exit

DETAILED STEPS
 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

controller j1 slot/port

Example:
Router(config)# controller j1 1/0

Configures the J1 controller in the specified slot and port.

Step 4 

exit

Example:

Router(config-control)# exit

Exits the current mode.

Configuring CAS

To configure the DS0 groups on the digital J1 VIC for voice applications, perform the following steps.


Note The J1 controller supports the E&M wink start and E&M immediate channel-associated signaling (CAS) protocols for the voice ports. The Companding type: mu-law and CP tone: JP parameters have default values for the J1 interface.


SUMMARY STEPS

1. enable

2. configure terminal

3. controller j1 slot/port

4. ds0-group

5. exit

6. Repeat as needed

DETAILED STEPS
 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

controller j1 slot/port

Example:
Router(config)# controller j1 1/0

Enters controller configuration mode for the J1 controller in the specified slot and port.

Step 4 

ds0-group ds0-group-no timeslots timeslot-list type signaling-type

Example:

Router(config-controller)# ds0-group 1 timeslots 1-15,17-31 type e&m-wink-start

Configures channelized J1 time slots for use by compressed voice calls and the signaling method for connecting to the PBX. The keywords and arguments are as follows:

ds0-group-no—DS0 group number.

timeslots timeslot-list—DS0 timeslot. Range: 1 to 31. Timeslot 16 is reserved for signaling.

type signaling-type—Signaling type to be applied to the selected group:

e&m-delay-dial—Originating endpoint sends an off-hook signal and then and waits for an off-hook signal followed by an on-hook signal from the destination.

e&m-immediate-start—No specific off-hook and on-hook signaling.

e&m-wink-start—Originating endpoint sends an off-hook signal and waits for a wink signal from the destination.

none—Null signaling for external call control.

Step 5 

exit

Example:

Router(config-controller)# exit

Exits the current mode.

Step 6 

Repeat if your router has more than one J1 controller to configure.

Configuring the Clock Source

To configure the clock source for a digital J1 VIC, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. controller j1

4. clock source

5. exit

6. Repeat as needed

DETAILED STEPS
 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

controller j1 slot/port

Example:
Router(config)# controller j1 1/0

Enters controller configuration mode for the J1 controller in the specified slot and port.

Step 4 

clock source {line | internal}

Example:

Router(config-controller)# clock source line

Specifies the clock source. Keywords are as follows:

line—Controller recovers external clock from the line and provides the recovered clock to the internal (system) clock generator.

internal—Controller synchronizes itself to the internal (system) clock.

Default: line.

Step 5 

exit

Example:

Router(config-controller)# exit

Exits the current mode.

Step 6 

Repeat if your router has more than one J1 controller to configure.

Configuring Loopback

To configure loopback for testing a digital J1 VIC, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. controller j1

4. loopback

5. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

controller j1 slot/port

Example:
Router(config)# controller j1 1/0

Enters controller configuration mode for the J1 controller in the specified slot and port.

Step 4 

loopback {local | line | isolation}

Example:

Router(config-controller)# loopback isolation

Sets the loopback method for testing the J1 interface. Keywords are as follows:

local—Local loopback mode

line—External loopback mode at the line level

isolation—Both local and line loopback mode

Step 5 

exit

Example:

Router(config-controller)# exit

Exits the current mode.

Configuring T-CCS for a Clear-Channel Codec

To configure transparent common-channel signaling (T-CCS), perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. controller j1

4. ds0-group

5. no shutdown

6. exit

7. dial-peer voice

8. destination-pattern

9. port

10. exit

11. dial-peer voice

12. codec clear-channel

13. vad

14. destination-pattern

15. session target

16. exit

DETAILED STEPS
 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enters privileged EXEC mode. Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

controller j1 slot/port

Example:
Router(config)# controller j1 1/0

Enters controller configuration mode for the J1 controller in the specified slot and port.

Step 4 

ds0-group ds0-group-no timeslots timeslot-list type signaling-type

Example:

Router(config-controller)# ds0-group 1 timeslots 1-15,17-31 type e&m-wink-start

Configures channelized J1 time slots for use by compressed voice calls and the signaling method that the router uses to connect to the PBX. The keywords and arguments are as described earlier.

Step 5 

no shutdown

Example:

Router(config-controller)# no shutdown

Activates the controller.

Step 6 

exit

Example:

Router(config-controller)# exit

Exits the current mode.

Step 7 

dial-peer voice number pots

Example:

Router(config)# dial-peer voice 20 pots

Enters dial-peer configuration mode for the specified POTS dial peer.

Step 8 

destination-pattern string [T]

Example:

Router(config-dialpeer)# destination-pattern 3050 T

Configures the dial peer's destination pattern so that the system can reconcile dialed digits with a telephone number. The keyword and argument are as follows:

string—Series of digits that specify the E.164 or private-dialing-plan phone number. Valid entries: digits 0 to 9 and letters A to D. The plus symbol (+) is not valid. You can enter the following special characters:

Star character (*) that appears on standard touch-tone dial pads—Can be in any dial string, but not as a leading character (for example, *650).

Period (.)—Acts as a wildcard character.

Comma (,)—In prefixes, inserts a one-second pause.

T—When included at the end of the destination pattern, causes the system to collect dialed digits as they are entered until the interdigit timer expires (default: 10 seconds) or the user dials the termination of end-of-dialing key (default: #).

Note The timer character must be a capital T.

Step 9 

port slot/port:ds0-group-no

Example:

Router(config-dialpeer)# port 1/0:1

Associates the dial peer with a specific logical interface. Arguments are as follows:

slot— Router location where the voice module is installed. Range: 0 to 3.

port—Voice interface card location. Range: 0 to 1.

ds0-group-no—DS0 group number. Each defined DS0 group number is represented on a separate voice port, allowing you to define individual DS0s.

Step 10 

exit

Example:

Router(config-dialpeer)# exit

Exits the current mode.

Step 11 

dial-peer voice number voip

Example:

Router(config)# dial-peer voice 20 voip

Enters dial-peer configuration mode for the specified VoIP dial peer.

Step 12 

codec clear-channel

Example:

Router(config-dialpeer)# codec clear-channel

Specifies use of the clear-channel codec.

Step 13 

vad

Example:

Router(config-dialpeer)# vad

(Optional; enabled by default) Activates voice activity detection (VAD), which allows the system to reduce unnecessary voice transmissions caused by unfiltered background noise.

Step 14 

destination-pattern string [T]

Example:

Router(config-dialpeer)# destination-pattern 3050 T

Configures the dial peer's destination pattern so that the system can reconcile dialed digits with a telephone number. The keyword are argument are as described above.

Step 15 

session target {ipv4:destination-address | dns:[$s$. | $d$. | $e$. | $u$.] hostname}

Example:

Router(config-dialpeer)# session target {ipv4:10.168.1.1 serverA.mycompany.com}

Configures the IP session target for the dial peer. Keywords and arguments are as follows:

ipv4:destination-address —IP address of the dial peer to receive calls.

dns:hostname—Domain-name server that resolves the name of the IP address. You can use wildcards by using source, destination, and dialed information in the hostname. Use one of the following macros with this keyword when defining the session target for VoIP peers:

$s$.—Source destination pattern is used as part of the domain name.

$d$.—Destination number is used as part of the domain name.

$e$.—Digits in the called number are reversed and periods are added between the digits of the called number. The resulting string is used as part of the domain name.

·$u$.—Unmatched portion of the destination pattern (such as a defined extension number) is used as part of the domain name.

Step 16 

exit

Example:

Router(config-dialpeer)# exit

Exits the current mode.

Verifying Digital J1 VIC Configuration

To verify that the digital J1 VIC is configured correctly, use the show running-config command as shown in the"Configuration Examples for the Digital J1 VIC" section.

Monitoring and Maintaining the Digital J1 VIC

To monitor and maintain the J1 VIC, use the following commands:

show controllers j1 slot/port—Displays statistics for the J1 link.

show dial-peer voice—Displays configuration information for dial peers.

Troubleshooting Tips

Three digital loopback modes are possible for diagnostics and fault isolation:

Line loopback loops the received signal (R-D) from the PBX to the transmit going back to the PBX.

Local loopback loops the transmitted signal (T-D) from the host to the receive going back to the host.

Isolation loopback routes PBX and TDM generated traffic back to their respective sources.


Note In the following figures, Tx=transmit interface and Rx=receive interface. Tip / Ring leads carry audio between the signaling unit and the trunking circuit.


Line Loopback

To place the controller into line loopback, use the loopback line command (Figure 21). Line loopback loops the receiver inputs to the transmitter outputs. The receive path is not affected by the activation of this loopback.

Figure 21 Line Loopback

Local Loopback

To place the controller into local loopback, use the loopback local command (Figure 22). To turn off loopback, use the no form of the command. Local loopback loops the transmit line encoder outputs to the receive line encoder inputs. The transmit path is not affected by the activation of this loopback.


Note Use this command only for testing purposes.


Figure 22 Local Loopback

Isolation Loopback

To place the controller into line loopback, use the loopback isolation command (Figure 23). Both line and local loopback are turned on.

Figure 23 Isolation Loopback

Configuration Examples for the Digital J1 VIC

Controller (J1): Example

Channel-Associated Signaling: Example

Clock Source: Example

Loopback: Example

Transparent Common-Channel Signaling for a Clear-Channel Codec: Example

Router# show running-config

Building configuration...

Current configuration :2023 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname kmm-3660-1
!
boot system tftp /tftpboot/kmenon/c3660-is-mz 223.255.254.254
enable password lab
!
voice-card 1
!
voice-card 3
!
voice-card 4
!
ip subnet-zero
!
!
voice service pots
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller J1 1/0
 clock source line
!
controller E1 3/0
!
controller E1 3/1
!
controller T1 4/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 24
!
controller T1 4/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 24
!
!
interface Multilink1
 ip address 30.30.30.1 255.255.255.0
 keepalive 1
 no cdp enable
 ppp multilink
 no ppp multilink fragmentation
 multilink-group 1
!
interface FastEthernet0/0
 ip address 1.7.29.1 255.255.0.0
 no ip mroute-cache
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 1.8.0.1 255.255.0.0
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Serial4/0:0
 no ip address
 encapsulation ppp
 no fair-queue
 no cdp enable
 ppp multilink
 multilink-group 1
!
interface Serial4/1:0
 no ip address
 encapsulation ppp
 no fair-queue
 no cdp enable
 ppp multilink
 multilink-group 1
!
ip default-gateway 1.7.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 1.9.0.1 255.255.255.255 30.30.30.2
ip route 223.255.254.254 255.255.255.255 1.7.0.1
no ip http server
ip pim bidir-enable
!
!
snmp-server engineID local 00000009020000044D0EF520
snmp-server packetsize 4096
!
call rsvp-sync
!
no mgcp timer receive-rtcp
!
mgcp profile default
!
dial-peer cor custom
!
!
dial-peer voice 1 pots
 destination-pattern 88
!
dial-peer voice 20 voip
 destination-pattern 3050
 session target ipv4:10.8.0.2
 codec clear-channel
!
dial-peer voice 77 pots
 destination-pattern 77
!
dial-peer voice 100 voip
 incoming called-number 100
 destination-pattern 100
 session target ipv4:10.8.0.2
 no vad
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Controller (J1): Example

The following example shows the Cisco IOS interface card in slot 4, port 0 of a Cisco 3660 configured as a J1 controller:

controller J1 4/0

Channel-Associated Signaling: Example

The following example shows the DS0 groups on the J1 controller.

controller J1 4/0
 clock source line
 ds0-group 1 timeslots 1-15,17-31 type e&m-wink-start

Clock Source: Example

The following example shows the J1 controller clock source is configured to line, where the controller recovers external clock from the line and provides the recovered clock to the internal (system) clock generator.

controller J1 3/0
 clock source line

Loopback: Example

The following example shows the loopback method for testing the J1 controller is set at the line level.

controller J1 3/0
 clock source line
 loopback line

Transparent Common-Channel Signaling for a Clear-Channel Codec: Example

The following example shows the codec option set to clear-channel.

dial-peer voice 20 voip
 destination-pattern 3050
 session target ipv4:10.8.0.2
 codec clear-channel

CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.