This documentation has been moved
Configuring Modem Passthrough
Downloads: This chapterpdf (PDF - 154.0KB) The complete bookPDF (PDF - 1.62MB) | Feedback

Configuring Modem Passthrough

Table Of Contents

Configuring Modem Passthrough

Contents

Prerequisites for Configuring Modem Passthrough

Restrictions for Configuring Modem Passthrough

Information About Modem Passthrough

Modem Passthrough Functions

Passthrough Rollover

Payload Redundancy

Clock Slip Buffer Management

How to Configure Modem Passthrough

Configuring Modem Passthrough Globally

Configuring Modem Passthrough for a Specific Dial Peer

Troubleshooting Tips for Modem Passthrough

Configuration Examples for Modem Passthrough

Modem Passthrough Configuration for Cisco AS5300: Example


Configuring Modem Passthrough


Modem Passthrough over VoIP provides the transport of modem signals through a packet network by using pulse code modulation (PCM) encoded packets. This chapter describes the configuration for modem passthrough.

Your software release may not support all the features documented in this chapter. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this chapter, and to see a list of the releases in which each feature is supported, see the Cisco IOS Fax and Modem Services over IP Roadmap chapter.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for Configuring Modem Passthrough

Restrictions for Configuring Modem Passthrough

Information About Modem Passthrough

How to Configure Modem Passthrough

Configuration Examples for Modem Passthrough

Prerequisites for Configuring Modem Passthrough

Before configuring modem passthrough, perform the following tasks:

Establish a working VoIP-enabled network.

Verify network suitability to pass modem traffic. The key characteristics of the network are packet loss, delay, and jitter. These characteristics can be determined by using the Service Assurance Agent (SAA) feature of Cisco IOS software.

Configure clock sourcing on the T1 controller on the voice gateway that connects to the PSTN. For modem passthrough to operate correctly, the gateway clock must be synced with the PSTN clock. See the following example configuration:

!
controller T1 0
 framing esf
 linecode b8zs
 clock source line
 channel-group 1 timeslots 1-24 speed 64
 !


Note Configure clock sourcing for all interfaces connected to the PSTN.


Restrictions for Configuring Modem Passthrough

Restrictions for configuring modem passthrough are as follows:

The modem passthrough protocol and fax protocol commands cannot be configured at the same time. If you enter either one of these commands when the other is already configured, the command-line interface returns an error message.

The error message serves as a confirmation notice because the modem passthrough protocol command is internally treated the same as the fax protocol pass-through command by the Cisco IOS software. For example, no other mode of fax protocol (for example, fax protocol T.38) can operate if the modem passthrough protocol command is configured.

Even though the modem passthrough protocol and fax protocol pass-through commands are treated the same internally, be aware that if you change the configuration from the modem passthrough protocol command to the modem passthrough nse command, the configured fax protocol pass-through command is not automatically reset to the default. If default settings are required for the fax protocol command, you have to specifically configure the fax protocol command.

Information About Modem Passthrough

Modem Passthrough Functions

Passthrough Rollover

Payload Redundancy

Clock Slip Buffer Management

Modem Passthrough Functions

Modem passthrough over VoIP performs the following functions:

Represses processing functions like compression, echo cancellation, high-pass filter, and voice activity detection (VAD).

Issues redundant packets to protect against random packet drops.

Provides static jitter buffers of 200 milliseconds to protect against clock skew.

Discriminates modem signals from voice and fax signals, indicating the detection of the modem signal across the connection, and placing the connection in a state that transports the signal across the network with the least amount of distortion.

Reliably maintains a modem connection across the packet network for a long duration under normal network conditions.

Passthrough Rollover

When the gateway detects a data modem, both the originating gateway and the terminating gateway roll over to G.711. The roll over to G.711 disables the high-pass filter, disables echo cancellation, and disables VAD. At the end of the modem call, the voice ports revert to the prior configuration and the digital signal processor (DSP) goes back to the state before the rollover.


Note The gateway can detect modems at speeds up to V.90.


Payload Redundancy

Payload redundancy enables the modem passthrough switchover and this causes the gateway to emit redundant packets. When redundancy is enabled, 10-ms sample-sized packets are sent. When redundancy is disabled, 20-ms sample-sized packets are sent.

Redundancy is enabled on one or both of the gateways. When only a single gateway is configured for redundancy, the second gateway receives the packets correctly but does not produce redundant packets.

Clock Slip Buffer Management

When the gateway detects a data modem, both the originating gateway and the terminating gateway switch from dynamic jitter buffers to static jitter buffers of 200-ms depth. The switch from dynamic to static is to compensate for PSTN clocking differences at the originating gateway and the terminating gateway. At the conclusion of a modem call, the voice ports revert to dynamic jitter buffers.

How to Configure Modem Passthrough

Modem passthrough can be configured at two levels:

Under voice-service configuration mode—This configuration is the global, or system-wide configuration that is applied to any VoIP call on the gateway. The default for voice-service configuration mode is no modem passthrough. See the "Configuring Modem Passthrough Globally" section.

Under dial-peer configuration mode for VoIP dial peers—This configuration applies only to calls that match a specific dial peer. The default dial-peer configuration is modem passthrough system, which tells the gateway to use the parameters configured at the global level. See the "Configuring Modem Passthrough for a Specific Dial Peer" section.

The two configuration tasks can be used separately or together. If both are configured, the dial-peer configuration overrides the global configuration.


Note You must configure modem passthrough on both the originating and terminating gateways.


Configuring Modem Passthrough Globally

Use the following steps to configure modem passthrough for all the dial peers on a gateway.

SUMMARY STEPS

1. enable

2. configure terminal

3. voice service voip

4. modem passthrough {nse | protocol} [payload-type number] codec {g711ulaw | g711alaw} [redundancy [maximum-sessions sessions] [sample-duration [10 | 20]]]

DETAILED STEPS
 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

voice service voip

Example:

Router(config)# voice service voip

Enters voice-service configuration mode and configures voice service for all gateway connections.

Step 4 

modem passthrough {nse | protocol} [payload-type number] codec {g711ulaw | g711alaw} [redundancy [maximum-sessions sessions] [sample-duration [10 | 20]]]


Example:

Router(conf-voi-serv)# modem passthrough nse payload-type 101 codec g711ulaw redundancy maximum-sessions 1

Configures modem passthrough for all dial peers on the gateway. The default behavior is no modem passthrough.

nse—Specifies that named signaling events (NSEs) are used to communicate codec switchover between gateways.

protocol—Session Initiation Protocol (SIP)/H.323 protocol is used to signal modem pass-through.

payload-type number—(Optional) NSE payload type. Range varies, but is from 96 to 119 on most platforms. For details, refer to command-line interface (CLI) help. Default is 100.

Note The payload-type must match on the originating and terminating gateways.

codec—Codec selections for upspeed.

g711ulaw—Codec G.711 u-law, 64000 bits per second for T1.

g711alaw—Codec G.711 a-law, 64000 bits per second for E1.

redundancy—(Optional) Enables a single repetition of packets (using RFC 2198) to improve reliability by protecting against packet loss.

maximum-sessions value—(Optional) Maximum number of simultaneous pass-through sessions. Ranges and defaults vary by platform.

Configuring Modem Passthrough for a Specific Dial Peer

You must configure a VoIP dial peer on both the originating and terminating gateways to match the call—for example, using a destination pattern.

When the system keyword is entered, the following parameters are not available: nse, payload-type, codec, and redundancy. The configuration is taken from the modem passthrough nse command in voice-service configuration mode.


Note When modem passthrough is configured for a specific dial peer, the dial-peer configuration takes precedence over the global configuration.


Use the following steps to configure modem passthrough for a specific dial peer.

SUMMARY STEPS

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. modem passthrough {system | nse [payload-type number] codec {g711ulaw | g711alaw} [redundancy]}

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 1 

dial-peer voice tag voip

Example:

Router(config)# dial-peer voice 20 voip

Enters dial-peer configuration mode and names a specific VoIP dial peer.

tag—Digits that define a particular dial peer. Range is from 1 to 2147483647.

voip—Indicates that this is a VoIP peer that uses voice encapsulation on the POTS network.

Step 2 

modem passthrough {system | nse [payload-type number] codec {g711ulaw | g711alaw} [redundancy]}

Example:

Router(config-dial-peer)# modem passthrough nse codec g711ulaw redundancy

Configures modem passthrough for a specific dial peer. The default behavior for modem passthrough in dial-peer configuration mode is modem passthrough system.

system—Defaults to the global configuration.

nse—Specifies that named signaling events (NSEs) are used to communicate codec switchover between gateways.

payload-type number—(Optional) NSE payload type. Range varies by platform, but is from 96 to 119 on most platforms. The default is 100.

codec—Codec selections for upspeeding.

g711ulaw—Codec G.711 u-law 64000 bits per second for T1.

g711alaw—Codec G.711 a-law 64000 bits per second for E1.

redundancy—(Optional) Enables a single repetition of packets (using RFC 2198) to improve reliability by protecting against packet loss.

Troubleshooting Tips for Modem Passthrough

Use the following steps to troubleshoot modem passthrough:

Ensure that you can make a voice call.

Ensure that modem passthrough over VoIP is configured on both the originating gateway and the terminating gateway.

Ensure that the originating and terminating gateways have the same NSE payload-type number.

When two gateways are configured in voice-service configuration mode, ensure that the originating and terminating gateways have the same maximum-sessions value.

Use the following commands to troubleshoot modem passthrough:

debug voip vtsp—Displays information about the voice telephony service provider (VTSP).

debug vtsp—Used to trace how the router interacts with the digital signal processor (DSP) based on the signaling indications from the signaling stack and requests from the application. Effective with Cisco IOS Release 12.3(8)T, this command was replaced by the debug voip vtsp command.

show dial-peer voice —Used to verify that modem passthrough over VoIP is enabled.

show call active voice—Displays the voice information for the active call table.

show call history voice—Displays the voice information for the call history table.

show dial-peer voice—Displays configuration information for dial peers.

To verify that modem passthrough is configured, you can use the show call active voice brief command. In the following sample output, the IP call leg shows the keyword MODEMPASS to signify that the call is in modem passthrough mode:

11DD : 1 1565860ms.1 +15340 pid:2 Answer 100 active 
dur 00:00:19 tx:864/110008 rx:858/102929 
Tele 0/0/0 (1) [0/0/0] tx:12270/12270/0ms g711ulaw noise:-11 acom:6 i/0:-14/-59 dBm 
11DD : 2 1570100ms.1 +11090 pid:1 Originate 200 active 
dur 00:00:19 tx:858/102929 rx:864/103096 
IP 1.1.1.2:16610 SRTP: off rtt:1ms pl:40/0ms lost:0/0/0 delay:60/60/60ms g711ulaw 
TextRelay: off 
media inactive detected:n media contrl rcvd:n/a timestamp:n/a 
long duration call detected:n long duration call duration:n/a timestamp:n/a MODEMPASS nse 
buf:0/0 loss 0% 0/0 last 1031s dur:0/0s

Configuration Examples for Modem Passthrough

Modem Passthrough Configuration for Cisco AS5300: Example

Modem Passthrough Configuration for Cisco AS5300: Example

The following is sample configuration for the Modem Passthrough over VoIP feature for the Cisco AS5300 universal access servers:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
voice service voip 
 modem passthrough nse codec g711ulaw redundancy maximum-session 5
!
resource-pool disable
!
ip subnet-zero
ip ftp source-interface Ethernet0
ip ftp username lab
ip ftp password lab
no ip domain-lookup
!
isdn switch-type primary-5ess
cns event-service server
!
mta receive maximum-recipients 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 shutdown
 clock source line secondary 1
!
interface Ethernet0
 ip address 10.10.2.2 255.0.0.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0:23
 no ip address
 encapsulation ppp
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no peer default ip address
 no fair-queue
 no cdp enable
 no ppp lcp fast-start
!
interface FastEthernet0
 ip address 172.16.0.1 255.0.0.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 duplex full
 speed auto
 no cdp enable
!
ip classless
ip route 192.168.0.0 255.255.0.0 10.10.1.1
no ip http server
!
voice-port 0:D
!
dial-peer voice 1 pots
 incoming called-number 55511..
 destination-pattern 020..
 direct-inward-dial
 port 0:D 
 prefix 020
!
dial-peer voice 2 voip
 incoming called-number 020..
 destination-pattern 55511..
 modem passthrough nse codec g711ulaw redundancy
 session target ipv4:10.10.0.2
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!

Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries. A listing of Cisco's trademarks can be found at www.cisco.com/go/trademarks. Third party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)