Guest

IP Multicast

Configuring a Rendezvous Point

  • Viewing Options

  • PDF (230.8 KB)
  • Feedback
Configuring a Rendezvous Point

Table Of Contents

Configuring a Rendezvous Point

Rendezvous Point Overview

RP Configuration Overview

Sparse-Dense Mode for Auto-RP

Auto-RP Filters

Recommended Methods for Configuring an RP

Auto-RP with Multiple RPs Scenario

Configuration Files

BSR with Multiple RPs Scenario

Configuration Files

Anycast Static RP Scenario

Configuration Files

Anycast RP with Auto-RP Scenario

Configuration Files

Related Documents


Configuring a Rendezvous Point


Version History

Version Number
Date
Notes

1

03/15/2002

This document was created.


The purpose of this document is to outline four recommended methods for configuring a rendezvous point (RP) in a Protocol Independent Multicast sparse mode (PIM-SM) network. It provides scenario descriptions and basic configuration examples for each option.

This document has the following sections:

Rendezvous Point Overview

RP Configuration Overview

Recommended Methods for Configuring an RP

Related Documents

Rendezvous Point Overview

A rendezvous point (RP) is required only in networks running Protocol Independent Multicast sparse mode (PIM-SM). The protocol is described in RFC 2362. In PIM-SM, only network segments with active receivers that have explicitly requested multicast data will be forwarded the traffic. This method of delivering multicast data is in contrast to the PIM dense mode (PIM-DM) model. In PIM-DM, multicast traffic is initially flooded to all segments of the network. Routers that have no downstream neighbors or directly connected receivers prune back the unwanted traffic.

An RP acts as the meeting place for sources and receivers of multicast data. In a PIM-SM network, sources must send their traffic to the RP. This traffic is then forwarded to receivers down a shared distribution tree. By default, when the first hop router of the receiver learns about the source, it will send a join message directly to the source, creating a source-based distribution tree from the source to the receiver. This source tree does not include the RP unless the RP is located within the shortest path between the source and receiver.

In most cases, the placement of the RP in the network is not a complex decision. By default, the RP is needed only to start new sessions with sources and receivers. Consequently, the RP experiences little overhead from traffic flow or processing. In PIM-SM version 2, the RP requires less processing than in PIM-SM version 1 because sources must only periodically register with the RP to create state.

RP Configuration Overview

In the first version of PIM-SM, all leaf routers (routers directly connected to sources or receivers) were required to be manually configured with the IP address of the RP. This type of configuration is also known as static RP configuration. Configuring static RPs is relatively easy in a small network, but it can be laborious in a large, complex network.

Following the introduction of PIM-SM version 1, Cisco implemented a version of PIM-SM with the Auto-RP feature. Auto-RP automates the distribution of group-to-RP mappings in a PIM network. To make Auto-RP work, a router must be designated as an RP mapping agent, which receives the RP announcement messages from the RPs and arbitrates conflicts. The RP mapping agent then sends the consistent group-to-RP mappings to all other routers by dense mode flooding. Thus, all routers automatically discover which RP to use for the groups they support. The Internet Assigned Numbers Authority (IANA) has assigned two group addresses, 224.0.1.39 and 224.0.1.40, for Auto-RP. One advantage of Auto-RP is that any change to the RP designation must be configured only on the routers that are RPs and not on the leaf routers. Another advantage of Auto-RP is that it offers the ability to scope the RP address within a domain. Scoping can be achieved by defining the time-to-live (TTL) value allowed for the Auto-RP advertisements.

Another RP selection model called bootstrap router (BSR) was introduced after Auto-RP in PIM-SM version 2. BSR performs similarly to Auto-RP in that it uses candidate routers for the RP function and for relaying the RP information for a group. RP information is distributed through BSR messages, which are carried within PIM messages. PIM messages are link-local multicast messages that travel from PIM router to PIM router. Because of this single hop method of disseminating RP information, TTL scoping cannot be used with BSR. A BSR performs similarly as an RP, except that it does not run the risk of reverting to dense mode operation, and it does not offer the ability to scope within a domain.

Each method for configuring an RP has its own strengths, weaknesses, and level of complexity. In conventional IP multicast network scenarios, we recommend using Auto-RP to configure RPs because it is easy to configure, well-tested, and stable.

Sparse-Dense Mode for Auto-RP

A prerequisite of Auto-RP is that all interfaces must be configured in sparse-dense mode using the ip pim sparse-dense-mode interface configuration command. An interface configured in sparse-dense mode is treated in either sparse mode or dense mode of operation, depending on which mode the multicast group operates. If a multicast group has a known RP, the interface is treated in sparse mode. If a group has no known RP, the interface is treated in dense mode and data will be flooded over this interface.

To successfully implement Auto-RP and prevent any groups other than 224.0.1.39 and 224.0.1.40 from operating in dense mode, we recommend configuring a "sink RP" (also known as "RP of last resort"). A sink RP is a statically configured RP that may or may not actually exist in the network. Configuring a sink RP does not interfere with Auto-RP operation because, by default, Auto-RP messages supersede static RP configurations. We recommend configuring a sink RP for all possible multicast groups in your network, because it is possible for an unknown or unexpected source to become active. If no RP is configured to limit source registration, the group may revert to dense mode operation and be flooded with data.

Auto-RP Filters

When using Auto-RP, configure the ip pim rp-announce-filter global configuration command on Auto-RP mapping agent routers to filter Auto-RP announcement messages that arrive on group 224.0.1.39 from candidate RP routers. This command prevents unwanted candidate RP announcement messages from being processed by the mapping agent. Unwanted messages could interfere with the RP election mechanism of the mapping agent.


Note Only routers configured as mapping agents subscribe to candidate RP announcement messages. Therefore, the ip pim rp-announce-filter global configuration command is effective only when configured on a mapping agent router. This command has no effect when configured on any other router.


The following example shows how to configure the router to accept announcements from RP addresses 10.0.0.1 and 10.0.0.2. This router is also configured to accept announcements for all groups.

ip pim rp-announce-filter rp-list 1 group-list 2
access-list 1 permit 10.0.0.1
access-list 1 permit 10.0.0.2
access-list 2 permit 224.0.0.0 15.255.255.255

Recommended Methods for Configuring an RP

The following sections describe the four recommended methods for configuring an RP in a PIM-SM network. Sample configurations are also provided for each scenario. Figure 1 shows the network topology used for the sample configurations.

Auto-RP with Multiple RPs Scenario

BSR with Multiple RPs Scenario

Anycast Static RP Scenario

Anycast RP with Auto-RP Scenario

Figure 1 Network Topology Used for Sample Configurations


Note Unicast routing must be configured and stable in your network before implementing any of the sample configurations provided in the following sections.



Note The sample configurations provided in the following sections use boldface text to indicate pertinent configuration commands used for deploying the IP multicast scenarios described in this document.


Auto-RP with Multiple RPs Scenario

In this scenario, RP information is distributed to the routers by the Auto-RP mechanism. For more information about Auto-RP, see the "RP Configuration Overview" section earlier in this document. A prerequisite of Auto-RP is that all interfaces must be configured in PIM sparse-dense mode. For more information about using sparse-dense mode with Auto-RP, see the "Sparse-Dense Mode for Auto-RP" section earlier in this document.

In the following sample configuration, routers 72a and 75a are configured as both a candidate RP and RP mapping agent. At any given time, only one RP address is active (either per group or, as in the following sample configuration, for all groups).

Having multiple candidates for the role of RP and mapping agent greatly enhances the redundancy of the PIM-SM network. Redundancy reduces the risk of groups (configured in sparse-dense mode) reverting to dense mode operation if an RP cannot be located. To eliminate this risk, we recommend configuring a sink RP on every router in the network. In the following sample configuration, a sink RP with the fictitious address 1.1.1.1 is configured on all routers. For more information on sink RPs, see the "Sparse-Dense Mode for Auto-RP" section earlier in this document.

For the Auto-RP with Multiple RPs scenario, no load balancing is provided, and, when an RP changes, convergence is normally on the order of 3 minutes.

The following relevant multicast commands are used in this scenario:

ip pim sparse-dense-mode

ip pim rp-address rp-address access-list

ip pim send-rp-announce

ip pim send-rp-discovery

Configuration Files

Router 36a

ip multicast-routing

interface Ethernet0/1
ip address 20.0.7.6 255.255.255.0
ip pim sparse-dense-mode

interface FastEthernet2/0
ip address 20.0.6.6 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 36b

ip multicast-routing

interface Ethernet0/1
ip address 20.0.7.7 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet1/0
ip address 20.0.10.7 255.255.255.0
ip pim sparse-dense-mode

interface FastEthernet2/0
ip address 20.0.8.7 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 36c

ip multicast-routing

interface Serial0/0
ip address 20.0.9.10 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet0/1
ip address 20.0.10.10 255.255.255.0
ip pim sparse-dense-mode

interface FastEthernet1/0
ip address 20.0.3.10 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 36d

ip multicast-routing

interface Serial0/0
ip address 20.0.9.11 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet0/1
ip address 20.0.5.11 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 72a

ip multicast-routing

interface Loopback0
ip address 20.0.0.3 255.255.255.255
ip pim sparse-dense-mode

interface FastEthernet0/0
ip address 20.0.1.3 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet3/1
ip address 20.0.3.3 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet3/2
ip address 20.0.2.3 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
ip pim send-rp-announce Loopback0 scope 32 group-list 10
ip pim send-rp-discovery Loopback0 scope 32
access-list 10 permit 224.0.0.0 15.255.255.255
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 75a

ip multicast-routing distributed

interface Loopback0
ip address 20.0.0.2 255.255.255.255
ip pim sparse-dense-mode

interface FastEthernet0/0/0
ip address 20.0.1.2 255.255.255.0
ip pim sparse-dense-mode
ip route-cache distributed

interface FastEthernet0/1/0
ip address 20.0.6.2 255.255.255.0
ip pim sparse-dense-mode
ip route-cache distributed

ip pim rp-address 1.1.1.1 20
ip pim send-rp-announce Loopback0 scope 32 group-list 10
ip pim send-rp-discovery Loopback0 scope 32
access-list 10 permit 224.0.0.0 15.255.255.255
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

The following example shows output from the show ip pim rp and show ip pim rp mapping commands. In this example, all groups are using 20.0.0.3 as the RP address. This address was chosen by the RP mapping agent because it was the highest IP address.

36b# show ip pim rp

Group: 224.128.1.1, RP: 20.0.0.3, v2, v1, uptime 00:03:01, expires 00:02:50
The RP has now changed to 20.0.0.3

36b# show ip pim rp mapping

PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 20.0.0.3 (?), v2v1
Info source: 20.0.0.2 (?), via Auto-RP
Uptime: 00:22:08, expires: 00:02:40

BSR with Multiple RPs Scenario

In this scenario, RP information is distributed to the routers by the BSR mechanism. For more information about the BSR mechanism, see the "RP Configuration Overview" section earlier in this document.

In the following sample configuration, routers 72a and 75a are configured as both a BSR candidate and an RP candidate. Having multiple candidates for the role of BSR and RP greatly enhances the redundancy of the PIM-SM network. At any given time, only one RP address is active (either per group or, as in the following sample configuration, for all groups).

For the BSR with Multiple RPs scenario, no load balancing is provided, and, when an RP changes, convergence is normally on the order of 3 minutes.

The following relevant multicast commands areused in this scenario:

ip pim sparse-mode

ip pim bsr-candidate

ip pim rp-candidate

Configuration Files

Router 36a

ip multicast-routing

interface Ethernet0/1
ip address 20.0.7.6 255.255.255.0
ip pim sparse-mode

interface FastEthernet2/0
ip address 20.0.6.6 255.255.255.0
ip pim sparse-mode

Router 36b

ip multicast-routing

interface Ethernet0/1
ip address 20.0.7.7 255.255.255.0
ip pim sparse-mode

interface Ethernet1/0
ip address 20.0.10.7 255.255.255.0
ip pim sparse-mode

interface FastEthernet2/0
ip address 20.0.8.7 255.255.255.0
ip pim sparse-mode

Router 36c

ip multicast-routing

interface Serial0/0
ip address 20.0.9.10 255.255.255.0
ip pim sparse-mode

interface Ethernet0/1
ip address 20.0.10.10 255.255.255.0
ip pim sparse-mode

Router 36d

ip multicast-routing

interface Serial0/0
ip address 20.0.9.11 255.255.255.0
ip pim sparse-mode

interface Ethernet0/1
ip address 20.0.5.11 255.255.255.0
ip pim sparse-mode

Router 72a

ip multicast-routing

interface Loopback0
ip address 20.0.0.3 255.255.255.255
ip pim sparse-mode

interface FastEthernet0/0
ip address 20.0.1.3 255.255.255.0
ip pim sparse-mode

interface Ethernet3/1
ip address 20.0.3.3 255.255.255.0
ip pim sparse-mode

interface Ethernet3/2
ip address 20.0.2.3 255.255.255.0
ip pim sparse-mode

ip pim bsr-candidate Loopback0 1
ip pim rp-candidate Loopback0

Router 75a

ip multicast-routing distributed

interface Loopback0
ip address 20.0.0.2 255.255.255.255
ip pim sparse-mode

interface FastEthernet0/0/0
ip address 20.0.1.2 255.255.255.0
ip pim sparse-mode

interface FastEthernet0/1/0
ip address 20.0.6.2 255.255.255.0
ip pim sparse-mode

ip pim bsr-candidate Loopback0 1
ip pim rp-candidate Loopback0

The following example shows output from the show ip pim bsr command. The IP addresses of the two candidates for BSR are 20.0.0.2 and 20.0.0.3. The 20.0.0.3 address is chosen as the BSR because it is the higher IP address.

75a# show ip pim bsr

PIMv2 Bootstrap information
BSR address: 20.0.0.3 (?)
Uptime: 00:23:32, BSR Priority: 0, Hash mask length: 1
Expires: 00:01:57
This system is a candidate BSR
Candidate BSR address: 20.0.0.2, priority: 0, hash mask length: 1
Next C and_RP_advertisement in 00:00:18
RP: 20.0.0.2(Loopback0)

Anycast Static RP Scenario

In this scenario, Anycast RPs are configured statically and interfaces are configured to operate in PIM-SM. In Anycast RP, two or more RPs are configured with the "same" IP address on loopback interfaces. The Anycast RP loopback address should be configured with a 32-bit mask, making it a host address. This scenario is easy to configure and troubleshoot because the same host address is used as the RP address regardless of which router it is configured on.


Note The Interior Gateway Protocol (IGP) used in your network must support host addresses. Ensure that the loopback interface used for Anycast RP does not conflict with the loopback interface used to uniquely identify routers within the IGP.


All the downstream routers should be configured to "know" that the Anycast RP loopback address is the IP address of their local RP. IP routing will automatically select the topologically closest RP for each source and receiver. Assuming that the sources are evenly distributed around the network, an equal number of sources will register with each RP. That is, the process of registering the sources will be shared equally by all the RPs in the network.

In the following sample configuration, routers 72a and 75a are configured as Anycast RPs. Because two routers are configured with the same RP address, there is not a single point of failure. At any given time, only one RP address is active (either per group or, as in the following sample configuration, for all groups).

Anycast RP provides excellent redundancy and load balancing. The load balancing is achieved through Multicast Source Discovery Protocol (MSDP), which allows RPs to exchange information about active sources.

For the Anycast Static RP scenario, when an RP changes, convergence is normally on the order of seconds.


Note In the following sample configuration, an MSDP mesh group is configured. The use of an MSDP mesh group is unnecessary when only two Anycast RPs are configured. However, if there are more than two Anycast RPs, you should configure MSDP mesh groups to prevent looping of Source-Active (SA) messages.


The following relevant multicast commands are used in this scenario:

ip pim sparse-mode

ip pim rp-address rp-address

ip msdp peer {peer-address | peer-name} connect-source type number

ip msdp mesh-group mesh-name {peer-address | peer-name}

ip msdp originator-id type number

Configuration Files

Router 36a

ip multicast-routing

interface Ethernet0/1
ip address 20.0.7.6 255.255.255.0
ip pim sparse-mode

interface FastEthernet2/0
ip address 20.0.6.6 255.255.255.0
ip pim sparse-mode

ip pim rp-address 20.0.0.1

Router 36b

ip multicast-routing

interface Ethernet0/1
ip address 20.0.7.7 255.255.255.0
ip pim sparse-mode

interface Ethernet1/0
ip address 20.0.10.7 255.255.255.0
ip pim sparse-mode

interface FastEthernet2/0
ip address 20.0.8.7 255.255.255.0
ip pim sparse-mode

ip pim rp-address 20.0.0.1

Router 36c

ip multicast-routing

interface Serial0/0
ip address 20.0.9.10 255.255.255.0
ip pim sparse-mode

interface Ethernet0/1
ip address 20.0.10.10 255.255.255.0
ip pim sparse-mode

interface FastEthernet1/0
ip address 20.0.3.10 255.255.255.0
ip pim sparse-mode

ip pim rp-address 20.0.0.1

Router 36d

ip multicast-routing

interface Serial0/0
ip address 20.0.9.11 255.255.255.0
ip pim sparse-mode

interface Ethernet0/1
ip address 20.0.5.11 255.255.255.0
ip pim sparse-mode

ip pim rp-address 20.0.0.1

Router 72a

ip multicast-routing

interface Loopback0
ip address 20.0.0.3 255.255.255.255
ip pim sparse-mode

interface Loopback1
ip address 20.0.0.1 255.255.255.255
ip pim sparse-mode

interface FastEthernet0/0
ip address 20.0.1.3 255.255.255.0
ip pim sparse-mode

interface Ethernet3/1
ip address 20.0.3.3 255.255.255.0
ip pim sparse-mode

interface Ethernet3/2
ip address 20.0.2.3 255.255.255.0
ip pim sparse-mode

ip pim rp-address 20.0.0.1
ip msdp peer 20.0.0.2 connect-source Loopback0
ip msdp mesh-group anycast 20.0.0.2
ip msdp originator-id Loopback0

Router 75a

ip multicast-routing distributed

interface Loopback0
ip address 20.0.0.2 255.255.255.255
ip pim sparse-mode

interface Loopback1
ip address 20.0.0.1 255.255.255.255
ip pim sparse-mode

interface FastEthernet0/0/0
ip address 20.0.1.2 255.255.255.0
ip pim sparse-mode
ip route-cache distributed

interface FastEthernet0/1/0
ip address 20.0.6.2 255.255.255.0
ip pim sparse-mode
ip route-cache distributed

ip pim rp-address 20.0.0.1
ip msdp peer 20.0.0.3 connect-source Loopback0
ip msdp mesh-group anycast 20.0.0.3
ip msdp originator-id Loopback0

Anycast RP with Auto-RP Scenario

In this scenario, Anycast RP information is distributed to the routers by the Auto-RP mechanism. For more information about Anycast RP, see the "Anycast Static RP Scenario" section earlier in this document. For more information about Auto-RP, see the "RP Configuration Overview" section earlier in this document. A prerequisite of Auto-RP is that all interfaces must be configured in PIM sparse-dense mode. For more information about using sparse-dense mode with Auto-RP, see the "Sparse-Dense Mode for Auto-RP" section earlier in this document.

In the following sample configuration, routers 72a and 75a are configured as Anycast RPs. Because two routers are configured with the same RP address, there is not a single point of failure. At any given time, only one RP address is active (either per group or, as in the following sample configuration, for all groups).

Anycast RP provides excellent redundancy and load balancing. The load balancing is achieved through Multicast Source Discovery Protocol (MSDP), which allows RPs to exchange information about active sources. Redundancy reduces the risk of groups (configured in sparse-dense mode) reverting to dense mode operation if an RP cannot be located. To eliminate this risk, we recommend configuring a sink RP on every router in the network. In the following sample configuration, a sink RP with the fictitious address 1.1.1.1 is configured on all routers. For more information on sink RPs, see the "Sparse-Dense Mode for Auto-RP" section earlier in this document.

For the Anycast RP with Auto-RP scenario, when an RP changes, convergence is normally on the order of seconds.


Note In the following sample configuration, an MSDP mesh group is configured. The use of an MSDP mesh group is unnecessary when only two Anycast RPs are configured. However, if there are more than two Anycast RPs, you should configure MSDP mesh groups to prevent looping of SA messages.


The following relevant multicast commands are used in this scenario:

ip pim sparse-dense-mode

ip pim rp-address rp-address access-list

ip pim send-rp-announce

ip pim send-rp-discovery

ip msdp peer {peer-address | peer-name} connect-source type number

ip msdp mesh-group mesh-name {peer-address | peer-name}

ip msdp originator-id type number

Configuration Files

Router 36a

ip multicast-routing

interface Ethernet0/1
ip address 20.0.7.6 255.255.255.0
ip pim sparse-dense-mode

interface FastEthernet2/0
ip address 20.0.6.6 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 36b

ip multicast-routing

interface Ethernet0/1
ip address 20.0.7.7 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet1/0
ip address 20.0.10.7 255.255.255.0
ip pim sparse-dense-mode

interface FastEthernet2/0
ip address 20.0.8.7 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 36c

ip multicast-routing

interface Serial0/0
ip address 20.0.9.10 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet0/1
ip address 20.0.10.10 255.255.255.0
ip pim sparse-dense-mode

interface FastEthernet1/0
ip address 20.0.3.10 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 36d

ip multicast-routing

interface Serial0/0
ip address 20.0.9.11 255.255.255.0
ip pim sparse-dense-mode
!
interface Ethernet0/1
ip address 20.0.5.11 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 72a

ip multicast-routing

interface Loopback0
ip address 20.0.0.3 255.255.255.255
ip pim sparse-dense-mode

interface Loopback1
ip address 20.0.0.1 255.255.255.255
ip pim sparse-dense-mode

interface FastEthernet0/0
ip address 20.0.1.3 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet3/1
ip address 20.0.3.3 255.255.255.0
ip pim sparse-dense-mode

interface Ethernet3/2
ip address 20.0.2.3 255.255.255.0
ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20
ip pim send-rp-announce Loopback1 scope 32 group-list 10
ip pim send-rp-discovery Loopback1 scope 32
ip msdp peer 20.0.0.2 connect-source Loopback0
ip msdp mesh-group anycast 20.0.0.2
ip msdp originator-id Loopback0
access-list 10 permit 224.0.0.0 15.255.255.255
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Router 75a

ip multicast-routing distributed

interface Loopback0
ip address 20.0.0.2 255.255.255.255
ip pim sparse-dense-mode

interface Loopback1
ip address 20.0.0.1 255.255.255.255
ip pim sparse-dense-mode

interface FastEthernet0/0/0
ip address 20.0.1.2 255.255.255.0
ip pim sparse-dense-mode
ip route-cache distributed

interface FastEthernet0/1/0
ip address 20.0.6.2 255.255.255.0
ip pim sparse-dense-mode
ip route-cache distributed

ip pim rp-address 1.1.1.1 20
ip pim send-rp-announce Loopback1 scope 32 group-list 10
ip pim send-rp-discovery Loopback1 scope 32
ip msdp peer 20.0.0.3 connect-source Loopback0
ip msdp mesh-group anycast 20.0.0.3
ip msdp originator-id Loopback0
access-list 10 permit 224.0.0.0 15.255.255.255
access-list 20 deny 224.0.1.39
access-list 20 deny 224.0.1.40
access-list 20 permit 224.0.0.0 15.255.255.255

Related Documents

Anycast RP, Cisco white paper

http://www.cisco.com/univercd/cc/td/doc/cisintwk/intsolns/mcst_sol/anycast.htm

IP Multicast Technology Overview, Cisco white paper

http://www.cisco.com/univercd/cc/td/doc/cisintwk/intsolns/mcst_sol/mcst_ovr.htm

Developing IP Multicast Networks, Cisco Press

Cisco IOS IP Configuration Guide, Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/index.htm

Cisco IOS IP Command Reference, Volume 3 of 3: Multicast, Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fiprmc_r/index.htm

Cisco IOS Software Multicast Services web page

http://www.cisco.com/go/ipmulticast

Cisco IOS Software IP Multicast Groups External Homepage

ftp://ftpeng.cisco.com/ipmulticast.html