Guest

IP Multicast

Using IP Multicast Over Frame Relay Networks

  • Viewing Options

  • PDF (220.5 KB)
  • Feedback
Using IP Multicast over Frame Relay Networks

Table Of Contents

Using IP Multicast over Frame Relay Networks

Frame Relay Overview

Network Architecture

How IP Multicast Operates in a Frame Relay Network

How the Router Sends Broadcast and Multicast Packets in a Frame Relay Network

NBMA Mode Solution

Auto-RP Issues with NBMA Mode

Point-to-Point Subinterfaces Solution

Configuration Examples

NBMA Mode Example

Point-to-Point Subinterface Example

Related Documents


Using IP Multicast over Frame Relay Networks


Version History

Version Number
Date
Notes

1

12/20/2001

This document was created.


The purpose of this document is to describe the network operation issues involved when deploying IP multicast in a Frame Relay network environment. Frame Relay has no inherent broadcast or multicast capabilities, and therefore care should be taken to choose the correct configuration model when using IP multicast over Frame Relay networks. Either of the following recommended solutions—which are described in this document—can be used to configure IP multicast over Frame Relay:

NBMA mode

Point-to-point subinterfaces

If your network can support both of these solutions, we recommend point-to-point subinterfaces because of its simplicity and ease of use with Auto-RP.

This document has the following sections:

Frame Relay Overview

Network Architecture

How IP Multicast Operates in a Frame Relay Network

How the Router Sends Broadcast and Multicast Packets in a Frame Relay Network

NBMA Mode Solution

Point-to-Point Subinterfaces Solution

Configuration Examples

Related Documents

Frame Relay Overview

Frame Relay is a WAN protocol that operates at the physical and data link layers of the Open System Interconnection (OSI) reference model. This protocol is standardized by both the International Telecommunication Union Telecommunications Standardization Sector (ITU-T) and American National Standards Institute (ANSI).

Frame Relay uses statistical multiplexing techniques to provide network access in a packet-switched network. It is strictly a Layer 2 protocol suite. Being a Layer 2 protocol enables Frame Relay to offer higher performance WAN applications (such as LAN interconnection) than the older protocols (such as X.25), which incorporated Layer 3 functions. Given these performance benefits, Frame Relay is a popular WAN medium. However, it has some limitations with regard to IP multicast. To illustrate, Frame Relay is a Layer 2 nonbroadcast multiaccess (NBMA) network protocol. IP multicast networks are designed to utilize the capabilities of Layer 2 broadcast media such as on a LAN.

Network Architecture

To provide efficient IP multicast support in Frame Relay networks, the underlying Frame Relay network architecture should be designed in a "hub and spoke" topology (hierarchical topology). The hub and spoke topology is also named a "star" topology, because the central hub acts as the center of a star and the connections to the remote sites act as light radiating from the star.

In the hub and spoke topology, each remote router may also act as a hub and each connection to another remote site may act as a spoke (in a hierarchical fashion). In a multiple hub topology, the load associated with sending broadcast and multicast data can be distributed across multiple central hub sites rather than concentrated at a single central site. Thus, even though data may require extra hops to get to a particular location, data delivery is more efficient in a hub and spoke network than in other network topologies. This design also provides a scalable, hierarchical network that greatly reduces the resource requirements of the central router, allowing the Frame Relay network to utilize the advantages of IP multicast applications.

How IP Multicast Operates in a Frame Relay Network

Typically, a Frame Relay network consists of a physical Layer 2 point-to-point network that is partially meshed, appearing to the Layer 3 functions of the router as a logical LAN. In this situation, a remote site router expects all routers in the network to receive any broadcast or multicast packet sent. Figure 1 shows the network topology of the logical Layer 3 perspective of a router in a Frame Relay network.

Figure 1 Logical Layer 3 Perspective of a Router in a Frame Relay Network

In reality, however, broadcast or multicast traffic sent by a remote site router will be received only by the central site router, not by the other remote site routers, because each remote site router is connected point-to-point to the central site router (see Figure 2).

Figure 2 Layer 3 Point-to-Point Connections in a Frame Relay Network

The following example illustrates a specific issue regarding IP multicast deployment within the partial mesh design of Frame Relay networks. If a remote site router sends a Protocol Independent Multicast (PIM) prune message, only the central site router will receive the prune message (see Figure 3). Consequently, other remote site routers cannot override this prune message. This situation could prevent members of multicast groups from receiving multicast traffic that they want.

Figure 3 Prune Message Override Failure

How the Router Sends Broadcast and Multicast Packets in a Frame Relay Network

When nonbroadcast multiaccess (NBMA) networks such as Frame Relay networks need to send broadcast or multicast data packets on a main interface, routers perform a pseudobroadcast. This process uses the broadcast queue, which operates independently of the normal interface queue (see Figure 4). The broadcast queue is commonly configured to prevent routing updates from being dropped from the queue.

Figure 4 Broadcast Queue Versus Normal Interface Queue

To understand a pseudobroadcast, imagine seven WAN locations that are all running Open Shortest Path First (OSPF). When one router sends an OSPF hello packet to an IP multicast group address, the data link layer of the router replicates the hello packet, sending one copy to each WAN neighbor. In this example, six copies of the hello packet are created and sent over the link to the multiaccess WAN. Consequently, the router that sent the initial OSPF hello packet was required to use six times the resources than a router connected to true broadcast media such as Ethernet or Token Ring.

The limitations of pseudobroadcasts in an NBMA network such as Frame Relay are as follows:

The pseudobroadcast solution is not scalable for IP multicast applications (that may consist of high traffic rates) because pseudobroadcasts are process-switched.

Pseudobroadcast data packets are treated as broadcast traffic and sent to all neighbors on the WAN regardless of their need for receiving these packets. This situation can quickly lead to packets, including control data, being dropped from the broadcast queue due to oversubscription.

NBMA Mode Solution

The NBMA mode software feature is one solution to configuring IP multicast within a Frame Relay network. This PIM feature allows you to configure a router to send packets only to those neighbors that want to receive them. A router in PIM NBMA mode treats each remote PIM neighbor as if it were connected to the router through a point-to-point link.

In a Frame Relay network that uses IP multicast, NBMA mode improves router performance for the following reasons:

Traffic is fast-switched rather than process-switched.

Routers receive traffic only for the multicast groups to which they are joined.

To enable NBMA mode on an interface, use the ip pim nbma-mode command in interface configuration mode. This command allows the router to track the IP address of each neighbor when a PIM join message is received from that neighbor. The router can also track the interface of the neighbor in the outgoing interface list for the multicast groups that the neighbor joins. This information allows the router to forward data destined for a particular multicast group to only those neighbors that have joined that particular group.

When using the ip pim nbma-mode command, note the following usage guidelines:

This command applies to only PIM sparse mode configurations because its functionality is dependent on the PIM sparse mode join message.

As the number of PIM neighbors increases, the outgoing interface list increases. Each interface entry requires additional resources from the NBMA mode-enabled router, therefore increasing data replication time and memory utilization.

Auto-RP Issues with NBMA Mode

The NBMA mode feature does not support PIM dense mode. Auto-RP, a method for disseminating rendezvous point (RP) information in an IP multicast network, relies on dense mode flooding of data from two well-known multicast group addresses, 224.0.1.39 and 224.0.1.40. These groups are candidate RP and RP mapping information groups. Without dense mode flooding capability, multicast routers in a Frame Relay network using Auto-RP may have problems receiving RP mapping information unless the Mapping Agent (MA) is placed in the appropriate location within the network or a more costly full mesh architecture is created.

Use the following guidelines when placing the MA in your network:

All candidate RPs must be connected to the MA.

All MAs must be connected to all PIM routers.

As shown in Figure 5, if the MA were placed below router R2, then only the central site router (R1) would receive the Auto-RP messages containing RP mapping information. In this situation, the central site router would not resend the Auto-RP messages to routers R3, R4, and R5.

Figure 5 Ineffective Placement of MA in a Frame Relay Network Using Auto-RP

However, if the MA were placed above the central site router (R1), then the central site router, which has direct connections to the remote site routers, will forward the RP mapping information to routers R2, R3, R4, and R5 (see Figure 6).

Figure 6 Effective Placement of MA in a Frame Relay Network Using Auto-RP

Point-to-Point Subinterfaces Solution

An alternative solution to using NBMA mode to configure IP multicast within a Frame Relay network is to use point-to-point subinterfaces for each of the remote sites. For the point-to-point subinterfaces solution, the partially meshed Frame Relay network is divided into a number of virtual, point-to-point networks using subinterfaces. Each new point-to-point subnetwork is assigned its own network number. To the routed protocol, each subnetwork now appears to be located on separate interfaces.

In a Frame Relay network that uses IP multicast, the benefits of point-to-point subinterfaces are as follows:

No prune message override issues are associated with the partial mesh design of Frame Relay networks.

They avoid limitations associated with pseudobroadcasts in a Frame Relay network because point-to-point subinterfaces are treated more like standard serial interfaces than LAN interfaces.

They prevent Auto-RP issues related to multicast routers receiving dense mode traffic.


Note If your network can support both the point-to-point subinterfaces and NBMA mode solutions, we recommend point-to-point subinterfaces because of its simplicity and ease of use with Auto-RP.


Configuration Examples

This section provides the following configuration examples. The network topology for these examples is shown in Figure 7.

NBMA Mode Example

Point-to-Point Subinterface Example


Note The example configurations provided in the following sections use boldface text to indicate pertinent configuration commands used for deploying the IP multicast solutions described in this document.


Figure 7 Network Topology for Configuration Examples

NBMA Mode Example

RouterA

ip multicast-routing
!
interface Loopback10
ip address 10.1.1.1 255.255.255.255
ip pim sparse-dense-mode
!
interface Serial0/1
ip address 10.1.48.1 255.255.255.248
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
frame-relay interface-dlci 100
frame-relay interface-dlci 200
!
ip pim send-rp-announce Loopback10 scope 16
ip pim send-rp-discovery Loopback10 scope 16
!

To display the outgoing interface list (OIL) information, use the show ip mroute command. The following is sample output of this command:

RouterA# show ip mroute

IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, C - Connected, L - Local, 
       P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set, 
       J - Join SPT, M - MSDP created entry, X - Proxy Join Timer Running
       A - Advertised via MSDP
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.39), 01:22:13/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1, Forward/Sparse-Dense, 00:19:09/00:00:00
    Loopback10, Forward/Sparse-Dense, 01:22:13/00:00:00

(10.1.1.1, 224.0.1.39), 01:21:13/00:02:56, flags: CLTA
  Incoming interface: Loopback10, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1, Forward/Sparse-Dense, 00:19:09/00:00:00

(*, 224.0.1.40), 01:22:14/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
 Serial0/1, Forward/Sparse-Dense, 00:19:08/00:00:00
 Loopback10, Forward/Sparse-Dense, 01:22:15/00:00:00

(10.1.1.1, 224.0.1.40), 01:06:06/00:02:26, flags: CLTA
  Incoming interface: Loopback10, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1, Forward/Sparse-Dense, 00:19:09/00:00:00

(*, 227.1.1.1), 00:18:27/00:02:53, RP 10.1.1.1, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1, Forward/Sparse-Dense, 00:18:27/00:02:53

(*, 228.1.1.1), 00:18:27/00:02:53, RP 10.1.1.1, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1, Forward/Sparse-Dense, 00:18:27/00:02:52

RouterB

ip multicast-routing
!
interface Serial0/0
ip address 10.1.48.3 255.255.255.248
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
frame-relay interface-dlci 201
!
interface Ethernet0/1
ip address 10.2.32.1 255.255.255.0
ip pim sparse-dense-mode

RouterC

ip multicast-routing
!
interface Serial0/0
ip address 10.1.48.2 255.255.255.248
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
frame-relay interface-dlci 101
!
interface Ethernet0/1
ip address 10.2.16.2 255.255.255.0
ip pim sparse-dense-mode

To verify that Auto-RP is configured properly, use the show ip pim rp mapping command. The following is sample output of this command:

RouterC# show ip pim rp mapping

PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.1.1.1 (?), v2v1
    Info source: 10.1.1.1 (?), via Auto-RP
         Uptime: 00:19:17, expires: 00:02:33

Point-to-Point Subinterface Example

RouterA

ip multicast-routing
!
interface Loopback10
ip address 10.1.1.1 255.255.255.255
ip pim sparse-dense-mode
!
!
interface Serial0/1
encapsulation frame-relay
!
interface Serial0/1.1 point-to-point
ip address 10.1.16.1 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 100   
!
interface Serial0/1.2 point-to-point
ip address 10.1.32.1 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 200   
!
ip pim send-rp-announce Loopback10 scope 16
ip pim send-rp-discovery Loopback10 scope 16
!

To display the outgoing interface list (OIL) information, use the show ip mroute command. The following is sample output of this command:

RouterA# show ip mroute

IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, C - Connected, L - Local, 
       P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set, 
       J - Join SPT, M - MSDP created entry, X - Proxy Join Timer Running
       A - Advertised via MSDP
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.39), 01:53:59/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1.1, Forward/Sparse-Dense, 01:09:32/00:00:00
    Serial0/1.2, Forward/Sparse-Dense, 01:10:32/00:00:00
    Loopback10, Forward/Sparse-Dense, 01:52:46/00:00:00

(10.1.1.1, 224.0.1.39), 01:53:59/00:02:00, flags: CLTA
  Incoming interface: Loopback10, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1.1, Forward/Sparse-Dense, 01:09:32/00:00:00
    Serial0/1.2, Forward/Sparse-Dense, 01:10:32/00:00:00

(*, 224.0.1.40), 01:54:09/00:00:00, RP 0.0.0.0, flags: DJCL
Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1.2, Forward/Sparse-Dense, 01:08:03/00:00:00
    Serial0/1.1, Forward/Sparse-Dense, 01:09:16/00:00:00
    Loopback10, Forward/Sparse-Dense, 01:54:11/00:00:00

(10.1.1.1, 224.0.1.40), 01:52:01/00:02:37, flags: CLTA
  Incoming interface: Loopback10, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1.2, Forward/Sparse-Dense, 01:08:03/00:00:00
    Serial0/1.1, Forward/Sparse-Dense, 01:09:16/00:00:00

(*, 227.1.1.1), 00:49:31/00:03:16, RP 10.1.1.1, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1.1, Forward/Sparse-Dense, 00:40:26/00:03:16

(*, 228.1.1.1), 01:03:10/00:03:17, RP 10.1.1.1, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1.1, Forward/Sparse-Dense, 00:40:26/00:03:17

RouterB

ip multicast-routing
!
interface Serial0/0
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 10.1.32.2 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 201   
!
interface Ethernet0/1
ip address 10.2.32.1 255.255.255.0
ip pim sparse-dense-mode

RouterC

ip multicast-routing
!
interface Serial0/0
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 10.1.16.2 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 101   
!
interface Ethernet0/1
ip address 10.2.16.2 255.255.255.0
ip pim sparse-dense-mode

To verify that Auto-RP is configured properly, use the show ip pim rp mapping command. The following is sample output of this command:

RouterC# show ip pim rp mapping

PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.1.1.1 (?), v2v1
    Info source: 10.1.1.1 (?), via Auto-RP
         Uptime: 1d03h, expires: 00:02:49

Related Documents

Configuring and Troubleshooting Frame Relay, Cisco Tech Note

http://www.cisco.com/warp/customer/125/12.html

I.D. Number: 256 Frame Relay Broadcast Queue, Cisco Product Bulletin

http://www.cisco.com/warp/partner/synchronicd/cc/techno/media/wan/frame/prodlit/256_pb.htm

Cisco IOS IP Configuration Guide, Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/index.htm

Cisco IOS IP Command Reference, Volume 3 of 3: Multicast, Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fiprmc_r/index.htm

Cisco IOS Software Multicast Services web page

http://www.cisco.com/go/ipmulticast

Cisco IOS Software IP Multicast Groups External Homepage

ftp://ftpeng.cisco.com/ipmulticast.html