This documentation has been moved
NHRP MIB
Downloads: This chapterpdf (PDF - 137.0KB) The complete bookPDF (PDF - 7.9MB) | Feedback

NHRP MIB

Table Of Contents

NHRP MIB

Finding Feature Information

Contents

Prerequisites for NHRP MIB

Restrictions for NHRP MIB

Information About NHRP MIB

CISCO-NHRP-MIB

RFC-2677

How to Use NHRP MIB

Verifying NHRP MIB Status

Configuration Examples for NHRP MIB

Example: Verifying NHRP MIB Status

Example: VRF-Aware NHRP MIB Configuration

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for NHRP MIB


NHRP MIB


First Published: July 11, 2008
Last Updated: October 5, 2011

The Cisco NHRP MIB feature introduces support for the NHRP MIB, which helps to manage and monitor the Next Hop Resolution Protocol (NHRP) via Simple Network Management Protocol (SNMP). Statistics can be collected and monitored via standards-based SNMP techniques (get operations) to query objects defined in the NHRP MIB. The NHRP MIB is VRF aware and supports VRF aware queries.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for NHRP MIB" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for NHRP MIB

Restrictions for NHRP MIB

Information About NHRP MIB

How to Use NHRP MIB

Configuration Examples for NHRP MIB

Additional References

Feature Information for NHRP MIB

Feature Information for NHRP MIB

Prerequisites for NHRP MIB

You should be familiar with configuring SNMP.

Restrictions for NHRP MIB

Cisco does not support all the MIB variables defined in RFC-2677, Definitions of Managed Objects for the NBMA Next Hop Resolution Protocol (NHRP). For a list of variables supported and other caveats of this feature, see the Agent Capabilities file. Cisco does not support the set operations defined in RFC-2677.

Information About NHRP MIB

CISCO-NHRP-MIB

RFC-2677

CISCO-NHRP-MIB

CISCO-NHRP-MIB provides the following NHRP MIB data - information on managed objects relating to clients only, servers only, and clients and servers.

The NHRP MIB module contains ten tables of objects. The tables are as follows:

NHRP Cache Table

NHRP Purge Request Table

NHRP Client Table

NHRP Client Registration Table

NHRP Client NHS Table

NHRP Client Statistics Table

NHRP Server Table

NHRP Server Cache Table

NHRP Server NHC Table

NHRP Server Statistics Table

The Cisco implementation supports all of the tables except the NHRP Purge Request Table.

RFC-2677

RFC-2677 - Definitions of Managed Objects for the NBMA Next Hop Resolution Protocol (NHRP), describes managed objects that can be used to remotely monitor NHRP using SNMP and provide management information on the performance of NHRP.

How to Use NHRP MIB

No special configuration is needed for this feature. The SNMP framework can be used to manage NHRP MIB. See the section "Configuration Examples for NHRP MIB" for an example of how to manage a VRF aware NHRP MIB.

This section contains the following task:

Verifying NHRP MIB Status

Verifying NHRP MIB Status

Use this task to verify the NHRP MIB status.

SUMMARY STEPS

1. enable

2. show snmp mib nhrp status

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables EXEC mode.

Enter your password if prompted.

Step 2 

show snmp mib nhrp status

Example:

Router# show snmp mib nhrp status

Displays the status of the NHRP MIB.

Configuration Examples for NHRP MIB

Example: Verifying NHRP MIB Status

Example: VRF-Aware NHRP MIB Configuration

Example: Verifying NHRP MIB Status

The following output is from the show snmp mib nhrp status command:

Spoke_103# show snmp mib nhrp status 
 
   
NHRP-SNMP Agent Feature: Enabled
NHRP-SNMP Tree State: Good
ListEnqueue Count = 0 Node Malloc Counts = 1
Spoke_103#
 
   

The "Enabled" status of "NHRP-SNMP Agent Feature:" indicates that the NHRP MIB is enabled. If the NHRP MIB was disabled, it would display "Disabled". "ListEnqueue Count" and "Node Malloc Counts" counts are internal counts. "ListEnqueue Count" indicates how many nodes are queued for freeing. "Node Malloc Counts" displays how many nodes are allocated.

Example: VRF-Aware NHRP MIB Configuration

The following is an example of how to configure a VRF Table with the name V3red, for monitoring by SNMP:

ip vrf V3red
 rd 198102
! Name of the SNMP VPN context
 context V3red_context
!
crypto isakmp policy 1
 authentication pre-share
crypto isakmp key cisco47 address 0.0.0.0
!
crypto ipsec transform-set trans2 esp-des esp-md5-hmac
!
crypto ipsec profile vpnprof
 set transform-set trans2
!
interface Tunnel0
 bandwidth 1000
! DMVPN tunnel for V3red VPN
 ip vrf forwarding V3red
 ip address 10.0.0.1 255.255.255.0
 ip mtu 1400
 ip nhrp authentication donttell
 ip nhrp map multicast dynamic
 ip nhrp network-id 99
 ip nhrp holdtime 300
 no ip split-horizon eigrp 1
 ip tcp adjust-mss 1360
 delay 1000
 tunnel source Ethernet0
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile vpnprof
!
interface Ethernet0
 ip address 172.17.0.1 255.255.255.0
!
interface Ethernet1
 ip address 192.168.0.1 255.255.255.0
!
router eigrp 1
address-family ipv4 vrf V3red
 network 10.0.0.0 0.0.0.255 
 network 192.168.0.0 0.0.0.255 
 no auto-summary
 autonomous-system 1
exit-address-family
 
   
!
! V2C Community ABC for VRF V3red
snmp-server group abc v2c context V3red_context read view_V3 
snmp-server view view_V3 iso included 
snmp-server community abc RO 
snmp-server community public RO 
snmp-server context V3red_context 
!
!
snmp mib community-map abc context V3red_context 
 
   
 
   
Spoke Configuration for DMVPN Example 
 
   
crypto isakmp policy 1
 authentication pre-share
crypto isakmp key cisco47 address 0.0.0.0
!
crypto ipsec transform-set trans2 esp-des esp-md5-hmac
!
crypto ipsec profile vpnprof
 set transform-set trans2
!
interface Tunnel0
 bandwidth 1000
 ip address 10.0.0.2 255.255.255.0
 ip mtu 1400
 ip nhrp authentication donttell
 ip nhrp map 10.0.0.1 172.17.0.1
 ip nhrp map multicast 172.17.0.1
 ip nhrp network-id 99 
 ip nhrp holdtime 300
 ip nhrp nhs 10.0.0.1
 ip tcp adjust-mss 1360
 delay 1000
 tunnel source Ethernet0
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile vpnprof
!
interface Ethernet0
 ip address dhcp hostname Spoke1
!
interface Ethernet1
 ip address 192.168.1.1 255.255.255.0
!
router eigrp 1
 network 10.0.0.0 0.0.0.255
 network 192.168.1.0 0.0.0.255

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Description of SNMP, SNMP MIBs, and how to configure SNMP on Cisco devices

The chapter "Configuring SNMP Support" in the Cisco IOS Network Management Configuration Guide


Standards

Standard
Title

None


MIBs

MIB
MIBs Link

CISCO-NHRP-MIB

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 2677

Definitions of Managed Objects for the NBMA Next Hop Resolution Protocol (NHRP)


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for NHRP MIB

Table 1 lists the release history for this feature.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 1 Feature Information for NHRP MIB 

Feature Name
Releases
Feature Information

NHRP MIB

12.4(20)T

The Cisco NHRP MIB feature introduces support for the NHRP MIB, which helps to manage and monitor Next Hop Resolution Protocol (NHRP) via Simple Network Management Protocol (SNMP). Statistics can be collected and monitored via standards-based SNMP techniques (get operations) to query objects defined in the NHRP MIB.

The following commands were introduced or modified: debug snmp mib nhrp, show snmp mib nhrp status.