This documentation has been moved
AutoQoS - VoIP
Downloads: This chapterpdf (PDF - 229.0KB) The complete bookPDF (PDF - 5.85MB) | Feedback

AutoQoS - VoIP

Table Of Contents

AutoQoS - VoIP

Finding Feature Information

Contents

Prerequisites for AutoQoS - VoIP

Restrictions for AutoQoS - VoIP

Information About AutoQoS - VoIP

Benefits of AutoQoS - VoIP

Design Considerations

Configurations for the Interface Configurations, Policy Maps, Class Maps, and ACLs

How to Configure the AutoQoS - VoIP Feature

Enabling the AutoQoS - VoIP Feature

Prerequisites for Using the auto qos Command

Restrictions for Using the auto qos Command

FAQs and Troubleshooting Tips

What to Do Next

Verifying the Configuration

Configuration Examples for AutoQoS - VoIP

Examples: Configuring the AutoQoS - VoIP Feature

Examples: Verifying the AutoQoS - VoIP Feature Configuration

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for AutoQoS - VoIP


AutoQoS - VoIP


First Published: March 17, 2003
Last Updated: March 22, 2011

The AutoQoS — VoIP feature allows you to automate the delivery of quality of service (QoS) on your network and provides a means for simplifying the implementation and provisioning of QoS for Voice over IP (VoIP) traffic.efr

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for AutoQoS - VoIP" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for AutoQoS - VoIP

Restrictions for AutoQoS - VoIP

Information About AutoQoS - VoIP

How to Configure the AutoQoS - VoIP Feature

Configuration Examples for AutoQoS - VoIP

Additional References

Feature Information for AutoQoS - VoIP

Prerequisites for AutoQoS - VoIP

Ensure that no QoS policies (service policies) are attached to the interface. This feature cannot be configured if a QoS policy (service policy) is attached to the interface.

To include Simple Network Protocol (SNMP) traps (monitored events), the SNMP server must be enabled.

Restrictions for AutoQoS - VoIP

General Restrictions

The AutoQoS — VoIP feature is supported on the following interfaces, data-link connection identifiers (DLCIs), and permanent virtual circuits (PVCs) only:

Serial interfaces with PPP or High-Level Data Link Control (HDLC)

Frame Relay DLCIs in point-to-point subinterfaces only

ATM PVCs

The AutoQoS — VoIP feature is supported on low-speed ATM PVCs in point-to-point subinterfaces only. The AutoQoS — VoIP feature is supported on high-speed ATM PVCs in any type of subinterface.


Note An ATM PVC is classified as low-speed if its bandwidth is less than or equal to 768 kbps; an ATM PVC is classified as high-speed if its bandwidth is greater than 768 kpbs


Frame Relay-to-ATM Interworking links

Serial Interface Restrictions

For a serial interface with a low-speed link, Multilink PPP (MLP) is configured automatically. The serial interface must have an IP address. When MLP is configured, this IP address is removed and put on the MLP bundle. To ensure that the traffic goes through the low-speed link, the following conditions must be met:

The AutoQoS - VoIP feature must be configured at the both ends of the link.

The amount of bandwidth configured must be the same on both ends of the link.

Frame Relay DLCI Restrictions

The AutoQoS — VoIP feature cannot be configured on a Frame Relay DLCI if a map class is attached to the DLCI.

If a Frame Relay DLCI is already assigned to one subinterface, the AutoQoS — VoIP feature cannot be configured from a different subinterface.

For low-speed Frame Relay DLCIs configured for use on Frame Relay-to-ATM networks, MLP over Frame Relay (MLPoFR) is configured automatically. The subinterface must have an IP address.

When MLPoFR is configured, this IP address is removed and put on the MLP bundle. The AutoQoS — VoIP feature must also be configured on the ATM side of the network.

For low-speed Frame Relay DLCIs with Frame Relay-to-ATM Interworking, the AutoQoS — VoIP feature cannot be configured if a virtual template is already configured for the DLCI.

ATM PVC Restrictions

For a low-speed ATM PVC, the AutoQoS — VoIP feature cannot be configured if a virtual template is already configured for the ATM PVC.

For low-speed ATM PVCs, MLP over ATM (MLPoATM) is configured automatically. The subinterface must have an IP address.

When MLPoATM is configured, this IP address is removed and put on the MLP bundle. The AutoQoS — VoIP feature must also be configured on the ATM side of the network.

Information About AutoQoS - VoIP

To configure the AutoQoS — VoIP feature, you need to understand the following concepts:

Benefits of AutoQoS - VoIP

Design Considerations

Configurations for the Interface Configurations, Policy Maps, Class Maps, and ACLs

Benefits of AutoQoS - VoIP

The key benefits of the AutoQos -VoIP feature include the following:

Customers can implement the QoS features required for VoIP traffic without an in-depth knowledge of the following underlying technologies:

PPP

Frame Relay

ATM

Service policies

Link efficiency mechanisms (LEM), such as Link Fragmentation and Interleaving (LFI)

The AutoQoS — VoIP feature simplifies QoS implementation and speeds up the provisioning of QoS technology over a Cisco network. It reduces human error and lowers training costs. With the AutoQoS — VoIP feature, one command (the auto qos command) enables QoS for VoIP traffic across every Cisco router and switch.

Customers can also use existing Cisco IOS commands to modify the configurations automatically generated by the AutoQoS — VoIP feature as needed to meet specific requirements.

The Cisco product, CiscoWorks QoS Policy Manager (QPM), can be used in conjunction with the AutoQoS — VoIP feature to provide a centralized, web-based tool to cost effectively manage and monitor network-wide QoS policies. The AutoQoS — VoIP feature together with CiscoWorks QPM, eases QoS implementation, provisioning, and management.

Design Considerations

General QoS Requirements

Recommended methods and values are configured to meet the QoS requirements for voice traffic.

The AutoQoS — VoIP feature takes the interface type and bandwidth into consideration when implementing the following QoS features:

Classification

Classification is used to differentiate the voice packets from the data packets and handle the voice packets appropriately.

Low latency queueing (LLQ) - Priority Queueing (PQ)

The LLQ (specifically, PQ) is applied to the voice packets to meet the latency requirements.

Compressed Real-Time Protocol (cRTP)

With cRTP, the 40-byte IP header of the voice packet is reduced from 2 to 4 bytes, thereby reducing voice bandwidth requirements. cRTP must be applied at both ends of a network link.

LFI

LFI is used to reduce the jitter of voice packets by preventing voice packets from getting delayed behind large data packets in a queue. LFI must be applied at both ends of a network link.

Bandwidth Implications

The bandwidth of the serial interface determines the speed of the link. The speed of the link in turn determines the configurations generated by the AutoQoS — VoIP feature.


Note Changing the bandwidth before configuring the AutoQoS — VoIP feature is not recommended.


The AutoQoS — VoIP feature uses the bandwidth at the time the feature is configured. AutoQoS — VoIP does not respond to changes made to bandwidth after the feature is configured.

For example, if the auto qos voip command is used to configure the AutoQoS — VoIP feature on an interface with 1000 Kbps, the AutoQoS — VoIP feature generates configurations for high-speed interfaces. However, if the bandwidth is later changed to 500 Kbps, the AutoQoS — VoIP feature will not use the lower bandwidth. The AutoQoS — VoIP feature retains the higher bandwidth and continues to use the generated configurations for high-speed interfaces.

To force the AutoQoS — VoIP feature to use the lower bandwidth (and thus generate configurations for the low-speed interfaces), use the no auto qos voip command to remove the AutoQoS — VoIP feature and then reconfigure the feature.

Fragmentation for Frame Relay Networks

For Frame Relay networks, fragmentation is configured using a delay of 10 milliseconds (ms) and a minimum fragment size of 60 bytes. This ensures that the VoIP packets are not fragmented. However, when the G.711 coder-decoder (codec) is used on low-speed links, the fragment size configured by the AutoQoS — VoIP feature could be smaller than the size of the G.711 VoIP packet.

To solve this potential problem, choose one of the following:

Change the fragment size to the required value.

Change the size of the G.711 VoIP packet to a smaller value.

For example, if the AutoQoS — VoIP feature is configured on a Frame Relay DLCI with 128 Kbps, the fragment size configured by the AutoQoS — VoIP feature will be 160 bytes. The size of the G.711 VoIP packet will be 160 bytes, minus the bytes in the packet headers for the layers. The workaround is to either change the fragment size from 160 bytes to 220 bytes or change the size of the G.711 VoIP packet from 160 bytes to 80 bytes.

Signaling Protocols

The AutoQoS — VoIP feature currently identifies the following signaling protocols:

H.323

H.225 (Unicast only)

Session Initiation Protocol (SIP)

"Skinny" gateway protocol

Media Gateway Control Protocol (MGCP)


Note Access control lists (ACLs) can be configured to identify any additional signaling protocols that may be needed.


Configurations for the Interface Configurations, Policy Maps, Class Maps, and ACLs

The AutoQoS — VoIP feature automatically creates configurations that are then used for the interface configurations, policy maps, class maps, and ACLs. The interface configurations, policy maps, class maps, and ACLs are created to classify VoIP packets and to provide the appropriate QoS treatment for the network traffic.

This feature also creates interface (or PVC)-specific configurations. These interface (or PVC)-specific configurations are created according to the interface type and the link speed.


Note Links with bandwidths lower than or equal to 768 kpbs are considered low-speed links; links with bandwidths higher than 768 kpbs are considered high-speed links.


How to Configure the AutoQoS - VoIP Feature

This section contains the following tasks. Each task is identified as either required or optional.

Enabling the AutoQoS - VoIP Feature (required)

Verifying the Configuration (optional)

Enabling the AutoQoS - VoIP Feature

Prerequisites for Using the auto qos Command

Before using the auto qos command at an interface or an ATM PVC, ensure that the following prerequisites have been met:

Cisco Express Forwarding (CEF) must be enabled at the interface or ATM PVC.

If the interface or subinterface has a link speed of 768 kpbs or lower, configure the primary or secondary IP address of the interface by using the ip address command.

For all interfaces or subinterfaces, configure the amount of bandwidth by using the bandwidth command. The amount of bandwidth allocated should be based on the link speed of the interface.

For an ATM PVC, configure the variable bit rate (VBR) by using either the vbr-nrt command or the vbr-rt command or configure the constant bit rate (CBR) by using the cbr command.

Restrictions for Using the auto qos Command

The auto qos voip command is not supported on subinterfaces.

Do not change the bandwidth of the interface before using the auto qos command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. bandwidth kilobits

5. vbr-nrt output-pcr output-scr output-mbs [input-pcr] [input-scr] [input-mbs]

6. vbr-rt peak-rate average-rate burst

7. cbr rate

8. pvc [name] vpi/vci [ces | ilmi | qsaal | smds]

9. ip address ip-address mask [secondary]

10. frame-relay interface-dlci dlci [ietf | cisco] [voice-cir cir] [ppp virtual-template-name]

11. auto qos voip [trust] [fr-atm]

12. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config-if)# interface s4/0

Configures an interface (or subinterface) type and enters interface configuration mode.

Enter the interface type number.

Step 4 

bandwidth kilobits

Example:

Router(config-if)# bandwidth 1540


(Optional) Sets a bandwidth value for an interface.

Enter the bandwidth value in kbps.

Note This step applies only to interfaces and subinterfaces. It is not required for ATM PVCs.

Step 5 

vbr-nrt output-pcr output-scr output-mbs [input-pcr] [input-scr] [input-mbs]

Example:

Router(config-if)# vbr-nrt 10000 5000 32 20000 10000 64


(Optional) Configures the variable bit rate-nonreal time (VBR-NRT) QoS and specifies the output peak cell rate (PCR), output sustainable cell rate (SCR), and output maximum burst cell size (MBS) for an ATM PVC, PVC range, switched virtual circuit (SVC), virtual circuit (VC) class, or VC bundle member.

Enter the output PCR, SCR, and MBS.

Note This step applies only to ATM PVCs. It is not required for interfaces or subinterfaces.

Step 6 

vbr-rt peak-rate average-rate burst

Example:

Router(config-if)# vbr-rt 640 56 80

(Optional) Configures the real-time VBR for Voice over ATM connections.

Enter the peak information rate (PIR), the average information rate (AIR), and the burst size.

Note This step applies only to ATM PVCs. It is not required for interfaces or subinterfaces.

Step 7 

cbr rate
Example:

Router(config-if-atm-vc)# cbr 56


(Optional) Configures the CBR for the ATM circuit emulation service (CES) for an ATM PVC.

This command can be used in different modes, including ATM-VC configuration mode (for ATM PVCs and SVCs), ATM PVC range configuration mode (for an ATM PVC range), or ATM PVC-in-range configuration mode (for an individual PVC within a PVC range).

Enter the CBR.

Note This step applies only to ATM PVCs. It is not required for interfaces or subinterfaces.

Step 8 

pvc [name] vpi/vci [ces | ilmi | qsaal | smds]
Example:

Router(config-if)# pvc 1/32


(Optional) Creates or assigns a name to an ATM PVC and specifies the encapsulation type on an ATM PVC.

Enter the ATM network virtual path identifier (VPI) and the ATM network virtual channel identifier (VCI) for the ATM PVC.

Note This step applies only to ATM PVCs. It is not required for interfaces or subinterfaces.

Step 9 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 10.10.100.1 255.255.255.0

(Optional) Sets a primary or secondary IP address for an interface.

Note Applies only to low-speed interfaces (that is, interfaces with link speeds of 768 kbps or lower.)

Step 10 

frame-relay interface-dlci dlci [ietf | cisco] 
[voice-cir cir] [ppp virtual-template-name] 
Example:

Router(config-if)# frame-relay interface-dlci 100


(Optional) Assigns a DLCI to a specified Frame Relay subinterface on the router or access server, or assigns a specific PVC to a DLCI, or applies a virtual template configuration for a PPP session.

Enter the DLCI number.

Note This step applies only to Frame Relay interfaces (either low-speed or high-speed).

Step 11 

auto qos voip [trust] [fr-atm]

Example:

Router(config-if)# auto qos voip

or

Router(config-fr-dlci)# auto qos voip


Configures the AutoQoS — VoIP feature.

Note For low-speed Frame Relay DLCIs interconnected with ATM PVCs in the same network, the fr-atm keyword must be explicitly configured in the auto qos voip command to configure the AutoQoS - VoIP feature properly. That is, the command must be configured as auto qos voip fr-atm.

Step 12 

exit

Example:

Router(config-if)# exit

(Optional) Returns to interface configuration mode.


FAQs and Troubleshooting Tips

Below are answers to frequently asked questions (FAQs) and tips for troubleshooting situations that you may encounter when configuring or using the AutoQoS — VoIP feature.

Why can't I configure the AutoQoS - VoIP feature?

To configure the feature, CEF must be is enabled. Verify that CEF is enabled on your network.

Also, the feature cannot be enabled if a service policy is already attached to the interface. Determine whether there is a service policy attached to the interface. If so, remove the service policy from the interface.

Why isn't the AutoQoS - VoIP feature supported on my router?

The AutoQoS — VoIP feature is supported only on the IP Plus image for lower-end platforms. Verify that you have the IP Plus image installed on your router.

Why are some of my QoS configurations still present after I disable the AutoQoS - VoIP feature?

You have to manually disable any QoS configurations that were modified by the AutoQoS — VoIP feature.

Why did my low-speed network link go down when I enabled the AutoQoS - VoIP feature?

Ensure that AutoQoS — VoIP is enabled on both sides of the network link.

Why can't I establish an end-to-end connection on the Frame Relay link?

Check the bandwidth on both sides of the Frame Relay link. The bandwidth on both sides of the link must be the same, otherwise a fragmentation size mismatch occurs and a connection cannot be established.


Note For more help, see the "Technical Assistance" section.


What to Do Next

If the interface configurations, policy maps, class maps, and ACLs created (on the basis of the configurations created by the AutoQoS - VoIP feature) do not meet the needs of your network, the interface configurations, policy maps, class maps, and ACLs can be modified using the appropriate Cisco IOS commands.


Note While you can modify the interface configurations, policy maps, class maps, and ACLs, they may not be removed properly when the AutoQoS — VoIP feature is disabled using the no auto qos command. You may need to manually remove any modified interface configurations, policy maps, class maps, and ACLs. For more information about the no auto qos command, see the Cisco IOS Quality of Service Solutions Command Reference.


Verifying the Configuration

SUMMARY STEPS

1. enable

2. show auto qos [interface [interface type]]

3. show policy-map interface [interface type]

4. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

show auto qos [interface [interface type]]

Example:

Router# show auto qos interface s4/0

(Optional) Displays the interface configurations, policy maps, class maps, and ACLs created on the basis of automatically generated configurations.

The interface configurations, policy maps, class maps, and ACLs can be displayed for a specific interface or all interfaces.

Step 3 

show policy-map interface [interface type]

Example:

Router# show policy-map interface s4/0

(Optional) Displays the packet statistics of all classes that are configured for all service policies either on the specified interface or subinterface or on a specific PVC on the interface.

The packet statistics can be displayed for a specific interface, subinterface, PVC, or all interfaces, subinterfaces, or PVCs.

Step 4 

exit

Example:

Router# exit

(Optional) Exits privileged EXEC mode.


Configuration Examples for AutoQoS - VoIP

This section provides the following configuration examples:

Examples: Configuring the AutoQoS - VoIP Feature

Examples: Verifying the AutoQoS - VoIP Feature Configuration

Examples: Configuring the AutoQoS - VoIP Feature

When the auto qos voip command is used to configure the AutoQoS — VoIP feature, configurations are generated. These configurations are then used to create interface configurations, policy maps, class maps, and aCLs.

This section contains the following examples of configuring the AutoQoS — VoIP feature on the interfaces, PVCs, and links.

Configuring the AutoQoS - VoIP Feature on a High-Speed Serial Interface Example

In this example, the AutoQoS — VoIP feature is configured on the high-speed serial interface s1/2.

Router> enable
Router# configure terminal

Router(config)# interface s1/2

Router(config-if)# bandwidth 1540

Router(config-if)# auto qos voip

Router(config-if)# exit

Configuring the AutoQoS - VoIP Feature on a Low-Speed Serial Interface Example

In this example, the AutoQoS — VoIP feature is configured on the low-speed serial interface s1/3.

Router# configure terminal

Router(config)# interface s1/3

Router(config-if)# bandwidth 512

Router(config-if)# ip address 10.10.100.1 255.255.255.0

Router(config-if# auto qos voip

Router(config-if)# exit

Configuring the AutoQoS - VoIP Feature on High-Speed Frame Relay Interfaces Example

In this example, the AutoQoS — VoIP feature is configured on the high-speed serial point-to-point Frame Relay subinterface s4/1.2.

Router> enable
Router# configure terminal

Router(config)# interface s4/1.2 point-to-point

Router(config-if)# bandwidth 1540

Router(config-if)# frame-relay interface-dlci 100

Router(config-fr-dlci)# auto qos voip

Router(config-if)# exit

Configuring the AutoQoS - VoIP Feature on Low-Speed Frame Relay Interfaces Example

In this example, the AutoQoS — VoIP feature is configured on the low-speed point-to-point Frame Relay subinterface s4/2.1.

Router# configure terminal

Router(config)# interface s4/2.1 point-to-point

Router(config-if)# bandwidth 512

Router(config-if)# ip address 10.10.100.1 255.255.255.0

Router(config-if)# frame-relay interface-dlci 100

Router(config-fr-dlci)# auto qos voip

Router(config-if)# exit

Configuring the AutoQoS - VoIP Feature on a High-Speed ATM PVC Example

In this example, the AutoQoS — VoIP feature is configured on the high-speed point-to-point ATM PVC ATM5/0.1.

Router# configure terminal

Router(config)# interface ATM5/0.1 point-to-point

Router(config-if)# pvc 1/32

Router(config-if)# vbr-nrt 1540 1540

Router(config-if)# auto qos voip

Router(config-if)# exit

Configuring the AutoQoS - VoIP Feature on a Low-Speed ATM PVC Example

In this example, the AutoQoS — VoIP feature is configured on a low-speed point-to-point ATM PVC ATM5/0.2.

Router# configure terminal

Router(config)# interface ATM5/0.2 point-to-point

Router(config-if)# ip address 10.10.100.1 255.255.255.0

Router(config-if)# pvc 1/32

Router(config-if)# vbr-nrt 512 512

Router(config-if)# auto qos voip

Router(config-if)# exit

Configuring the AutoQoS - VoIP Feature for Frame Relay-to-ATM Interworking Example

In this example, the AutoQoS — VoIP feature is configured for Frame Relay-to-ATM Interworking. The AutoQoS — VoIP feature is configured on the serial point-to-point subinterface s1/3.1.

Router# configure terminal

Router(config)# interface s1/3.1 point-to-point

Router(config-if)# bandwidth 512

Router(config-if)# ip address 10.10.100.1 255.255.255.0

Router(config-if)# frame-relay interface-dlci 100

Router(config-if)# auto qos voip fr-atm

Router(config-if)# exit


In this configuration, the optional fr-atm keyword is used to enable the AutoQoS — VoIP feature for the Frame Relay-to-ATM Interworking.


Note The ATM-to-ATM side of the network needs no special configuration to distinguish it from the ATM-to-Frame Relay side of the network.


Examples: Verifying the AutoQoS - VoIP Feature Configuration

When the auto qos voip command is used to configure the AutoQoS — VoIP feature, configurations are generated. These configurations are then used to create interface configurations, policy maps, class maps, and ACLs. The show auto qos interface command can be used to verify the contents of the interface configurations, policy maps, class maps, and ACLs.

This section contains the following sample output of the show auto qos interface command for interfaces, PVCs, and links.


Note The show auto qos interface command output displays only those configurations created by the AutoQoS - VoIP feature.


Sample show auto qos interface Command Output for a High-Speed Serial Interface

The following is sample output of the show auto qos command for a high-speed serial interface:

Router# show auto qos interface s6/0

 Serial6/0 -
 !
  interface Serial6/0 
   service-policy output AutoQoS-Policy-UnTrust 

Sample show auto qos interface Command Output for a Low-Speed Serial Interface

The following is sample output of the show auto qos interface command for a low-speed serial interface:

Router# show auto qos interface s6/0

 Serial6/0 -
 !
  interface Serial6/0 
   no ip address 
   encapsulation ppp 
   no fair-queue 
   ppp multilink 
   multilink-group 2001100126 
 !
  interface Multilink2001100126 
   bandwidth 512 
   ip address 10.10.100.1 255.255.255.0 
   service-policy output AutoQoS-Policy-UnTrust 
   ppp multilink 
   ppp multilink fragment-delay 10 
   ppp multilink interleave 
   ip rtp header-compression iphc-format 

Sample show auto qos Interface Command Output for a High-Speed Frame Relay Interface

The following is sample output of the show auto qos command for a high-speed Frame Relay interface:

Router# show auto qos interface s6/1.1

 Serial6/1.1: DLCI 100 -
 !
  interface Serial6/1 
   frame-relay traffic-shaping 
 !
  interface Serial6/1.1 point-to-point 
   frame-relay interface-dlci 100    
    class AutoQoS-VoIP-FR-Serial6/1-100 
 !
  map-class frame-relay AutoQoS-VoIP-FR-Serial6/1-100 
   frame-relay cir 1540000 
   frame-relay bc 15400 
   frame-relay be 0 
   frame-relay mincir 1540000 
   service-policy output AutoQoS-Policy-UnTrust 

Note The output of the show autoqos interface command for high-speed Frame Relay interfaces is similar to the output for low-speed Frame Relay interfaces. The only difference is that Frame Relay Fragmentation and cRTP are not configured for high-speed Frame Relay interfaces.


Sample show auto qos interface Command Output for a Low-Speed Frame Relay Interface

The following is sample output of the show auto qos command for a low-speed Frame Relay interface:

Router# show auto qos interface s6/1.1

 Serial6/1.1: DLCI 100 -
 !
  interface Serial6/1 
   frame-relay traffic-shaping 
 !
  interface Serial6/1.1 point-to-point 
   frame-relay interface-dlci 100    
    class AutoQoS-VoIP-FR-Serial6/1-100 
   frame-relay ip rtp header-compression 
 !
  map-class frame-relay AutoQoS-VoIP-FR-Serial6/1-100 
   frame-relay cir 512000 
   frame-relay bc 5120 
   frame-relay be 0 
   frame-relay mincir 512000 
   service-policy output AutoQoS-Policy-UnTrust 
   frame-relay fragment 640 

Sample show auto qos interface Command Output for a High-Speed ATM PVC

The following is sample output of the show auto qos command for a high-speed ATM PVC:

Router# show auto qos interface a2/0.1

 ATM2/0.1: PVC 1/100 -
 !
  interface ATM2/0.1 point-to-point 
   pvc 1/100  
    tx-ring-limit 3 
    service-policy output AutoQoS-Policy-UnTrust 

Sample show auto qos interface Command Output for a Low-Speed ATM PVC

The following is sample output of the show auto qos command for a low-speed ATM PVC:

Router# show auto qos interface a2/0.1

 ATM2/0.1: PVC 1/100 -
 !
  interface ATM2/0.1 point-to-point 
   pvc 1/100  
    tx-ring-limit 3 
    encapsulation aal5mux ppp Virtual-Template200 
 !
  interface Virtual-Template200 
   bandwidth 512 
   ip address 10.10.100.1 255.255.255.0 
   service-policy output AutoQoS-Policy-UnTrust 
   ppp multilink 
   ppp multilink fragment-delay 10 
   ppp multilink interleave 

Sample show auto qos interface Command Output for Frame Relay-to-ATM Interworking Links

The following is sample output of the show auto qos command for Frame Relay-to-ATM Interworking links:

Router# show auto qos interface s6/1.1

 Serial6/1.1: DLCI 100 -
 !
  interface Serial6/1 
   frame-relay traffic-shaping 
 !
  interface Serial6/1.1 point-to-point 
   frame-relay interface-dlci 100 ppp Virtual-Template200 
    class AutoQoS-VoIP-FR-Serial6/1-100 
 !
  interface Virtual-Template200 
   bandwidth 512 
   ip address 10.10.100.1 255.255.0.0 
   service-policy output AutoQoS-Policy-UnTrust 
   ppp multilink 
   ppp multilink fragment-delay 10 
   ppp multilink interleave 
 !
  map-class frame-relay AutoQoS-VoIP-FR-Serial6/1-100 
   frame-relay cir 512000 
   frame-relay bc 5120 
   frame-relay be 0 
   frame-relay mincir 512000 

Additional References

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Related Documents

Related Topic
Document Title

QoS commands: complete command syntax, command modes, command history, defaults, usage guidelines, and examples

Cisco IOS Quality of Service Solutions Command Reference

LFI and cRTP

"Header Compression" module

Packet classification

"Classifying Network Traffic" module

LLQ

"Configuring Weighted Fair Queueing" module

Service policies (policy maps)

"Applying QoS Features Using the MQC" module

Frame Relay and ATM commands: complete command syntax, command modes, command history, defaults, usage guidelines, and examples

Cisco IOS Wide-Area Networking Command Reference

Frame Relay configuration

"Configuring Frame Relay" module

MLPPP

"Configuring Media-Independent PPP and Multilink PPP" module

CEF

"Cisco Express Forwarding Features Roadmap" module

SNMP

"Configuring SNMP Support" module

CiscoWorks QoS Policy Manager (QPM)

Product information available online at Cisco.com


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing standards has not been modified by this feature.

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing standards has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for AutoQoS - VoIP

Table 1 lists the features in this module and provides links to specific configuration information. Only features that were introduced or modified in Cisco IOS Release 12.2(15)T appear in the table.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.

Table 1 Feature Information for AutoQoS - VoIP

Feature Name
Releases
Feature Information

AutoQoS—VoIP

12.2(15)T
Cisco IOS XE 3.1.0 SG

The AutoQoS — VoIP feature allows you to automate the delivery of quality of service (QoS) on your network and provides a means for simplifying the implementation and provisioning of QoS for Voice over IP (VoIP) traffic.

The following commands are new or modified: auto qos voip, show auto qos.

In Cisco IOS XE 3.1.0 SG, this feature was integrated.