This documentation has been moved
NSF/SSO/ISSU Support for VPLS
Downloads: This chapterpdf (PDF - 320.0KB) The complete bookPDF (PDF - 11.12MB) | Feedback

NSF/SSO/ISSU Support for VPLS

Table Of Contents

NSF/SSO/ISSU Support for VPLS

Contents

Prerequisites for NSF/SSO/ISSU Support for VPLS

Restrictions for NSF/SSO/ISSU Support for VPLS

Information About NSF/SSO/ISSU Support for VPLS

How NSF/SSO Works with VPLS

How ISSU Works with VPLS

How to Configure NSF/SSO/ISSU Support for VPLS

Configuring VPLS

Configuring NSF/SSO: Any Transport over MPLS

Configuring NSF/SSO Router support

Configuring ISSU Router Support

Verifying and Troubleshooting NSF/SSO/ISSU Support for VPLS

Configuration Examples for NSF/SSO/ISSU Support for VPLS

NSF/SSO/ISSU VPLS: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

Feature Information for NSF/SSO/ISSU Support for VPLS


NSF/SSO/ISSU Support for VPLS


First Published: January 7, 2008
Last Updated: January 7, 2008

Virtual Private LAN Services (VPLS), with nonstop forwarding (NSF), stateful switchover (SSO), and in service software upgrade (ISSU) support, improves the availability of service provider networks that use VPLS for multipoint Layer 2 virtual private network (VPN) services. Cisco NSF with SSO is effective at increasing availability of network services. Cisco NSF with SSO provides continuous packet forwarding, even during a network processor hardware or software failure. In a redundant system, the secondary processor recovers control plane service in the event of a critical failure in the primary processor, while SSO synchronizes the network state information between the primary and the secondary processor.

In conjunction with VPLS NSF/SSO, VPLS High Availability (HA) features include the ISSU capability. Working together, ISSU and NSF/SSO enable upgrades or downgrades of a Cisco IOS image without control and data plane outages.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. For the latest feature information and caveats, see the release notes for your Cisco IOS software release. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the Feature Information for NSF/SSO/ISSU Support for VPLS.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for NSF/SSO/ISSU Support for VPLS

Restrictions for NSF/SSO/ISSU Support for VPLS

Information About NSF/SSO/ISSU Support for VPLS

How to Configure NSF/SSO/ISSU Support for VPLS

Verifying and Troubleshooting NSF/SSO/ISSU Support for VPLS

Configuration Examples for NSF/SSO/ISSU Support for VPLS

Additional References

Command Reference

Feature Information for NSF/SSO/ISSU Support for VPLS

Prerequisites for NSF/SSO/ISSU Support for VPLS

This section lists the following prerequisites that are required to use the NSF/SSO/ISSU Support for VPLS feature.

You must configure the following features on your network:

VPLS (see the "Virtual Private LAN Services on the Optical Services Modules" chapter in the
Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SR)

VPLS Autodiscovery (see VPLS Autodiscovery: BGP Based and BGP Support for the L2VPN Address Family)

NSF/SSO: Any Transport over MPLS (see NSF/SSO—Any Transport over MPLS and AToM Graceful Restart)

NSF/SSO router support on the 7600 router (see the "Configuring NSF with SSO Supervisor Engine Redundancy" chapter in the Cisco 7600 Series Cisco IOS Software Configuration Guide, Release 12.2SR)

ISSU router support on the 7600 router (see the "ISSU and eFSU on Cisco 7600 Series Routers" chapter in the Cisco 7600 Series Cisco IOS Software Configuration Guide, Release 12.2SR)

Restrictions for NSF/SSO/ISSU Support for VPLS

The NSF/SSO/ISSU Support for VPLS feature has the following restrictions:

NSF/SSO/ISSU support for VPLS does not include support for PWs to auto discovered neighbors via Border Gateway Protocol (BGP). Statically configured neighbors are supported.

For supported hardware, see the Cisco Release 12.2SR Release Notes.

NSF/SSO/ISSU support for VPLS does not include support for line cards that do not support Minimal Disruptive Restart (MDR) or pre downloading of firmware or driver code.

Information About NSF/SSO/ISSU Support for VPLS

To configure the NSF/SSO/ISSU Support for VPLS feature, you should understand the following concepts:

How NSF/SSO Works with VPLS

How ISSU Works with VPLS

How NSF/SSO Works with VPLS

VPLS with NSF/SSO support improves the availability of service provider networks that use VPLS for multipoint Layer 2 VPN services. HA minimizes service disruptions that can occur if a system failure occurs. To address failures, VPLS HA includes SSO and NSF mechanisms using a standby Route Processor (RP) to provide control-plane redundancy. VPLS NSF is achieved by SSO and NSF mechanisms.

While the standby RP transitions to the active RP, packet forwarding either continues forwarding on line card(s) or packet forwarding is switched over (switchover) to other hardware devices associated with the newly active RP.

How ISSU Works with VPLS

In conjunction with VPLS NSF/SSO, VPLS HA includes ISSU, a comprehensive in-service upgrade solution for the IP/MPLS edge. ISSU minimizes network downtime due to software upgrades and maintenance activities. ISSU allows upgrades or downgrades to Cisco IOS software images with no effect on the control plane and minimal effect on system packet forwarding. With ISSU, all message data structures used for checkpointing, and exchanges between the active RP and standby RP are versioned.

To perform an in-service upgrade, the standby RP in a dual RP-based platform (such as the Cisco 7600 router) is first loaded with the desired Cisco IOS software release. The standby RP then comes up as a hot-standby RP with an upgraded version of the software, and a switchover is performed to transfer control to the standby RP and run the upgraded image.

During the ISSU procedure, supported SSO protocols and features maintain their session states with no disruption of the Layer 2 protocol sessions. Cisco NSF technology is used to continue packet forwarding during the software upgrade procedure while the routing information is re-created on the newly active RP. The result is a seamless software upgrade for an IP/MPLS provider edge router with no disruptions to Layer 2 protocol sessions and minimal effect on packet forwarding.

Benefits

Primary benefits for ISSU are:

Rapid, nondisruptive feature deployment—By preserving user sessions and minimizing packet loss during software upgrades, ISSU helps enable rapid, nondisruptive deployments for new features and services at the IP/MPLS provider edge.

Comprehensive solution for planned downtime—ISSU addresses the entire spectrum of software upgrade needs, from applying caveat fixes to deploying new features and services, and delivers a comprehensive solution for addressing planned network downtime.

Increased operational efficiencies—ISSU minimizes and streamlines planned downtime and helps enable operational process changes for software deployment, significantly decreasing planned downtime effort and expenses and increasing operational efficiency.

How to Configure NSF/SSO/ISSU Support for VPLS

This section contains the following procedures:

Configuring VPLS (required)

Configuring NSF/SSO: Any Transport over MPLS (required)

Configuring NSF/SSO Router support (required)

Configuring ISSU Router Support (required)

Configuring VPLS

VPLS must be configured on the router. See the "Virtual Private LAN Services on the Optical Services Modules" chapter in the Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SR for information on configuring VPLS.

Configuring NSF/SSO: Any Transport over MPLS

You must configure the NSF/SSO: Any Transport over MPLS feature on the router. See the NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature module for information on configuring the NSF/SSO: Any Transport over MPLS feature.

Configuring NSF/SSO Router support

You must configure NSF/SSO router support on the Cisco 7600 router. See the "Configuring NSF with SSO Supervisor Engine Redundancy" chapter in the Cisco 7600 Series Cisco IOS Software Configuration Guide, Release 12.2SR for information on configuring the NSF with SSO Supervisor Engine Redundancy feature.

Configuring ISSU Router Support

You must configure ISSU router support on the Cisco 7600 router.

See the "ISSU and eFSU on Cisco 7600 Series Routers" chapter in the Cisco 7600 Series Cisco IOS Software Configuration Guide, Release 12.2SR for information on configuring ISSU and Enhanced Fast Software Upgrade (eFSU) on Cisco 7600 series routers.

Verifying and Troubleshooting NSF/SSO/ISSU Support for VPLS

To verify the NSF/SSO/ISSU Support for VPLS configuration, use the following show and debug commands:

DETAILED STEPS

1. show checkpoint clients

2. show vfi [name vfi-name] checkpoint [summary]

3. debug cwan atom

4. debug cwan ltl

5. debug issu client negotiation

6. debug issu client registration

7. debug issu client transform

8. debug vfi checkpoint

DETAILED STEPS


Step 1 show checkpoint clients

Use this command to display information about checkpoint clients:

Router# show checkpoint clients

                         Check Point List of Clients

 CHKPT on ACTIVE server.

--------------------------------------------------------------------------------
Client Name         Client  Entity  Bundle
                        ID      ID    Mode
--------------------------------------------------------------------------------
CHKPT Test client        1     --     On

  Total API Messages Sent:             0
  Total IPC Sent:                      0
  Total Message Len:                   0
  Total Bytes Allocated:               0
  Buffers Held:                        0
  IPC Frag Count:                      0
  IPC HW mark:                         0
  IPC Sends w/Flow Off:                0
  Send Errs:                           0
  Send Peer Errs:                      0
  Rcv Xform Errs:                      0
  Xmit Xform Errs:                     0
  Incompatible Messages:               0
--------------------------------------------------------------------------------
Client Name         Client  Entity  Bundle
                        ID      ID    Mode
--------------------------------------------------------------------------------
Network RF Client        3     --    Off

  Total API Messages Sent:            10
  Total IPC Sent:                     10
  Total Message Len:                2144
  Total Bytes Allocated:            2904
  Buffers Held:                        0
  IPC Frag Count:                      0
  IPC HW mark:                         0
  IPC Sends w/Flow Off:                0
  Send Errs:                           0
  Send Peer Errs:                      0
  Rcv Xform Errs:                      0
  Xmit Xform Errs:                     0
  Incompatible Messages:               0
--------------------------------------------------------------------------------
Client Name         Client  Entity  Bundle
                        ID      ID    Mode
 --More-- 
.
.
.

Step 2 show vfi [name vfi-name] checkpoint [summary]

Use this command to display checkpoint information related to a specific virtual forwarding instance (VFI) named H-VPLS-A-VFI:

Router# show vfi name H-VPLS-A-VFI checkpoint

VFI Active RP
 Checkpointing: Allowed
 ISSU Client id: 2092, Session id: 65543, Compatible with peer

                                 VFI      VFI AC      VFI PW
 Bulk-sync                         1           1           3
 Checkpoint failures:              0           3          21
 Recovered at switchover:          0           0           0
 Recovery failures:                0           0           0

Legend: C=Checkpointed

VFI name: H-VPLS-A-VFI, state: up, type: multipoint
  VPN ID: 12, Internal ID 1 C
  Local attachment circuits:
    Vlan200  16387 / 8195  C
Neighbors connected via pseudowires:
    Peer ID          VC ID               SSM IDs
    10.0.0.12      12                  4096 / 12292       C 
    10.0.0.15      12                  8193 / 16389       C 
    10.0.0.14      12                  12290 / 20486      C 

Step 3 debug cwan atom

Use this command to enable debugging of Any Transport over MPLS (AToM) platform events.

The following example shows debug message output that appears when debugging is enabled and a PW port is configured and then unconfigured:

Router# debug cwan atom

ConstWan Generic AToM debugging is on
Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router#(config)# l2 vfi VPLS-2000 manual
Router#(config-vfi)# vpn id 2000     
Router#(config-vfi)# neighbor 10.1.1.1 encapsulation mpls
Router#(config-vfi)#
01:16:36: cwan_rp_vfi_atom_provision_vlan PROV[VFI-ATOM]: plat_index(0xC7D00084) 
vlanid(2000) pseudo_port(0x84) vfi_plat_index(0xC7D00084) seginfo(0x53D38220) segtype(25) 
seghandle(0x53AEE074) split-horizon(On) cwan_atom_intfs(3) vfi_vcs(3) spoke_vcs(0)
Router#(config-vfi)# end

Router# debug cwan atom

ConstWan Generic AToM debugging is on
Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# l2 vfi VPLS-2000
Router(config-vfi)# no neighbor 10.1.1.1 encapsulation mpls
Router(config-vfi)#
01:27:18: cwan_rp_vfi_atom_unprovision_vlan: UNPROV[VFI-ATOM]: circ_index(0xC7D00084) 
is_vfi(1) vlan(2000) vfi_vcs(3) spoke_vcs(0) split_horizon(On)
01:27:18: cwan_atom_vlan_remove_rp: Vlan2000 ip_iw(0) ip_enabled(0)
Router#(config-vfi)# end

Step 4 debug cwan ltl

Use this command to enable debugging of Local Target Manager (LTL) debugging events and errors.

The following example shows debug message outputs that appear when debugging is enabled and a PW port is configured and then unconfigured:


Router# debug cwan ltl

ConstWan LTL manager debugging is on
Router# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.
Router#(config)# l2 vfi VPLS-2000 manual
Router#(config-vfi)# vpn id 2000
Router#(config-vfi)# neighbor 10.1.1.1 encapsulation mpls
Router#(config-vfi)#

01:17:35: CWAN LTL MGR: Port 133 is free to use for VPLS with vlan 2000 - tx_tvc(0x9F404)
Router#(config-vfi)# end
Router# debug cwan ltl

ConstWan LTL manager debugging is on
Router# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# l2 vfi VPLS-2000 manual               
Router(config-vfi)# no neighbor 10.1.1.1 encapsulation mpls
Router(config-vfi)#

01:29:05: CWAN LTL MGR: DELETE VPLS PW vlan(2000) pseudo_slotunit(133)
Router(config-vfi)# end

Step 5 debug issu client negotiation

Use this command to enable debugging of ISSU client negotiation events and errors:

Router# debug issu client negotiation

*Jun  5 22:41:47.332: VFI ISSU: Negotiation rc ISSU_RC_NEGO_DONE, compatible
*Jun  5 22:41:47.332: AToM HA: CID 84 Seq 230 Event RF_PROG_STANDBY_CONFIG Op 0 State 
ACTIVE Peer STANDBY COLD-CONFIG
*Jun  5 22:41:47.432: ATOM ISSU: Propose L2HW cap 0xFFF rc 0
*Jun  5 22:41:47.532: ATOM ISSU: Active negotiator, accept compatible L2HW cap 0xFFF
*Jun  5 22:41:48.232: ATOM ISSU: Negotiation rc ISSU_RC_NEGO_DONE, compatible
*Jun  5 22:41:50.836: cwan_atom_issu_start_nego_session: Start session negotiation
*Jun  5 22:41:50.836: cwan_atom_issu_start_nego_session: Started nego successfully, 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:41:50.836: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:41:50.840: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:41:50.940: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:41:50.940: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:41:51.040: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:41:51.040: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:41:51.140: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:41:51.140: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:41:51.240: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:41:51.240: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:41:51.340: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:50:40.156: VFI ISSU: Negotiation rc ISSU_RC_NEGO_DONE, compatible
*Jun  5 22:50:40.156: AToM HA: CID 84 Seq 230 Event RF_PROG_STANDBY_CONFIG Op 0 State 
ACTIVE Peer STANDBY COLD-CONFIG
*Jun  5 22:50:40.256: ATOM ISSU: Passive negotiator, accept compatible L2HW cap 0xFFF
*Jun  5 22:50:40.964: ATOM ISSU: Negotiation rc ISSU_RC_NEGO_DONE, compatible
*Jun  5 22:50:43.516: cwan_atom_issu_start_nego_session: Start session negotiation
*Jun  5 22:50:43.516: cwan_atom_issu_start_nego_session: Started nego successfully, 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:50:43.520: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:50:43.520: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:50:43.620: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:50:43.620: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:50:43.720: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:50:43.720: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:50:43.820: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:50:43.820: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:50:43.920: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun  5 22:50:43.920: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg 
rc=ISSU_RC_NEGO_NOT_DONE
*Jun  5 22:50:44.020: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0

Step 6 debug issu client registration

Use this command to enable debugging of ISSU client registration events and errors.

After the peer router reloads, the following debug messages appear:

Router# debug issu client registration

Router# 

00:42:21: VFI ISSU: Unregistered ISSU session 0, ISSU_RC_OK
00:42:21: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to down
00:42:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet6/2, changed 
state to down
00:42:21: %LINK-3-UPDOWN: Interface Vlan2000, changed state to down
00:42:21: %LINK-3-UPDOWN: Interface Vlan2001, changed state to down
00:42:21: %LINK-3-UPDOWN: Interface Vlan2002, changed state to down
Router# 
00:42:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2000, changed state to down
00:42:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2001, changed state to down
00:42:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2002, changed state to down
Router# 
00:49:01: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to down
00:49:02: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to up
PE-3#
00:49:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet6/2, changed 
state to up
Router# 
00:49:35: %LINK-3-UPDOWN: Interface Vlan2000, changed state to up
00:49:35: %LINK-3-UPDOWN: Interface Vlan2001, changed state to up
00:49:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2000, changed state to up
00:49:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2001, changed state to up
00:49:35: %LINK-3-UPDOWN: Interface Vlan2002, changed state to up
Router# 
00:49:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2002, changed state to up
Router# 
00:49:48: VFI ISSU: Registered session 131171, ISSU_RC_OK
Router# 
00:50:08: %HA_CONFIG_SYNC-6-BULK_CFGSYNC_SUCCEED: Bulk Sync succeeded
Router# 

Step 7 debug issu client transform [clientID client-id]

Use this command to enable debugging of ISSU client transform events and errors.

The following command example enables debug output for a specific ISSU client (clientID 2092). After the peer router reloads, the following debug messages appear:

Router# debug issu client transform clientID 2092

Router# 

05:35:15: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to down
05:35:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet6/2, changed 
state to down
05:35:15: %LINK-3-UPDOWN: Interface Vlan2000, changed state to down
05:35:15: %LINK-3-UPDOWN: Interface Vlan2001, changed state to down
05:35:15: %LINK-3-UPDOWN: Interface Vlan2002, changed state to down
Router# 
05:35:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2000, changed state to down
05:35:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2001, changed state to down
05:35:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2002, changed state to down
Router# 
05:41:55: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to down
05:41:56: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to up
.
.
.
05:43:02: VFI ISSU: Xmit transform message 5, rc ISSU_RC_OK
05:43:02: ISSU Buffer dump @ 0x0817EC7C
05:43:02:     00 00 00 00 
05:43:02: VFI ISSU: Xmit transform message 1, rc ISSU_RC_OK
05:43:02: %HA_CONFIG_SYNC-6-BULK_CFGSYNC_SUCCEED succeeded
Router# 

Step 8 debug vfi checkpoint

Use this command to enable debugging VFI checkpointing events and errors:

Router# debug vfi checkpoint

Router# $may24_v1  6 slavedisk0:s72033-adventerprisek9_wan-mz.cflow_may24_v1

Router# 

*Jun  5 22:37:17.268: AToM HA: CF status 3 not processed
*Jun  5 22:37:17.268: VFI HA: CF status 3 not processed
*Jun  5 22:37:17.296: AC HA RF: CId:83, Seq:228, Sta:RF_STATUS_PEER_COMM, Opr:0, 
St:ACTIVE, PSt:STANDBY HOT
*Jun  5 22:37:17.296: VFI HA: CID 145, Seq 229, Status RF_STATUS_PEER_COMM, Op 0, State 
ACTIVE, Peer STANDBY HOT
*Jun  5 22:37:17.296: AToM HA: CID 84, Seq 230, Status RF_STATUS_PEER_COMM, Op 0, State 
ACTIVE, Peer STANDBY HOT
*Jun  5 22:37:17.444: AToM HA: CF status 3 not processed
*Jun  5 22:37:17.444: VFI HA: CF status 3 not processed
*Jun  5 22:37:17.268: %OIR-SP-3-PWRCYCLE: Card in module 6, is being power-cycled (RF 
request)
*Jun  5 22:37:17.792: AC HA RF: CId:83, Seq:228, Sta:RF_STATUS_PEER_PRESENCE, Opr:0, 
St:ACTIVE, PSt:DISABLED
*Jun  5 22:37:17.792: VFI HA: CID 145, Seq 229, Status RF_STATUS_PEER_PRESENCE, Op 0, 
State ACTIVE, Peer DISABLED
*Jun  5 22:40:40.244: SP-STDBY: SP: Currently running ROMMON from S (Gold) region
*Jun  5 22:40:45.028: %DIAG-SP-STDBY-6-RUN_MINIMUM: Module 6: Running Minimal 
Diagnostics...
*Jun  5 22:40:56.492: %DIAG-SP-STDBY-6-DIAG_OK: Module 6: Passed Online Diagnostics
*Jun  5 22:41:53.436: %SYS-SP-STDBY-5-RESTART: System restarted --
*Jun  5 22:42:12.760: VFI HA: CID 145 Seq 229 Event RF_PROG_STANDBY_BULK Op 0 State ACTIVE 
Peer STANDBY COLD-BULK
*Jun  5 22:42:12.764: VFI HA: Ignore RF progression event, VFI Mgr process is not running, 
skipped bulk sync 
.
.
.
*Jun  5 22:42:16.948: %ISSU_PROCESS-SP-7-DEBUG: Peer state is [ STANDBY HOT ]; Please 
issue the runversion command
*Jun  5 22:42:15.928: %PFREDUN-SP-STDBY-6-STANDBY: Ready for SSO mode
*Jun  5 22:42:16.956: %RF-SP-5-RF_TERMINAL_STATE: Terminal state reached for (SSO)
*Jun  5 22:42:16.112: %SYS-SP-STDBY-3-LOGGER_FLUSHED: System was paused for 00:00:00 to 
ensure console debugging output.
Router# 

Configuration Examples for NSF/SSO/ISSU Support for VPLS

The following example shows the configuration of a network using the NSF/SSO/ISSU Support feature for VPLS:

NSF/SSO/ISSU VPLS: Example

NSF/SSO/ISSU VPLS: Example

Figure 1 shows a basic configuration of NSF/SSO/ISSU VPLS.

Figure 1 Basic NSF/SSO/ISSU VPLS Configuration

CE1


CE1_7206#
!
hostname CE1_7206
!
ip cef
!
interface Loopback0
 description - FULL MESH VPN
 ip address 10.0.0.0 10.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.57.100 255.255.255.0
 no ip mroute-cache
 duplex half
 no cdp enable
!
interface FastEthernet1/0
 description - H-VPLS VPN to uPE1
 no ip address
 no ip mroute-cache
 duplex auto
 speed auto
!
interface FastEthernet1/0.1
 description - H-VPLS VPN to uPE1
 encapsulation dot1Q 121
 ip address 10.1.1.120 255.255.255.0
!
interface FastEthernet4/1
 description - FULL MESH VPN to PE1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4/1.1
 description - FULL MESH VPN to PE1
 encapsulation dot1Q 120
 ip address 10.1.1.120 255.255.255.0
!
interface FastEthernet6/1
 description - VPWS VPN to PE1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet6/1.1
 description - VPWS VPN to PE1
 encapsulation dot1Q 122
 ip address 10.1.1.120 255.255.255.0
!
router ospf 10
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 10.120.120.120 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0
!
ip default-gateway 10.0.57.1
!
end

uPE1


uPE1_7609#
!
upgrade fpd auto
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service internal
!
hostname uPE1_7609
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xx
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
ip host lab24 172.16.0.0
ip host dirt 172.16.0.19
!
vtp mode transparent
!
multilink bundle-name authenticated
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
!
vlan 100
!
interface Loopback0
 description - H-VPLS
 ip address 10.0.0.0 255.255.255.255
!
interface GigabitEthernet1/1
 description - H-VPLS to CE1
 switchport
 switchport trunk allowed vlan 10-1000
 switchport mode trunk
!
interface GigabitEthernet5/2
 ip address 10.0.0.0 255.255.255.0
 media-type rj45
 no cdp enable
!
interface GigabitEthernet9/0/0
 description - H-VPLS to PE1
 ip address 10.0.0.1 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 passive-interface Loopback0
 network 10.0.5.0 0.0.0.255 area 0
 network 10.0.0.8 0.0.0.0 area 0
!
ip route 172.16.17.19 255.255.255.255 10.0.57.1
ip route 172.16.0.0 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
control-plane
!
end

PE1


PE1_7613#
!
upgrade fpd auto
service internal
!
hostname PE1_7613
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xxx
boot-end-marker
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
ip host dirt 172.16.0.0
ip host lab24 172.16.0.01
!
ipv6 mfib hardware-switching replication-mode ingress
!
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
no mls acl tcam share-global
mls cef error action freeze
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
l2 vfi vpls_auto autodiscovery
 vpn id 1
!
l2 vfi vpls_man manual
 vpn id 10
 neighbor 10.0.0.12 encapsulation mpls
 neighbor 10.0.0.11 encapsulation mpls
!
interface Loopback0
 description - FULL MESH
 ip address 10.0.0.9 255.255.255.255
!
interface Loopback1
 description - VPWS
 ip address 172.16.0.0 255.255.255.255
!
interface Loopback2
 description - H-VPLS
 ip address 10.0.0.0 255.255.255.255
!
interface GigabitEthernet7/2
 ip address 10.0.0.01 255.255.255.0
 media-type rj45
 no cdp enable
!
interface GigabitEthernet10/1
 description - FULL MESH to CE1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10-1000
 switchport mode trunk
!
interface GigabitEthernet10/2
 description - VPWS to CE1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10-1000
 switchport mode trunk
!
interface GigabitEthernet12/0/0
 description - H-VPLS to uPE1
 ip address 10.0.0.3 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet12/0/1
 description - H-VPLS to nPE2
 ip address 10.0.0.1 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet12/1/0
 description - VPWS to P
 ip address 10.0.0.3 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet12/1/1
 description - FULL MESH to P
 ip address 10.0.2.0 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet12/2/0
 description - FULL MESH to PE3
 ip address 10.1.0.3 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 no ip address
 xconnect vfi vpls_auto
!
router ospf 10
 ! for FULL MESH
 log-adjacency-changes
 passive-interface Loopback0
 network 10.1.1.0 0.0.0.255 area 0
 network 10.2.2.0 0.0.0.255 area 0
 network 10.5.5.0 0.0.0.255 area 0
 network 10.9.9.9 0.0.0.0 area 0
 network 10.0.0.02 0.0.0.255 area 0
 network 10.0.0.04 0.0.0.0 area 0
 network 10.0.0.5 0.0.0.0 area 0
!
router ospf 20
 ! for VPWS
 log-adjacency-changes
 passive-interface Loopback1
 network 10.0.20.0 0.0.0.255 area 0
 network 10.0.0.9 0.0.0.0 area 0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 10.0.11.0 remote-as 1
 neighbor 10.0.10.0 update-source Loopback0
 neighbor 10.0.12.0 remote-as 1
 neighbor 10.0.0.12 update-source Loopback0
 neighbor 10.0.0.32 remote-as 1
 neighbor 10.0.0.31 update-source Loopback2
 !
 address-family ipv4
  no synchronization
  neighbor 10.0.11.0 activate
  neighbor 10.12.0.0 activate
  neighbor 10.0.32.0 activate
  no auto-summary
 exit-address-family
 !
 address-family l2vpn vpls
  neighbor 10.0.0.11 activate
  neighbor 10.0.11.0 send-community both
  neighbor 10.12.0.0 activate
  neighbor 10.0.0.12 send-community both
  neighbor 10.0.0.32 activate
  neighbor 10.0.32.0 send-community both
 exit-address-family
!
ip default-gateway 10.0.57.1
ip route 172.16.0.0 255.255.255.255 10.0.57.1
ip route 172.16.0.2 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
end

P


P_7206_g1#
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P_7206_g1
!
ip cef
ip host lab24 172.16.0.254
ip host dirt 172.16.0.129
!
mpls label protocol ldp
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
!
interface Loopback0
 description - FULL MESH
 ip address 10.0.0.10 255.255.255.255
!
interface Loopback1
 description - VPWS
 ip address 10.0.0.1 255.255.255.255
!
!
interface GigabitEthernet1/0
 description - VPWS to PE1
 ip address 10.0.20.6 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet2/0
 description - FULL MESH to PE1
 ip address 10.0.2.6 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet3/0
 description - VPWS to PE2
 ip address 10.0.0.6 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet4/0
 description - FULL MESH to PE2
 ip address 10.0.3.6 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
router ospf 10
 ! for FULL MESH
 log-adjacency-changes
 passive-interface Loopback0
 network 10.0.2.6 0.0.0.0 area 0
 network 10.0.2.0 0.0.0.255 area 0
 network 10.0.3.6 0.0.0.0 area 0
 network 10.0.3.0 0.0.0.255 area 0
 network 10.0.0.0 0.0.0.255 area 0
!
router ospf 20
 ! for VPWS
 log-adjacency-changes
 passive-interface Loopback1
 network 10.0.20.0 0.0.0.255 area 0
 network 10.21.0.0 0.0.0.255 area 0
 network 10.0.10.0 0.0.0.0 area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.0.9.9 remote-as 1
 neighbor 10.9.0.9 update-source Loopback0
 neighbor 10.11.0.11 remote-as 1
 neighbor 10.0.11.0 update-source Loopback0
 no auto-summary
!
ip default-gateway 10.0.0.0
!
mpls ldp router-id Loopback0 force
!

PE2


PE2_7606#
!
upgrade fpd auto
!
service internal
service counters max age 10
!
hostname PE2_7606
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xx
boot-end-marker
!
no aaa new-model
!
ipv6 mfib hardware-switching replication-mode ingress
!
mls ip multicast flow-stat-timer 9
!
multilink bundle-name authenticated
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
!
l2 vfi vpls_auto autodiscovery
 vpn id 1
!
l2 vfi vpls_manual manual
 vpn id 10
 neighbor 10.0.0.9 encapsulation mpls
 neighbor 10.0.0.11 encapsulation mpls
!
interface Loopback0
 description - FULL MESH
 ip address 10.0.0.12 255.255.255.255
!
interface Loopback1
 description - VPWS
 ip address 10.0.0.112 255.255.255.255
!
interface Loopback2
 description - H-VPLS
 ip address 10.0.32.0 255.255.255.255
!
interface GigabitEthernet2/1
 description - FULL MESH to CE2
 switchport
 switchport trunk allowed vlan 10-1000
 switchport mode trunk
!
interface GigabitEthernet4/0/0
 description - FULL MESH to PE3
 ip address 10.0.4.0 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet4/1/0
 description - VPWS to P
 ip address 10.0.21.0 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet4/1/1
 description - FULL MESH to P
 ip address 10.0.3.4 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet4/3/0
 description - VPWS to CE2
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet4/3/1
 description - H-VPLS to nPE1
 ip address 10.0.0.3 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet5/2
 ip address 10.0.5.0 255.255.255.0
 media-type rj45
 no cdp enable
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 no ip address
 shutdown
 xconnect vfi vpls_auto
!
router ospf 10
 log-adjacency-changes
 passive-interface Loopback0
 network 10.0.3.4 0.0.0.0 area 0
 network 10.0.4.0 0.0.0.255 area 0
 network 10.0.6.4 0.0.0.0 area 0
 network 10.0.0.5 0.0.0.255 area 0
 network 10.0.0.12 0.0.0.0 area 0
 network 10.0.32.0 0.0.0.0 area 0
 network 10.0.1.0 0.0.0.0 area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp update-delay 1
 neighbor 10.0.0.9 remote-as 1
 neighbor 10.0.9.0 update-source Loopback0
 neighbor 10.0.11.0 remote-as 1
 neighbor 10.0.0.11 update-source Loopback0
 neighbor 10.0.29.0 remote-as 1
 neighbor 10.0.0.29 update-source Loopback2
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family l2vpn vpls
  neighbor 10.0.0.9 activate
  neighbor 10.0.9.0 send-community both
  neighbor 10.0.11.0 activate
  neighbor 10.0.0.11 send-community both
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.3 send-community both
 exit-address-family
!
ip default-gateway 10.0.0.1
ip route 172.16.0.0 255.255.255.255 10.0.57.1
ip route 172.16.0.254 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
end

uPE2


uPE2_7606#
!
upgrade fpd auto
version 12.2
service timestamps debug uptime
service timestamps log uptime
service internal
!
hostname uPE2_7606
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xx
boot-end-marker
!
ipv6 mfib hardware-switching replication-mode ingress
!
multilink bundle-name authenticated
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
power redundancy-mode combined
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
!
interface Loopback0
 description - H-VPLS
 ip address 10.0.0.13 255.255.255.255
!
interface FastEthernet3/1
 description - H-VPLS to CE2
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10-1000
 switchport mode trunk
!
interface GigabitEthernet4/0/0
 description - H-VPLS to uPE2
 ip address 10.0.0.2 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet5/2
 ip address 10.0.0.11 255.255.255.0
 media-type rj45
 no cdp enable
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 passive-interface Loopback0
 network 10.0.6.0 0.0.0.255 area 0
 network 10.0.0.13 0.0.0.0 area 0
!
ip default-gateway 10.0.0.1
ip route 172.16.1.129 255.255.255.255 10.0.57.1
ip route 172.16.192.254 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
control-plane
!
end

CE2


CE2_7206#
!
hostname CE2_7206
!
ip cef
!
interface Loopback0
 ip address 10.0.0.123 255.255.255.255
!
interface FastEthernet1/0
 description - H-VPLS VPN to uPE2
 no ip address
 no ip mroute-cache
 duplex auto
 speed auto
!
interface FastEthernet1/0.1
 description - H-VPLS VPN to uPE2
 encapsulation dot1Q 10
 ip address 10.0.0.121 255.255.255.0
!
interface Ethernet2/0
 ip address 10.0.0.97 255.255.255.0
 no ip mroute-cache
 duplex half
 no cdp enable
!
interface FastEthernet4/0
 description - FULL MESH VPN to PE2
 no ip address
 no ip mroute-cache
 duplex auto
 speed auto
!
interface FastEthernet4/0.1
 description - FULL MESH VPN to PE2
 encapsulation dot1Q 10
 ip address 10.0.0.121 255.255.255.0
!
interface GigabitEthernet5/0
 description - VPWS VPN to PE2
 no ip address
 no ip mroute-cache
 no negotiation auto
!
interface GigabitEthernet5/0.1
 description - VPWS VPN to PE2
 encapsulation dot1Q 10
 ip address 10.0.0.121 255.255.255.0
!
router ospf 10
 log-adjacency-changes
 network 10.0.1.0 0.0.0.255 area 0
 network 10.0.0.1 0.0.0.255 area 0
 network 10.0.0.123 0.0.0.0 area 0
!
ip default-gateway 10.0.0.4
!
end

PE3


PE3_7606#
!
upgrade fpd auto
version 12.2
service timestamps debug uptime
service timestamps log uptime
service internal
!
hostname PE3_7606
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xx
boot-end-marker
!
ipv6 mfib hardware-switching replication-mode ingress
!
multilink bundle-name authenticated
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
l2 vfi vpls_auto autodiscovery
 vpn id 1
!
l2 vfi vpls_manual manual
 vpn id 10
 neighbor 10.0.9.9 encapsulation mpls
 neighbor 10.0.0.12 encapsulation mpls
!
interface Loopback0
 description - FULL MESH
 ip address 10.0.0.11 255.255.255.255
!
interface Loopback1
 description - H-VPLS
 ip address 10.0.0.31 255.255.255.255
!
interface GigabitEthernet3/2/1
 description - FULL MESH to PE1
 ip address 10.0.0.5 255.255.255.0
 negotiation auto
 mpls label protocol ldp
 mpls ip
!
interface GigabitEthernet5/2
 ip address 10.0.0.115 255.255.255.0
 media-type rj45
 no cdp enable
!
interface GigabitEthernet6/2
 description - FULL MESH to CE3
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10-1000
 switchport mode trunk
 no cdp enable
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 passive-interface Loopback0
 network 10.0.4.0 0.0.0.255 area 0
 network 10.0.0.11 0.0.0.0 area 0
 network 10.0.31.0 0.0.0.0 area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp update-delay 1
 neighbor 10.0.0.9 remote-as 1
 neighbor 10.0.9.0 update-source Loopback0
 neighbor 10.0.12.0 remote-as 1
 neighbor 10.0.0.12 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family l2vpn vpls
  neighbor 10.0.9.0 activate
  neighbor 10.0.0.9 send-community both
  neighbor 10.0.0.12 activate
  neighbor 10.0.12.0 send-community both
 exit-address-family
!
ip default-gateway 10.0.57.1
ip route 172.16.0.129 255.255.255.255 10.0.57.1
ip route 172.16.0.254 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
end

Additional References

The following sections provide references related to the NSF/SSO/ISSU Support for VPLS feature.

Related Documents

Related Topic
Document Title

Stateful switchover

Stateful Switchover

MPLS Label Distribution Protocol

MPLS Label Distribution Protocol (LDP)

Cisco nonstop forwarding

Cisco Nonstop Forwarding

Any Transport over MPLS

Any Transport over MPLS

NSF/SSO: Any Transport over MPLS

NSF/SSO—Any Transport over MPLS and AToM Graceful Restart

L2VPN Interworking configuration

L2VPN Interworking

VPLS

See the "Virtual Private LAN Services on the Optical Services Modules" chapter in the Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SR)

VPLS Autodiscovery

See VPLS Autodiscovery: BGP Based and BGP Support for the L2VPN Address Family

NSF/SSO router support on the 7600 router

See the "Configuring NSF with SSO Supervisor Engine Redundancy" chapter in the Cisco 7600 Series Cisco IOS Software Configuration Guide, Release 12.2SR

ISSU router support on the 7600 router

See the "ISSU and eFSU on Cisco 7600 Series Routers" chapter in the Cisco 7600 Series Cisco IOS Software Configuration Guide, Release 12.2SR


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIB
MIBs Link

MPLS Label Distribution Protocol MIB Version 8 Upgrade

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 3036

LDP Specification

RFC 3478

Graceful Restart Mechanism for Label Distribution


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Command Reference

The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS Multiprotocol Label Switching Command Reference at http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html. For information about all Cisco IOS commands, go to the Command Lookup Tool at http://tools.cisco.com/Support/CLILookup or to the Cisco IOS Master Commands List.

debug cwan atom

debug cwan ltl

debug issu client negotiation

debug issu client registration

debug issu client transform

debug vfi checkpoint

show checkpoint clients

show vfi checkpoint

Feature Information for NSF/SSO/ISSU Support for VPLS

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for NSF/SSO/ISSU Support for VPLS

Feature Name
Releases
Feature Information

NSF/SSO/ISSU Support for VPLS

12.2(33)SRC

Virtual Private LAN Services (VPLS), with NSF/SSO/ISSU support, improves the availability of service provider networks that use VPLS for multipoint Layer 2 VPN services. Cisco nonstop forwarding (NSF) with stateful switchover (SSO) is effective at increasing availability of network services.

In 12.2(33)SRC, this feature was introduced on the
Cisco 7600 router.