This documentation has been moved
NSF/SSO—Any Transport over MPLS and AToM Graceful Restart
Downloads: This chapterpdf (PDF - 175.0KB) The complete bookPDF (PDF - 11.12MB) | Feedback

NSF/SSO—Any Transport over MPLS and AToM Graceful Restart

Table Of Contents

NSF/SSO—Any Transport over MPLS and AToM Graceful Restart

Finding Feature Information

Contents

Prerequisites for AToM NSF

Supported Hardware

Restrictions for AToM NSF

Information About AToM NSF

How AToM NSF Works

AToM Information Checkpointing

Checkpointing Troubleshooting Tips

ISSU Support

Configuring MPLS LDP Graceful Restart

Configuration Examples for AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for AToM NSF


NSF/SSO—Any Transport over MPLS and AToM Graceful Restart


First Published: August 11, 2004
Last Updated: July 20, 2011

The NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature allows Any Transport over MPLS (AToM) to use Cisco nonstop forwarding (NSF), stateful switchover (SSO), and Graceful Restart (GR) to facilitate a Route Processor (RP) to recover from a disruption in control plane service without losing its Multiprotocol Label Switching (MPLS) forwarding state.

NSF with SSO is effective at increasing the availability of network services. Cisco NSF with SSO provides continuous packet forwarding, even during a network processor hardware or software failure. In a redundant system, the secondary processor recovers the control plane service during a critical failure in the primary processor. SSO synchronizes the network state information between the primary and the secondary processor.


Note In this document, the NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature is referred to as AToM NSF for brevity.


Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for AToM NSF" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for AToM NSF

Restrictions for AToM NSF

Information About AToM NSF

Configuration Examples for AToM NSF

Additional References

Feature Information for AToM NSF

Prerequisites for AToM NSF

Before you configure AToM NSF, ensure the following tasks are completed:

AToM virtual circuits (VCs) are configured on the router. For information on configuring AToM, see the Any Transport over MPLS feature module. For configuring L2VPN Interworking, see the L2VPN Interworking feature module.

SSO is configured on the Route Processors. For configuration information, see the Stateful Switchover feature module.

Nonstop forwarding is configured on the routers. You must enable nonstop forwarding on the routing protocols running between the provider edge (PE) and customer edge (CE) routers. The routing protocols are Open Shortest Path First (OSPF), Intermediate System-to-Intermediate System (IS-IS), and Border Gateway Protocol (BGP). For configuring nonstop forwarding, see the
Cisco Nonstop Forwarding feature module.

The routers must be configured to detect and interact with the neighbor routers in the MPLS high availibility (HA) environment. AToM NSF requires that neighbor networking devices be able to perform AToM GR. In Cisco IOS Releases 12.2(25)S and 12.2(28)SB, the Cisco 7200 and Cisco 7500 routers support AToM GR and can be used as neighbor networking devices. In Cisco IOS Release 12.2(33)SRC, the Cisco 7600 routers support AToM high availability HA and MPLS Label Distribution Protocol (LDP) GR.

The Route Processors for SSO and GR are configured. For more information, see the Stateful Switchover feature module.

NSF on the routing protocols running between the PE, and CE routers must be enabled. The routing protocols are as follows:

BGP

IS-IS

OSPF

For more information, see the Cisco Nonstop Forwarding feature module.

Supported Hardware

For hardware requirements for this feature, see the following documents:

For Cisco IOS Release 12.2(25)S, see the "Supported Hardware" section of the Cross-Platform Release Notes for Cisco IOS Release 12.2S.

For Cisco IOS Release 12.2(28)SB, see the "Supported Hardware" section of the Cross-Platform Release Notes for Cisco IOS Release 12.2SB.

For Cisco IOS Release 12.2(33)SRC, see the "Supported Hardware" section of the Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers.

Restrictions for AToM NSF

Tag Distribution Protocol (TDP) sessions are not supported. Only LDP sessions are supported.

AToM NSF cannot be configured on label-controlled ATM (LC-ATM) interfaces.

AToM NSF does not support Layer 2 Tunnel Protocol Version 3 (L2TPv3) Interworking; only AToM Layer 2 Virtual Private Network (L2VPN) Interworking is supported.

AToM NSF interoperates with Layer 2 local switching. However, AToM NSF has no effect on interfaces configured for local switching.

You must disable fair queueing on serial interfaces to allow distributed Cisco Express Forwarding to work on the interfaces.

On Cisco 7500 series routers, distributed Cisco Express Forwarding is needed to support AToM NSF.

The Cisco 7500 router does not support AToM Ethernet-VLAN interworking IP; however, AToM Ethernet-VLAN interworking Ethernet is supported.

Information About AToM NSF

How AToM NSF Works

AToM Information Checkpointing

ISSU Support

How AToM NSF Works

AToM NSF improves the availability of the network of the service provider that uses AToM to provide Layer 2 VPN services. HA provides the ability to detect failures and handle them with minimal disruption to the service being provided. AToM NSF is achieved by SSO and NSF mechanisms. A standby RP provides control-plane redundancy. The control plane state and data plane provisioning information for the attachment circuits (ACs) and AToM pseudowires (PWs) are checkpointed to the standby RP to provide NSF for AToM L2VPNs.

AToM Information Checkpointing

Checkpointing is a function that copies state information from the active RP to the backup RP, thereby ensuring that the backup RP has the latest information. If the active RP fails, the backup RP can take over the copying of state information.

For the AToM NSF feature, the checkpointing function copies the active RP's information bindings to the backup RP. The active RP sends updates to the backup RP when information is modified.

To display checkpointing data, use the show acircuit checkpoint command on the active and backup RPs. The active and backup RPs have identical copies of the information.

Checkpointing Troubleshooting Tips

To help troubleshoot checkpointing errors, use the following commands:

Use the debug acircuit checkpoint command to enable checkpointing debug messages for ACs.

Use the debug mpls l2transport checkpoint command to enable checkpointing debug messages for AToM.

Use the debug vfi checkpoint command to debug virtual forwarding instance (VFI) checkpointing events and errors.

Use the show acircuit checkpoint command to display AC checkpoint information.

Use the show mpls l2transport checkpoint command to display whether checkpointing is allowed, how many AToM VCs were bulk-synchronized (on the active RP), and how many AToM VCs have checkpoint data (on the standby RP).

Use the show mpls l2transport vc detail command to display details of VC checkpointed information.

Use the show vfi checkpoint command to display checkpointing information on a VFI.

ISSU Support

Beginning with Cisco IOS Release 12.2(33)SRC, AToM NSF supports the In Service Software Upgrade (ISSU) capability. Virtual Private LAN Services (VPLS) NSF/SSO and HA with ISSU work together to enable upgrades or downgrades of a Cisco IOS image without control and data plane outages. With ISSU, all message data structures that are used for checkpointing and exchanges between the active RP and standby RP are versioned.

The maximum transmission length (MTU) of checkpoint messages can be negotiated. The VPLS ISSU client transforms checkpoint messages by converting Source Specific Multicast (SSM) IDs and VFI IDs of an individual VFI to AC and PW, respectively.

Configuring MPLS LDP Graceful Restart

Before you configure AToM NSF, you need to configure MPLS LDP Graceful Restart.

MPLS LDP GR is enabled globally. When you enable LDP GR, it has no effect on existing LDP sessions. LDP GR is enabled for new sessions that are established after the feature has been globally enabled.

Perform this task to configure MPLS LDP GR.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip cef [distributed]

4. mpls ldp graceful-restart

5. interface type slot/port

6. mpls ip

7. mpls label protocol {ldp | tdp | both}

8. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip cef [distributed]

Example:

Router(config)# ip cef distributed

Enables Cisco Express Forwarding.


Note In Cisco ASR 1000 Series Aggregation Services Routers, the distributed keyword is mandatory.


Step 4 

mpls ldp graceful-restart

Example:
Router(config)# mpls ldp graceful-restart

Enables the router to protect LDP bindings and the MPLS forwarding state during service disruption.

Step 5 

interface type slot/port

Example:
Router(config)# interface pos 3/0 

Specifies an interface and enters interface configuration mode.

Step 6 

mpls ip

Example:

Router(config-if)# mpls ip

Configures MPLS hop-by-hop forwarding for an interface.

Step 7 

mpls label protocol {ldp | tdp | both}

Example:

Router(config-if)# mpls label protocol ldp

Configures the LDP on an interface.

You must use LDP, because TDP sessions are not supported.

You can also issue the mpls label protocol ldp command in global configuration mode, which enables LDP on all interfaces configured for MPLS.

Step 8 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.


Configuration Examples for AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

The following example shows how to configure AToM NSF on two PE routers:

PE1
PE2
ip cef distributed
!
redundancy
mode sso
!
boot system flash disk2:rsp-pv-mz
!
mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-labels
!
pseudowire-class atom-eth
 encapsulation mpls
 interworking ethernet
!
interface Loopback0
 ip address 10.8.8.8 255.255.255.255
!
interface FastEthernet1/1/0
 xconnect 10.9.9.9 123 encap mpls pw-class atom-eth

interface POS6/1/0
 ip address 10.1.1.1 255.255.255.0
 mpls ip
 mpls label protocol ldp
 clock source internal
 crc 32
!
interface Loopback0
 ip address 10.8.8.8 255.255.255.255
 no shutdown
!
router ospf 10
 nsf
 network 10.8.8.8 0.0.0.0 area 0
 network 19.1.1.1 0.0.0.0 area 0

ip cef distributed
!
redundancy
mode sso
!
boot system flash disk2:rsp-pv-mz

mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-labels
!
pseudowire-class atom-eth
 encapsulation mpls
 interworking eth
!
interface Loopback0
 ip address 10.9.9.9 255.255.255.255
!
interface FastEthernet3/0/0
 ip route-cache cef
!
interface FastEthernet3/0/0.3
 encapsulation dot1Q 10
 xconnect 10.8.8.8 123 encap mpls pw-class atom-eth

interface POS1/0/0
 ip address 10.1.1.2 255.255.255.0
 mpls ip
 mpls label protocol ldp
 clock source internal
 crc 32
!
interface Loopback0
 ip address 10.9.9.9 255.255.255.255
!
router ospf 10
 nsf
 network 10.9.9.9 0.0.0.0 area 0
 network 10.1.1.2 0.0.0.0 area 0

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Cisco IOS Multiprotocol Label Switching Command Reference

Cisco IOS Multiprotocol Label Switching Command Reference

Stateful switchover

Stateful Switchover

MPLS Label Distribution Protocol

MPLS Label Distribution Protocol (LDP)

Cisco nonstop forwarding

Cisco Nonstop Forwarding

Any Transport over MPLS

Any Transport over MPLS

L2VPN Interworking configuration

L2VPN Interworking


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

MPLS Label Distribution Protocol MIB Version 8 Upgrade

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 3036

LDP Specification

RFC 3478

Graceful Restart Mechanism for Label Distribution


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for AToM NSF

Table 1 lists the release history for this feature.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 1 Feature Information for AToM NSF Any Transport over MPLS and AToM Graceful Restart

Feature Name
Releases
Feature Information

AToM NSF

12.2(25)S
12.2(28)SB
12.2(33)SRC

This feature uses NSF, SSO, and Graceful Restart to allow a Route Processor to recover from a disruption in control plane service without losing its MPLS forwarding state.

In 12.2(25)S, this feature was introduced on the Cisco 7500 series router.

In 12.2(28)SB, this feature was integrated into the release.

In 12.2(33)SRC, this feature was integrated into the release for the Cisco 7600 router. Support for ISSU was added.

The following commands were introduced or modified: debug acircuit checkpoint, debug mpls l2transport checkpoint, show acircuit checkpoint, show mpls l2transport checkpoint, show mpls l2transport vc.

AToM over MPLS

12.2(50)SY

The HA capabilities such as SSO and Non-Stop Forwarding to MPLS over AToM were added to the feature.

The following commands were introduced or modified: debug vfi checkpoint, show vfi checkpoint.