This documentation has been moved
MPLS LDP-IGP Synchronization
Downloads: This chapterpdf (PDF - 215.0KB) The complete bookPDF (PDF - 11.12MB) | Feedback

MPLS LDP-IGP Synchronization

Table Of Contents

MPLS LDP-IGP Synchronization

Finding Feature Information

Contents

Prerequisites for MPLS LDP-IGP Synchronization

Restrictions for MPLS LDP-IGP Synchronization

Information About MPLS LDP-IGP Synchronization

How MPLS LDP-IGP Synchronization Works

MPLS LDP-IGP Synchronization with Peers

MPLS LDP-IGP Synchronization Delay Timer

MPLS LDP-IGP Synchronization Incompatibility with IGP Nonstop Forwarding

MPLS LDP-IGP Synchronization Compatibility with LDP Graceful Restart

How to Configure MPLS LDP-IGP Synchronization

Configuring MPLS LDP-IGP Synchronization with OSPF Interfaces

Disabling MPLS LDP-IGP Synchronization on Some OSPF Interfaces

Verifying MPLS LDP-IGP Synchronization with OSPF

Configuring MPLS LDP-IGP Synchronization with IS-IS Interfaces

Configuring MPLS LDP-IGP Synchronization on All IS-IS Interfaces

Configuring MPLS LDP-IGP Synchronization on an IS-IS Interface

Disabling MPLS LDP-IGP Synchronization on Some IS-IS Interfaces

Verifying MPLS LDP-IGP Synchronization with IS-IS

Troubleshooting Tips

Configuration Examples for MPLS LDP-IGP Synchronization

MPLS LDP-IGP Synchronization with OSPF: Example

MPLS LDP-IGP Synchronization with IS-IS: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature History for MPLS LDP-IGP Synchronization


MPLS LDP-IGP Synchronization


First Published: November 20, 2004
Last Updated: September 2, 2009

The MPLS LDP-IGP Synchronization feature ensures that the Label Distribution Protocol (LDP) is fully established before the Interior Gateway Protocol (IGP) path is used for switching.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature History for MPLS LDP-IGP Synchronization" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for MPLS LDP-IGP Synchronization

Restrictions for MPLS LDP-IGP Synchronization

Information About MPLS LDP-IGP Synchronization

How to Configure MPLS LDP-IGP Synchronization

Configuration Examples for MPLS LDP-IGP Synchronization

Additional References

Feature History for MPLS LDP-IGP Synchronization

Prerequisites for MPLS LDP-IGP Synchronization

This feature is supported only on interfaces that are running Open Shortest Path First (OSPF) or Intermediate System-to-System (IS-IS) processes.

This feature works when LDP is enabled on interfaces with either the mpls ip command or the mpls ldp autoconfig command.

Restrictions for MPLS LDP-IGP Synchronization

In Cisco IOS Release 12.2(33)SB, and Cisco IOS Release 12.2(33)SRB, the MPLS LDP-IGP Synchronization feature is not supported with IS-IS. Only OSPF is supported.

The Tag Distribution Protocol (TDP) is not supported. You must specify that the default label distribution protocol is LDP for a router or for an interface.

This feature is not supported on tunnel interfaces or LC-ATM interfaces.

This feature is not supported with interface-local label space or downstream-on-demand (DoD) requests.

This feature does not support targeted LDP sessions. Therefore, Any Transport over MPLS (AToM) sessions are not supported.

Information About MPLS LDP-IGP Synchronization

To configure the MPLS LDP-IGP Synchronization feature, you should understand the following concepts:

How MPLS LDP-IGP Synchronization Works

MPLS LDP-IGP Synchronization with Peers

MPLS LDP-IGP Synchronization Delay Timer

MPLS LDP-IGP Synchronization Incompatibility with IGP Nonstop Forwarding

MPLS LDP-IGP Synchronization Compatibility with LDP Graceful Restart

How MPLS LDP-IGP Synchronization Works

Packet loss can occur because the actions of the IGP and LDP are not synchronized. Packet loss can occur in the following situations:

When an IGP adjacency is established, the router begins forwarding packets using the new adjacency before the LDP label exchange completes between the peers on that link.

If an LDP session closes, the router continues to forward traffic using the link that is associated with the LDP peer rather than an alternate pathway with a fully synchronized LDP session.

The MPLS LDP-IGP Synchronization feature does the following:

Provides a means to synchronize LDP and IGPs to minimize Multiprotocol Label Switching (MPLS) packet loss.

Enables you to globally enable LDP-IGP synchronization on each interface that is associated with an IGP OSPF or IS-IS process.

Provides a means to disable LDP-IGP synchronization on interfaces that you do not want enabled.

Prevents MPLS packet loss due to synchronization conflicts.

Works when LDP is enabled on interfaces using either the mpls ip or mpls ldp autoconfig command.

To enable LDP-IGP synchronization on each interface that belongs to an OSPF or IS-IS process, enter the mpls ldp sync command. If you do not want some of the interfaces to have LDP-IGP synchronization enabled, issue the no mpls ldp igp sync command on those interfaces.

If the LDP peer is reachable, the IGP waits indefinitely (by default) for synchronization to be achieved. To limit the length of time the IGP session must wait, enter the mpls ldp igp sync holddown command. If the LDP peer is not reachable, the IGP establishes the adjacency to enable the LDP session to be established.

When an IGP adjacency is established on a link but LDP-IGP synchronization is not yet achieved or is lost, the IGP advertises the max-metric on that link.

MPLS LDP-IGP Synchronization with Peers

When the MPLS LDP-IGP Synchronization feature is enabled on an interface, LDP determines if any peer connected by the interface is reachable by looking up the peer's transport address in the routing table. If a routing entry (including longest match or default routing entry) for the peer exists, LDP assumes that LDP-IGP synchronization is required for the interface and notifies the IGP to wait for LDP convergence.

LDP-IGP synchronization with peers requires that the routing table be accurate for the peer's transport address. If the routing table shows there is a route for the peer's transport address, that route must be able to reach the peer's transport address. However, if the route is a summary route, a default route, or a statically configured route, it may not the correct route for the peer. You must verify that the route in the routing table can reach the peer's transport address.

When the routing table has an inaccurate route for the peer's transport address, LDP cannot set up a session with the peer, which causes the IGP to wait for LDP convergence unnecessarily for the sync hold-down time.

MPLS LDP-IGP Synchronization Delay Timer

Cisco IOS Release 12.0(32)SY and later releases of the MPLS LDP-IGP Synchronization feature provide the option to configure a delay time for MPLS LDP and IGP synchronization on an interface-by-interface basis. Normally, when LDP-IGP synchronization is configured, LDP notifies IGP as soon as LDP is converged. When the delay timer is configured, this notification is delayed. If you want to configure a delay time on an interface, use the mpls ldp igp sync delay delay-time command in interface configuration mode. To remove the delay timer from a specified interface, enter the no mpls ldp igp sync delay command. This command sets the delay time to 0 seconds, but leaves MPLS LDP-IGP synchronization enabled.

When LDP is fully established and synchronized, LDP checks the delay timer:

If you configured a delay time, LDP starts the timer. When the timer expires, LDP checks that synchronization is still valid and notifies the OSPF process.

If you did not configure a delay time, if synchronization is disabled or down, or if an interface was removed from an IGP process, LDP stops the timer and immediately notifies the OSPF process.

If you configure a new delay time while a timer is running, LDP saves the new delay time but does not reconfigure the running timer.

MPLS LDP-IGP Synchronization Incompatibility with IGP Nonstop Forwarding

The MPLS LDP-IGP Synchronization feature is not supported during the startup period if IGP nonstop forwarding (NSF) is configured. The MPLS LDP-IGP Synchronization feature conflicts with IGP NSF when the IGP is performing NSF during startup. After the NSF startup is complete, the MPLS LDP-IGP Synchronization feature is supported.

MPLS LDP-IGP Synchronization Compatibility with LDP Graceful Restart

LDP graceful restart protects traffic when an LDP session is lost. If an interface that supports a graceful-restart-enabled LDP session fails, MPLS LDP-IGP synchronization is still achieved on the interface while it is protected by Graceful Restart. MPLS LDP-IGP synchronization is eventually lost under the following circumstances

If LDP fails to restart before the LDP Graceful Restart reconnect timer expires.

If an LDP session restarts through other interfaces, but the LDP session on the protected interface fails to recover when the LDP Graceful Restart recovery timer expires.

How to Configure MPLS LDP-IGP Synchronization

Configuring MPLS LDP-IGP Synchronization with OSPF Interfaces (required)

Disabling MPLS LDP-IGP Synchronization on Some OSPF Interfaces (optional)

Verifying MPLS LDP-IGP Synchronization with OSPF (optional)

Configuring MPLS LDP-IGP Synchronization with IS-IS Interfaces (required)

Disabling MPLS LDP-IGP Synchronization on Some IS-IS Interfaces (optional)

Verifying MPLS LDP-IGP Synchronization with IS-IS (optional)

Configuring MPLS LDP-IGP Synchronization with OSPF Interfaces

To configure MPLS LDP-IGP synchronization with OSPF interfaces, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol ldp

5. interface type number

6. ip address prefix mask

7. mpls ip

8. exit

9. router ospf process-id

10. network ip-address wildcard-mask area area-id

11. mpls ldp sync

12. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls ip

Example:

Router(config)# mpls ip

Globally enables hop-by-hop forwarding.

Step 4 

mpls label protocol ldp

Example:

Router(config)# mpls label protocol ldp

Specifies LDP as the default label distribution protocol.

Step 5 

interface type number

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 6 

ip address prefix mask

Example:

Router(config-if)# ip address 10.25.0.11 255.255.255.255

Assigns an IP address to the interface.

Step 7 

mpls ip

Example:

Router(config-if)# mpls ip

Enables hop-by-hop forwarding on the interface.

Step 8 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 9 

router ospf process-id

Example:

Router(config)# router ospf 1

Enables OSPF routing and enters router configuration mode.

Step 10 

network ip-address wildcard-mask area area-id

Example:

Router(config-router)# network 10.0.0.0 0.255.255.255 area 3

Defines an interface on which OSPF runs and defines the area ID for that interface.

Step 11 

mpls ldp sync

Example:

Router(config-router)# mpls ldp sync

Enables MPLS LDP-IGP synchronization for interfaces for an OSPF or an IS-IS process.

Step 12 

end

Example:

Router(config-router)# end

Exits router configuration mode and returns to privileged EXEC mode.

Disabling MPLS LDP-IGP Synchronization on Some OSPF Interfaces

When you issue the mpls ldp sync command, all of the interfaces that belong to an OSPF process are enabled for LDP-IGP synchronization. To remove LDP-IGP synchronization from some interfaces, use the no form of the mpls ldp igp sync command on those interfaces. The following configuration steps show how to disable LDP-IGP synchronization from some OSPF interfaces after they have been configured with LDP-IGP synchronization through the mpls ldp sync command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no mpls ldp igp sync

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 4 

no mpls ldp igp sync

Example:

Router(config-if)# no mpls ldp igp sync

Disables MPLS LDP-IGP synchronization for that interface.

Step 5 

end

Example:

Router(config-if)# end

Exits interface configuration mode and returns to privileged EXEC mode.

Verifying MPLS LDP-IGP Synchronization with OSPF

After you configure the interfaces for LDP, OSPF, and LDP-IGP synchronization, verify that the configuration is working correctly using the show mpls ldp igp sync and show ip ospf mpls ldp interface commands.

SUMMARY STEPS

1. enable

2. show mpls ldp igp sync

3. show ip ospf mpls ldp interface

DETAILED STEPS


Step 1 enable

Enables privileged EXEC mode. Enter your password if prompted.

Step 2 show mpls ldp igp sync

The output of this command (as shown in the following example) shows that MPLS LDP-IGP synchronization is configured correctly, because LDP is configured and the SYNC status shows that synchronization is enabled.

Router# show mpls ldp igp sync

Ethernet0/0:
 LDP configured; SYNC enabled.
 SYNC status: sync achieved; peer reachable.
 IGP holddown time: infinite.
 Peer LDP Ident: 10.0.0.1:0
 IGP enabled: OSPF 1

If MPLS LDP-IGP synchronization is not enabled on an interface, the output appears as follows:

Ethernet5/1:
 LDP configured; LDP-IGP Synchronization not enabled.

Step 3 show ip ospf mpls ldp interface

The output of the show ip ospf mpls ldp interface command in the following example shows that the interfaces are properly configured:

Router# show ip ospf mpls ldp interface

Ethernet3/0/0
  Process ID 1, Area 0
  LDP is configured through LDP autoconfig
  LDP-IGP Synchronization: Yes
  Holddown timer is not configured
  Timer is not running
Ethernet3/0/2
  Process ID 1, Area 0
  LDP is configured through LDP autoconfig
  LDP-IGP Synchronization: Yes
  Holddown timer is not configured
  Timer is not running 

Configuring MPLS LDP-IGP Synchronization with IS-IS Interfaces


Note In Cisco IOS Releases 12.2(33)SRB and 12.2(33)SB, the MPLS LDP-IGP Synchronization feature is not supported with IS-IS. Only OSPF is supported.


The following sections contain the steps and examples for configuring MPLS LDP-IGP synchronization for interfaces that are running IS-IS processes:

Configuring MPLS LDP-IGP Synchronization on All IS-IS Interfaces

Configuring MPLS LDP-IGP Synchronization on an IS-IS Interface

Configuring MPLS LDP-IGP Synchronization on All IS-IS Interfaces

This section contains the steps for configuring the MPLS LDP-IGP Synchronization feature on all interfaces that are running IS-IS processes.

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol ldp

5. router isis process-name

6. mpls ldp sync

7. mpls ldp autoconfig

8. exit

9. interface type number

10. ip address prefix mask

11. ip router isis process-name

12. mpls ip

13. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls ip

Example:

Router(config)# mpls ip

Globally enables hop-by-hop forwarding.

Step 4 

mpls label protocol ldp

Example:

Router(config)# mpls label protocol ldp

Specifies LDP as the default label distribution protocol.

Step 5 

router isis process-name

Example:

Router(config)# router isis ISIS

Enables the IS-IS protocol on the router, specifies an IS-IS process, and enters router configuration mode.

Step 6 

mpls ldp sync

Example:

Router(config-router)# mpls ldp sync

Enables MPLS LDP-IGP synchronization on interfaces belonging to an IS-IS process.

Step 7 

mpls ldp autoconfig

Example:

Router(config-router)# mpls ldp autoconfig

Configures auto-configuration to quickly configure the auto synchronization. When auto-configure is configured, auto-sync configuration is not required on any interfaces with MPLS enabled.

Step 8 

exit

Example:

Router(config-router)# exit

Exits router configuration mode and returns to global configuration mode.

Step 9 

interface type number

Example:

Router(config)# interface POS0/3

Specifies the interface to configure and enters interface configuration mode.

Step 10 

ip address prefix mask

Example:

Router(config-if)# ip address 10.25.25.11 255.255.255.0

Assigns an IP address to the interface.

Step 11 

ip router isis process-name

Example:

Router(config-if)# ip router isis ISIS

Enables IS-IS.

Step 12 

mpls ip

Example:

Router(config-if)# mpls ip

Enables MPLS IP.

Step 13 

end

Example:

Router(config-if)# end

Exits interface configuration mode and returns to privileged EXEC mode.

Configuring MPLS LDP-IGP Synchronization on an IS-IS Interface

This section contains the steps for configuring the MPLS LDP-IGP Synchronization feature on an interface that is running an IS-IS process.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ip address prefix mask

5. mpls ldp igp sync

6. ip router isis

7. exit

8. router isis

9. mpls ldp sync

10. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface POS0/2

Specifies the interface to configure and enters interface configuration mode.

Step 4 

ip address prefix mask

Example:

Router(config-if)# ip address 10.50.72.4 255.0.0.0

Assigns an IP address to the interface.

Step 5 

mpls ldp igp sync

Example:

Router(config-if)# mpls ldp igp sync

Enables MPLS LDP-IGP synchronization.

Step 6 

ip router isis

Example:

Router(config-if)# ip router isis

Enables the IS-IS protocol for IP on the interface.

Step 7 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 8 

router isis

Example:

Router(config)# router isis

Enables IS-IS process on the router.

Step 9 

mpls ldp sync

Example:

Router(config-router)# mpls ldp sync

Enables LDP-IGP synchronization for interfaces that belongs to an IS-IS process.

Step 10 

end

Example:

Router(config-router)# end

Exits router configuration mode and returns to privileged EXEC mode.

Disabling MPLS LDP-IGP Synchronization on Some IS-IS Interfaces

When you issue the mpls ldp sync command, all of the interfaces that belong to an IS-IS process are enabled for LDP-IGP synchronization. To remove LDP-IGP synchronization from some interfaces, use the no form of the mpls ldp igp sync command on those interfaces. The following configuration steps show how to disable LDP-IGP synchronization from some IS-IS interfaces after they have been configured with LDP-IGP synchronization through the mpls ldp sync command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no mpls ldp igp sync

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 4 

no mpls ldp igp sync

Example:

Router(config-if)# no mpls ldp igp sync

Disables MPLS LDP-IGP synchronization for that interface.

Step 5 

end

Example:

Router(config-if)# end

Exits interface configuration mode and returns to privileged EXEC mode.

Verifying MPLS LDP-IGP Synchronization with IS-IS

After you configure the interfaces for LDP-IGP synchronization with IS-IS, you can verify that the configuration is working correctly with the show isis mpls ldp command.

SUMMARY STEPS

1. enable

2. show isis mpls ldp

DETAILED STEPS


Step 1 enable

Enables privileged EXEC mode. Enter your password if prompted.

Step 2 show isis mpls ldp

The output of the following command shows that IS-IS is configured on the interface (ISIS is UP) and that MPLS LDP-IGP synchronization with IS-IS is configured properly (SYNC achieved).

Router# show isis mpls ldp

Interface: POS0/2; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: NO
 SYNC Information :
   Required: YES
   Achieved: YES
   IGP Delay: NO
   Holddown time: Infinite
   State: SYNC achieved

If MPLS LDP-IGP synchronization with IS-IS is not enabled on an interface, the output looks like the following:

Interface: Ethernet0; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: NO
 SYNC Information :
   Required: NO

If MPLS LDP-IGP synchronization with IS-IS is configured but is not enabled, the output looks like the following:

Interface: Ethernet0/0; ISIS tag ISIS-1 enabled
  ISIS is UP on interface
  AUTOCONFIG Information :
    LDP enabled: YES
  SYNC Information :
    Required: YES
    Achieved: NO
    IGP Delay: YES
    Holddown time: Infinite
    State: Holding down until SYNC

The IS-IS process holds down the adjacency of the interface until synchronization is enabled.


Troubleshooting Tips

Use the debug mpls ldp igp sync command to display events related to MPLS LDP-IGP synchronization.

Configuration Examples for MPLS LDP-IGP Synchronization

The following sections show examples for the MPLS LDP-IGP Synchronization feature with OSPF and IS-IS processes:

MPLS LDP-IGP Synchronization with OSPF: Example

MPLS LDP-IGP Synchronization with IS-IS: Example

MPLS LDP-IGP Synchronization with OSPF: Example

The following configuration commands enable LDP for OSPF process 1. The mpls ldp sync command and the OSPF network commands enable LDP on interfaces POS0/0, POS0/1, and POS1/1, respectively. The no mpls ldp igp sync command on interface POS1/0 prevents LDP from being enabled on interface POS1/0, even though OSPF is enabled for that interface.

Router# configure terminal 
Router(config)# interface POS0/0 
Router(config-if)# ip address 10.0.0.1 
Router(config-if)# mpls ip 
!
Router(config)# interface POS0/1 
Router(config-if)# ip address 10.0.1.1 
Router(config-if)# mpls ip 
!
Router(config)# interface POS1/1 
Router(config-if)# ip address 10.1.1.1 
Router(config-if)# mpls ip 
!
Router(config)# interface POS1/0 
Router(config-if)# ip address 10.1.0.1 
Router(config-if)# mpls ip 
!
Router(config)# router ospf 1 
Router(config-router)# network 10.0.0.0 0.0.255.255 area 3 
Router(config-router)# network 10.1.0.0 0.0.255.255 area 3 
Router(config-router)# mpls ldp sync 
Router(config-router)# exit 
Router(config)# interface POS1/0 
Router(config-if)# no mpls ldp igp sync 

MPLS LDP-IGP Synchronization with IS-IS: Example


Note In Cisco IOS Release 12.2(33)SRB and 12.2(33)SB, the MPLS LDP-IGP Synchronization feature is not supported with IS-IS. Only OSPF is supported.


The following commands configure MPLS LDP-IGP synchronization on interfaces POS0/2 and POS0/3, which are running IS-IS processes:

Router# configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface POS0/2 
Router(config-if)# ip router isis 
Router(config-if)# exit 
Router(config)# router isis
Router(config-router)# mpls ldp sync 
!
!
Router(config)# interface POS0/3
Router(config-if)# ip router isis
Router(config-if)# exit
Router(config)# router isis
Router(config-router)# mpls ldp sync

Additional References

Related Documents

Related Topic
Document Title

MPLS LDP

MPLS Label Distribution Protocol

MPLS LDP Autoconfiguration

MPLS LDP Autoconfiguration

MPLS LDP Session Protection

MPLS LDP Session Protection


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

MPLS LDP MIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 3036

LDP Specification

RFC 3037

LDP Applicability


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Feature History for MPLS LDP-IGP Synchronization

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for MPLS LDP-IGP Synchronization

Feature Name
Releases
Feature Information

MPLS LDP-IGP Synchronization

12.0(30)S
12.0(32)SY
12.2(33)SB
12.2(33)SRB
15.0(1)M
12.3(14)T
Cisco IOS XE
Release 2.1

The MPLS LDP-IGP Synchronization feature ensures that LDP is fully established before the IGP path is used for switching.

In 12.0(30)S, this feature was introduced.

In 12.0(32)SY, support for enabling synchronization on interfaces running Intermediate System-to-System (IS-IS) processes was added.

In 12.2(33)SB, the feature was integrated. MPLS LDP-IGP synchronization for IS-IS is not supported in this release.

In 12.2(33)SRB, the feature was integrated. MPLS LDP-IGP synchronization for IS-IS is not supported in this release.

In 12.3(14)T, this feature was integrated. MPLS LDP-IGP synchronization for IS-IS is not supported in this release.

In 15.0(1)M, support for enabling synchronization on interfaces running IS-IS processes was added.

In XE 2.1, this feature was implemented on
Cisco ASR 1000 Series Routers.

The following commands were modified: debug mpls ldp igp sync, mpls ldp igp sync, mpls ldp igp sync holddown, mpls ldp sync, show ip ospf mpls ldp interface, show isis mpls ldp, and show mpls ldp igp sync.