This documentation has been moved
AToM Static Pseudowire Provisioning
Downloads: This chapterpdf (PDF - 168.0KB) The complete bookPDF (PDF - 11.12MB) | Feedback

AToM Static Pseudowire Provisioning

Table Of Contents

AToM Static Pseudowire Provisioning

Finding Feature Information

Contents

Restrictions for AToM Static Pseudowire Provisioning

Information About AToM Static Pseudowire Provisioning

Pseudowire Provisioning

Benefits of Statically Provisioned Pseudowires

How to Provision an AToM Static Pseudowire

Provisioning an AToM Static Pseudowire

Verifying the AToM Static Pseudowire Configuration

Configuration Examples for AToM Static Pseudowire Provisioning

Provisioning an AToM Pseudowire: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for AToM Static Pseudowire Provisioning


AToM Static Pseudowire Provisioning


First Published: February 19, 2007
Last Updated: March 1, 2010

The AToM Static Pseudowire Provisioning feature allows provisioning an Any Transport over Multiprotocol Label Switching (MPLS) (AToM) static pseudowire without the use of a directed control connection. In environments that do not or cannot use directed control protocols, this feature provides a means for provisioning the pseudowire parameters statically at the Cisco IOS command-line interface (CLI).

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for AToM Static Pseudowire Provisioning" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Restrictions for AToM Static Pseudowire Provisioning

Information About AToM Static Pseudowire Provisioning

How to Provision an AToM Static Pseudowire

Configuration Examples for AToM Static Pseudowire Provisioning

Additional References

Feature Information for AToM Static Pseudowire Provisioning

Restrictions for AToM Static Pseudowire Provisioning

The following parameters are exchanged using directed control protocol messages on pseudowires, but cannot be changed using the AToM Static Pseudowire Provisioning feature introduced in Cisco IOS Release 12.33(SRB). Instead, the software has preconfigured defaults.

The Virtual Circuit Connectivity Verification (VCCV) options used for fault detection, isolation, and verification at both ends of the connection are set as follows:

Control channel type 1 sets the control word.

Control channel type 2 sets the MPLS router alert label.

Connectivity verification type 2 sets the label switched path (LSP) ping command.

In Cisco IOS Release 12.2(33)SRE, support for cell packing for static pseudowires was added. This feature has the following restrictions:

Both provider-edge routers (PEs) must run Cisco IOS Release 12.2(33)SRE, and the maximum number of cells that can be packed must be set to the same value on each PE router.

Autosensing of the virtual circuit type for Ethernet over MPLS is not supported.

Additionally, the following functionality is not supported for static pseudowires:

Sequence number resynchronization—configured by the sequencing function in the pseudowire-class command—is not supported because the sequence number resynchronization is done when the Label Distribution Protocol (LDP) software sends an LDP Label Release or Withdraw message followed by a Label Request or Mapping message, and static pseudowires do not use LDP.

Tunnel stitching is not supported because it requires an extension of the neighbor command to start the mode that allows configuring static pseudowire parameters such as remote and local labels. Note that a tunnel switch point can be configured using a different static label command. The tunnel switch point will not process control words, but label swapping will occur.

Pseudowire redundancy is not supported because it requires using a directed control protocol between the peer provider edge routers.

Information About AToM Static Pseudowire Provisioning

To provision an AToM static pseudowire, you should understand the following concepts:

Pseudowire Provisioning

Benefits of Statically Provisioned Pseudowires

Pseudowire Provisioning

The AToM Static Pseudowire Provisioning feature allows you to configure static pseudowires in cases where you cannot use directed control protocols. .In most cases, pseudowires are dynamically provisioned using LDP or another directed control protocol, such as Resource Reservation Protocol over traffic-engineered tunnels (RSVP-TE), to exchange the various parameters required for these connections.

The AToM Static Pseudowire Provisioning feature is platform-independent, but has been tested on only the Cisco 7600 series routers.

Benefits of Statically Provisioned Pseudowires

This feature allows provisioning an AToM label switching static pseudowire without the use of a directed control connection. This feature also includes static provisioning of the tunnel label and the pseudowire label.

How to Provision an AToM Static Pseudowire

This section contains the following procedures:

Provisioning an AToM Static Pseudowire

Verifying the AToM Static Pseudowire Configuration

Provisioning an AToM Static Pseudowire

In this configuration task, you use options in the xconnect Ethernet interface configuration command to specify a static connection, and mpls commands in xconnect mode to statically set the following pseudowire parameters:

Set the local and remote pseudowire labels

Enable or disable sending the MPLS control word

SUMMARY STEPS

1. enable

2. configure terminal

3. interface ethernet-type interface-number

4. xconnect peer-ip-address vcid encapsulation mpls manual pw-class class-name

5. mpls label local-pseudowire-label remote-pseudowire-label

6. [no] mpls control-word

7. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface ethernet-type interface-number
Example:

Router(config)# interface Ethernet 1/0

Enters interface configuration mode for the specified interface.

Step 4 

xconnect peer-ip-address vcid encapsulation 
mpls manual pw-class class-name
Example:

Router(config-if)# xconnect 10.131.191.252 100 encapsulation mpls manual pw-class mpls

Configures a static AToM pseudowire and enters xconnect configuration mode where the local and remote pseudowire labels are set.

Step 5 

mpls label local-pseudowire-label 
remote-pseudowire-label
Example:

Router(config-if-xconn)# mpls label 100 150

Sets the local and remote pseudowire labels.

The label must be an unused static label within the static label range configured using the mpls label range command.

The mpls label command checks the validity of the label entered and displays an error message if it is not valid. The label supplied for the remote-pseudowire-label argument must be the value of the peer PE's local pseudowire label.

Step 6 

[no] mpls control-word
Example:

Router(config-if-xconn)# no mpls control-word

Sets whether the MPLS control word is sent.

This command must be set for Frame Relay data-link connection identifier (DLCI) and ATM adaptation layer 5 (AAL5) attachment circuits. For other attachment circuits, the control word is included by default.

If you enable inclusion of the control word, it must be enabled on both ends of the connection for the circuit to work properly.

Inclusion of the control word can be explicitly disabled using the no mpls control-word command.

Step 7 

exit
Example:

Router(config-if-xconn)# exit

Exits the configuration mode.

Continue entering the exit command at the router prompt until you reach the desired configuration mode.

Verifying the AToM Static Pseudowire Configuration

To verify the AToM static pseudowire configuration, use the show running-config EXEC command. To verify that the AToM static pseudowire was provisioned correctly, use the show mpls l2transport vc detail and ping mpls pseudowire EXEC commands as described in the following steps.

SUMMARY STEPS

1. show mpls l2transport vc detail

2. ping mpls pseudowire ipv4-address vc-id vc-id

DETAILED STEPS


Step 1 show mpls l2transport vc detail

For nonstatic pseudowire configurations, this command lists the type of protocol used to send the MPLS labels (such as LDP). For static pseudowire configuration, the value of the signaling protocol field should be Manual. Following is sample output:

Router# show mpls l2transport vc detail

Local interface: Et1/0 up, line protocol up, Ethernet up
  Destination address: 10.0.1.1, VC ID: 200, VC status: up
    Output interface: Et3/0, imposed label stack {17}
    Preferred path: not configured  
    Default path:
    Next hop: 10.0.0.2
  Create time: 00:27:27, last status change time: 00:27:24
  Signaling protocol: Manual
    MPLS VC labels: local 17, remote 17 
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
  Sequencing: receive disabled, send disabled
  VC statistics:
    packet totals: receive 193, send 193
    byte totals:   receive 19728, send 23554
    packet drops:  receive 0, send 0

Step 2 ping mpls pseudowire ipv4-address vc-id vc-id

Because there is no directed control protocol exchange of parameters on a static pseudowire, both ends of the connection must be correctly configured. One way to detect mismatch of labels or control word options is to send an MPLS pseudowire LSP ping command as part of configuration task, and then reconfigure the connection if problems are detected. An exclamation point (!) is displayed when the ping command is successfully sent to its destination. An example of command use and output follows:

Router# ping mpls pseudowire 10.7.1.2 vc-id 1001

Sending 5, 100-byte MPLS Echos to 10.7.1.2,
      timeout is 2 seconds, send interval is 0 msec:

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
   'L' - labeled output interface, 'B' - unlabeled output interface,
   'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
   'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
   'P' - no rx intf label prot, 'p' - premature termination of LSP,
   'R' - transit router, 'I' - unknown upstream index,
   'X' - unknown return code, 'x' - return code 0

Type escape sequence to abort.
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Configuration Examples for AToM Static Pseudowire Provisioning

This section contains the following example:

Provisioning an AToM Pseudowire: Example

Provisioning an AToM Pseudowire: Example

The following examples show the configuration commands for an AToM static pseudowire connection between two PEs, PE1 and PE2.

The mpls label range static command must be used to configure the static label range prior to provisioning the AToM static pseudowire.

Router# configure terminal
Router(config)# mpls label range 200 16000 static 16 199
% Label range changes will take effect at the next reload.

The mpls ip command must also be configured on the core-facing interface of both PE1 and PE2 (which is also done for directed control protocol signaled pseudowires). Following is a configuration example:

Router(config)# interface Ethernet 0/0
Router(config-if)# description Backbone interface
Router(config-if)# ip address 10.0.0.1 255.255.255.0
Router(config-if)# mpls ip
Router(config-if)# exit

Following is an example AToM static pseudowire configuration for PE1:

Router(config)# interface Ethernet 1/0
Router(config-if)# no ip address
Router(config-if)# xconnect 10.131.191.251 100 encapsulation mpls manual pw-class mpls
Router(config-if-xconn)# mpls label 100 150
Router(config-if-xconn)# exit

Following is an example AToM static pseudowire configuration for PE2:

Router(config)# interface Ethernet 1/0
Router(config-if)# no ip address
Router(config-if)# xconnect 10.132.192.252 100 encapsulation mpls manual pw-class mpls
Router(config-if-xconn)# mpls label 150 100
Router(config-if-xconn)# exit

This feature also allows tunnel labels to be statically configured using the mpls static binding ipv4 vrf command. This means that there is no need to use a directed control protocol to provision tunnels and pseudowires. Refer to the MPLS Static Labels feature module and the Cisco IOS Multiprotocol Label Switching Command Reference for information about static labels and the mpls static binding ipv4 vrf command.

Additional References

The following sections provide references related to the AToM Static Pseudowire Provisioning feature.

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

MPLS commands

Cisco IOS Multiprotocol Label Switching Command Reference

Configuring the pseudowire class

Any Transport over MPLS

MPLS and xconnect commands

Cisco IOS Multiprotocol Label Switching Command Reference

Static labels and the mpls static binding ipv4 vrf command

"MPLS Static Labels" section of the Cisco IOS Multiprotocol Label Switching Configuration Guide


Standards

Standard
Title

IETF draft-ietf-pwe3-vccv-12.txt

Pseudo Wire Virtual Circuit Connectivity Verification (VCCV)


MIBs

MIB
MIBs Link

None

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 3036

LDP Specification


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for AToM Static Pseudowire Provisioning

Table 1 lists the features in this module and provides links to specific configuration information. Only features that were introduced or modified in Cisco IOS Release 12.2(1) or a later release appear in the table.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for AToM Static Pseudowire Provisioning

Feature Name
Releases
Feature Information

AToM Static Pseudowire Provisioning

12.2(33)SRB
12.2(33)SRE

This feature allows provisioning an AToM static pseudowire without the use of a directed control protocol connection.

The AToM Static Pseudowire feature is platform-independent, but has been tested on only the Cisco 7600 series routers for Cisco IOS Release 12.33(SRB).

In Cisco IOS Release 12.2(33)SRE, the L2VPN Support for Cell Packing on Static PW feature was added.

The following commands were introduced or modified by this feature: cell-packing, mpls control-word, mpls label, show mpls l2transport vc, xconnect.