This documentation has been moved
Configuring Security for VPNs with IPsec
Downloads: This chapterpdf (PDF - 364.0KB) The complete bookPDF (PDF - 3.42MB) | Feedback

Configuring Security for VPNs with IPsec

Table Of Contents

Configuring Security for VPNs with IPsec

Finding Feature Information

Contents

Prerequisites for Configuring Security for VPNs with IPsec

Restrictions for Configuring Security for VPNs with IPsec

Information About Configuring Security for VPNs with IPsec

Supported Standards

Supported Hardware, Switching Paths, and Encapsulation

Supported Switching Paths

Supported Encapsulation

IPsec Functionality Overview

IPsec Traffic Nested to Multiple Peers

Crypto Access Lists

Crypto Access List Overview

When to Use the permit and deny Keywords in Crypto Access Lists

Mirror Image Crypto Access Lists at Each IPsec Peer

When to Use the any Keyword in Crypto Access Lists

Transform Sets: A Combination of Security Protocols and Algorithms

About Transform Sets

Crypto Map Sets

About Crypto Maps

Load Sharing Among Crypto Maps

Crypto Map Guidelines

Dynamic Crypto Maps

Redundant Interfaces Sharing the Same Crypto Map

Establishing Manual SAs

How to Configure IPsec VPNs

Creating Crypto Access Lists

What to Do Next

Defining Transform Sets

What to Do Next

Creating Crypto Map Sets

Creating Static Crypto Maps

Creating Dynamic Crypto Maps

Creating Crypto Map Entries to Establish Manual SAs

Applying Crypto Map Sets to Interfaces

Configuration Examples for Configuring an IPsec VPN

AES-Based Static Crypto Map: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for Security for VPNs with IPsec

Glossary


Configuring Security for VPNs with IPsec


First Published: May 2, 2005

Last Updated: February 28, 2011

This module describes how to configure basic IP Security (IPsec) virtual private networks (VPNs). IPsec is a framework of open standards developed by the Internet Engineering Task Force (IETF). It provides security for transmission of sensitive information over unprotected networks such as the Internet. IPsec acts at the network layer, protecting and authenticating IP packets between participating IPsec devices ("peers"), such as Cisco routers.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for Security for VPNs with IPsec" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for Configuring Security for VPNs with IPsec

Restrictions for Configuring Security for VPNs with IPsec

Information About Configuring Security for VPNs with IPsec

How to Configure IPsec VPNs

Configuration Examples for Configuring an IPsec VPN

Additional References

Feature Information for Security for VPNs with IPsec

Glossary

Prerequisites for Configuring Security for VPNs with IPsec

IKE Configuration

You must configure Internet Key Exchange (IKE) as described in the module "Configuring Internet Key Exchange Security for IPsec VPNs."

Even if you decide to not use IKE, you still must disable it as described in the module "Configuring Internet Key Exchange for IPsec VPNs."

Ensure Access Lists Are Compatible with IPsec

IKE uses UDP port 500. The IPsec Encapsulating Security Payload (ESP) and Authentication Header (AH) protocols use protocol numbers 50 and 51. Ensure that your access lists are configured so that protocol 50, 51, and User Datagram Protocol (UDP) port 500 traffic is not blocked at interfaces used by IPsec. In some cases you might need to add a statement to your access lists to explicitly permit this traffic.

Restrictions for Configuring Security for VPNs with IPsec

Unicast IP Datagram Application Only

At this time, IPsec can be applied to unicast IP datagrams only. Because the IPsec Working Group has not yet addressed the issue of group key distribution, IPsec does not currently work with multicasts or broadcast IP datagrams.

NAT Configuration

If you use Network Address Translation (NAT), you should configure static NAT translations so that IPsec works properly. In general, NAT translation should occur before the router performs IPsec encapsulation; in other words, IPsec should be working with global addresses.

Nested IPsec Tunnels

Cisco IOS XE IPsec supports nested tunnels that terminate on the same router. Double encryption of locally generated IKE packets and IPsec packets is supported only when a static virtual tunnel interface (sVTI) is configured. Double encryption is not supported on later releases.

Information About Configuring Security for VPNs with IPsec

Supported Standards

Supported Hardware, Switching Paths, and Encapsulation

IPsec Functionality Overview

IPsec Traffic Nested to Multiple Peers

Crypto Access Lists

Transform Sets: A Combination of Security Protocols and Algorithms

Crypto Map Sets

Supported Standards

Cisco implements the following standards with this feature:

IPsec—IP Security Protocol. IPsec is a framework of open standards that provides data confidentiality, data integrity, and data authentication between participating peers. IPsec provides these security services at the IP layer; it uses IKE to handle negotiation of protocols and algorithms based on local policy, and to generate the encryption and authentication keys to be used by IPsec. IPsec can be used to protect one or more data flows between a pair of hosts, between a pair of security gateways, or between a security gateway and a host.


Note The term IPsec is sometimes used to describe the entire protocol of IPsec data services and IKE security protocols and is also sometimes used to describe only the data services.


IKE—A hybrid protocol that implements Oakley and SKEME key exchanges inside the ISAKMP framework. While IKE can be used with other protocols, its initial implementation is with the IPsec protocol. IKE provides authentication of the IPsec peers, negotiates IPsec security associations, and establishes IPsec keys.

The component technologies implemented for IPsec include:

AES—Advanced Encryption Standard. A cryptographic algorithm that protects sensitive, unclassified information. AES is privacy transform for IPsec and IKE and has been developed to replace the DES. AES is designed to be more secure than DES: AES offers a larger key size, while ensuring that the only known approach to decrypt a message is for an intruder to try every possible key. AES has a variable key length—the algorithm can specify a 128-bit key (the default), a 192-bit key, or a 256-bit key.

DES—Data Encryption Standard. An algorithm that is used to encrypt packet data. Cisco IOS XE implements the mandatory 56-bit DES-CBC with Explicit IV. Cipher Block Chaining (CBC) requires an initialization vector (IV) to start encryption. The IV is explicitly given in the IPsec packet. For backwards compatibility, Cisco IOS XE IPsec also implements the RFC 1829 version of ESP DES-CBC.

Cisco IOS XE also implements Triple DES (168-bit) encryption, depending on the software versions available for a specific platform. Triple DES (3DES) is a strong form of encryption that allows sensitive information to be transmitted over untrusted networks. It enables customers to utilize network layer encryption.


Note Cisco IOS XE images with strong encryption (including, but not limited to, 56-bit data encryption feature sets) are subject to United States government export controls, and have a limited distribution. Images to be installed outside the United States require an export license. Customer orders might be denied or subject to delay due to United States government regulations. Contact your sales representative or distributor for more information, or send e-mail to export@cisco.com.


MD5 (HMAC variant)—MD5 (Message Digest 5) is a hash algorithm. HMAC is a keyed hash variant used to authenticate data.

SHA (HMAC variant)—SHA (Secure Hash Algorithm) is a hash algorithm. HMAC is a keyed hash variant used to authenticate data.

IPsec as implemented in Cisco IOS XE software supports the following additional standards:

AH—Authentication Header. A security protocol which provides data authentication and optional anti-replay services. AH is embedded in the data to be protected (a full IP datagram).

ESP—Encapsulating Security Payload. A security protocol which provides data privacy services and optional data authentication, and anti-replay services. ESP encapsulates the data to be protected.

Supported Hardware, Switching Paths, and Encapsulation

Supported Switching Paths

Supported Encapsulation

Supported Switching Paths

Table 1 Supported Switching Paths for IPsec 

Switching Paths
Examples

Process switching

interface fastethernet0/0/1
 no ip route-cache

Fast switching

interface fastethernet0/0/1
 ip route-cache
! Ensure that you will not hit flow switching.
 no ip route-cache flow
! Disable CEF for the interface, which 
supercedes global CEF.
 no ip route-cache cef

Cisco Express Forwarding (CEF)

ip cef
interface fastethernet0/0/1
 ip route-cache
! Ensure that you will not hit flow switching.
 no ip route-cache flow

Fast-flow switching

interface fastethernet0/0/1
 ip route-cache
! Enable flow switching
p route-cache flow
! Disable CEF for the interface.
  no ip route-cache cef

CEF-flow switching

! Enable global CEF.
ip cef
interface fastethernet0/0/1
 ip route-cache
 ip route-cache flow
! Enable CEF for the interface 
 ip route-cache cef

Supported Encapsulation

IPsec works with the following serial encapsulations: High-Level Data-Links Control (HDLC), PPP, and Frame Relay.

IPsec also works with the Generic Routing Encapsulation (GRE) and IPinIP Layer 3 protocols. Other Layer 3 tunneling protocols may not be supported for use with IPsec.

Because the IPsec Working Group has not yet addressed the issue of group key distribution, IPsec currently cannot be used to protect group traffic (such as broadcast or multicast traffic).

IPsec Functionality Overview

IPsec provides the following network security services. (In general, local security policy dictates the use of one or more of these services.)

Data Confidentiality—The IPsec sender can encrypt packets before transmitting them across a network.

Data Integrity—The IPsec receiver can authenticate packets sent by the IPsec sender to ensure that the data has not been altered during transmission.

Data Origin Authentication—The IPsec receiver can authenticate the source of the IPsec packets sent. This service is dependent upon the data integrity service.

Anti-Replay—The IPsec receiver can detect and reject replayed packets.

IPsec provides secure tunnels between two peers, such as two routers. You define which packets are considered sensitive and should be sent through these secure tunnels, and you define the parameters that should be used to protect these sensitive packets, by specifying characteristics of these tunnels. Then, when the IPsec peer recognizes such a sensitive packet, the peer sets up the appropriate secure tunnel and sends the packet through the tunnel to the remote peer. (The use of the term tunnel in this chapter does not refer to using IPsec in tunnel mode.)

More accurately, these tunnels are sets of security associations (SAs) that are established between two IPsec peers. The SAs define which protocols and algorithms should be applied to sensitive packets and specify the keying material to be used by the two peers. SAs are unidirectional and are established per security protocol (AH or ESP).

With IPsec you define what traffic should be protected between two IPsec peers by configuring access lists and applying these access lists to interfaces by way of crypto map sets. Therefore, traffic may be selected on the basis of source and destination address, and optionally Layer 4 protocol, and port. (The access lists used for IPsec are used only to determine which traffic should be protected by IPsec, not which traffic should be blocked or permitted through the interface. Separate access lists define blocking and permitting at the interface.)

A crypto map set can contain multiple entries, each with a different access list. The crypto map entries are searched in order—the router attempts to match the packet to the access list specified in that entry.

When a packet matches a permit entry in a particular access list, and the corresponding crypto map entry is tagged as cisco, connections are established if necessary. If the crypto map entry is tagged as ipsec-isakmp, IPsec is triggered. If no SA exists that IPsec can use to protect this traffic to the peer, IPsec uses IKE to negotiate with the remote peer to set up the necessary IPsec SAs on behalf of the data flow. The negotiation uses information specified in the crypto map entry as well as the data flow information from the specific access list entry. (The behavior is different for dynamic crypto map entries. See the section "Creating Dynamic Crypto Maps" section later in this module.)

If the crypto map entry is tagged as ipsec-manual, IPsec is triggered. If no SA exists that IPsec can use to protect this traffic to the peer, the traffic is dropped. In this case, the SAs are installed via the configuration, without the intervention of IKE. If the SAs did not exist, IPsec did not have all of the necessary pieces configured.

Once established, the set of SAs (outbound, to the peer) is then applied to the triggering packet and to subsequent applicable packets as those packets exit the router. "Applicable" packets are packets that match the same access list criteria that the original packet matched. For example, all applicable packets could be encrypted before being forwarded to the remote peer. The corresponding inbound SAs are used when processing the incoming traffic from that peer.

Multiple IPsec tunnels can exist between two peers to secure different data streams, with each tunnel using a separate set of SAs. For example, some data streams might be authenticated only while other data streams must both be encrypted and authenticated.

Access lists associated with IPsec crypto map entries also represent which traffic the router requires to be protected by IPsec. Inbound traffic is processed against the crypto map entries—if an unprotected packet matches a permit entry in a particular access list associated with an IPsec crypto map entry, that packet is dropped because it was not sent as an IPsec-protected packet.

Crypto map entries also include transform sets. A transform set is an acceptable combination of security protocols, algorithms, and other settings to apply to IPsec protected traffic. During the IPsec SA negotiation, the peers agree to use a particular transform set when protecting a particular data flow.

IPsec Traffic Nested to Multiple Peers

You can nest IPsec traffic to a series of IPsec peers. For example, in order for traffic to traverse multiple firewalls (these firewalls have a policy of not letting through traffic that they have not authenticated), the router must establish IPsec tunnels with each firewall in turn. The "nearer" firewall becomes the "outer" IPsec peer.

In the example shown in Figure 1, Router A encapsulates the traffic destined for Router C in IPsec (Router C is the inner IPsec peer). However, before Router A can send this traffic, it must first reencapsulate this traffic in IPsec in order to send it to Router B (Router B is the "outer" IPsec peer).

Figure 1 Nesting Example of IPsec Peers

It is possible for the traffic between the "outer" peers to have one kind of protection (such as data authentication) and for traffic between the "inner" peers to have different protection (such as both data authentication and encryption).

Crypto Access Lists

Crypto Access List Overview

When to Use the permit and deny Keywords in Crypto Access Lists

Mirror Image Crypto Access Lists at Each IPsec Peer

When to Use the any Keyword in Crypto Access Lists

Crypto Access List Overview

Crypto access lists are used to define which IP traffic is protected by crypto and which traffic is not protected by crypto. (These access lists are not the same as regular access lists, which determine what traffic to forward or block at an interface.) For example, access lists can be created to protect all IP traffic between Subnet A and Subnet Y or Telnet traffic between Host A and Host B.

The access lists themselves are not specific to IPsec. It is the crypto map entry referencing the specific access list that defines whether IPsec processing is applied to the traffic matching a permit in the access list.

Crypto access lists associated with IPsec crypto map entries have four primary functions:

Select outbound traffic to be protected by IPsec (permit = protect).

Indicate the data flow to be protected by the new SAs (specified by a single permit entry) when initiating negotiations for IPsec security associations.

Process inbound traffic in order to filter out and discard traffic that should have been protected by IPsec.

Determine whether or not to accept requests for IPsec security associations on behalf of the requested data flows when processing IKE negotiation from the IPsec peer.

Negotiation is performed only for ipsec-isakmp crypto map entries. In order to be accepted, if the peer initiates the IPsec negotiation, it must specify a data flow that is "permitted" by a crypto access list associated with an ipsec-isakmp crypto map entry.

If you want certain traffic to receive one combination of IPsec protection (for example, authentication only) and other traffic to receive a different combination of IPsec protection (for example, both authentication and encryption), you need to create two different crypto access lists to define the two different types of traffic. These different access lists are then used in different crypto map entries which specify different IPsec policies.

When to Use the permit and deny Keywords in Crypto Access Lists

Crypto protection can be permitted or denied for certain IP traffic in a crypto access list as follows:

To protect IP traffic that matches the specified policy conditions in its corresponding crypto map entry, use the permit keyword in an access list.

To refuse protection for IP traffic that matches the specified policy conditions in its corresponding crypto map entry, use the deny keyword in an access list.


Note IP traffic is not protected by crypto if it is refused protection in all of the crypto map entries for an interface.


After the corresponding crypto map entry is defined and the crypto map set is applied to the interface, the defined crypto access list is applied to an interface the defined crypto access list is applied to an interface. Different access lists must be used in different entries of the same crypto map set. However, both inbound and outbound traffic is evaluated against the same "outbound" IPsec access list. Therefore, the access list's criteria is applied in the forward direction to traffic exiting your router and in the reverse direction to traffic entering your router.

In Figure 2, IPsec protection is applied to traffic between Host 10.0.0.1 and Host 192.168.0.2 as the data exits Router A's S0 interface en route to Host 192.168.0.2. For traffic from Host 10.0.0.1 to Host 192.168.0.2, the access list entry on Router A is evaluated as follows:

source = host 10.0.0.1
dest = host 192.168.0.2

For traffic from Host 192.168.0.2 to Host 10.0.0.1, that same access list entry on Router A is evaluated as follows:

source = host 192.168.0.2
dest = host 10.0.0.1

Figure 2 How Crypto Access Lists Are Applied for Processing IPsec


If you configure multiple statements for a given crypto access list that is used for IPsec, in general the first permit statement that is matched is the statement used to determine the scope of the IPsec SA. That is, the IPsec SA is set up to protect traffic that meets the criteria of the matched statement only. Later, if traffic matches a different permit statement of the crypto access list, a new, separate IPsec SA is negotiated to protect traffic matching the newly matched access list statement.

Any unprotected inbound traffic that matches a permit entry in the crypto access list for a crypto map entry flagged as IPsec is dropped, because this traffic was expected to be protected by IPsec.


Note If you view your router's access lists by using a command such as show ip access-lists, all extended IP access lists are shown in the command output. This display output includes extended IP access lists that are used for traffic filtering purposes and those that are used for crypto. The show command output does not differentiate between the different uses of the extended access lists.


The following example shows that if overlapping networks are used, then the most specific networks are defined in crypto sequence numbers before less specific networks are defined. In this example, the more specific network is covered by the crypto map sequence number 10, followed by the less specific network in the crypto map, which is sequence number 20.

crypto map mymap 10 ipsec-isakmp 
 set peer 192.168.1.1
 set transform-set test 
 match address 101
crypto map mymap 20 ipsec-isakmp 
 set peer 192.168.1.2
 set transform-set test 
 match address 102

access-list 101 permit ip 10.1.1.0 0.0.0.255 172.16.1.0 0.0.0.255

access-list 102 permit ip 10.0.0.0 0.255.255.255 172.16.0.0 0.15.255.255

The following example shows how having a deny keyword in one crypto map sequence number and having a permit keyword for the same subnet and IP range in another crypto map sequence number is not supported.

crypto map mymap 10 ipsec-isakmp 
 set peer 192.168.1.1
 set transform-set test 
 match address 101
crypto map mymap 20 ipsec-isakmp 
 set peer 192.168.1.2
 set transform-set test 
 match address 102

access-list 101 deny   ip 10.1.1.0 0.0.0.255 172.16.1.0 0.0.0.255
access-list 101 permit ip 10.0.0.0 0.255.255.255 172.16.0.0 0.15.255.255

access-list 102 permit ip 10.1.1.0 0.0.0.255 172.16.1.0 0.0.0.255

Mirror Image Crypto Access Lists at Each IPsec Peer

Cisco recommends that for every crypto access list specified for a static crypto map entry that you define at the local peer, you define a "mirror image" crypto access list at the remote peer. This ensures that traffic that has IPsec protection applied locally can be processed correctly at the remote peer. (The crypto map entries themselves must also support common transforms and must refer to the other system as a peer.)

Figure 3 shows some sample scenarios when you have mirror image access lists and when you do not have mirror image access lists.

Figure 3 Mirror Image vs. Nonmirror Image Crypto Access Lists (for IPsec)

As Figure 3 indicates, IPsec SAs can be established as expected whenever the two peers' crypto access lists are mirror images of each other. However, an IPsec SA can be established only some of the time when the access lists are not mirror images of each other. This can happen in the case where an entry in one peer's access list is a subset of an entry in the other peer's access list, such as shown in Cases 3 and 4 of Figure 3. IPsec SA establishment is critical to IPsec—without SAs, IPsec does not work, causing any packets matching the crypto access list criteria to be silently dropped instead of being forwarded with IPsec.

In Figure 3, an SA cannot be established in Case 4. This is because SAs are always requested according to the crypto access lists at the initiating packet's end. In Case 4, Router N requests that all traffic between Subnet X and Subnet Y be protected, but this is a superset of the specific flows permitted by the crypto access list at Router M so the request is therefore not permitted. Case 3 works because Router M's request is a subset of the specific flows permitted by the crypto access list at Router N.

Because of the complexities introduced when crypto access lists are not configured as mirror images at peer IPsec devices, Cisco strongly encourages you to use mirror image crypto access lists.

When to Use the any Keyword in Crypto Access Lists

When you create crypto access lists, using the any keyword could cause problems. Cisco discourages the use of the any keyword to specify source or destination addresses.

The any keyword in a permit statement is discouraged when you have multicast traffic flowing through the IPsec interface; the any keyword can cause multicast traffic to fail.

The permit any any statement is strongly discouraged, because this causes all outbound traffic to be protected (and all protected traffic sent to the peer specified in the corresponding crypto map entry) and requires protection for all inbound traffic. Then, all inbound packets that lack IPsec protection are silently dropped, including packets for routing protocols, Network Time Protocol (NTP), echo, echo response, and so on.

You need to be sure you define which packets to protect. If you must use the any keyword in a permit statement, you must preface that statement with a series of deny statements to filter out any traffic (that would otherwise fall within that permit statement) that you do not want to be protected.

Also, use of any keyword in access control lists (ACLs) with reverse route injection (RRI) is not supported. (For more information on RRI, see the section "Creating Crypto Map Sets.")

Transform Sets: A Combination of Security Protocols and Algorithms

About Transform Sets

About Transform Sets

A transform set represents a certain combination of security protocols and algorithms. During the IPsec SA negotiation, the peers agree to use a particular transform set for protecting a particular data flow.

You can specify multiple transform sets, and then specify one or more of these transform sets in a crypto map entry. The transform set defined in the crypto map entry is used in the IPsec SA negotiation to protect the data flows specified by that crypto map entry's access list.

During IPsec security association negotiations with IKE, the peers search for a transform set that is the same at both peers. When such a transform set is found, it is selected and is applied to the protected traffic as part of both peers' IPsec SAs. (With manually established SAs, there is no negotiation with the peer, so both sides must specify the same transform set.)

If you change a transform set definition, the change is only applied to crypto map entries that reference the transform set. The change is not applied to existing security associations, but is used in subsequent negotiations to establish new SAs. If you want the new settings to take effect sooner, you can clear all or part of the SA database by using the clear crypto sa command.

Table 2 shows allowed transform combinations.

Table 2 Allowed Transform Combinations 

Transform Type
Transform
Description

AH Transform

ah-md5-hmac

ah-sha-hmac

AH with the MD5 (a Hash-based Message Authentication Code [HMAC] variant) authentication algorithm

AH with the SHA (an HMAC variant) authentication algorithm

ESP Encryption Transform

esp-aes


esp-aes 192


esp-aes 256


esp-des

esp-3des

esp-null

ESP with the 128-bit AES encryption algorithm 

ESP with the 192-bit AES encryption algorithm


ESP with the 256-bit AES encryption algorithm

ESP with the 56-bit DES encryption algorithm


ESP with the 168-bit DES encryption algorithm (3DES or Triple DES)

Null encryption algorithm

ESP Authentication Transform

esp-md5-hmac

esp-sha-hmac

ESP with the MD5 (HMAC variant) authentication algorithm

ESP with the SHA (HMAC variant) authentication algorithm


Crypto Map Sets

Before you create crypto map entries, you should determine which type of crypto map—static, dynamic, or manual—best addresses the needs of your network.

About Crypto Maps

Load Sharing Among Crypto Maps

Crypto Map Guidelines

Dynamic Crypto Maps

Redundant Interfaces Sharing the Same Crypto Map

Establishing Manual SAs

About Crypto Maps

Crypto map entries created for IPsec pull together the various parts used to set up IPsec SAs, including:

Which traffic should be protected by IPsec (per a crypto access list)

The granularity of the flow to be protected by a set of SAs

Where IPsec-protected traffic should be sent (who the remote IPsec peer is)

The local address to be used for the IPsec traffic (See the section "Applying Crypto Map Sets to Interfaces" for more details.)

What IPsec SA should be applied to this traffic (selecting from a list of one or more transform sets)

Whether SAs are manually established or are established via IKE

Other parameters that might be necessary to define an IPsec SA

How Crypto Maps Work

Crypto map entries with the same crypto map name (but different map sequence numbers) are grouped into a crypto map set. Later, you apply these crypto map sets to interfaces; then, all IP traffic passing through the interface is evaluated against the applied crypto map set. If a crypto map entry sees outbound IP traffic that should be protected and the crypto map specifies the use of IKE, a SA is negotiated with the remote peer according to the parameters included in the crypto map entry; otherwise, if the crypto map entry specifies the use of manual SAs, an SA should have already been established via configuration. (If a dynamic crypto map entry sees outbound traffic that should be protected and no security association exists, the packet is dropped.)

The policy described in the crypto map entries is used during the negotiation of SAs. If the local router initiates the negotiation, it uses the policy specified in the static crypto map entries to create the offer to be sent to the specified IPsec peer. If the IPsec peer initiates the negotiation, the local router checks the policy from the static crypto map entries, as well as any referenced dynamic crypto map entries to decide whether to accept or reject the peer's request (offer).

For IPsec to succeed between two IPsec peers, both peers' crypto map entries must contain compatible configuration statements.

Compatible Crypto Maps: Establishing an SA

When two peers try to establish a SA, they must each have at least one crypto map entry that is compatible with one of the other peer's crypto map entries. For two crypto map entries to be compatible, they must at least meet the following criteria:

The crypto map entries must contain compatible crypto access lists (for example, mirror image access lists). In the case where the responding peer is using dynamic crypto maps, the entries in the local crypto access list must be "permitted" by the peer's crypto access list.

The crypto map entries must each identify the other peer (unless the responding peer is using dynamic crypto maps).

The crypto map entries must have at least one transform set in common.

Load Sharing Among Crypto Maps

You can define multiple remote peers using crypto maps to allow for load sharing. Load sharing is useful because if one peer fails, there continues to be a protected path. The peer that packets are actually sent to is determined by the last peer that the router heard from (received either traffic or a negotiation request from) for a given data flow. If the attempt fails with the first peer, IKE tries the next peer on the crypto map list.

If you are not sure how to configure each crypto map parameter to guarantee compatibility with other peers, you might consider configuring dynamic crypto maps as described in the section "Creating Dynamic Crypto Maps." Dynamic crypto maps are useful when the establishment of the IPsec tunnels is initiated by the remote peer (such as in the case of an IPsec router fronting a server). They are not useful if the establishment of the IPsec tunnels is locally initiated, because the dynamic crypto maps are policy templates, not complete statements of policy. (Although the access lists in any referenced dynamic crypto map entry are used for crypto packet filtering.)

Crypto Map Guidelines

You can apply only one crypto map set to a single interface. The crypto map set can include a combination of IPsec/IKE and IPsec/manual entries. Multiple interfaces can share the same crypto map set if you want to apply the same policy to multiple interfaces.

If you create more than one crypto map entry for a given interface, use the seq-num argument of each map entry to rank the map entries: the lower the seq-num argument, the higher the priority. At the interface that has the crypto map set, traffic is evaluated against higher priority map entries first.

You must create multiple crypto map entries for a given interface if any of the following conditions exist:

If different data flows are to be handled by separate IPsec peers.

If you want to apply different IPsec security to different types of traffic (to the same or separate IPsec peers); for example, if you want traffic between one set of subnets to be authenticated, and traffic between another set of subnets to be both authenticated and encrypted. In this case the different types of traffic should have been defined in two separate access lists, and you must create a separate crypto map entry for each crypto access list.

If you are not using IKE to establish a particular set of security associations, and want to specify multiple access list entries, you must create separate access lists (one per permit entry) and specify a separate crypto map entry for each access list.

Dynamic Crypto Maps

Dynamic crypto maps can ease IPsec configuration and are recommended for use with networks where the peers are not always predetermined.


Note Dynamic crypto maps are only available for use by IKE.


A dynamic crypto map entry is essentially a static crypto map entry without all the parameters configured. It acts as a policy template where the missing parameters are later dynamically configured (as the result of an IPsec negotiation) to match a remote peer's requirements. This allows remote peers to exchange IPsec traffic with the router even if the router does not have a crypto map entry specifically configured to meet all of the remote peer's requirements.

Dynamic crypto maps are not used by the router to initiate new IPsec security associations with remote peers. Dynamic crypto maps are used when a remote peer tries to initiate an IPsec security association with the router. Dynamic crypto maps are also used in evaluating traffic.

A dynamic crypto map set is included by reference as part of a crypto map set. Any crypto map entries that reference dynamic crypto map sets should be the lowest priority crypto map entries in the crypto map set (that is, have the highest sequence numbers) so that the other crypto map entries are evaluated first; that way, the dynamic crypto map set is examined only when the other (static) map entries are not successfully matched.

If the router accepts the peer's request, at the point that it installs the new IPsec security associations it also installs a temporary crypto map entry. This entry is filled in with the results of the negotiation. At this point, the router performs normal processing, using this temporary crypto map entry as a normal entry, even requesting new security associations if the current ones are expiring (based upon the policy specified in the temporary crypto map entry). Once the flow expires (that is, all of the corresponding security associations expire), the temporary crypto map entry is then removed.

For both static and dynamic crypto maps, if unprotected inbound traffic matches a permit statement in an access list, and the corresponding crypto map entry is tagged as "IPsec," then the traffic is dropped because it is not IPsec-protected. (This is because the security policy as specified by the crypto map entry states that this traffic must be IPsec-protected.)

For static crypto map entries, if outbound traffic matches a permit statement in an access list and the corresponding SA is not yet established, the router initiates new SAs with the remote peer. In the case of dynamic crypto map entries, if no SA existed, the traffic would simply be dropped (because dynamic crypto maps are not used for initiating new SAs).


Note Use care when using the any keyword in permit entries in dynamic crypto maps. If it is possible for the traffic covered by such a permit entry to include multicast or broadcast traffic, the access list should include deny entries for the appropriate address range. Access lists should also include deny entries for network and subnet broadcast traffic, and for any other traffic that should not be IPsec protected.


Redundant Interfaces Sharing the Same Crypto Map

For redundancy, you could apply the same crypto map set to more than one interface. The default behavior is as follows:

Each interface has its own piece of the security association database.

The IP address of the local interface is used as the local address for IPsec traffic originating from or destined to that interface.

If you apply the same crypto map set to multiple interfaces for redundancy purposes, you need to specify an identifying interface. One suggestion is to use a loopback interface as the identifying interface. This has the following effects:

The per-interface portion of the IPsec security association database is established one time and shared for traffic through all the interfaces that share the same crypto map.

The IP address of the identifying interface is used as the local address for IPsec traffic originating from or destined to those interfaces sharing the same crypto map set.

Establishing Manual SAs

The use of manual security associations is a result of a prior arrangement between the users of the local router and the IPsec peer. The two parties may begin with manual SAs and then move to using SAs established via IKE, or the remote party's system may not support IKE. If IKE is not used for establishing the SAs, there is no negotiation of SAs, so the configuration information in both systems must be the same in order for traffic to be processed successfully by IPsec.

The local router can simultaneously support manual and IKE-established SAs, even within a single crypto map set.

There is very little reason to disable IKE on the local router (unless the router only supports manual SAs, which is unlikely).


Note Access lists for crypto map entries tagged as ipsec-manual are restricted to a single permit entry and subsequent entries are ignored. In other words, the SAs established by that particular crypto map entry are only for a single data flow. To be able to support multiple manually established SAs for different kinds of traffic, define multiple crypto access lists, and then apply each one to a separate ipsec-manual crypto map entry. Each access list should include one permit statement defining what traffic to protect.


How to Configure IPsec VPNs

Creating Crypto Access Lists

Defining Transform Sets

Creating Crypto Map Sets

Applying Crypto Map Sets to Interfaces

Creating Crypto Access Lists

Perform this task to create crypto access lists.

SUMMARY STEPS

1. enable

2. configure terminal

3. access-list access-list-number {deny | permit} protocol source source-wildcard destination destination-wildcard [log]

or

ip access-list extended name

4. Repeat Step 3 for each crypto access list you want to create.

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

access-list access-list-number {deny | permit} protocol source source-wildcard destination destination-wildcard [log]

Example:

Router(config)# access-list 100 permit ip 10.0.68.0 0.0.0.255 10.1.1.0 0.0.0.255


or

ip access-list extended name

Example:

Router(config)# ip access-list extended vpn-tunnel

Specifies conditions to determine which IP packets are protected.1

Enable or disable crypto for traffic that matches these conditions.

Tip Cisco recommends that you configure "mirror image" crypto access lists for use by IPsec and that you avoid using the any keyword.

Step 4 

Repeat Step 3 for each crypto access list you want to create.

1 You specify conditions using an IP access list designated by either a number or a name. The access-list command designates a numbered extended access list; the ip access-list extended command designates a named access list.

What to Do Next

After at least one crypto access list is created, a transform set needs to be defined as described in the section "Defining Transform Sets."

Next the crypto access lists need to be associated to particular interfaces when you configure and apply crypto map sets to the interfaces are configured and applied (following instructions in the sections "Creating Crypto Map Sets" and "Applying Crypto Map Sets to Interfaces").

Defining Transform Sets

Perform this task to define a transform set that is to be used by the IPsec peers during IPsec security association negotiations with IKE.

SUMMARY STEPS

1. enable

2. configure terminal

3. crypto ipsec transform-set transform-set-name transform1 [transform2 [transform3]]

4. mode [tunnel | transport]

5. exit

6. clear crypto sa [peer {ip-address | peer-name} | sa map map-name | sa entry destination-address protocol spi]

7. show crypto ipsec transform-set [tag transform-set-name]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

crypto ipsec transform-set transform-set-name transform1 [transform2 [transform3]]

Example:

Router(config)# crypto ipsec transform-set aesset esp-aes 256 esp-sha-hmac

Defines a transform set and enters crypto transform configuration mode.

There are complex rules defining which entries you can use for the transform arguments. These rules are explained in the command description for the crypto ipsec transform-set command, and Table 2 provides a list of allowed transform combinations.

Step 4 

mode [tunnel | transport]

Example:

Router(cfg-crypto-tran)# mode transport

(Optional) Changes the mode associated with the transform set.

The mode setting is applicable only to traffic whose source and destination addresses are the IPsec peer addresses; it is ignored for all other traffic. (All other traffic is in tunnel mode only.)

Step 5 

exit

Example:

Router(config)# exit

Exits global configuration mode.

Step 6 

clear crypto sa [peer {ip-address | peer-name} | sa map map-name | sa entry destination-address protocol spi]

Example:

Router# clear crypto sa

(Optional) Clears existing IPsec security associations so that any changes to a transform set takes effect on subsequently established security associations.

Manually established SAs are reestablished immediately.

Using the clear crypto sa command without parameters clear out the full SA database, which clears out active security sessions.

You may also specify the peer, map, or entry keywords to clear out only a subset of the SA database.

Step 7 

show crypto ipsec transform-set [tag transform-set-name]

Example:

Router# show crypto ipsec transform-set

(Optional) Displays the configured transform sets.

What to Do Next

After you have defined a transform set, you should create a crypto map as specified in the section "Creating Crypto Map Sets."

Creating Crypto Map Sets

Creating Static Crypto Maps

Creating Dynamic Crypto Maps

Creating Crypto Map Entries to Establish Manual SAs

Creating Static Crypto Maps

When IKE is used to establish SAs, the IPsec peers can negotiate the settings they use for the new security associations. This means that you can specify lists (such as lists of acceptable transforms) within the crypto map entry.

Perform this task to create crypto map entries that use IKE to establish the SAs.

SUMMARY STEPS

1. enable

2. configure terminal

3. crypto map map-name seq-num ipsec-isakmp

4. match address access-list-id

5. set peer {hostname | ip-address}

6. set transform-set transform-set-name1 [transform-set-name2...transform-set-name6]

7. set security-association lifetime {seconds seconds | kilobytes kilobytes}

8. set security-association level per-host

9. set pfs [group1 | group2 | group5]

10. exit

11. exit

12. show crypto map [interface interface | tag map-name]

DETAILED STEPS

 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

crypto map map-name seq-num ipsec-isakmp

Example:

Router(config)# crypto map static-map 1 ipsec-isakmp

Names the crypto map entry to create (or modify), and enters crypto map configuration mode.

Step 4 

match address access-list-id

Example:

Router(config-crypto-m)# match address vpn-tunnel

Names an extended access list.

This access list determines which traffic should be protected by IPsec and which traffic should not be protected by IPsec security in the context of this crypto map entry.

Step 5 

set peer {hostname | ip-address}

Example:

Router(config-crypto-m)# set-peer 192.168.101.1

Specifies a remote IPsec peer, the peer to which IPsec protected traffic can be forwarded.

Repeat for multiple remote peers.

Step 6 

set transform-set transform-set-name1 [transform-set-name2...transform-set-name6]

Example:

Router(config-crypto-m)# set transform-set aesset

Specifies which transform sets are allowed for this crypto map entry.

List multiple transform sets in order of priority (highest priority first).

Step 7 

set security-association lifetime {seconds seconds | kilobytes kilobytes}

Example:

Router (config-crypto-m)# set security-association lifetime seconds 2700

(Optional) Specifies a SA lifetime for the crypto map entry.

By default, the SAs of the crypto map are negotiated according to the global lifetimes.

Step 8 

set security-association level per-host

Example:

Router(config-crypto-m)# set security-association level per-host

(Optional) Specifies that separate SAs should be established for each source and destination host pair.

By default, a single IPsec "tunnel" can carry traffic for multiple source hosts and multiple destination hosts.


Caution Use this command with care, because multiple streams between given subnets can rapidly consume resources.

Step 9 

set pfs [group1 | group2 | group 5]

Example:

Router(config-crypto-m)# set pfs group2

(Optional) Specifies that IPsec either should ask for perfect forward secrecy (PFS) when requesting new SAs for this crypto map entry or should demand PFS in requests received from the IPsec peer.

By default, PFS is not requested. If no group is specified with this command, group1 is used as the default.

Step 10 

exit

Example:

Router(config-crypto-m)# exit

Exits crypto-map configuration mode.

Step 11 

exit

Example:

Router(config)# exit

Exits global configuration mode.

Step 12 

show crypto map [interface interface | tag map-name]

Example:

Router# show crypto map

Displays your crypto map configuration.

Troubleshooting Tips

Certain configuration changes take effect only when negotiating subsequent SAs. If you want the new settings to take immediate effect, you must clear the existing SAs so that they are re-established with the changed configuration. If the router is actively processing IPsec traffic, it is desirable to clear only the portion of the SA database that would be affected by the configuration changes (that is, clear only the SAs established by a given crypto map set). Clearing the full SA database should be reserved for large-scale changes, or when the router is processing very little other IPsec traffic.

To clear IPsec SAs, use the clear crypto sa command with appropriate parameters. (Omitting all parameters clears out the full SA database, which clears active security sessions.)

What to Do Next

After you have successfully created a static crypto map, you must apply the crypto map set to each interface through which IPsec traffic flows. To complete this task, see the section "Applying Crypto Map Sets to Interfaces."

Creating Dynamic Crypto Maps

Perform this task to create dynamic crypto map entries that use IKE to establish the SAs.

Restrictions for Dynamic Crypto Maps

Dynamic crypto map entries specify crypto access lists that limit traffic for which IPsec SAs can be established. A dynamic crypto map entry that does not specify an access list is ignored during traffic filtering. A dynamic crypto map entry with an empty access list causes traffic to be dropped. If there is only one dynamic crypto map entry in the crypto map set, it must specify acceptable transform sets.

SUMMARY STEPS

1. enable

2. configure terminal

3. crypto dynamic-map dynamic-map-name dynamic-seq-num

4. set transform-set transform-set-name1 [transform-set-name2...transform-set-name6]

5. match address access-list-id

6. set peer {hostname | ip-address}

7. set security-association lifetime {seconds seconds | kilobytes kilobytes}

8. set pfs [group1 | group2 | group5]

9. exit

10. exit

11. show crypto dynamic-map [tag map-name]

12. configure terminal

13. crypto map map-name seq-num ipsec-isakmp dynamic dynamic-map-name [discover]

DETAILED STEPS

 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

crypto dynamic-map dynamic-map-name dynamic-seq-num

Example:

Router(config)# crypto dynamic-map test-map 1

Creates a dynamic crypto map entry and enters crypto map configuration mode.

Step 4 

set transform-set transform-set-name1 [transform-set-name2...transform-set-name6]

Example:

Router(config-crypto-m)# set transform-set aesset

Specifies which transform sets are allowed for the crypto map entry.

List multiple transform sets in order of priority (highest priority first). This is the only configuration statement required in dynamic crypto map entries.

Step 5 

match address access-list-id

Example:

Router(config-crypto-m)# match address 101

(Optional) Accesses list number or name of an extended access list.

This access list determines which traffic should be protected by IPsec and which traffic should not be protected by IPsec security in the context of this crypto map entry.

Note Although access-lists are optional for dynamic crypto maps, they are highly recommended.

If this is configured, the data flow identity proposed by the IPsec peer must fall within a permit statement for this crypto access list.

If this is not configured, the router accepts any data flow identity proposed by the IPsec peer. However, if this is configured but the specified access list does not exist or is empty, the router drops all packets. This is similar to static crypto maps because they also require that an access list be specified.

Care must be taken if the any keyword is used in the access list, because the access list is used for packet filtering as well as for negotiation.

You must configure a match address; otherwise, the behavior is not secure.

Step 6 

set peer {hostname | ip-address}

Example:

Router(config-crypto-m)# set peer 192.168.101.1

(Optional) Specifies a remote IPsec peer. Repeat for multiple remote peers.

Note This is rarely configured in dynamic crypto map entries. Dynamic crypto map entries are often used for unknown remote peers.

Step 7 

set security-association lifetime {seconds seconds | kilobytes kilobytes}

Example:

Router (config-crypto-m)# set security-association lifetime seconds 7200

(Optional) Overrides (for a particular crypto map entry) the global lifetime value, which is used when negotiating IP Security SAs.

Step 8 

set pfs [group1 | group2 | group5]

Example:

Router(config-crypto-m)# set pfs group2

(Optional) Specifies that IPsec should ask for PFS when requesting new security associations for this crypto map entry or should demand PFS in requests received from the IPsec peer.

By default, PFS is not requested. If no group is specified with this command, group1 is used as the default.

Step 9 

exit

Example:

Router(config-crypto-m)# exit

Exits crypto-map configuration mode and returns to global configuration mode.

Step 10 

exit

Example:

Router(config)# exit

Exits global configuration mode.

Step 11 

show crypto dynamic-map [tag map-name]

Example:

Router# show crypto dynamic-map

(Optional) Displays information about dynamic crypto maps.

Step 12 

configure terminal

Example:

Router# configure terminal

Returns to global configuration mode.

Step 13 

crypto map map-name seq-num ipsec-isakmp dynamic dynamic-map-name

Example:

Router(config)# crypto map static-map 1 ipsec-isakmp dynamic test-map

(Optional) Adds a dynamic crypto map to a crypto map set.

You should set the crypto map entries referencing dynamic maps to the lowest priority entries in a crypto map set.

Troubleshooting Tips

Certain configuration changes take effect only when negotiating subsequent SAs. If you want the new settings to take immediate effect, you must clear the existing SAs so that they are reestablished with the changed configuration. If the router is actively processing IPsec traffic, it is desirable to clear only the portion of the SA database that would be affected by the configuration changes (that is, clear only the SAs established by a given crypto map set). Clearing the full SA database should be reserved for large-scale changes, or when the router is processing very little other IPsec traffic.

To clear IPsec SAs, use the clear crypto sa command with appropriate parameters. (Omitting all parameters clears the full SA database, which clears active security sessions.)

What to Do Next

After you have successfully created a crypto map set, you must apply the crypto map set to each interface through which IPsec traffic flows. To complete this task, see the section "Applying Crypto Map Sets to Interfaces."

Creating Crypto Map Entries to Establish Manual SAs

To create crypto map entries to establish manual SAs (that is, when IKE is not used to establish the SAs), perform this task.

SUMMARY STEPS

1. enable

2. configure terminal

3. crypto map map-name seq-num ipsec-manual

4. match address access-list-id

5. set peer {hostname | ip-address}

6. set transform-set transform-set-name

7. set session-key inbound ah spi hex-key-string

or

set session-key outbound ah spi hex-key-string

8. set session-key inbound esp spi cipher hex-key-string [authenticator hex-key-string]

or

set session-key outbound esp spi cipher hex-key-string [authenticator hex-key-string]

9. exit

10. exit

11. show crypto map [interface interface | tag map-name]

DETAILED STEPS

 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

crypto map map-name seq-num ipsec-manual

Example:

Router(config)# crypto map mymap 10 ipsec-manual

Specifies the crypto map entry to create or modify and enters crypto map configuration mode.

Step 4 

match address access-list-id

Example:

Router(config-crypto-m)# match address 102

Names an IPsec access list that determines which traffic should be protected by IPsec and which traffic should not be protected by IPsec in the context of this crypto map entry.

(The access list can specify only one permit entry when IKE is not used.)

Step 5 

set peer {hostname | ip-address}

Example:

Router(config-crypto-m)# set peer 10.0.0.5

Specifies the remote IPsec peer. This is the peer to which IPsec protected traffic should be forwarded.

(Only one peer can be specified when IKE is not used.)

Step 6 

set transform-set transform-set-name

Example:

Router(config-crypto-m)# set transform-set someset

Specifies which transform set should be used.

This must be the same transform set that is specified in the remote peer's corresponding crypto map entry.

Note Only one transform set can be specified when IKE is not used.

Step 7 

set session-key inbound ah spi hex-key-string

Example:

Router(config-crypto-m)# set session-key inbound ah 256 98765432109876549876543210987654

and

set session-key outbound ah spi hex-key-string
Example:

Router(config-crypto-m)# set session-key outbound ah 256 fedcbafedcbafedcfedcbafedcbafedc

Sets the AH security parameter indexes (SPIs) and keys to apply to inbound and outbound protected traffic if the specified transform set includes the AH protocol.

(This manually specifies the AH security association to be used with protected traffic.)

Step 8 

set session-key inbound esp spi cipher hex-key-string [authenticator hex-key-string]

Example:

Router(config-crypto-m)# set session-key inbound esp 256 cipher 0123456789012345


and

set session-key outbound esp spi cipher hex-key-string [authenticator hex-key-string]

Example:

Router(config-crypto-m)# set session-key outbound esp 256 cipher abcdefabcdefabcd

Sets the ESP SPIs and keys to apply to inbound and outbound protected traffic if the specified transform set includes the ESP protocol. Specifies the cipher keys if the transform set includes an ESP cipher algorithm. Specifies the authenticator keys if the transform set includes an ESP authenticator algorithm.

(This manually specifies the ESP security association to be used with protected traffic.)

Step 9 

exit
Example:

Router(config-crypto-m)# exit

Exits crypto-map configuration mode and returns to global configuration mode.

Step 10 

exit

Example:

Router(config)# exit

Exits global configuration mode.

Step 11 

show crypto map [interface interface | tag map-name]

Example:

Router# show crypto map

Displays your crypto map configuration.

Troubleshooting Tips

For manually established SAs, you must clear and reinitialize the SAs for the changes to take effect. To clear IPsec SAs, use the clear crypto sa command with appropriate parameters. (Omitting all parameters clears the full SA database, which clears active security sessions.)

What to Do Next

After you have successfully created a crypto map set, you must apply the crypto map set to each interface through which IPsec traffic flows. To complete this task, see the section "Applying Crypto Map Sets to Interfaces."

Applying Crypto Map Sets to Interfaces

You need to apply a crypto map set to each interface through which IPsec traffic flows. Applying the crypto map set to an interface instructs the router to evaluate all the interface's traffic against the crypto map set and to use the specified policy during connection or security association negotiation on behalf of traffic to be protected by crypto.

Perform this task to apply a crypto map to an interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. crypto map map-name

5. exit

6. crypto map map-name local-address interface-id

7. exit

8. show crypto map [interface interface]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# Interface FastEthernet 0/0

Configures an interface and enters interface configuration mode.

Step 4 

crypto map map-name

Example:

Router(config-if)# crypto map mymap

Applies a crypto map set to an interface.

Step 5 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 6 

crypto map map-name local-address interface-id

Example:

Router(config)# crypto map mymap local-address loopback0

(Optional) Permits redundant interfaces to share the same crypto map using the same local identity.

Step 7 

exit

Example:

Router(config)# exit

(Optional) Exits global configuration mode.

Step 8 

show crypto map [interface interface]

Example:

Router# show crypto map

(Optional) Displays your crypto map configuration

Configuration Examples for Configuring an IPsec VPN

AES-Based Static Crypto Map: Example

The following example is a portion of the show running-config command. This example shows how to configure a static crypto map and define AES as the encryption method.

crypto isakmp policy 10
 encryption aes 256
 authentication pre-share
 lifetime 180

crypto isakmp key cisco123 address 10.0.110.1
!
!
crypto ipsec transform-set aesset esp-aes 256 esp-sha-hmac
 mode transport
!
crypto map aesmap 10 ipsec-isakmp
 set peer 10.0.110.1
 set transform-set aesset
 match address 120
!
!
!
voice call carrier capacity active
!
!
mta receive maximum-recipients 0
!
!
interface FastEthernet0/0/1
 ip address 10.0.110.2 255.255.255.0
 ip nat outside
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
 crypto map aesmap
!
interface Serial0/0
 no ip address
 shutdown
!
interface FastEthernet0/1/1
 ip address 10.0.110.1 255.255.255.0
 ip nat inside
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
!
ip nat inside source list 110 interface FastEthernet0/0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 10.5.1.1
ip route 10.0.110.0 255.255.255.0 FastEthernet0/0/1
ip route 172.18.124.0 255.255.255.0 10.5.1.1
ip route 172.18.125.3 255.255.255.255 10.5.1.1
ip http server
!
!
access-list 110 deny   ip 10.0.110.0 0.0.0.255 10.0.110.0 0.0.0.255
access-list 110 permit ip 10.0.110.0 0.0.0.255 any
access-list 120 permit ip 10.0.110.0 0.0.0.255 10.0.110.0 0.0.0.255
!

Additional References

Related Documents

Related Topic
Document Title

IKE configuration

Configuring IKE for IPsec VPNs

IKE, IPsec, and PKI configuration commands: complete command syntax, command mode, defaults, usage guidelines, and examples

Cisco IOS Security Command Reference


Standards

Standards
Title

None.


MIBs

MIBs
MIBs Link

CISCO-IPSEC-FLOW-MONITOR- MIB

CISCO-IPSEC-MIB

CISCO-IPSEC-POLICY-MAP-MIB

To locate and download MIBs for selected platforms, Cisco IOS XE releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 2401

Security Architecture for the Internet Protocol

RFC 2402

IP Authentication Header

RFC 2403

The Use of HMAC-MD5-96 within ESP and AH

RFC 2404

The Use of HMAC-SHA-1-96 within ESP and AH

RFC 2405

The ESP DES-CBC Cipher Algorithm With Explicit IV

RFC 2406

IP Encapsulating Security Payload (ESP)

RFC 2407

The Internet IP Security Domain of Interpretation for ISAKMP

RFC 2408

Internet Security Association and Key Management Protocol (ISAKMP)


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for Security for VPNs with IPsec

Table 3 lists the features in the modules and provides links to specific configuration information.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 3 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 3 Feature Information for Configuring Security for IPsec VPNs 

Feature Name
Software Releases
Feature Configuration Information

Advanced Encryption Standard (AES)

Cisco IOS XE Release 2.1

This feature adds support for the new encryption standard AES, which is a privacy transform for IPsec and IKE and has been developed to replace DES.

The following sections provide information about this feature:

Supported Standards

Defining Transform Sets

The following commands were modified by this feature: crypto ipsec transform-set, encryption (IKE policy), show crypto ipsec transform-set, show crypto isakmp policy

IKE Shared Secret Using AAA Server

Cisco IOS XE Release 2.1

This feature was implemented on Cisco ASR 1000 Series Routers.


Glossary

anti-replay—Security service where the receiver can reject old or duplicate packets to protect itself against replay attacks. IPsec provides this optional service by use of a sequence number combined with the use of data authentication. Cisco IOS XE IPsec provides this service whenever it provides the data authentication service, except for manually established SAs (that is, SAs established by configuration and not by IKE).

data authentication—Verification of the integrity and origin of the data.

Data authentication can refer either to integrity alone or to both of these concepts (although data origin authentication is dependent upon data integrity).

data confidentialitySecurity service in which the protected data cannot be observed.

data flowGrouping of traffic, identified by a combination of source address or mask; destination address or mask; IP next protocol field, and source and destination ports, where the protocol and port fields can have the values of any. IPsec protection is applied to data flows.

peerIn the context of this module, a "peer" is a router or other device that participates in IPsec.

PFS—perfect forward secrecy. Cryptographic characteristic associated with a derived shared secret value. With PFS, if one key is compromised, previous and subsequent keys are not compromised, because subsequent keys are not derived from previous keys.

SA—security association. Description of how two or more entities use security services in the context of a particular security protocol (AH or ESP) to communicate securely on behalf of a particular data flow. The transform and the shared secret keys are used for protecting the traffic.

SPI—security parameter index. A number which, together with a destination IP address and security protocol, uniquely identifies a particular security association. Without IKE, the SPI is manually specified for each security association.

transformList of operations performed on a dataflow to provide data authentication, data confidentiality, and data compression. For example, one transform is the ESP protocol with the HMAC-MD5 authentication algorithm; another transform is the AH protocol with the 56-bit DES encryption algorithm and the ESP protocol with the HMAC-SHA authentication algorithm.

tunnelIn the context of this module, "tunnel" is a secure communication path between two peers, such as two routers. It does not refer to using IPsec in tunnel mode.