This documentation has been moved
NSF/SSO—Any Transport over MPLS and AToM Graceful Restart
Downloads: This chapterpdf (PDF - 179.0KB) The complete bookPDF (PDF - 6.78MB) | Feedback

NSF/SSO—Any Transport over MPLS and AToM Graceful Restart

Table Of Contents

NSF/SSO—Any Transport over MPLS and AToM Graceful Restart

Finding Feature Information

Contents

Prerequisites for AToM NSF

Restrictions for AToM NSF

Information About AToM NSF

How AToM NSF Works

AToM Information Checkpointing

Checkpointing Troubleshooting Tips for AToM NSF

NSF/SSO Support for Ethernet to Ethernet VLAN Interworking

ISSU Support for AToM NSF

How to Configure AToM NSF

Configuring MPLS LDP Graceful Restart

Configuration Examples for AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for AToM NSF


NSF/SSO—Any Transport over MPLS and AToM Graceful Restart


First Published: August 11, 2004
Last Updated: June 25, 2009

The NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature allows Any Transport over MPLS (AToM) to use Cisco nonstop forwarding (NSF), stateful switchover (SSO), and Graceful Restart (GR) to allow a Route Processor (RP) to recover from a disruption in control plane service without losing its Multiprotocol Label Switching (MPLS) forwarding state.

NSF with SSO is effective at increasing availability of network services. Cisco NSF with SSO provides continuous packet forwarding, even during a network processor hardware or software failure. In a redundant system, the secondary processor recovers control plane service during a critical failure in the primary processor. SSO synchronizes the network state information between the primary and the secondary processor.


Note In this document, the NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature is referred to as AToM NSF for brevity.


In Cisco IOS XE software, AToM NSF supports the following attachment circuits:

ATM

Ethernet to Ethernet VLAN interworking

Finding Feature Information

For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for AToM NSF" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS XE software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for AToM NSF

Restrictions for AToM NSF

Information About AToM NSF

How to Configure AToM NSF

Configuration Examples for AToM NSF

Additional References

Feature Information for AToM NSF

Prerequisites for AToM NSF

Before you can configure AToM NSF, make sure the following tasks have been completed:

AToM virtual circuits (VCs) have been configured on the router. See the Any Transport over MPLS for information on configuring AToM. For configuring L2VPN Interworking, see the L2VPN Interworking feature module.

SSO has been configured on the RPs. See the Stateful Switchover feature module for configuration information.

Nonstop forwarding has been configured on the routers. You must enable nonstop forwarding on the routing protocols running between the P routers, PE routers, and CE routers. The routing protocols are the following:

Open Shortest Path First (OSPF),

Intermediate System-to-Intermediate System (IS-IS), and

Border Gateway Protocol (BGP).

See the Cisco Nonstop Forwarding feature module for configuration information.

AToM NSF requires that neighbor networking devices be able to perform AToM GR.

Restrictions for AToM NSF

AToM NSF cannot be configured on label-controlled ATM (LC-ATM) interfaces.

AToM NSF supports AToM Layer 2 Virtual Private Network (L2VPN) Interworking. However, Layer 2 Tunnel Protocol Version 3 (L2TPv3) Interworking is not supported.

AToM NSF interoperates with Layer 2 local switching. However, AToM NSF has no effect on interfaces configured for local switching.

To allow distributed Cisco Express Forwarding to work on the interfaces, disable fair queueing on serial interfaces.

Information About AToM NSF

How AToM NSF Works

AToM Information Checkpointing

Checkpointing Troubleshooting Tips for AToM NSF

NSF/SSO Support for Ethernet to Ethernet VLAN Interworking

ISSU Support for AToM NSF

How AToM NSF Works

AToM NSF improves the availability of a service provider's network that uses AToM to provide Layer 2 VPN services to its customers. HA provides the ability to detect failures and handle them with minimal disruption to the service being provided. AToM NSF is achieved by SSO and NSF mechanisms. A standby RP provides control-plane redundancy. The control plane state and data plane provisioning information for the attachment circuits (ACs) and AToM pseudowires (PWs) are checkpointed to the standby RP to provide NSF for AToM L2VPNs.

AToM Information Checkpointing

Checkpointing is a function that copies state information from the active RP to the backup RP, thereby ensuring that the backup RP has the latest information. If the active RP fails, the backup RP can take over.

For the AToM NSF feature, the checkpointing function copies the active RP's information bindings to the backup RP. The active RP sends updates to the backup RP when information is modified.

To display checkpointing data, issue the show acircuit checkpoint command on the active and backup RPs. The active and backup RPs have identical copies of the information.

Checkpointing Troubleshooting Tips for AToM NSF

To help troubleshoot checkpointing errors, use the following commands:

Use the debug acircuit checkpoint command to enable checkpointing debug messages for ACs.

Use the debug mpls l2transport checkpoint command to enable checkpointing debug messages for AToM.

Use the show acircuit checkpoint command to display the AC checkpoint information.

Use the show mpls l2transport checkpoint command to display whether checkpointing is allowed, how many AToM VCs were bulk-synchronized (on the active RP), and how many AToM VCs have checkpoint data (on the standby RP).

Use the show mpls l2transport vc detail command to display details of VC checkpointed information.

NSF/SSO Support for Ethernet to Ethernet VLAN Interworking

The NSF/SS0—Ethernet to Ethernet VLAN Interworking features enables SSO and NSF capabilities for Ethernet to VLAN attachment circuits. Changes in the learned MAC address for interworking are reflected on the standby RP so that identical values exist on the active and standby RPs.

ISSU Support for AToM NSF

AToM NSF supports In Service Software Upgrade (ISSU) capability. Virtual Private LAN Services (VPLS) NSF/SSO and HA with ISSU work together to enable upgrades or downgrades of a Cisco IOS XE image without control and data plane outages. With ISSU, all message data structures that are used for checkpointing and exchanges between the active RP and standby RP are versioned.

How to Configure AToM NSF

There is no AToM-specific configuration for AToM NSF. Before you configure AToM NSF, you need to configure MPLS LDP Graceful Restart. You enable MPLS LDP Graceful Restart to assist a neighboring router configured with AToM NSF to maintain its forwarding state while the LDP session is disrupted. See the LDP Graceful Restart document for information about how MPLS LDP Graceful Restart works and how you can customize it for your network.

MPLS LDP Graceful Restart is enabled globally. When you enable MPLS LDP Graceful Restart, it has no effect on existing LDP sessions. MPLS LDP Graceful Restart is enabled for new sessions that are established after the feature has been globally enabled.

This section contains the following task:

Configuring MPLS LDP Graceful Restart (required)

Configuring MPLS LDP Graceful Restart

SUMMARY STEPS

1. enable

2. configure terminal

3. ip cef distributed

4. mpls ldp graceful-restart

5. interface type slot/subslot/port[.subinterface-number]

6. mpls ip

7. mpls label protocol ldp

8. exit

9. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip cef distributed

Example:

Router(config)# ip cef distributed

Enables distributed Cisco Express Forwarding.


Note In Cisco ASR 1000 Series Aggregation Services Routers, the distributed keyword is mandatory.


Step 4 

mpls ldp graceful-restart

Example:
Router (config)# mpls ldp graceful-restart

Enables the router to protect the LDP bindings and MPLS forwarding state during a disruption in service.

Step 5 

interface type slot/subslot/port[.subinterface-number]

Example:
Router(config)# interface pos 0/3/0 

Specifies an interface and enters interface configuration mode.

Step 6 

mpls ip

Example:

Router(config-if)# mpls ip

Configures MPLS hop-by-hop forwarding for an interface.

Step 7 

mpls label protocol ldp

Example:

Router(config-if)# mpls label protocol ldp

Configures the use of LDP for an interface.

You can also issue the mpls label protocol ldp command in global configuration mode, which enables LDP on all interfaces configured for MPLS.

Step 8 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 9 

exit

Example:

Router(config)# exit

Exits global configuration mode and returns to privileged EXEC mode.


Configuration Examples for AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

The following example shows how to configure AToM NSF on two PE routers:

PE1

ip cef distributed
!
redundancy
mode sso
!
boot system flash disk2:rsp-pv-mz
!
mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-labels
!
pseudowire-class atom-eth
 encapsulation mpls
 interworking ethernet
!
interface Loopback0
 ip address 10.8.8.8 255.255.255.255
!
interface FastEthernet1/1/0
 xconnect 10.9.9.9 123 encap mpls pw-class atom-eth

interface POS0/1/0
 ip address 10.1.1.1 255.255.255.0
 mpls ip
 mpls label protocol ldp
 clock source internal
 crc 32
!
interface Loopback0
 ip address 10.8.8.8 255.255.255.255
 no shutdown
!
router ospf 10
 nsf
 network 10.8.8.8 0.0.0.0 area 0
 network 10.19.1.1 0.0.0.0 area 0

PE2

ip cef distributed
!
redundancy
mode sso
!
boot system flash disk2:rsp-pv-mz

mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-labels
!
pseudowire-class atom-eth
 encapsulation mpls
 interworking eth
!
interface Loopback0
 ip address 10.9.9.9 255.255.255.255
!
interface FastEthernet0/3/0
 ip route-cache cef
!
interface FastEthernet0/3/0.3
 encapsulation dot1Q 10
 xconnect 10.8.8.8 123 encap mpls pw-class atom-eth

interface POS1/0/0
 ip address 10.1.1.2 255.255.255.0
 mpls ip
 mpls label protocol ldp
 clock source internal
 crc 32
!
interface Loopback0
 ip address 10.9.9.9 255.255.255.255
!
router ospf 10
 nsf
 network 10.9.9.9 0.0.0.0 area 0
 network 10.1.1.2 0.0.0.0 area 0

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Stateful switchover

Stateful Switchover

MPLS Label Distribution Protocol

MPLS Label Distribution Protocol (LDP)

Cisco nonstop forwarding

Cisco Nonstop Forwarding

Any Transport over MPLS

Any Transport over MPLS

L2VPN Interworking configuration

L2VPN Interworking

MPLS AToM and LDP commands

Cisco IOS Multiprotocol Label Switching Command Reference

High availability commands

Cisco IOS High Availability Command Reference


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

MPLS Label Distribution Protocol MIB Version 8 Upgrade

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 3036

LDP Specification

RFC 3478

Graceful Restart Mechanism for Label Distribution


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for AToM NSF

Table 1 lists the features in this module and provides links to specific configuration information.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS XE software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS XE software release that introduced support for a given feature in a given Cisco IOS XE software release train. Unless noted otherwise, subsequent releases of that Cisco IOS XE software release train also support that feature.


Table 1 Feature Information for AToM NSF Any Transport over MPLS and AToM Graceful Restart

Feature Name
Releases
Feature Information

NSF/SSO—AToM ATM Attachment Circuit

Cisco IOS XE Release 2.3

This feature provides support for AToM NSF/SSO support for ATM over MPLS (ATMoMPLS), which allows ATMoMPLS to use Cisco nonstop forwarding (NSF), stateful switchover (SSO), and Graceful Restart (GR) to allow a Route Processor (RP) to recover from a disruption in control plane service without losing its Multiprotocol Label Switching (MPLS) forwarding state.

In Cisco IOS XE Release 2.3, this feature was implemented on the Cisco ASR 1000 Series Aggregation Services Routers.

The following sections provide information about this feature:

How AToM NSF Works

AToM Information Checkpointing

Configuring MPLS LDP Graceful Restart

The following commands were introduced or modified: debug acircuit checkpoint, debug mpls l2transport checkpoint, show acircuit checkpoint, show mpls l2transport checkpoint, show mpls l2transport vc.

ISSU—AToM ATM Attachment Circuit

Cisco IOS XE Release 2.3

This feature supports In Service Software Upgrade (ISSU) capability. Virtual Private LAN Services (VPLS) NSF/SSO and HA with ISSU work together to enable upgrades or downgrades of a Cisco IOS XE image without control and data plane outages. With ISSU, all message data structures that are used for checkpointing and exchanges between the active RP and standby RP are versioned.

In Cisco IOS XE Release 2.3, this feature was implemented on the Cisco ASR 1000 Series Aggregation Services Routers.

The following sections provide information about this feature:

ISSU Support for AToM NSF

Configuring MPLS LDP Graceful Restart

No commands were introduced or modified for this feature.

NSF/SSO—Ethernet to Ethernet VLAN Interworking

Cisco IOS XE Release 2.4

The NSF/SS0—Ethernet to Ethernet VLAN Interworking features enables stateful switchover (SSO) and nonstop forwarding (NSF) capabilities for Ethernet to VLAN attachment circuits. Changes in the learned MAC address for interworking are reflected on the standby RP so that identical values exist on the Active and Standby RPs.

In Cisco IOS XE Release 2.4, this feature was introduced on the Cisco ASR 1000 Series Aggregation Routers.

The following sections provide information about this feature:

How AToM NSF Works

AToM Information Checkpointing

NSF/SSO Support for Ethernet to Ethernet VLAN Interworking

Example: Ethernet to VLAN Interworking with AToM NSF

No commands were introduced or modified for this feature.