This documentation has been moved
MPLS - Multilink PPP Support
Downloads: This chapterpdf (PDF - 425.0KB) The complete bookPDF (PDF - 6.78MB) | Feedback

MPLS—Multilink PPP Support

Table Of Contents

MPLS—Multilink PPP Support

Finding Feature Information

Contents

Prerequisites for MPLS—Multilink PPP Support

Information About MPLS—Multilink PPP Support

MPLS Layer 3 Virtual Private Network Features Supported for Multilink PPP

MPLS Quality of Service Features Supported for Multilink PPP

MPLS—Multilink PPP Support and PE-to-CE Links

MPLS—Multilink PPP Support and Core Links

MPLS—Multilink PPP Support in a CSC Network

MPLS—Multilink PPP Support in an Interautonomous System

How to Configure MPLS—Multilink PPP Support

Enabling Cisco Express Forwarding Switching

Prerequisites

Creating a Multilink Bundle for MPLS—Multilink PPP Support

Assigning an Interface to a Multilink Bundle for MPLS—Multilink PPP Support

Disabling PPP Multilink Fragmentation

Verifying the Multilink PPP Configuration

Configuration Examples for MPLS—Multilink PPP Support

Example: Sample Multilink PPP Configuration on an MPLS CSC PE Router

Example: Enabling Cisco Express Forwarding

Example: Creating a Multilink Bundle for MPLS—Multilink PPP Support

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for MPLS—Multilink PPP Support

Glossary


MPLS—Multilink PPP Support


First Published: December 18, 2003
Last Updated: May 4, 2009

The MPLS—Multilink PPP Support feature ensures that MPLS Layer 3 Virtual Private Networks (VPNs) with quality of service (QoS) can be enabled for bundled links. This feature supports Multiprotocol Label Switching (MPLS) over Multilink PPP (MLP) links in the edge (provider edge [PE]-to-customer edge [CE]) or in the MPLS core (PE-to-PE and PE-to-provider router [P]).

Service providers that use relatively low-speed links can use MLP to spread traffic across them in their MPLS networks. Link fragmentation and interleaving (LFI) should be deployed in the CE-to-PE link for efficiency, where traffic uses a lower link bandwidth (less than 768 kbps).

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for MPLS—Multilink PPP Support" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for MPLS—Multilink PPP Support

Information About MPLS—Multilink PPP Support

How to Configure MPLS—Multilink PPP Support

Configuration Examples for MPLS—Multilink PPP Support

Additional References

Feature Information for MPLS—Multilink PPP Support

Glossary

Prerequisites for MPLS—Multilink PPP Support

Cisco Express Forwarding enabled

MPLS enabled on PE and P routers

Cisco Express Forwarding switching enabled on the interface with the ip route-cache cef command

Information About MPLS—Multilink PPP Support

MPLS Layer 3 Virtual Private Network Features Supported for Multilink PPP

MPLS—Multilink PPP Support and PE-to-CE Links

MPLS—Multilink PPP Support and Core Links

MPLS—Multilink PPP Support in a CSC Network

MPLS—Multilink PPP Support in an Interautonomous System

MPLS Layer 3 Virtual Private Network Features Supported for Multilink PPP

Table 1 lists MPLS Layer 3 VPN features supported for MLP and indicates if the feature is supported on CE-to-PE links, PE-to-P links, and Carrier Supporting Carrier (CSC) CE-to-PE links.

Table 1 MPLS Layer 3 VPN Features Supported for MLP 

MPLS L3 VPN Feature
CE-to-PE Links
PE-to-P Links
CSC CE-to-PE Links

Static routes

Supported

1

External Border Gateway Protocol (eBGP)

Supported

Not applicable to this configuration

Supported

Intermediate System-to-Intermediate System (IS-IS)

Supported

Open Shortest Path first (OSPF)

Supported

Supported

Enhanced Interior Gateway Routing Protocol (EIGRP)

Supported

Supported

Interprovider (Inter-AS) VPNs (with Label Distribution Protocol [LDP])

Not applicable to this configuration

Supported (MLP between Autonomous System Border routers {ASBRs])

Not applicable to this configuration

Inter-AS VPNs with IPv4 Label Distribution

Not applicable to this configuration

Supported (MLP between ASBRs]

Not applicable to this configuration

CSC VPNs (with LDP)

Not applicable to this configuration

Supported

CSC VPNs with IPv4 label distribution

Supported

Not applicable to this configuration

Supported

External and internal BGP (eiBGP) Multipath

Not applicable to this configuration

Internal BGP (iBGP) Multipath

Not applicable to this configuration

Not applicable to this configuration

eBGP Multipath

1 An em dash (—) indicates that the configuration is not supported.


MPLS Quality of Service Features Supported for Multilink PPP

Table 2 lists the MPLS QoS features supported for MLP and indicates if the feature is supported on CE-to-PE links, PE-to-P links, and CSC-CE-to-CSC-PE links.

Table 2 MPLS QoS Features Supported for MLP 

MPLS QoS Feature
CE-to-PE Links
PE-to-P Links
CSC-CE-to-PE Links

Default copy of IP Precedence to EXP bits and the reverse

Supported

1

Set MPLS EXP bits using the modular QoS Command-Line Interface (MQC)

Supported

Supported

Supported

Matching on MPLS EXP using MQC

Supported

Supported

Supported

Low Latency Queueing (LLQ)/
Class-Based Weighted Fair Queueing (CBWFQ) support

Supported

Supported

Supported

Weighted Random Early Detection (WRED) based on EXP bits using MQC

Supported

Supported

Supported

Policer with EXP bit-marking using MQC-3 action

Supported

Supported

Supported

Support for EXP bits in MPLS accounting

Supported

Supported

Supported

1 An em dash (—) indicates that the configuration is not supported.


MPLS—Multilink PPP Support and PE-to-CE Links

Figure 1 shows a typical MPLS network in which the PE router is responsible for label imposition (at ingress) and disposition (at egress) of the MPLS traffic.

In this topology, MLP is deployed on the PE-to-CE links. The VPN routing and forwarding instance (VRF) interface is in a multilink bundle. There is no MPLS interaction with MLP; all packets coming into the MLP bundle are IP packets.

Figure 1 MLP and Traditional PE-to-CE Links

The PE-to-CE routing protocols that are supported for the MPLS—Multilink PPP Support feature are eBGP, OSPF, and EIGRP. Static routes are also supported between the CE and PE routers.

QoS features that are supported for the MPLS—Multilink PPP Support feature on CE-to-PE links are LFI, header compression, policing, marking, and classification.

MPLS—Multilink PPP Support and Core Links

Figure 2 shows a sample topology in which MPLS is deployed over MLP on PE-to-P and P-to-P links. Enabling MPLS on MLP for PE-to-P links is similar to enabling MPLS on MLP for P-to-P links.

Figure 2 MLP on PE-to-P and P-to-P Links

You employ MLP in the PE-to-P or P-to-P links primarily so that you can reduce the number of Interior Gateway Protocol (IGP) adjacencies and facilitate the load sharing of traffic.

In addition to requiring MLP on the PE-to-P links, the MPLS—Multilink PPP Support feature requires the configuration of an IGP routing protocol and LDP.

MPLS—Multilink PPP Support in a CSC Network

Figure 3 shows a typical MPLS VPN CSC network where MLP is configured on the CSC-CE-to-CSC-PE links.

Figure 3 MLP on CSC-CE-to-CSC-PE Links with MPLS VPN Carrier Supporting Carrier

The MPLS—Multilink PPP Support feature supports MLP between CSC-CE and CSC-PE links with LDP or with EBGP IPv4 label distribution. This feature also supports LFI for an MPLS VPN CSC configuration. Figure 4 shows all MLP links that this feature supports for CSC configurations.

Figure 4 MLP Supported Links with MPLS VPN Carrier Supporting Carrier

MPLS—Multilink PPP Support in an Interautonomous System

Figure 5 shows a typical MPLS VPN interautonomous system (Inter-AS) network where MLP is configured on the PE-to-CE links.

Figure 5 MLP on ASBR-to-PE Links in an MPLS VPN Inter-AS Network

The MPLS—Multilink PPP Support feature supports MLP between ASBR links for Inter-AS VPNs with LDP and with eBGP IPv4 label distribution.

How to Configure MPLS—Multilink PPP Support

Enabling Cisco Express Forwarding Switching (required)

Creating a Multilink Bundle for MPLS—Multilink PPP Support (required)

Assigning an Interface to a Multilink Bundle for MPLS—Multilink PPP Support (required)

Disabling PPP Multilink Fragmentation (optional)

Verifying the Multilink PPP Configuration (optional)

Service providers that use relatively low-speed links can use MLP to spread traffic across them in their MPLS networks. LFI should be deployed in the CE-to-PE link for efficiency, where traffic uses lower link bandwidth (less than 768 kbps). The MPLS—Multilink PPP Support feature can reduce the number of IGP adjacencies and facilitate load sharing of traffic.

The tasks in this section can be performed on CE-to-PE links, PE-to-P links, P-to-P links, and CSC CSC-CE-to-CSC-PE links.

Enabling Cisco Express Forwarding Switching

Perform the following task to enable Cisco Express Forwarding switching. Cisco Express Forwarding is required for the forwarding of MLP traffic.

Prerequisites

Multilink PPP requires the configuration of standard Cisco Express Forwarding. To find out if Cisco Express Forwarding is enabled on your router, enter the show ip cef command. If Cisco Express Forwarding is enabled, you receive output that looks like the following:

Router# show ip cef 

Prefix              Next Hop            Interface
10.2.61.8/24        192.168.100.1       FastEthernet1/0/0
                    192.168.101.1       FastEthernet6/1/0

If Cisco Express Forwarding is not enabled on your platform, the output for the show ip cef command looks like the following:

Router# show ip cef

%CEF not running

SUMMARY STEPS

1. enable

2. configure terminal

3. ip cef

4. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip cef

Example:

Router(config)# ip cef

Enables standard Cisco Express Forwarding switching.

Step 4 

exit

Example:

Router(config)# exit

Exits to privileged EXEC mode.

Creating a Multilink Bundle for MPLS—Multilink PPP Support

Perform this task to create a multilink bundle for the MPLS—Multilink PPP Support feature. This can reduce the number of IGP adjacencies and facilitate load sharing of traffic.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface multilink group-number

4. ip address address mask [secondary]

5. encapsulation encapsulation-type

6. ppp multilink

7. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface multilink group-number

Example:

Router(config)# interface multilink 1

Creates a multilink bundle or enters multilink interface configuration mode.

The group-number argument is the number of the multilink bundle (a nonzero number).

Step 4 

ip address address mask [secondary]

Example:

Router(config-if)# ip address 10.0.0.0 255.255.0.0

Sets a primary or secondary IP address for an interface.

The address argument is the IP address.

The mask argument is the mask for the associated IP subnet.

The secondary keyword specifies that the configured address is a secondary IP address. If this keyword is omitted, the configured address is the primary IP address.

This command is used to assign an IP address to the multilink interface.

Step 5 

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp

Sets the encapsulation method used by the interface.

The encapsulation-type argument specifies the encapsulation type. The keyword ppp enables PPP encapsulation.

Step 6 

ppp multilink

Example:

Router(config-if)# ppp multilink

Enables MLP on an interface.

Step 7 

end

Example:

Router(config-if)# end

Exits to privileged EXEC mode.

Assigning an Interface to a Multilink Bundle for MPLS—Multilink PPP Support

SUMMARY STEPS

1. enable

2. configure terminal

3. controller {t1 | e1} slot/port

4. channel-group channel-number timeslots range

5. exit

6. interface serial slot/subslot/port[.subinterface]

7. ip route-cache [cef |distributed]

8. no ip address

9. keepalive [period [retries]]

10. encapsulation encapsulation-type

11. multilink-group group-number

12. ppp multilink

13. ppp authentication chap

14. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

controller {t1 | e1} slot/port

Example:

Router# controller t1 1/3

Configures a T1 or E1 controller and enters controller configuration mode.

The t1 keyword indicates a T1 line card.

The e1 keyword indicates an E1 line card.

The slot/port arguments are the backplane slot number and port number on the interface. Refer to your hardware installation manual for the specific slot numbers and port numbers.

Step 4 

channel-group channel-number timeslots range

Example:

Router(config-controller)# channel-group 1 timeslots 1

Defines the time slots that belong to each T1 or E1 circuit.

The channel-number argument is the channel-group number. When a T1 data line is configured, channel-group numbers can be values from 0 to 23. When an E1 data line is configured, channel-group numbers can be values from 0 to 30.

The timeslots range keyword-argument pair specifies one or more time slots or ranges of time slots belonging to the channel group. The first time slot is numbered 1. For a T1 controller, the time slot range is from 1 to 24. For an E1 controller, the time slot range is from 1 to 31. You can specify a time slot range (for example, 1-29), individual time slots separated by commas (for example 1, 3, 5), or a combination of the two (for example 1-14, 15, 17-31).

Step 5 

exit

Example:

Router(config-controller)# exit

Exits to global configuration mode.

Step 6 

interface serial slot/subslot/port[.subinterface]

Example:

Router(config)# interface serial 1/0/0:1

Configures a serial interface and enters interface configuration mode.

Step 7 

ip route-cache [cef]

Example:

Router(confg-if)# ip route-cache cef

Controls the use of switching methods for forwarding IP packets

The cef keyword enables Cisco Express Forwarding operation on an interface after Cisco Express Forwarding operation was disabled.

Step 8 

no ip address

Example:

Router(config-if)# no ip address

Removes any specified IP address.

Step 9 

keepalive [period [retries]]

Example:

Router(config-if)# keepalive

Enables keepalive packets and specifies the number of times that the Cisco IOS XE software tries to send keepalive packets without a response before bringing down the interface or before bringing the tunnel protocol down for a specific interface.

The period argument is an integer value, in seconds, greater than 0. The default is 10.

The retries argument specifies the number of times that the device will continue to send keepalive packets without response before bringing the interface down. Enter an integer value greater than 1 and less than 255. If you do not enter a value, the value that was previously set is used; if no value was specified previously, the default of 5 is used.

If you are using this command with a tunnel interface, the command specifies the number of times that the device will continue to send keepalive packets without response before bringing the tunnel interface protocol down.

Step 10 

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp

Sets the encapsulation method used by the interface.

The encapsulation-type argument specifies the encapsulation type. The keyword ppp enables PPP encapsulation.

Step 11 

multilink-group group-number

Example:

Router(config-if)# multilink-group 1

Designates an interface as part of a multilink leased line bundle.

The group-number argument is the number of the multilink bundle (a nonzero number).

Step 12 

ppp multilink

Example:

Router(config-if)# ppp multilink

Enables MLP on an interface.

Step 13 

ppp authentication chap

Example:

Router(config-if)# ppp authentication chap

(Optional) Enables Challenge Handshake Authentication Protocol (CHAP) authentication on a serial interface.

Step 14 

end

Example:

Router(config-if)# end

Exits to privileged EXEC mode.

Disabling PPP Multilink Fragmentation

Perform this task to disable PPP multilink fragmentation. PPP multilink fragmentation is enabled by default.

Enabling fragmentation reduces the delay latency among bundle links, but adds some load to the CPU. Disabling fragmentation might produce better throughput.

If your data traffic is consistently of a similar size, we recommend disabling fragmentation. In this case, the benefits of fragmentation can be outweighed by the added load on the CPU.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ppp multilink fragmentation disable

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface serial 1/0/0

Configures an interface type and enters interface configuration mode.

The type argument indicates the type of interface to be configured.

The number argument specifies the port, connector, or interface card number. The numbers are assigned at the factory at the time of installation or when the interface is added to a system, and can be displayed with the show interfaces command.

Step 4 

ppp multilink fragmentation disable

Example:

Router(config-if)# ppp multilink fragmentation disable

Disables packet fragmentation.

Step 5 

end

Example:

Router(config-if)# end

Exits to privileged EXEC mode.

Verifying the Multilink PPP Configuration

SUMMARY STEPS

1. enable

2. show ip interface brief

3. show ppp multilink

4. show ppp multilink interface interface-bundle

5. show interface interface-name interface-number

6. show mpls forwarding-table

7. exit

DETAILED STEPS


Step 1 enable

Use this command to enable privileged EXEC mode. Enter your password if prompted. For example:

Router> enable
Router#

Step 2 show ip interface brief

Use this command to verify logical and physical MLP interfaces. For example:

Router# show ip interface brief

Locolrface                  IP-Address      OK? Method Status                Prot
FastEthernet1/0/0         10.3.62.106      YES NVRAM  up                    up

FastEthernet0/0/1          unassigned      YES NVRAM  administratively down down
FastEthernet0/0/0          unassigned      YES NVRAM  administratively down down
FastEthernet0/0/1          unassigned      YES NVRAM  administratively down down
FastEthernet0/0/2          unassigned      YES NVRAM  administratively down down
FastEthernet0/1/0          unassigned      YES NVRAM  administratively down down
FastEthernet0/1/1          unassigned      YES NVRAM  administratively down down
FastEthernet0/1/2          unassigned      YES NVRAM  administratively down down
FastEthernet1/2/0          unassigned      YES NVRAM  administratively down down
FastEthernet1/0/1          unassigned      YES NVRAM  administratively down down
FastEthernet1/1/0          unassigned      YES NVRAM  administratively down down
FastEthernet1/1/1          unassigned      YES NVRAM  administratively down down
FastEthernet1/1/2          unassigned      YES NVRAM  administratively down down
Serial1/1/0:1              unassigned      YES NVRAM  administratively down down
Serial1/1/0:2              unassigned      YES NVRAM  administratively down down
Serial1/1/1:1              unassigned      YES NVRAM  up                    up

Serial1/1/1:2              unassigned      YES NVRAM  up                    down
Serial1/1/3:1              unassigned      YES NVRAM  up                    up

Serial1/1/3:2              unassigned      YES NVRAM  up                    up

Multilink6                 10.30.0.2       YES NVRAM  up                    up

Multilink8                 unassigned      YES NVRAM  administratively down down
Multilink10                10.34.0.2       YES NVRAM  up                    up

Loopback0                  10.0.0.1        YES NVRAM  up                    up

Step 3 show ppp multilink

Use this command to verify that you have created a multilink bundle. For example:

Router# show ppp multilink 

Multilink1, bundle name is group 1
 Bundle is Distributed
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x0/0x0 rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 4 active, 0 inactive (max no set, min not set)
 Serial1/0/0/:1
 Serial1/0/0/:2
 Serial1/0/0/:3
 Serial1/0/0/:4

Step 4 show ppp multilink interface interface-bundle

Use this command to display information about a specific MLP interface. For example:

Router# show ppp multilink interface multilink6

Multilink6, bundle name is router
  Bundle up for 00:42:46, 1/255 load
  Receive buffer limit 24384 bytes, frag timeout 1524 ms
  Bundle is Distributed
    0/0 fragments/bytes in reassembly list
    1 lost fragments, 48 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x4D7 received sequence, 0x0 sent sequence
  Member links: 2 active, 0 inactive (max not set, min not set)
    Se1/1/3:1, since 00:42:46, 240 weight, 232 frag size
    Se1/1/3:2, since 00:42:46, 240 weight, 232 frag size


Step 5 show interface interface-name interface-number

Use this command to display information about serial interfaces in your configuration. For example:

Router# show interface serial 1/1/3:1

Serial1/1/3:1 is up, line protocol is up
  Hardware is Multichannel T1
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open, crc 16, Data non-inverted
  Last input 00:00:01, output 00:00:01, output hang never
  Last clearing of "show interface" counters 00:47:13
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     722 packets input, 54323 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     697 packets output, 51888 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions no alarm present
  Timeslot(s) Used:1, subrate: 64Kb/s, transmit delay is 0 flags
  Transmit queue length 25

Router# show interface serial 1/1/3:2

Serial1/1/3:2 is up, line protocol is up
  Hardware is Multichannel T1
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open, crc 16, Data non-inverted
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters 00:47:16
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     725 packets input, 54618 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     693 packets output, 53180 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions no alarm present
  Timeslot(s) Used:2, subrate: 64Kb/s, transmit delay is 0 flags
  Transmit queue length 26

You can also use the show interface command to display information about the multilink interface:

Router# show interface multilink6

Multilink6 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 10.30.0.2/8
  MTU 1500 bytes, BW 128 Kbit, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open
  Open: CDPCP, IPCP, TAGCP, loopback not set
  DTR is pulsed for 2 seconds on reset
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 00:48:43
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
     1340 packets input, 102245 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1283 packets output, 101350 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

Step 6 show mpls forwarding-table

Use this command to display contents of the MPLS Label Forwarding Information Base (LFIB) and look for information on multilink interfaces associated with a point2point next hop. For example:

Router# show mpls forwarding-table

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Untagged    10.30.0.1/32      0          Mu6        point2point
17     Pop tag     10.0.0.3/32       0          Mu6        point2point
18     Untagged    10.0.0.9/32[V]    0          Mu10       point2point
19     Untagged    10.0.0.11/32[V]   6890       Mu10       point2point
20     Untagged    10.32.0.0/8[V]    530        Mu10       point2point
21     Aggregate   10.34.0.0/8[V]    0
22     Untagged    10.34.0.1/32[V]   0          Mu10       point2point

Use the show ip bgp vpnv4 command to display VPN address information from the Border Gateway Protocol (BGP) table:

Router# show ip bgp vpnv4 all summary

BGP router identifier 10.0.0.1, local AS number 100
BGP table version is 21, main routing table version 21
10 network entries using 1210 bytes of memory
10 path entries using 640 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1994 total bytes of memory
BGP activity 10/0 prefixes, 10/0 paths, scan interval 5 secs

10.0.0.3  4 100 MsgRc52 MsgSe52  TblV21  0  0 00:46:35 State/P5xRcd

Step 7 exit

Use this command to exit to user EXEC mode. For example:

Router# exit
Router>


Configuration Examples for MPLS—Multilink PPP Support

Example: Sample Multilink PPP Configuration on an MPLS CSC PE Router

Example: Enabling Cisco Express Forwarding

Example: Creating a Multilink Bundle for MPLS—Multilink PPP Support

Example: Sample Multilink PPP Configuration on an MPLS CSC PE Router

The following is a sample configuration for an MPLS CSC PE router. The configuration of MLP on an interface is the same for PE-to-CE links, PE-to-P links, and P-to-P links. An eBGP session is configured between the PE and CE routers.

Router# show running-config interface Serial1/0/0:1

Building configuration...

!
mpls label protocol ldp
ip cef
ip vrf vpn2
 rd 200:1
 route-target export 200:1
 route-target import 200:1
!
controller T1 1/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1
 channel-group 2 timeslots 2
 no yellow generation
 no yellow detection
!
interface Serial1/0:1
 no ip address
 encapsulation ppp
 tx-ring-limit 26
 ppp multilink
 ppp multilink group 1
!
interface Serial1/0:2
 no ip address
 encapsulation ppp
 tx-ring-limit 26
 ppp multilink
 ppp multilink group 1
!
interface Multilink1
 ip vrf forwarding vpn2
 ip address 10.35.0.2 255.0.0.0
 no peer neighbor-route
 load-interval 30
 ppp multilink
 ppp multilink interleave
 ppp multilink group 1
!
!
router ospf 200
 log-adjacency-changes
 auto-cost reference-bandwidth 1000
 redistribute connected subnets
 passive-interface Multilink1
 network 10.0.0.7 0.0.0.0 area 200
 network 10.31.0.0 0.255.255.255 area 200
!
!
 router bgp 200
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 10.0.0.11 remote-as 200
 neighbor 10.0.0.11 update-source Loopback0
 !
 address-family vpnv4
 neighbor 10.0.0.11 activate
 neighbor 10.0.0.11 send-community extended
 bgp scan-time import 5
 exit-address-family
 !
 address-family ipv4 vrf vpn2
 redistribute connected
 neighbor 10.35.0.1 remote-as 300
 neighbor 10.35.0.1 activate
 neighbor 10.35.0.1 as-override
 neighbor 10.35.0.1 advertisement-interval 5
 no auto-summary
 no synchronization
 exit-address-family

Example: Enabling Cisco Express Forwarding

The following example shows how to enable Cisco Express Forwarding for MLP configurations:

Router> enable
Router# configure terminal 
Router(config)# ip cef 

Example: Creating a Multilink Bundle for MPLS—Multilink PPP Support

The following example shows how to create a multilink bundle for the MPLS—Multilink PPP Support feature:

Router(config)# interface multilink 1
Router(config-if)# ip address 10.0.0.0 10.255.255.255
Router(config-if)# encapsulation ppp
Router(config-if)# ppp chap hostname group 1
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 1

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Description of commands associated with MPLS and MPLS applications

Cisco IOS Multiprotocol Label Switching Command Reference

Basic MPLS VPNs

Configuring MPLS Layer 3 VPNs


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 1990

The PPP Multilink Protocol (MP)


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for MPLS—Multilink PPP Support

Table 3 lists the release history for this feature and provides links to specific configuration information.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 3 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 3 Feature Information for MPLS—Multilink PPP Support 

Feature Name
Releases
Feature Information

MPLS—Multilink PPP Support

Cisco IOS XE Release 2.1

The MPLS—Multilink PPP Support feature ensures that MPLS Layer 3 Virtual Private Networks (VPNs) with quality of service (QoS) can be enabled for bundled links. This feature supports Multiprotocol Label Switching (MPLS) over Multilink PPP (MLP) links in the edge (provider edge [PE]-to-customer edge [CE]) or in the MPLS core (PE-to-PE and PE-to-provider router [P]).

The following sections provide information about this feature:

Information About MPLS—Multilink PPP Support

How to Configure MPLS—Multilink PPP Support


Glossary

bundle—A group of interfaces connected by parallel links between two systems that have agreed to use Multilink PPP (MLP) over those links.

CBWFQ—class-based weighted fair queueing. A queueing option that extends the standard Weighted Fair Queueing (WFQ) functionality to provide support for user-defined traffic classes.

Cisco Express Forwarding—A proprietary form of switching that optimizes network performance and scalability for networks with large and dynamic traffic patterns, such as the Internet, and for networks characterized by intensive web-based applications or interactive sessions. Although you can use Cisco Express Forwarding in any part of a network, it is designed for high-performance, highly resilient Layer 3 IP backbone switching.

EIGRP—Enhanced Interior Gateway Routing Protocol. An advanced version of the Interior Gateway Routing Protocol (IGRP) developed by Cisco. It provides superior convergence properties and operating efficiency, and combines the advantages of link-state protocols with those of distance vector protocols.

IGP—Interior Gateway Protocol. An Internet protocol used to exchange routing information within an autonomous system. Examples of common Internet IGPs include Interior Gateway Routing Protocol (IGRP), Open Shortest Path First (OSPF), and Routing Information Protocol (RIP).

IGRP—Interior Gateway Routing Protocol. An Interior Gateway Protocol (IGP) developed by Cisco to address the issues associated with routing in large, heterogeneous networks. Compare with Enhanced Interior Gateway Routing Protocol (EIGRP).

IS-IS—Intermediate System-to-Intermediate System. An Open Systems Interconnection (OSI) link-state hierarchical routing protocol, based on DECnet Phase V routing, in which IS-IS routers exchange routing information based on a single metric to determine network topology.

LCP—Link Control Protocol. A protocol that establishes, configures, and tests data link connections for use by PPP.

LFI—link fragmentation and interleaving. The Cisco IOS XE LFI feature reduces delay on slower-speed links by breaking up large datagrams and interleaving low-delay traffic packets with the smaller packets resulting from the fragmented datagram. LFI allows reserve queues to be set up so that Real-Time Protocol (RTP) streams can be mapped into a higher priority queue in the configured weighted fair queue set.

link—One of the interfaces in a bundle.

LLQ—low latency queueing. A quality of service QoS queueing feature that provides a strict priority queue (PQ) for voice traffic and weighted fair queues for other classes of traffic. It is also called priority queueing/class-based weighted fair queueing (PQ/CBWFQ).

MLP—Multilink PPP. A method of splitting, recombining, and sequencing datagrams across multiple logical links. The use of MLP increases throughput between two sites by grouping interfaces and then load balancing packets over the grouped interfaces (called a bundle). Splitting packets at one end, sending them over the bundled interfaces, and recombining them at the other end achieves load balancing.

MQC—Modular QoS CLI. MQC is a CLI structure that allows users to create traffic polices and attach these polices to interfaces. MQC allows users to specify a traffic class independently of QoS policies.

NCP—Network Control Protocol. A series of protocols for establishing and configuring different network layer protocols (such as for AppleTalk) over PPP.

OSPF—Open Shortest Path First. A link-state, hierarchical Interior Gateway Protocol (IGP) routing algorithm proposed as a successor to Routing Information Protocol (RIP) in the Internet community. OSPF features include least-cost routing, multipath routing, and load balancing. OSPF was derived from an early version of the IS-IS protocol.

PPP—Point-to-Point Protocol. A successor to the Serial Line Interface Protocol (SLIP) that provides router-to-router and host-to-network connections over synchronous and asynchronous circuits. PPP works with several network layer protocols (such as IP, Internetwork Packet Exchange [IPX], and AppleTalk Remote Access [ARA]). PPP also has built-in security mechanisms (such as Challenge Handshake Authentication Protocol [CHAP] and Password Authentication Protocol [PAP]). PPP relies on two protocols: Link Control Protocol (LCP) and Network Control Protocol (NCP).

RIP—Routing Information Protocol. A version of Interior Gateway Protocol (IGP) that is supplied with UNIX Berkeley Standard Distribution (BSD) systems. Routing Information Protocol (RIP) is the most common IGP in the Internet. It uses hop count as a routing metric.

Virtual Bundle Interface—An interface that represents the master link of a bundle. It is not tied to any physical interface. Data going over the bundle is transmitted and received through the master link.

WFQ—weighted fair queueing. A congestion management algorithm that identifies conversations (in the form of traffic streams), separates packets that belong to each conversation, and ensures that capacity is shared fairly among the individual conversations. WFQ is an automatic way of stabilizing network behavior during congestion and results in improved performance and reduced retransmission.

WRED—weighted random early detection. A queueing method that ensures that high-precedence traffic has lower loss rates than other traffic during times of congestion.