Cisco IOS XE Configuration Fundamentals Configuration Guide, Release 2
Configuration Partitioning
Downloads: This chapterpdf (PDF - 249.0KB) The complete bookPDF (PDF - 1.48MB) | Feedback

Configuration Partitioning

Table Of Contents

Configuration Partitioning

Finding Feature Information

Contents

Information About Configuration Partitioning

System Running Configurations

Retrieving the Running Configuration for Display or Copy Operations

Benefits of Partitioning the Running Configuration

How to Use the Configuration Partitioning Feature

Displaying Configuration Partitions

Disabling the Configuration Partitioning Feature

What to Do Next

Configuration Examples for Configuration Partitioning

Displaying Configuration Partitions: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for Configuration Partitioning


Configuration Partitioning


First Published: February 26, 2007
Last Updated: May 4, 2009

The Configuration Partitioning feature provides modularization ("partitioning") of the running configuration state to provide granular access to the running configuration in Cisco IOS XE software.

This feature is enabled by default in Cisco IOS XE software images that include this feature.

The configuration state of a device is retrieved dynamically whenever a user issues the show running-config command. When the Configuration Partitioning feature is enabled, the system groups the configuration state of the device into parts (called "partitions") so that only the configuration state the user wishes to review is retrieved when generating a displayed list of commands in the running configuration. This feature improves performance for high-end systems with complex configurations because only a part of the running configuration state is processed when generating the running configuration command list, as opposed to the existing method of processing the entire system configuration state.

Default configuration partitions are provided by the introduction of this feature; other Cisco IOS XE software features may define their own command partitions in later releases.

Finding Feature Information

For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for Configuration Partitioning" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS XE software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Information About Configuration Partitioning

How to Use the Configuration Partitioning Feature

Configuration Examples for Configuration Partitioning

Additional References

Feature Information for Configuration Partitioning

Information About Configuration Partitioning

To use the Configuration Partitioning feature, you should understand the following concepts:

System Running Configurations

Retrieving the Running Configuration for Display or Copy Operations

Benefits of Partitioning the Running Configuration

System Running Configurations

Managing the configuration of any Cisco IOS XE software-based device involves managing the startup configuration (startup-config), which is a file stored in nonvolatile memory, and the running configuration (running-config), which is the set of all configuration options currently in effect on the system. Typically, the startup configuration file is loaded when the system boots, and changes to the system's running configuration, applied using the command-line interface (CLI), are saved by copying the running configuration to a configuration file (either locally or on the network), which can then be used to configure the device at startup, or used to configure other devices.

Retrieving the Running Configuration for Display or Copy Operations

In the Cisco IOS XE software configuration model, the configuration state is maintained in a distributed manner, with each component storing its own configuration state. To retrieve global configuration information, the software must poll every component to collect the distributed information. This configuration state retrieval operation is performed by a process known as nonvolatile generation (NVGEN), and it is invoked by commands such as show running-config, which is used to display the current configuration state, and copy system:running-configuration, which is used to save the running configuration by copying it to a file. When invoked, the NVGEN process queries each system component, each interface instance, and all other configured component objects in a standard sequence. A running configuration file is constructed as NVGEN traverses the system performing these queries, and it is this "virtual file" that is displayed or copied.

Benefits of Partitioning the Running Configuration

The Configuration Partitioning feature is the latest in a series of Configuration Generation Performance Enhancement Features for Cisco IOS XE software. (See the "Related Documents" section for related features.) This feature improves the system's response time by providing a method for querying only the system component you wish to review when issuing the show running-config command.

When the Configuration Partitioning feature is enabled, the system groups the configuration state of the device into parts (called "partitions") for the purpose of generating the virtual running configuration file (the list of configuration commands). A new command, show running-config partition, allows you to display only the part of the running configuration that you want to examine, rather than having to display the entire running configuration at once, or displaying only lines that match a certain string.

The key benefit of this feature is that it increases system performance by allowing the system to run the NVGEN process for only the collection of system components (such as specific interfaces) that you need to display. This is in contrast to other existing extensions to the show running-config command, which only filter the generated list after all system components have been processed.

The selective processing of the system's configuration state for the purpose of generating a partial running configuration is called "configuration partitioning."

More granular access to configuration information offers important performance benefits for high-end routing platforms with very large configuration files, while also enhancing configuration management by allowing advanced configuration features to be implemented at a more granular level. Advanced configuration options include Cisco IOS XE software support for provisioning of customer services, Config Rollback, Config Locking, and configuration access control.

How to Use the Configuration Partitioning Feature

This section contains the following tasks:

Displaying Configuration Partitions (optional)

Disabling the Configuration Partitioning Feature (optional)

Displaying Configuration Partitions

The main method of taking advantage of this feature is by using the show running-config partition part command, which is a specialized extension to the show running-config command.


Note The partition part command extension is not available for the more system:running-config command.


Because this feature offers improved performance for existing commands, this feature is enabled by default in Cisco IOS XE software images that support this feature. To quickly determine if this feature is supported and running on your system, issue the show running-config partition ? command in privileged EXEC mode.

SUMMARY STEPS

1. show running-config partition ?

2. show runningconfig partition part

DETAILED STEPS


Step 1 show running-config partition ?

Issuing this command will show you the list of running configuration parts available for display on your system.

If the Configuration Partitioning feature is supported on your system and is enabled, you will see the string "config partition is TRUE" as the first line of help output.

If you receive an error message when entering the command syntax shown here, this feature is not supported on your system. See the command documentation for the show running-config command for existing extensions of that command in other releases that allow you to show only part of the running configuration.


Note The list of available configuration parts may vary by software image and is dependent on what features are currently configured.


Router# show running-config partition ?
access-list       All access-list configurations
  class-map         All class-map configurations
  common            All remaining unregistered configurations
  global-cdp        All global cdp configurations
  interface         Each Interface specific Configurations
  ip-as-path        All IP as-path configurations
  ip-community      All IP community list configurations
  ip-domain-list    All ip domain list configurations
  ip-prefix-list    All ip prefix-list configurations
  ip-static-routes  All IP static configurations
  line              All line mode configurations
  policy-map        All policy-map configurations
  route-map         All route-map configurations
  router            All routing configurations
  snmp              All SNMP configurations
  tacacs            All TACACS configurations

Choose the part of the running configuration you want to display, and use the associated keyword as the part argument in Step 2.

Step 2 show running-config partition part

As an example, to have the system perform the NVGEN process on only the components associated with the access-list parts of the running configuration state, and display only the access-list related configurations, you would enter the show running-config partition access-list command:

Router# show running-config partition access-list
        Building configuration...

Current configuration : 127 bytes
!
Configuration of Partition access-list 
!
!
!
access-list 90 permit 0.0.0.0 1.2.3.5
access-list 100 permit 10 any any
!
end


Note This command also allows you to run the NVGEN process and display the resulting output for specific interfaces. This is a key capability of this feature, as it was designed for systems with numerous active interfaces.


In the following example, the main configuration partition is the interface configuration, and the specific part of the configuration to be generated is the configuration for Fast Ethernet interface 0/0.

Router# show running-config partition interface fastethernet0/0
Building configuration... 

Current configuration : 213 bytes
!
Configuration of Partition interface FastEthernet0/0
!
!
interface FastEthernet0/0
 ip address 10.4.2.39 255.255.255.0
 no ip route-cache cef
 no ip route-cache
 duplex half
 ipv6 enable
 no cdp enable
!
!
end

Disabling the Configuration Partitioning Feature

Because this feature offers improved performance for existing commands, this feature is enabled by default for Cisco IOS XE software images that support this feature. However, you may want to disable this feature if you determine that it is not needed, as this feature does use a small amount of system resources (memory and CPU utilization). To disable configuration partitioning, perform the following task, which assumes you are starting in user EXEC mode.

SUMMARY STEPS

1. enable

2. configure terminal

3. no parser config partition

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

no parser config partition

Example:

Router(config)# no parser config partition

Disables the configuration partitioning feature.

What to Do Next

To reenable the feature after it has been disabled, use the parser config partition command in global configuration mode.


Note As this feature is enabled by default, only the no form will appear in the running configuration file, or will be written to the startup configuration file when you issue the copy running-config startup-config command.


Configuration Examples for Configuration Partitioning

This section provides examples of displaying configuration partitions with the show running-config partition command:

Displaying Configuration Partitions: Example

Displaying Configuration Partitions: Example

In this example, the show running-config partition command is used with related commands in a series of steps an administrator might take to check the status of a specific interface and the current configuration of some of the system's other components. Comparable filtered output from the standard show running-config command (for example, show running-config | include access-list) is included for demonstration purposes.


Note The part argument can consist of multiple partition name keywords, as in show running-config part router eigrp 1.


Router# show running-config partition ?

access-list All access-list configurations

class-map All class-map configurations

common All remaining unregistered configurations

global-cdp All global cdp configurations

interface Each Interface specific Configurations

ip-as-path All IP as-path configurations

ip-community All IP community list configurations

ip-domain-list All ip domain list configurations

ip-prefix-list All ip prefix-list configurations

ip-static-routes All IP static configurations

line All line mode configurations

policy-map All policy-map configurations

route-map All route-map configurations

router All routing configurations

snmp All SNMP configurations

  tacacs            All TACACS configurations

Router# show running-config partition access-list 
Building configuration...

Current configuration : 87 bytes
!
!
!
!
access-list 90 permit 0.0.0.0 1.2.3.5
access-list 100 permit 10 any any
!
end

Router# show running-config | include access-list 
access-list 90 permit 0.0.0.0 1.2.3.5
access-list 100 permit 10 any any
Router#

Router# show running-config partition class-map 
Building configuration...

Current configuration : 78 bytes
!
!
!
class-map match-all abc
  match any 
class-map match-all xyz
!
!
!
end

Router# show running-config | begin class-map 
class-map match-all abc
  match any 
class-map match-all xyz
!
!

Router# show running-config partition global-cdp 
Building configuration...

Current configuration : 43 bytes
!
!
!
cdp timer 20
cdp holdtime 100
!
end

Router# show running-config | include global-cdp 
cdp timer 20
cdp holdtime 100
Router#

Router# show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down    
FastEthernet2/0                10.4.2.32       YES NVRAM  up                    up      
FastEthernet2/1                unassigned      YES NVRAM  administratively down down    
FastEthernet2/2                unassigned      YES NVRAM  administratively down down    
FastEthernet2/3                unassigned      YES NVRAM  administratively down down    
Serial3/0                  unassigned      YES NVRAM  administratively down down    
Serial3/1                  unassigned      YES NVRAM  administratively down down    
Serial3/2                  unassigned      YES NVRAM  administratively down down    
Serial3/3                  unassigned      YES NVRAM  administratively down down    
Loopback0                  unassigned      YES NVRAM  administratively down down    
Loopback234                unassigned      YES NVRAM  administratively down down    

Router# show running-config partition interface fastethernet0/0
Building configuration...

Current configuration : 98 bytes
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex half
!
!
end

Router# show running-config partition interface FastEthernet2/0   
Building configuration...

Current configuration : 122 bytes
!
!
!
interface FastEthernet2/0
 ip address 10.4.2.32 255.255.255.0
 no ip proxy-arp
 no ip route-cache
 duplex half
!
!
end

Router# show running-config partition interface FastEthernet2/1
Building configuration...

Current configuration : 94 bytes
!
!
!
interface FastEthernet2/1
 no ip address
 no ip route-cache
 shutdown
 duplex half
!
!
end

Router# show running-config partition interface FastEthernet2/2 
Building configuration...

Current configuration : 94 bytes
!
!
!
interface FastEthernet2/2
 no ip address
 no ip route-cache
 shutdown
 duplex half
!
!
end

Router# show running-config partition interface FastEthernet2/3
Building configuration...

Current configuration : 94 bytes
!
!
!
interface FastEthernet2/3
 no ip address
 no ip route-cache
 shutdown
 duplex half
!
!
end

Router# show running-config partition interface serial3/0
Building configuration...

Current configuration : 103 bytes
!
!
!
interface Serial3/0
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
end

Router# show running-config partition interface serial3/1
Building configuration...

Current configuration : 103 bytes
!
!
!
interface Serial3/1
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
end

Router# show running-config partition interface serial3/2
Building configuration...

Current configuration : 103 bytes
!
!
!
interface Serial3/2
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
end

Router# show running-config partition interface serial3/3
Building configuration...

Current configuration : 103 bytes
!
!
!
interface Serial3/3
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
end

Router# show running-config partition interface loopback0
Building configuration...

Current configuration : 79 bytes
!
!
!
interface Loopback0
 no ip address
 no ip route-cache
 shutdown
!
!
end

Router# show running-config partition interface loopback1
                                                      ^
% Invalid input detected at '^' marker.

Router# show running-config partition interface loopback234
Building configuration...

Current configuration : 81 bytes
!
!
!
interface Loopback234
 no ip address
 no ip route-cache
 shutdown
!
!
end

Router# configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# interface FastEthernet 2/0.1
Router(config-subif)# exit
Router(config)# exit

Router#
00:13:05: %SYS-5-CONFIG_I: Configured from console by console
Router# show running-config partition interface FastEthernet2/0.1
Building configuration...

Current configuration : 58 bytes
!
!
!
interface FastEthernet2/0.1
 no ip route-cache
!
!
end
Router# show run partition ip?
ip-as-path  ip-community  ip-domain-list  ip-static-routes  

Router# show running-config partition ip-as
Router# show running-config partition ip-as-path 

Building configuration...

Current configuration : 125 bytes
!
!
!
ip as-path access-list 2 permit $ABC
ip as-path access-list 2 permit $xyz*
ip as-path access-list 2 permit qwe*
!
end
Router# show running-config partition ip-community 
Building configuration...

Current configuration : 92 bytes
!
!
!
ip community-list standard asd permit
ip community-list expanded qwe deny uio*
!
end

Router# show running-config | include ip community
ip community-list standard asd permit
ip community-list expanded qwe deny uio*
Router#
Router# show running-config partition ip-domain-list 
Building configuration...

Current configuration : 70 bytes
!
ip domain-list iop
ip domain-list tyu
ip domain-list jkl
!
!
!
end
Router# show running-config partition ip-static-routes 
Building configuration...

Current configuration : 98 bytes
!
!
!
ip route 0.0.0.0 0.0.0.0 FastEthernet2/0
ip route 171.69.1.129 255.255.255.255 10.4.29.1
!
end

Router# show running-config partition line
Building configuration...

Current configuration : 489 bytes
!
!
!
!
line con 0
 exec-timeout 0 0
 transport output lat pad v120 mop telnet rlogin udptn nasi
 stopbits 1
line aux 0
 transport output lat pad v120 mop telnet rlogin udptn nasi
 stopbits 1
line vty 0
 password lab
 login
 transport input lat pad v120 mop telnet rlogin udptn nasi
 transport output lat pad v120 mop telnet rlogin udptn nasi
line vty 1 4
 login
 transport input lat pad v120 mop telnet rlogin udptn nasi
 transport output lat pad v120 mop telnet rlogin udptn nasi
!
end       
Router# show running-config partition policy-map
Building configuration...

Current configuration : 162 bytes
!
!
!
policy-map qwer
 description policy-map qwer.
  class xyz
    shape peak 8000 32 32
policy-map p1
policy-map sdf
  class abc
   set precedence 4
!
!
!
end
Router# show running-config partition route-map
Building configuration...

Current configuration : 65 bytes
!
!
!
route-map iop permit 10
!
route-map rty permit 10
!
!
end
Router# show running-config partition router bgp 1
Building configuration...

Current configuration : 111 bytes
!
!
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 distance bgp 2 2 2
 no auto-summary
!
!
end

Router# show running-config partition router egp ?
<0-65535>  Remote autonomous system number

Router# show running-config partition router egp 1
Building configuration...

Current configuration : 46 bytes
!
!
!
router egp 1
 timers egp 20 20
!
!
end

Router# show running-config partition router ?
  bgp       Border Gateway Protocol (BGP)
  egp       Exterior Gateway Protocol (EGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)

Router# show running-config partition router eigrp ?
<1-65535>  Autonomous system number

Router# show running-config partition router eigrp 1
Building configuration...

Current configuration : 13 bytes
!
!
!
!
end

Router#
Router# show running-config partition router eigrp 2 
Building configuration...

Current configuration : 57 bytes
!
!
!
router eigrp 2
 variance 10
 auto-summary
!
!
end

Router# show running-config partition router ?
  bgp       Border Gateway Protocol (BGP)
  egp       Exterior Gateway Protocol (EGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)

Router# show running-config partition router isis ?
  WORD  ISO routing area tag
  |     Output modifiers
  <cr>

Router# show running-config partition router isis qwe
Building configuration...

Current configuration : 86 bytes
!
!
!
router isis qwe
 set-attached-bit route-map qwer
 use external-metrics
!
!
end

Router# show running-config partition router isis ?
  WORD  ISO routing area tag
  |     Output modifiers
  <cr>

Router# show running-config partition router iso
Router# show running-config partition router iso-igrp ?
  WORD  ISO routing area tag
  |     Output modifiers
  <cr>

Router# show running-config partition router iso-igrp 
Building configuration...

Current configuration : 31 bytes
!
!
!
router iso-igrp
!
!
end

Router# show running-config | begin iso
router iso-igrp
!
router isis qwe
 set-attached-bit route-map qwer
 use external-metrics
!
router egp 1
 timers egp 20 20
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 distance bgp 2 2 2
 no auto-summary
!

Router# show running-config partition router ?
  bgp       Border Gateway Protocol (BGP)
  egp       Exterior Gateway Protocol (EGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)

Router# show running-config partition router mobile ?
  |  Output modifiers
  <cr>

Router# show running-config partition router mobile 
Building configuration...

Current configuration : 42 bytes
!
!
!
router mobile
 distance 20
!
!
end


Router# show running-config | include router 
router mobile
router odr
router eigrp 2
router ospf 4
router iso-igrp
router isis qwe
router egp 1
router bgp 1

Router# show running-config partition router ?
  bgp       Border Gateway Protocol (BGP)
  egp       Exterior Gateway Protocol (EGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  rip       Routing Information Protocol (RIP)

Router# show running-config partition router ospf ?
  <1-65535>  Process ID

Router# show running-config partition router ospf 4
Building configuration...

Current configuration : 64 bytes
!
!
!
router ospf 4
 log-adjacency-changes
 distance 4
!
!
end

Router# show running-config partition service 
Building configuration...

Current configuration : 190 bytes
!
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
service udp-small-servers
service tcp-small-servers
!
!
!
end
Router# show running-config partition snmp 
Building configuration...

Current configuration : 84 bytes
!
!
!
snmp-server community user101 RW
snmp mib target list qwe host 0.0.0.0
!
end

Additional References

The following sections provide references related to the Configuration Partitioning feature.

Related Documents

Related Topic
Document Title

Running configuration performance enhancement—parser config cache for interfaces.

"Configuration Generation Performance Enhancement"

Provisioning of customer services, Config Rollback, Config Locking, and configuration access control

"Contextual Configuration Diff Utility"

Configuration management—Config change logging.

"Configuration Change Notification and Logging"

Cisco IOS XE software configuration access control and config session locking ("Config Lock").

"Exclusive Configuration Change Access and Access Session Locking"


Standards

Standard
Title

No standards are associated with this feature.


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Feature Information for Configuration Partitioning

Table 1 lists the features in this module and provides links to specific configuration information.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS XE software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS XE software release that introduced support for a given feature in a given Cisco IOS XE software release train. Unless noted otherwise, subsequent releases of that Cisco IOS XE software release train also support that feature.


Table 1 Feature Information for Configuration Partitioning

Feature Name
Releases
Feature Information

Configuration Partitioning

Cisco IOS XE Release 2.1

The Configuration Partitioning feature provides modularization ("partitioning") of the running configuration state to provide granular access to the running configuration in Cisco IOS XE software. This feature is enabled by default in Cisco IOS XE software images that include this feature.

In Cisco IOS XE Release 2.1, this feature was introduced on Cisco ASR 1000 Series Routers.

The following sections provide information about this feature:

Information About Configuration Partitioning

How to Use the Configuration Partitioning Feature