This documentation has been moved
Using AutoInstall to Remotely Configure Cisco Networking Devices
Downloads: This chapterpdf (PDF - 828.0KB) The complete bookPDF (PDF - 2.76MB) | Feedback

Using AutoInstall to Remotely Configure Cisco Networking Devices

Table Of Contents

Using AutoInstall to Remotely Configure Cisco Networking Devices

Finding Feature Information

Contents

Prerequisites for Using AutoInstall to Remotely Configure Cisco Networking Devices

Restrictions for Using AutoInstall to Remotely Configure Cisco Networking Devices

Information About Using AutoInstall to Remotely Configure Cisco Networking Devices

AutoInstall Overview

Services and Servers Used by AutoInstall: Dynamic Assignment of IP Addresses

Services and Servers Used by AutoInstall: IP-to-Hostname Mapping

Services and Servers Used by AutoInstall: Storage and Transmission of Configuration Files

Networking Devices Used by AutoInstall

Configuration Files Used by AutoInstall

Configuration Options for AutoInstall

The AutoInstall Process

Benefits of Using AutoInstall to Remotely Configure a Cisco Networking Device

AutoInstall Using DHCP for LAN Interfaces

AutoInstall over Frame Relay-ATM Interworking Connections

How to Use AutoInstall to Remotely Configure Cisco Networking Devices

Disabling the SDM Default Configuration File

Using AutoInstall with Frame Relay to ATM Service Internetworking

Configuring R6 for Frame Relay to ATM Service Internetworking

Verifying Frame Relay to ATM Service Internetworking on R6

Configuring R4 for Frame Relay to ATM Service Internetworking

Configuring IP Routing R4

Configuring the LS1010 Switch

Verifying AutoInstall with Frame Relay to ATM Service Internetworking

Using AutoInstall to Set Up Devices Connected to LANs

Determining the Value for the DHCP Client Identifier Manually

Determining the Value for the DHCP Client Identifier Automatically

Configuration Examples for Using AutoInstall to Remotely Configure Cisco Networking Devices

Using AutoInstall with Frame Relay to ATM Service Internetworking: Example

Configuring R6 for Frame Relay to ATM Service Internetworking: Example

Configuring R4 for Frame Relay to ATM Service Internetworking: Example

Configuring R4 for Frame Relay to ATM Service Internetworking: Example

Configuring the LS1010 Switch: Example

Creating the Configuration File for R2: Example

Using AutoInstall to Set Up Devices Connected to LANs: Example

Determining the Value for the DHCP Client Identifier Automatically: Example

Creating a Private DHCP Pool for Each of The Routers: Example

Creating Configuration Files for Each Router: Example

Creating the network-confg file: Example

Setting Up the Routers with AutoInstall: Example

Saving the Configuration Files on the Routers: Example

Removing the Private DHCP Address Pools from R1: Example

Using AutoInstall to Set Up Devices Connected to WANs: Example

HDLC WAN Connections: Example

Frame-Relay WAN Connections: Example

Additional References

Related Documents

MIBs

RFCs

Technical Assistance

Feature Information for Using AutoInstall to Remotely Configure a Cisco Networking Device


Using AutoInstall to Remotely Configure Cisco Networking Devices


First published: November 28, 2005
Last updated: April 6, 2010

AutoInstall enables remote, automatic configuration of networking devices. AutoInstall is typically used to set up new networking devices remotely. You can, however, use AutoInstall to configure existing networking devices after you remove the configuration file from their NVRAM. The AutoInstall process uses preexisting configuration files that are stored on a TFTP server.

In this module the term networking device means a router that runs Cisco IOS software. Also, the following terms are used interchangeably:

initial configuration and startup configuration

set up and configure

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for Using AutoInstall to Remotely Configure a Cisco Networking Device" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for Using AutoInstall to Remotely Configure Cisco Networking Devices

Restrictions for Using AutoInstall to Remotely Configure Cisco Networking Devices

Information About Using AutoInstall to Remotely Configure Cisco Networking Devices

How to Use AutoInstall to Remotely Configure Cisco Networking Devices

Configuration Examples for Using AutoInstall to Remotely Configure Cisco Networking Devices

Additional References

Feature Information for Using AutoInstall to Remotely Configure a Cisco Networking Device

Prerequisites for Using AutoInstall to Remotely Configure Cisco Networking Devices

You have read Overview: Basic Configuration of a Cisco Networking Device module in the Cisco IOS Configuration Fundamentals Configuration Guide.

This document is written specifically for networking devices running Cisco IOS Release 12.4(1) or newer. However most of the information in this document can be used to configure networking devices that support AutoInstall and are not running Cisco IOS release 12.4(1) or newer. The two key differences that you must allow for are:

Some Cisco networking devices use BOOTP instead of DHCP to request IP address addresses over LAN interfaces. Enabling BOOTP support on your DHCP server will resolve this issue.

Some Cisco networking devices use a DHCP client identifier format that is different from the format used by networking devices running Cisco IOS release 12.4(1) or newer. This document only explains the DHCP client identifier format used by networking devices running Cisco IOS release 12.4(1) or newer. Use the process described in "Determining the Value for the DHCP Client Identifier Automatically: Example" section to determine the DHCP client identifier format that your Cisco networking device is using.

No configuration file resides in NVRAM on the networking device that is being configured with AutoInstall.

The configuration files that you want to load on to the networking device using AutoInstall reside on a TFTP server that is connected to the network. In most cases there is more than one file; for example, a network file with the IP-to-hostname mappings and a device-specific configuration file.

You have someone at the remote site to connect the networking device that is being configured with AutoInstall to the network and power it on.

The network has the IP connectivity necessary to permit the networking device to load configuration files from the TFTP server during the AutoInstall process.

A DHCP server is available on the network to provide IP addresses to networking devices that are using AutoInstall over a LAN connection.

Restrictions for Using AutoInstall to Remotely Configure Cisco Networking Devices

(Serial interfaces only) AutoInstall over a serial interface using either HDLC or Frame Relay can be performed only over the first serial port on a new device (serial interface 0 or serial interface x/0).

(LAN interfaces only) Only LAN Token Ring interfaces that set ring speed with physical jumpers support AutoInstall.

AutoInstall does not automatically run on a T1 interface. For AutoInstall to work on a T1 interface, you have to manually configure the T1 interface to create a serial interface and then assign an IP address and network mask to that serial interface.

Information About Using AutoInstall to Remotely Configure Cisco Networking Devices

Before you configure or use AutoInstall, you should understand the following concepts:

AutoInstall Overview

Benefits of Using AutoInstall to Remotely Configure a Cisco Networking Device

AutoInstall Overview

AutoInstall can be used to load a final full configuration, or a partial temporary configuration, on to a networking device that is being configured with AutoInstall.


Tip When you use AutoInstall to load a partial temporary configuration, you must finish configuring the device manually.


The requirements for provisioning your network for AutoInstall, and the configuration options for provisioning AutoInstall, are explained in these sections:

Services and Servers Used by AutoInstall: Dynamic Assignment of IP Addresses

Services and Servers Used by AutoInstall: IP-to-Hostname Mapping

Services and Servers Used by AutoInstall: Storage and Transmission of Configuration Files

Networking Devices Used by AutoInstall

Configuration Files Used by AutoInstall

Configuration Options for AutoInstall

The AutoInstall Process

Services and Servers Used by AutoInstall: Dynamic Assignment of IP Addresses

The network must be able to provide the dynamic assignment of an IP address to the networking device that is being configured with AutoInstall. The type of IP address assignment server that is used depends on the type of connection that the networking that is being configured with AutoInstall has to the network.

AutoInstall uses these types of IP address servers:

DHCP Servers

SLARP Servers

BOOTP Servers

DHCP Servers

Networking devices using AutoInstall over a LAN connection require a DHCP server to provide an IP address dynamically. This requirement applies to Ethernet, Token Ring, and FDDI interfaces. The network must be configured to provide IP connectivity between the DHCP server and any devices that are using AutoInstall over LAN connections.

DHCP (defined in RFC 2131) is an extension of the functionality provided by the Bootstrap Protocol (defined in RFC 951). DHCP provides the framework for passing configuration information to hosts on a TCP/IP network. DHCP adds the capability of automatic allocation of reusable network addresses and additional configuration options such as a router (gateway) IP address, a TFTP server IP address, the name of a boot file to load, and the domain name to use. DHCP servers can be configured on routers, UNIX servers, Microsoft Windows-based servers, and other platforms.

DHCP servers typically assign IP addresses from a pool of IP addresses randomly. It is possible for a device that uses DHCP to obtain its IP address to have a different IP address every time it is connected to the network. This behavior creates a problem for the AutoInstall process when you want to ensure that a particular device is assigned a specific hostname during the AutoInstall process. For example, if you are installing routers on different floors in a remote site and each router is supposed to be assigned a name that indicates its location, such as ChicagoHQ-1st and ChicagoHQ-2nd, you need to ensure that each device gets the IP address that will be mapped to its correct hostname.

The process of ensuring that a device is assigned a specific IP address is referred to as creating a reservation. A reservation is a manually configured relationship between an IP address and a physical layer address of a LAN interface on the device. Many Cisco IOS-based devices do not use their MAC address when they request an IP address via DHCP. They use a much longer client identifier instead. Due to the complexity of identifying the client identifier so that you can preconfigure a reservation, and the complexity of finding out if the new device uses its MAC address or the client identifier, we recommend that you allow a new device to obtain an IP address without using a DHCP reservation first in order to discover if the device is using its MAC address or a client identifier. When you have learned how the new device is identifying itself to the DHCP server, you can make a note of the format and create a reservation for it. The next time the new device is rebooted it should obtain the IP address that you reserved to ensure that the new device is assigned the correct hostname. Refer to the information on creating DHCP reservations that was provided with your DHCP server software. The process for creating reservations using Cisco IOS based DHCP servers is explained in the "Using AutoInstall to Set Up Devices Connected to LANs: Example" section. This section includes instructions for identifying the client identifier before the device is connected to the network so that you can preconfigure the DHCP reservations.


Note This document uses a Cisco router as the DHCP server for using AutoInstall to configure LAN-connected networking devices. If you are using a different device as your DHCP server ensure that you have the user documentation for it available in the event that you need help configuring it.



Note There are several configuration parameters such as TFTP server addresses, DNS server addresses, domain names and so on, that can be provided to LAN-connected clients by DHCP servers during the process of assigning IP addresses to clients. These parameters are not required by AutoInstall, therefore they are not included in this document. If you know how to use these parameters, you can include them in your DHCP server configuration when you are using AutoInstall to set up your networking devices.


For more information on DHCP services visit the IETF RFC site (http://www.ietf.org/rfc.html) and look for RFCs about DHCP. Most server operating systems support DHCP servers. Refer to the documentation that was provided with your operating system for more information.

SLARP Servers

A router that is being configured with AutoInstall over a serial interface using HDLC encapsulation will send a Serial Line ARP (SLARP) request for an IP address over the serial interface that is connected to the staging router.

The serial interface of the staging router must be configured with an IP address in which the host portion is 1 or 2, such as 192.168.10.1 or 192.168.10.2. The staging router will send a SLARP response to the router that is being configured with AutoInstall that contains the value that the staging router is not using. For example, if the interface on the staging router that is connected to the router that is being configured with AutoInstall is using 192.168.10.1 as its IP address, the staging router will send a SLARP response with a value of 192.168.10.2 to the router that is being configured with AutoInstall.


Tip If you are using a mask of 255.255.255.252 on the serial interface of the staging router SLARP will assign the available IP host address to the new device. For example, if you assign IP address 198.162.10.5 255.255.255.252 to serial 0 on the staging router, SLARP will assign 198.162.10.6 to the new device. If you assign IP addresses 198.162.10.6 255.255.255.252 to serial 0 on the staging router SLARP will assign 198.162.10.5 to the new device.


Figure 1 shows an example of SLARP.

In Figure 1, the IP address of serial interface 0 on the staging router (R2) is 192.168.10.1. SLARP therefore assigns the IP address 192.168.10.2 to serial interface 0 on the new device.

Figure 1 Using SLARP to Assign an IP Address to a New Device


Note AutoInstall over a serial interface using HDLC can be performed only over the first serial port on a new device (serial interface 0 or serial interface x/0). The staging router and new device must be directly connected using the first serial interface port on the new device; for example, serial 0/0 or if the first serial port is in the second slot of the device, serial 2/0.



Tip The IP address that is assigned to the router that is being configured with AutoInstall by SLARP from the staging router is the IP address that you must use in the ip host hostname ip-address command in the AutoInstall network-confg or cisconet.cfg file to ensure that the router that is being configured with AutoInstall is assigned the correct hostname so that it can request its host-specific configuration file.


BOOTP Servers

A router that is being configured with AutoInstall over a serial interface using Frame Relay encapsulation will send a BOOTP request for an IP address over the serial interface that is connected to the staging router.

The staging router learns the correct IP address to provide in its BOOTP response to the router that is being configured with AutoInstall by examining the frame-relay map ip ip-address dlci command that is configured on the interface that it is using to connect to the router that is being configured with AutoInstall.

In Figure 2 R2 is the staging router. R2 has the frame-relay map ip 172.16.27.100 100 broadcast command configured on interface serial 0. When R2 receives the BOOTP request for an IP address from R3 during the AutoInstall process, R2 will reply with 172.16.27.100.

Figure 2 Example of Using BOOTP for AutoInstall over a Frame Relay Network


Tip The limitation imposed by SLARP in which the IP addresses for the new device and the staging router must end in either .1 or .2 does not apply to BOOTP. BOOTP for AutoInstall over Frame Relay supports all host addresses for the IP address subnet that is assigned to the Frame Relay circuit between the router that is being configured with AutoInstall and the staging router.



Tip The IP address that is assigned to the router that is being configured with AutoInstall by BOOTP from the staging router is the IP address that you must use in the ip host hostname ip-address command in the AutoInstall network-confg or cisconet.cfg file to ensure that the router that is being configured with AutoInstall is assigned the correct hostname so that it can request its host-specific configuration file.



Note AutoInstall over a serial interface using Frame Relay encapsulation can be performed only over the first serial port on a new device (serial interface 0 or serial interface x/0). The staging router and new device must be directly connected using the first serial interface port on the new device; for example, serial 0/0 or if the first serial port is in the second slot of the device, serial 2/0.


Services and Servers Used by AutoInstall: IP-to-Hostname Mapping

If you want the networking device to load a full configuration file during the AutoInstall process, the networking device must be able to determine its hostname so that it can request the configuration file that you created specifically for it.

The following caveats apply to the provisioning of IP address to hostname mapping for AutoInstall:

Any networking device that is being configured with AutoInstall can determine its hostname by loading one of the AutoInstall network configuration files (network-confg or cisconet.cfg) from the TFTP server that contain the ip host hostname ip-address commands. For example, to map host R3 to IP address 198.162.100.3, the network-confg or cisconet.cfg file must contain the ip host r3 198.162.100.3 command.

A networking device that is being configured with AutoInstall over a LAN interface can also determine its hostname by querying a DNS server. If the DNS server is not connected to the same LAN the device must learn the IP address of the DNS server from the DHCP server during the process of obtaining its dynamically assigned IP address from the DHCP server.

DNS Servers

DNS servers are used to provide a network service that maps hostnames to IP addresses and IP addresses to hostnames (reverse DNS lookups). Anytime that you use a hostname to initiate an IP connection to a host, your PC must determine the IP address that is assigned to the hostname that you want to contact. For example, when you visit Cisco's website (http://www.cisco.com/) your PC sends a DNS query to a DNS server to discover the current IP address that can be used to contact Cisco's website.

For more information on DNS services visit the IETF RFC site (http://www.ietf.org/rfc.html) and look for RFCs about DNS. The Name Server LookUp tool (nslookup) is very useful for learning more about DNS. There are several excellent websites available about nslookup that you can find by searching for them.

Services and Servers Used by AutoInstall: Storage and Transmission of Configuration Files

TFTP is a protocol used to transfer files between devices on a network. A TFTP server is a device that uses TFTP to transfer files to devices. TFTP servers can be configured on UNIX servers, Microsoft Windows-based PCs and servers, and other platforms.


Tip If you do not have a TFTP server available you can configure a Cisco IOS-based router as a TFTP server using the tftp-server file-system:filename command. Refer to the Configuring Basic File Transfer Services feature for more information on configuring your router as a TFTP server.


Cisco routers use TFTP to load the configuration files that are required for AutoInstall. You must have a TFTP server deployed in your network to provide file storage and file transmission services to the devices that will be using AutoInstall.

For more information on TFTP services visit the IETF RFC site (http://www.ietf.org/rfc.html) and look for RFCs about TFTP. There are several excellent websites available about TFTP that you can find by searching for them. Several freeware and shareware versions of TFTP servers for various operating systems and hardware platforms are available from the Internet.

The following caveats apply to the provisioning of TFTP servers for AutoInstall:

Devices using AutoInstall over a LAN—If the TFTP server and the devices using AutoInstall are on different LAN segments, you must either configure the ip helper-address address command on all of the interfaces that will receive TFTP session initialization requests from the devices that are using AutoInstall.

Devices using AutoInstall over a WAN—If the devices using AutoInstall are connected to a WAN, you must configure the ip helper-address address command on all of the interfaces that will receive TFTP session initialization requests from devices that are using AutoInstall.

ip helper-address

If the new device does not learn the IP address of the TFTP server via DHCP option 150, it will transmit the TFTP session initialization requests as network layer broadcasts using the IP destination broadcast address of 255.255.255.255. Routers block network layer broadcast datagrams which prevents the TFTP session initialization requests from reaching the TFTP server, and AutoInstall will fail. The solution to this problem is to use the ip helper-address address command. The ip helper-address address command changes the broadcast address of TFTP session initialization request from 255.255.255.255 to the address that is configured with the address argument. For example, the ip helper-address 172.16.29.252 command will change IP destination broadcast address of 255.255.255.255 to 172.16.29.252.

Networking Devices Used by AutoInstall

These networking devices are used by AutoInstall:

Device That Is Being Configured with AutoInstall (Required)

Staging Router (Required)

Intermediate Frame Relay-ATM Switching Device (Optional)

Device That Is Being Configured with AutoInstall

A device that is being configured with AutoInstall can be any Cisco IOS-based router that supports AutoInstall and does not have a configuration file in its NVRAM.

Staging Router

A staging router acts as an intermediary between the TFTP server (to which it must have IP connectivity) and a device that is being configured with AutoInstall when the new device and the TFTP server are connected to different networks. In Figure 3 R1 requires a staging router because it is connected to a different LAN segment than the TFTP server.

Staging routers are required in the following situations:

Devices using AutoInstall over a LAN—If the TFTP and/or DHCP servers and the devices using AutoInstall are on different LAN segments you must use a staging router.

Devices using AutoInstall over a WAN—If the devices using AutoInstall are connected to a WAN, you must configure the ip helper-address address command on all of the directly connected interfaces that will receive TFTP session initialization requests from the devices that are using AutoInstall.

Figure 3 Example of AutoInstall That Requires a Staging Router

Staging routers are not required when the new device that is being configured with AutoInstall is connected to the same LAN segment as the TFTP and DHCP servers. In Figure 4 R2 does not require a staging server to use AutoInstall because it is on the same LAN segment as the TFTP server.

Figure 4 Example of AutoInstall That Does Not Require a Staging Router

Intermediate Frame Relay-ATM Switching Device

An intermediate Frame Relay-ATM switching device is one that can perform both routing and switching operations. Frame Relay-ATM switching devices are used to connect Frame Relay and ATM networks.

The AutoInstall over Frame Relay-ATM Interworking Connections feature modifies the AutoInstall process to use Frame Relay encapsulation defined by the IETF standard instead of the Frame Relay encapsulation defined by Cisco.

Figure 5 shows an example topology using AutoInstall over Frame Relay-ATM Interworking Connections. Router R6 does the Frame Relay to ATM Service Internetworking (FRF8) conversion for Frame Relay DLCI 50 to ATM VPI/VCI 5/50. The LS1010 switch routes the VPI/VCI combination used by R6 (5/50) to the VPI/VCI combination used by R4 (6/60).

Figure 5 Example Topology for AutoInstall over Frame Relay-ATM Interworking Connections

Configuration Files Used by AutoInstall

A configuration file executes predefined commands and settings that enable a device to function in a network. The type of configuration file you choose determines many aspects of how you set up the network for AutoInstall.

These types of files are used by AutoInstall:

Network Configuration File (Required)

Host-Specific Configuration File (Required)

Default Configuration File (Optional)

Network Configuration File

The network configuration file is the first file that the AutoInstall process attempts to use. After the device has obtained an IP address it will try to discover its hostname by attempting to download a network configuration file that contains IP address to host name mappings.

If you want the device to learn its hostname from the network-confg file so that it can download a host-specific configuration file, you must add an entry for the device in the network-confg network configuration file. The syntax for the entry is ip host hostname ip-address where hostname is the name that you want the host to use and ip-address is the address that the host will receive from the IP address server. For example, if you want the new device to use the name Australia, and the IP address that was dynamically assigned the new device is 172.16.29.103, you need to create an entry in the network configuration file that contains the ip host australia 172.16.29.103 command.

The file names used for the network configuration file are network-confg or cisconet.cfg. Routers running AutoInstall will try to load the network-confg from the TFTP server first. If the network-confg is not found on the TFTP server, the AutoInstall process will attempt to load the cisconet.cfg file. The cisconet.cfg filename was used by DOS-based TFTP servers that only supported the old 8.3 file naming convention. We recommend that you use the network-confg filename to avoid the delay that is created when AutoInstall has to timeout attempting to load the network-confg before it attempts to load the cisconet.cfg file.

If you use AutoInstall to set up multiple devices, you can create one network configuration file that contains an entry for each of the devices.

Host-Specific Configuration File

Host-specific configuration files are a full configuration for each new device. If you decide to use host-specific files, you must create a separate file for each new device that you are using AutoInstall to set up.

The filenames used for the host-specific configuration files are name-confg or name.cfg where the word name is replaced by the hostname of the router. For example, the filename for a router named hqrouter is hqrouter-confg or hqrouter.cfg.

Routers running AutoInstall will try to load the host-specific configuration filename using the format name-confg from the TFTP server first. If the name-confg file is not found on the TFTP server, the AutoInstall process will attempt to load the name.cfg file. The name.cfg file name format was used by DOS based TFTP servers that only supported the old 8.3 file naming convention. We recommend that you use the name-confg filename to avoid the delay that is created when AutoInstall has to timeout attempting to load the name-confg before it attempts to load the name.cfg file.


Tip If you use the name.cfg format for host-specific configuration files the filenames for hostnames that are longer than 8 characters must be truncated to the first eight characters. For example, the filename for a device with the hostname australia must be truncated to australi.cfg. When AutoInstall maps the IP address assigned to the new router to its hostname of australia in the network configuration file, AutoInstall will attempt to download a host-specific file with the name australi.cfg after it fails to load the host-specific filename austrailia-confg.



Tip Cisco recommends that you use the host-specific file option for setting up new devices to ensure that each new device is set up properly.


Default Configuration File

A default configuration file, which includes minimum configuration information allows you to telnet to the new device and configure it manually.


Tip If the new device has learned its hostname after it loaded the network configuration file the default configuration file is not used. You must use the host-specific file instead to configure features such as passwords for remote CLI sessions.


Figure 6 is an example of using the default configuration file to stage new routers for remote manual configuration. Routers A, B, and C are new routers that will be added to the network one at a time. You connect the first router and wait for it to load the default configuration file. The default configuration file must have enough information in it to allow the new router to communicate with the PC that you will be using to finish its configuration using a Telnet session. After the default configuration file is loaded on the new router, you can use Telnet to connect to the router to complete its configuration. You must assign a new, unique IP address to its interfaces so that the default configuration file can be used for configuring the next router.


Caution Failure to change the IP addresses in the router that you are configuring remotely with Telnet will result in duplicate IP addresses on the LAN when the next router loads the default configuration file. In this situation you will not be able to use Telnet to connect to either router. You must disconnect one of the routers before you can resolve this problem.

Figure 6 Example of Using the Default Configuration File To Stage Routers For Remote Manual Configuration


Tip You must include the commands for configuring passwords for remote Telnet access and access to privileged EXEC mode. If you are going to access the routers remotely to complete their configurations, save their configuration files to NVRAM.


The filenames used for the default network configuration file are router-confg or router.cfg. Routers running AutoInstall will try to load the router-confg from the TFTP server first. If the router-confg is not found on the TFTP server the AutoInstall process will attempt to load the router.cfg file. The router.cfg file name was used by DOS-based TFTP servers that only supported the old 8.3 file naming convention. We recommend that you use the router-confg filename to avoid the delay that is created when AutoInstall has to timeout while attempting to load the router-confg before it attempts to load the router.cfg file.

If you are using AutoInstall to configure LAN-attached devices, you can specify a different default boot filename in DHCP Option 067.

Configuration Options for AutoInstall

You can provision your network to support AutoInstall using several different combinations of devices and services. For example:

You can provision all of the services required for AutoInstall (except dynamic IP address assignment using SLARP or BOOTP that must be preformed by a Cisco router) on one network server, or you can provision each service on a different network server.

You can provision the DHCP service on a Cisco router.

The device using AutoInstall can determine its IP address from a DNS server, or you can use one of the AutoInstall network configuration files (network-confg or cisconet.cfg) that contain the ip host hostname ip-address commands.

You can use provision AutoInstall to load a full configuration or a partial configuration onto a device that is using AutoInstall.

This module focuses on some of the most common methods for provisioning AutoInstall. Refer to the "How to Use AutoInstall to Remotely Configure Cisco Networking Devices" section for information on the most common methods for provisioning AutoInstall.

The AutoInstall Process

The AutoInstall process begins when a networking device that does not have any files in its NVRAM is connected to the network.


Timesaver You can decrease the time that the AutoInstall process takes to complete by only connecting the interface on the networking device that you want to use for AutoInstall until the AutoInstall process has finished. For example, if you want the networking device to perform AutoInstall over a WAN interface and you connect its LAN interfaces and its WAN interfaces the networking device will attempt to perform AutoInstall over the LAN interfaces before it attempts to use the WAN interfaces. Leaving the LAN interfaces disconnected until the AutoInstall process is finished causes the networking device to initiate the AutoInstall process over its WAN interface immediately.


Figure 7 shows the basic flow of the AutoInstall process.

Figure 7 AutoInstall Process Flowchart

Benefits of Using AutoInstall to Remotely Configure a Cisco Networking Device

AutoInstall facilitates the deployment of Cisco routers by allowing you to manage the setup procedure for routers from a central location. The person responsible for physically installing the router does not require specific networking skills. The ability to physically install the router, connect the power and networking cables, and power it on are the only skills required by the installer. The configuration files are stored and managed on a central TFTP server. By using AutoInstall one skilled network technician based at a central site can manage the deployment of several routers in a short period of time.

Two enhancements to AutoInstall:

AutoInstall Using DHCP for LAN Interfaces

AutoInstall over Frame Relay-ATM Interworking Connections

AutoInstall Using DHCP for LAN Interfaces

The AutoInstall Using DHCP for LAN Interfaces feature enhances the benefits of AutoInstall by replacing the use of the Bootstrap Protocol (BOOTP) with the use of the Dynamic Host Configuration Protocol (DHCP) for Cisco IOS AutoInstall over LAN interfaces (specifically Ethernet, Token Ring, and FDDI interfaces).

DHCP (defined in RFC 2131) is an extension of the functionality provided by the BOOTP (defined in RFC 951). DHCP provides the framework for passing configuration information to hosts on a TCP/IP network. DHCP adds the capability of automatic allocation of reusable network addresses and additional configuration options. In Cisco IOS Release 12.1(5)T, and later releases, the IP address procurement phase of the AutoInstall process is now accomplished using DHCP for Ethernet, Token Ring, and FDDI interfaces. Prior to this release, IP addresses for LAN interfaces were obtained using BOOTP or RARP during the AutoInstall process. Additionally, this feature allows for the uploading of configuration files using unicast TFTP.

AutoInstall over Frame Relay-ATM Interworking Connections

The AutoInstall over Frame Relay-ATM Interworking Connections feature further enhances the benefits of AutoInstall by allowing you to use a router with an ATM interface as a BOOTP server for new routers being connected at remote locations.

How to Use AutoInstall to Remotely Configure Cisco Networking Devices

This section describes the how to prepare a router for AutoInstall, how to use AutoInstall with Frame Relay to ATM Service Internetworking, and how to use AutoInstall for new routers connected to LANs. Additional examples for using AutoInstall for new routers connected to LANs, HDLC WANs, and Frame Relay networks that do not use Frame Relay to ATM Service Internetworking, are provided in the "Configuration Examples for Using AutoInstall to Remotely Configure Cisco Networking Devices" section.

In most cases you need to configure a staging router through which a new device running AutoInstall sends TFTP, BOOTP, and DNS requests.


Tip In all cases, you must verify and save the configuration on the networking device after the AutoInstall process is complete. If you do not save the configuration, you must repeat the entire process.


Disabling the SDM Default Configuration File

Using AutoInstall with Frame Relay to ATM Service Internetworking

Using AutoInstall to Set Up Devices Connected to LANs

Disabling the SDM Default Configuration File

Perform this task if Security Device Manager (SDM) was preinstalled on your device and you want to use AutoInstall to configure the device instead. SDM remains on the device.

SUMMARY STEPS

1. Connect the console cable from the console port on the device to the serial port on the PC.

2. Connect the power supply to the device, plug the power supply into a power outlet, and turn on the device.

3. Connect to the device using a terminal emulation program.

4. enable

5. erase startup-config

6. reload

DETAILED STEPS


Step 1 Connect the console cable, shipped with your device, from the console port on the device to a serial port on your PC. Refer to the hardware installation guide for the device for instructions.

Step 2 Connect the power supply to the device, plug the power supply into a power outlet, and turn on the device. Refer to the quick start guide for the device for instructions.

Step 3 Use Hyperterminal or a similar terminal emulation program on your PC, with the following terminal emulation settings, to connect to the device:

9600 baud

8 data bits, no parity, 1 stop bit

No flow control

Step 4 enable

Enter privileged EXEC mode.

enable

Router> enable
Router#
 
   

Step 5 erase startup-config

Erases the existing configuration in NVRAM.

Router# erase startup-config
 
   

Step 6 reload

Initiates the reload process. The router will initiate the AutoInstall process after it finishes the reload process.

Router# reload
 
   

Using AutoInstall with Frame Relay to ATM Service Internetworking

Refer to figure 8 for the sample network used in this task. Perform this task to configure routers R6, R4, and the LS1010 ATM switch so that AutoInstall can be used with Frame Relay to ATM Service Internetworking (FRF8) to set up router R2.


Tip The IP address that will be assigned to Serial 0 on R2 (10.10.10.1/24) during and after the AutoInstall process and the IP address that is assigned to ATM 0/0.50 on R4 (10.10.10.2/24) are on the same subnet (10.10.10.0/24). Using IP addresses on the same subnet is required because the interfaces on R6 and the LS10101 switch are switching the IP packets between R2 and R4 at Layer 2.


Figure 8 Example Topology for AutoInstall over Frame Relay/ATM Interworking Connections

This sections contains the following tasks:

Configuring R6 for Frame Relay to ATM Service Internetworking

Verifying Frame Relay to ATM Service Internetworking on R6

Configuring R4 for Frame Relay to ATM Service Internetworking

Configuring IP Routing R4

Configuring the LS1010 Switch

Verifying AutoInstall with Frame Relay to ATM Service Internetworking

Configuring R6 for Frame Relay to ATM Service Internetworking

Router R6 does the Frame Relay to ATM Service Internetworking (FRF8) conversion for Frame Relay DLCI 50 to ATM VPI/VCI 5/50.


Note The serial interface and the ATM interface on R6 that are used for ATM Service Internetworking (FRF8) do not have IP addresses because they are used as Layer 2 switching interfaces in this configuration.


SUMMARY STEPS

1. enable

2. configure terminal

3. hostname hostname

4. interface serial interface-number

5. no ip address

6. encapsulation frame-relay ietf

7. frame-relay interface-dlci dlci switched

8. exit

9. frame-relay lmi-type ansi

10. frame-relay intf-type dce

11. exit

12. interface atm interface-number

13. no ip address

14. pvc vpi/vci qsaal

15. pvc vpi/vci ilmi

16. no atm ilmi-keepalive

17. pvc vpi/vci

18. encapsulation aal5mux fr-atm-srv

19. exit

20. exit

21. connect name serial slot/port dlci atm slot/port vpi/vci service-interworking

22. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

hostname hostname

Example:

Router(config)# hostname R6

Changes the name of the host (router) to R6.

Step 4 

interface serial interface-number

Example:

R6(config)# interface serial 3/0

Specifies the serial interface that connects to the router that is being set up with AutoInstall and enters interface configuration mode.

Step 5 

no ip address

Example:

R6(config-if)# no ip address

Removes an existing IP address.

Note This interface is used as a layer 2 switch interface in this configuration. It is not an IP layer 3 endpoint. Therefore it does not require an IP address.

Step 6 

encapsulation frame-relay ietf

Example:

R6(config-if)# encapsulation frame-relay IETF

Enables and specifies the Frame Relay encapsulation method.

Note Only the Frame Relay commands and keywords required for this task are described in this task. For more information on the other Frame Relay commands and keywords, refer to the Cisco IOS Wide-Area Networking Command Reference,

Step 7 

frame-relay interface-dlci dlci switched

Example:

R6(config-if)# frame-relay interface-dlci 50 switched

Specifies that the Frame Relay data-link connection identifier (DLCI) is switched and enters Frame Relay DLCI configuration mode.

Step 8 

exit

Example:

R6(config-fr-dlci)# exit

Exits Frame Relay DLCI configuration mode and enters interface configuration mode.

Step 9 

frame-relay lmi-type ansi

Example:

Router(config-if)# frame-relay lmi-type ansi

Specifies that the router should use Annex D defined by American National Standards Institute (ANSI) standard T1.617 as the LMI type.

Step 10 

frame-relay intf-type dce

Example:

R6(config-if)# frame-relay intf-type dce

Specifies that the router functions as a switch connected to a router.

Step 11 

exit

Example:

R6(config-if)# exit

Returns to global configuration mode.

Step 12 

interface atm interface-number

Example:

R6(config)# interface ATM4/0

Specifies the ATM interface and enters interface configuration mode.

Note Only the ATM commands and keywords required for this task are described in this task. For more information on the other Frame Relay commands and keywords refer to the Cisco IOS Asynchronous Transfer Mode Command Reference.

Step 13 

no ip address

Example:

R6(config-if)# no ip address

Removes an existing IP address.

Note This interface is used as a layer 2 switch interface in this configuration. It is not an IP layer 3 endpoint. Therefore it does not require an IP address.

Step 14 

pvc vpi/vci qsaal

Example:

R6(config-if)# pvc 0 5 qsaal

Configures a PVC for QSAAL1 signaling.

Step 15 

pvc vpi/vci ilmi

Example:

R6(config-if)# pvc 0 16 ilmi

Configures a PVC for ILMI signaling.

Step 16 

no atm ilmi-keepalive

Example:

R6(config-if)# no atm ilmi-keepalive

Disables ATM ILMI keep alives.

Step 17 

pvc vpi/vci

Example:

R6(config-if)# pvc 5/50

Configures the PVC. When configuring PVCs, configure the lowest available VPI and VCI numbers first and enters interface ATM VC configuration mode.

Note VCIs 0 to 31 on all VPIs are reserved.

Step 18 

encapsulation aal5mux fr-atm-srv

Example:

R6(config-if-atm-vc)# encapsulation aal5mux fr-atm-srv

Enables the Frame Relay and ATM internetworking service.

Step 19 

exit

Example:

R6(config-if-atm-vc)# exit

Exits interface ATM VC configuration mode and returns to interface configuration mode.

Step 20 

exit

Example:

R6(config-if)# exit

Returns to global configuration mode.

Step 21 

connect name serial slot/port dlci atm slot/port vpi/vci service-interworking

Example:

R6(config)# connect r2 serial3/0 50 ATM4/0 5/50 service-interworking

Creates the connection between the Frame Relay DLCI and the ATM PVC for the Frame Relay and ATM internetworking service and enters FRF .8 configuration mode.

Step 22 

end

Example:

R6(config-frf8)# end

Returns to privileged EXEC mode.

Verifying Frame Relay to ATM Service Internetworking on R6

Use the show connection name r2 command to verify whether the Service Interworking Connection is up.

The output of the show connection name r2 command indicates that the Service Interworking Connection is up.

R6# show connection name r2
 
   
FR/ATM Service Interworking Connection: r2
  Status    - UP
  Segment 1 - Serial3/0 DLCI 50
  Segment 2 - ATM4/0 VPI 5 VCI 50
Interworking Parameters -
    service translation
    efci-bit 0
    de-bit map-clp
    clp-bit map-de

Configuring R4 for Frame Relay to ATM Service Internetworking

R4 is one of the endpoints for Frame Relay to ATM Service Internetworking in this task. R2 is the other endpoint. R4 is not directly connected to the Frame Relay network. Therefore R4 requires only the ATM commands to act as the endpoint for Frame Relay to ATM Service Internetworking.

R4 is the core router that connects to the LAN with the TFTP server. R4 is the BOOTP server that will provide the IP address required for R2 (10.10.10.1/24) when R2 runs AutoInstall.

SUMMARY STEPS

1. enable

2. configure terminal

3. hostname hostname

4. interface ethernet module/slot/port

5. ip address ip-address mask

6. exit

7. interface atm interface-number

8. no ip address

9. pvc vpi/vci qsaal

10. pvc vpi/vci ilmi

11. no atm ilmi-keepalive

12. exit

13. interface atm slot/port.subinterface-number multipoint

14. ip address ip-address mask

15. ip helper-address ip-address

16. pvc vpi/vci

17. protocol ip ip-address broadcast

18. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

hostname hostname

Example:

Router(config)# hostname R4

Changes the name of the host (router) to R4.

Step 4 

interface ethernet module/slot/port

Example:

R4(config)# interface ethernet 3/0/0

Species the Ethernet interface and enters interface configuration mode.

Step 5 

ip address ip-address mask

Example:

R4(config-if)# ip address 172.16.29.97 255.255.255.0

Specifies the IP address for the interface.

Step 6 

exit

Example:

R4(config-if)# exit

Returns to global configuration mode.

Step 7 

interface atm interface-number

Example:

R4(config)# interface atm0/0

Species the ATM interface and enters interface configuration mode.

Note Only the ATM commands and keywords required for this task are described in this task. For more information on the other Frame Relay commands and keywords, refer to the Cisco IOS Asynchronous Transfer Mode Command Reference.

Step 8 

no ip address

Example:

R4(config-if)# no ip address

The main ATM interface does not require an IP address in this configuration. The IP address is assigned to the multipoint subinterface in Step 9.

Step 9 

pvc vpi/vci qsaal

Example:

R4(config-if)# pvc 0 5 qsaal

Configures a PVC for QSAAL1 signaling.

Step 10 

pvc vpi/vci ilmi

Example:

R4(config-if)# pvc 0 16 ilmi

Configures a PVC for ILMI signaling.

Step 11 

no atm ilmi-keepalive

Example:

R4(config-if)# no atm ilmi-keepalive

Disables ATM ILMI keep alives.

Step 12 

exit

Example:

R4(config-if)# exit

Returns to global configuration mode.

Step 13 

interface atm slot/port.subinterface-number multipoint

Example:

R4(config-if)# interface atm0/0.50 multipoint

Creates the ATM multipoint virtual subinterface and enters subinterface configuration mode.

Step 14 

ip address ip-address mask

Example:

R4(config-subif)# ip address 10.10.10.2 255.255.255.0

Specifies the IP address for the subinterface.

Step 15 

ip helper-address ip-address

Example:

R4(config-subif)# ip helper-address 172.16.29.252

Specifies the IP address of the TFTP server. This IP address is used to replace the 255.255.255.255 IP destination broadcast address that R2 will use when it attempts to establish a connection to the TFTP server.

Step 16 

pvc vpi/vci

Example:

R4(config-subif)# pvc 6/60

Configures the PVC. When configuring PVCs, configure the lowest available VPI and VCI numbers first and enters ATM VC configuration mode.

Note VCIs 0 to 31 on all VPIs are reserved.

Step 17 

protocol ip ip-address broadcast

Example:

R4(config-if-atm-vc)# protocol ip 10.10.10.1 broadcast

Specifies the IP address of the device at the other end of this PVC. In this example the device is R2.

For this example, this address is the IP address that will be assigned by the BOOTP server on R4 to R2 during the AutoInstall process.

Step 18 

end

Example:

R4(config-if-atm-vc)# end

Returns to privileged EXEC mode.

Configuring IP Routing R4

In order for R4 to be able to forward IP traffic between network 172.16.29.0 and R2 after the AutoInstall process is complete, R4 needs to have IP routing configured.


Note The configuration file for R2 provided in the "Creating the Configuration File for R2: Example" section includes the IP routing commands required to establish IP routing connectivity for R2 using RIP Version 2.


SUMMARY STEPS

1. enable

2. configure terminal

3. router rip

4. version version

5. network ip-network

6. Repeat Step 5 for the other IP networks.

7. no auto-summary

8. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router rip

Example:

Router(config)# router rip

Enables RIP routing on R4.

Note Only the RIP commands and keywords required for this task are described in this task. For more information on the other RIP commands and keywords, refer to the Cisco IOS Routing Protocols Command Reference.

Step 4 

version version

Example:

Router(config-router)# version 2

Specifies the version of RIP that the router will use.

Step 5 

network ip-network

Example:

Router(config-router)# network 172.16.0.0

Specifies the IP networks for which RIP will provide routing services.

Step 6 

Repeat Step 5 for the other IP networks.

Example:

Router(config-router)# network 10.0.0.0

Step 7 

no auto-summary

Example:

Router(config-router)# no auto-summary

Disables the default RIP V2 behavior of summarizing IP subnets in the routing advertisements.

Step 8 

end

Example:

Router(config-router)# end

Returns to privileged EXEC mode.

Configuring the LS1010 Switch

This task describes how to configure an LS1010 switch to route the PVCs between R6 and R4. R6 is connected to ATM 3/1/1 on the LS1010 switch. R4 is connected to ATM 3/1/2 on the LS1010 switch.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface atm module/slot/port

4. pvc vpi vci interface atm interface-number vpi vci

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface atm module/slot/port

Example:

Router(config)# interface ATM3/1/2

Species the ATM interface and enters interface configuration mode.

Note Only the LS1010 ATM commands and keywords required for this task are described in this task. For more information on the other ATM commands and keywords available on the LS1010, refer to the Lightstream 1010 ATM Switch Documents.

Step 4 

pvc vpi vci interface atm interface-number vpi vci

Example:

Router(config-if)# pvc 6 60 interface ATM3/1/1 5 50

Configures a static PVC route.

In this example, a route for the PVC from R6 (5/50) to R4 (6/60) is configured.

Step 5 

end

Example:

Router(config-if)# end

Returns to privileged EXEC mode.

Verifying AutoInstall with Frame Relay to ATM Service Internetworking

Perform this task to verify the AutoInstall with Frame Relay to ATM Service Internetworking configuration by setting up R2, as shown in Figure 8, using AutoInstall.

Prerequisites

The following prerequisites must be met before you can perform this task:

You must have a TFTP server on the network with the IP address that you specified on R4 with the ip helper-address ip-address command.

You must have a configuration file for R2 named r2-confg on the TFTP server.

You must have a network configuration named network-confg file with the ip host r2 10.10.10.1 command in it on the TFTP server.

You must have configured R6, R4 and the LS1010 ATM switch (or a functional equivalent of the ATM switch) following the instructions provided in the previous tasks in this section.

R2 must not have a configuration file in NVRAM.

SUMMARY STEPS


Step 1 Connect a console terminal to R2.

Step 2 Power cycle, or power on R2.

Step 3 Answer no, when the prompt to enter the initial configuration dialog appears.

Step 4 Answer no, when the prompt to terminate AutoInstall appears.

Step 5 The AutoInstall process can take several minutes to complete. Do not press any keys on R2's terminal session until AutoInstall has completed.

Step 6 Copy the running configuration to the startup-configuration with the copy running-configuration startup-configuration command.


DETAILED STEPS


Step 1 Connect a console terminal to R2.

Use Hyperterminal or a similar terminal emulation program on your PC, with the following terminal emulation settings, to connect to the device:

9600 baud

8 data bits, no parity, 1 stop bit

No flow control

Step 2 Power cycle, or power on R2.

Step 3 When the prompt to enter the initial configuration dialog appears, answer no.

Would you like to enter the initial configuration dialog? [yes/no]: no
 
   

Step 4 When the prompt to terminate AutoInstall appears answer no.

Would you like to terminate autoinstall? [yes]: no
 
   

AutoInstall will start.

Please Wait. Autoinstall being attempted over Serial0 !!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
   

Step 5 The AutoInstall process can take several minutes to complete. Do not press any keys on R2's terminal session until AutoInstall has completed.

This display output is from a successful Auto Installation process.


Note You can ignore the "%PARSER-4-BADCFG: Unexpected end of configuration file" error message. This problem does not adversely affect the AutoInstall process.



Note The last two lines with the %SYS-5-CONFIG_I messages indicate the network-confg and r2-confg files have been received successfully.


Press RETURN to get started!
 
   
*Mar  1 00:00:11.155: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
*Mar  1 00:00:11.159: %LINK-3-UPDOWN: Interface Serial0, changed state to up
*Mar  1 00:00:11.527: %LINK-3-UPDOWN: Interface Serial1, changed state to down
*Mar  1 00:00:12.271: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,changed 
state to up
*Mar  1 00:00:29.487: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
state to down
*Mar  1 00:00:32.347: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed 
state to up
*Mar  1 00:00:40.355: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed 
state to down
*Mar  1 00:00:45.551: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed 
state to up
*Mar  1 00:01:58.499: %IP-5-WEBINST_KILL: Terminating DNS process
*Mar  1 00:02:00.035: %LINK-5-CHANGED: Interface Ethernet0, changed state to 
administratively down
*Mar  1 00:02:00.039: %LINK-5-CHANGED: Interface Serial1, changed state to 
administratively down
*Mar  1 00:02:01.039: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed 
state to down
*Mar  1 00:02:50.635: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-IS-L), Version 12.3(13a), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Tue 26-Apr-05 12:52 by ssearch
*Mar  1 00:02:50.643: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing
 a cold start
*Mar  1 00:03:54.759: %PARSER-4-BADCFG: Unexpected end of configuration file.
 
   
*Mar  1 00:03:54.763: %SYS-5-CONFIG_I: Configured from tftp://172.16.29.252/network-confg 
by console
 
   
*Mar  1 00:04:12.747: %SYS-5-CONFIG_I: Configured from tftp://172.16.29.252/r2-confg by 
console
 
   

If you have logging enabled on your TFTP server the log should contain messages similar to the following text:

Sent network-confg to (10.10.10.1), 76 bytes
Sent r2-confg to (10.10.10.1),687 bytes
 
   

Step 6 Copy the running configuration to the startup configuration with the copy running-config startup-config command.


Troubleshooting

If after approximately five minutes you do not see the %SYS-5-CONFIG_I messages and R2 has a factory default prompt of Router>, the AutoInstall process failed.


Step 1 Look for error messages on the TFTP server indicating that the files were not found. A very common mistake is that the .txt extension was added to the r2-confg file (r2-confg.txt) by your text editor. Your operating system might be hiding the extension for known file types when you browse the TFTP root directory. Disable the Hide file extensions for known file types option.


Tip You can stop most text editors from adding the filename extension by saving the file with double quotes ("filename") around the filename. For example, saving the file as "r2-confg" should force the text editor to only use r2-confg.


Step 2 Test the connectivity in your network by configuring R2 with the configuration file that you created. You can copy the configuration for R2 to R2 by pasting it into the console terminal session.

After you have copied the configuration to R2, try to ping 10.10.10.2. If this fails, you have a problem between R2 and R4. Verify the cabling, the status of the interfaces, and the configurations on the routers.

If R2 can ping 10.10.10.2, try pinging the TFTP server (172.16.29.252) from R2. If this fails, you have a configuration problem somewhere between R4 and the TFTP server. Verify the cabling, the status of the interfaces, and the configurations on the routers. Verify the IP address and IP default gateway on the TFTP server.


Tip The IP default gateway on the TFTP server should be 172.16.29.97 (the local Ethernet interface on R4).


If R2 can ping the TFTP server (172.16.29.252), you probably have a problem with the TFTP server itself. A common mistake with TFTP servers is that they are configured to receive files but not to send them. Another common mistake on UNIX-based TFTP servers is that the files do not have the correct permissions. On a UNIX TFTP server the files should have permissions set to rw-rw-rw.

Step 3 If the IP connectivity appears to be working and the TFTP server is configured correctly, verify that you entered the ip helper-address ip-address command on R4 correctly.


Using AutoInstall to Set Up Devices Connected to LANs

Using AutoInstall to set up devices connected to LANs uses the network in Figure 9. This task shows how to use AutoInstall to set up routers R2, R3, and R4. Router R1 is the DHCP server that will assign the IP address for Ethernet 0 on the new routers during the AutoInstall process.

Figure 9 Network Topology for Assigning AutoInstall Configuration Files for Specific Devices

Every DHCP client has a unique DHCP client identifier. The DHCP client identifier is used by DHCP servers to keep track of IP address leases and for configuring IP address reservations. You need to know the DHCP client identifier for each of the networking devices that you want to configure with AutoInstall so that you can configure the DHCP IP address reservations which will ensure that each device is provided with the correct IP address, and subsequently its unique configuration file. You can determine the DHCP client identifier manually or automatically.

To use AutoInstall to set up routers R2, R3, and R4, perform following tasks:

Determining the Value for the DHCP Client Identifier Manually

Determining the Value for the DHCP Client Identifier Automatically

Determining the Value for the DHCP Client Identifier Manually

If you want to determine the value for the client identifiers automatically, you do not need to perform this task. Proceed to the "Determining the Value for the DHCP Client Identifier Automatically: Example" section.


Tip If you are using AutoInstall to configure networking devices that are running a Cisco IOS release other than 12.4(1) or newer the DHCP client identifier might use a different format. In this case use the process explained in the "Determining the Value for the DHCP Client Identifier Automatically: Example" section.


You must know the MAC address of the Ethernet interface that will be used to connect the router to the LAN during the AutoInstall process to determine the client identifier manually. To determine the client identifier manually requires connecting a terminal to the router, and powering it on, so that you can enter the show interface interface-type interface-number command.

The client-identifier looks like this:

0063.6973.636f.2d30.3030.362e.3533.6237.2e38.6537.312d.4661.332f.30

The format is nullcisco-0006.53b7.8e71-fa3/0 where 0006.53b7.8e71 is the MAC address and fa3/0 is the short interface name for the interface that the IP address request is made.

The values for the short-if-name field can be obtained from an SNMP workstation with the Cisco MIBs installed. The following is an example of how to map ifIndex to an interface on Cisco IOS:

snmpwalk -c public ponch ifName
IF-MIB::ifName.1 = STRING: AT2/0
IF-MIB::ifName.2 = STRING: Et0/0
IF-MIB::ifName.3 = STRING: Se0/0
IF-MIB::ifName.4 = STRING: BR0/0
 
   

Use the show interface interface-type interface-number command to display the information and statistics for a Fast Ethernet interface.

 
   
R6> show interface fastethernet 3/0
FastEthernet3/0 is up, line protocol is up
  Hardware is AmdFE, address is 0006.53b7.8e71 (bia 0006.53b7.8e71)
.
.
.
R6>
 
   

The MAC address for Fast Ethernet 3/0 on R6 is 0006.53b7.8e71. The format of the client identifier for this interface is nullcisco-0006.53b7.8e71-fa3/0.


Note The short interface name for Fast Ethernet interfaces is fa.


Table 1 shows the values for converting characters to their hexadecimal equivalents. The last row in Table 2 shows the client identifier for Fast Ethernet 3/0 on R6 (nullcisco-0006.53b7.8e71-fa3/0).

Table 1 Hexadecimal to Character Conversion Chart 

Hex
Char
Hex
Char
Hex
Char
Hex
Char
Hex
Char

00

NUL

1a

SUB

34

4

4e

N

68

h

01

SOH

1b

ESC

35

5

4f

O

69

I

02

STX

1c

FS

36

6

50

P

6a

j

03

ETX

1d

GS

37

7

51

Q

6b

k

04

EOT

1e

RS

38

8

52

R

6c

l

05

ENQ

1f

US

39

9

53

S

6d

m

06

ACK

20

 

3a

:

54

T

6e

n

07

BEL

21

!

3b

;

55

U

6f

o

08

BS

22

"

3c

56

V

70

p

09

TAB

23

#

3d

=

57

W

71

q

0A

LF

24

$

3e

58

X

72

r

0B

VT

25

%

3f

?

59

Y

73

s

0C

FF

26

&

40

@

5a

Z

74

t

0D

CR

27

`

41

A

5b

[

75

u

0E

SO

28

(

42

B

5c

\

76

v

0F

SI

29

)

43

C

5d

]

77

w

10

DLE

2a

*

44

D

5e

^

78

x

11

DC1

2b

+

45

E

5f

_

79

y

12

DC2

2c

,

46

F

60

`

7a

z

13

DC3

2d

-

47

G

61

a

7b

{

14

DC4

2e

.

48

H

62

b

7c

|

15

NAK

2f

/

49

I

63

c

7D

}

16

SYN

30

0

4a

J

64

d

7e

~

17

ETB

31

1

4b

K

65

e

7f

D

18

CAN

32

2

4c

L

66

f

   

19

EM

33

3

4d

M

67

g

   

Table 2 Conversion of nullcisco-0006.53b7.8e71-fa3/0 To A Client Identifier

00

c

i

s

c

o

-

0

0

0

6

.

5

3

b

7

.

8

e

7

1

-

f

a

3

/

0

00

63

69

73

63

6f

2d

30

30

30

36

2e

35

33

62

37

2e

38

65

37

31

2d

46

61

33

2f

30


R4

Use the show interface interface-type interface-number command to display the information and statistics for Ethernet 0 on R4.

 
   
R4> show interface ethernet 0
Ethernet0 is up, line protocol is up
  Hardware is Lance, address is 00e0.1eb8.eb0e (bia 00e0.1eb8.eb0e)
 
   

The MAC address for Ethernet 0 on R4 is 00e0.1eb8.eb0e. The format of the client identifier for this interface is nullcisco-00e0.1eb8.eb0e-et0.


Note The short interface name for Ethernet interfaces is et.


Using the values for converting characters to their hexadecimal equivalents in Table 1, the client identifier for Ethernet 0 on R4 is shown in the last row of Table 3.

Table 3 Conversion of null.cisco-00e0.1eb8.eb0e-et0 To A Client Identifier for R4

00

c

i

s

c

o

-

0

0

e

0

.

1

e

b

8

.

e

b

0

e

-

e

t

0

00

63

69

73

63

6f

2d

30

30

65

30

2e

31

65

62

38

2e

65

62

30

65

2d

45

74

30


R3

Use the show interface interface-type interface-number command to display the information and statistics for Ethernet 0 on R3.

 
   
R3> show interface ethernet 0
Ethernet0 is up, line protocol is up
  Hardware is Lance, address is 00e0.1eb8.eb73 (bia 00e0.1eb8.eb73)
 
   

The MAC address for Ethernet 0 on R3 is 00e0.1eb8.eb73. The format of the client identifier for this interface is: nullcisco-00e0.1eb8.eb73-et0.

Using the values for converting characters to their hexadecimal equivalents in Table 1, the client identifier for Ethernet 0 on R3 is shown in the last row of Table 4.

Table 4 Conversion of null.cisco-00e0.1eb8.eb73-et0 To A Client Identifier for R3

00

c

i

s

c

o

-

0

0

e

0

.

1

e

b

8

.

e

b

7

3

-

e

t

0

00

63

69

73

63

6f

2d

30

30

65

30

2e

31

65

62

38

2e

65

62

37

33

2d

45

74

30


R2

Use the show interface interface-type interface-number command to display the information and statistics for Ethernet 0 on R2.

R2> show interface ethernet 0
Ethernet0 is up, line protocol is up
  Hardware is Lance, address is 00e0.1eb8.eb09 (bia 00e0.1eb8.eb09)
 
   

The MAC address for Ethernet 0 on R2 is 00e0.1eb8.eb09. The format of the client identifier for this interface is nullcisco-00e0.1eb8.eb09-et0.

Using the values for converting characters to their hexadecimal equivalents in Table 1, the client identifier for Ethernet 0 on R2 is shown in the last row of Table 5

Table 5 Conversion of null.cisco-00e0.1eb8.eb09-et0 To A Client Identifier for R2

00

c

i

s

c

o

-

0

0

e

0

.

1

e

b

8

.

e

b

0

9

-

e

t

0

00

63

69

73

63

6f

2d

30

30

65

30

2e

31

65

62

38

2e

65

62

30

39

2d

45

74

30


You have now determined the values for the client identifiers on each router. The final step is to add a period after each group of four characters working from the left to the right as shown below:

R4-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30

R3-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30

R2-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30

What to Do Next

Save the values in a text file and proceed to the "Creating a Private DHCP Pool for Each of The Routers: Example" section.

Determining the Value for the DHCP Client Identifier Automatically

If you determined the value for the client identifiers manually, you do not need to perform this task. Proceed to the "Creating a Private DHCP Pool for Each of The Routers: Example" section.

This task will create a DHCP server on R1 that will provide only one IP address. This IP address will used by each new router in sequence while you determine the value of the router's client identifier. By limiting the IP address scope to a single IP address you avoid any possible confusion about which router you are working on. If somebody powers up another router that attempts to start the AutoInstall process, it will not be able to obtain an IP address.


Tip Do not place the network-confg or router configuration files (r4-confg, r3-confg, or r2-confg) in the root directory of the TFTP server yet. You do not want any of the routers to load these files until you have ensured that each router will obtain the correct IP address from the DHCP server so that the router will load the correct configuration file.


This task is broken down into subtasks. See the "Determining the Value for the DHCP Client Identifier Manually" section section for more information.

Configuration Examples for Using AutoInstall to Remotely Configure Cisco Networking Devices

This section provides the following configuration examples:

Using AutoInstall with Frame Relay to ATM Service Internetworking: Example

Using AutoInstall to Set Up Devices Connected to LANs: Example

Using AutoInstall to Set Up Devices Connected to WANs: Example

Using AutoInstall with Frame Relay to ATM Service Internetworking: Example

The following configuration examples show how to configure AutoInstall with Frame Relay to ATM service internetworking:

Configuring R6 for Frame Relay to ATM Service Internetworking: Example

Configuring R4 for Frame Relay to ATM Service Internetworking: Example

Configuring R4 for Frame Relay to ATM Service Internetworking: Example

Configuring the LS1010 Switch: Example

Creating the Configuration File for R2: Example

Configuring R6 for Frame Relay to ATM Service Internetworking: Example

The following example shows how to configure R6 for Frame Relay to ATM Service Internetworking (FRF8).

!
hostname R6
!
interface Serial3/0
 no ip address
 encapsulation frame-relay IETF
 frame-relay interface-dlci 50 switched
 frame-relay lmi-type ansi
 frame-relay intf-type dce
!
interface ATM4/0
 pvc 0 5 qsaal
 pvc 0 16 ilmi
 no atm ilmi-keepalive
 pvc 5/50 
  encapsulation aal5mux fr-atm-srv
!
connect r2 serial3/0 50 atm4/0 5/50 service-interworking
!

Configuring R4 for Frame Relay to ATM Service Internetworking: Example

The following example configures R4 as the core router for AutoInstall using Frame Relay to ATM Service Internetworking (FRF8).

!
hostname R4
!
interface FastEthernet3/0/0
 ip address 172.16.29.97 255.255.255.0
!
interface ATM0/0
 no ip address
 pvc 0 5 qsaal
 pvc 0 16 ilmi
 no atm ilmi-keepalive
!
interface ATM0/0.50 multipoint
 ip address 10.10.10.2 255.255.255.0
 ip helper-address 172.16.29.252
 pvc 6/60 
  protocol ip 10.10.10.1 broadcast
 !
!

Configuring R4 for Frame Relay to ATM Service Internetworking: Example

The following example shows how to configure IP routing on R4.

!
router rip
 version 2
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary

!

Configuring the LS1010 Switch: Example

The following example shows how to configure the LS1010 ATM switch to route the PVCs between R6 and R4.

!
atm address 47.0091.8100.0000.0010.11b9.6101.0010.11b9.6101.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
interface ATM2/0/0
 no ip address
 no ip directed-broadcast
 atm maxvp-number 0
!
interface ATM3/1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM3/1/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM3/1/2
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 6 60 interface ATM3/1/1 5 50 
!
interface ATM3/1/3
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!

Creating the Configuration File for R2: Example

This section provides the content for the configuration file for R2.

SUMMARY STEPS

1. Create the configuration file for R2 using the information provided.

2. Store the configuration file on the TFTP server with the name r2-confg.

DETAILED STEPS


Step 1 Create the following configuration file for R2.

!
hostname R2
!
!
enable secret 7gD2A0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 10.10.10.1 255.255.255.0
 encapsulation frame-relay IETF
 frame-relay map ip 10.10.10.2 50 broadcast
 frame-relay interface-dlci 50
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
!
ip http server
ip classless
!
line vty 0 4
 password 87F3c0m
 login
!
end
 
   

Step 2 Store the configuration file on the TFTP server with the name r2-confg.

Router# copy running-config tftp:
Address or name of remote host []? 192.0.2.1
Destination filename [running-config]? r2-config
!!!
1030 bytes copied in 9.612 secs (107 bytes/sec)
Router#

Using AutoInstall to Set Up Devices Connected to LANs: Example

The following configuration examples show how to use AutoInstall to set up devices connected to LANs:

Determining the Value for the DHCP Client Identifier Automatically: Example

Creating a Private DHCP Pool for Each of The Routers: Example

Creating Configuration Files for Each Router: Example

Creating the network-confg file: Example

Setting Up the Routers with AutoInstall: Example

Saving the Configuration Files on the Routers: Example

Removing the Private DHCP Address Pools from R1: Example

Determining the Value for the DHCP Client Identifier Automatically: Example

The following configuration examples show how to determine the value for the DHCP client identifier automatically:

Configuring IP on the Interfaces on R1: Example

Configuring a DHCP Pool on R1: Example

Excluding All But One of the IP Addresses from the DHCP Pool on R1: Example

Verifying the Configuration on R1: Example

Enabling debug ip dhcp server events on R1: Example

Identifying the Value for the Client Identifier on Each of the Routers: Example

Removing the DHCP Pool on R1 for Network 172.16.28.0/24: Example

Removing the DHCP Pool on R1 for Network 172.16.28.0/24: Example

Removing the Excluded Address Range From R1: Example

Configuring IP on the Interfaces on R1: Example

The following example shows how to configure the ip helper-address ip-address command on Ethernet0/1.

!
interface Ethernet0/0
 ip address 172.16.29.99 255.255.255.0
!
interface Ethernet0/1
 ip address 172.16.28.99 255.255.255.0
 ip helper-address 172.16.29.252
!

Configuring a DHCP Pool on R1: Example

The following example shows how to configure the commands to set up a temporary DHCP server on R1.


Note There should be only one DHCP server in operation on R1. This server should be the only DHCP server that is accessible by the routers that you will be using AutoInstall to set up.


!
ip dhcp pool get-client-id
   network 172.16.28.0 255.255.255.0
!

Excluding All But One of the IP Addresses from the DHCP Pool on R1: Example

The following example shows how to configure the ip dhcp excluded-address command to exclude every IP address except 172.16.28.1 from the DHCP pool.


Note You need to ensure that there is only one IP address available from the DHCP server at any time.


!
ip dhcp excluded-address 172.16.28.2 172.16.28.255
!

Verifying the Configuration on R1: Example

The following example shows how to verify the configuration on R1.

Verify that the configuration file for R1 has a DHCP server pool configured to provide a single IP address (172.16.28.1) to a DHCP client.

Verify that the configuration file has the IP addresses for the Ethernet interfaces and the ip helper-address ip-address command.

!
ip dhcp excluded-address 172.16.28.2 172.16.28.255
!
ip dhcp pool get-client-id
   network 172.16.28.0 255.255.255.0
!
interface Ethernet0/0
 ip address 172.16.29.99 255.255.255.0
!
interface Ethernet0/1
 ip address 172.16.28.99 255.255.255.0
 ip helper-address 172.16.29.252
!

Enabling debug ip dhcp server events on R1: Example

The following example shows how to enable the debug ip dhcp server events command on R1.

Use the display output from the debug ip dhcp server events command on the terminal connected to R1 to identify the value of the client identifier for each router.

R1# debug ip dhcp server events

Identifying the Value for the Client Identifier on Each of the Routers: Example

The following example shows how to identify the value for the client identifier on each of the routers.

The following step is repeated for each of the routers. You should have only one of the routers powered-on at any time. When you have identified the value of the client identifier field for the router, turn the router off and proceed to the next router.

R4

Connect R4 to the Ethernet network and power it on. The following message is displayed on the terminal connected to R1 when R4 is assigned the IP address 172.16.28.1.

DHCPD: assigned IP address 172.16.28.1 to client 
0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30.
 
   

Copy the client identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30 to a text file and save it. Keep the text file open for the next two routers.

Turn off R4

Release the IP address binding for R4 from the DHCP pool on R1 using the clear ip dhcp binding * command on R1.

R1# clear ip dhcp binding *
R1#
01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.

R3

Connect R3 to the Ethernet network and power it on. The following message is displayed on the terminal connected to R1 when R3 is assigned the IP address 172.16.28.1.

DHCPD: assigned IP address 172.16.28.1 to client 
0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30.
 
   

Copy the client identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30 to the text file and save it. Keep the text file open for the final router.

Turn off R3.

Release the IP address binding for R3 from the DHCP pool on R1 using the clear ip dhcp binding * command on R1.

R1# clear ip dhcp binding *
R1#
01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.

R2

Connect R2 to the Ethernet network and power it on. The following message is displayed on the terminal connected to R1 when R2 is assigned the IP address 172.16.28.1.

DHCPD: assigned IP address 172.16.28.1 to client 
0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30.
 
   

Copy the client identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30 to the text file and save it.

Turn off R2

Release the IP address binding for R2 from the DHCP pool on R1 using the clear ip dhcp binding * command on R1.

R1# clear ip dhcp binding *
R1#
01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.

Client Identifiers for R4, R3, and R2

You have determined the values for the client identifiers on each router.

R4-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30

R3-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30

R2-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30

Removing the DHCP Pool on R1 for Network 172.16.28.0/24: Example

The following example shows how to remove the temporary DHCP pool on the router that is no longer required.

R1(config)# no ip dhcp pool get-client-id

Removing the Excluded Address Range From R1: Example

The following example shows how to remove the command for excluding all of the IP addresses except 172.16.28.1 from the DHCP pool on the router.

R1(config)# no ip dhcp excluded-address 172.16.28.2 172.16.28.255

Creating a Private DHCP Pool for Each of The Routers: Example

The following example shows how to create private DHCP address pools for each router to ensure that each router is assigned the IP address that maps to its host name in the network-configuration file.

!
ip dhcp pool r4
   host 172.16.28.100 255.255.255.0
   client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30
 
   
!
ip dhcp pool r3
   host 172.16.28.101 255.255.255.0
   client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30
 
   
!
ip dhcp pool r2
   host 172.16.28.102 255.255.255.0
   client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30

Creating Configuration Files for Each Router: Example

The following example shows how to create the configuration files for each router and place them in the root directory of the TFTP server.


Tip You must include the commands for configuring passwords for remote Telnet access and access to privileged EXEC mode if you are going to access the routers remotely to save their configuration files to NVRAM.


r2-confg

!
hostname R2
!
enable secret 7gD2A0
!
interface Ethernet0
 ip address 172.16.28.102 255.255.255.0
!
interface Serial0
 ip address 192.168.100.1 255.255.255.252
 no shutdown
!
interface Serial1
 ip address 192.168.100.5 255.255.255.252
 no shutdown
!
no ip http server
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
line vty 0 4
 password 5Rf1k9
 login
!
end
 
   

r3-confg

!
hostname R3
!
enable secret 7gD2A0
!
interface Ethernet0
 ip address 172.16.28.101 255.255.255.0
!
interface Serial0
 ip address 192.168.100.9 255.255.255.252
 no shutdown
!
interface Serial1
 ip address 192.168.100.13 255.255.255.252
 no shutdown
!
no ip http server
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
line vty 0 4
 password 5Rf1k9
 login
!
end
 
   

r4-confg

!
hostname R3
!
enable secret 7gD2A0
!
interface Ethernet0
 ip address 172.16.28.101 255.255.255.0
!
interface Serial0
 ip address 192.168.100.9 255.255.255.252
 no shutdown
!
interface Serial1
 ip address 192.168.100.13 255.255.255.252
 no shutdown
!
no ip http server
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
line vty 0 4
 password 5Rf1k9
 login
!
end

Creating the network-confg file: Example

The following example shows how to create the network-configuration file with the ip host hostname ip-address commands that map the IP addresses that you will be assigning with the DHCP server to the hostname.

ip host r4 172.16.28.100
ip host r3 172.16.28.101
ip host r2 172.16.28.102

Setting Up the Routers with AutoInstall: Example

The following example shows how to set up three routers (R4, R3, and R2) using AutoInstall.

Connect a terminal to the routers if you want to monitor the progress of AutoInstall. Use Hyperterminal or a similar terminal emulation program on your PC, with the following terminal emulation settings, to connect to the device:

9600 baud

8 data bits, no parity, 1 stop bit

No flow control

You should have the following files in the root directory of the TFTP server.

network-confg

r4-confg

r3-confg

r2-confg

The TFTP server must be running.

Power on each router.


Timesaver You can set up all three routers concurrently.


R4

The following is an excerpt of the messages that are displayed on R4's console terminal during the AutoInstall process:

Loading network-confg from 172.16.29.252 (via Ethernet0): !
[OK - 76 bytes]
Configuration mapped ip address 172.16.28.100 to r4
Loading r4-confg from 172.16.29.252 (via Ethernet0): !
[OK - 687 bytes]

R3

The following is an excerpt of the messages that are displayed on R3's console terminal during the AutoInstall process:

Loading network-confg from 172.16.29.252 (via Ethernet0): !
[OK - 76 bytes]
Configuration mapped ip address 172.16.28.101 to r3
Loading r3-confg from 172.16.29.252 (via Ethernet0): !
[OK - 687 bytes]

R2

The following is an excerpt of the messages that are displayed on R2's console terminal during the AutoInstall process:

Loading network-confg from 172.16.29.252 (via Ethernet0): !
[OK - 76 bytes]
Configuration mapped ip address 172.16.28.102 to r2
Loading r2-confg from 172.16.29.252 (via Ethernet0): !
[OK - 687 bytes]

TFTP Server Log

The TFTP server log should contain messages similar to the following text.

Sent network-confg to (172.16.28.100), 76 bytes
Sent r4-confg to (172.16.28.100),687 bytes
Sent network-confg to (172.16.28.101), 76 bytes
Sent r3-confg to (172.16.28.101),687 bytes
Sent network-confg to (172.16.28.102), 76 bytes
Sent r2-confg to (172.16.28.102),687 bytes

Saving the Configuration Files on the Routers: Example

The following example shows how to save the running configurations on each router to the startup configuration to ensure that the routers retain their configurations if they are ever power cycled.

R4

R1# telnet 172.16.28.100
Trying 172.16.28.100 ... Open
 
   
 
   
User Access Verification
 
   
Password:
R4> enable
Password:
 
   
R4# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R4# exit
 
   
[Connection to 172.16.28.100 closed by foreign host]
R1#

R3

R1# telnet 172.16.28.101
Trying 172.16.28.101 ... Open
 
   
 
   
User Access Verification
 
   
Password:
R3> enable
Password:
 
   
R3# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R3# exit
 
   
[Connection to 172.16.28.101 closed by foreign host]
R1#
 
   

R2

R1# telnet 172.16.28.102
Trying 172.16.28.102 ... Open
 
   
 
   
User Access Verification
 
   
Password:
R2> enable
Password:
 
   
R2# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R2# exit
 
   
[Connection to 172.16.28.102 closed by foreign host]
R1#

Removing the Private DHCP Address Pools from R1: Example

The following example shows how to remove the private DHCP address pools from R1.

R1(config)# no ip dhcp pool r4
R1(config)# no ip dhcp pool r3
R1(config)# no ip dhcp pool r2
 
   

This task is the final step for using AutoInstall to set up devices connected to LANs.

Using AutoInstall to Set Up Devices Connected to WANs: Example

The following configuration examples show how to use AutoInstall to set up devices connected to WANs:

HDLC WAN Connections: Example

Frame-Relay WAN Connections: Example

HDLC WAN Connections: Example

The following example shows uses the network in Figure 10. The example shows how to use AutoInstall to set up R4. R2 will use SLARP to provide R4 the IP address (192.168.20.2) required for AutoInstall.

Figure 10 Network Topology Using AutoInstall to Configure Routers Connected to HDLC WANs

The following examples show how to use AutoInstall to set up router R2:

Creating the Configuration for R4 : Example

Creating the network-confg File: Example

Configuring R1 and R2: Example

Setting Up R4 using AutoInstall: Example

Save the Configuration File on R4: Example

Creating the Configuration for R4 : Example

The following example shows how to create the configuration file for R4 and save it on the TFTP server as r4-confg:

!
hostname R4
!
enable secret 7gD2A0
!
interface Ethernet0
 ip address 10.89.45.1 255.255.255.0
 no shutdown
!
interface Serial0
 ip address 192.168.10.2 255.255.255.0
 no fair-queue
!
router rip
 version 2
 network 168.192.0.0
 no auto-summary
!
ip http server
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Serial0
!
line vty 0 4
password 6T2daX9
!
end

Creating the network-confg File: Example

The following example shows how to create the network configuration file for R4 and save it on the TFTP server as network-confg:

ip host r4 192.168.10.2

Configuring R1 and R2: Example

The following example shows how to configure R1 and R2 using the following configurations:

R1

!
hostname R1
!
enable secret 7gD2A0
!
interface Ethernet0/0
 ip address 172.16.29.99 255.255.255.0
!
interface Ethernet0/1
 ip address 172.16.28.99 255.255.255.0
!
interface Serial2
 ip helper-address 172.16.29.252
!
router rip
 version 2
 network 172.16.0.0
 no auto-summary
!
ip classless
ip http server
!
line vty 0 4
 password 67F2SaB
!
end

R2

!
hostname R2
!
enable secret 7gD2A0
!
interface Ethernet0
 ip address 172.16.28.98 255.255.255.0
!
interface Serial1
 ip address 192.168.10.1 255.255.255.0
 clockrate 64000
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.10.0
 no auto-summary
!
ip http server
ip classless
!
line vty 0 4
 password u58Hg1
!
end

Setting Up R4 using AutoInstall: Example

The following example shows how to set up R4 using AutoInstall.

Connect R4 to the HDLC WAN network.

Power R4 on.

The AutoInstall process should be complete in approximately 5 minutes.

TFTP Server Log

The TFTP server log should contain messages similar to the following text:

Sent network-confg to (192.168.10.2), 76 bytes
Sent r4-confg to (192.168.10.2),687 bytes

Save the Configuration File on R4: Example

The following example shows how to save the running configurations on R4 to the startup configuration to ensure that R4 retains its configuration if it is ever power cycled.

R1# telnet 192.168.10.2
Trying 192.168.10.2 ... Open
 
   
User Access Verification
 
   
Password:
R4> enable
Password:
 
   
R4# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R4# exit
 
   
[Connection to 192.168.10.2 closed by foreign host]
R1#

Frame-Relay WAN Connections: Example

This example uses the network in Figure 11. This example shows how to use AutoInstall to set up R4.

R2 uses BOOTP to provide R4 the IP address (172.16.27.100) required for AutoInstall. R2 uses 172.16.27.100 as the IP address to provide to R3 using BOOTP because this is the IP address in the frame-relay map ip 172.16.27.100 100 broadcast command on serial 0 that points to serial 0 on R3.

Figure 11 Network Topology for Using AutoInstall to Configure Routers Connected to Frame Relay WANs

The following examples show how to use AutoInstall to set up router R3:

Creating the Configuration for R3: Example

Creating the network-confg File: Example

Configuring R1 and R2: Example

Setting Up R3 using AutoInstall: Example

Saving the Configuration File on R3: Example

Creating the Configuration for R3: Example

The following example shows how to create the configuration file for R4 and save it on the TFTP server as r3-confg:

!
hostname R3
!
enable secret 8Hg5Zc20
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.27.100 255.255.255.0
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay map ip 172.16.27.99 101 broadcast
 frame-relay interface-dlci 101
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 no auto-summary
!
line vty 0 4
 password 67Td3a
 login
!
end

Creating the network-confg File: Example

The following example shows how to create the network configuration file for R3 and save in on the TFTP server as network-confg:

ip host r3 172.16.27.100

Configuring R1 and R2: Example

The following example shows how to configure R1 and R2 using the following configurations:

R1

!
hostname R1
!
enable secret 86vC7Z
!
interface Ethernet0/0
 ip address 172.16.29.99 255.255.255.0
!
interface Ethernet0/1
 ip address 172.16.28.99 255.255.255.0
!
router rip
 version 2
 network 172.16.0.0
 no auto-summary
!
line vty 0 4
 password 6Gu8z0s
!
!
end

R2

!
hostname R2
!
enable secret 67Hfc5z2
!
interface Ethernet0
 ip address 172.16.28.98 255.255.255.0
 ip helper-address 172.16.29.252
!
interface Serial0
 ip address 172.16.27.99 255.255.255.0
 ip helper-address 172.16.29.252
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay map ip 172.16.27.100 100 broadcast
 frame-relay interface-dlci 100
!
interface Serial1
 no ip address
!
router rip
 version 2
 network 172.16.0.0
 no auto-summary
!
line vty 0 4
 password 9Jb6Z3g
!
end

Setting Up R3 using AutoInstall: Example

The following example shows how to set up R3 using AutoInstall.

Connect R3 to the Frame Relay network.

Power R3 on.

The AutoInstall process should be complete in approximately 5 minutes.

TFTP Server Log

The TFTP server log should contain messages similar to the following text:

Sent network-confg to (172.16.27.100), 76 bytes
Sent r3-confg to (172.16.27.100),687 bytes

Saving the Configuration File on R3: Example

The following example shows how to save the running configurations on R3 to the startup configuration to ensure that R3 retains its configuration if it is ever power cycled.

R1# telnet 172.16.27.100
Trying 172.16.27.100 ... Open
 
   
User Access Verification
 
   
Password:
R3> enable
Password:
 
   
R3# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R4# exit
 
   
[Connection to 192.168.10.2 closed by foreign host]
R1#

Additional References

The following sections provide references related to using AutoInstall to remotely configure Cisco networking devices.

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Configuration Fundamentals commands

Cisco IOS Configuration Fundamentals Command Reference

Frame Relay-to-ATM Service Interworking (FRF.8)

Frame Relay-ATM Interworking Supported Standards module in the Cisco IOS Wide-Area Networking Configuration Guide

Configuring Frame Relay-ATM Interworking module in the Cisco IOS Wide-Area Networking Configuration Guide

Overview of Cisco IOS setup mode and AutoInstall for configuring Cisco networking devices

Overview: Basic Configuration of a Cisco Networking Device module in the Cisco IOS Configuration Fundamentals Configuration Guide

Using setup mode to configure a Cisco networking device

Using Setup Mode to Configure a Cisco Networking Device module in the Cisco IOS Configuration Fundamentals Configuration Guide


MIBs

MIB
MIBs Link

IF-MIB

The IFNAME object in the IF-MIB can be used to identify the values for the short interface names used in the DHCP Client Identifier for Cisco IOS devices when they are configured as DHCP clients.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for Using AutoInstall to Remotely Configure a Cisco Networking Device

Table 6 lists the features in this module and provides links to specific configuration information. Only features that were introduced or modified in Cisco IOS Release 12.2(1) or 12.0(3)S or a later release appear in the table.

Not all commands may be available in your Cisco IOS software release. For details on when support for a specific command was introduced, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note Table 6 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 6 Feature Information for Using AutoInstall to Remotely Set Up a Cisco Networking Device 

Feature Name
Releases
Feature Configuration Information

AutoInstall over Frame Relay-ATM Interworking Connections

12.2(4)T

The AutoInstall over Frame Relay-ATM Interworking Connections feature extends the functionality of the existing Cisco IOS AutoInstall feature. While AutoInstall over Frame Relay encapsulated serial interfaces has long been supported, this feature provides the same functionality when the central (existing) router has an ATM interface instead of a Frame Relay interface.

The following sections provide information about this feature:

Intermediate Frame Relay-ATM Switching Device

Using AutoInstall with Frame Relay to ATM Service Internetworking

No new or modified commands are introduced with this feature. All commands used with this feature are documented in the Cisco IOS Configuration Fundamentals Command Reference.

AutoInstall Using DHCP for LAN Interfaces

12.1(5)T
12.2(33)SRC

The AutoInstall Using DHCP for LAN Interfaces feature enhances the benefits of AutoInstall by replacing the use of the Bootstrap Protocol (BOOTP) with the use of the Dynamic Host Configuration Protocol (DHCP) for Cisco IOS AutoInstall over LAN interfaces (specifically Ethernet, Token Ring, and FDDI interfaces).

The following section provides information about this feature:

AutoInstall Using DHCP for LAN Interfaces