Dial Configuration Guide, Cisco IOS XE Release 3S
IPv6 Cisco Express Forwarding Switching on Dialer Interfaces
Downloads: This chapterpdf (PDF - 150.0KB) | Feedback

IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Table Of Contents

IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Finding Feature Information

Restrictions for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Information About IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Dialer Watch

IPv6 Cisco Express Forwarding

Cisco Express Forwarding with IPv4 and IPv6 Packets

How to Configure IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Configuring Cisco Express Forwarding Switching of IPv6 Traffic

Configuration Examples for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Example: Configuring the Cisco Express Forwarding Switching of IPv6 Traffic

Example: Configuring the Dialer Watch to Monitor IPv6 Addresses

Example: Configuring the Dialer Watch to Monitor IPv6 Addresses and VRF Pairs

Example: Sample Configuration of IPv4 and IPv6 Cisco Express Forwarding on Dialer Interfaces

Additional References

Related Documents

MIBs

Technical Assistance

Feature Information for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces


IPv6 Cisco Express Forwarding Switching on Dialer Interfaces


First Published: March 16, 2012
Last Updated: April 04, 2013

The IPv6 Cisco Express Forwarding Switching on Dialer Interfaces feature allows Cisco Express Forwarding switching of IPv6 traffic on dialer interfaces.

Finding Feature Information

Restrictions for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Information About IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

How to Configure IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Configuration Examples for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Additional References

Feature Information for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Restrictions for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

IPv6 Cisco Express Forwarding switching is supported only on dialer-profile configuration. IPv6 Cisco Express Forwarding switching is not supported on dialer-legacy and dialer-rotary configurations because there is no mechanism for peer global prefix negotiation. For dialer-legacy and dialer-rotary configurations, the IPv6 packets are process switched.

Information About IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Dialer Watch

IPv6 Cisco Express Forwarding

Cisco Express Forwarding with IPv4 and IPv6 Packets

Dialer Watch

Dialer watch is a method of implementing redundancy or a backup system in case of a router failure. By configuring a set of watched routes that define the primary interface, you can monitor the status of the primary interfaces while watched routes are added or deleted.

The monitoring is performed in the following sequence:

1. Whenever a watched route is deleted, the dialer watch mechanism checks for a valid route for any of the defined watched IP addresses.

2. If no valid route exists, the primary link is considered down and unusable.

3. If a valid route exists for at least one of the defined IP addresses, and if the route is pointing to an interface other than the backup interface configured for dialer watch, the primary link is considered as up.

4. If the primary link goes down, the dialer watch is immediately notified by the routing protocol and the secondary link is brought up.

5. When the secondary link is up, after the idle timeout expires, the status of the primary link is rechecked.

6. If the primary link remains down, the idle timer is reset.

7. If the primary link is up, the secondary backup link is disconnected. By using the dialer watch-list delay command, you can create a delay for the secondary link to be disconnected after the primary link is reestablished.

IPv6 Cisco Express Forwarding

Cisco Express Forwarding is used to switch IPv6 packets on dialer interfaces. IPv6 packets are Cisco Express Forwarding-switched in inbound and outbound traffic, irrespective of the dialer mode.

Cisco Express Forwarding support for inbound traffic on dialer interfaces requires the virtual-access interfaces supporting the dialer to be IPv6-enabled and available in the same VPN routing and forwarding (VRF) instance as the dialer interface.

With CSCtk62149, the IPv6 Cisco Express Forwarding Switching on Dialer Interfaces feature is supported. For information about the Cisco Express Forwarding of IPv4 Traffic on Dialer Interfaces feature, see the "Configuring Dialer Cisco Express Forwarding" module in the Dial Technologies Configuration Guide.

Cisco Express Forwarding with IPv4 and IPv6 Packets

When both IPv4 and IPv6 are configured on a peer, the IP Control Protocol (IPCP) negotiates with a peer IPv4 address, and the IPv6CP negotiates with the interface and forms the peer link local address. When the PPP negotiation is successful, the IPv4 and IPv6 adjacency is complete on the dialer, thereby enabling Cisco Express Forwarding switching of IPv4 and IPv6 packets to the peer.

How to Configure IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Configuring Cisco Express Forwarding Switching of IPv6 Traffic

Configuring Cisco Express Forwarding Switching of IPv6 Traffic

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ipv6 address ipv6-address-prefix

5. ipv6 enable

6. exit

7. ipv6 unicast-routing

8. ipv6 cef

9. dialer watch-list group-number ipv6 ipv6-address ipv6-address-mask [vrf vrf-name]

10. Repeat Step 9 to define watch-list for each IPv6 address or IPv6-VRF pair to be monitored.

11. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Device> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Device(config)# interface dialer 2

Specifies the interface type and number and enters interface configuration mode.

Step 4 

ipv6 address ipv6-address-prefix

Example:

Device(config-if)# ipv6 address 2001:DB8:0:ABCD::1/64

Assigns an IPv6 address to the interface.

Step 5 

ipv6 enable

Example:

Device(config-if)# ipv6 enable

Enables IPv6 processing on the interface.

Step 6 

exit

Example:

Device(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 7 

ipv6 unicast-routing

Example:

Device(config)# ipv6 unicast-routing

Enables the forwarding of IPv6 unicast datagrams.

Step 8 

ipv6 cef

Example:

Device(config)# ipv6 cef

Enables Cisco Express Forwarding globally on the device.

Step 9 

dialer watch-list group-number ipv6 ipv6-address ipv6-address-mask [vrf vrf-name]

Example:

Device(config)# dialer watch-list 4 ipv6 2001:DB8:0:ABCD::1 FFFF:FFFF::

Defines the IPv6 adress route to be watched.

If the VRF instance is specified, this command defines the IPv6 address and the VRF instance pair to be monitored.

Step 10 

Repeat Step 9 to define watch-list for each IPv6 address or IPv6-VRF pair to be monitored.

Step 11 

exit

Example:

Device(config)# exit

Exits global configuration mode and returns to privileged EXEC mode.

Configuration Examples for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Example: Configuring the Cisco Express Forwarding Switching of IPv6 Traffic

Example: Configuring the Dialer Watch to Monitor IPv6 Addresses

Example: Configuring the Dialer Watch to Monitor IPv6 Addresses and VRF Pairs

Example: Sample Configuration of IPv4 and IPv6 Cisco Express Forwarding on Dialer Interfaces

Example: Configuring the Cisco Express Forwarding Switching of IPv6 Traffic

Device# configure terminal
Device(config)# interface dialer 2 
Device(config-if)# ipv6 address 2001:DB8:0:ABCD::1/64
Device(config-if)# ipv6 enable 
Device(config-if)# exit
Device(config)# ipv6 unicast-routing
Device(config)# ipv6 cef
Device(config)# dialer watch-list 4 ipv6 2001:DB8:0:ABCD::1 FFFF:FFFF::
Device(config)# dialer watch-list 4 ipv6 2001:DB8:0:ABCD::8 FFFF:FFFF:: vrf vrf4
Device(config)# exit

Example: Configuring the Dialer Watch to Monitor IPv6 Addresses

Device# configure terminal
Device(config)# dialer watch-list 1 ipv6 2001:DB8:0:ABCD::1 FFFF:FFFF::
Device(config)# dialer watch-list 1 ipv6 2001:DB8:0:ABCD::2 FFFF:FFFF::
Device(config)# dialer watch-list 1 ipv6 2001:DB8:0:ABCD::3 FFFF:FFFF::
Device(config)# exit

Example: Configuring the Dialer Watch to Monitor IPv6 Addresses and VRF Pairs

Device# configure terminal
Device(config)# dialer watch-list 2 ipv6 2001:DB8:0:ABCD::1 FFFF:FFFF::
Device(config)# dialer watch-list 2 ipv6 2001:DB8:0:ABCD::2 FFFF:FFFF:: vrf vrf1
Device(config)# dialer watch-list 2 ipv6 2001:DB8:0:ABCD::3 FFFF:FFFF:: vrf vrf2
Device(config)# exit

Example: Sample Configuration of IPv4 and IPv6 Cisco Express Forwarding on Dialer Interfaces

Device# show running-config interface dialer 1
 
   
Building configuration...
 
   
Current configuration : 1473 bytes
!
! Last configuration change at 08:53:54 IST Tue Feb 14 2012
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r601
!
boot-start-marker
boot-end-marker
!
no aaa new-model
clock timezone IST 0 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
ip cef
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
isdn switch-type primary-5ess
!
crypto pki token default removal timeout 0
!
controller T1 7/0
pri-group timeslots 1-24
!
interface Ethernet0/0
ip address 10.1.1.2 255.255.255.0
ipv6 address 2001:DB8:1::1122/64
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Serial7/0:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-5ess
isdn protocol-emulate network
!
interface Async1
no ip address
encapsulation slip
!
interface Dialer1
ip address 10.2.2.2 255.255.255.0
encapsulation ppp
dialer in-band
dialer idle-timeout 60
dialer string 1234
dialer-group 1
ipv6 address 2001:DB8:2::1234/64
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
dialer-list 1 protocol ipv6 permit
dialer-list 1 protocol ip permit
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
end

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS commands

Master Commands List, All Releases

Dial Technology commands

Dial Technologies Command Reference

Cisco Express Forwarding

"Cisco IOS Switching Paths Overview" module in the Switching Services Configuration Guide

IP Switching Command Reference

Dialer interfaces and profiles; Dialer Cisco Express forwarding

"Configuring Peer-to-Peer DDR with Dialer Profiles" module in the Dial Technologies Configuration Guide

"Configuring Dialer Cisco Express Forwarding" module in the Dial Technologies Configuration Guide


MIBs

MIB
MIBs Link

None

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Table 1 lists the release history for this feature.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 1 Feature Information for IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Feature Name
Releases
Feature Information

IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

15.2(3)T

The IPv6 Cisco Express Forwarding Switching on Dialer Interfaces feature allows Cisco Express Forwarding switching of IPv6 traffic on dialer interfaces.

The following command was introduced or modified: dialer watch-list.

IPv6 Cisco Express Forwarding Switching on Dialer Interfaces

Cisco IOS XE Release 3.9S

The IPv6 Cisco Express Forwarding Switching on Dialer Interfaces feature allows Cisco Express Forwarding switching of IPv6 traffic on dialer interfaces.

The following command was introduced or modified: dialer watch-list.