Cisco IOS Dial Technologies Configuration Guide, Release 12.4T
VRF Aware Dialer Watch
Downloads: This chapterpdf (PDF - 150.0KB) | Feedback

VRF Aware Dialer Watch

Table Of Contents

VRF Aware Dialer Watch

Contents

Information About VRF Aware Dialer Watch

How VRF Aware Dialer Watch Works

VRF Aware Dialer Watch Typical Scenario

How to Configure VRF Aware Dialer Watch

Configuring the Dialer Watch List

Configuration Examples for VRF Aware Dialer Watch

VRF Aware Dialer Watch on a Legacy Dialer Configuration: Example

VRF Aware Dialer Watch on a Dialer Rotary Group: Example

VRF Aware Dialer Watch on a Dialer Profile Configuration: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference


VRF Aware Dialer Watch


The VRF Aware Dialer Watch feature enhances dialer watch functionality by allowing an IP address and VPN routing and forwarding (VRF) instance pair to be watched for dial backup.

Feature History for the VRF Aware Dialer Watch Feature

Release
Modification

12.3(7)T

This feature was introduced.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Information About VRF Aware Dialer Watch

How to Configure VRF Aware Dialer Watch

Configuration Examples for VRF Aware Dialer Watch

Additional References

Command Reference

Information About VRF Aware Dialer Watch

To configure the VRF Aware Dialer Watch feature, you need to understand the following concepts:

How VRF Aware Dialer Watch Works

VRF Aware Dialer Watch Typical Scenario

How VRF Aware Dialer Watch Works

The Cisco IOS Dialer Watch software feature integrates dial backup with routing capabilities. The Dialer Watch dial backup technology uses a route called watched-route, and whenever the watched-route entry is lost from a routing table, a new a backup link is brought up.

With the VRF Aware Dialer Watch feature introduced in Cisco IOS Release 12.3(7)T, you configure the watched-route as an IP address and VRF pair. A VRF is a per-Virtual Private Network (VPN) routing information repository that defines the VPN membership of a customer site attached to a network access server. A VRF consists of an IP routing table, a derived Cisco Express Forwarding (CEF) table, a set of interfaces that use the forwarding table, and a set of rules and routing protocol parameters that control the information that is included in the routing table. A separate set of routing and CEF tables is maintained for each VPN customer.

The corresponding VRF table configured in the VRF Aware Dialer Watch feature is used to detect when watched-route for the VRF has gone down. The original Dialer Watch feature looked only at the global routing table to determine if the watched route had gone down. The VRF Aware Dialer Watch feature allows configuring multiple VRFs apart from the global routing table. A secondary link will be brought up when the watched route in the corresponding VRF table goes down.

It is important to note that the VRF might have overlapping address space, as follows: At the provider edge (PE) router, each customer edge (CE) router—the router that is part of the customer network and that interfaces to a PE router—will have a corresponding VRF associated with it. Further, two CE routers might be using the same address space, so that the corresponding VRFs at the PE router will have overlapping address space. For this reason, you must configure the watched route as an IP address and VRF name pair, where the IP address is the watched IP address and the VRF name is the routing and forwarding instance to which the IP address belongs. Configuring the Dialer Watch feature with only the IP address did not ensure that the correct CE route would be dialed when a watched route went down. Configuring the new VRF Aware Dialer Watch feature with an IP address and VRF name pair ensures that the VRF table corresponding to the routing and forwarding instance to which the IP address belongs is found and the correct CE is dialed.

VRF Aware Dialer Watch Typical Scenario

Figure 1 shows a typical configuration that uses the VRF Aware Dialer Watch feature.

Figure 1 VRF Aware Dialer Watch Typical Configuration

A typical scenario for the VRF Aware Dialer Watch feature follows:

A VRF router learns the route to the CE from a PE.

The VRF router watches these learned routes to the CEs.

The primary link between a PE and CE goes down.

The watched route goes down in the VRF router.

Dialer Watch call is initiated to the corresponding CE.

The backup link will be bound to the correct VRF. In configurations with a dialer profile, the dialer profile interface is statically bound to the corresponding VRF. In configurations without a dialer profile, a virtual access interface is created dynamically that is bound to the VRF.

How to Configure VRF Aware Dialer Watch

This section contains the following required task to configure the VRF Aware Dialer Watch feature:

Configuring the Dialer Watch List (required)

Configuring the Dialer Watch List

This task configures a watched route made up of an IP address and VRF pair to be monitored by Dialer Watch using the dialer watch-list command. Most configurations contain several dialer watch-list commands, to specify a list of watched routes.

You must also configure a group number in a dialer watch-group interface configuration command, and the standard commands required to enable the router to perform dial-on-demand routing in addition to the Dialer Watch commands. Refer to Cisco IOS configuration guides and command references listed in the "Related Documents" section for additional information. See the "Configuration Examples for VRF Aware Dialer Watch" section for examples of how the VRF Aware Dialer Watch feature can be configured.

SUMMARY STEPS

1. enable

2. configure terminal

3. dialer watch-list group-number {ip ip-address address-mask [vrf vrf-name] | delay route-check initial seconds}

4. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

dialer watch-list group-number {ip ip-address address-mask [vrf vrf-name] | delay route-check initial seconds}

Example:

Router(config)# dialer watch-list 1 ip 10.2.1.0 255.255.255.0 vrf v1

Specifies the list of watched routes of IP addresses or IP address and VRF pairs to be monitored by Dialer Watch.

group-number—Matches the group number set in a dialer watch-group interface configuration command.

ip ip-address address-mask—Specifies the IP address or address range and address mask to be applied to the list.

vrf vrf-name—(Optional) Specifies a watched route using the VRF table named in the vrf-name argument.

delay route-check initial seconds—Number of seconds after which the router ensures that the primary route is up once initial startup is complete.

Note You can define one watch route that watches the same IP address, but belongs to a different VRF, in a single watch list.

Step 4 

exit

Example:

Router(config)# exit

Exits global configuration mode.

Use the end command to save your configuration and leave configuration mode.

Configuration Examples for VRF Aware Dialer Watch

This section contains the following examples. See the "Related Documents" section for additional documents that contain examples that will show use of configuring VRF aware dialer maps.

VRF Aware Dialer Watch on a Legacy Dialer Configuration: Example

VRF Aware Dialer Watch on a Dialer Rotary Group: Example

VRF Aware Dialer Watch on a Dialer Profile Configuration: Example

VRF Aware Dialer Watch on a Legacy Dialer Configuration: Example

The following example specifies a pair of watched routes in a legacy dialer configuration. In this configuration, watch lists 1 and 2 are both watching the same IP address, but belong to different VRFs.

interface BRI3/0
 ip address 10.0.2.2 255.255.255.0
 encapsulation ppp
 dialer map 10.1.2.0 vrf v1 3xxxxxx
 dialer map 10.1.2.0 vrf v2 4xxxxxx
 dialer-group 1
 dialer watch-group 1
 dialer watch-group 2
 isdn switch-type ntt
 ppp authentication chap
!
dialer watch-list 1 ip 10.2.1.0 255.255.255.0 vrf v1
dialer watch-list 2 ip 10.2.1.0 255.255.255.0 vrf v2

VRF Aware Dialer Watch on a Dialer Rotary Group: Example

The following example specifies a pair of watched routes in a dialer rotary group configuration. In this configuration, watch lists 1 and 2 are both watching the same IP address, but belong to different VRFs.

interface BRI3/0
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 isdn switch-type ntt
 ppp authentication chap
!
interface Dialer1
 ip address 10.0.2.2 255.255.255.0
 encapsulation ppp
 dialer remote-name c3640-B
 dialer watch-disable 30
 dialer map 10.1.2.0 vrf v1 3xxxxxx
 dialer map 10.1.2.0 vrf v2 4xxxxxx
 dialer watch-group 1
 dialer watch-group 2
 dialer-group 1
 ppp authentication chap
!
dialer watch-list 1 ip 10.2.1.0 255.255.255.0 vrf v1
dialer watch-list 2 ip 10.2.1.0 255.255.255.0 vrf v2

VRF Aware Dialer Watch on a Dialer Profile Configuration: Example

The following example specifies a pair of watched routes in a dialer profile configuration. In this configuration, watch lists 1 and 2 are both watching the same IP address, but belong to different VRFs.

interface BRI3/0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type ntt
 ppp authentication chap
!
!
interface Dialer1
 ip vrf forwarding v1
 ip address 10.0.2.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer remote-name c3640-B
 dialer watch-disable 30
 dialer string 03xxxxxxx1
 dialer caller 03xxxxxxx1 callback
 dialer watch-group 1
 dialer-group 1
 ppp authentication chap
!
!
interface Dialer2
 ip vrf forwarding v2
 ip address 10.0.2.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer remote-name c3640-B
 dialer watch-disable 30
 dialer string 04xxxxxxx1
 dialer caller 04xxxxxxx1 callback
 dialer watch-group 2
 dialer-group 1
 ppp authentication chap
!
dialer watch-list 1 ip 10.2.1.0 255.255.255.0 vrf v1
dialer watch-list 2 ip 10.2.1.0 255.255.255.0 vrf v2

Additional References

The following sections provide references related to the VRF Aware Dialer Watch feature.

Related Documents

Related Topic
Document Title

Dialer Watch

"Configuring Dial Backup Using Dialer Watch" chapter in the Cisco IOS Dial Technologies Configuration Guide

Dialer commands

Cisco IOS Dial Technologies Command Reference, Release 12.3 T

VRF-aware dialer maps

Dialer Map VRF-Aware for an MPLS VPN feature module


Standards

Standards
Title

None


MIBs

MIBs
MIBs Link

None

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

None


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Command Reference

The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS Dial Technologies Command Reference at http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_book.html. For information about all Cisco IOS commands, go to the Command Lookup Tool at http://tools.cisco.com/Support/CLILookup or to the Cisco IOS Master Commands List.

dialer watch-list