Cisco IOS Dial Technologies Configuration Guide, Release 12.4T
1- and 2-Port V.90 Modem WICs for Cisco 2600 and Cisco 3600 Series Multiservice Platforms
Downloads: This chapterpdf (PDF - 160.0KB) | Feedback

1- and 2-Port V.90 Modem WICs for Cisco 2600 and Cisco 3600 Series Multiservice Platforms

Table Of Contents

1- and 2-Port V.90 Modem WICs for Cisco 2600 and Cisco 3600 Series Multiservice Platforms

Feature Overview

Remote Router Management and Out-of-Band Access

Asynchronous Dial-on-Demand Routing and Dial-Backup

Low-Density Analog RAS Access

Benefits

Restrictions

Related Features and Technologies

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Asynchronous Interface Configuration

Line Configuration

Alternative Configurations for the Modem WIC

Configuring the Group Asynchronous Interface

Configuring the Dialer List

Configuring the Line

Configuring the Dialer Interface

Configuring for Asynchronous Dial Backup

Verifying the V.90 Modem WIC Configuration

Troubleshooting the V.90 Modem WIC Operation

Command Reference

Glossary


1- and 2-Port V.90 Modem WICs for Cisco 2600 and Cisco 3600 Series Multiservice Platforms


Feature History

Release
Description

12.2(2)XB

This feature was introduced.

12.2(8)T

This feature was integrated into the Cisco IOS Release 12.2(8)T.


The 1- and 2-port V.90 modem WAN interface cards (WICs) for Cisco 2600 and 3600 series multiservice platforms provide low-density integrated modems to satisfy the market demand for remote management, dial-backup, and low-density remote-access servers (RAS).

This document describes the 1-port and 2-port V.90 modem WIC feature and contains the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Command Reference

Glossary

Feature Overview

Three applications are available for the V.90 modem WIC on the Cisco 2600 and Cisco 3600 series multiservice platforms:

Remote Router Management and Out-of-Band Access

In this mode, the modem WIC is used as a dial-in modem for remote terminal access to the router's command-line interface (CLI) for configuration, troubleshooting, and monitoring. The modem WIC acts similar to a modem that is connected to the AUX port of a router, but the integrated nature of the modem WIC greatly decreases customer configuration time and deployment and sustaining costs. Typically, the 1-port modem WIC is used for this application. Connection speeds of up to 33.6 kbps are possible.

Asynchronous Dial-on-Demand Routing and Dial-Backup

In this mode, the V.90 modem WIC transports network traffic. When ISDN service is not available and the traffic load does not justify a leased-line or Frame Relay connection, asynchronous dial-on-demand routing (DDR) is often the only choice for making a WAN connection. Even at sites that do have leased-line or Frame Relay connection, asynchronous DDR can increase bandwidth during sustained traffic load. In addition, when the primary leased-line or Frame Relay link is down during an outage, asynchronous dial-backup provides a secondary way to make the WAN connection. Both the 1-port and 2-port versions of the V.90 modem WIC can be used for this application.

For more information on Asynchronous Dial-on-Demand Routing and Dial-Backup, please see the document, Configuring Dial Backup for Serial Lines:

http://cisco.com/en/US/docs/ios/dial/configuration/guide/dia_preparing_ddr.html

Two ports on one modem WIC (or even three or more ports spanning multiple modem WIC cards) can be combined using Multilink PPP (MLP) to increase connection speeds in a scalar manner. Each connection is capable of V.90 speeds (up to 56 kbps) when connecting to a digital V.90 server modem.

For more information on MLP, please see the document, Multilink PPP for DDR—Basic Configuration and Verification:

http://www.cisco.com/warp/public/131/mppp-ddr.html

Low-Density Analog RAS Access

In this application, the V.90 modem WIC enables the platform to provide the services of a typical small remote access server (RAS). One service allows remote users to dial in and gain access to resources on the LAN (or even across the WAN). The analog modems in the modem WIC allow dial-in connection speeds of up to 33.6 kbps, but MLP can bind multiple links together and increase the throughput.

Another service allows PCs (running Cisco DialOut Utility) on the LAN to use the modems for dial-out. Users can connect to other modems (bulletin boards, AOL, ISPs, and so on) or fax machines. The modem WIC allows dial-out connection speeds of up to 56 kbps when dialing a digital V.90 server modem or up to 33.6 kbps when dialing another analog modem. Fax calls connect at up to 14.4 kbps.

Typical RAS deployments with the V.90 modem WIC use the 2-port modem version. With enough slots, the V.90 modem WIC can be used to scale to up to 24 modems in a Cisco 3660 multiservice platform.

There is no limit for lines in the MLP bundle with WICs and population of WICs on any Cisco 2600 series or Cisco 3600 series multiservices platforms.

Benefits

The 1-port and 2-port V.90 modem WIC feature provides the following benefits:

Integrated solution for ease of deployment

Improved remote management

Cost-effective alternative to leased lines or ISDN

Restrictions

Platform Memory Requirements

Cisco 2600 ip —8M Flash, 32M DRAMM.

Cisco 3620 ip plus—16M Flash, 48M DRAMM.

Cisco 3620 enterprise—16M Flash, 64M DRAMM.

Cisco 3640 ip plus—16M Flash, 64M DRAMM.

Cisco 3640 enterprise—16M Flash, 64M DRAMM.

Cisco 3660 ip plus—16M Flash and 64M DRAMM.

Cisco 3660 enterprise—16M Flash and 64M DRAMM.


Caution Ensure that the RJ-11/CA11 telephone cable is disconnected from the modem WIC before installing or removing the modem WIC from the router. The phone jack can have DC potential (up to 56.5 VDC) and can have ring signal (up to 150 VAC) in the United States.


Caution Ensure that the router is powered OFF before installing or removing the modem WIC from the router. The modem WICs do not support online insertion and removal (hot-swap).

Other than some currently unsupported commands, the V.90 modem WIC supports all commands available for modem WICs as described in the Cisco IOS Wide Area Networking Configuration Guide and the Cisco WAN Interface Cards Installation and Configuration Guide. For troubleshooting and verification, use only the following commands:

clear modem [counters][ slot/modem # | group group # | all ]

debug modem

show modem slot/modem#

Related Features and Technologies

For general and specific information on wide-area networking, see the following documents:

Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2  http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fwan_c/index.htm

Cisco IOS Wide-Area Networking Command Reference, Release 12.2  http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fwan_r/index.htm

Related Documents

WAN Interface Cards Hardware Installation Guide
http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis3600/wan_mod/index.htm

Modem-Router Connection Guide
http://www.cisco.com/warp/public/76/9.html

Cisco 3600-Series Router Configurations
http://www.cisco.com/warp/public/793/access_dial/3600_index.html

Cisco IOS Dial Services Quick Configuration Guide
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121sup/121dsqcg/index.htm

Supported Platforms

The following Cisco multiservice platforms are supported for the Cisco IOS Release 12.2(8)T:

Cisco 2600 series

Cisco 3600 series

Supported Standards, MIBs, and RFCs

Standards

No new or modified standards are supported by this feature.

MIBs

No new or modified MIBs are supported by this feature.

To obtain lists of MIBs supported by platform and Cisco IOS release and to download MIB modules, go to the Cisco MIB web site on Cisco Connection Online (CCO) at http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml.

RFCs

No new or modified RFCs are supported by this feature.

Configuration Tasks

Configuration tasks required for setting up the modem WIC for proper operation are:

Asynchronous Interface Configuration

Line Configuration

Asynchronous Interface Configuration

To configure the asynchronous interface on the V.90 modem WIC, use the following commands, starting in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface asynchronous number

Enters the interface configuration mode for the asynchronous serial interface. Enter the number of the interface you want to configure.

Step 2 

Router(config-if)# ip unnumbered type number

Conserves IP addresses by configuring the asynchronous interface as unnumbered, and assigns the IP address of the interface type that you want to leverage.

Step 3 

Router(config-if)# encapsulation ppp

Sets the encapsulation protocol for Point-to-Point Protocol (PPP).

Step 4 

Router(config-if)# dialer in-band [no-parity | odd-parity]

Specifies that dial-on-demand routing (DDR) is to be supported. This command specifies that chat scripts will be used on asynchronous interfaces. The parity keywords do not apply to asynchronous interfaces.

Step 5 

Router(config-if)# dialer string number

Enters the dialer string (telephone) number.

Step 6 

Router(config-if)# dialer-group group-number

Controls access by configuring the interface to belong to a specific dialing group. The number to which the dialer access group belongs is defined with the dialer-list command. Acceptable values are within the range from 1 to 10.

Step 7 

Router(config-if)# asynchronous mode interactive

Configures interactive mode on the asynchronous interface.

Step 8 

Router(config-if)# peer default ip address pool poolname

Assigns dial-in clients IP addresses from an address pool. To create an IP address pool, use the ip local pool global configuration command.

Example:

Router(config)# interface asyn 33
Router(config-if)# ip unnumbered f0/0
Router(config-if)# encapsulation ppp
Router(config-if)# dialer in-band
Router(config-if)# dialer string 14085551234
Router(config-if)# dialer-group 1
Router(config-if)# asyn mode interactive
Router(config-if)# peer default ip address pool pool123

Note pool123 is a name chosen for the pool used for defining the range of IP addresses for remote clients.


Line Configuration

To configure the line on the V.90 modem WIC, use the following commands, starting in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface asynchronous number

Enters the interface configuration mode for the asynchronous serial interface. Enter the number of the interface you want to configure.

Step 2 

Router(config-if)# line number

Enters interface mode line configuration submode.

Note The number entered here must be the same as the number entered for the asynchronous serial interface when the interface configuration mode was first entered.

Step 3 

Router(config-line)# modem inout

Configures the line for both incoming and outgoing calls.

Step 4 

Router(config-line)# autoselect {arap | ppp | slip | during login}

Configures the line to automatically start an ARA, PPP, or SLIP session. For this feature, ppp is recommended.

Step 5 

Router(config-line)# transport input {all | lat | mop | nasi | none | pad | rlogin | telnet | v120}

Defines which protocols can be used to connect to the line. For this feature, all is recommended.

Example:

Router(config-if)# line 33
Router(config-line)# modem inout
Router(config-line)# autoselect ppp
Router(config-line)# transport input all

Alternative Configurations for the Modem WIC

Configuring the Group Asynchronous Interface

interface Group-Async1
 ip address negotiated
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 512 either
 dialer-group 1
 async default routing
 async mode dedicated
 no peer default ip address
 no fair-queue
 no cdp enable
 ppp authentication chap
 group-range 33 34
 hold-queue 10 in

Configuring the Dialer List

dialer-list 1 protocol ip permit

Configuring the Line

line 97 112
 exec-timeout 0 0
 autoselect ppp
 script dialer dial
 login local
 modem InOut
 transport input all
 stopbits 1
 flowcontrol hardware

Configuring the Dialer Interface

interface Dialer1
 ip address 199.0.1.2 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 no ip proxy-arp
 encapsulation ppp
 load-interval 30
 dialer remote-name d1
 dialer pool 1
 dialer idle-timeout 7200 either
 dialer-group 1
 no fair-queue
 pulse-time 0
 no cdp enable

Configuring for Asynchronous Dial Backup

The following example shows an asynchronous dial backup configuration:

interface Serial2/0 
 ip address 70.1.1.2 255.255.255.0 
 backup delay 15 15 
 backup interface as33 

interface Async33 
 ip address 51.1.1.2 255.255.255.0 
  encapsulation ppp 
 dialer in-band 
 dialer map ip 51.1.1.1 name m1_2621_33 modem-script cisco-default 101 
 dialer-group 1 
 ppp authentication chap 
 async mode interactive 
! 
router eigrp 100 
 redistribute static 
network 10.0.0.0 
 network 70.0.0.0 
!
ip route 10.0.0.0 255.0.0.0 51.1.1.2  180
!/very important/ 
line 33 
 autoselect ppp 
 modem InOut 
 flowcontrol hardware 
transport input all 

In this example, the interface S2/0 is configured as a primary link. Configuring the route through the backup interface (the V.90 modem WIC in this case) is very important. 10.0.0.0 in the IP route indicates the network number of the remote end. Thus, all packets for the destination IP are routed through the backup link if the primary link goes down. The 180 in the route command indicates the cost of the route taken (It should be more than the cost of the primary route). This avoids the packets taking the backup link when the primary link is up.

Verifying the V.90 Modem WIC Configuration

Shown below are a few of the many commands that can be used to verify, monitor, and troubleshoot the V.90 modem WIC. Other commands are described in the Related Documents.

The show interface async [tty-number] command shows the state of the specified asynchronous interface.

Example:

3640-Router# show interfaces asynch 1
Async 1 is up, line protocol is up
   Hardware is Conexant modem
Internet address is 1.0.0.1, subnet mask is 255.0.0.0
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 56/255
Encapsulation ppp, keepalive set (0 sec)
Last input 0:00:03, output 0:00:03, output hang never
Last clearing of "show interface" counters never
Output queue 0/3, 2 drops; input queue 0/0, 0 drops
Five minute input rate 0 bits/sec, 1 packets/sec
Five minute output rate 2000 bits/sec, 1 packets/sec
273 packets input, 13925 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
221 packets output, 41376 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets, 0 restarts
0 carrier transitions

The show modem [slot/port | group number] command shows various performance statistics for a modem or group of modems.

Example:

3640-Router# show modem 1/0 
Mdm  Typ    Status     Tx/Rx     G  Duration  TX  RX  RTS  CTS  DSR  DCD  DTR 
1/0 V34    Idle   33600  /33600  0  00:02:41   -   -   x    x         -    x 

Modem 1/0 [line 33], Async33, TTY33 
SCM firmware P2109-V90 
Modem config:Incoming and Outgoing 
Protocol:LAPM, Compression:V42B 
  Last clearing of "show modem" counters:00:24:52 
    2 incoming complete 
    0 incoming failures 
    0 outgoing complete 
    1 outgoing failure 
Modulation type          V34 
# of connections           1 
Protocol type         LAPM 
# of connections           1 
Transmit Speed Counters:
Connection Speeds      33600 
# of connections           1 
Receive Speed Counters:
Connection Speeds      33600 
# of connections           1 

Troubleshooting the V.90 Modem WIC Operation

To aid in troubleshooting the V.90 modem WIC operation, use the debug modem command, as shown in the following example:

[no] debug modem

This command shows the state of the tty lines.

Example:

00:05:04:TTY1:dropping DTR, hanging up 
00:05:04:TTY1:Async Int reset:Dropping DTR 
00:05:04:tty1:Modem:HANGUP->(unknown)cpm_modem_interrupt_handler 

00:05:05:TTY1:cleanup pending. Delaying DTR 
00:05:05:TTY1:cleanup pending. Delaying DTR 
00:05:06:TTY1:cleanup pending. Delaying DTR 
00:05:06:TTY1:cleanup pending. Delaying DTR 
00:05:06:%LINK-5-CHANGED:Interface Async1, changed state to reset 
00:05:07:TTY1:cleanup pending. Delaying DTR 
00:05:07:TTY1:cleanup pending. Delaying DTR 
00:05:07:%LINEPROTO-5-UPDOWN:Line protocol on Interface Async1, 
changed state to down 
00:05:08:TTY1:cleanup pending. Delaying DTR 
00:05:08:TTY1:cleanup pending. Delaying DTR 

Command Reference

This feature uses no new or modified commands. For information about all Cisco IOS commands, go to the Command Lookup Tool at http://tools.cisco.com/Support/CLILookup or to the Cisco IOS Master Commands List.

Glossary

baud rate—bits per second data rate of an asynchronous interface.

DDR—dial-on-demand routing. Also known as direct data routing or dial-up routing (PPP or IP).

DRAMM—Dynamic Random Access Memory Module.

DS0—A single 64 kbps channel of a T1 span.

DSP—digital signal processor.

DSPM—digital signal processing module—voice module card.

IOS—Internet Operating System.

ISDN—Integrated Services Digital Network.

NM—network module.

MAR—modular access router.

MLP—Multilink PPP.

OIR—Online insertion and removal (hot swap).

POTS—Plain old telephone service.

PPP—Point-to-Point Protocol.

PSTN—Public Switched Telephone Network.

RAS—remote access server.

TDM—time-division multiplexing. Also used to describe a single channel on a TDM bus.

VFC—voice feature card.

VIC—voice interface card.

WIC—WAN interface card.


Note For a list of other internetworking terms, see the Internetworking Terms and Acronyms document available on the Documentation CD-ROM and Cisco Connection Online (CCO) at the following URL: http://www.cisco.com/univercd/cc/td/doc/cisintwk/ita/index.htm.