Cisco IOS Dial Technologies Configuration Guide, Release 12.4T
PPPoE Client DDR Idle-Timer
Downloads: This chapterpdf (PDF - 164.0KB) | Feedback

PPPoE Client DDR Idle-Timer

Table Of Contents

PPPoE Client DDR Idle-Timer

Contents

Prerequisites for Using the PPPoE Client DDR Idle-Timer

Information About the PPPoE Client DDR Idle-Timer

DDR Functionality and the PPPoE Client

How to Configure the PPPoE Client DDR Idle-Timer

Configure the PPPoE Client DDR Idle-Timer on an ATM PVC Interface

What to Do Next

Configure the PPPoE Client DDR Idle-Timer on an Ethernet Interface

What to Do Next

Configure the Dialer Interface

Configuration Examples for PPPoE Client DDR Idle-Timer

PPPoEoA Client Configuration Example

PPPoEoE Client Configuration Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference


PPPoE Client DDR Idle-Timer


The PPPoE Client DDR Idle-Timer feature supports the dial-on-demand routing (DDR) interesting traffic control list functionality of the dialer interface with a PPP over Ethernet (PPPoE) client, but also keeps original functionality (PPPoE connection up and always on after configuration) for those PPPoE clients that require it.

Feature Specifications for the PPPoE Client DDR Idle-Timer Feature

Feature History
 
Release
Modification

12.2(13)T

This feature was introduced.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for Using the PPPoE Client DDR Idle-Timer

Information About the PPPoE Client DDR Idle-Timer

How to Configure the PPPoE Client DDR Idle-Timer

Configuration Examples for PPPoE Client DDR Idle-Timer

Additional References

Command Reference

Prerequisites for Using the PPPoE Client DDR Idle-Timer

Before configuring the PPPoE Client DDR Idle-Timer feature, you must understand the concept of DDR interesting packets and access control lists and PPPoE Stage Protocols. See the "Additional References" section for links to the documents describing these concepts.

Information About the PPPoE Client DDR Idle-Timer

To configure the PPPoE client DDR idle-timer, you need to understand the following concept:

DDR Functionality and the PPPoE Client

DDR Functionality and the PPPoE Client

Before Cisco IOS Release 12.2(13)T, the DDR interesting traffic control list functionality of the dialer interface was not supported for PPPoE. However, the PPPoE Client DDR Idle-Timer feature, available as part of Cisco IOS Release 12.2(13)T, now supports this DDR functionality for a PPPoE client.

Protocol access lists and dialer access lists are central to the operation of DDR. Access lists are used as the screening criteria for determining when to initiate DDR calls. All packets are tested against the dialer access list. Packets that match a permit entry are deemed interesting. Packets that do not match a permit entry or that do match a deny entry are deemed uninteresting. When a packet is found to be interesting, either the dialer idle timer is reset (if the line is active) or a connection is attempted (assuming the line is available but not active). If a tested packet is deemed uninteresting, it will be forwarded if it is intended for a destination known to be on a specific interface and the link is active. However, such a packet will not initiate a DDR call and will not reset the idle timer. If dialer idle timer expires, the dialer interface calls a PPPoE function to tear down the connection.

A new command, pppoe-client dial-pool-number, allows configuring a DDR interesting traffic control list for PPPoE connections, but also keeps original connection functionality for those PPPoE clients that require it. If you do not require DDR, the PPPoE connection will be up and always on after configuration. If you do require DDR functionality, the connection will be brought up when interesting traffic comes in from the LAN interface and brought down after the dialer idle timer expires. Interesting traffic that comes from WAN interface will only reset the dialer idle timer.

Protocol access lists and dialer access lists have already been implemented in the dialer interface for the operation of DDR. For a PPPoE client, access lists are used as the screening criteria for determining if PPPoE Discovery initiation or a dialer idle timer reset is needed. But a protocol access list is not required for this feature; it depends on your network needs. An access-list can be configured and associated with dialer-list, or you can configure only the dialer list.

All packets destined to the dialer interface are tested against the dialer access list. Packets that match a permit entry are deemed interesting. Packets that do not match a permit entry or that do match a deny entry are deemed uninteresting. When a packet is found to be interesting, the dialer idle timer will be reset if the PPPoE session has already been set up, or a PPPoE Discovery will be attempted if there is no PPPoE session. If a tested packet is deemed uninteresting, it will not initiate PPPoE Discovery and will not reset the idle timer.

How to Configure the PPPoE Client DDR Idle-Timer

This section contains the following procedures. Each procedure is identified as either required or optional.

Configure the PPPoE Client DDR Idle-Timer on an ATM PVC Interface (required)

Configure the PPPoE Client DDR Idle-Timer on an Ethernet Interface (required)

Configure the Dialer Interface (required)

Configure the PPPoE Client DDR Idle-Timer on an ATM PVC Interface

To configure the PPPoE client DDR idle-timer in interface-ATM-VC configuration mode, use the following commands:

SUMMARY STEPS

1. enable

2. configure {terminal | memory | network}

3. interface atm atm-interface-number

4. pvc vpi/vci

5. pppoe-client dial-pool-number number [dial-on-demand]

6. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure {terminal | memory | network}

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface atm atm-interface-number

Example:

Router# interface atm 2/0

Configures an ATM interface type and enters interface configuration mode.

Step 4 

pvc vpi/vci

Example:

Router(config-if)# pvc 2/100

Creates an ATM permanent virtual circuit (PVC) and enters interface-ATM-VC configuration mode.

Step 5 

pppoe-client dial-pool-number number [dial-on-demand]

Example:

Router(config-if-atm-vc)# pppoe-client dial-pool-number 1 dial-on-demand

Configures DDR interesting traffic control list functionality of the dialer interface with a PPPoE client.

The optional dial-on-demand keyword enables DDR functionality on the PPPoE connection.

Step 6 

exit

Example:

Router(config-if-atm-vc)# exit

Exits the configuration mode.

Enter the exit command at each configuration mode to leave that mode.


What to Do Next

To support DDR functionality for the PPPoE client, DDR functionality must be configured. See the "Configure the Dialer Interface" section for the steps to do this.

Configure the PPPoE Client DDR Idle-Timer on an Ethernet Interface

To configure the PPPoE client DDR idle-timer on an Ethernet interface, use the following commands:

SUMMARY STEPS

1. enable

2. configure {terminal | memory | network}

3. interface ethernet ethernet-number

4. pppoe enable

5. pppoe-client dial-pool-number number [dial-on-demand]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure {terminal | memory | network}

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface ethernet ethernet-number

Example:

Router# interface ethernet 1

Configures an Ethernet interface and enters interface configuration mode.

Step 4 

pppoe enable

Example:

Router(config-if)# pppoe enable

Enables PPPoE sessions on an Ethernet interface.

Step 5 

pppoe-client dial-pool-number number [dial-on-demand]

Example:

Router(config-if)# pppoe-client dial-pool-number 1 dial-on-demand

Configures DDR interesting traffic control list functionality of the dialer interface with a PPPoE client.

The optional dial-on-demand keyword enables DDR functionality on the PPPoE connection.

Step 6 

exit

Example:

Router(config-if-atm-vc)# exit

Exits the configuration mode.

Enter the exit command at each configuration mode to leave that mode.


What to Do Next

To support DDR functionality for the PPPoE client, DDR functionality must be configured. See the "Configure the Dialer Interface" section for the steps to do this.

Configure the Dialer Interface

To configure the dialer interface (required when using the pppoe-client dial-pool-number command), you must also configure the following commands:

SUMMARY STEPS

1. enable

2. configure {terminal | memory | network}

3. interface dialer dialer-rotary-group-number

4. dialer idle-timeout seconds [inbound | either]

5. dialer hold-queue packets [timeout seconds]

6. dialer-group group-number

7. exit

8. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure {terminal | memory | network}

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface dialer dialer-rotary-group-number

Example:

Router# interface dialer 1

Defines a dialer rotary group and enters interface configuration mode.

Step 4 

dialer idle-timeout seconds [inbound | either]

Example:

Router(config-if)# dialer idle-timeout 180 either

Specifies the duration of idle time before a line is disconnected.

inbound—Only inbound traffic will reset the idle timeout.

either—Both inbound and outbound traffic will reset the idle timeout.

Step 5 

dialer hold-queue packets [timeout seconds]

Example:

Router(config-if)# dialer hold-queue 100

Allows interesting outgoing packets to be queued until a modem connection is established.

timeout—Amount of time, in seconds, to queue the packets.

Step 6 

dialer-group group-number

Example:

Router(config-if)# dialer-group 1

Controls access by configuring an interface to belong to a specific dialing group.

Step 7 

exit

Example:

Router(config-if)# exit

Leaves interface configuration mode and returns to global configuration mode.

Step 8 

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

Example:

Router(config)# dialer-list 1 protocol ip permit

Defines a DDR dialer list for dialing by protocol or by a combination of a protocol and a previously defined access list.

permit and deny—Configure access permissions.

list—Specifies that an access list will be used for defining a granularity finer than an entire protocol.


Configuration Examples for PPPoE Client DDR Idle-Timer

This section provides configuration examples to match the identified configuration tasks in the previous sections. The dialer interface configurations for each interface type required by the pppoe-client dial-pool-number command are included in the following client configuration examples:

PPPoEoA Client Configuration Example

PPPoEoE Client Configuration Example

PPPoEoA Client Configuration Example

The following example shows how to configure the PPPoE client DDR idle-timer on an ATM PVC interface:

!
vpdn enable
no vpdn logging
!
vpdn-group 1
 request-dialin
  protocol pppoe
!
interface ATM2/0
 pvc 2/100 
  pppoe-client dial-pool-number 1 dial-on-demand
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 180 either
 dialer hold-queue 100
 dialer-group 1
!
dialer-list 1 protocol ip permit
!
ip route 0.0.0.0 0.0.0.0 Dialer1

PPPoEoE Client Configuration Example

The following example shows how to configure the PPPoE client DDR idle-timer on an Ethernet interface:

!
vpdn enable
no vpdn logging
!
vpdn-group 1
 request-dialin
  protocol pppoe
!
interface Ethernet1
 pppoe enable
 pppoe-client dial-pool-number 1 dial-on-demand
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 180 either
 dialer hold-queue 100
 dialer-group 1
!
dialer-list 1 protocol ip permit
!
ip route 0.0.0.0 0.0.0.0 Dialer1

Additional References

For additional information related to the PPPoE client DDR idle-timer, refer to the following references:

Related Documents

Related Topic
Document Title

DDR interesting packets and access control lists

Cisco IOS Dial Technologies Configuration Guide. See the section "Configuring Access Control for Outgoing Calls " in the chapter "Configuring Legacy DDR Hubs."

DDR and dialer commands: complete command syntax, command mode, defaults, usage guidelines, and examples

Cisco IOS Dial Technologies Command Reference.

PPPoE Client DDR Idle-Timer

Cisco IOS Broadband Access Aggregation and DSL Configuration Guide.

PPPoE configuration commands: complete command syntax, command mode, defaults, usage guidelines, and example

Cisco IOS Wide-Area Networking Command Reference.


Standards

Standards
Title

None


MIBs

MIBs
MIBs Link

None

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

If Cisco MIB Locator does not support the MIB information that you need, you can also obtain a list of supported MIBs and download MIBs from the Cisco MIBs page at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

To access Cisco MIB Locator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

RFCs

RFCs
Title

None


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, tools, and lots more. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Command Reference

The following modified command is pertinent to this feature. To see the command pages for this command and other commands used with this feature, go to the Cisco IOS Master Commands List, at http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html.

pppoe-client dial-pool-number