Cisco IOS Dial Technologies Configuration Guide, Release 12.4T
Optimized PPP Negotiation
Downloads: This chapterpdf (PDF - 139.0KB) | Feedback

Optimized PPP Negotiation

Table Of Contents

Optimized PPP Negotiation

Feature Overview

Benefits

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Configuring the LCP and IPCP Predictive States

Verifying LCP and IPCP Predictive States

Troubleshooting Tips

Monitoring and Maintaining LCP and IPCP Predictive States

Configuration Examples

Configuration with a Wireless Dialup Client Example

Dialup Connection with Router as Client Example

Command Reference


Optimized PPP Negotiation


Feature History

Release
Modification

12.2(4)T

This feature was introduced.

12.2(11)T

This feature was implemented on Cisco access server platforms.


This document describes the Asynchronous Line Monitoring feature feature. It includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Monitoring and Maintaining LCP and IPCP Predictive States

Configuration Examples

Command Reference

Feature Overview

The Asynchronous Line Monitoring feature feature optimizes the time needed for PPP negotiation when a connection is made. PPP negotiation can include several cycles before the negotiation options are acknowledged. These negotiation cycles can cause a significant user-perceived delay, especially in networks with slow links such as a wireless data connection, where the round-trip time for the negotiation cycle can take 600 to 800 ms or more. Additionally, the PPP negotiation time can add significantly to the total time the user stays connected in these types of connections. The following changes to the PPP link control protocol (LCP) and PPP Internet Protocol Control Protocol (IPCP) negotiation strategies make a reduction in the negotiation time possible:

Send an LCP Configure-Ack packet, then send the next-level LCP Configure-Request packet before receiving acknowledgment for the PPP Configure-Request packet.

Send an LCP Configure-Ack packet after sending LCP Configure-Reject and Configure-Nak packets for certain configuration options.

Send an IPCP Configure-Ack packet after sending an IPCP Configure-Nak packet.

Send IPCP Configure-Nak and Configure-Ack packets after rejecting certain configuration options.

Benefits

The Asynchronous Line Monitoring feature feature reduces delay in PPP negotiation time by predicting responses from peers and sending expected reply and request packets in advance, yet allows PPP negotiations to remain compliant with RFC 1661, the industry standard for transporting multiprotocol datagrams over point-to-point links.

Related Documents

Refer to the part "PPP Configuration" in the Cisco IOS Dial Technologies Configuration Guide,
Release 12.2, for more information about configuring PPP.

Supported Platforms

See the next section for information about Feature Navigator and how to use this tool to determine the platforms and software images in which this feature is available.

Determining Platform Support Through Feature Navigator

Cisco IOS software is packaged in feature sets that support specific platforms. To get updated information regarding platform support for this feature, access Feature Navigator. Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Feature Navigator is a web-based tool that enables you to quickly determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image.

To access Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions at http://www.cisco.com/register.

Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Supported Standards, MIBs, and RFCs

Standards

None

MIBs

None

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFCs

RFC 1661, The Point-to-Point Protocol

Configuration Tasks

See the following sections for configuration tasks for the Asynchronous Line Monitoring feature feature. Each task in the list is identified as either required or optional:

Configuring the LCP and IPCP Predictive States (required)

Verifying LCP and IPCP Predictive States (required)

Configuring the LCP and IPCP Predictive States

The ppp lcp predictive and ppp ipcp predictive commands are configured on group asynchronous and dialer rotary group interfaces in a dialup network that uses PPP or Multilink PPP. Begin configuration in global configuration mode and use the interface group-async and interface dialer commands to start interface configuration mode.

To configure the LCP and IPCP predictive states, use the following commands in interface configuration mode, as needed:

Command
Purpose

Router(config-if)# ppp lcp predictive

Sets LCP to a predictive state that reduces negotiation time by predicting responses from peers and sending expected reply and request packets in advance.

Router(config-if)# ppp ipcp predictive

Sets IPCP to a predictive state that reduces negotiation time by predicting responses from peers and sending expected reply and request packets in advance.

See the section "Configuration Examples" for examples of how to configure a network that would make use of the ppp lcp predictive and ppp ipcp predictive commands.

Verifying LCP and IPCP Predictive States

To verify that the LCP and IPCP predictive states are configured correctly, use the debug ppp negotiation command in privileged EXEC mode.

In the following sample output, lines in bold text indicate reports of LCP and IPCP negotiations in the predictive state configured by the ppp lcp predictive and ppp ipcp predictive commands:

Router# debug ppp negotiation

*Mar  2 02:25:27.693: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
*Mar  2 02:25:27.693: Se0/0 PPP: Treating connection as a dedicated line
*Mar  2 02:25:27.693: Se0/0 PPP: Phase is ESTABLISHING, Active Open
*Mar  2 02:25:27.693: Se0/0 LCP: O CONFREQ [Closed] id 11 len 10
*Mar  2 02:25:27.693: Se0/0 LCP:    MagicNumber 0x35C4DB07 (0x050635C4DB07)
*Mar  2 02:25:27.729: Se0/0 LCP: I CONFREQ [REQsent] id 14 len 29
*Mar  2 02:25:27.729: Se0/0 LCP:    MagicNumber 0xBFAE7481 (0x0506BFAE7481)
*Mar  2 02:25:27.729: Se0/0 LCP:    MRRU 1524 (0x110405F4)
*Mar  2 02:25:27.729: Se0/0 LCP:    EndpointDisc 1 Local (0x130F01696F7377616ED3 23630 3063)
*Mar  2 02:25:27.729: Se0/0 LCP: O CONFREJ [REQsent] id 14 len 23
*Mar  2 02:25:27.729: Se0/0 LCP:    MRRU 1524 (0x110405F4)
*Mar  2 02:25:27.733: Se0/0 LCP:    EndpointDisc 1 Local (0x130F01696F7377616ED3 23630 3063)
*Mar  2 02:25:27.733: Se0/0 LCP: O CONFACK [REQsent] id 15 len 10
*Mar  2 02:25:27.733: Se0/0 LCP:    MagicNumber 0xBFAE7481 (0x0506BFAE7481)
*Mar  2 02:25:27.733: Se0/0 LCP: State is Open
*Mar  2 02:25:27.733: Se0/0 PPP: Phase is UP
*Mar  2 02:25:27.737: Se0/0 IPCP: O CONFREQ [Closed] id 10 len 16
*Mar  2 02:25:27.737: Se0/0 IPCP:    CompressType VJ 15 slots (0x0206002D0F00)
*Mar  2 02:25:27.737: Se0/0 IPCP:    Address 10.1.30.200 (0x03060A011EC8)
*Mar  2 02:25:27.745: Se0/0 LCP: I CONFACK [Open] id 11 len 10
*Mar  2 02:25:27.745: Se0/0 LCP:    MagicNumber 0x35C4DB07 (0x050635C4DB07)
*Mar  2 02:25:27.777: Se0/0 LCP: I CONFREQ [Open] id 15 len 10
*Mar  2 02:25:27.781: Se0/0 LCP:    MagicNumber 0xBFAE7481 (0x0506BFAE7481)
*Mar  2 02:25:27.781: Se0/0 LCP: Dropping packet, state is Open
*Mar  2 02:25:27.813: Se0/0 IPCP: I CONFREQ [REQsent] id 105 len 28
*Mar  2 02:25:27.813: Se0/0 IPCP:    CompressType VJ 15 slots (0x0206002D0F00)
*Mar  2 02:25:27.813: Se0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar  2 02:25:27.813: Se0/0 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
*Mar  2 02:25:27.813: Se0/0 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
*Mar  2 02:25:27.813: Se0/0 IPCP: Pool returned 10.1.30.109
*Mar  2 02:25:27.817: Se0/0 IPCP: O CONFREJ [REQsent] id 105 len 16
*Mar  2 02:25:27.817: Se0/0 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
*Mar  2 02:25:27.817: Se0/0 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
*Mar  2 02:25:27.817: Se0/0 IPCP: O CONFNAK [REQsent] id 106 len 10
*Mar  2 02:25:27.817: Se0/0 IPCP:    Address 10.1.30.109 (0x03060A011E6D)
*Mar  2 02:25:27.817: Se0/0 IPCP: O CONFACK [REQsent] id 107 len 16
*Mar  2 02:25:27.817: Se0/0 IPCP:    CompressType VJ 15 slots (0x0206002D0F00)
*Mar  2 02:25:27.821: Se0/0 IPCP:    Address 10.1.30.109 (0x03060A011E6D)
*Mar  2 02:25:27.833: Se0/0 IPCP: I CONFACK [ACKsent] id 10 len 16
*Mar  2 02:25:27.833: Se0/0 IPCP:    CompressType VJ 15 slots (0x0206002D0F00)
*Mar  2 02:25:27.833: Se0/0 IPCP:    Address 10.1.30.200 (0x03060A011EC8)
*Mar  2 02:25:27.833: Se0/0 IPCP: State is Open
*Mar  2 02:25:27.837: Se0/0 IPCP: Install route to 10.1.30.109
*Mar  2 02:25:27.837: Se0/0 IPCP: Add link info for cef entry 10.1.30.109
*Mar  2 02:25:27.861: Se0/0 IPCP: I CONFREQ [Open] id 106 len 16
*Mar  2 02:25:27.865: Se0/0 IPCP:    CompressType VJ 15 slots (0x0206002D0F00)
*Mar  2 02:25:27.865: Se0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar  2 02:25:27.865: Se0/0 IPCP: Dropping packet, state is Open
*Mar  2 02:25:27.881: Se0/0 IPCP: I CONFREQ [Open] id 107 len 16
*Mar  2 02:25:27.885: Se0/0 IPCP:    CompressType VJ 15 slots (0x0206002D0F00)
*Mar  2 02:25:27.885: Se0/0 IPCP:    Address 10.1.30.109 (0x03060A011E6D)
*Mar  2 02:25:27.885: Se0/0 IPCP: Dropping packet, state is Open
*Mar  2 02:25:28.733: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/, changed state to up

Refer to RFC 1661 for more information about the PPP link operation. To turn off debug messaging, enter the undebug ppp negotiation command in privileged EXEC mode.

Troubleshooting Tips

See the section "Verifying LCP and IPCP Predictive States" to troubleshoot the LCP and IPCP predictive states.

Monitoring and Maintaining LCP and IPCP Predictive States

To monitor and maintain interfaces using LCP and IPCP predictive states, use the following command in EXEC mode:

Command
Purpose

Router# show interfaces serial

Displays information about a serial interface.


Configuration Examples

This section provides the following configuration examples:

Configuration with a Wireless Dialup Client Example

Dialup Connection with Router as Client Example

Configuration with a Wireless Dialup Client Example

The following configuration supports a PC running Windows 95 or Windows NT, and a dialup client such as a cell phone:

hostname s5300
!
isdn switch-type primary-5ess
!
chat-script usr2 ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT
chat-script usr ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30  CONNECTfax 
interface-type modem
!
controller t1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
interface loopback 0
 ip address 2.2.2.2 255.255.255.0
 no ip mroute-cache
!
interface serial 0:23
 no ip address
 encapsulation ppp
 no keepalive
 dialer pool-member 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no peer default ip address
 no fair-queue
 no cdp enable
!
interface group-async1
 ip unnumbered loopback 0
 encapsulation ppp
 no ip mroute-cache
 dialer in-band
 dialer pool-member 1
 async dynamic address
 async dynamic routing
 async mode dedicated
 no fair-queue
 ppp lcp predictive
 ppp ipcp predictive
 group-range 1 48
 hold-queue 75 in
!
interface dialer 1
 ip unnumbered loopback 0
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 120000
 dialer enable-timeout 6
 dialer-group 1
 peer default ip address pool LOCAL
 no cdp enable
 ppp lcp predictive
 ppp ipcp predictive
 ppp multilink
!
ip local pool LOCAL 2.2.2.10 2.2.2.20
!
dialer-list 1 protocol ip permit
no cdp run
!
line con 0
 exec-timeout 0 0
 transport input none
line 1 48
 script dialer usr
 login
 modem InOut
 modem autoconfigure discovery
 transport preferred none
 transport input all
 transport output none
 autoselect during-login
 autoselect ppp
line aux 0
line vty 0 4
 password lab
 login
!
end

Dialup Connection with Router as Client Example

To change the configuration in the previous example so that the network supports the router rather than a PC device as the dialup client, change the dialer interface portion of the configuration commands (the portion beginning with the interface dialer 1 command) as follows:

!
interface dialer 1
no peer default ip address
end

All other commands listed in the "Configuration with a Wireless Dialup Client Example" remain unchanged.

Command Reference

The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS Dial Technologies Command Reference at http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_book.html. For information about all Cisco IOS commands, go to the Command Lookup Tool at http://tools.cisco.com/Support/CLILookup or to the Cisco IOS Master Commands List.

ppp lcp predictive

ppp ipcp predictive