Cisco IOS Dial Technologies Configuration Guide, Release 12.4T
Dialer Persistent
Downloads: This chapterpdf (PDF - 144.0KB) | Feedback

Dialer Persistent

Table Of Contents

Dialer Persistent

Feature Overview

Benefits

Restrictions

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring Dialer Persistent

Shutting Down an Interface Configured for Dialer Persistence

Verifying Dialer Persistent

Monitoring and Maintaining Dialer Persistence

Configuration Examples

Standard Dialer Persistent Configuration Example

Dialer Persistent Plus Failed Connection Delays Configuration Example

Command Reference

Glossary


Dialer Persistent


Feature History

Release
Modification

12.2(4)T

This feature was introduced.

12.2(11)T

This feature was implemented on Cisco access server platforms.


This document describes the Dialer Persistent feature. It includes the following sections.

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Monitoring and Maintaining Dialer Persistence

Configuration Examples

Command Reference

Glossary

Feature Overview

A new interface configuration command, dialer persistent, allows a dial-on-demand routing (DDR) dialer profile connection to be brought up without being triggered by interesting traffic. When configured, the dialer persistent command starts a timer when the dialer interface starts up and starts the connection when the timer expires. If interesting traffic arrives before the timer expires, the connection is still brought up and set as persistent. The command provides a default timer interval, or you can set a custom timer interval.

The connection is not brought down until the shutdown interface command is entered on the dialer interface. If the persistent connection is torn down for some other reason, such as the ISDN line goes down, the system immediately tries to bring the connection back up, and will use any other settings configured for dialing on the dialer interface.

Benefits

The Dialer Persistent feature allows the connection settings in the dialer profile to be configured as persistent, that is, the connection is not torn down until the shutdown interface command is entered on the dialer interface.

Until Cisco IOS Release 12.2(4)T, interesting traffic was used to bring up a DDR link. If there was no interesting traffic and the idle timeout interval was reached, the link was torn down. However, there are situations where a link needs to be up all the time. The Dialer Persistent feature provides the option to ignore idle timers and interesting traffic, thereby keeping the link up and maintaining DDR dialed calls indefinitely. The Dialer Persistent feature allows you to configure the intervals to be used for dial attempts, both initially on startup and when a persistent link is brought down due to external failures.

Restrictions

The Dialer Persistent feature is available only with dialer profiles and not with legacy dialers.

The dialer idle-timeout interface configuration command cannot be configured when the dialer persistent command is configured.

Related Documents

Cisco IOS Dial Technologies Command Reference, Release 12.2

Cisco IOS Dial Technologies Configuration Guide, "Dial-on-Demand Routing Configuration" part, Release 12.2

Supported Platforms

See the next section for information about Feature Navigator and how to use this tool to determine the platforms and software images in which this feature is available.

Platform Support Through Feature Navigator

Cisco IOS software is packaged in feature sets that support specific platforms. To get updated information regarding platform support for this feature, access Feature Navigator. Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Feature Navigator is a web-based tool that enables you to quickly determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image.

To access Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions at http://www.cisco.com/register.

Feature Navigator is updated when major Cisco IOS software releases and technology releases occur. As of May 2001, Feature Navigator supports M, T, E, S, and ST releases. You can access Feature Navigator at the following URL:

http://www.cisco.com/go/fn

Supported Standards, MIBs, and RFCs

Standards

None

MIBs

None

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFCs

None

Prerequisites

Before performing the configuration tasks in this document, review the overview of and steps to configure a dialer profile in the chapter "Configuring Peer-to-Peer DDR with Dialer Profiles" in the Cisco IOS Dial Technologies Configuration Guide, "Dial-on-Demand Routing Configuration" part, Release 12.2.

Configuration Tasks

See the following sections for configuration tasks for the Dialer Persistent feature. Each task in the list is identified as either required or optional:

Configuring Dialer Persistent (required)

Shutting Down an Interface Configured for Dialer Persistence (required)

Verifying Dialer Persistent (optional)

The section "Monitoring and Maintaining Dialer Persistence" describes how to monitor and maintain the Dialer Persistent feature. See the section"Configuration Examples" for an example of how to configure the Dialer Persistent feature.

Configuring Dialer Persistent

To configure a dialer interface as persistent, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface dialer number

Creates a dialer interface and enters interface configuration mode.

Step 2 

Router(config-if)# ip address address mask

Specifies the IP address and mask of the dialer interface as a node in the destination network to be called.

Step 3 

Router(config-if)# encapsulation type

Specifies the encapsulation type.

Step 4 

Router(config-if)# dialer string dial-string class class-name

Specifies the remote destination to call and the map class that defines characteristics for calls to this destination.

Step 5 

Router(config-if)# dialer pool number

Specifies the dialing pool to use for calls to this destination.

Step 6 

Router(config-if)# dialer-group group-number

Assigns the dialer interface to a dialer group.

Step 7 

Router(config-if)# dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number}

Specifies an access list by list number or by protocol and list number to define the interesting packets that can trigger a call.

Step 8 

Router(config-if)# dialer remote-name user-name

(Optional) Specifies the authentication name of the remote router on the destination subnetwork for a dialer interface.

Step 9 

Router(config-if)# dialer persistent [delay [initial] seconds | max-attempts number]

Forces a dialer interface to be connected at all times, even in the absence of interesting traffic.

See the configuration example in the section "Configuration Examples" and the "Examples" section in the dialer persistent command reference page for additional commands that might be entered for this configuration.

Shutting Down an Interface Configured for Dialer Persistence

To fully tear down (shut down) a dialer interface configured for dialer persistent, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface dialer number

Enters interface configuration mode on the specified dialer interface.

Step 2 

Router(config-if)# shutdown

Fully tears down a persistent connection and prevents the software from attempting more dialing.

Verifying Dialer Persistent

To verify that dialer persistent is configured correctly, perform the following verification steps:


Step 1 Enter the show dialer interface EXEC command with the interface type and number to display statistics on the physical interface bound to the dialer interface. Output includes the configured timers. The "Idle timer (never)" and "Dial reason:" lines indicate that persistent dialing is configured.

Router# show dialer interface dialer 1
 
 Di1 - dialer type = DIALER PROFILE
 Idle timer (never), Fast idle timer (20 secs)
 Wait for carrier (30 secs), Re-enable (15 secs)
 Dialer state is data link layer up
 Number of active calls = 1
 
 Dial String      Successes   Failures    Last DNIS   Last status
 7135551234 4          0    00:00:06       successful   Default
 
 BRI1/0 - dialer type = ISDN
 
 Dial String      Successes   Failures    Last DNIS   Last status
 0 incoming call(s) have been screened.
 0 incoming call(s) rejected for callback.
 
 BRI1/0:2 - dialer type = ISDN
 Idle timer (never), Fast idle timer (20 secs)
 Wait for carrier (30 secs), Re-enable (15 secs)
 Dialer state is data link layer up
 Dial reason: Dialing on persistent Dialer Profile
 Interface bound to profile Di1
 Time until disconnect never
 Current call connected 00:00:06
 Connected to 7135550134 (7135550134)

Step 2 Enter the debug dialer EXEC command and verify that the following message appears:

Di1 DDR: Persistent Dialer Profile nailed up successfully


Monitoring and Maintaining Dialer Persistence

To monitor and maintain a dialer interface configured for dialer persistent, use the following commands in EXEC mode, as needed:

Command
Purpose

Router# clear interface

When dialer persistent is configured, the clear interface command clears unsuccessful dial attempts on a line without interesting traffic, and then the dialer software attempts to bring up the connection as persistent.

Router# debug dialer

Displays debugging information about the packets received on a dialer interface.


Configuration Examples

This section provides the following Dialer Persistent configuration examples:

Standard Dialer Persistent Configuration Example

Dialer Persistent Plus Failed Connection Delays Configuration Example

Standard Dialer Persistent Configuration Example

The following example shows how to configure a 5-second initial delay before the persistent connection is established:

!
 interface dialer 1
  ip address negotiated
  encapsulation ppp
  dialer pool 1
  dialer remote-name remote1
  dialer idle-timeout 0 either
  dialer string 7135550199
  dialer persistent delay initial 5
  ppp authentication chap 
  ppp chap hostname DDR
  ppp chap password secret
 !
 ip classless
 ip route 0.0.0.0 0.0.0.0 dialer 1
 ip route 172.30.21.0 255.255.255.0 1.1.1.5
 ip route 172.30.114.0 255.255.255.0 172.30.21.1
 no ip http server
 !
 !
 map-class dialer test
  dialer isdn speed 56
 access-list 183 permit ip host 10.239.28.2 host 10.239.28.128
 access-list 183 permit ip host 10.239.28.128 host 10.239.28.2  
!

Dialer Persistent Plus Failed Connection Delays Configuration Example

The following example shows how to configure a 1-minute delay at boot-up, and a 10-second delay for redialing after a failed connection with a maximum of five tries before stopping:

!
interface dialer 1
  ip address negotiated
  encapsulation ppp
  dialer pool 1
  dialer remote-name remote1
  dialer idle-timeout 0 either
  dialer string 7135550199
  dialer persistent delay initial 60
  dialer persistent delay 10
  dialer persistent max-attempts 5
  ppp authentication chap 
  ppp chap hostname DDR
  ppp chap password mysecret
 !
 ip classless
 ip route 0.0.0.0 0.0.0.0 dialer 1
 ip route 172.30.21.0 255.255.255.0 1.1.1.5
 ip route 172.30.114.0 255.255.255.0 172.30.21.1
 no ip http server
 !
 !
 map-class dialer test
  dialer isdn speed 56
 access-list 183 permit ip host 10.239.28.2 host 10.239.28.128
 access-list 183 permit ip host 10.239.28.128 host 10.239.28.2  
!

Command Reference

The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS Dial Technologies Command Reference at http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_book.html. For information about all Cisco IOS commands, go to the Command Lookup Tool at http://tools.cisco.com/Support/CLILookup or to the Cisco IOS Master Commands List.

dialer persistent

Glossary

interesting packets—Dialer access lists are central to the operation of DDR. In general, access lists are used as the screening criteria for determining when to initiate DDR calls. All packets are tested against the dialer access list. Packets that match a permit entry are deemed interesting.

persistent connection—A connection that is brought up even without interesting traffic, and is not torn down until the shutdown interface configuration command is entered on the interface.