Cisco IOS Dial Technologies Configuration Guide, Release 12.4T
Configuring X.25 on ISDN
Downloads: This chapterpdf (PDF - 158.0KB) | Feedback

Configuring X.25 on ISDN

Table Of Contents

Configuring X.25 on ISDN

X.25 on ISDN Overview

X.25-over-D-Channel Logical Interface

Outbound Circuit-Switched X.25 Support over a Dialer Interface

How to Configure X.25 on ISDN

Configuring X.25 on the ISDN D Channel

Configuration Examples for X.25 on ISDN

X.25 on ISDN D-Channel Configuration Example

Outbound Circuit-Switched X.25 Example


Configuring X.25 on ISDN


This chapter describes how to configure X.25 on ISDN. It includes the following main sections:

X.25 on ISDN Overview

How to Configure X.25 on ISDN

Configuration Examples for X.25 on ISDN

To identify the hardware platform or software image information associated with a feature, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter.

For a complete description of the commands in this chapter, refer to the Cisco IOS Dial Technologies Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

X.25 on ISDN Overview

BRI is an ISDN interface, and it consists of two B channels (B1 and B2) and one D channel. The B channels are used to transfer data, voice, and video. The D channel controls the B channels.

ISDN uses the D channel to carry signal information. ISDN can also use the D channel in a BRI to carry X.25 packets. The D channel has a capacity of 16 kbps, and the X.25 over D channel can utilize up to 9.6 kbps.

X.25-over-D-Channel Logical Interface

When X.25 on ISDN is configured, a separate X.25-over-D-channel logical interface is created. You can set its parameters without disrupting the original ISDN interface configuration. The original BRI interface will continue to represent the D, B1, and B2 channels.

Because some end-user equipment uses static terminal endpoint identifiers (TEIs) to access this feature, static TEIs are supported. The dialer understands the X.25-over-D-channel calls and initiates them on a new interface.

X.25 traffic over the D channel can be used as a primary interface where low-volume, sporadic interactive traffic is the normal mode of operation. Supported traffic includes the Internet Protocol Exchange (IPX), AppleTalk, transparent bridging, Xerox Network Systems (XNS), DECnet, and IP.

This feature is not available on the ISDN PRI.


Note X.25 on ISDN is also supported using the ISDN Always On/Dynamic (AO/DI) feature. AO/DI uses the Multilink PPP (MLP) protocol signaling with standard Q.922 and X.25 encapsulations, and can additionally use the Bandwidth Allocation Control Protocol (BACP) to optimize bandwidth on demand. For information about how to configure AO/DI, see the chapter "Configuring X.25 on ISDN Using AO/DI" in this publication.


Outbound Circuit-Switched X.25 Support over a Dialer Interface

Current Cisco IOS software enablescircuit-switched X.25 clients—PAD, X.25 switching, and Qualified Logical Link Control (QLLC)—to initiate calls and dynamically bring the X.25 context (which runs the X.25 protocol) up or down as needed. This capability allows packet-switched traffic over ISDN.

In earlier releases of the Cisco IOS software, X.25 circuit-switched clients were required to do an X.25 route lookup to forward a call. If the lookup resulted in a route to a dialer interface, the client would check the X.25 protocol state on the dialer interface. If the interface was not already bound to run the X.25 protocol, the software would reroute the call instead of bringing up a link and running the X.25 protocol. With this new feature, the X.25 context is dynamically created on demand and then removed when the X.25 session is cleared on the dialer interface.

For dialer profile interfaces, the X.25 context is created on the dialer interface, because X.25 protocol functions run on the dialer interface itself. Member links act like forwarding devices, because their topmost interface runs the actual encapsulated protocol. But for legacy dialer interfaces, the X.25 context is created on the member links once they come up and bind to a dialer.

There are no specific configuration tasks required to enable outbound circuit-switched X.25 support. See the "Outbound Circuit-Switched X.25 Example" example in the section "Configuration Examples for X.25 on ISDN" at the end of this chapter for an example of how to make use of this feature in your network.

How to Configure X.25 on ISDN

You can configure X.25 on ISDN in three ways:

If the ISDN traffic will cross an X.25 network, you configure the ISDN interface as described in the "Setting Up Basic ISDN Services" and "Configuring signaling on T1 and E1" chapters earlier in this publication. Make certain to configure that ISDN interface for X.25 addressing and encapsulation as described in the "Configuring X.25" chapter of the Cisco IOS Wide-Area Networking Configuration Guide.

Configure dynamic X.25 as illustrated in the section "Outbound Circuit-Switched X.25 Example" later in this chapter.

If the D channel of an ISDN BRI interface is to carry X.25 traffic, perform the task described in the next section, "Configuring X.25 on the ISDN D Channel."

Configuring X.25 on the ISDN D Channel

To configure an ISDN BRI interface (and create a special ISDN interface) to carry X.25 traffic on the D channel, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface bri number

Specifies an ISDN BRI interface and begins interface configuration mode.

Step 2 

Router(config-if)# isdn x25 static-tei tei-number

Specifies a static TEI, if required by the switch.

Step 3 

Router(config-if)# isdn x25 dchannel

Creates a configurable interface for X.25 traffic over the ISDN D channel.

The last step is to configure the X.25-over-ISDN interface for X.25 traffic. See the chapter "Configuring LAPB and X.25" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2, for the commands and tasks.

The new X.25-over-ISDN interface is called interface bri number:0 in configuration displays. It must be configured as an individual X.25 interface. For information about configuring an interface for X.25 traffic, refer to the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2.


Note The encapsulation x25 command is neither required nor used on this new interface, but other X.25 commands can be used to configure this interface.


If you want to remove the X.25-over-ISDN interface later, use the no isdn x25 dchannel command.

See the section "X.25 on ISDN D-Channel Configuration Example" at the end of this chapter for a configuration example.

Configuration Examples for X.25 on ISDN

This section illustrates X.25 on ISDN with the following examples:

X.25 on ISDN D-Channel Configuration Example

Outbound Circuit-Switched X.25 Example

X.25 on ISDN D-Channel Configuration Example

The following example creates a BRI 0:0 interface for X.25 traffic over the D channel and then configures the new interface to carry X.25 traffic:

interface bri0
 isdn x25 dchannel
 isdn x25 static-tei 8
!
interface bri0:0
 ip address 10.1.1.2 255.255.255.0
 x25 address 31107000000100
 x25 htc 1
 x25 suppress-calling-address
 x25 facility windowsize 2 2
 x25 facility packetsize 256 256
 x25 facility throughput 9600 9600
 x25 map ip 10.1.1.3 31107000000200

Outbound Circuit-Switched X.25 Example

The following example shows how to configure dynamic X.25 on an ISDN interface. Figure 1 illustrates the configuration.

Figure 1 Dynamic X.25 over ISDN

Configuration for Yen

version 12.0(5)T
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname yen
!
enable secret 5 $1$K32j$4AZW2oMDivpUeuMa/Fdcd.
enable password secret
!
username peso password 0 cisco
username dinar password 0 cisco
ip subnet-zero
no ip domain-lookup
ip domain-name cicso.com
ip name-server 172.18.1.148
!
isdn switch-type basic-5ess
x25 routing
!
interface Loopback0
no ip address
no ip directed-broadcast
no ip mroute-cache
!
interface Ethernet0
ip address 172.21.75.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
media-type 10BaseT
!
interface BRI1
no ip address
no ip directed-broadcast
no ip mroute-cache
dialer pool-member 1
isdn switch-type basic-5ess
no fair-queue
!
interface Dialer0
ip address 10.1.1.1 255.0.0.0
no ip directed-broadcast
encapsulation x25
no ip mroute-cache
dialer remote-name dinar
dialer idle-timeout 180
dialer string 81060
dialer caller 81060
dialer max-call 1
dialer pool 1
dialer-group 1
x25 address 11111
x25 map ip 10.1.1.2 22222
!
ip default-gateway 172.21.75.1
no ip classless
ip route 0.0.0.0 0.0.0.0 172.21.75.1
no ip http server
!
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
x25 route 22222 interface Dialer0
x25 route 33333 interface Dialer0
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
transport input all
line vty 0 4
password cisco
login
line vty 5 100
password cisco
login
!
end

Configuration for Peso Acting as X.25 Switch

version 12.0(5)T
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname peso
!
enable secret 5 $1$.Q00$h3vIhbOwO1fPvA2LYx2gE.
enable password cisco
!
ip subnet-zero
!
isdn switch-type primary-5ess
x25 routing
!
controller T1 0
cablelength short
cablelength short 133
!
controller T1 1
framing esf
clock source line primary
pri-group timeslots 1-24
!
controller T1 2
cablelength short
cablelength short 133
!
controller T1 3
cablelength short
cablelength short 133
!
interface Ethernet0
ip address 172.21.75.3 255.255.255.0
no ip directed-broadcast
!
interface Serial1:23
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1
isdn switch-type primary-5ess
isdn incoming-voice modem
no fair-queue
no cdp enable
ppp authentication chap
!
interface Dialer0
no ip address
no ip directed-broadcast
encapsulation x25 dce
no ip mroute-cache
dialer remote-name yen
dialer idle-timeout 180
dialer string 61401
dialer caller 61401
dialer max-call 1
dialer pool 1
x25 address 33333
!
interface Dialer1
no ip address
no ip directed-broadcast
encapsulation x25 dce
no ip mroute-cache
dialer remote-name dinar
dialer idle-timeout 180
dialer string 61403
dialer caller 61403
dialer max-call 1
dialer pool 1
x25 address 44444
!
ip default-gateway 172.21.75.1
no ip classless
ip route 0.0.0.0 0.0.0.0 172.21.75.1
no ip http server
!
x25 route 11111 interface Dialer0
x25 route 22222 interface Dialer1
x25 route source 11111 interface Dialer1
x25 route input-interface Dialer0 interface Dialer1
!
line con 0
transport input none
line 1 48
line aux 0
line vty 0 4
password cisco
login
line vty 5 100
password cisco
login
!
end

Configuration for Dinar

version 12.0(5)T
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dinar
!
logging buffered 16384 debugging
enable secret 5 $1$8EjF$4.S0AoMOVa5OIAYEMrrFI/
enable password cisco
!
username yen password 0 cisco
username 7701
username drachma password 0 cisco
username AODI password 0 cisco
ip subnet-zero
ip rcmd rcp-enable
ip rcmd rsh-enable
ip rcmd remote-username atirumal
!
isdn switch-type basic-5ess
x25 routing
!
controller T1 0/0
!
interface BRI3/1
no ip address
no ip directed-broadcast
no ip mroute-cache
dialer pool-member 1
isdn switch-type basic-5ess
no fair-queue
!
interface Dialer0
ip address 10.1.1.2 255.0.0.0
no ip directed-broadcast
encapsulation x25
no ip mroute-cache
dialer remote-name yen
dialer idle-timeout 180
dialer string 81060
dialer caller 81060
dialer max-call 1
dialer pool 1
dialer-group 1
x25 address 22222
x25 map ip 10.1.1.1 11111
!
interface Dialer1
ip address 10.1.1.10 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
dialer in-band
dialer-group 1
no fair-queue
!
ip default-gateway 172.21.75.1
no ip classless
ip route 0.0.0.0 0.0.0.0 172.21.75.1
no ip http server
!
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
x25 route 11111 interface Dialer0
x25 route 44444 interface Dialer0
!