Cisco IOS Dial Technologies Configuration Guide, Release 12.4T
Configuring Modem Use over ISDN BRI
Downloads: This chapterpdf (PDF - 252.0KB) | Feedback

Configuring Modem Use over ISDN BRI

Table Of Contents

Configuring Modem Use over ISDN BRI

Modem over ISDN BRI Overview

How to Configure Modem over ISDN BRI

Verifying ISDN BRI Interface Configuration

Configuration Examples for Modem over ISDN BRI

BRI Interface Configuration Example

Complete Configuration Examples


Configuring Modem Use over ISDN BRI


This chapter describes how to configure the Modem over ISDN BRI feature. It includes the following main sections:

Modem over ISDN BRI Overview

How to Configure Modem over ISDN BRI

Verifying ISDN BRI Interface Configuration

Configuration Examples for Modem over ISDN BRI

Before beginning the tasks in this chapter, check your system for the following hardware and software:

At least one of the following digital modem network modules. The number in the model name indicates the number of digital modems that can be connected to the module.

NM-6DM

NM-12DM

NM-18DM

NM-24DM

NM-30DM

These digital modem network modules do not have their own network connections, but instead handle analog calls passing through other router interfaces. BRI modules can provide their ISDN connectivity. Other modules, such as Ethernet, can provide connectivity to the LAN. The digital modem module acts as a pool of available modems that can be used for both incoming and outgoing calls. Digital modem network modules do not support BRI voice interface cards or wide-area network (WAN) interface cards.

At least one of the following Cisco BRI network modules:

NM-4B-S/T: 4-port ISDN BRI network module, minimum version 800-01236-03

NM-4B-U: 4-port ISDN BRI with integrated network termination 1 (NT-1) network module, minimum version 800-01238-06

NM-8B-S/T: 8-port ISDN BRI network module, minimum version 800-01237-03

NM-8B-U: 8-port ISDN BRI with integrated NT-1 network module, minimum version 800-01239-06

The version level is available from the show diag command, which displays the version number as the part number.

If your BRI network module is a version lower than those cited or you need more details, refer to the Cisco.com Field Notice titled Using Digital Modems with the Cisco 3600 Basic Rate Interface (BRI) Network Module Upgrade in the Access Products index. If your existing Cisco BRI network module is one of those listed and does not support the Modem over ISDN BRI feature, Cisco will upgrade the module at no charge.

To support the Modem over ISDN BRI feature, V.90 modem portware—for instructions on downloading this software or obtaining it otherwise, refer to the Cisco 3600 Series Modem Portware Upgrade Configuration Note on Cisco.com.

Before you can configure a Cisco 3640 router to provide Modem over ISDN BRI connectivity, you must also perform the following tasks:

Obtain BRI service from your telecommunications provider. The BRI line must be provisioned at the switch to support voice calls.

Install a 4-port or 8-port BRI network module into your Cisco router. Depending on the type of network module and your BRI service, you might also need to install an external NT-1 for S/T interfaces.

Install a supported digital modem network module into the Cisco 3640 router.

After the system comes up, make sure enough buffers are in the free list of the buffer pool that matches the maximum transmission unit (MTU) of your BRI interface. If not, you must reconfigure buffers so the BRI interfaces function properly. To check the MTU of your interfaces, use the show interfaces bri command. The show buffers command displays the free buffer space. Use the buffers global configuration command to make adjustments to initial buffer pool settings and to the limits at which temporary buffers are created and destroyed.

For more information about the physical characteristics of the BRI network modules and their digital modem support, or instructions on how to install the network or modem modules, either refer to the Cisco 3600 series Network Module Hardware Installation Guide that came with your BRI network module or view the up-to-date information on CCO.

To identify the hardware platform or software image information associated with a feature, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter.

For a complete description of the Modem over ISDN BRI commands in this chapter, refer to the Cisco IOS Dial Technologies Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

Modem over ISDN BRI Overview

The Modem over ISDN BRI feature for the Cisco 3640 modular access router lowers the cost of remote access by offering high-speed modem and ISDN connectivity for mobile customers, offices, and other remote-access users. Branch offices and enterprises can support analog modem users who call over the Public Switched Telephone Network (PSTN) into BRI interfaces in Cisco 3640 routers.

The digital modem in the router accepts the modem calls at connection speeds as fast as 56 kbps, adhering to the V.90 standard. As shown in Figure 1, the Cisco 3640 router in this way provides rapid access to E-mail and other network services.

Figure 1 Modem over ISDN BRI Feature

The following are benefits of using the Modem over ISDN BRI feature:

Supports cost-effective and readily available BRI service.

Provides remote modem users with rapid Internet and LAN/WAN access.

Allows flexible remote access application support.

How to Configure Modem over ISDN BRI

The Modem over ISDN BRI feature is part of interface configuration for BRI. You configure the BRI interface after you have configured the ISDN global characteristics, which are switch type and TEI negotiation timing. These characteristics can also be defined for each BRI interface, as shown in the following task table.

To set up the BRI interface characteristics, set the global parameters and then configure each interface separately by using the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# isdn switch-type switch-type

Configures the global ISDN switch type to match the service provider switch type. For a list of keywords, see Table 1.

Step 2 

Router(config)# isdn tei [first-call | powerup]

Configures when the ISDN TEI negotiation occurs. If this command is not used, negotiation occurs when the router is powered up.

The first-call option is primarily used in European ISDN switch types, such as NET3 networks. The powerup option should be used in most other locations.

Step 3 

Router(config)# interface bri slot/port

Begins interface configuration mode to configure parameters for the specified interface.

slot is the location of the BRI module. Valid values are from 0 to 3.

port is an interface number. Valid values are from 0 to 7 if the module is an 8-port BRI network module, or from 0 to 4 if the module is a 4-port BRI network module.

Step 4 

Router(config-if)# ip address ip-address mask

Specifies an IP address and subnet for the interface. You can also specify that there is no IP address. For information about IP addressing, see the Release 12.2 Cisco IOS IP Configuration Guide publication.

Step 5 

Router(config-if)# encapsulation ppp

Enables PPP encapsulation on the BRI interface. PPP encapsulation is configured for most ISDN communication.

If the router needs to communicate with devices that require a different encapsulation protocol, needs to detect encapsulation on incoming calls automatically, or needs to send traffic over a Frame Relay or X.25 network, see the chapter "Configuring X.25 on ISDN" later in this part, and the chapters in the Dial-on-Demand Routing Configuration part of this publication for information.

Step 6 

Router(config-if)# dialer map protocol next-hop-address name hostname speed 56|64 dial-string[:isdn-subaddress]


or

Router(config-if)# dialer map protocol next-hop-address name hostname spc [speed 56 | 64] [broadcast] dial-string[:isdn-subaddress]

(Most locations) Defines the remote protocol address of the recipient, host name, and dialing string; optionally, provide the ISDN subaddress; set the dialer speed to 56 or 64 kbps, as needed.

(Germany) Use the spc keyword to enable ISDN semipermanent connections.

Step 7 

Router(config-if)# dialer-group group-number

Assigns the interface to a dialer group to control access to the interface.

Step 8 

Router(config-if)# dialer-list dialer-group list access-list-number

Associates the dialer group number with an access list number.

Step 9 

Router(config-if)# access-list access-list-number {deny | permit} protocol source address source-mask destination destination-mask

Defines an access list permitting or denying access to specified protocols, sources, or destinations. Permitted packets cause the router to place a call to the destination protocol address.

Step 10 

Router(config-if)# no ip-directed broadcast

(Optional) Disables the translation of directed broadcast to physical broadcasts.

Step 11 

Router(config-if)# isdn switch-type switch-type

(Optional) Configures the interface ISDN switch type to match the service provider switch type. The interface ISDN switch type overrides the global ISDN switch type on the interface.

For a list of keywords, refer to Table 1.

Step 12 

Router(config-if)# isdn tei [first-call | powerup]

(Optional) Determines when ISDN TEI negotiation occurs for an individual interface. This overrides the global configuration command.

Step 13 

Router(config-if)# isdn spid1 spid-number [ldn]

Specifies a service profile identifier (SPID) and local directory number for the B1 channel. Currently, only the DMS-100 and NI-1 switch types require SPIDs. Although the Lucent 5ESS switch type might support a SPID, we recommend that you set up that ISDN service without SPIDs.

Step 14 

Router(config-if)# isdn spid2 spid-number [ldn]

Specifies a SPID and local directory number for the B2 channel.

Step 15 

Router(config-if)# isdn caller number

(Optional) Configure caller ID screening.

Step 16 

Router(config-if)# isdn answer1 [called-party-number][:subaddress]

(Optional) Configures called-party number verification for a called-party number or subaddress number in the incoming setup message.

Step 17 

Router(config-if)# isdn calling-number calling-number

(Optional) Specifies the calling-party number.

Step 18 

Router(config-if)# isdn not-end-to-end [56 | 64]

(Optional) Configures the speed for incoming calls recognized as not ISDN end-to-end.

Step 19 

Router(config-if)# isdn incoming-voice modem

Routes incoming voice calls to the modem and treats them as analog data. This step is required for the Modem over ISDN BRI feature.

Step 20 

Router(config-if)# isdn disconnect-cause {cause-code-number | busy | not available}

Overrides specific cause codes such as modem availability and resource pooling that are sent to the switch by ISDN applications. When the isdn disconnect-cause command is implemented, the configured cause codes are sent to the switch; otherwise, the default cause codes of the application are sent.

The cause-code-number argument sends a cause code number (submitted as integer 1 through 127) to the switch.

The busy keyword sends the USER BUSY code to the switch.

The not available keyword sends the CHANNEL NOT AVAILABLE code to the switch.

Step 21 

Router(config-if)# isdn fast-rollover-delay seconds

(Optional) Configures a delay between fast rollover dials.

Step 22 

Router(config-if)# isdn sending-complete

(Optional) Configures the BRI interface to include the Sending Complete information element in the outgoing call Setup message. Used in some geographic locations, such as Hong Kong and Taiwan, where the sending complete information element is required in the outgoing call setup message.

Table 1 ISDN Switch Types 

Country
ISDN Switch Type
Description

Australia

basic-ts013

Australian TS013 switches

Europe

basic-1tr6

German 1TR6 ISDN switches

 

basic-net3

NET3 ISDN switches (United Kingdom and others)

vn2

French VN2 ISDN switches

vn3

French VN3 and VN4 ISDN switches

Japan

ntt

Japanese NTT ISDN switches

North America

basic-5ess

Lucent Technologies basic rate switches

 

basic-dms100

NT DMS-100 basic rate switches

basic-ni

National ISDN-1 switches


See the section "Configuration Examples for Modem over ISDN BRI" at the end of this chapter for configuration examples.

Verifying ISDN BRI Interface Configuration

Use the show running-config command in EXEC mode to verify the current configuration that is running on the terminal.


Note The show startup-config shows the configuration stored in NVRAM or in a location specified by the CONFIG_FILE environment variable.


The following example shows some of the command output that is relevant to BRI configuration tasks. The bold text in the example are the results of configuration steps such as those shown in the section "How to Configure Modem over ISDN BRI" earlier in this chapter.

Building configuration...
 
Current configuration:
!
version 12.0
no service udp-small-servers
service tcp-small-servers
!
hostname Router
!
enable secret 5 $1$c8xi$tObplXsIS.jDeo43yZgq50
enable password xxx
!
username xxxx password x 11x5xx07
no ip domain-lookup
ip host Labhost 172.17.12.1
ip host Labhost2 172.17.12.2
ip name-server 172.19.169.21
!
interface Ethernet0
 ip address 172.17.12.100 255.255.255.192
 no ip mroute-cache
 no ip route-cache
 no mop enabled
.
.
.
interface BRI1/7
 description (408) 555-3777
 ip address 10.1.1.26 255.255.255.1
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no keepalive
 shutdown
 dialer idle-timeout 180
 dialer map ip 10.1.1.9 name MDial1 14085550715
 dialer map ip 10.1.1.14 name MDial2 14085553775
 dialer-group 1
 isdn switch-type basic-5ess
 isdn incoming-voice modem
	 isdn disconnect-cause busy
no fair-queue
 no cdp enable
 ppp authentication chap
 ppp multilink
.
.
.
!
interface Group-Async1
 ip unnumbered Loopback0
 no ip directed-broadcast
 ip tcp header-compression passive
 async mode interactive
 peer default ip address pool default
 no fair-queue
 group-range 65 70
 hold-queue 10 in
!
router igrp 109
 network 172.21.0.0
!
ip local pool local 172.21.50.85 172.21.50.89
ip local pool default 10.1.1.1 10.1.1.253
ip classless
ip route 0.0.0.0 0.0.0.0 172.21.48.1
!
!
map-class dialer VOICE
 dialer voice-call
!
map-class dialer DATA
dialer-list 1 protocol ip list 101
tacacs-server host 172.19.2.74
tacacs-server host 192.168.15.197
snmp-server community isdn RW
snmp-server enable traps isdn call-information
snmp-server host 172.25.3.154 traps isdn

Use the show interfaces bri number command to verify information about the physical attributes of the ISDN BRI B and D channels. The number argument is the slot location of the BRI module. Valid values are from 0 to 3.

BRI0:1 is down, line protocol is down 
 Hardware is BRI
 MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
 Internet address is 10.1.1.3/27
 Encapsulation PPP, loopback not set, keepalive not set
 LCP Closed
 Closed: IPCP
 Last input never, output never, output hang never
 Last clearing of "show interface" counters never
 Queueing strategy: fifo
 Output queue 0/40, 0 drops; input queue 0/75, 0 drops
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 0 packets input, 0 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 0 packets output, 0 bytes, 0 underruns
 0 output errors, 0 collisions, 7 interface resets
 0 output buffer failures, 0 output buffers swapped out
 0 carrier transitions

Configuration Examples for Modem over ISDN BRI

This section provides the following examples:

BRI Interface Configuration Example

Complete Configuration Examples

These examples show configuration of just the Modem over ISDN BRI feature using the interface configuration commands for each interface and a complete configuration showing global configuration, BRI interfaces, and modem configuration.

BRI Interface Configuration Example

The following example shows how to configure each BRI interface on a Cisco 3640 router for the Modem over ISDN BRI feature:

interface BRI0/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000101 9194440001
 isdn spid2 0444001101 9194440011
 isdn incoming-voice modem
!
interface BRI0/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000201 9194440002
 isdn spid2 0444001201 9194440012
 isdn incoming-voice modem
!
interface BRI0/2
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000301 9194440003
 isdn spid2 0444001301 9194440013
 isdn incoming-voice modem
!
interface BRI0/3
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000401 9194440004
 isdn spid2 0444001401 9194440014
 isdn incoming-voice modem
!
interface BRI0/4
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000501 9194440005
 isdn spid2 0444001501 9194440015
 isdn incoming-voice modem
!
interface BRI0/5
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000601 9194440006
 isdn spid2 0444001601 9194440016
 isdn incoming-voice modem
!
interface BRI0/6
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000701 9194440007
 isdn spid2 0444001701 9194440017
 isdn incoming-voice modem
!
interface BRI0/7
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000801 9194440008
 isdn spid2 0444001801 9194440018
 isdn incoming-voice modem
!
interface BRI2/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000101 9195550001
 isdn spid2 0555001101 9195550011
 isdn incoming-voice modem
!
interface BRI2/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000201 9195550002
 isdn spid2 0555001201 9195550012
 isdn incoming-voice modem
!
interface BRI2/2
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000301 9195550003
 isdn spid2 0555001301 9195550013
 isdn incoming-voice modem
!
interface BRI2/3
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000401 9195550004
 isdn spid2 0555001401 9195550014
 isdn incoming-voice modem
!
interface BRI2/4
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000501 9195550005
 isdn spid2 0555001501 9195550015
 isdn incoming-voice modem
!
interface BRI2/5
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000601 9195550006
 isdn spid2 0555001601 9195550016
 isdn incoming-voice modem
!
interface BRI2/6
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000701 9195550007
 isdn spid2 0555001701 9195550017
 isdn incoming-voice modem
!
interface BRI2/7
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000801 9195550008
 isdn spid2 0555001801 9195550018
 isdn incoming-voice modem
!

Complete Configuration Examples

The following example shows a complete configuration for a dial-in router, including a global command, BRI interface configuration, and modem configuration including group-async and dialer commands.

version 12.0
service timestamps debug datetime localtime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname MBRI_IN
!
no logging buffered
enable password xxx

The following lines are used for PPP CHAP authentication. Each username and password is associated with one dialer interface.

username async1 password devtest
username async2 password devtest
username async3 password devtest
username async4 password devtest
username async5 password devtest
username async6 password devtest
username async7 password devtest
username async8 password devtest
username async9 password devtest
username async10 password devtest
username async11 password devtest
username async12 password devtest
username async13 password devtest
username async14 password devtest
username async15 password devtest
username async16 password devtest
username async17 password devtest
username async18 password devtest
username async19 password devtest
username async20 password devtest
username async21 password devtest
username async22 password devtest
username async23 password devtest
username async24 password devtest
username async25 password devtest
username async26 password devtest
username async27 password devtest
username async28 password devtest
username async29 password devtest
username async30 password devtest
username FLOYD password devtest
username MBRI_OUT password devtest
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess

interface BRI0/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000101 9194440001
 isdn spid2 0444001101 9194440011
 isdn incoming-voice modem
!
interface BRI0/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000201 9194440002
 isdn spid2 0444001201 9194440012
 isdn incoming-voice modem
!
interface BRI0/2
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000301 9194440003
 isdn spid2 0444001301 9194440013
 isdn incoming-voice modem
!
interface BRI0/3
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000401 9194440004
 isdn spid2 0444001401 9194440014
 isdn incoming-voice modem
!
interface BRI0/4
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000501 9194440005
 isdn spid2 0444001501 9194440015
 isdn incoming-voice modem
 no shut
!
interface BRI0/5
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000601 9194440006
 isdn spid2 0444001601 9194440016
 isdn incoming-voice modem
!
interface BRI0/6
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000701 9194440007
 isdn spid2 0444001701 9194440017
 isdn incoming-voice modem
!
interface BRI0/7
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0444000801 9194440008
 isdn spid2 0444001801 9194440018
 isdn incoming-voice modem
!
interface BRI2/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000101 9195550001
 isdn spid2 0555001101 9195550011
 isdn incoming-voice modem
!
interface BRI2/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000201 9195550002
 isdn spid2 0555001201 9195550012
 isdn incoming-voice modem
!
interface BRI2/2
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000301 9195550003
 isdn spid2 0555001301 9195550013
 isdn incoming-voice modem
!
interface BRI2/3
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000401 9195550004
 isdn spid2 0555001401 9195550014
 isdn incoming-voice modem
!
interface BRI2/4
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000501 9195550005
 isdn spid2 0555001501 9195550015
 isdn incoming-voice modem
!
interface BRI2/5
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000601 9195550006
 isdn spid2 0555001601 9195550016
 isdn incoming-voice modem
!
interface BRI2/6
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000701 9195550007
 isdn spid2 0555001701 9195550017
 isdn incoming-voice modem
!
interface BRI2/7
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type basic-ni
 isdn spid1 0555000801 9195550008
 isdn spid2 0555001801 9195550018
 isdn incoming-voice modem
!
interface Ethernet1/0
 ip address 172.18.16.123 255.255.255.192
 no ip directed-broadcast
!

The following example defines a group-async interface for grouping all the digital modems and configuring them together. Group-async configuration is much easier than configuring all 30 digital modems individually.

interface Group-Async1
 ip unnumbered Ethernet3/1
 no ip directed-broadcast
 encapsulation ppp
 load-interval 30
 dialer in-band
 dialer pool-member 1
 async default routing
 async mode dedicated
 no peer default ip address
 no cdp enable
 ppp authentication chap
 group-range 96 125
 hold-queue 10 in

The following example defines dialer interfaces, associates IP addresses, and sets all the authentication parameters required during the call establishment.

interface Dialer1
 ip address 10.1.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async1
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async1
 ppp chap password devtest
!
interface Dialer2
 ip address 10.2.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async2
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async2
 ppp chap password devtest
!
interface Dialer3
 ip address 10.3.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async3
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async3
 ppp chap password devtest
!
interface Dialer4
 ip address 10.4.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async4
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async4
 ppp chap password devtest
!
interface Dialer5
 ip address 10.5.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async5
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async5
 ppp chap password devtest
!
interface Dialer6
 ip address 10.6.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async6
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async6
 ppp chap password devtest
!
interface Dialer7
 ip address 10.7.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async7
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async7
 ppp chap password devtest
!
interface Dialer8
 ip address 10.8.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async8
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async8
 ppp chap password devtest
!
interface Dialer9
 ip address 10.9.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async9
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async9
 ppp chap password devtest
!
interface Dialer10
 ip address 10.10.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async10
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async10
 ppp chap password devtest
!
interface Dialer11
 ip address 10.11.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async11
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async11
 ppp chap password devtest
!
interface Dialer12
 ip address 10.12.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async12
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async12
 ppp chap password devtest
!
interface Dialer13
 ip address 10.13.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async13
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async13
 ppp chap password devtest
!
interface Dialer14
 ip address 10.14.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async14
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async14
 ppp chap password devtest
!
interface Dialer15
 ip address 10.15.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async15
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async15
 ppp chap password devtest
!
interface Dialer16
 ip address 10.16.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async16
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async16
 ppp chap password devtest
!
interface Dialer17
 ip address 10.17.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async17
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async17
 ppp chap password devtest
!
interface Dialer18
 ip address 10.18.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async18
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async18
 ppp chap password devtest
!
interface Dialer19
 ip address 10.19.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async19
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async19
 ppp chap password devtest
!
interface Dialer20
 ip address 10.20.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async20
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async20
 ppp chap password devtest
!
interface Dialer21
 ip address 10.21.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async21
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async21
 ppp chap password devtest
!
interface Dialer22
 ip address 10.22.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async22
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async22
 ppp chap password devtest
!
interface Dialer23
 ip address 10.23.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async23
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async23
 ppp chap password devtest
!
interface Dialer24
 ip address 10.24.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async24
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async24
 ppp chap password devtest
!
interface Dialer25
 ip address 10.25.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async25
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async25
 ppp chap password devtest
!
interface Dialer26
 ip address 10.26.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async26
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async26
 ppp chap password devtest
!
interface Dialer27
 ip address 10.27.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async27
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async27
 ppp chap password devtest
!
interface Dialer28
 ip address 10.28.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async28
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async28
 ppp chap password devtest
!
interface Dialer29
 ip address 10.29.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async29
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async29
 ppp chap password devtest
!
interface Dialer30
 ip address 10.30.0.1 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name async30
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname async30
 ppp chap password devtest
!
no ip classless

The following lines define routes that send incoming packets out via specific interfaces:

ip route 0.0.0.0 0.0.0.0 172.18.16.193
ip route 10.91.0.1 255.255.255.255 1.1.0.2
ip route 10.91.0.2 255.255.255.255 1.2.0.2
ip route 10.91.0.3 255.255.255.255 1.3.0.2
ip route 10.91.0.4 255.255.255.255 1.4.0.2
ip route 10.91.0.5 255.255.255.255 1.5.0.2
ip route 10.91.0.6 255.255.255.255 1.6.0.2
ip route 10.91.0.7 255.255.255.255 1.7.0.2
ip route 10.91.0.8 255.255.255.255 1.8.0.2
ip route 10.91.0.9 255.255.255.255 1.9.0.2
ip route 10.91.0.10 255.255.255.255 1.10.0.2
ip route 10.91.0.11 255.255.255.255 1.11.0.2
ip route 10.91.0.12 255.255.255.255 1.12.0.2
ip route 10.91.0.13 255.255.255.255 1.13.0.2
ip route 10.91.0.14 255.255.255.255 1.14.0.2
ip route 10.91.0.15 255.255.255.255 1.15.0.2
ip route 10.91.0.16 255.255.255.255 1.16.0.2
ip route 10.91.0.17 255.255.255.255 1.17.0.2
ip route 10.91.0.18 255.255.255.255 1.18.0.2
ip route 10.91.0.19 255.255.255.255 1.19.0.2
ip route 10.91.0.20 255.255.255.255 1.20.0.2
ip route 10.91.0.21 255.255.255.255 1.21.0.2
ip route 10.91.0.22 255.255.255.255 1.22.0.2
ip route 10.91.0.23 255.255.255.255 1.23.0.2
ip route 10.91.0.24 255.255.255.255 1.24.0.2
ip route 10.91.0.25 255.255.255.255 1.25.0.2
ip route 10.91.0.26 255.255.255.255 1.26.0.2
ip route 10.91.0.27 255.255.255.255 1.27.0.2
ip route 10.91.0.28 255.255.255.255 1.28.0.2
ip route 10.91.0.29 255.255.255.255 1.29.0.2
ip route 10.91.0.30 255.255.255.255 1.30.0.2
ip route 172.18.0.0 255.255.0.0 Ethernet3/1
!
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
 transport input none

The following example configures the lines associated with the digital modems:

line 96 125
 exec-timeout 0 0
 modem InOut
 transport input all
 stopbits 1
 flowcontrol hardware
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 password lab
 login
line vty 5 60
 exec-timeout 0 0
 password lab