Cisco IOS Dial Technologies Configuration Guide, Release 12.4T
Configuring ISDN on Cisco 800 Series Routers
Downloads: This chapterpdf (PDF - 150.0KB) | Feedback

Configuring ISDN on Cisco 800 Series Routers

Table Of Contents

Configuring ISDN on Cisco 800 Series Routers

CAPI and RCAPI Overview

Framing Protocols

Data Link and Network Layer Protocols

CAPI Features

Supported B-Channel Protocols

Supported Switch Types

CAPI and RVS-COM

Supported Applications

How to Configure RCAPI

Configuring RCAPI on the Cisco 800 Series Router

Monitoring and Maintaining RCAPI

Troubleshooting RCAPI

Configuration Examples for RCAPI


Configuring ISDN on Cisco 800 Series Routers


This chapter describes the Common Application Programming Interface (CAPI) and Remote Common Application Programming Interface (RCAPI) feature for the Cisco 800 series routers. This information is included in the following main sections:

CAPI and RCAPI Overview

How to Configure RCAPI

Configuration Examples for RCAPI

The CAPI is an application programming interface standard used to access ISDN equipment connected to ISDN BRIs and ISDN PRIs. RCAPI is the CAPI feature configured remotely from a PC client.

Before you can enable the RCAPI feature on the Cisco 800 series router, the following requirements must be met:

Cisco 800 series software with RCAPI support is installed on the router.

CAPI commands are properly configured on the router.

Both the CAPI local device console and RCAPI client devices on the LAN are correctly installed and configured with RVS-COM client driver software.

To identify the hardware platform or software image information associated with a feature, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter.

For a complete description of the commands in this chapter, refer to the Cisco IOS Dial Technologies Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

CAPI and RCAPI Overview

Figure 1 shows how CAPI connects applications, drivers, and controllers.

Figure 1 CAPI Connections

Framing Protocols

The framing protocols supported by CAPI include High-Level Data Link Control (HDLC), HDLC inverted, bit transparent (speech), and V.110 synchronous/asynchronous.

Data Link and Network Layer Protocols

CAPI integrates the following data link and network layer protocols:

Link Access Procedure on the D-channel (LAPD) in accordance with Q.921 for X.25 D-channel implementation

PPP

ISO 8208 (X.25 DTE-DTE)

X.25 DCE, T.90NL, and T.30 (fax group 3)

CAPI Features

CAPI supports the following features:

Basic call features, such as call setup and tear-down

Multiple B channels for data and voice connections

Multiple logical data link connections within a physical connection

Selection of different services and protocols during connection setup and on answering incoming calls

Transparent interface for protocols above Layer 3

One or more BRIs as well as PRI on one or more Integrated Services Digital Network (ISDN) adapters

Multiple applications

Operating-systems-independent messages

Operating-system-dependent exchange mechanism for optimum operating system integration

Asynchronous event-driven mechanism, resulting in high throughput

Well-defined mechanism for manufacturer-specific extensions

Multiple supplementary services

Figure 2 shows the components of the RCAPI implementation.

Figure 2 Components of RCAPI

CAPI provides a standardized interface through which application programs can use ISDN drivers and controllers. One application can use one or more controllers. Several applications can share one or more controllers.

CAPI supplies a selection mechanism that supports applications that use protocols at different levels and standardized network access. An abstraction from different protocol variables is performed to provide this support. All connection-related data, such as connection state and display messages, is available to the applications at any time.

Supported B-Channel Protocols

The router provides two 64-kbps B channels to RCAPI clients. Each B channel can be configured separately to work in either HDLC mode or bit transparent mode. For CAPI support, layers B2 through B7 protocols are transparent to the applications using these B channels.

The ISDN Core Engine of RVS-COM supports the following B-channel protocols:

CAPI layer B1

64-kbps with HDLC framing

64-kbps bit transparent operation with byte framing from the network

T.30 modem for fax group 3

Modem with full negotiation

CAPI layer B2

V.120

Transparent

T.30 modem for fax group 3

Modem with full negotiation

CAPI layer B3

Transparent

T.90NL with compatibility to T.70NL according to T.90 Appendix II

ISO 8208 (X.25 DTE-DTE) modulo 8 and windows size 2, no multiple logical connections

T.30 for fax group 3

Modem with full negotiation

T.30 for fax group 3 (SFF file format [default], sending and receiving up to 14400 bit/s with ECM option, modulations V.17, V.21, V.27ter, V.29)

Analog modem (sending and receiving up to 14,400 bit/s, modulations V.21, V.22, V.22bis, V.23, V.32, V.32bis)

Supported Switch Types

CAPI and RCAPI support is available only for the ISDN switch type Net3.

CAPI and RVS-COM

The router supports the ISDN Device Control Protocol (ISDN-DCP) from RVS-COM. ISDN-DCP allows a workstation on the LAN or router to use legacy dial computer telephony integration (CTI) applications. These applications include placing and receiving telephone calls and transmitting and receiving faxes.

Using ISDN-DCP, the router acts as a DCP server. By default, the router listens for DCP messages on TCP port number 2578 (the Internet-assigned number for RVS-COM DCP) on its LAN port.

When the router receives a DCP message from a DCP client (connected to the LAN port of the router), the router processes the message and acts on it; it can send confirmations to the DCP clients and ISDN packets through the BRI port of the router.

When the router receives packets destined for one of the DCP clients on its BRI port, the router formats the packet as a DCP message and sends it to the corresponding client. The router supports all the DCP messages specified in the ISDN-DCP specifications defined by RVS-COM.

Supported Applications

ISDN-DCP supports CAPI and non-CAPI applications. Applications are supported that use one or two B channels for data transfer, different HDLC-based protocols, Euro File transfer, or G4 fax; also supported are applications that send bit-transparent data such as A/Mu law audio, G3 fax, analog modem, or analog telephones.

How to Configure RCAPI

To configure RCAPI, perform the tasks in the following sections:

Configuring RCAPI on the Cisco 800 Series Router (Required)

Monitoring and Maintaining RCAPI (Optional)

Troubleshooting RCAPI (Optional)

Configuring RCAPI on the Cisco 800 Series Router

To configure RCAPI on the Cisco 800 series router, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# isdn switch-type basic-net3

Sets the switch type. In this example, the switch type is set to NET3 ISDN, which covers the Euro-ISDN E-DSS1 signaling system and is ETSI-compliant.

Step 2 

Router(config)# rcapi number number

Enters the RCAPI directory number assigned by the ISDN provider for the device.

An example command:

rcapi number 12345.

Step 3 

Router(config)# rcapi server port number

The rcapi server command is mandatory for RCAPI to be enabled on the router. The parameter port is optional and is entered only when you need to specify a port number for RCAPI functions. Otherwise, the default port 2578 is used.

An example command with default port 2578:

rcapi server port 

An example command with port 2000:

rcapi server port 2000

Configure the same number on both the router and the client PC.

Step 4 

Router(config)# interface bri0

Configures the ISDN BRI interface and begins interface configuration mode.

Step 5 

Router(config-if)# isdn switch-type basic-net3

Sets the switch type for the bri0 interface. In this example, the switch type is set to NET3 ISDN, which covers the Euro-ISDN E-DSS1 signaling system and is ETSI-compliant.

Step 6 

Router(config-if)# isdn incoming-voice modem

Sets the modem as the default handler for incoming voice calls.


Note If required, at each remote device console change to global configuration mode, using the command configure terminal, and repeat Step 2 through Step 7 to configure that device.


Monitoring and Maintaining RCAPI

To monitor and maintain RCAPI, use the following command in privileged EXEC mode:

Command
Purpose
Router# show rcapi status

Displays RCAPI status.

Troubleshooting RCAPI

To test the RCAPI operation, use the following command in privileged EXEC mode

Command
Purpose
Router# debug rcapi events

Starts a background debug program.

Configuration Examples for RCAPI

The following configuration output example shows two Cisco 800 series routers configured for RCAPI:

Router 1

Router1# show running-config

Building configuration...

Current configuration:
!
version xx.x
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname local
!
ip subnet-zero
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
interface Ethernet0
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
!
interface BRI0
 no ip address
 no ip directed-broadcast
 isdn switch-type basic-net3
 isdn incoming-voice modem
!
no ip http server
ip classless
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
!
rcapi server port 2578
!
rcapi number 5551000
rcapi number 5553000
!
end

Router1#


Router 2

Router2# show running-config

Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname local
!
ip subnet-zero
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
interface BRI0
 no ip address
 no ip directed-broadcast
 isdn switch-type basic-net3
 isdn incoming-voice modem
!
no ip http server
ip classless
!
line con 0
 transport input none
 stopbits 1
line vty 0 
!
rcapi server port 2578
!
rcapi number 5552000
rcapi number 5554000
!
end

Router2#