Cisco CMTS High Availability Features Configuration Guide, Release 12.2SC
Route Processor Redundancy Plus for the Cisco uBR10012 Universal Broadband Router
Downloads: This chapterpdf (PDF - 324.0KB) The complete bookPDF (PDF - 2.67MB) | Feedback

Table of Contents

Route Processor Redundancy Plus for the Cisco uBR10012 Broadband Router

Contents

Prerequisites for Route Processor Plus Redundancy

Restrictions for Route Processor Plus Redundancy

Information About Route Processor Plus Redundancy

Benefits

Terminology Changes with Cisco IOS Release 12.2(11)BC3

Synchronization

Synchronization During Initialization

Synchronization of Startup Configuration

Incremental Synchronization of the Running Configuration

The RPR+ Switchover Process

Redundant File Systems

DSX Messages and Synchronized PHS Information

High Availability Support for Encrypted IP Multicast

How to Configure, Verify, and Troubleshoot Route Processor Plus Redundancy

Configuring RPR+ on the

Prerequisites

Verifying RPR+ Configuration

Examples

Upgrading Cisco IOS Software Images

Prerequisites

Creating Additional Disk Space (Optional)

Copying the Cisco IOS Image

Resetting a PRE1 or PRE2 Module or Line Card After Upgrade

Reloading Cisco IOS (Restarting the System)

Performing a Manual Route Processor Switchover

Troubleshooting

Configuration Examples for Route Processor Plus Redundancy

Additional References

Supported Standards, MIBs, and RFC

Technical Assistance

Command Reference

Route Processor Redundancy Plus for the Cisco uBR10012 Broadband Router

First Published: February 14, 2008

This document describes the Route Processor Redundancy Plus (RPR+) feature on the Cisco uBR10012 universal broadband router. RPR+ and DOCSIS Stateful Switchover (DSSO) support in Cisco IOS® Software for fast route processor failover without DOCSIS line card reboot.


Note Cisco IOS Release 12.2(33)SCA integrates support for this feature on the Cisco CMTS routers. This feature is also supported in Cisco IOS Release 12.3BC, and this document contains information that references many legacy documents related to Cisco IOS 12.3BC. In general, any references to Cisco IOS Release 12.3BC also apply to Cisco IOS Release 12.2SC.


With RPR+ and DOCSIS SSO, the Cisco uBR10012 can rapidly fail over from the active route processor to the standby processor without the reloading of the cable line cards. However, even though the cable line cards are not reset, the new active route processor needs to perform certain recovery procedures in order for cable line card traffic-flow to resume. A Cisco implementation provides priority-recovery procedures for those modems carrying voice, providing more rapid recovery of voice services.


Note From Cisco IOS release 12.2SC onwards, NSF and SSO is recommended and supported on the Cisco uBR10012 router. For SSO configuration details, see the "Configuring SSO" section in the Stateful Switchover guide at the following link: http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/sso26s.html#wp1338159


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn . You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Prerequisites for Route Processor Plus Redundancy

  • You must have the same image on both the active and standby RPs to support RPR+. If one or more RPs does not have an RPR+ image, the router reverts to RPR mode on both RPs.
  • Two PRE1 or PRE2 modules must be installed in the Cisco uBR10012 chassis. The order number for the PRE1 module is UBR10-PRE1. You cannot mix PRE modules with PRE1 or PRE2 modules in the same chassis.

Note The PRE module no longer ships with the Cisco uBR10012 chassis.


  • For full redundancy, the Fast Ethernet port on the standby RP must have its own connection to the network. The console port on the standby RP must also be connected to a terminal, either by connecting it to a second terminal or by using a terminal server or other device to connect it to the same terminal used by the PRE1 or PRE2 module.
  • Both PRE1 or PRE2 modules must be configured with the same amount of onboard SDRAM. A standby RP cannot come online as the active RP if the standby RP has a smaller amount of SDRAM than the active RP.

Restrictions for Route Processor Plus Redundancy

ARP Filtering Statistics

The Cisco uBR10012 router maintains ARP filtering statistics on the Performance Routing Engine (PRE) module. Statistics are viewed with the show cable arp-filter command for a specified interface. When a switchover event occurs, as in RPR+ Redundancy, these ARP filtering statistics are reset to zero.

For additional information about ARP filtering, refer to the following document on Cisco.com:

  • Cable ARP Filtering

http://www.cisco.com/en/US/docs/cable/cmts/feature/cblarpfl.html

Command-line Interface Synchronization and SNMP

Command-line interface (CLI) configuration commands are synchronized only with the standby Performance Routing Engine (PRE) module. Simple Network Management Protocol (SNMP) persistence is not supported through a PRE1 or PRE2 switchover. Any configuration that is done with SNMP commands is not synchronized with the standby PRE module.

Console Port Usage After a PRE1 or PRE2 Module Switchover

When an active RP fails, and the standby RP becomes the active RP, you must use the console port on the new active RP to give command-line interface (CLI) commands and display statistics for the system. If you have connected your PC or terminal to the console port on an active RP and a switchover occurs, you no longer are able to access the console and the display shows "Standby console disabled."

To access the console, move the PC or terminal's serial cable to the console port on the other PRE1 or PRE2 module, which is now acting as the active RP.

Encrypted Multicast

Encrypted multicast is not supported during a line card switchover nor during a PRE1 or PRE2 switchover.

External Management Stations

External management stations lose connectivity with the cable modem termination system (CMTS) during PRE1 or PRE2 switchover. Stations must reestablish connectivity after the switchover between PRE1 or PRE2 modules is complete.

Flap Detection on WAN Interfaces During Switchover

Neighboring routers detect flapping on WAN interfaces during a switchover. The neighboring routers reconverge after the switchover is complete.


Note Cable interfaces do not flap during a switchover. Service may be temporarily suspended for approximately 30 seconds during a switchover and reinitialization, but service to cable interfaces does not stop.


Link States Reinitialized After Switchover

The synchronization of link states is not maintained between the active and standby RP. Link states are reinitialized after switchover

MIB Variables Reinitialized After Switchover

All MIB variables will be re-initialized following a switchover.

Telnet Sessions Disconnected During Switchover

A switchover automatically disconnects any Telnet sessions on the active (failed) RP.

Information About Route Processor Plus Redundancy

When two route processors (RPs) are installed in a Cisco uBR10012 router chassis, one RP acts as the active RP, and the other acts as a backup, or standby, RP. If the active RP fails, or is removed from the system, the standby RP detects the failure and initiates a switchover. During a switchover, the standby RP assumes control of the router, connects with the network interfaces, and activates the local network management interface and system console.

Using the RPR+ feature, the standby RP is fully initialized and configured. This allows RPR+ to dramatically shorten the switchover time if the active RP fails, or if a manual switchover is performed. Because both the startup configuration and running configuration are continually synchronized from the active to the standby RP, line cards are not reset during a switchover. The interfaces remain up during this transfer, so neighboring routers do not detect a link flap (that is, the link does not go down and back up).

Each RP contains all the resources required to operate the router, such as bootflash memory, Flash disks, Ethernet ports, and console port. In the default operation, the secondary RP also synchronizes the major systems files, such as the Cisco IOS startup configuration file, so that during a switchover, the secondary RP can duplicate the active RP's configuration. This process also resets the cable and network uplink interfaces.

This section describes the switchover process with RPR+, including synchronization between the active and standby RPs, and includes the following topics:

Benefits

DOCSIS Stateful Switchover (DSSO)

DOCSIS stateful switchover (DSSO) increases service uptime by instantaneously switching over between dual route processors should one processor fail. Switchover takes place without resetting or reloading line cards or affecting related subsystems or processes. The advantage of DOCSIS Stateful Switchover (DSSO) (with RPR+) is that a switchover between the primary and standby RP will not require the cable interfaces to be reset, nor do the modems reregister or go offline. Furthermore, the cable modems retain their service IDs (SIDs) through the switchover.

Standard RPR

In standard RPR, the system implemented Extended High System Availability (EHSA) redundancy, wherein the standby RP suspended its initialization midway through the startup process. To complete the initialization during a switchover, all line cards were reset and the switch fabric was reinitialized. Because initialization of the standby RP was suspended before configuration was parsed, chassis discovery and startup configuration parsing were conducted during the switchover.

Improved Switchover Time with RPR+

RPR+ provides a faster switchover by fully initializing and fully configuring the standby RP. The configuration data on the standby RP is fully synchronized with the active RP. With RPR+, the communication with line cards is reinitialized, but the line cards are not reset.

Supported Cable Interface Line Cards and Interface Modules

Beginning with Cisco IOS Release 12.2(11)BC3, the Cisco uBR10012 router supports the following cable interface line cards and interface modules with RPR+ and PRE1 or PRE2 modules:

  • Cisco uBR10-LCP2-MC16C/MC16E/MC16S Line Card
  • Cisco uBR10-LCP2-MC28C/B Line Card
  • Cisco uBR10-MC5X20S Cable Interface Line Card
  • Cisco uBR10-SRP-OC12SML/SMI DPT Adapter Card
  • Cisco uBR10012 OC-48 DPT/POS Interface Module

Terminology Changes with Cisco IOS Release 12.2(11)BC3

In Cisco IOS Release 12.2(11)BC3 and later, the following High Availability terms for the Cisco uBR10012 universal broadband router have been changed:

Old Term
New Term

Failover

Switchover

N+1 Redundancy

1:n Redundancy

Primary RP

Active RP

Secondary RP

Standby RP

Synchronization

To achieve the benefits of RPR+, the chassis and slot configuration information is synchronized from the active RP to the standby RP at startup and whenever changes to the active RP configuration occur. This synchronization occurs in two separate phases:

1. When a standby RP first comes online, the configuration information is synchronized in bulk from the active RP to the standby RP.

2. When configuration changes occur, an incremental synchronization from the active RP to the standby RP is conducted. Incremental synchronizations contain either the modifications to the shelf configuration or the trigger that caused the modification.

Synchronization During Initialization

When a system with RPR+ is initialized, the active RP performs a chassis discovery (discovery of the number and type of line cards and fabric cards in the system) and parses the startup configuration file.

The active RP then synchronizes this data to the standby RP and instructs the standby RP to complete its initialization. This method ensures that both RPs contain the same configuration information.


Note Even though the standby RP is fully initialized, it interacts only with the active RP to receive incremental changes to the configuration files as they occur. CLI commands on the standby RP are not supported.


Synchronization of Startup Configuration

The startup configuration is a text file stored in the RP's NVRAM. During system startup, the startup configuration file is copied from the active RP to the standby RP. Any existing startup configuration file on the standby RP is overwritten.

The startup configuration file is also synchronized whenever you perform the following operations:

  • CLI command: copy system:running-config nvram:startup-config
  • CLI command: copy running-config startup-config
  • CLI command: write memory
  • CLI command: copy filename nvram:startup-config
  • SNMP SET of MIB variable ccCopyEntry in CISCO_CONFIG_COPY MIB
  • System Configuration Saved on reload command.
  • System Configuration Saved on redundancy force-failover command.

Note Synchronization of the startup configuration file is enabled by default in RPR+ mode. Because this is necessary for RPR+ functionality, the command [no] auto-sync startup-config is not available in RPR+ mode. This command is available only in standard RPR mode. For additional information on the use of [no] auto-sync startup-config with standard RPR, see the Route Processor Redundancy for the Cisco uBR10012 Universal Broadband Router.


Incremental Synchronization of the Running Configuration

When both RPs are fully initialized, any further changes to the running configuration are synchronized to the standby RP as they occur.

CLI commands

CLI changes to the running configuration are synchronized from the active RP to the standby RP. In effect, the CLI command is run on both the active and the standby RP.

SNMP SET Commands

Configuration changes caused by an SNMP SET are also synchronized on a case-by-case basis. Currently only two SNMP configuration SETs are supported on the Cisco uBR10012 router:

  • shut/no-shut (of an interface)
  • link up/down trap enable/disable

Changes to Chassis State

  • Any changes to the chassis state because of line card insertion or removal are synchronized over to the standby RP.
  • Changes to the chassis state because of switch card insertion or removal, or from configuration changes to the alarm or power supply cards, are not synchronized to the standby RP. The standby learns these configuration changes using a discovery and reconciliation process during a switchover.
  • Information regarding line card states is not synced. Line cards that are not on line at the time of a switchover (that is, any cards not running the Cisco IOS software and not communicating with the active RP) are reset and reloaded during a switchover. This process does not add downtime.

The RPR+ Switchover Process

A switchover occurs when the standby RP takes over responsibilities from the active RP. The switchover can occur automatically if the standby RP has determined that the active RP has failed, or an operator can initiate a manual switchover whenever desired.

A switchover triggers the following events:

1. If this is a manual switchover, the active RP verifies that the standby RP is present and is running Cisco IOS software that supports the RPR feature. If so, it instructs the standby RP to begin switchover procedures, and the active RP either attempts to reload its configured Cisco IOS software image or enters ROM monitor mode, depending on the setting of its configuration register.

2. The standby RP completes its initialization procedures, which includes completely loading the Cisco IOS software, verifying the physical components of the Cisco uBR10012 chassis, and parsing the startup configuration file. The standby RP is configured identically to the previous active RP, including the IP address for its onboard Fast Ethernet management interface.

3. The standby RP assumes responsibility as the active RP and brings the Cisco uBR10012 chassis into a known state, which includes resetting all installed and enabled line cards and respective interfaces.


Note Resetting the Gigabit Ethernet and OC-12 Packet Over SONET (POS) line cards will interrupt traffic for approximately 30 seconds. The cable interface is not reset, and in support of DOCSIS requirements, the cable modems do not go offline.



Note Depending on the network configuration and on the configuration of the Ethernet/Fast Ethernet interfaces, the network could take between 3 to 25 seconds after an RPR+ switchover before all end-to-end connections are fully restored. During that time it is possible that some packets might be dropped.


4. The new active RP begins normal systems operations, including passing traffic.


Note Depending on the setting of the PRE1 or PRE2 module's configuration register, it either reloads the Cisco IOS software or is left in the ROM monitor state. If the PRE1 or PRE2 module is in the ROM monitor state, it does not begin functioning as a standby RP until it is reloaded with the hw-module sec-cpu reset command.



Note The backup PRE1 or PRE2 module starts forwarding traffic immediately to cable modems, presuming that the interfaces are up, and that all the FIB, adjacency, service flow, classifiers, and Virtual Traffic Management System (VTMS) queue information are correctly configured.


Redundant File Systems

Both the active and standby RPs have active file systems that can be accessed to store and transfer files. Table 1 lists the available file systems, the filenames that you can use with CLI commands to access the file systems, and a short description of each.

 

Table 1 Cisco uBR10012 Router File Systems

File System
Filename for
CLI Commands
Description

Bootflash
Secondary bootflash

bootflash: sec-bootflash:

Stores image and dump files.

NVRAM
Secondary NVRAM

nvram:
sec-nvram:

Typically stores the system default configuration file and startup configuration file.

System

system:

Stores the running configuration and other system files.

Disk 0
Disk 1
Slot 0
Slot 1
Secondary Disk 0
Secondary Disk 1
Secondary Slot 0
Secondary Slot 1

disk0:
disk1:
slot0:
slot1:
sec-disk0:
sec-disk1:
sec-slot0:
sec-slot1:

Disk refers to an ATA Flash disk (48 or 128 MB).
Slot refers to a Flash memory card (8, 16, or 20 MB).1
0 refers to the left slot on the PRE1 or PRE2 module.
1 refers to the right slot on the PRE1 or PRE2 module.
The sec prefix refers to the Flash disk or card in the standby RP.

FTP
TFTP
RCP

ftp:
tftp:
rcp:

Protocols used to transfer files to and from remote devices.

1.Because of the small file system, the slot devices are not typically used on the Cisco uBR10012 router. The disk and sec-disk file systems are typically used instead.

You can use the privileged EXEC commands dir, del, and copy to manage the contents of the file systems. You can also use the commands mkdir and rmdir to create and remove directories on Flash disks. You cannot use the commands squeeze and undelete on Flash disks.


Note For more information about using these file systems, see the “File Management” manual in the Cisco IOS Release 12.2 Configuration Fundamentals Configuration Guide.


DSX Messages and Synchronized PHS Information

Cisco IOS Release 12.3(17a)BC introduces support for PHS rules in a High Availability environment. In this release, and later releases, PHS rules synchronize and are supported during a switchover event of these types:

  • Route Processor Redundancy Plus (RPR+) for the Cisco uBR10012 router, with Active and Standby Performance Routing Engines (PREs)
  • HCCP N+1 Redundancy, with Working and Protect cable interface line cards

For further information about DSX messages and Payload Header Suppression (PHS) information on the Cisco CMTS, refer to these documents, and additional DOCSIS PHS information:

  • Cable DOCSIS 1.1 FAQs , Cisco TAC Document 12182

http://www.cisco.com/en/US/tech/tk86/tk168/technologies_q_and_a_item09186a0080174789.shtml

  • DOCSIS 1.1 for the Cisco CMTS

http://www.cisco.com/en/US/docs/cable/cmts/feature/guide/ufg_docs.html

High Availability Support for Encrypted IP Multicast

Cisco IOS Release 12.3(17a)BC introduces support for IP Multicast streams during switchover events in a High Availability environment. This feature is supported for Route Processor Redundancy Plus (RPR+), N+1 Redundancy, and encrypted BPI+ streams.

For additional information about IP Multicast and High Availability, refer to these documents on Cisco.com:

  • Cisco CMTS Universal Broadband Router MIB Specifications Guide

http://www.cisco.com/en/US/docs/cable/cmts/mib/12_2sc/reference/guide/ubrmibv5.html

  • Dynamic Shared Secret for the Cisco CMTS

http://www.cisco.com/en/US/docs/cable/cmts/feature/ubrdmic.html

  • IP Multicast in Cable Networks, White Paper

http://www.cisco.com/en/US/technologies/tk648/tk828/technologies_case_study0900aecd802e2ce2.html

  • N+1 Redundancy for the Cisco Cable Modem Termination System

http://www.cisco.com/en/US/docs/ios/cable/configuration/guide/cmts_nplus1_redun.html

How to Configure, Verify, and Troubleshoot Route Processor Plus Redundancy

This section provides the following procedures to configure and verify RPR+ and high availability on the Cisco uBR10012 router.

Configuring RPR+ on the Cisco uBR10012 Universal Broadband Router

The default redundancy mode in the Cisco uBR10012 router is standard Route Processor Redundancy (RPR). Perform the steps below to enable RPR+ on the Cisco uBR10012 router.

Prerequisites

To enable RPR+, both route processors must be running the same version of Cisco IOS software.


Note If necessary, refer to the “Upgrading Cisco IOS Software Images” section on page 14 to change the image on the Cisco uBR10012 router. Reload is required.


SUMMARY STEPS

1. enable

2. configure terminal

3. main-cpu

4. auto-sync option

5. no auto-sync option (optional)

6. CTRL-Z

7. copy running-config startup-config

DETAILED STEPS

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

main-cpu

 

Router(config)# main-cpu

Enters the main CPU configuration mode. (This configures the active RP, not the standby RP.) Refer to main-cpu command, for additional command syntax information.

Step 4

auto-sync option

 

Router(config-r-mc)# auto-sync standard

Specifies the files to be synchronized. Refer to auto-sync command, for additional command syntax information.

Note Cisco strongly recommends that you use the auto-sync standard command to ensure that all system files remain synchronized between the two PRE1 or PRE2 modules.

Step 5

no auto-sync option

 

Router(config-r-mc)# no auto-sync standard

(Optional) Specifies that one or more files should not be synchronized. Option can be any of the values specified previously.

Note The no auto-sync command is not typically used in production plants.

Step 6

CTRL-Z

 

Router(config-r-mc)# CTRL-Z

Returns to privileged EXEC mode.

Step 7

copy running-config startup-config

 

Router# copy running-config startup-config

Saves the current configuration as the default startup configuration.

Verifying RPR+ Configuration

Perform the steps below to verify that RPR+ is configured on the Cisco uBR10012 router:

SUMMARY STEPS

1. enable

2. show startup-config

3. show redundancy

DETAILED STEPS

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

show startup-config

 
Router# show startup-config
...
redundancy
main-cpu
auto-sync standard
...

Displays the startup configuration and verify that the lines configuring redundancy appear.

Note If the auto-sync line contains anything other than standard, it indicates that only some of the required system files are being synchronized between the two PRE1 or PRE2 modules. Verify that this is the desired configuration. If necessary, refer to the “Configuring RPR+ on the Cisco uBR10012 Universal Broadband Router” section to reconfigure the router for auto-sync standard operation.

Step 3

show redundancy

 
Router# show redundancy
PRE1 A (This PRE1) : Primary
PRE1 B : Secondary

...

Displays the current RPR state. The active RP typically is shown in slot A.

Examples

If a switchover has occurred, the show redundancy command displays information similar to the following, showing that the active RP has changed slots (in this case, moving from slot A to slot B):

Router# show redundancy
 
PRE1 A : Secondary
PRE1 B (This PRE1) : Primary
Redundancy state is REDUNDANCY_PEERSECONDARY_INITED
Secondary RP information....
Secondary is up.
Secondary BOOT variable = bootflash:ubr10k-k8p6-mz
Secondary CONFIG_FILE variable =
Secondary BOOTLDR variable = bootflash:c10k-eboot-mz
Secondary Configuration register is 0x2
Router#
 

If the standby RP is not installed or is not operational, the show redundancy command displays information similar to the following:

Router# show redundancy
 
PRE1 A (This PRE1) : Primary
PRE1 B : Secondary
Redundancy state is REDUNDANCY_PEERSECONDARY_NONOPERATIONAL
Secondary RP information....
Secondary RP is not up
 

Note The show redundancy command shows whether the PRE1 A slot or PRE1 B slot contains the active (Primary) PRE1 module. The other PRE1 slot will always be marked as Secondary, even if a second PRE1 module is not installed.


Upgrading Cisco IOS Software Images

RPR+ is enabled by default with the Cisco IOS Release 12.2(11)BC3 and later releases. Use this set of procedures when you need to upgrade your Cisco IOS to a release that supports RPR+ on the Cisco uBR10012 router.

Cisco IOS software upgrade involves these three procedures:

Prerequisites


Note You are required to have the same image on both the active and standby RPs to support RPR+. If one or more RPs does not have an RPR+ image, the router reverts to RPR mode on both RPs.


Creating Additional Disk Space (Optional)

(Optional) To create additional disk space in preparation for the RPR+ image, issue the following commands from global configuration mode on the active and standby RPs (where slot is the RP slot number and filename is the RPR+ image file name).

SUMMARY STEPS

1. delete slot slot:filename or delete sec-slot slot:filename

2. squeeze flash:

DETAILED STEPS

Step 1

delete slot 0:filename
or
delete sec-slot 0:filename
 

Router(config)# delete slot 0:ubr10k-p6-mz

or

Router(config)# delete sec-slot 0:ubr10k-p6-mz

Deletes an old file from the active or standby RP to make room for the new file.

Step 2

squeeze flash:
 

Router(config)# squeeze flash:

Permanently deletes all files marked "delete" on a Flash memory device, recovering space on the device.

 

Copying the Cisco IOS Image

To copy the Cisco IOS image from a TFTP server, and to set the boot variable on the active RP, issue the following commands in global configuration mode (where filename is the RPR+ image fil name).

SUMMARY STEPS

1. copy tftp://tftp-server/filename bootflash:filename
or
copy tftp://tftp-server/filename sec-bootflash:filename

2. boot system bootflash:filename

3. write memory

4. show bootvar

DETAILED STEPS.

Step 1

copy tftp://tftp-server/filename bootflash:filename

or

copy tftp://tftp-server/filename sec-bootflash:filename
 
Router# copy tftp://tftp-server/ubr10k-p6-mz bootflash:ubr10k-p6-mz
or
Router# copy tftp://tftp-server/ubr10k-p6-mz sec-bootflash:ubr10k-p6-mz

Copies the Cisco IOS image from a TFTP server to the bootflash of the active or standby RP. This command allows you to change software images without requiring access to the TFTP monitor mode.

The image you download is made available to the Cisco uBR10012 router on the next reload (reboot).

Step 2

boot system bootflash:filename
 

Router# boot system bootflash:ubr10k-p6-mz

Sets the BOOT environment variable. This variable specifies the location and name of the system image file to use when automatically booting the system.

Step 3

write memory
 
Router# write memory

Saves the configuration.

Step 4

show bootvar
 

Router# show bootvar

Displays the contents of the BOOT variable, the name of the configuration file pointed to by the CONFIG_FILE variable, the contents of the BOOTLDR variable, and the configuration register setting.

Resetting a PRE1 or PRE2 Module or Line Card After Upgrade

To reset a particular route processor (RP) or a particular line card, use the hw-module reset command in privileged EXEC mode.

SUMMARY STEPS

1. hw-module reset

DETAILED STEPS.

Step 1

hw-module sec-cpu reset
 
Router# hw-module sec-cpu reset

Resets the specified RP or line card slot.

for additional command syntax information.

 

Reloading Cisco IOS (Restarting the System)

To reload the operating system, use the reload command in privileged EXEC mode.


Note This reload is required if you are reloading an RPR+ image, but optional otherwise. The reload command restarts the entire system, including both the active and standby RPs.


SUMMARY STEPS

1. reload

DETAILED STEPS.

Step 1

Router# reload
 
Router# reload

Reloads the operating system and restarts the router.


Note If you are upgrading from a Cisco IOS image previously configured with RPR+ to a newer image with RPR+, the procedure is now complete. When the new active RP comes up, it will automatically configure RPR+ from the configuration information in the startup configuration (synchronized from the old active RP).


Performing a Manual Route Processor Switchover

For testing or maintenance, you may need to perform a manual switchover in which your standby RP becomes your active RP. Perform the following steps to force a manual switchover between RPs.

SUMMARY STEPS

1. show cable modem

2. redundancy force-failover main-cpu

3. show cable modem

DETAILED STEPS

Command or Action
Purpose

Step 1

show cable modem

 

Router> show cable modem

Displays information for the registered and unregistered cable modems supported by the active RP. The output from this command provides information that confirms successful switchover in pending steps.

Step 2

redundancy force-failover main-cpu

 

Router# configure terminal

Forces a switchover on the active RP. The standby RP becomes the active RP with a switchover time of approximately 30 seconds or less.

Note The modems do not redefine their ranges and the line cards do not reset during switchover.

Step 3

show cable modem

 

Router> enable

Displays information for the registered and unregistered cable modems supported by the newly active RP (formerly the standby RP).

 

Troubleshooting Route Processor Redundancy Plus

If RPR+ is not enabled after mode rpr-plus is run, verify that both the active and standby RPs are running Cisco IOS Release 12.2(11)BC3 or a later release.


Note If the active RP detects a different version of the image on the standby RP, the system automatically reverts to standard RPR behavior.


Configuration Examples for Route Processor Plus Redundancy

This section provides the following command examples that display the configuration and status of RPR+ on a Cisco uBR10012 router chassis with active and standby RPs. These commands all illustrate the same Cisco uBR10012 chassis:

  • show redundancy
  • show running configuration
  • show version

The following show redundancy command displays the slots for the primary RP (PRE in slot 15), the secondary RP (PRE in slot 7), and additional redundancy mode information.

Router# show redundancy
 
Primary PRE in slot 15:
Secondary PRE in slot 7:
Preferred PRE: 15
Operating Redundancy Mode: RPR Plus
Auto synch: startup-config running-config
switchover timer 8 seconds [default]
 

The following show running configuration command displays RPR+ information such as main-cpu and auto-sync status.

Router# show run
 
Building configuration...
 
Current configuration : 10895 bytes
!
version 12.2
no parser cache
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
service udp-small-servers max-servers no-limit
!
hostname "Router"
!
boot system flash bootflash:ubr10k-k8p6-mz.999-99.122BC_UB_030303
redundancy
no keepalive-enable
main-cpu
auto-sync standard
no logging rate-limit
enable password cisco
!
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm intake-temperature critical 57
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
facility-alarm core-temperature critical 60
card 1/0 1gigethernet-1
card 1/1 2cable-tccplus
card 3/0 1oc12pos-1
card 4/0 1gigethernet-1
card 5/0 2cable-mc28c
card 5/1 cable-lcp
card 6/0 2cable-mc28c
card 7/0 2cable-mc28c
card 8/0 1cable-mc16s
card 8/1 1cable-mc16s
cable modem max-cpe unlimited
cable spectrum-group 1 band 8000000 20000000
cable modulation-profile 1 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16
cable modulation-profile 1 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 1 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 1 short 6 75 6 8 16qam scrambler 152 no-diff 144 shortened uw8
cable modulation-profile 1 long 8 220 0 8 16qam scrambler 152 no-diff 160 shortened uw8
cable modulation-profile 2 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16
cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 short 6 75 6 8 16qam scrambler 152 no-diff 144 shortened uw8
cable modulation-profile 2 long 8 220 0 8 16qam scrambler 152 no-diff 160 shortened uw8
no cable qos permission create
no cable qos permission update
cable qos permission modems
no cable service flow inactivity-threshold
cable time-server
ip subnet-zero
ip cef table resolution-timer 1
no ip domain lookup
ip host abrick 223.255.254.254
ip dhcp relay information option
!
ip dhcp pool modems-c6
network 1.6.1.64 255.255.255.224
bootfile schcfr_new.cm
next-server 1.10.41.3
default-router 1.10.41.3
option 7 ip 1.10.41.3
option 4 ip 1.6.1.65
option 2 hex ffff.8f80
!
ip dhcp pool modems-c5
network 1.5.1.64 255.255.255.224
bootfile schcfr_new.cm
next-server 1.5.1.65
default-router 1.5.1.65
option 7 ip 1.5.1.65
option 4 ip 1.5.1.65
option 2 hex ffff.8f80
!
ip dhcp pool modems-c7
network 1.7.1.64 255.255.255.224
bootfile up2-down2-nobpi.cm
next-server 1.10.41.3
default-router 1.10.41.3
option 7 ip 1.10.41.3
option 4 ip 1.7.1.65
option 2 hex ffff.8f80
!
ip dhcp pool modems-c8
network 1.8.1.64 255.255.255.224
bootfile schcfr_new.cm
next-server 1.8.1.65
default-router 1.8.1.65
option 7 ip 1.8.1.65
option 4 ip 1.8.1.65
option 2 hex ffff.8f80
!
ip dhcp pool modems-c51
network 1.9.1.64 255.255.255.224
bootfile config.cm
next-server 1.10.41.3
default-router 1.10.41.3
option 7 ip 1.10.41.3
option 4 ip 1.9.1.65
option 2 hex ffff.8f80
!
ip multicast-routing
!
!
interface Loopback1
ip address 222.1.1.1 255.255.255.0
!
interface FastEthernet0/0/0
ip address 1.10.41.3 255.255.0.0
no ip proxy-arp
no ip route-cache
no ip mroute-cache
load-interval 30
no cdp enable
!
interface GigabitEthernet1/0/0
ip address 1.1.1.1 255.255.0.0
no negotiation auto
no cdp enable
!
interface POS3/0/0
ip address 200.200.0.1 255.255.0.0
shutdown
crc 32
no cdp enable
pos ais-shut
!
interface GigabitEthernet4/0/0
no ip address
negotiation auto
no cdp enable
!
interface Cable5/0/0
no ip address
load-interval 30
no keepalive
cable bundle 1 master
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 441000000
cable downstream channel-id 60
cable upstream 0 spectrum-group 1
cable upstream 0 power-level 0
no cable upstream 0 concatenation
cable upstream 0 data-backoff automatic
no cable upstream 0 shutdown
cable upstream 1 power-level 0
cable upstream 1 shutdown
cable upstream 2 power-level 0
cable upstream 2 shutdown
cable upstream 3 power-level 0
cable upstream 3 shutdown
hccp 1 working 5
hccp 1 channel-switch 5 uc wavecom-ma 1.10.41.6 2 1.10.41.5 1
hccp 1 channel-switch 5 nru rfswitch-group 1.10.41.7 80080000 1
hccp 1 reverttime 6
!
interface Cable5/0/0.1
ip address 111.111.111.1 255.255.255.0 secondary
ip address 1.5.1.65 255.255.255.224
ip pim sparse-mode
ip helper-address 1.10.41.3
ip igmp static-group 239.0.0.11
ip igmp static-group 239.0.0.12
ip igmp static-group 239.0.0.14
ip igmp static-group 239.0.0.16
ip igmp static-group 239.0.0.32
ip igmp static-group 239.0.0.35
ip igmp static-group 239.0.0.36
cable source-verify dhcp
cable dhcp-giaddr policy
!
interface Cable5/0/1
no ip address
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream channel-id 1
cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
!
interface Cable6/0/0
no ip address
no keepalive
cable bundle 1
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 441000000
cable downstream channel-id 70
cable upstream 0 frequency 12000000
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 power-level 0
cable upstream 1 shutdown
cable upstream 2 power-level 0
cable upstream 2 shutdown
cable upstream 3 power-level 0
cable upstream 3 shutdown
hccp 1 working 6
hccp 1 channel-switch 6 uc wavecom-ma 1.10.41.6 2 1.10.41.5 2
hccp 1 channel-switch 6 nru rfswitch-group 1.10.41.7 80080000 2
!
interface Cable6/0/1
no ip address
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream channel-id 1
cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
!
interface Cable7/0/0
no ip address
no keepalive
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 441000000
cable downstream channel-id 60
cable upstream 0 power-level 0
no cable upstream 0 concatenation
no cable upstream 0 shutdown
cable upstream 1 power-level 0
cable upstream 1 shutdown
cable upstream 2 power-level 0
cable upstream 2 shutdown
cable upstream 3 power-level 0
cable upstream 3 shutdown
hccp 1 protect 5 222.1.1.1
hccp 1 channel-switch 5 nru rfswitch-group 1.10.41.7 80080000 1
hccp 1 channel-switch 5 uc wavecom-ma 1.10.41.6 2 1.10.41.5 1
hccp 1 protect 6 222.1.1.1
hccp 1 channel-switch 6 uc wavecom-ma 1.10.41.6 2 1.10.41.5 2
hccp 1 channel-switch 6 nru rfswitch-group 1.10.41.7 80080000 2
hccp 1 timers 5000 15000
!
interface Cable7/0/1
no ip address
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream channel-id 1
cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
!
interface Cable8/0/0
no ip address
ip access-group 99 in
no keepalive
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 441000000
cable downstream channel-id 60
cable upstream 0 spectrum-group 1
cable upstream 0 power-level 0
cable upstream 0 modulation-profile 2 1
no cable upstream 0 shutdown
cable upstream 1 power-level 0
cable upstream 1 shutdown
cable upstream 2 power-level 0
cable upstream 2 threshold cnr-profile1 21 cnr-profile2 11 Corr-Fec 11 Uncorr-Fec 21
cable upstream 2 shutdown
cable upstream 3 power-level 0
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 shutdown
hccp 2 working 8
hccp 2 channel-switch 8 uc wavecom-ma 1.10.41.6 2 1.10.41.5 1
hccp 2 channel-switch 8 nru rfswitch-group 1.10.41.7 80080000 1
!
interface Cable8/0/0.1
ip address 1.8.1.65 255.255.255.224
cable source-verify dhcp
!
interface Cable8/1/0
no ip address
no keepalive
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 441000000
cable downstream channel-id 60
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 power-level 0
cable upstream 1 shutdown
cable upstream 2 power-level 0
cable upstream 2 shutdown
cable upstream 3 power-level 0
cable upstream 3 shutdown
cable upstream 4 power-level 0
cable upstream 4 shutdown
cable upstream 5 power-level 0
cable upstream 5 shutdown
hccp 2 protect 8 222.1.1.1
hccp 2 channel-switch 8 uc wavecom-ma 1.10.41.6 2 1.10.41.5 1
hccp 2 channel-switch 8 nru rfswitch-group 1.10.41.7 80080000 1
hccp 2 timers 5000 15000
no hccp 2 revertive
!
ip default-gateway 1.10.0.1
ip classless
ip route 1.9.0.0 255.255.0.0 1.10.0.1
ip route 2.6.0.0 255.255.0.0 200.200.0.2
ip route 223.255.254.254 255.255.255.255 1.10.0.1
no ip http server
ip pim bidir-enable
!
ip access-list standard XYZ
permit any
ip access-list standard pqRS
permit any
no logging linecard
access-list 3 permit 210.221.55.46
access-list 99 permit any
access-list 110 permit ip any any
access-list 110 permit udp any eq bootps any
access-list 111 permit udp any eq bootps any
arp 1.10.41.6 0020.4a51.1776 ARPA
arp 1.10.41.5 0020.4a51.00ea ARPA
no cdp run
snmp-server manager
tftp-server bootflash:up2-down2-nobpi.cm alias up2-down2-nobpi.cm
tftp-server bootflash:tony11.cm alias tony11.cm
tftp-server bootflash:up2-down2.cm alias up2-down2.cm
tftp-server bootflash:new-privacy.cm alias new-privacy.cm
tftp-server bootflash:10.cm alias 10.cm
tftp-server bootflash:att-10plus.cm alias att-10plus.cm
tftp-server bootflash:schcfr_new.cm alias schcfr_new.cm
tftp-server bootflash:test11.cm alias test11.cm
tftp-server bootflash:4us16ds.cm alias 4us16ds.cm
!
alias exec scm show cable modem
alias exec sqos show cable qos profile
alias exec shc show hccp
alias exec nd no debug all
alias exec sr show running-config
alias exec sip show ip interface b
alias exec dc debug hccp channel-switch
alias exec spm sh proc mem | in HCCP
alias exec de debug hccp event
alias exec ds debug hccp sync
alias exec dp debug hccp plane
alias exec dt debug hccp timing
alias exec dipc debug cr10k-rp ipc
alias exec dpm debug hccp plane message
alias exec dpp debug hccp plane packet
alias exec sib show ip int br
alias exec shb show hccp br
alias exec scs show cable spectrum-group
!
line con 0
exec-timeout 0 0
line aux 0
stopbits 1
speed 19200
line vty 0 4
exec-timeout 0 0
password lab
login
length 0
!
end
 

The following show version command displays active and standby RP status.

Router# show version
 
Cisco Internetwork Operating System Software
IOS (tm) 10000 Software (UBR10K-K8P6-M), Version 12.2(122BC.030303.)
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Mon 03-Mar-03 21:23 by
Image text-base: 0x60008954, data-base: 0x61B00000
 
ROM: System Bootstrap, Version 12.0(9r)SL2, RELEASE SOFTWARE (fc1)
 
amit-rp2 uptime is 57 minutes
System returned to ROM by reload at 02:05:40 UTC Sun Nov 26 2000
System image file is "bootflash:ubr10k-k8p6-mz.999-99.122BC_UB_030303"
 
cisco uBR10000 (PRE1-RP) processor with 393215K/131072K bytes of memory.
Processor board ID TBA05191959
R7000 CPU at 262Mhz, Implementation 39, Rev 2.1, 256KB L2, 2048KB L3 Cache
Backplane version 1.0, 8 slot
 
Last reset from other pre
Toaster processor tmc0 is running.
Toaster processor tmc1 is running.
1 OC12 POS controller (1 POS)
1 TCCplus card(s)
1 FastEthernet/IEEE 802.3 interface(s)
1 Gigabit Ethernet/IEEE 802.3 interface(s)
1 Packet over SONET network interface(s)
8 Cable Modem network interface(s)
509K bytes of non-volatile configuration memory.
 
125440K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).
32768K bytes of Flash internal SIMM (Sector size 256KB).
Secondary is up.
Secondary has 524288K bytes of memory.
 
Configuration register is 0x0
 

 

Additional References

To access documentation for the Cisco uBR10012 universal broadband router and router components, use the following procedure:


Step 1 Go to the Cisco website at http://www.cisco.com/ .

Step 2 Select Products and Services from the Welcome to Cisco Systems list.

Step 3 Select Cable Products from the Products list.

Step 4 Select Cisco uBR10012 Universal Broadband Router from the Cisco Cable Products list.

Step 5 Select Technical Documentation from the Cisco uBR10012 universal broadband router menu.

To go directly to this website, enter the following URL in your web browser.

http://www.cisco.com/en/US/products/hw/cable/ps2209/tsd_products_support_series_home.html


 

The following documents provide additional information about the Cisco uBR10012 universal broadband router, supporting line cards and interface modules, and feature configuration.

Document
Description

Cisco IOS CMTS Cable Command Reference

Contains the cable-specific commands for the Cisco uBR7100 series, Cisco uBR7200 series, and Cisco uBR10012 universal broadband routers.

Cisco IOS CMTS Cable Software Configuration Guide

Document describes software features contained in the Cisco Cable Modem Termination System (CMTS). Each chapter describes a feature; the supported releases; benefits; restrictions; any supported standards, MIBs, or RFCs; any prerequisites; and the configuration tasks and examples used to set up and implement the feature. The CMTS features are used by the Cisco uBR7100 series, the Cisco uBR7200 series, and the Cisco uBR10012 universal broadband routers.

Cisco High Availability Initiatives

Article provides an overview of high availability networks and Cisco’s related initiatives and hardware.

Documentation for the Cisco uBR10000 Series Universal Broadband Routers

Web page provides an index of primary documentation for the Cisco uBR10012 router, including release notes, Field Replaceable Units, installation and configuration documents.

 

Supported Standards, MIBs, and RFC

MIBs
MIBs Link
  • No new or modified MIBs are supported by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/cisco/web/support/index.html

Command Reference

The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS Cable Command Reference at http://www.cisco.com/en/US/docs/ios/cable/command/reference/cbl_book.html. For information about all Cisco IOS commands, go to the Command Lookup Tool at http://tools.cisco.com/Support/CLILookup or to the Cisco IOS Master Commands List .

  • auto-sync
  • debug checkpoint
  • debug cr10k-rp
  • debug redundancy
  • hw-module reset
  • main-cpu
  • redundancy force-failover main-cpu
  • secondary aux
  • show cable modem
  • show chassis eeprom
  • show checkpoint
  • show redundancy
  • switchover timeout