Guest

Support

Planning to Configure the GGSN

Hierarchical Navigation

  • Viewing Options

  • PDF (229.0 KB)
  • Feedback
Planning to Configure the GGSN

Table Of Contents

Planning to Configure the GGSN

Supported Platforms

Prerequisites

Before You Begin

Cisco 7200 Series Platform Prerequisites

Catalyst 6500 / Cisco 7600 Series Platform Prerequisites

Hardware and Software

Required Base Configuration

Restrictions

Supported Standards, MIBs, and RFCs

Related Documents


Planning to Configure the GGSN


This chapter provides information that you should know before configuring a gateway GPRS support node (GGSN).

This chapter includes the following sections:

Supported Platforms

Prerequisites

Restrictions

Supported Standards, MIBs, and RFCs

Related Documents

Supported Platforms

Cisco GGSN Release 5.2, Cisco IOS Release 12.3(14)YQ, is supported on the Cisco 7200 and the Cisco Multi-Processor WAN Application Module (MWAM) for the Catalyst 6500 series switch / Cisco 7600 series Internet router platforms. However, the GGSN Release 5.2 Service-Aware GGSN feature is supported on the Catalyst 6500 series switch / Cisco 7600 series router platform only.

Prerequisites

Depending on the platform on which you are implementing a GGSN, the prerequisites vary. The sections below provide general guidelines to follow before configuring a GGSN in your network:

Before You Begin

Cisco 7200 Series Platform Prerequisites

Catalyst 6500 / Cisco 7600 Series Platform Prerequisites

Before You Begin

Before you begin to configure a GGSN, you should know which networks your mobile users will be allowed to access using the GGSN. After you identify the networks, you can plan the interfaces to configure for those networks and plan the associated access points to those networks and configure them on the GGSN. For example, you might want to provide user access to the World Wide Web through a public data network (PDN), plus access to two private corporate intranets. In this case, you need to set up three access points—one to enable user access to the PDN, and one for each of the two private intranets.

Cisco 7200 Series Platform Prerequisites

In addition to following the general guidelines documented in the "Before You Begin" section, ensure that the following hardware and software requirements are met before you implement a GGSN in a General Packet Radio Service/Universal Mobile Telephone Service (GPRS/UMTS) network on the Cisco 7200 series router platform:

Cisco 7200 VXR router with network processing engine (NPE) models NPE-300 or NPE-400 running Cisco IOS Release 12.2(8)YW and later—(Required)

Integrated Services Adapter (ISA)—(Optional) Provides IP security protocol (IPSec) support.

Catalyst 6500 / Cisco 7600 Series Platform Prerequisites

In addition to following the general guidelines given in the "Before You Begin" section, when configuring GGSNs on the Catalyst 6500 series switch / Cisco 7600 series Internet router platform, ensure that requirements outlined in the following sections are met:

Hardware and Software

Required Base Configuration

Hardware and Software

The following sections list the minimum hardware and software requirements for implementing a GGSN on a Catalyst 6500 / Cisco 7600 platform.

GGSN Release 4.0 and GGSN Release 5.0

GGSN Release 5.1—GTP-SR

GGSN Release 4.0 and GGSN Release 5.0

Implementing GGSNs in a GPRS/UMTS network on the Catalyst 6500 series switch / Cisco 7600 series Internet router platform requires the following hardware and software:

Catalyst 6500 series switch / Cisco 7600 series Internet router in which a Supervisor Engine 2 (Sup2) with the 512-MB Multilayer Switch Feature Card 2 (MSFC2) is installed and running Cisco IOS Release 12.2(14)ZA1 and later—(Required) Performs routing and/or switching and Cisco IOS GPRS Tunneling Protocol (GTP) Server Load Balancing (SLB) functions.

Additional Supervisor Engine 2 (Sup2) with 512 MB MSFC2—(Optional) Functions as a redundant Supervisor Engine.

Catalyst 6500 / Cisco 7600 Fast Ethernet / Gigabit Ethernet port adapter (such as the Catalyst 6500 48-port 10/100)—(Required) Provides physical connectivity to the GPRS/UMTS network elements such as the SGSN, authentication, authorization, and accounting (AAA), and charging gateway (CG).

Cisco Multi-Processor WAN Application Module (MWAM) running the Cisco IOS Release 12.3(2) XB or later release GGSN feature—(Required) Enables up to 5 instances of a Cisco IOS mobile wireless application, such as a GGSN, to be configured and running on one module. Up to two MWAMs can be installed and configured in a Catalyst 6500 / Cisco 7600 chassis, enabling the configuration of up to 10 GGSNs in one chassis. The interfaces to the IOS instances are Gigabit Ethernet 802.1Q trunk ports which carry VLAN-encapsulated traffic to and from the network through the switched fabric.

VPN IPSec Module—(Optional) Performs IPSec.

GGSN Release 5.1—GTP-SR

Implementing the GGSN Release 5.1 GTP-SR feature requires the following hardware and software:

Two Cisco 7600 series routers with a Cisco Supervisor Engine 720 and third-generation policy feature card (PFC3BXL) with integrated Multilayer Switch Feature Card 3 (MSFC3). The MSFC3s must be running the same Cisco IOS software release.

A Cisco Multi-Processor WAN Application Module (MWAM) in each of the Cisco 7600 series routers. The MWAMs must be running the same Cisco IOS GGSN software release.

GGSN Release 5.2—Service-Aware GGSN

Implementing the GGSN Release 5.2 service-aware GGSN feature requires the following hardware and software:

Two Catalyst 6500 series switches / Cisco 7600 series Internet routers in which Sup720s with the 512-MB Multilayer Switch Feature Card 2 (MSFC2) are installed and running Cisco IOS Release 12.2(18)SXE and later.

Depending on GGSN scaling and redundancy, Multiple Cisco Multi-Processor WAN Application Module (MWAMs), each with the 1 GB memory option.

IPSec VPN card (for security)

A Cisco Content Services Gateway (CSG) module in each of the Cisco 7600 series routers. The CSGs must be running the same Cisco CSG software release, Release 3.1(3)C6(1) or later.

Required Base Configuration

After connectivity has been established from the switch to the different elements in your network, ensure that you complete the following base configuration before implementing and customizing GGSNs on the Cisco MWAM:

1. On the Supervisor/MSFC2, ensure that

a. A Layer-3-routed VLAN for each of the GPRS/UTMS interfaces has been created. Specifically, create a VLAN for the following interfaces:

— Gn VLAN—Interconnects the Gn interfaces.

— Ga VLAN—Interconnects the Ga interfaces.

— AAA/OAM/DHCP VLAN—Interconnects the GGSN interfaces used for AAA, Operation, Administration, and Maintenance (OAM), and DHCP functions.

— One VLAN per APN Gi interface

You can configure the VLANs from VLAN database mode or global configuration mode.


Note You cannot configure extended-range VLANs in VLAN database mode. You can configure extended-range VLANs only in global configuration mode.



Note RPR+ redundancy does not support configurations entered in VLAN database mode. If you have a high-availability configuration with redundant Supervisor modules using RPR(+), configure the VLANs in global configuration mode and not through the VLAN database mode; otherwise, the VLAN information will not be synchronized to the redundant Supervisor module.


To configure a VLAN from global configuration mode:

Sup#conf terminal 
Enter configuration commands, one per line. End with CNTL/Z. 
Sup(config)#vlan 222 
Sup(config-vlan)#end 
Sup# 

In the preceding examples, VLAN 222 is a Layer 2-switched VLAN. The subnet associated with it is not known by the MSFC2 routing table. To configure VLAN 222 as a Layer 3-switched VLAN (or routed VLAN), specify a VLAN 222 interface on the MSFC2 and assign an IP address to the interface:

Sup# configure terminal
Sup(config)# interface vlan222
Sup(config-if)# ip address n.n.n.n mask
Sup(config-if)# no ip redirects

The following is an example of the VLAN configuration on the MSFC2:

Sup# show running-config
!
. . .
vlan 103,110,160,200,300-301,310 
!
!
interface Vlan103
 description Gn VLAN
 ip address 10.20.21.1 255.255.255.0
 no ip redirects
!
interface Vlan110
 description OAM/AAA/DHCP VLAN
 ip address 10.20.50.1 255.255.255.0
 no ip redirects
!
interface Vlan200
 description Ga Charging VLAN
 no ip address
 no ip redirects
!
interface Vlan310
 description VLAN for APN Internet
 ip address 10.20.51.1 255.255.255.0

For detailed information on configuring VLANs, see the Catalyst 6500 Series Software Configuration Guide.

b. The Cisco IOS software server load balancing (SLB) feature is installed and configured for GTP load balancing. For more information, see the IOS Server Load Balancing feature module and "Configuring Load Balancing on the GGSN."

c. The Cisco MWAM has been added to each of the VLANs you created, using the mwam module allowed-vlan command. For more information, see the Cisco Multiprocessor WAN Application Module Installation and Configuration Note.


Note VLAN IDs must be consistent be the same in the MSFC2 and Cisco MWAM configurations.


The following is an example of the mwam module allowed-vlan configuration:

!
...
!
mwam module 7 port 1 allowed-vlan 71,95,100,101
mwam module 7 port 2 allowed-vlan 71,95,100,101
mwam module 7 port 3 allowed-vlan 71,95,100,101
!
...
!

d. A static route is configured to each Cisco IOS instance configured as a GGSN on the Cisco MWAM:

!
...
!
ip route 10.20.30.1 255.255.255.255 10.20.21.20
ip route 10.20.30.2 255.255.255.255 10.20.21.21
ip route 10.20.30.3 255.255.255.255 10.20.21.22
ip route 10.20.30.4 255.255.255.255 10.20.21.23
ip route 10.20.30.5 255.255.255.255 10.20.21.24
!
...
!

2. On each GGSN instance configured on the Cisco MWAM, ensure that

a. A static route is configured to the Supervisor/MSFC2.

!
...
!
ip route 0.0.0.0.0 0.0.0.0 10.20.21.1
...
!

b. A subinterface is configured on which 802.1Q encapsulation is enabled to each of the VLANs you created on the MSFC2.

The following is an example of a Ga/Gn subinterface configuration on the GGSN to VLAN 103 configured on the MSFC2:

!
...
interface GigabitEthernet0/0.2
 description Ga/Gn Interface
 encapsulation dot1Q 101
 ip address 10.1.1.72 255.255.255.0
 no cdp enable
...
!

For detailed information on configuring

— Ga subinterfaces, see the "Configuring an Interface to the Charging Gateway" section.

— Gn subinterfaces, see the "Configuring an Interface to the SGSN" section.

— Gi subinterfaces, see the "Configuring an Interface to a PDN" section.

Configuration Examples

The following are base configuration examples for the Supervisor/MSFC2 and the GGSN instance running on the Cisco MWAM.

Supervisor / MSFC2


hostname Cat6500-a
!
boot system flash 
boot device module 7 cf:4

mwam module 7 port 1 allowed-vlan 71,95,100,101
mwam module 7 port 2 allowed-vlan 71,95,100,101
mwam module 7 port 3 allowed-vlan 71,95,100,101
vtp mode transparent
redundancy
 mode rpr-plus
 main-cpu
  auto-sync running-config
  auto-sync standard
!
power redundancy-mode combined
!
!
vlan 1
 vlan1 1002
 vlan2 1003
!
vlan 2
 name SNIFFER
!
vlan 71,95 
!
vlan 100
 name Internal_Gi_for_GGSN-MWAM
!
vlan 101
 name Internal_Gn/Ga
!
vlan 165
!
vlan 302
 name Gn_1
!
vlan 303
 name Ga_1
!
vlan 1002
 vlan1 1
 vlan2 1003
!
vlan 1003
 vlan1 1
 vlan2 1002
 parent 1005
 backupcrf enable
!
vlan 1004
 bridge 1
 stp type ibm
!
vlan 1005
 bridge 1
!
interface FastEthernet8/22
 description To SGSN
 no ip address
 switchport
 switchport access vlan 302
!
interface FastEthernet8/23
 description To CGF
 no ip address
 switchport
 switchport access vlan 302
!
interface FastEthernet8/26
 description To DHCP/RADIUS Servers
 no ip address
 switchport
 switchport access vlan 95
!
interface FastEthernet8/31
 description To BackBone
 no ip address
 switchport
 switchport access vlan 71
!
interface FastEthernet9/32
 description To CORPA
 no ip address
 switchport
 switchport access vlan 165
 no cdp enable
!
!interface Vlan1
 no ip address
 shutdown
!
interface Vlan71
 description VLAN to tftpserver
 ip address 1.7.46.65 255.255.0.0
!
interface Vlan95
 description VLAN for RADIUS and DHCP
 ip address 10.2.25.1 255.255.255.0
!
interface Vlan100
 description Internal VLAN SUP-to-MWAM Gi
 ip address 10.1.2.1 255.255.255.0
!
interface Vlan101
 description VLAN to GGSN for GA/GN
 ip address 10.1.1.1 255.255.255.0
!
interface Vlan165
 description VLAN to CORPA
 ip address 165.1.1.1 255.255.0.0
!
interface Vlan302
 ip address 40.0.2.1 255.255.255.0
!
interface Vlan303
 ip address 40.0.3.1 255.255.255.0
!
router ospf 300
 log-adjacency-changes
 summary-address 9.9.9.0 255.255.255.0
 redistribute static subnets route-map GGSN-routes
 network 40.0.2.0 0.0.0.255 area 300
 network 40.0.3.0 0.0.0.255 area 300
!
ip classless
ip route 9.9.9.72 255.255.255.255 10.1.1.72
ip route 9.9.9.73 255.255.255.255 10.1.1.73
ip route 9.9.9.74 255.255.255.255 10.1.1.74
ip route 9.9.9.75 255.255.255.255 10.1.1.75
ip route 9.9.9.76 255.255.255.255 10.1.1.76
ip route 110.72.0.0 255.255.0.0 10.1.1.72
ip route 110.73.0.0 255.255.0.0 10.1.1.73
ip route 110.74.0.0 255.255.0.0 10.1.1.74
ip route 110.75.0.0 255.255.0.0 10.1.1.75
ip route 110.76.0.0 255.255.0.0 10.1.1.76
!
access-list 1 permit 9.9.9.0 0.0.0.255
!
route-map GGSN-routes permit 10
 match ip address 1
!

GGSN Instance on the Cisco MWAM


service gprs ggsn
!
hostname 6500-7-2
!
ip cef
!
interface Loopback0
 description USED FOR DHCP gateway
 ip address 110.72.0.2 255.255.255.255
!
interface Loopback100
 description GPRS GTP V-TEMPLATE IP ADDRESS
 ip address 9.9.9.72 255.255.255.0
!
interface GigabitEthernet0/0
 no ip address
!
interface GigabitEthernet0/0.1
 description Gi
 encapsulation dot1Q 100
 ip address 10.1.2.72 255.255.255.0
!
interface GigabitEthernet0/0.2
 description Ga/Gn Interface
 encapsulation dot1Q 101
 ip address 10.1.1.72 255.255.255.0
 no cdp enable
!
interface GigabitEthernet0/0.71
 description TFTP or Backbone
 encapsulation dot1Q 71
 ip address 1.7.46.72 255.255.0.0
!
interface GigabitEthernet0/0.95
 description CNR and CAR
 encapsulation dot1Q 95
 ip address 10.2.25.72 255.255.255.0
!
interface Virtual-Template1
 description GTP v-access
 ip unnumbered Loopback100
 encapsulation gtp
 gprs access-point-list gprs
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.2.1
ip route 40.1.2.1 255.255.255.255 10.1.1.1
ip route 40.1.3.10 255.255.255.255 10.1.1.1
ip route 40.2.2.1 255.255.255.255 10.1.1.1
ip route 40.2.3.10 255.255.255.255 10.1.1.1
ip route 40.3.2.3 255.255.255.255 10.1.1.1
ip route 40.4.2.3 255.255.255.255 10.1.1.1
!
gprs access-point-list gprs
  access-point 1
   access-point-name CORPA.com
   ip-address-pool dhcp-proxy-client  
   aggregate auto
   dhcp-server 10.2.25.90
   dhcp-gateway-address 110.72.0.2     
!

Restrictions

The number of PDP contexts supported on a GGSN is dependent on the memory and platform in use and the GGSN configuration (for example, whether or not a method of Point to Point Protocol [PPP] has been configured to forward packets beyond the terminal equipment and mobile termination, whether Dynamic Feedback Protocol [DFP] is being used or the memory protection feature is enabled, and what rate of PDP context creation will be supported).


Note DFP weighs PPP PDPs against IP PDPs with one PPP PDP equal to eight IP PDPs.


Cisco 7200 Series Router

The following list shows the maximum number of PDP contexts supported on the GGSN according to the memory and Cisco 7206 series router in use when no method of PPP has been configured:

Cisco 7206 VXR NPE-300 with 256 Mb RAM—80,000 IP PDP contexts

Cisco 7206 VXR NPE-400 router with 512 Mb RAM—135,000 IP PDP contexts

Catalyst 6500 Series Switch / Cisco 7600 Series Router

The Cisco MWAM can support up to 60,000 IP PDP contexts per GGSN instance, with a maximum of 300,000 IP PDP contexts per MWAM on which five GGSNs are configured.

Supported Standards, MIBs, and RFCs

Standards

Cisco IOS GGSN Release 5.2 supports the following Third Generation Partnership Program (3GPP) standards:

Release 97/98

3G TS 03.03

3G TS 03.60 (7.7.0)

3G TS 04.08 (7.14.0)

3G TS 09.02

3G TS 09.60 (7.9.0)

3G TS 09.61 (7.4.0)

3G TS 12.15

Release 99

3G TS 22.107

3G TS 23.003

3G TS 23.107 (3.9.0)

3G TS 23.060 (3.14.0)

3G TS 24.008 (3.14.0)

3G TS 29.002

3G TS 29.060 (3.15.0)

3G TS 29.061 (3.11.0)

3G TS 32.015 (3.10.0)

Release 4

3G TS 23.107 (4.6.0)

3G TS 23.060 (4.7.0)

3G TS 24.008 (4.9.0)

3G TS 29.060 (4.6.0)

3G TS 29.061 (4.6.0)

3G TS 32.215 (4.4.0)

Release 5

3G TS 23.107 (5.7.0)

3G TS 23.060 (5.4.0)

3G TS 24.008 (5.6.0)

3G TS 29.060 (5.4.0)

3G TS 29.061 (5.4.0)

3G TS 32.215 (5.2.0)

The GGSN interfaces comply with the following SMG (Special Mobile Group) standards:

Ga interface—SMG#28 R99

Gn interface—SMG#31 R98

MIBs

CISCO-GGSN-MIB

CISCO-GGSN-QOS-MIB

CISCO-GPRS-ACC-PT-MIB

CISCO-GPRS-CHARGING-MIB

CISCO-GPRS-GTP-CAPABILITY-MIB

CISCO-GPRS-GTP-MIB

CISCO-GTP-CAPABILITY-MIB

CISCO-GTP-MIB


Note The CISCO-GPRS-GTP-CAPABILITY-MIB describes the scope of objects supported in the CISCO-GPRS-GTP-MIB. The CISCO-GTP-CAPABILITY-MIB describes the scope of objects supported in the CISCO-GTP-MIB.


To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFCs

RFC 1518, An Architecture for IP Address Allocation with CIDR

RFC 1519, Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy

RFC 1661, The Point-to-Point Protocol (PPP)

RFC 2475, An Architecture for Differentiated Services

RFC 3588, Diameter Base Protocol

Related Documents

Cisco IOS Software Documentation

Cisco IOS Dial Technologies Configuration Guide, Release 12.3

Cisco IOS Dial Technologies Command Reference, Release 12.3

Cisco IOS Interface Configuration Guide, Release 12.3

Cisco IOS Interface Command Reference, Release 12.3

Cisco IOS IP Configuration Guide, Release 12.3

Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.3

Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.3

Cisco IOS IP Command Reference, Volume 3 of 3: Multicast, Release 12.3

Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.3

Cisco IOS Quality of Service Solutions Command Reference, Release 12.3

Cisco IOS Security Configuration Guide, Release 12.3

Cisco IOS Security Command Reference, Release 12.3

Cisco IOS Switching Services Configuration Guide, Release 12.3

Cisco IOS Switching Services Command Reference, Release 12.3

Cisco Multi-Processor WAN Application Module Installation and Configuration Note