Guest

Cisco IOS Software Releases 12.3 Special and Early Deployments

PPP Random Reconnect Timer

  • Viewing Options

  • PDF (253.2 KB)
  • Feedback
PPP Random Reconnect Timer

Table Of Contents

PPP Random Reconnect Timer

Contents

Prerequisites for the PPP Random Reconnect Timer Feature

Information About the PPP Random Reconnect Timer Feature

How the PPP Random Reconnect Timer Feature Works

Benefits of the PPP Random Reconnect Timer Feature

How to Configure the PPP Random Reconnect Timer Feature

Configuring the PPP Random Reconnect Timer Feature

Configuration Examples for the PPP Random Reconnect Timer Feature

Configuring the LCP Timer for Random Expiration: Examples

Configuring CONFREQ Discard: Examples

Configuring the LCP Timer for Random Expiration and CONFREQ Discard: Examples

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

ppp lcp delay


PPP Random Reconnect Timer


When a PPP link comes up, the devices at the endpoints of the link must negotiate link control protocol (LCP). An LCP delay timer can be configured that allows the peer device a certain amount of time to send the first packet. Before Cisco IOS Release 12.3(11)YS, no mechanism was available to prevent synchronous setup requests from multiple peers. In large scale environments such as broadband aggregation, a failure at the access server or aggregation server can result in many remote routers attempting to reconnect simultaneously, overloading the device. The PPP Random Reconnect Timer feature introduces the ability to randomize the duration of the LCP delay timer, preventing synchronous setup requests from overloading the access server or aggregation server.

History for the PPP Random Reconnect Timer Feature

Release
Modification

12.3(11)YS

This feature was introduced.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for the PPP Random Reconnect Timer Feature

Information About the PPP Random Reconnect Timer Feature

How to Configure the PPP Random Reconnect Timer Feature

Configuration Examples for the PPP Random Reconnect Timer Feature

Additional References

Command Reference

Prerequisites for the PPP Random Reconnect Timer Feature

PPP must be configured. For information about configuring PPP, refer to the "PPP Configuration" part of the Cisco IOS Dial Technologies Configuration Guide.

Information About the PPP Random Reconnect Timer Feature

To configure the PPP Random Reconnect Timer feature, you should understand the following concepts:

How the PPP Random Reconnect Timer Feature Works

Benefits of the PPP Random Reconnect Timer Feature

How the PPP Random Reconnect Timer Feature Works

When a PPP link comes up, the devices at the endpoints of the link must negotiate LCP. LCP negotiations are initiated by a configuration request (CONFREQ) from one device to the other. An LCP delay timer can be configured that allows the peer device a certain amount of time to send the first packet. If the LCP delay timer expires before a CONFREQ is received from the peer, the router can initiate LCP negotiations.

The PPP Random Reconnect Timer feature introduces two new configuration options to the ppp lcp delay command:

random max-delay-seconds—Configuring this option adds a random amount of time to the LCP delay timer.

discard—Configuring this option instructs the router to discard all incoming CONFREQs until the LCP delay timer has expired. LCP negotiations will not be initiated until the delay timer expires.

These new configuration options can be used to better control the behavior of the LCP delay timer, minimizing the number of simultaneous setup requests a router must process.

Benefits of the PPP Random Reconnect Timer Feature

In large scale environments such as broadband aggregation, if an access server or aggregation server fails many peers will attempt to reconnect at once. Multiple synchronized setup requests can overload the device, impacting performance. The PPP Random Reconnect Timer feature introduces the ability to randomize the duration of the LCP delay timer, preventing synchronous setup requests that can overload the access server or aggregation server.

How to Configure the PPP Random Reconnect Timer Feature

This section contains the following configuration tasks:

Configuring the PPP Random Reconnect Timer Feature

Configuring the PPP Random Reconnect Timer Feature

Perform this task to configure the PPP Random Reconnect Timer feature on a device that might receive many synchronous LCP negotiation requests.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number
or
interface dialer dialer-rotary-group-number
or
interface virtual-template number

4. ppp lcp delay seconds [milliseconds] [random max-delay-seconds] [discard]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

or

interface dialer dialer-rotary-group-number

or

interface virtual-template number

Example:

Router(config)# interface serial 1/1

or

Router(config)# interface dialer 1

or
Router(config)# interface virtual-template 1

Configures an interface type and enters interface configuration mode.

or

Defines a dialer rotary group.

or

Creates a virtual template interface that can be configured and applied dynamically in creating virtual access interfaces

Step 4 

ppp lcp delay seconds [milliseconds] [random max-delay-seconds] [discard]

Example:

Router(config-if)# ppp lcp delay 10 random 5 discard

Configures the LCP delay timer for initiating LCP negotiations after a link connects and configures the router to discard incoming setup requests until the LCP delay timer expires.

random max-delay-seconds—(Optional) Specifies that a random amount of additional time will be added to the configured LCP delay timer. The additional amount of time will not exceed the number of seconds specified with the max-delay-seconds argument. Valid values for max-delay-seconds range from 1 to 255. Random delay is disabled by default.

discard—(Optional) Specifies that incoming CONFREQs will be discarded until the delay timer has expired. CONFREQs are not discarded by default.

Configuration Examples for the PPP Random Reconnect Timer Feature

This section contains the following configuration examples:

Configuring the LCP Timer for Random Expiration: Examples

Configuring CONFREQ Discard: Examples

Configuring the LCP Timer for Random Expiration and CONFREQ Discard: Examples

Configuring the LCP Timer for Random Expiration: Examples

The following examples configure PPP with an LCP delay timer that will expire at a random time between 10 and 15 seconds after the link comes up. If a CONFREQ is received before the LCP delay timer expires, LCP negotiations will be initiated. Once the randomized LCP delay timer has expired, LCP negotiations can be initiated by either peer.

Serial Interface

interface Serial 0/1
 ip address 10.0.0.1 255.255.255.0
 encapsulation ppp
 ip tcp header-compression
 no keepalive
 clockrate 64000
 no cdp enable
 ppp lcp delay 10 random 5
 ppp authentication ms-chap-v2

Dialer Interface

interface Ethernet1
  ip address 10.0.0.2 255.255.255.0
  pppoe enable 
  pppoe-client dial-pool-number 1
  no shut
interface dialer 1
  encapsulation ppp
  ppp lcp delay 10 random 5
  dialer pool 1
  dialer-group 1

Virtual Template Interface

interface ATM0 
 ip address 172.18.0.1 255.255.0.0 
 no shut 
 pvc 7/70 
  encapsulation aal5mux ppp virtual-template1
interface virtual-template 1
 encapsulation ppp
 ppp lcp delay 10 random 5

Configuring CONFREQ Discard: Examples

The following examples configure PPP and a 10 second LCP delay timer with the discard option enabled. Incoming CONFREQs will be discarded until the LCP delay timer expires. After 10 seconds, LCP negotiations can be initiated by either peer.

Serial Interface

interface Serial 0/1
 ip address 10.0.0.1 255.255.255.0
 encapsulation ppp
 ip tcp header-compression
 no keepalive
 clockrate 64000
 no cdp enable
 ppp lcp delay 10 discard
 ppp authentication ms-chap-v2

Dialer Interface

interface Ethernet1
  ip address 10.0.0.2 255.255.255.0
  pppoe enable 
  pppoe-client dial-pool-number 1
  no shut
interface dialer 1
  encapsulation ppp
  ppp lcp delay 10 discard
  dialer pool 1
  dialer-group 1

Virtual Template Interface

interface ATM0 
 ip address 172.18.0.1 255.255.0.0 
 no shut 
 pvc 7/70 
  encapsulation aal5mux ppp virtual-template1
interface virtual-template 1
 encapsulation ppp
 ppp lcp delay 10 discard

Configuring the LCP Timer for Random Expiration and CONFREQ Discard: Examples

The following examples configure PPP, enable an LCP delay timer that will expire at a random time between 10 and 25 seconds after the link comes up, and enable the discard option. Incoming CONFREQs will be discarded until the LCP delay timer expires. Once the randomized LCP delay timer has expired, LCP negotiations can be initiated by either peer.

Serial Interface

interface Serial 0/1
 ip address 10.0.0.1 255.255.255.0
 encapsulation ppp
 ip tcp header-compression
 no keepalive
 clockrate 64000
 no cdp enable
 ppp lcp delay 10 random 15 discard
 ppp authentication ms-chap-v2

Dialer Interface

interface Ethernet1
  ip address 10.0.0.2 255.255.255.0
  pppoe enable 
  pppoe-client dial-pool-number 1
  no shut
interface dialer 1
  encapsulation ppp
  ppp lcp delay 10 random 15 discard
  dialer pool 1
  dialer-group 1

Virtual Template Interface

interface ATM0 
 ip address 172.18.0.1 255.255.0.0 
 no shut 
 pvc 7/70 
  encapsulation aal5mux ppp virtual-template 1
interface virtual-template 1
 encapsulation ppp
 ppp lcp delay 10 random 15 discard

Additional References

The following sections provide references related to the PPP Random Reconnect Timer feature.

Related Documents

Related Topic
Document Title

Information about configuring PPP

The "PPP Configuration" part of the Cisco IOS Dial Technologies Configuration Guide.

Additional PPP commands: complete command syntax, command mode, defaults, usage guidelines and examples

Cisco IOS Dial Technologies Command Reference,


Standards

Standard
Title

None


MIBs

MIB
MIBs Link

None


RFCs

RFC
Title

None


Technical Assistance

Description
Link

The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents the modified ppp lcp delay command.

ppp lcp delay

To configure the link control protocol (LCP) delay timer for initiating LCP negotiations after a link connects and to configure the router to discard incoming setup requests until the LCP delay timer expires, use the ppp lcp delay command in interface configuration mode. To disable the LCP delay timer, use the no form of this command.

ppp lcp delay seconds [milliseconds] [random max-delay-seconds] [discard]

no ppp lcp delay

Syntax Description

seconds

Delay, in seconds, before initiating LCP negotiations. Valid values for the seconds argument range from 0 to 255. The default value is 2 seconds.

milliseconds

(Optional) Delay, in milliseconds, before initiating LCP negotiations. Valid values for the milliseconds argument range from 0 to 999. The default value is 0 milliseconds.

random max-delay-seconds

(Optional) Specifies that a random amount of additional time will be added to the configured LCP delay timer. The additional amount of time will not exceed the number of seconds specified with the max-delay-seconds argument. Valid values for max-delay-seconds range from 1 to 255. Random delay is disabled by default.

discard

(Optional) Specifies that incoming configuration requests (CONFREQs) will be discarded until the LCP delay timer has expired. CONFREQs are not discarded by default.


Command Default

No LCP delay timer is configured.

Command Modes

Interface configuration

Command History

Release
Modification

12.1

This command was introduced.

12.2(13)T

Support for the milliseconds argument was added to this command.

12.3(11)YS

Support for the random max-delay-seconds and discard keywords and argument was added to this command.


Usage Guidelines

Configure an LCP delay timer to allow the peer device a short amount of time to send the first packet after the PPP link comes up. If the LCP delay timer expires before a CONFREQ is received from the peer, the router can initiate LCP negotiations.

The LCP delay timer is applied only to incoming connections. PPP does not delay for outbound connections or connections where PPP cannot determine a direction.

Use the random max-delay-seconds keyword and argument combination add a random amount of time to the LCP delay timer. Setting a random delay on the initiation of LCP negotiations prevents overload when many PPP links come up at the same time.

Use the discard keyword to specify that incoming CONFREQs should be discarded until the configured delay has expired. LCP negotiations will not be initiated until the LCP delay timer has expired.

Examples

The following example configures an LCP delay timer of 4 seconds. If a CONFREQ is not received before the LCP delay timer expires, LCP negotiations can be initiated by either peer.

ppp lcp delay 4

The following example configures an LCP delay timer that will expire at a random time between 5 and 15 seconds after the link comes up. If a CONFREQ is not received before the LCP delay timer expires, LCP negotiations can be initiated by either peer.

ppp lcp delay 5 random 10

The following example configures an LCP delay timer of 3.25 seconds and specifies that incoming CONFREQs will be discarded until the LCP delay timer has expired. After 3.25 seconds, LCP negotiations can be initiated by either peer.

ppp lcp delay 3 250 discard

The following example configures an LCP delay timer that will expire at a random time between 10 and 15 seconds after the link comes up, and specifies that incoming CONFREQs will be discarded until the LCP delay timer has expired. After the LCP delay timer expires, negotiations can be initiated by either peer.

ppp lcp delay 10 random 5 discard