Guest

Cisco IOS Software Releases 12.4 T

Configuring the Cisco NM-1A-T3/E3 Network Module

  • Viewing Options

  • PDF (345.5 KB)
  • Feedback
Configuring the Cisco NM-1A-T3/E3 Network Module

Table Of Contents

Configuring the Cisco NM-1A-T3/E3 Network Module

Contents

Restrictions for the Cisco ATM T3/E3 Network Module

Information About the Cisco ATM T3/E3 Network Module

ATM

Virtual Circuits

Permanent Virtual Circuits

Switched Virtual Circuits

Classes of Service

How to Configure the ATM T3/E3 Network Module

Configuring the Card Type

Changing the Card Type

Troubleshooting Tip

Enabling the ATM Interface

Configuring PVCs

Creating a PVC

Mapping a Protocol Address to a PVC

Configuring the AAL and Encapsulation Type

Configuring PVC Traffic Parameters

Setting PVC Watermarks

SVCs

Configuring Communication with the ILMI

Configuring the PVC That Performs SVC Call Setup

Configuring the NSAP Address

Configuring the ESI and Selector Fields

Creating an SVC

Customizing the ATM T3/E3 Network Module

Configuring ATM Framing

Setting the Loopback Mode

Configuration Example

Recommendations for Watermark Settings

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

debug atm t3e3

Feature Information for the Cisco ATM T3/E3 Network Module


Configuring the Cisco NM-1A-T3/E3 Network Module


OL-10215-01
First Published: June 28, 2007

The Cisco NM-1A-T3/E3 (or ATM T3/E3) network module provides Asynchronous Transfer Mode (ATM) services on a T3 or E3 connection. This feature module explains how to configure the ATM T3/E3 network module for each connection. The ATM T3/E3 network module is supported on Cisco 2800 and Cisco 3800 routers and includes the following features:

ATM traffic management features including constant bit rate (CBR), variable bit rate (VBR), available bit rate (ABR), unspecified bit rate (UBR), and UBR+

Classic IP over ATM encapsulation (RFC 1577)

Multiprotocol encapsulation over ATM adaptive layer 5 (AAL5) segmentation (RFC 1483)

Point-to-Point Protocol (PPP) over ATM

LAN Emulation (LANE)

Finding Feature Information in This Module

Your Cisco IOS software release may not support all the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, see the "Feature Information for the Cisco ATM T3/E3 Network Module" section.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. You do not need an account on Cisco.com.

Contents

Restrictions for the Cisco ATM T3/E3 Network Module

Information About the Cisco ATM T3/E3 Network Module

How to Configure the ATM T3/E3 Network Module

SVCs

Customizing the ATM T3/E3 Network Module

Configuration Example

Recommendations for Watermark Settings

Additional References

Command Reference

Feature Information for the Cisco ATM T3/E3 Network Module

Obtaining Documentation, Obtaining Support, and Security Guidelines, page 6

Restrictions for the Cisco ATM T3/E3 Network Module

The following restrictions apply to the Cisco ATM T3/E3 network module:

There is no default card type configuration on the ATM T3/E3 network module. You must configure the ATM T3/E3 network module for T3 or E3 before it will work.

The atm vc-per-vp command is not supported on the ATM T3/E3 network module.

Information About the Cisco ATM T3/E3 Network Module

To configure the Cisco ATM T3/E3 network module, you should understand the following:

ATM

Permanent Virtual Circuits

Switched Virtual Circuits

Classes of Service

ATM

ATM is an International Telecommunication Union-Telecommunications Standards Section (ITU-T) standard for cell relay wherein information for multiple service types (such as voice, video, and data), is conveyed in small, fixed-size (53-byte) cells via connection-oriented virtual circuits (VCs).

Virtual Circuits

A virtual circuit (VC) is a point-to-point connection between remote hosts and routers. A VC is established for each ATM end node with which the router communicates. The characteristics of the VC are established when the VC is created and include the following:

Classes of Service

ATM adaptation layer 5 (AAL5)

Encapsulation type:

Logical link control Subnetwork Address Protocol (AAL5SNAP)

Multiplexer (AAL5MUX)

Network Layer Protocol ID (AAL5NLPID)

Integrated Local Management Interface (ILMI)

Switched Multimegabit Data Service (SMDS)

ITU/Q.2931 Signaling ATM Adaptation Layer (QSAAL)

Cisco AUTO PPP over AAL5 (aal5autoppp)

Cisco PPP over AAL5 (aal5ciscoppp)

Each VC supports the following router functions:

Multiprotocol switching

Fast switching of IP packets

Flow, and Cisco Express Forwarding (CEF) switching of IP packets

Pseudo-broadcast support for multicast packets

By default, CEF switching is enabled on all ATM T3/E3 module interfaces. These switching features can be turned off by using interface configuration commands. Flow must be explicitly enabled for each interface.

Permanent Virtual Circuits

To use a permanent virtual circuit (PVC), configure the PVC in both the router and the ATM switch. PVCs remain active until the circuit is removed from either configuration. When a PVC is configured, all the configuration options are passed on to the OC-3 module. You can write these PVCs into NVRAM; they are used when the system image is reloaded.

Some ATM switches might have point-to-multipoint PVCs that do the equivalent of broadcasting. A point-to-multipoint PVC can be used as the sole broadcast PVC for all multicast requests.These switching features can be turned off by using interface configuration commands. Flow must be explicitly enabled for each interface.

Switched Virtual Circuits

ATM switched virtual circuit (SVC) service operates much like X.25 SVC service, although ATM allows much higher throughput. Virtual circuits are created and released dynamically, providing user bandwidth on demand. This service requires a signaling protocol between the router and the switch.

The ATM signaling software provides a method of dynamically establishing, maintaining, and clearing ATM connections at the user-network interface (UNI). The ATM signaling software conforms to ATM Forum UNI 3.0 or ATM Forum UNI 3.1, depending on what version is selected by interim local management interface (ILMI) or configuration.

In UNI mode, the user is the router and the network is an ATM switch. This is an important distinction. The Cisco router does not perform ATM-level call routing. Instead, the ATM switch does the ATM call routing, and the router routes packets through the resulting circuit. The router performs as the user and the LAN interconnection device at the end of the circuit, and the ATM switch performs as the network.

Classes of Service

ATM resources can be specified dynamically on a per-connection basis (per SVC). The ATM T3/E3 network module supports four classes of service:

Constant Bit Rate (CBR): This class emulates circuit switching. CBR has the highest transport priority, which is 0. CBR can be used for connections such as voice and video. This bandwidth is characterized by peak cell rate (PCR).

Variable Bit Rate (VBR): VBR is available in non-real-time (VBR-nrt) and real-time (VBR-rt). VBR has the second highest transport priority, which is 1. VBR sends traffic at a rate that varies with time, depending on the availability of user information.

Available Bit Rate (ABR): ABR has the transport priority of 2. ABR provides rate-based flow control and is aimed at data traffic.

Unspecified Bit Rate (UBR): UBR has the transport priority of 3. UBR is a "best effort" class of service that uses the unutilized bandwidth for a connection. Traffic categorized as UBR+ is guaranteed a minimum line rate through the minimum cell rate (MCR) traffic parameter.

How to Configure the ATM T3/E3 Network Module

To configure the ATM T3/E3 network module, complete the following procedures:

Configuring the Card Type

Changing the Card Type

Enabling the ATM Interface

Configuring PVCs

Configuring the Card Type

To configure the ATM T3/E3 network module for T3 or E3 operation, perform the following tasks.


Note The ATM T3/E3 network module will not be operational until a card type is configured.


SUMMARY STEPS

1. enable

2. configure terminal

3. card type {t3 | e3} slot

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

card type {t3|e3} slot

Example:

Router(config)# card type t3 1

Specifies T3 or E3 connectivity for the ATM T3/E3 network module.

Changing the Card Type

To change the ATM T3/E3 network module for T3 or E3 operation, perform the following tasks:

SUMMARY STEPS

1. enable

2. configure terminal

3. no card type {t3 | e3}

4. card type {t3 | e3} slot

5. reload

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

no card type {t3 | e3}

Example:

Router(config)# no card type t3

Optional. Removes any previously configured card type.

Step 4 

card type {t3 | e3} slot

Example:

Router(config)# card type t3 1

Specifies T3 or E3 connectivity for the ATM T3/E3 network module.

Step 5 

reload

Example:

Router(config)# reload

Reloads the router so that changes can take affect.


Note When changing from T3 card type to E3 card type make sure that the interface is configured for 34 Mbps or less. This is the maximum bandwidth for an E3 connection.


Troubleshooting Tip

T3 interfaces support a maximum bandwidth of 44,209 kbps in ATM and 40,700 kbps in physical layer convergence procedures (PLCP) mode. E3 interfaces support a maximum bandwidth of 33,920 kbps in ATM and 30,528 kbps in PLCP mode.

If the total bandwidth used by an interface is greater than 34 Mbps and the card type is changed from T3 to E3, the traffic shaping characteristics of the VCs will be changed. The Cisco IOS software will reconfigure the VCs so that the total allocated guaranteed bandwidth does not exceed the maximum allowable E3 bandwidth.

Enabling the ATM Interface

To enable the ATM T3/E3 interface, perform the following tasks, starting in global configuration mode.

SUMMARY STEPS

1. interface ATM slot

2. atm clock internal

3. no shut down

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

interface ATM slot

Example:

Router(config)# interface ATM 1

Enters interface configuration mode.

Step 2 

atm clock internal

Example:

Router(config-if)# atm clock internal

Mandatory if the ATM port the network module is connected to is configured line. Optional otherwise.

Specifies ATM clock source. Default source is line.

Step 3 

no shutdown

Example:

Router(config)# no shutdown

(Optional) Enables the ATM interface, thereby beginning the segmentation and reassembly (SAR) operation on the interface. The ATM interface is enabled by default.

Configuring PVCs

To use a PVC, you must configure the PVC into both the router and the ATM switch. PVCs remain active until the circuit is removed from either configuration.

To configure a PVC, perform these tasks:

Creating a PVC

Mapping a Protocol Address to a PVC

Configuring the AAL and Encapsulation Type

Configuring PVC Traffic Parameters

Setting PVC Watermarks

Creating a PVC

To create a PVC on the ATM interface and enter interface-ATM-VC configuration mode, use the following command, beginning in interface configuration mode:

Command
Purpose

Router(config-if)# pvc [name] vpi/vci [ilmi | qsaal]

Example:

Router(config-if)# pvc cisco 0/16 ilmi

Configures a new ATM PVC by assigning a name (optional) and VPI/VCI values. Enters interface-ATM-VC configuration mode. Optionally configures ILMI or QSAAL encapsulation.


The range of values for vpi isfrom 0 to 255. The range of values for vci is from 1 to 65535.

Once you specify a name for a PVC, you can reenter the interface-ATM-VC configuration mode by simply entering pvc name.

Mapping a Protocol Address to a PVC

The ATM interface supports a static mapping scheme that identifies the network addresses of remote hosts or routers. This section describes how to map a PVC to an address, which is a required task for configuring a PVC.

To map a protocol address to a PVC, use the following command in interface-ATM-VC configuration mode:

Command
Purpose

Router(config-if-atm-vc)# protocol protocol protocol-address [ [no] broadcast]

Example:

Router(config)# protocol ip 10.68.34.237 broadcast

Maps a protocol address to a PVC.



Note If you enable or disable broadcasting directly on a PVC by using the protocol command, this broadcasting configuration will take precedence over any direct configuration made using the broadcast command.


Configuring the AAL and Encapsulation Type

To configure the ATM adaptation layer (AAL) and encapsulation type on a VC, use the following command, beginning in interface-ATM-VC configuration mode:

Command
Purpose

Router(config-if-atm-vc)# encapsulation {aal2 | aal5auto | aal5autoppp virtual-template number [group group-name] | aal5ciscoppp virtual-template number | aal5mux protocol | aal5nlpid | aal5snap}

Example:

Router(config-if-atm-vc)# encapsulation aal5auto

Configures the ATM adaptation layer (AAL) and encapsulation type on the VC.


For a description of AAL types, see the encapsulation aal5 command in the "ATM Commands" chapter of the Cisco IOS Wide-Area Networking Command Reference.

Configuring PVC Traffic Parameters

The supported traffic parameters (or classes of service) for the ATM T3/E3 network module are CBR, real-time and non-real-time VBR, UBR, UBR+, and ABR.

To configure PVC traffic parameters on a VC, use one of the following commands, beginning in interface-ATM-VC configuration mode:

Command
Purpose

Router(config-if-atm-vc)# abr output-pcr output-mcr

Example:

Router(config-if-atm-vc)# abr 10000 3000

Configures ABR.

Router(config-if-atm-vc)# ubr output-pcr

Example:

Router(config-if-atm-vc)# ubr 10000

Configures UBR.

Router(config-if-atm-vc)# ubr+ output-pcr output-mcr

Example:

Router(config-if-atm-vc)# ubr+ 10000 3000

Configures UBR+.

Router(config-if-atm-vc)# vbr-nrt output-pcr output-scr output-mbs

Example:

Router(config-if-atm-vc)# vbr-nrt 10000 5000 64

Configures non-real-time VBR.

Router(config-if-atm-vc)# vbr-rt peak-rate average-rate burst

Example:

Router(config-if-atm-vc)# vbr-rt 10000 3000 64

Configures real-time VBR.

Router(config-if-atm-vc)# cbr rate

Example:

Router(config-if-atm-vc)# cbr 10000

Configures CBR.


The -pcr, -scr, and -mcr arguments are peak cell rate, sustainable cell rate, and guaranteed minimum cell rate, respectively, in kbps. The -mbs argument is maximum burst size in number of cells.

The peak rate, average rate, and rate arguments are in kbps. The burst argument is in number of cells.

For ABR VCs, you can optionally configure the factor by which the cell transmission rate increases or decreases in response to flow control information from the network or destination. To configure this option, use the following command in interface-ATM-VC configuration mode:

Command
Purpose

Router(config-if-atm-vc)# atm abr rate-factor [rate-increase-factor] [rate-decrease-factor]

Example:

Router(config-if-atm-vc)# atm abr rate-factor 32 32

Specifies the ABR rate factors. The default rate increase factor is 16. The default rate decrease factor is 16.


Setting PVC Watermarks

The SAR, which is used by the ATM T3/E3 module, uses queues inside the SAR hardware. One queue is used for each created PVC. To manage the latency, shaping, and throughput on the PVCs, use the following command in interface-ATM-VC configuration mode:

Command
Purpose

Router(config-if-atm-vc)# queue-depth <hwm> <lwm>

Example:

Router(config-if-atm-vc)# queue-depth 10 5

Sets the high watermark (hwm) and low watermark (lwm) level for each created PVC.

When the number of ATM cells in the SAR queues reach the high watermark level, the SAR stops processing the ATM cells on that particular PVC. After the ATM cells drain to the low watermark level, the SAR starts processing the ATM cells again.


SVCs

To use SVCs, complete the following sections:

Configuring Communication with the ILMI

Configuring the PVC That Performs SVC Call Setup

Configuring the NSAP Address

Creating an SVC

Configuring Communication with the ILMI

In an SVC environment, you must configure a PVC for communication with ILMI so that the router can receive simple network management protocol (SNMP) traps and new network prefixes. The recommended vpi and vci values for the ILMI PVC are 0 and 16, respectively. To configure ILMI communication, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# pvc [name] 0/16 ilmi

Example:

Router(config-if)# pvc cisco 0/16 ilmi

Creates an ILMI PVC on an ATM main interface.



Note This ILMI PVC can be set up only on an ATM main interface, not on ATM subinterfaces.


Once you have configured an ILMI PVC, you can optionally enable the ILMI keepalive function by using the following command in interface configuration mode:

Command
Purpose

Router(config-if)# atm ilmi-keepalive [seconds]

Example:

Router(config-if)# atm ilmi-keepalive 6

Enables ILMI keepalives and sets the interval between keepalives.


No other configuration steps are required.

ILMI address registration for receipt of SNMP traps and new network prefixes is enabled by default. The ILMI keepalive function is disabled by default; when enabled, the default interval between keepalives is 3 seconds.

Configuring the PVC That Performs SVC Call Setup

ATM uses out-of-band signaling. There is one dedicated PVC between the router and the ATM switch, over which all SVC call establishment and call termination requests flow. After a call is established, data transfer occurs over the SVC, from router to router. The signaling that accomplishes the call setup and teardown is called Layer 3 signaling or the Q.2931 protocol.

For out-of-band signaling, a signaling PVC must be configured before any SVCs can be set up. Figure 1 shows how a signaling PVC from the source router to the ATM switch is used to set up two SVCs. This is a fully meshed network; workstations A, B, and C can all communicate with each other.

Figure 1 SVCs within a signaling PVC

To configure the signaling PVC for all SVC connections, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# pvc [name] vpi/vci qsaal

Example:

Router(config-if)# pvc cisco 0/5 qsaal

Configures the signaling PVC for an ATM main interface that uses SVCs.



Note This signaling PVC can be set up only on an ATM main interface, not on ATM subinterfaces.


The VPI and VCI values must be configured consistently with the local switch. The standard values for VPI and VCI are 0 and 5, respectively.

Configuring the NSAP Address

Every ATM interface involved with signaling must be configured with a network service access point (NSAP) address. The NSAP address is the ATM address of the interface and must be unique across the network.

To configure an NSAP address, complete the tasks described in one of the following sections:

Configuring the ESI and Selector Fields

If the switch is capable of delivering the NSAP address prefix to the router by using ILMI, and the router is configured with a PVC for communication with the switch via ILMI, you can configure the end station ID (ESI) and selector fields by using the atm esi-address command. The atm esi-address command allows you to configure the ATM address by entering the ESI (12 hexadecimal characters) and the selector byte (2 hexadecimal characters). The NSAP prefix (26 hexadecimal characters) is provided by the ATM switch.

To configure the router to obtain the NSAP prefix from the switch and use locally entered values for the remaining fields of the address, use the following commands, beginning in interface configuration mode:

SUMMARY STEPS

1. pvc [name] 0/16 ilmi

2. exit

3. atm esi-address esi.selector

DETAILED STEPS

Command
Purpose

Router(config-if)# pvc [name] 0/16 ilmi

Example:

Router(config-if)# pvc cisco 0/16 ilmi

Configures ILMI PVC on an ATM main interface.

Router(config-if-atm-vc)# exit

Returns to interface configuration mode.

Router(config-if) atm esi-address esi.selector

Example:

Router(config-if)# atm esi-address 345678901234.12

Enters the ESI and selector fields of the NSAP address.


The atm nsap-address and atm esi-address commands are mutually exclusive. Configuring the router with the atm nsap-address command negates the atm esi-address setting, and configuring the router with the atm esi-address command negates the atm nsap-address setting. For information about using the atm esi-address command, see the section "Configuring the ESI and Selector Fields"

Creating an SVC

To create an SVC, use the following commands beginning in interface configuration mode:

SUMMARY STEPS

1. svc [name] nsap address

2. encapsulation aal5encap

3. protocol protocol protocol-address [[no] broadcast]

DETAILED STEPS

 
Command
Purpose

Step 1 

Router(config-if)# svc [name] nsap address

Example:

Router(config-if)# svc cisco nsap 47.0091.81.000000.0040.0B0A.2501.ABC1.3333.3333.05

Creates an SVC and specifies the destination NSAP address.

Step 2 

Router(config-if-atm-vc)# encapsulation aal5encap

Example:

Router(config-if-atm-vc)# encapsulation aal5auto

(Optional) Configures the ATM adaptation layer (AAL) and encapsulation type.

Step 3 

Router(config-if-atm-vc)# protocol protocol protocol-address [[no] broadcast]

Example:

Router(config-if-atm-vc)# protocol ip

Maps a protocol address to an SVC.

Once you specify a name for an SVC, you can reenter interface-ATM-VC configuration mode by entering the svc name command. You can remove an SVC configuration by entering the no svc name command.

For a list of AAL types and encapsulations, see the section "Configuring the AAL and Encapsulation Type".

Customizing the ATM T3/E3 Network Module

You can customize the ATM T3/E3 network module. The features you can customize have default values that will probably suit your environment and do not need to be changed. However, you might need to enter configuration commands, depending on the requirements for your system configuration and the protocols you plan to route on the interface. Perform the tasks in the following sections if you need to customize the ATM T3/E3 network module:

Configuring ATM Framing

Setting the Loopback Mode

Configuring ATM Framing

The ATM T3/E3 network module supports different framing types when it is configured as a T3 connection or an E3 connection. To configure T3 ATM framing on the T3/E3 network module enter the following command in interface configuration mode. The no form of this command removes T3 ATM framing.

Command
Purpose

Router(config-if)# atm framing [cbitadm | cbitplcp | m23adm | m23plcp]

Example:

Router(config-if)# atm framing cbitadm

Optional. Configures T3 ATM framing type. The default T3 ATM framing type is cbitplcp.


To configure E3 ATM framing on the ATM T3/E3 network module, use the following command in interface configuration mode. The no form of this command removes E3 ATM framing.


Note G751adm framing is not supported on the ATM T3/E3 network module.


Command
Purpose

Router(config-if)# atm framing [g832adm | g751plcp]

Example:
Router(config-if)# atm framing g751 plcp

Optional. Configures E3 ATM framing type The default E3 ATM framing type is g832.adm.


Setting the Loopback Mode

To loop all packets back to your ATM interface instead of to the network, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# loopback

Sets loopback mode.


To loop the incoming network packets back to the ATM network, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# loopback line

Sets line loopback mode.


Configuration Example

This section gives a basic example of how to configure the MN-1A-T3/E3 network module.

Router# configure terminal
Router(config)# interface ATM2/0 
Router(config-if)# ip address 10.0.0.2 255.0.0.0 
Router(config-if)# no atm ilmi-keepalive 
Router(config-if)# pvc 0/32 
Router(config-if-atm-vc)# cbr 34000 

Recommendations for Watermark Settings

Table 1 provides recommendations for watermark settings on the ATM T3/E3 module with a single VC.

For information about the traffic pattern used to test the watermark settings recommendations, see Traffic Pattern.

For an example of the router configuration, see Example of the Router Configuration Used for Watermark Testing.

Table 1 Ideal Watermark Settings for Better Performance

EF Description
Voice Packet 64B and Data Packet 300B With or Without Burst
Voice Packet 64B and Data Packet 1400B With or Without Burst

1M PVC
2M PVC
5M PVC
10M PVC
20M PVC
1M PVC
2M PVC
5M PVC
10M PVC
20M PVC

30% EF

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

40% EF

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

50% EF

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

20/20

60% EF

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

10/5

20/20


Traffic Pattern

The following pageant configuration was used in bi-directional way for continuous burst on traffic streams:
packet length - 300 bytes and 1400 bytes:

For 300 bytes data traffic from pageant, the following rates were used:
350 for 1 Mbps; 700 for 2 Mbps; 1750 for 5 Mbps; and 3500 for 10 Mbps

For 1400 bytes data traffic from pageant, the following rates were used:
150 for 1 Mbps; 300 for 2 Mbps; 750 for 5 Mbps; and 1500 for 10 Mbps

IXIA was used for pumping UDP bi-directional unicast streams for simulating racing condition.

Average latency is calculated based on two to three minutes of traffic from IXIA; Latency might differ based on the drop rate of data traffic.

1500 bytes (data) was not used due to ATM cell conversion overhead.

64B frame size IXIA traffic streams includes CRC.

Example of the Router Configuration Used for Watermark Testing

The following example provides the router configuration that was used for the watermark testing.

Table 2 Example of the Router Configuration Used for Watermark Testing

UUT1 (3845)
UUT2 (3845)

 class-map match-any COSQ_NBIP_LABS_TC1_COS4

  match any

class-map match-any COSP_NBIP_LABS_TC1_COS4

  match any

class-map match-any COSP_NBIP_LABS_TC1_EF

match access-group name EF_APP_IPV4_TC1

class-map match-any COSQ_NBIP_LABS_TC1_EF

match access-group name EF_QUEUE_IPV4_TC1

!

!

policy-map Child_Map3

class COSP_NBIP_LABS_TC1_EF

police cir 5000000 bc 625000

conform-action set-dscp-transmit 46

exceed-action drop

policy-map Child_Map2

class COSP_NBIP_LABS_TC1_COS4

police cir 5000000 bc 625000

conform-action set-dscp-transmit 0

exceed-action set-dscp-transmit 0

policy-map Parent_Map1

class COSQ_NBIP_LABS_TC1_EF

priority 5000 625000

service-policy Child_Map3

class COSQ_NBIP_LABS_TC1_COS4

bandwidth remaining percent 99

random-detect dscp-based

random-detect exponential-weighting-constant 1

random-detect dscp 0 901 1200 10

service-policy Child_Map2

!

interface GigabitEthernet0/0

ip address 110.0.0.2 255.255.255.0

load-interval 30

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

ip address 20.0.0.1 255.0.0.0

load-interval 30

duplex auto

speed auto

media-type rj45

!

 class-map match-any COSQ_NBIP_LABS_TC1_COS4

  match any

class-map match-any COSP_NBIP_LABS_TC1_COS4

match any

class-map match-any COSP_NBIP_LABS_TC1_EF

match access-group name EF_APP_IPV4_TC1

class-map match-any COSQ_NBIP_LABS_TC1_EF

match access-group name EF_QUEUE_IPV4_TC1

!

!

policy-map Child_Map3

class COSP_NBIP_LABS_TC1_EF

police cir 5000000 bc 625000

conform-action set-dscp-transmit 46

exceed-action drop

policy-map Child_Map2

class COSP_NBIP_LABS_TC1_COS4

police cir 5000000 bc 625000

conform-action set-dscp-transmit 0

exceed-action set-dscp-transmit 0

policy-map Parent_Map1

class COSQ_NBIP_LABS_TC1_EF

priority 5000 625000

service-policy Child_Map3

class COSQ_NBIP_LABS_TC1_COS4

bandwidth remaining percent 99

random-detect dscp-based

random-detect exponential-weighting-constant 1

random-detect dscp 0 901 1200 10

service-policy Child_Map2

!

interface GigabitEthernet0/0

ip address 120.0.0.2 255.255.255.0

load-interval 30

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

ip address 30.0.0.1 255.0.0.0

load-interval 30

duplex auto

speed auto

media-type rj45

!

interface ATM1/0

mtu 1500

bandwidth 5000

no ip address

ip virtual-reassembly

load-interval 30

atm scrambling cell-payload

no atm ilmi-keepalive

!

interface ATM1/0.1 point-to-point

ip address 195.18.18.1 255.255.255.0

ip virtual-reassembly

pvc 1/313

vbr-nrt 10000 10000 1

vc-hold-queue 2048

oam-pvc manage

oam retry 3 5 1

oam ais-rdi 10 3

encapsulation aal5snap

service-policy output Parent_Map1

max-reserved-bandwidth 98

ip forward-protocol nd

ip route 30.0.0.0 255.255.255.0 195.18.18.2

ip route 120.0.0.0 255.255.255.0 195.18.18.2

!

!

ip http server

no ip http secure-server

!

ip access-list extended EF_APP_IPV4_TC1

permit udp any eq 5060 any

permit udp any any eq 5060

deny ip any 120.0.0.0 0.0.0.255

ip access-list extended EF_QUEUE_IPV4_TC1

permit udp any eq 5060 any

permit udp any any eq 5060

deny ip any 120.0.0.0 0.0.0.255

interface ATM1/0

mtu 1500

bandwidth 5000

no ip address

ip virtual-reassembly

load-interval 30

atm scrambling cell-payload

no atm ilmi-keepalive

!

interface ATM1/0.1 point-to-point

ip address 195.18.18.2 255.255.255.0

ip virtual-reassembly

pvc 1/313

vbr-nrt 10000 10000 1

vc-hold-queue 2048

oam-pvc manage

oam retry 3 5 1

oam ais-rdi 10 3

encapsulation aal5snap

service-policy output Parent_Map1

max-reserved-bandwidth 98

ip forward-protocol nd

ip route 20.0.0.0 255.255.255.0 195.18.18.1

ip route 110.0.0.0 255.255.255.0 195.18.18.1

!

!

ip http server

no ip http secure-server

!

ip access-list extended EF_APP_IPV4_TC1

permit udp any eq 5060 any

permit udp any any eq 5060

deny ip any 110.0.0.0 0.0.0.255

ip access-list extended EF_QUEUE_IPV4_TC1

permit udp any eq 5060 any

permit udp any any eq 5060

deny ip any 110.0.0.0 0.0.0.255


Additional References

The following sections provide references related to the ATM T3/E3 network module.

Related Documents

Related Topic
Document Title

Hardware installation of network modules

Cisco Network Modules Hardware Installation Guide


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards have not been modified by this feature.


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs have not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs have not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Command Reference

This section documents only commands that are new or modified.

debug atm t3e3

debug atm t3e3

To display debug messages for ATM T3/E3 network modules, use the debug atm t3e3 command in privileged EXEC mode. To disable debugging output, use the no form of this command.

debug atm t3e3 {data | flow | pa | sar | trace}

no debug atm t3e3 {data | flow | pa | sar | trace}

Syntax Description

data

Displays debug messages for incoming packet indications.

flow

Displays debug messages for flow control indications.

pa

Displays debug messages for online insertion or removal (OIR) of the ATM T3/E3 network module.

sar

Displays debug messages for blocking commands sent to the segmentation and reassembly (SAR) and their acknowledgments.

trace

Displays debug messages that give the hexadecimal representation of commands sent to the SAR and their acknowledgments.


Command Modes

Privileged EXEC (#)

Command History

Release
Modification

12.4(15)T

This command was introduced.


Usage Guidelines

debug atm t3e3 data command

Use the debug atm t3e3 data command to display the incoming packet indications. Each incoming packet transferred by direct memory access (DMA) to the host memory by the SAR will cause a packet indication.

debug atm t3e3 flow command

Use the debug atm t3e3 flow command to display flow control indications.

When traffic sent to the SAR exceeds the peak cell rate for a particular virtual circuit (VC), the SAR indicates this to the host by sending flow control indications. These indications inform the host that either the high watermark or the low watermark has been reached for that VC queue.

When a high watermark is received from the SAR, indicating that the VC queue is full, the host will stop sending packets to the SAR until a low watermark indication is received. A low watermark indicates that the VC queue has been drained sufficiently to receive additional packets.

debug atm t3e3 pa command

Use the debug atm t3e3 pa command on those platforms supporting OIR to display the indications generated when the port adapter (the ATM T3/E3 network module) is subjected to OIR. This command is used principally during the port adapter initialization phase.

debug atm t3e3 sar command

Use the debug atm t3e3 sar command to display blocking commands or indications sent to or received from the SAR. This includes commands or indications of the creation or deletion of virtual circuits or virtual paths.

debug atm t3e3 trace command

Use the debug atm t3e3 trace command to display the hexadecimal representation of commands sent to or received from the SAR. To facilitate debugging, use this command in conjunction with the debug atm t3e3 sar command.

Examples

Example for the debug atm t3e3 data command

The following is sample output from the debug atm t3e3 data command:

Router# debug atm t3e3 data

DATA debugging is on
Router#
*Jun 27 22:03:17.996: Packet Indication:
*Jun 27 22:03:17.996:   word 0: 0x00007D24
*Jun 27 22:03:17.996:   word 1: 0x00002F02
*Jun 27 22:03:17.996:   word 2: 0xEE323464
*Jun 27 22:03:17.996:   word 3: 0x006C006D

Table 3 describes the significant fields shown in the display.

Table 3 debug atm t3e3 data Field Descriptions 

Field
Description

Jun 27 22:03:17.996:

Date or time stamp of packet DMA transfer.

word [0 - 3]: 0xXXXXXXXX

Hexadecimal representation of four-word acknowledgment from the SAR when a packet is transferred by DMA to the host memory by the SAR.


Example for the debug atm t3e3 flow command

The following example illustrates the output from the debug atm t3e3 flow command:

Router# debug atm t3e3 flow

FLOW CNTL INDICATION debugging is on
Router#
*Jun 27 15:14:13.123: Flow Indication:
*Jun 27 15:14:13.123:   word 0: 0x00000001
*Jun 27 15:14:13.123:   word 1: 0x300012C0
*Jun 27 15:14:13.123:   word 2: 0x18001060
*Jun 27 15:14:13.123:   word 3: 0x00080021

*Jun 27 15:14:13.456: Flow Indication:
*Jun 27 15:14:13.456:   word 0: 0x00000001
*Jun 27 15:14:13.456:   word 1: 0x300012C0
*Jun 27 15:14:13.456:   word 2: 0x18001060
*Jun 27 15:14:13.456:   word 3: 0x00090022

Table 4 describes the significant fields shown in the display.

Table 4 debug atm t3e3 flow Field Descriptions 

Field
Description

Jun 27 15:14:13.456:

Date or time stamp of flow indication

word [0 - 3]: 0xXXXXXXXX

Hexadecimal representation of four-word indication sent by the SAR to the host that a high watermark or low watermark event has occurred.

word 3: 0x00XXYYYY

When XX is 08, a high watermark has been received by the host. The host will stop queueing packets for the VC.

When XX is 09, a low watermark has been received by the host. The host will resume sending packets to the VC.

YYYY is the running count of flow indication events sent to the host.


Examples for the debug atm t3e3 pa command

The following examples illustrate the output from the debug atm t3e3 pa command.

The first example gives the output when the network module is removed:

Router# debug atm t3e3 pa

PA debugging is on

*Jun 27 22:40:56.110: %OIR-6-REMCARD: Card removed from slot 2, interfaces disabled
*Jun 27 22:40:56.122: *** Freed 6146 buffers


The second example gives the output when the network module is inserted, and gives the values of internal registers of the module:

*Jun 27 22:41:08.654: %OIR-6-INSCARD: Card inserted in slot 2, interfaces administratively 
shut down
*Jun 27 22:41:11.402: sar_base_addr 0x5C800000
*Jun 27 22:41:11.402: PCI_MEMBAR2_REG after configuring:0x5E000008
*Jun 27 22:41:11.402: PCI_MEMBAR3_REG after configuring:0x5F000000
*Jun 27 22:41:11.402: PCI_COMMAND_REG: Offset= 0x4; value= 0x2A00006
*Jun 27 22:41:11.402: FPGA Base address is 0x5C900000
*Jun 27 22:41:11.402: FPGA PCI config Reg is 0x02200002

Examples for the debug atm t3e3 sar command

The following examples illustrate the output from the debug atm t3e3 sar command.

The first example displays command indications for setting up a VC and opening the reassembly channel and the segmentation channel in the SAR:

Router# debug atm t3e3 sar

SAR debugging is on
Router# configure terminal
Router(config)# interface atm 2/0
Router(config-if)# pvc 2/2
Router(config-if-atm-vc)# exit
Router(config-if)#
*Jun 27 22:12:28.816: ATM2/0: Setup_VC: vc:3 vpi:2 vci:2
*Jun 27 22:12:28.816: ATM2/0: Open_Channel(RSY): CH (1), VPI (2), VCI (2)
*Jun 27 22:12:28.816: ATM2/0: HI/LO watermarks: 526/263; PeakRate: 149760
*Jun 27 22:12:28.816: ATM2/0: Open_Channel(SEG): CH (1), VPI (2), VCI (2)
*Jun 27 22:12:28.820: ATM2/0: Setup_Cos: vc:3 wred_name:- max_q:0

The second example displays the commands sent to the SAR and the acknowledgements returned when the VC is deleted and the segmentation and reassembly channels are closed:

Router(config-if)# no pvc 2/2
Router(config-if)#
*Jun 27 22:12:59.016: ATM2/0: Sent pending EOP successfully
*Jun 27 22:12:59.016: ATM2/0: Close_Channel(RSY): Chan_ID (0x104)
*Jun 27 22:12:59.016: ATM2/0: Close_Channel(RSY): Chan_ID (0x104) CLOSE
*Jun 27 22:12:59.016: ATM2/0: Close_Channel: CLOSE_PENDING
*Jun 27 22:12:59.016: ATM2/0: Close_Channel(SEG): Chan_ID (0x105)
*Jun 27 22:12:59.016: ATM2/0: Close_Channel: CLOSE

Examples for the debug atm t3e3 trace command

The first example illustrates the output from the debug atm t3e3 trace command when it is run without the debug atm t3e3 sar command being activated:

Router# debug atm t3e3 trace
SAR CMD/ACK debugging is on
Router# configure terminal
Router(config)# interface atm 2/0
router(config-if)# pvc 2/2
Router(config-if-atm-vc)# exit
Router(config-if)#
*Jun 27 22:15:09.284: Command Sent:
*Jun 27 22:15:09.284:   word 0: 0x00000480
*Jun 27 22:15:09.284:   word 1: 0x00012010
*Jun 27 22:15:09.284:   word 2: 0x00000000
*Jun 27 22:15:09.284:   word 3: 0x00000000
*Jun 27 22:15:09.284:   word 4: 0x00200020
*Jun 27 22:15:09.284:   word 5: 0x00000000
*Jun 27 22:15:09.284:   word 6: 0x00000000
*Jun 27 22:15:09.284:   word 7: 0x00000000
*Jun 27 22:15:09.284:   word 8: 0x00000000
*Jun 27 22:15:09.284: Command Indication:
*Jun 27 22:15:09.284:   word 0: 0x00000000
*Jun 27 22:15:09.284:   word 1: 0x01042110
*Jun 27 22:15:09.284:   word 2: 0x01050000
*Jun 27 22:15:09.284:   word 3: 0x0000003B
*Jun 27 22:15:09.284: ACK received = 200 usecs
*Jun 27 22:15:09.284: Command Sent:
*Jun 27 22:15:09.284:   word 0: 0x01050480
*Jun 27 22:15:09.284:   word 1: 0x00011010
*Jun 27 22:15:09.284:   word 2: 0x02000000
*Jun 27 22:15:09.284:   word 3: 0x00010003
*Jun 27 22:15:09.284:   word 4: 0x00200020
*Jun 27 22:15:09.284:   word 5: 0x64B30000
*Jun 27 22:15:09.284:   word 6: 0x10C00000
*Jun 27 22:15:09.284:   word 7: 0x86850000
*Jun 27 22:15:09.284:   word 8: 0x00010040
*Jun 27 22:15:09.284:   word 9: 0x00000000
*Jun 27 22:15:09.284: Command Indication:
*Jun 27 22:15:09.284:   word 0: 0x00010000
*Jun 27 22:15:09.284:   word 1: 0x00011110
*Jun 27 22:15:09.284:   word 2: 0x02000000
*Jun 27 22:15:09.284:   word 3: 0x0001003D
*Jun 27 22:15:09.284: ACK received = 200 usecs

Table 5 describes the significant fields shown in the display.

Table 5 debug atm t3e3 trace Field Descriptions 

Field
Description

Jun 27 22:15:09.284:

Date or time stamp for the command dialog.

word [0 - n]: 0xXXXXXXXX

Hexadecimal representation of the n-word command sent to the SAR (under Command Sent:) and the four-word acknowledgment returned by the SAR (under Command Indication:).

ACK received

Time (in microseconds) between sending the command to the SAR and receiving the acknowledgment.


The second example illustrates the output from the debug atm t3e3 trace command run in conjunction with the debug atm t3e3 sar command.

In this example, each command sent to the SAR is displayed by the debug atm t3e3 sar command. Then the hexadecimal representation of the command and its acknowledgement are displayed by the debug atm t3e3 trace command.

Router# debug atm t3e3 trace

SAR CMD/ACK debugging is on
Router# debug atm t3e3 sar
SAR debugging is on
Router# configure terminal
Router(config)# interface atm 2/0
router(config-if)# pvc 2/2
Router(config-if-atm-vc)# exit
Router(config-if)#
*Jun 27 22:15:09.284: ATM2/0: Setup_VC: vc:4 vpi:2 vci:2
*Jun 27 22:15:09.284: ATM2/0: Open_Channel(RSY): CH (1), VPI (2), VCI (2)
*Jun 27 22:15:09.284: Command Sent:
*Jun 27 22:15:09.284:   word 0: 0x00000480
*Jun 27 22:15:09.284:   word 1: 0x00012010
*Jun 27 22:15:09.284:   word 2: 0x00000000
*Jun 27 22:15:09.284:   word 3: 0x00000000
*Jun 27 22:15:09.284:   word 4: 0x00200020
*Jun 27 22:15:09.284:   word 5: 0x00000000
*Jun 27 22:15:09.284:   word 6: 0x00000000
*Jun 27 22:15:09.284:   word 7: 0x00000000
*Jun 27 22:15:09.284:   word 8: 0x00000000
*Jun 27 22:15:09.284: Command Indication:
*Jun 27 22:15:09.284:   word 0: 0x00000000
*Jun 27 22:15:09.284:   word 1: 0x01042110
*Jun 27 22:15:09.284:   word 2: 0x01050000
*Jun 27 22:15:09.284:   word 3: 0x0000003B
*Jun 27 22:15:09.284: ACK received = 200 usecs
*Jun 27 22:15:09.284: ATM2/0: HI/LO watermarks: 526/263; PeakRate: 149760
*Jun 27 22:15:09.284: ATM2/0: Open_Channel(SEG): CH (1), VPI (2), VCI (2)
*Jun 27 22:15:09.284: Command Sent:
*Jun 27 22:15:09.284:   word 0: 0x01050480
*Jun 27 22:15:09.284:   word 1: 0x00011010
*Jun 27 22:15:09.284:   word 2: 0x02000000
*Jun 27 22:15:09.284:   word 3: 0x00010003
*Jun 27 22:15:09.284:   word 4: 0x00200020
*Jun 27 22:15:09.284:   word 5: 0x64B30000
*Jun 27 22:15:09.284:   word 6: 0x10C00000
*Jun 27 22:15:09.284:   word 7: 0x86850000
*Jun 27 22:15:09.284:   word 8: 0x00010040
*Jun 27 22:15:09.284:   word 9: 0x00000000
*Jun 27 22:15:09.284: Command Indication:
*Jun 27 22:15:09.284:   word 0: 0x00010000
*Jun 27 22:15:09.284:   word 1: 0x00011110
*Jun 27 22:15:09.284:   word 2: 0x02000000
*Jun 27 22:15:09.284:   word 3: 0x0001003D
*Jun 27 22:15:09.284: ACK received = 200 usecs
*Jun 27 22:15:09.284: ATM2/0: Setup_Cos: vc:4 wred_name:- max_q:0

Feature Information for the Cisco ATM T3/E3 Network Module

Table 6 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 6 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 6 Feature Information for the Cisco ATM T3/E3 Network Module 

Feature Name
Releases
Feature Information

NM-1A-T3/E3 Network Module

12.4(15)T

The NM-1A-T3/E3 network module provides ATM services on a T3 or E3 connection.

This feature is supported on Cisco 2800 and Cisco 3800 series routers.

The following command was introduced by this feature: debug atm t3e3.