Guest

Cisco IOS Software Releases 12.4 Special and Early Deployments

High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways

  • Viewing Options

  • PDF (329.5 KB)
  • Feedback
High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways

Table Of Contents

High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways

Contents

Restrictions for the High-Density Packet Voice Feature Card

Information About the High-Density Packet Voice Feature Card

High-Density Packet Voice Feature Card Key Features

How to Configure and Manage the High-Density Packet Voice Feature Card

Upgrading DSP Firmware on the High-Density Packet Voice Feature Card

Creating and Applying Voicecaps for the High-Density Packet Voice Feature Card (Optional)

Configuring the GSMAMR-NB Codec for the High-Density Packet Voice Feature Card

Overview and Restrictions for the GSMAMR-NB Codec

GSMAMR-NB Codec Compliance with RFC 3267

How to Configure the GSMAMR-NB Codec on the High-Density Packet Voice Feature Card

Verifying and Troubleshooting the High-Density Packet Voice Feature Card

Using Online Insertion and Removal to Replace the High-Density Packet Voice Feature Card

Configuration Examples for the High-Density Packet Voice Feature Card

show running-config for the High-Density Packet VFC on a Cisco AS5400XM: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

Feature Information for the High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways

Glossary


High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways


First Published: February 27, 2006
Last Updated: July 11, 2008

The High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways (product number AS5X-FC) feature supports up to six high-density packet voice/fax digital signal processor (DSP) modules (product number AS5X-PVDM2-64), increasing the density of the feature card to 384 low-complexity or 192 medium-complexity or 144 high-complexity VoIP calls.

The High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways (referred to here as the High-Density Packet VFC) with one to six PVDM2-64 modules can provide the correct number of DSPs depending on the codec type needed and Cisco AS5350XM and Cisco AS5400XM trunk configuration.

You can select the minimum number of PVDM2-64 modules depending on the voice channels currently needed, and then add PVDM2-64 modules as requirements expand. The High-Density Packet VFC supports T1/E1 and CT3 configurations.

The High-Density Packet VFC is designed to work with basic software configurations on Cisco AS5350XM and Cisco AS5400XM platforms without requiring specific configuration changes. However, there are some changes to existing command-line interface (CLI) commands that enable you to customize and troubleshoot your configuration to improve performance. These commands are described in the "Command Reference" section on page 28.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for the High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways" section on page 29.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Restrictions for the High-Density Packet Voice Feature Card, page 2

Information About the High-Density Packet Voice Feature Card, page 3

How to Configure and Manage the High-Density Packet Voice Feature Card, page 4

Configuration Examples for the High-Density Packet Voice Feature Card, page 21

Additional References, page 27

Command Reference, page 28

Glossary, page 30

Restrictions for the High-Density Packet Voice Feature Card

Before you can run the High-Density Packet VFC for Cisco AS5350XM and AS5400XM Universal Gateways, you must install an IP Plus image (minimum) of Cisco IOS Release 12.4(9)T or a later release.

Software echo cancellation is the default configuration—G.168-compliant echo cancellation is enabled by default with a coverage of 128 milliseconds (ms). Hardware echo cancellation is not available.

The High-Density Packet VFC uses only PVDM2-64 Packet Fax/Voice DSP modules.

Global System for Mobile Adaptive Multi-Rate Narrow Band (GSMAMR-NB) codec support is available only with H.323 and Session Initiation Protocol (SIP) as call control protocols. When DSPware supporting the GSMAMR-NB codec is used, all DSPs on all VFCs in the Cisco AS5350XM or AS5400XM must run the GSMAMR-NB DSPware.

Skinny Client Control Protocol (SCCP) is not supported.

To use High-Density Packet VFCs in your gateway, you must have at least one High-Density Packet VFC installed prior to bootup. Additional High-Density Packet VFCs can be installed later.

A mix of High-Density Packet VFCs and NextPort Dial Feature Cards (NP DFCs) is not supported. If a High-Density Packet VFC is installed in a Cisco AS5350XM or Cisco AS5400XM with a NextPort DFC running, you must reboot the system to support the High-Density Packet VFC, and the NextPort DFC will be powered down. That is, if a High-Density Packet VFC is present during bootup, dial-only and universal port cards will not operate.


Note If no AS5X-FC is installed during bootup, the gateway will support only dial-only or universal port cards. If you want to use an AS5X-FC, you must install the card and reboot the system.


Information About the High-Density Packet Voice Feature Card

This section provides information about the following concept:

High-Density Packet Voice Feature Card Key Features, page 3

High-Density Packet Voice Feature Card Key Features

The High-Density Packet VFC features the following:

Port densities on the High-Density Packet Voice Feature Card depend on codec complexity:

Low complexity: up to 384 G.711, Clear-Channel, and Fax/Modem Passthrough ports

Medium complexity: up to 192 G.726, G.729a, G.729ab, fax-relay ports

High complexity: up to 144 G.728, G.729, G.729b, G.723.1, Modem Relay, and GSMAMR-NB ports (AMR-NB supports a packetization period of 20 ms only)

Each High-Density Packet VFC can support the following:

Up to six AS5X-PVDM2-64s.

Each AS5X-PVDM2-64 has four DSPs

Each DSP can support up to 16 low-complexity calls, 8 medium-complexity calls, or 6 high-complexity calls.

The DSPs are always set to flex mode and the codec complexity is determined by the codec that is negotiated.

Support is provided for packetization periods for all codecs: 10 ms to 30 ms with configurable increments of the minimum defined by the codec or 5 ms, whichever is greater.

Support is provided for H.323, SIP, and MGCP call control protocols.

DSPware is bundled into the Cisco IOS image, but the DSPware is also supported as a standalone firmware image that can be loaded to the DSP (independent of the Cisco AS5350XM and Cisco AS5400XM image).

High-Density Packet VFCs are hot-swappable and replaceable (using online insertion and removal [OIR]). However, you should complete the software procedure in the "Using Online Insertion and Removal to Replace the High-Density Packet Voice Feature Card" section on page 19 before removing a card from the chassis.

The PVDM2 SIMM is field-replaceable.

G.168-compliant echo cancellation for tail circuits up to 128 ms can be configured by software.

Support is provided for voice activity detection (VAD), comfort noise generation, adaptive jitter buffering, and caller ID.

AMR-NB calls are brought up with the common modes from the mode-set of both endpoints.

Beginning with Cisco IOS Release 12.4(9)T, support is provided for the Media and Signaling Authentication and Encryption Feature for Cisco IOS H.323 Gateways, which provides authentication, integrity, and encryption of voice media and call control signaling for H.323 protocol-based voice gateways. For more information about this feature and instructions for configuration, refer to "Media and Signaling Authentication and Encryption Feature for Cisco IOS H.323 Gateways."

How to Configure and Manage the High-Density Packet Voice Feature Card

This section contains the following procedures:

Upgrading DSP Firmware on the High-Density Packet Voice Feature Card, page 4

Creating and Applying Voicecaps for the High-Density Packet Voice Feature Card (Optional), page 5

Configuring the GSMAMR-NB Codec for the High-Density Packet Voice Feature Card, page 7

Verifying and Troubleshooting the High-Density Packet Voice Feature Card, page 12

Using Online Insertion and Removal to Replace the High-Density Packet Voice Feature Card, page 19

Upgrading DSP Firmware on the High-Density Packet Voice Feature Card

The High-Density Packet Voice Feature Card should work without specific modifications to the software configuration on the Cisco AS5350XM and AS5400XM platforms. However, to ensure that you have the latest version of firmware, you can use the Cisco IOS commands in this section to upgrade the firmware.

For more information about GSMAMR-NB DSPware, see the "Overview and Restrictions for the GSMAMR-NB Codec" section on page 8. To upgrade the DSP firmware of the High-Density Packet Voice Feature Card, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. voice dsp slot [/dsp] [slot [/dsp]]

4. firmware {location flash:filename | upgrade [busyout | reboot]}

5. exit

6. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

voice dsp slot [/dsp] [slot [/dsp]]
Example:

Router(config)# voice dsp 1/1

Enters config-voicedsp configuration mode and specifies the slot and DSP location or a range of slots and DSPs.

For the slot argument, specify a value from 1 to 7 to specify the location of the High-Density Packet VFCs.

For the dsp argument, specify a value from 1 to 24 to specify the location of the DSP.

To specify a range, enter the first two arguments to specify the first slot and DSP in the range. The second two arguments specify the last slot and DSP in the range.

Where slash marks appear in the command syntax, they are required.

Step 4 

firmware {location flash:filename | upgrade 
[busyout | reboot]}
Example:

Router(config-voicedsp)# firmware location flash:123

Example:

Router(config-voicedsp)# firmware upgrade busyout

Specifies the location and filename of firmware and timing for the upgrade.

flash:—Loads the firmware from the flash NVRAM located within the router.

filename—The firmware filename.


Note The maximum number of DSPware versions permitted in flash memory is nine.


busyout—Starts the firmware upgrade immediately.

reboot—Delays the firmware upgrade until the next reboot.

Step 5 

exit
Example:

Router(config-voicedsp)# exit

Exits config-voicedsp configuration mode and returns to global configuration mode.

Step 6 

end
Example:
Router(config)# end

Exits global configuration mode and returns to privileged EXEC mode.

Creating and Applying Voicecaps for the High-Density Packet Voice Feature Card (Optional)

Voicecaps provide flexibility and configurability for diversified types of installations maintained by VoIP gateway service providers. To create and apply voicecaps for the High-Density Packet Voice Feature Card, complete the following steps. Additional information on the syntax and use of these commands is provided in the "Command Reference" section on page 28.


Note In Cisco IOS Release 12.4(4)XC, voicecap is defined only for the GSMAMR-NB codec using the High-Density VFC. Voicecaps defined for NextPort are not applicable for the High-Density VFC.


SUMMARY STEPS

1. enable

2. configure terminal

3. voicecap entry [name string]

4. voice-port slot/port

5. voicecap configure name

6. exit

7. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

voicecap entry [name string]
Example:

Router(config)# voicecap entry gsmamrnb-ctrl v0=1

Creates a voicecap entry and defines the parameter list. In Release 12.4(4)XC, voicecap is defined only for the GSMAMR-NB codec on the High-Density VFC.

For the GSMAMR NB codec, the string argument can be 0 or 1. This value specifies one or more voicecap register entries, similar to a modemcap. Each entry is of the form vindex=value, where index refers to a specific V register, and value designates the value for that V register.

0 = Determines how the AMR responds to an incoming Codec Mode Request (CMR) that is not a member of the mode set.

0 = Drops the packet with the bad CMR.

1 = Ignore the CMR (do not change rates) but process the rest of the packet data normally.

2 = Change the rate to the highest rate in the mode set lower than the rate requested by the CMR.

1 = Determines how the AMR handles packets with a frame type (AMR rate) that is not a member of the mode set:

0 = Drops the packet with the bad frame type.

1 = Attempts to decode the packet.

Step 4 

voice-port slot/port
Example:

Router(config)# voice-port 3/0:D

Enters voiceport configuration mode and identifies the slot and port where the High-Density Packet Voice Feature Card is installed.

The slash mark is required.

Step 5 

voicecap configure name
Example:

Router(config-voiceport)# voicecap configure gsmamrnb-ctrl

Applies the voicecap entries to the specified voice port.

Note The voicecap must be applied to the voice port.

Step 6 

exit
Example:
Router(config-voiceport)# exit

Exits voiceport configuration mode and returns to global configuration mode.

Step 7 

end
Example:
Router(config)# end

Exits global configuration mode and returns to privileged EXEC mode.

Configuring the GSMAMR-NB Codec for the High-Density Packet Voice Feature Card

This section provides information about the following:

Overview and Restrictions for the GSMAMR-NB Codec, page 8

GSMAMR-NB Codec Compliance with RFC 3267, page 9

How to Configure the GSMAMR-NB Codec on the High-Density Packet Voice Feature Card, page 10

Overview and Restrictions for the GSMAMR-NB Codec

The Adaptive Multirate Narrow Band (AMR-NB) codec is a high complexity multimode codec that supports eight narrowband speech encoding modes with bit rates between 4.75 and 12.2 kbps. The sampling frequency used in AMR-NB is 8000 Hz and the speech encoding is performed on 20 ms speech frames. Therefore, each encoded AMR-NB speech frame represents 160 samples of the original speech.

The AMR-NB codec was originally developed and standardized by the European Telecommunications Standards Institute (ETSI) for Groupe Speciale Mobile (GSM) cellular systems. and chosen by the Third Generation Partnership Project (3GPP) as the mandatory codec for third generation (3G) cellular systems.


Note You must buy a license to access the DSPware that supports the AMR-NB codec. It is recommended that you purchase a Cisco SMARTnet contract in order to streamline the process of getting the AMR-NB codec DSPware. When obtaining your license, use the following part numbers:


FR535XM-AMR-LIC for the Cisco AS5350XM

FR54XM-AMR-LIC for the Cisco AS5400XM

For more information, contact your Cisco representative or visit the following Cisco.com website to obtain a Cisco SMARTnet contract:
http://www.cisco.com/en/US/partner/products/svcs/ps3034/ps2827/ps2978/serv_datasheet09186a0080092491.html

Table 1 contains codec mode and bit rate information for the AMR codec.

Table 1 AMR Codec Modes and Bit Rates

Codec Mode
Bit Rate (kbps)

0

4.75

1

5.15

2

5.90

3

6.70

4

7.40

5

7.95

6

10.2

7

12.2

81

1.80

1 Used for Silence Indication Detection (SID) frames.


How the AMR-NB Codec Works

The multirate encoding (or multimode) capability of AMR-NB is designed for preserving high speech quality under a wide range of transmission conditions. Unlike other codecs, the AMR-NB codec can adapt to different bit rates (see Table 1) based on channel conditions during the call.

To perform mode adaptation, the decoder (speech receiver) sends a signal to the encoder (speech sender) to indicate which new mode it prefers. This mode-change signal is called codec mode request (CMR). Because speech is sent in both directions between the two ends in most sessions, the mode requests from the decoder at one end to the encoder at the other end are sent in a piggyback form over the speech frames in the reverse direction; there is no out-of-band signaling needed for sending CMRs. The Cisco AS5400XM and Cisco AS5350XM cannot initiate CMRs and received CMRs can be processed. For more information about AMR-NB codecs, see RFC 3267.

Feature Limitations or Restrictions

All the DSPs in the system must be upgraded with the GSMAMR-NB DSPware.

The following message is displayed when an upgrade takes place if a version of DSPware other than the recommended version is uploaded:

WARNING: Recommended GSM AMR-NB supported DSPware for this Cisco IOS image is X.Y.Z 
Where X.Y.Z changes depending on the Cisco IOS image that is used by the customer.

This warning has no impact on the firmware upgrade and calls can be brought up with a version of DSPware that is not the recommended version.

GSMAMR-NB Codec Compliance with RFC 3267

GSMAMR-NB codec support is compliant with RFC 3267. Specifications for RFC 3267 are supported by the High-Density Packet Voice Feature Card:

The Cisco AS5350XM and Cisco AS5400XM do not initiate CMRs. However, these platforms can process the received CMRs.

RFC 3267 allows for the sending of redundant voice frames with the same sequence number and time stamp. The Cisco AS5350XM and Cisco AS5400XM platforms do not send redundant packets, but they can receive redundant frames. When redundancy is used, RFC 3267 allows for different compression modes to be used for redundant frames. The standard recommends that when two redundant frames are received accurately, the frame with the lower compression (highest bit rate) be used. The Cisco AS5350XM and Cisco AS5400XM instead use the frame that is first received.

The following apply to the codec gsmamr-nb command used to configure the GSMAMR-NB codec:

Cisco AS5350XM and Cisco AS5400XM do not support any of the parameter changes after the call is up.

Support is provided for both octet-aligned and bandwidth-efficient frame formats.

Support is provided for all eight modes of AMR-NB codec.

The gateway can change to any mode at any time, which translates to mode-change-period of 20 ms and mode-change-neighbor value of 0.

CRC is supported.

Only supported value for maxptime and ptime arguments is 20 ms.

Robust sorting and interleaving are not supported.

The only supported value for the channels argument is 1.

How to Configure the GSMAMR-NB Codec on the High-Density Packet Voice Feature Card

To configure GSMAMR-NB codec support on the High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. dial-peer voice tag {pots | mmoip | voip}

4. codec gsmamr-nb [packetization-period 20][encap rfc3267] [frame-format {bandwidth-efficient | octet-aligned [crc | no-crc]}] [modes modes-value]

5. rtp payload-type cisco-codec-gsmamrnb number

6. exit

7. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

dial-peer voice tag {pots | mmoip | voip}
Example:

Router(config)# dial-peer voice 10 voip

Defines a particular dial peer, specifies the method of voice encapsulation, and enters dial-peer configuration mode:

tag—Digits that define a particular dial peer. Range is from 1 to 2147483647.

pots—Indicates that this is a POTS peer that uses VoIP encapsulation on the IP backbone.

mmoip—Indicates that this is a POTS peer that uses MMoIP encapsulation on the IP backbone.

voip—Indicates that this is a VoIP peer that uses voice encapsulation on the POTS network.

Step 4 

codec gsmamr-nb [packetization-period 20][encap 
rfc3267] [frame-format {bandwidth-efficient | 
octet-aligned [crc | no-crc]}] [modes 
modes-value]
Example:

Router(config-dial-peer)# codec gsmamr-nb packetization-period 20 encap rfc3267 frame-format octet-aligned crc

Specifies the GSMAMR-NB codec for a dial peer:

packetization-period 20—Sets the packetization period to 20 ms.

encap rfc3267—Sets the encapsulation value to comply with RFC 3267.

frame-format—Specifies a frame format. Supported values are octet-aligned and bandwidth-efficient. The default is octet-aligned.

crc | no-crc—CRC is applicable only for octet-aligned frame format. If you enter bandwidth-efficient frame format, the crc | no-crc options will not be available because they are inapplicable.

modes—Valid values are from 0 to 7. You can specify modes as a range (for example, 0-2), or individual modes separated by commas (for example, 2,4,6), or a combination of the two (for example, 0-2,4,6-7). Applicable only to GSMAMR-NB codec support.

Step 5 

rtp payload-type cisco-codec-gsmamrnb number 
Example:

Router(config-dial-peer)# rtp payload-type cisco-codec-gsmamrnb 110

Configures a dynamic payload-type value for the GSMAMR-NB codec.

The default value is 117.

There are other options available with this command, but an abbreviated syntax is shown here to clearly indicate the keywords and options for the GSMAMR-NB codec.

Step 6 

exit
Example:

Router(config-dial-peer)# exit

Exits dial-peer voice configuration mode and returns to global configuration mode.

Step 7 

end
Example:
Router(config)# end

Exits global configuration mode and returns to privileged EXEC mode.

Verifying and Troubleshooting the High-Density Packet Voice Feature Card

To verify the configuration of the High-Density Packet VFC, use the show running-config command. Sample output is located in the "Configuration Examples for the High-Density Packet Voice Feature Card" section on page 21.

For troubleshooting, steps 1 through 7 are useful to obtain status and statistics on network operation. Steps 8 through 10 can be used to obtain debugging information for the High-Density Packet VFC.

SUMMARY STEPS

1. show voice dsp [active | channel {operational-status | statistics | traffic [slot [/dsp [/channel]]]}| crash-dump | detailed | error | group | signaling | summary | version | voice]

2. show voice dsp summary

3. show voice hpi capture

4. show call active fax

5. show call active voice

6. show chassis slot slot

7. show diag

8. debug voice dsp crash-dump {detail | keepalive}

9. debug dsp-resource-manager flex {all | detail | download | dspfarm | dspstats | error | function}

10. debug voice hpi {all | capture | command | default | detail | error | function | inout | nack | notification | response | stats}

DETAILED STEPS


Step 1 show voice dsp [active | channel {operational-status | statistics | traffic [slot [/dsp [/channel]]]}| crash-dump | detailed | error | group | signaling | summary | version | voice]

The following example shows the operational status for slot 3, dsp 2, channel 15 on a Cisco AS5400XM router:

Router# show voice dsp channel operational-status 3/2/15

Slot/DSP/channel -- 3/2/15
Service Type                        : Fax-relay service
Max. transmission rate              : 14400 bps
: 20 ms
TCF generation                      : transparent
Transmit level                      : -10 dBm
Encapsulation protocol              : UDPTL
ECM Disable                         : Not disabled
Current playout delay               : 13 ms
Min/Max playout delay               : 1/240 ms
Buffer underflow discard            : 0
Buffer overflow discard             : 0
End-point detection errors          : 0
Tx/Rx Fax packets                   : 979/35
Tx/Rx duration                      : 20549/4412 ms
Tx/Rx pages                         : 0/0
Out of sequence packets             : 0
Bad protocol headers                : 0
Fax state                           : V.17 demodulation - short train 14400 bps
Current signal level                : 4.5 dBm
Phase jitter                        : 253 degrees
Frequency offset                    : 0 Hz
Packet loss concealment count       : 0
TX/RX Byte Count                    : 0/23
Recent HS Modulation                : V.17 modulation - short train 14400 bps
Number of SSRC changes              : 0
Number of payload violations        : 0


Note If the GSMAMR-NB codec has been configured, and there are calls using this codec, the following statistics will be included in the output for the show voice dsp channel operational-status command.


CodecEncodeRate=7
CodecDecodeRate=7
CodecEncodeChanges=0
CodecDecodeChanges=0
CodecCrcFails=0
CodecBadFrameQuality=0
CodecInvalidCMRs=0
CodecInvalidFrameType=0

Step 2 show voice dsp summary

This command generates a display of the DSP status and summary information for each DSP. The following is sample output from this command:

Router# show voice dsp summary

Total number of DSPs = 24

Codectype       Calls    Codectype       Calls    Codectype       Calls
g729r8              1    

Legend       :
======
Channel state: (s)shutdown   (a)active call (d)download pending
               (b)busiedout  (B)bad         (p)busyout pending
Call type    : (v)voice      (f)fax-relay   (_)not in use

Summary   :
=======
Channels  :  Total 384  In-Use    001  
Calls     :  Total 001  Voice     001  Fax  000
Credits   :  Free  350  Disabled  032 

      DSP      DSP        DSP    Channel            Call            
DSP#  State    Complexity Resets State              Type
3/1   ACTIVE   FLEXI      0      a_______ ________  v_______ ________
3/2   B-OUT    FLEXI      0      bbbbbbbb bbbbbbbb  ________ ________
3/3   OOS      FLEXI      0      ssssssss ssssssss  ________ ________
3/4   ACTIVE   FLEXI      1      ________ ________  ________ ________
3/5   ACTIVE   FLEXI      0      ________ ________  ________ ________
3/6   ACTIVE   FLEXI      0      ________ ________  ________ ________
3/7   ACTIVE   FLEXI      0      ________ ________  ________ ________
3/8   ACTIVE   FLEXI      0      ________ ________  ________ ________
3/9   ACTIVE   FLEXI      0      ________ ________  ________ ________
3/10  ACTIVE   FLEXI      0      ________ ________  ________ ________
3/11  ACTIVE   FLEXI      0      ________ ________  ________ ________
3/12  ACTIVE   FLEXI      0      ________ ________  ________ ________
3/13  ACTIVE   FLEXI      0      ________ ________  ________ ________
3/14  ACTIVE   FLEXI      0      ________ ________  ________ ________
3/15  ACTIVE   FLEXI      0      ________ ________  ________ ________
3/16  ACTIVE   FLEXI      0      ________ ________  ________ ________
4/5   ACTIVE   FLEXI      0      ________ ________  ________ ________
4/6   ACTIVE   FLEXI      0      ________ ________  ________ ________
4/7   ACTIVE   FLEXI      0      ________ ________  ________ ________
4/8   ACTIVE   FLEXI      0      ________ ________  ________ ________
4/9   ACTIVE   FLEXI      0      ________ ________  ________ ________
.
.
.

Step 3 show voice hpi capture

In the following example, the show voice hpi capture command is used in privileged EXEC mode to check on the status of the logger before, during, and after configuration:

Router# show voice hpi capture 

HPI Capture is on and is logging to URL ftp://10.23.184.216/d:\test_data.dat
1 messages sent to URL, 0 messages dropped
Message Buffer (total:inuse:free)  2134:0000:2134Buffer 
Memory:699952 bytes, Message size:328 bytes

Step 4 show call active fax

The following is sample output from the command that shows no fax activity on the router:

Router# show call active fax

Telephony call-legs: 0
SIP call-legs: 0
H323 call-legs: 0
Call agent controlled call-legs: 0
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 0

Step 5 show call active voice

The following is sample output from the command that shows statistics for active voice calls on the router:

Router# show call active voice

GENERIC:
SetupTime=94523746 ms
Index=448
PeerAddress=##73072
PeerSubAddress=
PeerId=70000
PeerIfIndex=37
LogicalIfIndex=0
ConnectTime=94524043
DisconectTime=94546241
CallOrigin=1
ChargedUnits=0
InfoType=2
TransmitPackets=6251
TransmitBytes=125020
ReceivePackets=3300
ReceiveBytes=66000
VOIP:
ConnectionId[0x142E62FB 0x5C6705AF 0x0 0x385722B0]
RemoteIPAddress=171.68.235.18
RemoteUDPPort=16580
RoundTripDelay=29 ms
SelectedQoS=best-effort
tx_DtmfRelay=inband-voice
SessionProtocol=cisco
SessionTarget=ipv4:171.68.235.18
OnTimeRvPlayout=63690
GapFillWithSilence=0 ms
GapFillWithPrediction=180 ms
GapFillWithInterpolation=0 ms
GapFillWithRedundancy=0 ms
HiWaterPlayoutDelay=70 ms
LoWaterPlayoutDelay=30 ms
ReceiveDelay=40 ms
LostPackets=0 ms
EarlyPackets=1 ms
LatePackets=18 ms
VAD = disabled
CoderTypeRate=g729r8
CodecBytes=20
cvVoIPCallHistoryIcpif=0
SignalingType=cas

Step 6 show chassis slot slot

The following example shows the hardware information for slot 1 on a Cisco AS5400XM:

Router# show chassis slot 1

Slot 1:
DFC type is AS5400XM E1 8 PRI DFC

OIR events:
        Number of insertions = 0, Number of removals = 0
DFC State is DFC_S_OPERATIONAL

Step 7 show diag

The following example shows diagnostic information on a per-slot basis for an AS5400XM:

Router# show diag

Slot 0:
AS5400XM Motherboard
Manufacture Cookie Info:
        Board ID                 : 0x4BD
        Hardware Revision        : 2.6
        Top Assy. Part Number    : 800-25673-01
        Part Number              : 73-9526-02
        Board Revision           : C0
        Fab Part Number          : 28-6926-02
        Platform features        : 00 00 00 00 
        Processor type           : AA 
        Product (FRU) Number     :                   
        PCB Serial Number        : JAE09148V4P
        Chassis MAC Address      : 0013.803e.8c72
        MAC Address block size   : 2
        CLEI Code                : 
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Version Identifier       : V01 
 EEPROM contents (hex):
          0x00: 04 FF 40 04 BD 41 02 06 C0 46 03 20 00 64 49 01
          0x10: 82 49 25 36 02 42 43 30 85 1C 1B 0E 02 C9 84 00
          0x20: 00 00 00 09 AA CB 92 20 20 20 20 20 20 20 20 20
          0x30: 20 20 20 20 20 20 20 20 20 C1 8B 4A 41 45 30 39
          0x40: 31 34 38 56 34 50 C3 06 00 13 80 3E 8C 72 43 00
          0x50: 02 C6 8A FF FF FF FF FF FF FF FF FF FF 03 00 81
          0x60: 00 00 00 00 04 00 89 56 30 31 20 FF FF FF FF FF
 FRU NUMBER : AS5400XM

Slot 1:
DFC type is AS5400XM E1 8 PRI DFC

OIR events:
        Number of insertions = 0, Number of removals = 0
DFC State is DFC_S_OPERATIONAL

Error events (Bus errors, PCI errors):
        Number of errors recovered = 0

DFC Cookie Info:
Manufacture Cookie Info:
 EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x03,
 Board Hardware Version 4.8, Item Number 73-3996-05,
 Board Revision A0, Serial Number JAE090867PL,
 PLD/ISP Version <unset>,  Manufacture Date 14-Feb-2005.
 RMA Number1 <unset>, RMA Number2 <unset>
 EEPROM format version 0x1
 EEPROM contents (hex):
  0x00: 00 01 01 03 04 08 00 49 00 0F 9C 05 41 00 4A 41
  0x10: 45 30 39 30 38 36 37 50 4C 00 00 00 00 00 14 05
  0x20: 02 0E FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
 FRU NUMBER : AS54-DFC-8CE1
Trunk DFC Info:
 PLD Version 0x9, PLX9054 Revision 0xC,
 Boot ROM Version 0x2.

Carrier Card Master PLD/FPGA Rev 0x0006

Slot 2:
DFC type is AS5400XM AS5X-FC

OIR events:
        Number of insertions = 0, Number of removals = 0
DFC State is DFC_S_OPERATIONAL

Error events (Bus errors, PCI errors):
        Number of errors recovered = 0

Carrier Card Cookie Info:
Manufacture Cookie Info:
        Board ID                 : 0x4BE
        Hardware Revision        : 1.1
        Part Number              : 73-9527-01
        Board Revision           : A0
        Fab Part Number          : 28-6928-01
        Product (FRU) Number     : 
        PCB Serial Number        : JAE09096VW5
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Version Identifier       : V01 
 EEPROM contents (hex):
          0x00: 04 FF 40 04 BE 41 01 01 82 49 25 37 01 42 41 30
          0x10: 85 1C 1B 10 01 CB 92 00 00 00 00 00 00 00 00 00
          0x20: 00 00 00 00 00 00 00 00 00 C1 8B 4A 41 45 30 39
          0x30: 30 39 36 56 57 35 03 00 81 00 00 00 00 04 00 89
          0x40: 56 30 31 20 FF FF FF FF FF FF FF FF FF FF FF FF
DFC Cookie Info:
Manufacture Cookie Info:
        Board ID                 : 0x4CF
        Hardware Revision        : 1.0
        Part Number              : 73-9980-01
        Board Revision           : 03
        Fab Part Number          : 28-7322-01
        Product (FRU) Number     : aa
        PCB Serial Number        : JAB091100MC
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Version Identifier       : VP1
 EEPROM contents (hex):
          0x00: 04 FF 40 04 CF 41 01 00 82 49 26 FC 01 42 30 33
          0x10: 85 1C 1C 9A 01 CB 82 61 61 C1 8B 4A 41 42 30 39
          0x20: 31 31 30 30 4D 43 03 00 81 00 00 00 00 04 00 89
          0x30: 56 50 31 00 D9 02 40 C1 FF FF FF FF FF FF FF FF
 FRU NUMBER : UNKNOWN_BOARD_ID

        PVDM Slot 5:
        64-channel (G.711) Voice/Fax PVDMII DSP SIMM PVDM daughter card
        Hardware Revision        : 3.2
        Part Number              : 73-8541-04
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 03
        PCB Serial Number        : FOC09044PN8
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 00 
        Product (FRU) Number     : PVDM2-64
        Version Identifier       : NA  
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 03 EC 41 03 02 82 49 21 5D 04 42 41 30
          0x10: 88 00 00 00 00 02 03 C1 8B 46 4F 43 30 39 30 34
          0x20: 34 50 4E 38 03 00 81 00 00 00 00 04 00 09 00 CB
          0x30: 88 50 56 44 4D 32 2D 36 34 89 4E 41 20 20 D9 02
          0x40: 40 C1 FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
Carrier Card Master PLD/FPGA Rev 0x0006
VFC FPGA Rev 0x0008

Slot 3:
DFC type is AS5400XM Empty DFC
DFC is not powered

OIR events:
        Number of insertions = 0, Number of removals = 0

Error events (Bus errors, PCI errors):
        Number of errors recovered = 0

Carrier Card Cookie Info:
Manufacture Cookie Info:
        Board ID                 : 0x4BE
        Hardware Revision        : 1.1
        Part Number              : 73-9527-01
        Board Revision           : A0
        Fab Part Number          : 28-6928-01
        Product (FRU) Number     : 
        PCB Serial Number        : JAE09096VW5
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Version Identifier       : V01 
 EEPROM contents (hex):
          0x00: 04 FF 40 04 BE 41 01 01 82 49 25 37 01 42 41 30
          0x10: 85 1C 1B 10 01 CB 92 00 00 00 00 00 00 00 00 00
          0x20: 00 00 00 00 00 00 00 00 00 C1 8B 4A 41 45 30 39
          0x30: 30 39 36 56 57 35 03 00 81 00 00 00 00 04 00 89
          0x40: 56 30 31 20 FF FF FF FF FF FF FF FF FF FF FF FF
Carrier Card Master PLD/FPGA Rev 0x0006

Slot 4:
DFC type is AS5400XM Empty DFC
DFC is not powered

OIR events:
        Number of insertions = 0, Number of removals = 0

Error events (Bus errors, PCI errors):
        Number of errors recovered = 0

Carrier Card Master PLD/FPGA Rev 0x0006

Slot 5:   
DFC type is AS5400XM Empty DFC
DFC is not powered

OIR events:
        Number of insertions = 0, Number of removals = 0

Error events (Bus errors, PCI errors):
        Number of errors recovered = 0

Carrier Card Master PLD/FPGA Rev 0x0006

Slot 6:
DFC type is AS5400XM Empty DFC
DFC is not powered

OIR events:
        Number of insertions = 0, Number of removals = 0

Error events (Bus errors, PCI errors):
        Number of errors recovered = 0

Carrier Card Master PLD/FPGA Rev 0x0006
          
Slot 7:
DFC type is AS5400XM Empty DFC
DFC is not powered

OIR events:
        Number of insertions = 0, Number of removals = 0

Error events (Bus errors, PCI errors):
        Number of errors recovered = 0

Carrier Card Master PLD/FPGA Rev 0x0006

Step 8 debug voice dsp crash-dump {detail | keepalive}

Use this command to turn on the function for detailed DSP crash-dump debugging or to debug DSP crash-dump keepalives.

Step 9 debug dsp-resource-manager flex {all | detail | download | dspfarm | dspstats | error | function}

To turn on error debugging for the DSP resource manager function for flexible codec complexity, use the following command (a response from the command-line interface indicates that the function is turned on):

Router# debug dsp-resource-manager flex error
flexdsprm error debugging is on

To turn off error debugging for the DSP resource manager function for flexible codec complexity, use the following command (a response from the command-line interface indicates that the function is turned off):

Router# undebug dsp-resource-manager flex error
flexdsprm error debugging is off

Step 10 debug voice hpi {all | capture | command | default | detail | error | function | inout | nack | notification | response | stats}

Use this command to debug voice hpi functions. Use the available keywords to customize the output and focus the debug capability.


Using Online Insertion and Removal to Replace the High-Density Packet Voice Feature Card

High-Density Packet VFCs are hot-swappable and replaceable (using online insertion and removal [OIR]). However, you should complete the following steps before removing the card:

SUMMARY STEPS

1. enable

2. busyout slot

3. show busyout slot

4. show chassis slot slot

5. clear voice dsp {channels | error} [slot[/dsp][/channel]] [slot[/dsp][/channel]]

6. Remove the High-Density Packet VFC from the slot.

7. Insert the new High-Density Packet VFC in the slot.

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

busyout slot

Example:

Router# busyout 2

Disconnects calls on the card.

The slot argument identifies the location of the High-Density Packet VFC in the chassis.

Step 3 

show busyout slot

Example:

Router# show busyout 2

Shows information that indicates when busyout is complete and all calls are disconnected.

The slot argument identifies the location of the High-Density Packet VFC in the chassis.

The associated configuration of the High-Density Packet VFC is automatically removed from the system configuration.

Step 4 

show chassis slot slot

Example:

Router# show chassis slot 2

During the busyout process, the show chassis slot displays the state of the High-Density Packet VFC as DFC_S_REMOVING.

The slot argument identifies the location of the High-Density Packet VFC in the chassis.

Confirm the completion of the busyout by repeating the show chassis slot slot command until the status changes to DFC_S_REMOVED.

Step 5 

clear voice dsp {channels | error} [slot[/dsp][/channel]] [slot[/dsp][/channel]]

(Optional) Forces a busyout of all calls on a channel. Use this command to forcefully busyout any remaining calls on specific channels, slots, or DSPs.

channels—Clears DSP calls on a specific channel or a range of channels.

errors—Clears DSP error statistics.

/slot—(Optional) Specifies either a single slot or the first slot in a range. To specify a range of slots, you can enter a second slot in the syntax of this argument. The second slot specifies the end of the range. All slots in the range are affected by the command.

/dsp—(Optional) Specifies either a single DSP on the slot or the first DSP in a range. To specify a range of DSPs, you can enter a second DSP in the syntax of this argument. The second DSP specifies the end of the range. All DSPs in the range are affected by the command.

/channel—(Optional) Specifies either a single channel on the DSP or the first channel in a range. To specify a range of channels, you can enter a second channel in the syntax of this argument. The second channel specifies the end of the range. All channels in the range are affected by the command.

Step 6 

Remove the High-Density Packet VFC from the slot.

The High-Density Packet VFC is physically removed from the chassis.

Step 7 

Insert the High-Density Packet VFC in the slot.

When the High-Density Packet VFC is reinserted in the chassis, the card is automatically detected and activated.

Configuration Examples for the High-Density Packet Voice Feature Card

This section provides a sample default configuration for the High-Density Packet Voice Feature Card installed in a Cisco AS5400XM platform:

show running-config for the High-Density Packet VFC on a Cisco AS5400XM: Example

show running-config for the High-Density Packet VFC on a Cisco AS5400XM: Example


Current configuration : 4693 bytes
!
version 12.4
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
hostname vfc
!
boot-start-marker
no boot startup-test
boot-end-marker
!
logging buffered 3000000 debugging
enable secret 5 $1$WOeC$Op027LZYZXKiNrYq0zRp1/
enable password lab
!
!
!
resource-pool disable
no aaa new-model
!
resource policy
!
!
!
ip cef
no ip domain lookup
ip host tftp 209.165.202.129
!
!
isdn switch-type primary-5ess
!
voice dsp 2/21
 firmware location flash:dsp_c5510_flex.rbf
!
voice dsp crash-dump file-limit 5
voice dsp crash-dump destination flash:dsp-crash
!
voice service voip 
 h323
!
!
!         
!
!
!!
!
trunk activate port-threshold 100
!
!
!
controller E1 1/0
 pri-group timeslots 1-31
!
controller E1 1/1
 pri-group timeslots 1-31
!
controller E1 1/2
 pri-group timeslots 1-31
!
controller E1 1/3
 pri-group timeslots 1-31
!
controller E1 1/4
 pri-group timeslots 1-31
!
controller E1 1/5
 pri-group timeslots 1-31
!
controller E1 1/6
 pri-group timeslots 1-31
!
controller E1 1/7
 pri-group timeslots 1-31
!
!
!
interface GigabitEthernet0/0
 ip address 10.4.104.200 255.255.0.0
 no ip mroute-cache
 duplex full
 speed 100
 negotiation auto
 no cdp enable
!
interface GigabitEthernet0/1
 ip address 10.0.0.3 255.255.0.0
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
 no fair-queue
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown 
 clock rate 2000000
 no cdp enable
!
interface Serial1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial1/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial1/2:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial1/3:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial1/4:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial1/5:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial1/6:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial1/7:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
ip default-gateway 10.0.18.126
ip route 209.165.202.129 255.255.255.254 10.4.0.1
!
no ip http server
!
!
snmp-server community cisco RO
snmp-server host 10.4.121.5 version 2c public 
!
!         
!
!
!
voice-port 1/0:D
!
voice-port 1/1:D
!
voice-port 1/2:D
!
voice-port 1/3:D
!
voice-port 1/4:D
!
voice-port 1/5:D
!
voice-port 1/6:D
!
voice-port 1/7:D
!
mgcp behavior rsip-range all
!
!
dial-peer voice 1 pots
 destination-pattern 650...
 incoming called-number 408525
 no digit-strip
 direct-inward-dial
 port 1/0:D
!
dial-peer voice 2 pots
 destination-pattern 652...
 incoming called-number 428525
 no digit-strip
 direct-inward-dial
 port 1/1:D
!
dial-peer voice 3 pots
 destination-pattern 653...
 incoming called-number 438525
 no digit-strip
 direct-inward-dial
 port 1/2:D
!
dial-peer voice 4 pots
 destination-pattern 654...
 incoming called-number 448525
 no digit-strip
 direct-inward-dial
 port 1/3:D
!
dial-peer voice 5 pots
 destination-pattern 655...
 incoming called-number 458525
 no digit-strip
 direct-inward-dial
 port 1/4:D
!
dial-peer voice 6 pots
 destination-pattern 656...
 incoming called-number 468525
 no digit-strip
 direct-inward-dial
 port 1/5:D
!
dial-peer voice 7 pots
 destination-pattern 657...
 incoming called-number 478525
 no digit-strip
 direct-inward-dial
 port 1/6:D
!
dial-peer voice 8 pots
 destination-pattern 658...
 incoming called-number 488525
 no digit-strip
 direct-inward-dial
 port 1/7:D
!
dial-peer voice 100 voip
 destination-pattern 4.....
 no modem passthrough
 session target ipv4:100.0.0.4
 codec g711ulaw
 no vad
!
dial-peer voice 999 voip
!
!
no environment
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
 exec-timeout 0 0
 transport output all
 stopbits 1
line aux 0
 transport output all
 stopbits 1
line vty 0 4
 password lab
 login
 transport input all
 transport output all
!
exception core-file nobozo/core/kauai-core
exception dump 172.16.1.129
no scheduler allocate
no process cpu extended
no process cpu autoprofile hog
end

Additional References

The following sections provide references related to the High-Density Packet Voice Feature Card.

Related Documents

Related Topic
Document Title

Hardware installation instructions for the High-Density Packet Voice Feature Card feature

Cisco AS5350XM and Cisco AS5400XM Universal Gateways Card Installation Guide

Software installation and configuration instructions for the Cisco AS5350XM and Cisco AS5400XM platforms

Cisco AS5350XM and Cisco AS5400XM Universal Gateways Software Configuration Guide


Standards

Standard
Title

ITU-T Recommendation H.245 — To support the GSM AMR-NB codec in H.245, a proposal by Cisco Systems that is compliant with RFC 3267 has been added as "Annex R" in the H.245 Version 12. This proposal has been approved as a reference for implementation to support GSMAMR-NB codec support in H.323.

Control Protocol for Multimedia Communication


MIBs

MIB
MIBs Link

ENTITY-MIB

OLD-CISCO-CHASSIS-MIB

CISCO-DSP-MGMT-MIB

CISCO-ENTITY-VENDORTYPE-OID-MIB

CISCO-PROXY-CONTROL-MIB

CISCO-VOICE-DIAL-CONTROL-MIB

CISCO-VOICE-COMMON-DIAL-CONTROL-MIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 3267

Real-Time Transport Protocol (RTP) Payload Format and File Storage Format for the Adaptive Multi-Rate (AMR) and Adaptive Multi-Rate Wideband (AMR-WB) Audio Codecs

This RFC will be used as a reference for implementation to provide GSMAMR-NB codec support in SIP.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Command Reference

The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS Voice Command Reference at http://www.cisco.com/en/US/docs/ios/voice/command/reference/vr_book.html. For information about all Cisco IOS commands, use the Command Lookup Tool at http://tools.cisco.com/Support/CLILookup or a Cisco IOS master commands list.

clear voice dsp

codec gsmamr-nb

codec preference

rtp payload-type

show voice dsp

voicecap entry

Feature Information for the High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways

Table 2 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note Table 2 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 2 Feature Information for the High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways 

Feature Name
Releases
Feature Information

High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways

12.4(4)XC
12.4(9)T
12.4(20)T

The High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways (product number AS5X-FC) supports up to six high-density packet voice/fax digital signal processor (DSP) modules (product number AS5X-PVDM2-64), providing scalability from 64 to 384 channels. In Release 12.4(4)XC, this feature was introduced on the Cisco AS5350XM and Cisco AS5400XM.

This feature was integrated into Cisco IOS Release 12.4(9)T and support was added for the Media and Signaling Authentication and Encryption Feature for Cisco IOS H.323 Gateways, which provides authentication, integrity, and encryption of voice media and call control signaling for H.323 protocol-based voice gateways. For more information about this feature and instructions for configuration, refer to "Media and Signaling Authentication and Encryption Feature for Cisco IOS H.323 Gateways."

This feature was integrated into Cisco IOS Release 12.4(20)T and software-configurable echo cancellation coverage was expanded to include 80, 96, 112, and 128 milliseconds. The default is changed from 64 ms to 128 ms.


Glossary

AMR-NB—Adaptive Multi-Rate Narrow Band.

CMR—codec mode request.

DFC—Dial Feature Card.

DSP—digital signal processor.

DSPRM—DSP Resource Manager. The sofware module that is responsible for managing the DSP resources on the AS5300XM and AS5400XM platforms.

FlexDSPRM—common DSP resource manager subsystem.

GSMAMR-NB—Global System for Mobile Adaptive Multi-Rate Narrow Band.

HWECAN—hardware echo cancellation.

HPI—Host Port Interface.

NM-HDV—A high-density packet voice trunk network module that support up to two T1/E1 interfaces.

NextPort Module—A hardware card that supports NextPort hardware and software interfaces.

NP VFC—NextPort voice feature card.

Module Manager—A component in the NextPort infrastructure. It provides a set of APIs for other NextPort Device Driver components to manage and configure the NextPort Module.

PVDM2—Packet Voice Digital Signal Processor Module.

VAD—voice activity detection.

VFC—Voice Feature Card.