Guest

Cisco IOS Software Releases 12.4 T

RFC 3020 Multilink Frame Relay MIB Support

  • Viewing Options

  • PDF (167.0 KB)
  • Feedback
RFC 3020 Multilink Frame Relay MIB Support

Table Of Contents

RFC 3020 Multilink Frame Relay MIB Support

Contents

Prerequisites for RFC 3020 Multilink Frame Relay MIB Support

Information About RFC 3020 Multilink Frame Relay MIB Support

How to Configure RFC 3020 Multilink Frame Relay MIB Support

Configuration Example for the RFC 3020 Multilink Frame Relay MIB

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

snmp-server enable traps frame-relay multilink bundle-mismatch

Feature Information for RFC 3020 Multilink Frame Relay MIB Support


RFC 3020 Multilink Frame Relay MIB Support


First Published: June 19, 2006
Last Updated: February 19, 2007

The RFC 3020 Multilink Frame Relay MIB Support feature introduces MIB functionality to manage and monitor multilink Frame Relay interfaces via the use of MIB tables. The feature is based on RFC 3020, Definitions of Managed Objects for Monitoring and Controlling the UNI/NNI Multilink Frame Relay Function.

This feature uses three MIB tables:

mfrBundleTable for managing bundle interfaces

mfrBundleLinkTable for managing bundle links

mfrBundleIfIndexMappingTable for associating bundle links with bundles

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for RFC 3020 Multilink Frame Relay MIB Support" section.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for RFC 3020 Multilink Frame Relay MIB Support

Information About RFC 3020 Multilink Frame Relay MIB Support

How to Configure RFC 3020 Multilink Frame Relay MIB Support

Configuration Example for the RFC 3020 Multilink Frame Relay MIB

Additional References

Command Reference

Feature Information for RFC 3020 Multilink Frame Relay MIB Support

Prerequisites for RFC 3020 Multilink Frame Relay MIB Support

Before the RFC 3020 multilink Frame Relay MIB can be used, the Simple Network Management Protocol (SNMP) server for the router must be configured.

Information About RFC 3020 Multilink Frame Relay MIB Support

Multilink Frame Relay is a feature in Cisco IOS software, and the RFC 3020 multilink Frame Relay MIB is a MIB standard. The purpose of this feature is to provide a multilink Frame Relay MIB based on RFC 3020.


Note The Cisco implementation of the RFC 3020 multilink Frame Relay MIB supports only read-only operations. Therefore, adding, deleting, or modifying a MIB table row is not supported.


Table 1 lists the MIB tables used for multilink Frame Relay support.

 

Table 1 Multilink Frame Relay MIB Tables  

MIB Table Name
Description

mfrBundleTable

Bundle table, which contains bundle configuration and status information.

The table is indexed by mfrBundleIndex, which is an internal index that is maintained to uniquely identify each entry in the table. Each entry in the table represents a bundle interface configured on a device.

mfrBundleLinkTable

Bundle link table, which contains bundle link configuration and status information.

The table is indexed by ifIndex.

mfrBundleIfIndexMappingTable

Bundle-to-ifIndex mapping table, which provides mapping between ifIndex and mfrBundleIndex.

The table is indexed by ifIndex.


How to Configure RFC 3020 Multilink Frame Relay MIB Support

To configure the RFC 3020 Multilink Frame Relay MIB, you enable the multilink Frame Relay bundle-mismatch trap by using the following procedure.

SUMMARY STEPS

1. enable

2. configure terminal

3. snmp-server enable traps frame-relay multilink bundle-mismatch

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

snmp-server enable traps frame-relay multilink bundle-mismatch

Example:

Router(config)# snmp-server enable traps frame-relay multilink bundle-mismatch

Enters class-map configuration mode and enables monitoring for multilink Frame Relay.

Step 4 

end

Example:

Router(config-cmap)# end

Exits class-map configuration mode and returns to privileged EXEC mode.

Configuration Example for the RFC 3020 Multilink Frame Relay MIB

The following example shows how to configure the RFC 3020 multilink Frame Relay MIB. The example shows a multilink Frame Relay configuration on a host and a peer with two bundles and six bundle links.

On the host router:

Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# controller T3 6/0
Router(config)# t1 1 channel-group 0 timeslots 1-24
Router(config)# t1 2 channel-group 0 timeslots 1-24
Router(config)# t1 3 channel-group 0 timeslots 1-24
Router(config)# t1 4 channel-group 0 timeslots 1-24
Router(config)# t1 5 channel-group 0 timeslots 1-24
Router(config)# t1 6 channel-group 0 timeslots 1-24
!
Router(config)# interface MFR1
Router(config)# ip address 209.165.200.225 255.255.255.224
Router(config)# frame-relay multilink bid RUB_BUNDLE_ONE
Router(config)# frame-relay interface-dlci 100
!
Router(config)# interface MFR2
Router(config)# ip address 209.165.200.226 255.255.255.224
Router(config)# frame-relay multilink bid RUB_BUNDLE_TWO
Router(config)# frame-relay interface-dlci 100
!
Router(config)# interface Serial6/0/1:0
Router(config)# encapsulation frame-relay MFR1
Router(config)# frame-relay multilink lid RUB_BUNDLE_ONE_LINK_1
!
Router(config)# interface Serial6/0/2:0
Router(config)# encapsulation frame-relay MFR1
Router(config)# frame-relay multilink lid RUB_BUNDLE_ONE_LINK_2
!
Router(config)# interface Serial6/0/3:0
Router(config)# encapsulation frame-relay MFR1
Router(config)# frame-relay multilink lid RUB_BUNDLE_ONE_LINK_3
!
Router(config)# interface Serial6/0/4:0
Router(config)# encapsulation frame-relay MFR2
Router(config)# frame-relay multilink lid RUB_BUNDLE_TWO_LINK_1
!
Router(config)# interface Serial6/0/5:0
Router(config)# encapsulation frame-relay MFR2
Router(config)# frame-relay multilink lid RUB_BUNDLE_TWO_LINK_2
!
Router(config)# interface Serial6/0/6:0
Router(config)# encapsulation frame-relay MFR2
Router(config)# frame-relay multilink lid RUB_BUNDLE_TWO_LINK_3
!
Router(config)# snmp-server community public RW
Router(config)# snmp-server enable traps frame-relay multilink bundle-mismatch
Router(config)# snmp-server host 209.165.200.227 public
!

On the peer router:

Router(config)# controller T3 6/0
Router(config)# t1 1 channel-group 0 timeslots 1-24
Router(config)# t1 2 channel-group 0 timeslots 1-24
Router(config)# t1 3 channel-group 0 timeslots 1-24
Router(config)# t1 4 channel-group 0 timeslots 1-24
Router(config)# t1 5 channel-group 0 timeslots 1-24
Router(config)# t1 6 channel-group 0 timeslots 1-24
Router(config)# t1 7 channel-group 0 timeslots 1-24
!
Router(config)# interface MFR1
Router(config)# ip address 209.165.200.228 255.255.255.224
Router(config)# frame-relay multilink bid GAN_BUNDLE_ONE
Router(config)# frame-relay interface-dlci 100
Router(config)# frame-relay intf-type dce
!
Router(config)# interface MFR2
Router(config)# ip address 209.165.200.229 255.255.255.224
Router(config)# frame-relay multilink bid GAN_BUNDLE_TWO
Router(config)# frame-relay interface-dlci 100
Router(config)# frame-relay intf-type dce
!
Router(config)# interface Serial6/0/1:0
Router(config)# encapsulation frame-relay MFR1
Router(config)# frame-relay multilink lid GAN_BUNDLE_ONE_LINK_1
!
Router(config)# interface Serial6/0/2:0
Router(config)# encapsulation frame-relay MFR1
Router(config)# frame-relay multilink lid GAN_BUNDLE_ONE_LINK_2
!
Router(config)# interface Serial6/0/3:0
Router(config)# encapsulation frame-relay MFR1
Router(config)# frame-relay multilink lid GAN_BUNDLE_ONE_LINK_3
!
Router(config)# interface Serial6/0/4:0
Router(config)# encapsulation frame-relay MFR2
Router(config)# frame-relay multilink lid GAN_BUNDLE_TWO_LINK_1
!
Router(config)# interface Serial6/0/5:0
Router(config)# encapsulation frame-relay MFR2
Router(config)# frame-relay multilink lid GAN_BUNDLE_TWO_LINK_2
!
Router(config)# interface Serial6/0/6:0
Router(config)# encapsulation frame-relay MFR2
Router(config)# frame-relay multilink lid GAN_BUNDLE_TWO_LINK_3

Router(config)# exit

Additional References

The following sections provide references related to the RFC 3020 Multilink Frame Relay MIB Support feature.

Related Documents

Related Topic
Document Title

Information about configuring multilink Frame Relay using Cisco IOS software

"Multilink Frame Relay (FRF.16)" chapter in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.4

Cisco IOS Wide-Area Networking Command Reference, Release 12.4T


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIB
MIBs Link

FR-MFR-MIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 3020

Definitions of Managed Objects for Monitoring and Controlling the UNI/NNI Multilink Frame Relay Function


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http://www.cisco.com/techsupport


Command Reference

This section documents only new commands.

snmp-server enable traps frame-relay multilink bundle-mismatch

snmp-server enable traps frame-relay multilink bundle-mismatch

To enable multilink Frame Relay Simple Network Management Protocol (SNMP) notifications, use the snmp-server enable traps frame-relay multilink bundle-mismatch command in global configuration mode. To disable these notifications, use the no form of this command.

snmp-server enable traps frame-relay multilink bundle-mismatch

no snmp-server enable traps frame-relay multilink bundle-mismatch

Syntax Description

This command has no arguments or keywords.

Command Default

SNMP notifications are disabled.

Command Modes

Global configuration

Command History

Release
Modification

12.4(9)T

This command was introduced.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

Use the multilink Frame Relay MIB to manage devices that are configured with multilink Frame Relay.

SNMP notifications can be sent as traps or inform requests. This command enables both traps and inform requests.

Although the bundle-mismatch trap is one of five traps defined in RFC 3020, Cisco IOS supports only the bundle-mismatch trap.

For a complete description of MIB functions, see the CISCO-FRAME-RELAY-MIB.my file, which is available in the "SNMP v2 MIBs" directory found at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Examples

In the following example, multilink Frame Relay is configured on the host router with one bundle, and the peer router is configured with zero bundle links.

On the host router:

Router(config)# interface MFR1
Router(config)# ip address 209.165.200.225 255.255.255.224
Router(config)# frame-relay multilink bid UUT_BUNDLE_ONE
Router(config)# frame-relay interface-dlci 100
!
Router(config)# snmp-server community public RW
Router(config)# snmp-server enable traps frame-relay multilink bundle-mismatch
Router(config)# snmp-server host 10.0.47.4 public

On the peer router:

Router(config)# interface MFR1
Router(config)# ip address 209.165.200.226 255.255.255.224
Router(config)# frame-relay multilink bid PEER_BUNDLE_ONE
Router(config)# frame-relay interface-dlci 100
Router(config)# frame-relay intf-type dce

Router(config)# snmp-server enable traps frame-relay multilink bundle-mismatch
Router(config)# snmp-server host myhost.cisco.com informs version 2c public

Related Commands

Command
Description

snmp-server host

Specifies the recipient of an SNMP notification operation.

snmp-server trap-source

Specifies the interface from which an SNMP trap should originate.


Feature Information for RFC 3020 Multilink Frame Relay MIB Support

Table 2 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 2 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 2 Feature Information for RFC 3020 Multilink Frame Relay MIB Support 

Feature Name
Releases
Feature Information

RFC 3020 Multilink Frame Relay MIB Support

12.4(9)T
12.2(33)SRB

The RFC 3020 Multilink Frame Relay MIB Support feature introduces MIB functionality to manage and monitor multilink Frame Relay interfaces via the use of MIB tables.