Guest

Cisco IOS Software Releases 12.4 T

ADSL HWICs

  • Viewing Options

  • PDF (283.9 KB)
  • Feedback
ADSL HWICs

Table Of Contents

ADSL HWICs

Contents

Restrictions for ADSL HWICs

Information about ADSL HWICs

ADSL Features

ISDN Features

Interface Numbering on Cisco Integrated Services Routers

How to Configure ADSL HWICs

Configuring the ADSL Port on an ADSL HWIC

Configuration Example for ADSL HWICs

VoIP over ATM (AAL5) on the ADSL Interface: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference


ADSL HWICs


The ADSL high speed WAN interface cards (HWICs) feature for Cisco modular integrated services routers provide high-speed ADSL digital data transfer between a single customer premises equipment (CPE) subscriber and a central office (CO). ADSL HWICs are available in the following variations:

ADSL over POTS (ADSLoPOTS) HWICs

HWIC-1ADSL, a 1-port ADSLoPOTS card

HWIC-ADSL-B/ST, a 2-port card with a port for ADSLoPOTS and a data-only port for an ISDN BRI S/T connection

ADSL over ISDN (ADSLoISDN) HWICs

HWIC-1ADSLI, a 1-port ADSLoISDN card

HWIC-ADSLI-B/ST, a 2-port card with a port for ADSLoISDN and a data-only port for an ISDN BRI S/T connection

Feature History for ADSL HWICs

Release
Modification

12.4(4)T

This feature was introduced.

12.4(6)T

Support was added for 2-port HWIC-ADSL-B/ST and HWIC-ADSLI-B/ST cards.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Restrictions for ADSL HWICs

Information about ADSL HWICs

How to Configure ADSL HWICs

Configuration Example for ADSL HWICs

Additional References

Command Reference

Restrictions for ADSL HWICs

ADSL HWICs can be inserted only into onboard HWIC-enabled slots on Cisco routers. Initially, these routers are the Cisco 1800 series (modular), the Cisco 2800 series, and the Cisco 3800 series integrated services routers.

The ISDN interfaces on HWIC-ADSL-B/ST and HWIC-ADSLI-B/ST are data only.

ATM adaption layer 2 (AAL2) is not supported.

ADSL HWICs do not support dual latency. When the ADSL link is intended to support both voice and data traffic simultaneously, the link should be configured for either all fast-path data or all interleave data with an interleave depth of zero to insure that latency is minimized. In addition, the total supported data rate must be reduced to adjust for the reduced coding gain, which is usually present with high-latency traffic.

The following command is not supported by ADSL HWICs:

clock rate

The following ISDN command is not supported by HWIC-ADSL-B/ST or HWIC-ADSLI-B/ST:

leased-line

Loop back functionality is not supported.

Information about ADSL HWICs

This section provides information about the ADSL HWICs feature.

ADSL Features

ISDN Features

Interface Numbering on Cisco Integrated Services Routers

ADSL Features

Supported ADSL features are as follows:

Provides ADSL high-speed digital data transmissions between the customer premises equipment (CPE) and the central office (CO).

HWIC-1ADSL and HWIC-ADSL-B/ST support ADSL-over-POTS (ADSL, ADSL2, and ADSL2+), complying with Annex A of ITU G.992.1, G.992.3, and G.992.5.

HWIC-1ADSLI and HWIC-ADSLI-B/ST support ADSL-over-ISDN (ADSL, ADSL2, and ADSL2+), complying with Annex B of ITU G.992.1, G.992.3, and G.992.5. They also support and comply with ETSI 101-388 and the Deutsche Telekom U-R2 specification.

Supports reach-extended ADSL2, complying with Annex L of ITU G.992.3.

Complies with ANSI T1.413 issue 2.

Supports ATM AAL5 services and applications, ATM class of service (constant bit rate [CBR], variable bit rate-nonreal time [VBR-NRT], variable bit rate-real time [VBR-rt], and unspecified bit rate [UBR]) and up to 23 virtual circuits on an HWIC in Cisco routers.

Provides ATM traffic management and Quality of Service (QoS) features to enable service providers to manage their core ATM network infrastructures.

Supports Dying Gasp functionality.

ISDN Features

Supported ISDN features on HWIC-ADSL-B/ST and HWIC-ADSLI-B/ST are as follows:

Provides an industry-standard, full duplex, 2B+D, S/T, data only hardware interface.

Operates independently of the ADSL interface on the HWIC.

Interface Numbering on Cisco Integrated Services Routers

This section describes the interface numbering scheme for Cisco integrated services routers If an interface card is installed in a Cisco 1800 series (modular), Cisco 2800 series, or Cisco 3800 series router, the interfaces must use a triple-number scheme to identify them. This triple-number assignment is different from the standard interface numbering scheme on other Cisco routers.

Table 1 shows the interface numbering for the onboard Fast Ethernet ports and the interface slots on Cisco 1800 series (modular), Cisco 2800 series, and Cisco 3800 series integrated services routers.

Table 1 Interface Numbering on Cisco Integrated Services Routers

Port/Slot
Interface Numbering
Example

Fast Ethernet ports (onboard)

0/0, 0/1

FE 0/0, 0/1

Slot 0

Slot 0/0/0

FE 0/0/0, 0/0/1, 0/0/2, 0/0/3

Slot 1

Slot 0/1/0

(Serial 2T) Serial 0/1/0, 0/1/1

Slot 2

Slot 0/2/0

FE 0/2/0

Slot 3

Slot 0/3/0

(ADSL) ATM 0/3/0


How to Configure ADSL HWICs

This section describes the ADSL configuration task for this feature.


Note Features configured on the ADSL HWIC must also be configured on the Digital Subscriber Loop Access Multiplexer (DSLAM) located in the CO. See the documentation for the specific DSLAM for information about configuring features.


Configuring the ADSL Port on an ADSL HWIC

To configure the ADSL port on an ADSL HWIC, complete the following steps:

SUMMARY STEPS

1. enable

2. configure terminal

3. interface atm interface-id

4. ip address IP-address

5. pvc [name] vpi/vci

6. protocol ip IP-address

7. vbr-rt peak-rate average-rate burst

8. encapsulation {aal5autoppp | aal5ciscoppp | aal5mux | aal5nlpid | aal5snap}

9. exit

10. dsl operating-mode {ansi-dmt | auto | itu-dmt | adsl2 | adsl2+}
or
dsl operating-mode {etsi | auto | itu-dmt | adsl2 | adsl2+}

11. no shutdown

12. exit

13. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

Router(config)# interface atm interface-id

Example:

Router(config)# interface atm 0/1/0

Enters ATM configuration mode for the ATM interface in the specified slot and port.

Step 4 

Router(config-if)# ip address IP-address

Example:

Router(config-if)# ip address 192.168.10.25 255.255.255.0

Assigns an IP address to the ADSL ATM interface.

Step 5 

Router(config-if)# pvc [name] vpi/vci

Example:

Router(config-if)# pvc [name] vpi/vci

Enters atm-virtual-circuit (interface-atm-vc) configuration mode, and configures a new ATM PVC by assigning a name (optional) and virtual path identifier (VPI)/virtual channel identifier (VCI) numbers.

The default traffic shaping is UBR; the default encapsulation is AAL5+LLC/SNAP.

Step 6 

Router(config-if-vc)# protocol ip IP-address

Example:

Router(config-if-vc)# protocol ip 192.168.0.4

(Optional) Enables IP connectivity and create a point-to-point IP address for the virtual circuit (VC).

Step 7 

Router(config-if-vc)# vbr-rt peak-rate average-rate burst

Example:

Router(config-if-vc)# vbr-rt peak-rate average-rate burst

(Optional) Configures the PVC for real-time variable bit rate (VBR) traffic shaping.

Peak rate—Peak information rate (PIR)

Average rate—Average information rate (AIR)

Burst—Burst size in cells

Step 8 

Router(config-if-vc)# encapsulation {aal5autoppp | aal5ciscoppp | aal5mux | aal5nlpid | aal5snap}

Example:

Router(config-if-vc)# encapsulation aal5snap

(Optional) Configures the ATM adaptation layer (AAL) and encapsulation type.

aal5autoppp—Cisco AUTO PPP over AAL5

aal5ciscoppp—Cisco PPP over AAL5

aal5mux—AAL5+MUX

aal5nlpid—AAL5+NLPID

aal5snap—AAL5+LLC/SNAP (the default)

Step 9 

Router(config-if-vc)# exit

Example:

Router(config-if-vc)# exit

Exits from interface-atm-vc configuration mode.

Step 10 

Router(config-if)# dsl operating-mode {ansi-dmt 
| auto | itu-dmt | adsl2 | adsl2+}










or

Router(config-if)# dsl operating-mode {etsi | 
auto | itu-dmt | adsl2 | adsl2+}
Example:

Router(config-if)# dsl operating-mode auto

Configures HWIC-1ADSL or HWIC-ADSL-B/ST to operate in a specified mode:

ansi-dmt—ANSI full rate mode per T1.413, Issue 2

auto—Automatic detection mode

itu-dmt—ITU full rate mode (ITU G.992.1)

adsl2—ADSL 2 mode per ITU G.992.3

adsl2+—ADSL 2+ mode per ITU G.992.5

Configures HWIC-1ADSLI or HWIC-ADSLI-B/ST to operate in a specified mode:

etsi—Alcatel proprietary ETSI mode

auto—Automatic selection mode

itu-dmt—ITU full rate mode (ITU G.992.1)

adsl2—ADSL 2 mode per ITU G.992.3

adsl2+—ADSL 2+ mode per ITU G.992.5


Caution This command is for testing or lab environments only. Using a configuration other than the default configuration for the DSL operating mode can lead to unpredictable behavior on the ADSL line.

Step 11 

Router(config-if)# no shutdown

Example:

Router(config-if)# no shutdown

Activates the ATM interface.

Step 12 

Router(config-if)# exit

Example:

Router(config-if)# exit

Exits from ATM interface configuration mode.

Step 13 

Router(config)# exit

Example:

Router(config)# exit

Exits from global configuration mode.

Configuration Example for ADSL HWICs

This section provides the following configuration example:

VoIP over ATM (AAL5)

For comprehensive examples of configuring ISDN interfaces on HWIC-ADSL-B/ST and HWIC-ADSLI-B/ST, refer to the following document:

"Configuring ISDN BRI" chapter of the Cisco IOS Dial Technologies Configuration Guide.

VoIP over ATM (AAL5) on the ADSL Interface: Example

The following example shows a Cisco router configured for VoIP over ATM (AAL5) on the ADSL interface with an ADSL HWIC.

Router#
version 12.4
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
!
no aaa new-model

resource policy

mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmisnmp-timeout 180
ip subnet-zero
ipcef
!
no ip domain-lookup
!
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.0.0
 duplex auto
 speed auto
!
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface ATM0/1/0
 ip address 100.0.0.1 255.255.0.0
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 1/100
  protocol ip 100.0.0.2 broadcast
!
!
ip classless
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
dial-peer voice 10000 voip
 destination-pattern 10000
 session target ipv4:100.0.0.2
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

Additional References

The following sections provide references related to ADSL HWICs.

Related Documents

Related Topic
Document Title

Interface Card Installation

Cisco Interface Cards Hardware Installation Guide

Command Reference in ADSL HWIC Feature Guide on Cisco IOS Release 12.4(4)T

ADSL HWICs


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

There are no new or modified IOS commands for this feature in Cisco IOS Release 12.4(6)T.